生物

    四代总计有67种生物（此数字未包含资料片新增生物），初看起来好像比三代少了很多。但实际上是因为取消生物升级设计所造成的错觉，实际种类相差并不多。

    生物的等级从前作的7级削减成为了四级，级与级之间的实力差距拉大了。每个种族都有8种生物，每级2种。在城堡里建造生物招募地的时候，两种一级生物的招募地是可以同时建造的，而2-4级的生物招募地，就必须从两者之间选择其一进行建造。也就是说，在一个城堡里，最多只能招募5种本族生物（自然城堡的生物召唤门除外）。

    所有生物都拥有特殊技能，不同生物之间区别较大。每种生物都有自己的个性，都是独一无二的，而不像前作那样大部分只有数值上的不同。

    生物的能力数据比较复杂，以下是对各个项目的详细解说：

生命值（Hit Points）：单个生物的生命值，生物抗打击能力最主要因素
伤害力（Damage）：单个生物的杀伤力，一般有一个最低值和一个最高值，实际伤害力在最低到最高的这个范围内波动。
近战攻击力（Melee Attack）。大部分远程部队近战攻击力是远程攻击力的一半。
远程攻击力（Ranged Attack）。没有这项属性的生物，表示不能够进行远程攻击。
近战防御力（Melee Defense）。
远程防御力（Ranged Defense）。绝大部分生物的两个防御力是相同的，仅有骷髅兵和骨龙例外。

    四代的攻击伤害计算公式比较简单，最终杀伤＝基本杀伤×部队数量×攻击力÷防御力，另外要考虑到一些相关魔法和技能、宝物的作用，基本上也是按乘除法来计算。此计算方式与前三代都不同，这一点一定要注意。

速度（Speed）：速度快慢决定了生物在战斗中出手的先后次序
地图移动力（Movement）：决定了生物在地图上每天能够行走的距离
战场移动力（Movement）：决定了生物在战斗中一回合能够移动的距离。

    在战场上看到的生物移动力，其单位为码（yard），而在城堡内招募生物时所看到的移动力，则是按英尺（feet）计算的战场移动力。在游戏中，1码=3英尺，所以在城内看到的移动力数据基本上是战场上看到的3倍。旧版卷轴中列出的移动力数据以“码”为单位，现在统一改为以“英尺”为单位，这样更加精确。

经验值（Experience）：表示英雄击败一个生物后，能够得到多少经验值，这点设定与前几代的按生命值算不同。

    经验值另一方面可能也是表明了生物的实力排名。有些英雄技能和召唤魔法的运算一般也是按照经验值进行的。另外需要注意的是战斗获胜后英雄得到的经验值与游戏难度有关，普通难度经验值正常，最高难度则只能获得1/3经验值（但野兵数量也是普通难度的3倍，通算起来所获经验值是不变的）。

魔法值（Spell Points）。因为四代里有很多生物都有施法能力，所以他们也各自有自己的魔法值。
弹药量（Shots）：远程部队能够进行射击的次数。无远程攻击能力的生物，此项属性将是空白的。
士气（Morale）：从最低值-10到最高值+10。部队种族混编会引起士气低落，战斗中遭受比较大的打击，部队损失一部分以后，整体士气也会大幅度下降。
幸运（Luck）：从最低值-10到最高值+10。

产量（Growth）：生物的周产量。实际上生物每天都会增长，就是按周产量除以7以后每天匀速增长。野外招募地的产量，为城堡内产量的一半
招募价格（Cost）

    这两个图标并非是游戏里的相应图标，而是为了说明方便而做的。


种族

    游戏中一共存在6种类型的城堡，每种城堡类型对应于一个阵营（派系），因此种族与派系之间基本上可以划等号。每个种族的城堡均有8种生物，除此之外还有17种中立生物。中立生物也有特定阵营，农民是生命系生物；海盗、穴居人、观察者和洞穴居人是混乱系生物；僵尸、石像鬼、木乃伊和冰魔是死亡系生物；美人鱼和海怪是力量系生物；可以在生物门召唤的8种生物实际上是自然系的。仅有守序系没有中立生物。之所以要确定中立生物的阵营，是为了方便于部队混编时的士气计算，另外有些魔法/技能也是要对特定阵营生物才会起作用的。

    守序城堡（Academy）：对应于守序魔法。生物接近于前两代泰坦所在种族，但是因为法师在这一代里变成了可施法的部队，被剥夺了远程攻击能力，所以本族不再是远程部队最多的种族，但配合精准和迟缓等魔法，远程表现力还是所有种族中排第一的。

    混乱城堡（Asylum）：对应于混乱魔法，生物接近于前几代黑龙所在种族。2-4级兵都相当强，而1级兵盗贼的潜行技能对发展有极大帮助。4级兵恐怕多数人会选择强大而不惧魔法的黑龙，但只要有合适的魔法相配合，九头蛇的攻击表现其实更出众。

    生命城堡（Haven）：对应于生命魔法，生物接近于上一代的骑士族。远程部队有三种，是所有种族中最多的，但三种远程全部加起来威力未必比泰坦强。四级兵天使和精英骑士，精英骑士能力弱但产量高，合理利用冲锋，攻击表现要强于天使。天使的优势在于是飞行部队，并且有复活魔法，可以复活生物或英雄。

    死亡城堡（Necropolis）：对应于死亡魔法，生物方面可以算是上一代鬼族与地狱族的混合体，可分为亡灵与魔鬼两类。这个族在很多方面克制着学院族。守序魔法的那些精神控制魔法对死亡族的亡灵生物毫无作用，法师的施毒与灯神的和平之歌对亡灵生物也无用武之地，骷髅兵、幽灵、骨龙都有超高的远程防御力，吸血鬼的吸血威力强大……常规发展策略就是要尽快出吸血鬼，为此即使换矿也在所不惜。

    自然城堡（Preserve）：对应于自然魔法，以贴近于自然的生物为基础。一级生物妖精和狼实用性不错，合理配合德鲁伊的召唤魔法，可以应付一般的早期战斗。三级兵狮鹫的实力比前几代急剧增强，以至于把一向很实力派的生物——独角兽逼到了鸡肋地位。四级兵里仙女龙更容易造，也更好用，最大的价值不是在攻击魔法，而是混乱这个辅助魔法。特殊建筑生物门里面始终有8种生物供招募，其中螳螂是四级兵，绝对实力在凤凰与仙女龙之上，只是差不多每周才能招募一头，不容易积攒力量。除螳螂外，最重要的召唤门生物是水元素，早期3（或4）水元素+1半羊人+妖精的组合，是对付地面部队的无赖招式，非常实用（但此打法很消耗现实时间，是否采用看个人喜好了）。

    力量城堡（Stronghold）：力量阵营是最特殊的阵营，没有对应的魔法。兵种实力比较强，而且物美价廉。在最高难度的游戏下，早期战斗的取胜要诀在于“堵狂暴者”战术。总体发展的关键则在于三级兵独眼巨人，其范围攻击极其厉害，实用价值未必在吸血鬼的吸血之下。四级兵里，巨兽是游戏中物理攻击力仅次于黑龙的生物；而雷鸟因为攻击时附带闪电伤害，因此在面对高级兵种的时候，攻击表现要超过巨兽。


守序城堡生物

守序城堡

半身人（Halfling）
1-2 | 5 | 10 | N/A
8 | 10 | 10 | 10
6 | 18 | 14 | 7
23 | 22金
 Ranged Giantslayer
能力低下的远程部队，即使考虑到产量较高的因素，仍然不显得出众。不过由于本族“精准”魔法的存在，使得半身人在初期战斗中还能发挥比较强的作用，其作用基本上可以延续到四级兵出来之前。当游戏进行到中后期时，半身人会逐步失去上阵价值，虽然巨人杀手特技能使他们对四级兵产生双倍伤害，作用却仍然有限。在灯神分组或是多英雄上阵的情况下，半身人从主力部队中被剔除基本上是必然趋势。

矮人（Dwarf）
2-3 | 11 | N/A | N/A
12 | 11 | 11 | N/A
3 | 18 | 14 | 8
18 | 28金
 Magic Resistance
矮人的攻防能力在一级兵中算是相当不错，再加上50%的魔法抗性，看起来比较强。可惜低下的速度和移动力大大拖累了其战斗表现，而半身人的存在更宣布了矮人只能安分于“肉盾”地位。当然，这个肉盾可是说是最称职的一级肉盾，无论是面对远程部队，还是面对施法部队，都能支撑相当长时间。
低下的移动力在面对野外灯神时反而有奇效，敌人复制的矮人要好几个回合才能走上来，为我方的攻击、施法提供了足够的时间。

法师（Mage）
3-4 | 6 | N/A | 16
16 | 12 | 12 | N/A
5 | 19 | 18 | 38
8 | 160金
 Spellcaster
法师可施展的魔法包括模糊、诅咒、魔法拳、施毒和驱役骷髅，威力为：魔法基本威力×法师数量×0.24。
虽然生命值低下，但在法师与金人的选择中，我多数时候还是选择法师。施毒和造骷髅的效果都不错，而法师施毒配合灯神的组合，可以打赢许多用等量金人、灯神所拿不下来的战斗。当然，这样做有可能会使战斗消耗相当长的现实时间，有些人可能不屑于这么做。
中后期战斗法师往往很少被带上阵，毕竟地图移动力偏低了点。但若攒起一定数量，在决战中可以考虑用一用，魔法拳和施毒对于敌人的主力部队和英雄是一个不可忽视的威胁。
在英雄抗魔能力不强的情况下，野外的法师是比较让人头疼的对手，如果与金人混编就更难对付。耍点赖，用快速战斗（Quick Combat，不进入战斗画面），有时是比较好的选择。

金人（Gold Golem）
8-12 | 16 | N/A | N/A
50 | 16 | 16 | N/A
3 | 19 | 18 | 56
6 | 240金
 Mechanical Magic Resistance
在二级兵中首屈一指的攻防实力（结合伤害力和生命值因素，并不单指攻击力与防御力。以下的表述中如果提到“攻防实力”，都是采用同一原则），加上75%的魔法抗性，又因为是机械，不吃许多诅咒类魔法，这样的兵种在野外遇到是相当令人头疼的。在本方实力不足的情况下，基本上只有流沙（或召唤水元素）才是最好的对付方法。
但是若由玩家来使用，金人却多少有点鸡肋的感觉（当然是指最高难度中）。本族的发展关键是灯神，而金人与灯神配合的战术，基本上只有灯神复制金人顶在前面当肉盾，或是复制杂兵骗反击、金人上去狂殴这两种。在一般地图中，出灯神与出四级兵之间的时间间隔基本上只有一周左右，这段时间内金人和灯神的数量都不会太多，前述两种战术的作用就比较有限。而法师与灯神的配合，数量多少在很多时候并不决定胜败，只是影响战斗时间长短。
当然，如果你并不在乎游戏内所耗时间长短，更看重节约现实时间的话，那么还是推荐出金人，积攒一定数量后战斗进程要明显快于用法师。
周围野兵的配置也会对金人与法师的抉择起影响。

灯神（Genie）
9-12 | 10 | N/A | 24
60 | 18 | 18 | N/A
6 | 25 | 30 | 105
6 | 550金
 flying Spellcaster
灯神可施展的魔法包括怯懦、制造幻象、冰箭、振奋、迟缓和和平之歌，威力为：魔法基本威力×灯神数量×0.45
单纯从攻防实力来看，灯神是极度平庸的三级兵，在游戏正式推出之前，恐怕没有人能意识到她的作用竟是如此之强。在数量少的时候，多组单个的灯神施展迟缓和和平之歌，已经足以实现许多以弱胜强的战例。而在四级兵出现之后，数量不少的主力灯神复制四级兵，可以让战斗变得相当轻松。灯神的作用可以从刚造出来时一直涵盖到最终决战时，说她是守序族的灵魂，丝毫也不为过。

蛇妖（Naga）
14-22 | 22 | N/A | N/A
90 | 22 | 22 | N/A
7 | 20 | 20 | 157
4 | 850金
 No Retaliation
虽然实力比起三代的女王降低了不少，但不错的攻防能力和不受反击的特性使蛇妖依然强悍，按产量进行单挑的话，在三级兵中名列前茅。遗憾的是，灯神的存在让如此有实力的蛇妖完全沦为了配角，简直有“永无出头之日”的悲哀感觉。少量灯神就可以改变战斗的胜败，而蛇妖若不积攒到相当数量，是没有多大用处的。即使单论伤害能力，蛇妖也仅在面对低级兵的时候才比灯神强，更不用说这两者一个是用魔法直接进行攻击，另一个只能慢慢地爬上去砍了。

泰坦（Titan）
34-50 | 32 | 32 | N/A
210 | 32 | 32 | 16
6 | 21 | 22 | 616
2 | 4000金+2宝石
 Ranged Normal Melee
Chaos Ward
作为二代和三代中实力最强的兵种之一，泰坦在四代毫无疑问被削弱了很多。但这种削弱，很大程度上是因为游戏规则改变（战场扩大，视线因素，以及相关魔法）而造成的，只要使用得当，还是非常好用的顶级兵。如果经济条件许可，造泰坦应该是比较好的选择。要说缺点，就是地图移动力慢了点，可能会拖延主力部队的推进速度。
不吃精神类魔法的特权被剥夺，总体来说有利有弊，好处是可以加振奋和精准两个好用的状态魔法，坏处则是有可能被敌人所控制。不过，这也可以看作是游戏规则改变带来的另一后果，否则的话，野外的大量泰坦就太难对付了点，就算打赢也可能会有不小损失（要考虑到复活魔法已经被取消这一因素）。
新加入的混乱抵御技能当然是一个好技能，这让我们在面对混乱族时有更充分的理由选择泰坦。

傀儡龙（Dragon Golem）
36-55 | 34 | N/A | N/A
220 | 34 | 34 | N/A
9 | 27 | 36 | 630
2 | 4000金+4矿石
 Mechanical First Strike
Negate First Strike
攻防实力较为一般的傀儡龙，能够在经验值排名上仅居黑龙之后、与巨兽并列第二位（不考虑资料片新增兵种的情况下），靠的是它的特技。抢先攻击和否定先攻两个技能的结合，使得傀儡龙能够在绝大多数情况下都抢在对手之前进行攻击或反击（除非对手也拥有否定先攻能力），在接触战中令敌人先遭受惨重损失。在地面部队中排名第一的速度和战场移动力，使傀儡龙不会像其他地面部队那样有较大局限性，更何况本族还有飞行魔法存在。
当然，傀儡龙不像泰坦那样可以轻易提升伤害能力，而且虽然攻击时先出手，但毕竟还是要受反击的，所以感觉还是没泰坦好用。机械特性和高地图移动力是有时选择出傀儡龙的理由，而且造它的前提建筑比造泰坦省钱并有用。


混乱城堡生物

混乱城堡

盗贼（Bandit）
1-3 | 9 | N/A | N/A
10 | 9 | 9 | N/A
7 | 23 | 27 | 6
26 | 20金
 Stealth
盗贼可以说是混乱族前期发展的关键因素之一，高级潜行技能让盗贼可以绕过地图上的一级野兵，而偷到许多资源。现在有些新编地图把资源设得特别死，限制了盗贼的偷盗作用，其实是违背了游戏设计者的本意。
在战斗方面，综合产量因素，盗贼的攻击实力尚算不错。虽然没有任何强化战斗力的技能存在，本级的半兽人能给的帮助又比较有限，但这就是为潜行技能付出的代价，也该知足了。高速度和移动力令盗贼的战斗辅助作用相对较高，同时也使他们成为游戏开始阶段所最不愿意碰到的一级野兵之一。

半兽人（Orc）
1-3 | 11 | 11 | N/A
12 | 9 | 9 | 6
4 | 19 | 18 | 10
16 | 34金
 Ranged Normal Melee
Short Range
实力不错的一级兵，却因为短程射击技能的存在影响了其实用性。弹药数量比半人马多，有时反而成为缺点，没那么容易射出不受衰减的最后一箭。由于其近战伤害不减，加速后冲上去和盗贼一起砍人有时反而是更好的选择。
作为野兵，算是比较好对付的了。无论是用远程部队与之对射，还是前排放几个弱兵、待其走上来后再用地面部队与之对砍，感觉都比对付一般远程部队容易。

美杜莎（Medusa）
3-6 | 19 | 19 | N/A
24 | 17 | 17 | 100
5 | 19 | 18 | 52
6 | 220金
 Ranged Normal Melee
Unlimited Shots Stone Gaze
无限弹药是一个很奇怪的技能（上面列出的100弹药其实只是随便写的一个数字），让美杜莎从三代弹药最少的生物变成了四代弹药最多的生物。如今美杜莎是用眼神来进行攻击，而不再像三代那样弯弓射箭，无限的弹药和巫师群战术正可以说是绝配。
石化效果的变化令美杜莎比前两代更加可怕，无论是对英雄还是高级兵，石化都是一个实实在在的威胁。曾经以为石化的几率与双方实力对比有关，但据黑孔雀的研究，石化实际上只和美杜莎自身数量、英雄或生物的等级、受攻击部队的抗魔能力有关，与攻防能力无关。50个美杜莎就能够做到平均每次攻击杀死1个四级兵了，虽然积攒50个美杜莎并不是一件容易的事情……即使是面对低级兵，石化也可以近似看作直接提升美杜莎的伤害力。
石化对无生命的部队和免疫魔法的部队无效，对有抗魔能力的部队时效果大打折扣，是在使用美杜莎时需要注意的最主要问题。

牛头怪（Minotaur）
5-10 | 16 | N/A | N/A
38 | 15 | 15 | N/A
6 | 19 | 18 | 53
6 | 230金
 Block
曾经强悍的牛头怪，在四代中算是被大大削弱了。虽然在二级兵中还算名列前茅，却没有多少实用价值。格挡的几率若高于50%还好，30%实在有点不够。与身为远程的美杜莎相比，牛头怪连移动力都不占据优势，在混乱城二级兵建造选择中被舍弃几乎是必然的结果。

梦魇兽（Nightmare）
12-26 | 23 | N/A | 6
110 | 20 | 20 | N/A
6 | 23 | 27 | 148
4 | 800金
 Terror
梦魇兽的攻防实力相当优秀，而能够施展恐怖魔法进一步增强了其实用性。虽然它的魔法值只够施放一次恐怖，但将敌人主力定住两回合已经为我方攻击、施法提供了一定的缓冲期，也容易实现将敌人分而歼灭的战术意图。

火怪（Efreet）
10-20 | 25 | N/A | N/A
80 | 23 | 23 | N/A
6 | 29 | 40 | 161
4 | 850金
 flying Fire Shield
Fire Resistance Fire Attack
自己用起来感觉一般，但作为敌人时却又难以对付，火怪就是这样一个典型的兵种。
飞行、高移动力和火盾特性，付出的代价就是攻防实力上的削弱（与梦魇兽相比）。火盾的反弹，除了黑龙、凶牙兽和具备火抵抗能力的部队外，无人可以幸免，包括抗魔宗师的英雄。从这个意义上来说，火怪也可以算是英雄杀手了。肉搏能力越强的英雄，在面对火怪时就会越头痛。
但当玩家自己使用火怪的时候，形势就反了过来。有谁希望自己的火怪靠火盾杀死敌人呢？那样意味着火怪本身已经损失惨重。因此，在这一级兵的选择中，火怪往往位居梦魇兽之后，成为次要选择。在战役中，英雄本身战力足够强的时候，造火怪来提升英雄移动力倒是比较常见的选择。

九头蛇（Hydra）
28-60 | 30 | N/A | N/A
250 | 26 | 26 | N/A
6 | 21 | 22 | 617
2 | 4000金+2水银
 Multiple Attack No Retaliation
九头蛇是优缺点都十分明显的兵种。混乱系的辅助魔法多以加强攻击伤害为主，被魔法祝福过的九头蛇冲进敌人堆里乱咬的感觉是很爽的，配合巫师群战术表现尤其出色。但在对战中，对诅咒类魔法毫无抵抗能力的九头蛇常常受制于敌人魔法，不能够发挥其真正实力。而对于追求速度的部分单机玩家来说，九头蛇低下的地图移动力是比较令人难受的。

黑龙（Black Dragon）
55-110 | 40 | N/A | N/A
400 | 40 | 40 | N/A
7 | 30 | 45 | 1233
1 | 8000金+4硫磺
 flying Immune to Magic
Breath Attack
免疫所有魔法是黑龙的最大亮点，与强大法术系部队交战时可以充分体现其优势。但这个能力也是一柄双刃剑，不能对黑龙加先攻、灵猫等好魔法，不管怎么说都有点遗憾。缺乏骗反击的杂兵时，黑龙在战斗中的应用就不如九头蛇那样顺畅，对付三级以下兵还好办，对付四级兵时被敌人反击一下可实在有点受不了。因此四代黑龙的伤害和生命值要设定得如此高，而周产量相应减少为1，就是为了避免免疫魔法带来黑龙容易损失的尴尬局面。利用德鲁伊英雄召唤魔法来帮黑龙骗反击，是可以考虑的一种战术。
总体而言，黑龙在对战中的作用要强于在单机游戏中。而与野兵交战时要用好黑龙，对玩家水平的要求要比用九头蛇高。不管怎么说，作为敌人而言，黑龙可要比九头蛇难对付多了，它无愧于四代老大的地位。


生命城堡生物

生命城堡

侍从（Squire）
2-3 | 9 | N/A | N/A
10 | 11 | 11 | N/A
5 | 19 | 18 | 7
21 | 26金
 Stun
实力中规中矩的一级步兵。由于移动力不高，多数时候要安分地替弩手作肉盾，等敌人接近时再群起而攻之。
击晕的技能和侍从的武器（链锤）比较合拍，其出现的几率为：(攻击造成的伤害÷攻击目标的总生命值)×100%－5%。与兵种(平均伤害力×攻击力)÷(生命值×防御力)≈0.2这一公式结合起来看，侍从在攻击抗打击能力与自身相当（考虑了数量因素之后）的部队时，只有15%击晕对手的可能性，这就决定了击晕的作用基本上仅存在于低级兵的接触战中，后期作用十分有限。战术英雄对击晕几率的提高是十分有帮助的，除攻击术外，领导术也可以间接提升这种几率。

弩手（Crossbowman）
2-3 | 4 | 9 | N/A
10 | 11 | 11 | 10
2 | 19 | 18 | 9
16 | 32金
 Ranged Long Range
长程射击技能让弩手成为最实用一级兵之一，若配以英雄的祝福、振奋魔法，会更加好用。在兵种整体实力不算出众的生命城堡里，弩手在发展初期的作用相当重要。

枪兵（Pikeman）
6-8 | 12 | N/A | N/A
30 | 14 | 14 | N/A
4 | 19 | 18 | 35
9 | 150金
 Long Weapon Negate First Strike
长武器攻击技能在绝大多数时候都有不受反击的效果，而且令枪兵的控制范围变得相当大，被他逼入角落的地面部队，想跑掉几乎是不可能的。虽然看起来攻击指数低，但结合产量因素，加上专门克制白虎、游牧人等兵种的忽略先攻能力，即使与本级强力部队对阵，枪兵也丝毫不落下风。
移动力低倒不是什么问题，按本族的魔法、兵种搭配来看，前期战斗本来就是以守势打法为主。速度上的缺点反而比较突出，一定程度上限制了枪兵实力的发挥。

弩车（Ballista）
5-7 | 8 | 15 | N/A
28 | 16 | 16 | 20
0 | 15 | 8 | 44
7 | 190金
 Mechanical Ranged
Long Range No Obstacle Penalty
作为远程伤害不受任何衰减的兵种，弩车在实用性上无疑强于枪兵。不吃精神类魔法的特点，也是一大优势，速度慢恐怕是其在战斗中唯一的缺点了。缓慢的地图移动力（即使加上马厩也只有20）或许是舍弃它而造枪兵的唯一原因，但有些时候还是不得不选择它。

十字军（Crusader）
10-16 | 22 | N/A | N/A
65 | 23 | 23 | N/A
7 | 19 | 18 | 124
5 | 650金
 Two Attacks Death Ward
单纯从实力上来看，十字军显然比同级的僧侣强很多。考虑到产量因素后，如果让十字军两次攻击的能量完全发挥出来，其攻击表现不会弱于某些四级兵。但作为移动力不高的地面兵种，十字军的作用还是受到了一定程度的限制。若没有好魔法的配合，在游戏中期面对强敌时难免有所损失，造成在后期难以形成数量上的优势。
死亡抵御能力原本是为十字军对付吸血鬼量身定做的，不仅能减少所受伤害，也将吸血的效果降低了一半。可惜的是宗师招魂技能的存在，让原本可以完全克制吸血鬼的十字军失去了优势。

僧侣（Monk）
10-15 | 10 | 20 | N/A
55 | 22 | 22 | 12
5 | 19 | 18 | 107
6 | 550金
 Ranged Death Ward
能力上毫不出彩的三级兵，唯一的优势就是其远程攻击特性了。虽然实力上远不及十字军，但实用性却并不差，在没有好魔法的时候，反而更能体现作为远程部队的优势：在接触战之前就充分打击敌人。

精英骑士（Champion）
24-36 | 25 | N/A | N/A
150 | 25 | 25 | N/A
6 | 25 | 30 | 320
4 | 2000金+2木/铁
 First Strike Charge
产量高是精英骑士的优势，但也是其劣势。正因为产量高，所以其抗打击能力仅仅是一般四级兵的一半，在大兵团作战中就比一般四级兵更容易遭受损失。感觉上与十字军有点相似，就是攻击实力出众，但若无好英雄、魔法配合，较易遭受损失。
先攻能力以及冲锋所积累的伤害，可以一定程度弥补其抗打击能力偏弱的缺点。但在面对强力远程部队时，精英骑士的处境还是有些尴尬，因为其相对较低的防御力，战斗开始时往往不敢站在前排，冲上去要绕不少路，如果战场上还有障碍物，就更难以实现压制远程的任务了。

天使（Angel）
40-65 | 30 | N/A | 20
230 | 34 | 34 | N/A
10 | 30 | 45 | 620
2 | 4000金+2水晶
 flying Resurrection
在三代傲视群雄的天使，在四代仅仅只是一个中游的顶级兵罢了，在攻击实力上不如精英骑士，单挑恶魔也打不赢，更加给人以落魄的感觉。
然而兵种的实用性并不仅仅取决于其实力，相对较高的抗打击能力、飞行、高移动力、复活魔法，这些都是天使的优势。尤其在英雄复活魔法已经被取消的四代中，天使的复活对保持部队的持续战斗力有相当帮助。


死亡城堡生物

死亡城堡

恶魔之子（Imp）
1-2 | 10 | N/A | N/A
7 | 10 | 10 | N/A
6 | 28 | 38 | 5
28 | 18金
 flying Mana Leech
攻防能力与自然的妖精一样，但是因为没有战斗辅助特技，因此基本上不可能成为战斗中可倚重的力量，除非是用召唤恶魔之子魔法一次召唤大量出来。利用高移动力四处引诱敌人，让敌人部队之间拉开距离，是恶魔之子为数不多的用处之一。
吸取魔力有点用处，但在一般地图中，与敌人英雄交战不会太早，以中后期的部队组成来说，幽灵分组的情况更多见，分多组恶魔之子是不太可能的，这限制了吸取的效果（注意吸取还有视线要求）。而在战役中，多组恶魔之子狂吸敌人英雄魔法值的情况倒是常见一些。吸取技能更现实的作用是吸取生物魔法值，而非吸取英雄魔法值，像天使的复活，魔法值被吸一次就用不出来了。在面对野外施法兵种时，吸取能起到一定作用，少量吸血鬼在搭配恶魔之子后，打法师或是水元素会轻松许多。
恶魔之子在战略发展上的作用其实比战斗中的作用更强，高地图移动力对于四处捡矿和带英雄走路都是非常有用的。

骷髅兵（Skeleton）
1-2 | 12 | N/A | N/A
8 | 12 | 24 | N/A
4 | 19 | 18 | 6
25 | 22金
 Undead Skeletal
曾经叱咤风云的骷髅兵，在四代中已经大大没落了。在四代中，积攒数百骷髅的情况已经不多见，招魂术如今的重点（终点）是招吸血鬼。而且，就算有数百骷髅，凭借其低下的攻防实力，也发挥不出太大的作用。利用高远程防御力来挡箭，是没落骷髅仅存的优势。

地狱犬（Cerberi）
4-6 | 16 | N/A | N/A
24 | 16 | 16 | N/A
6 | 21 | 22 | 44
7 | 190金
 3-Headed Attack No Retaliation
地狱犬的实力与上一代相比基本上没多大变化，但在规则改变的四代中（英雄攻防不再直接叠加在部队攻防上），作用却下降了。当然，产量降低也是影响因素之一。积攒到一定数量的地狱犬，其战斗力无疑是强悍的，但这种积攒过程却太漫长而不值得等待。基本上，只有通过召唤地狱犬魔法，我们才能体会那种强悍。
不过在实战中，地狱犬的狗舍却更常被建造。原因无他，只是因为建造需求低，可以更快过渡到三级的吸血鬼。在狗舍完成后，地狱犬却依然难有出头之日，一般都是永远被囤积，成为一种摆设。

幽灵（Ghost）
2-4 | 15 | N/A | N/A
15 | 30 | 30 | N/A
6 | 28 | 38 | 33
9 | 140金
 flying Undead
Aging Insubstantial
实力在二级兵中排名倒数第一位的幽灵，却因为老化特技的存在，成为了最实用的二级兵。降低敌人攻防和速度、移动力减半，战斗的胜负往往就是因此而改变的。更可怕的是，老化的效果还能和其余减速类效果叠加，即使快如天使、凤凰这样的兵种，在双重打击下也只能小行龟步，被玩家无情地戏耍。
因为在建造前提上多了一个耗废2500的建筑，幽灵在城内往往是不造的。但这并不代表幽灵被舍弃了，因为专家和大师招魂术都能制造幽灵，在宗师招魂修炼完成的这段真空期内，造那么二三十甚至更多的幽灵是完全可能的。

食尸怪（Venom Spawn）
16-24 | 13 | 26 | N/A
100 | 26 | 26 | 15
6 | 19 | 18 | 201
3 | 1100金
 Ranged Posion

食尸怪攻防两方面的实力在三级兵中都排名第一（不考虑产量因素），但在与吸血鬼的争夺中，它却只能无奈地败下阵来。一是因为没有吸血鬼那么无赖好用，二是地图移动力太低。由幽灵、吸血鬼、骨龙（或是恶魔）组成的部队，既有强大战斗力，又有高达28点的地图移动力。如果要在这里加上食尸怪，移动力一下子降低1/3左右，实在有点难以令人接受。
当然食尸怪与吸血鬼之间的差距，并不像蛇妖与灯神之间的差距那样大，毕竟这么高的攻击能力摆在那里，又是远程部队，毒击也难以解除，总是有点难对付。电脑如果不造灯神而造蛇妖，估计很多人心中都会窃笑；但若是电脑不造吸血鬼而造食尸怪（事实上电脑经常是这么干的），却并不会让人轻松多少。若没有好魔法，攻城时看见一些食尸怪站在箭塔上，可着实令人头疼。

吸血鬼（Vampire）
12-18 | 30 | N/A | N/A
75 | 30 | 30 | N/A
8 | 28 | 38 | 205
3 | 1100金
 flying Undead
No Retaliation Life Draining
吸血鬼可以说是游戏中最为无赖的兵种，对付有生命的部队时可以依靠吸血，对付无生命但移动力低的部队时，可以凭借高移动力和不受反击特性采取打了就跑的游击战术。
对于整个死亡族的发展来说，吸血鬼无疑是极其重要的。2个吸血鬼就可以对付绝大多数一级野兵了，而若有英雄的疲劳魔法，多数二级兵和少部分三级兵也可以打。如此好用的兵种，建造起来却没有多少前提条件，资源需求也不大，给人感觉不太公平。更加不公平的是宗师招魂可以制造吸血鬼，这才是对手见吸血鬼色变的最重要原因。吸血鬼虽然强，但与其他兵种配合上不如灯神，纯攻击能力上不如独眼，三者的战略价值虽然有所差距（受地图实际情况影响），但原本还是相当的，是宗师招魂使吸血鬼的作用被夸大化。亡灵巫师上来就将钱箱转化为经验值猛升级，是比较奇异的景象，但也会是绝大多数人的选择。

恶魔（Devil）
34-50 | 33 | N/A | 8
210 | 33 | 33 | N/A
7 | 30 | 150 | 614
2 | 4000金+2硫磺
 Teleport Summon Demons
Life Ward
传送的移动方式、恐怖的战场移动力，使得恶魔成为又一个英雄杀手。尽管为这些特性付出了攻防实力设定略低的代价，也是值得的。虽然在突袭敌人英雄后有可能遭受围攻而损失惨重，但若能令对方部队在失却英雄后陷入被戏耍状态（死亡魔法本来就以诅咒削弱见长，比较容易实现戏耍），那么恶魔的舍生取义还是值得的。当然，这一幕最好发生在决战中。
虽然失去了三代中不受反击的能力，但若有恐惧结界魔法的配合，还是可以部分实现不受反击的效果。再加上能召唤冰魔，恶魔的实用性其实相当强。生命抵御技能是很有趣的能力，在三代中怎么也打不过天使的恶魔，如今终于可以得意地冷笑了。另外，在对付灯神战术时，生命抵御也能起相当作用。

骨龙（Bone Dragon）
45-65 | 30 | N/A | N/A
275 | 30 | 60 | N/A
5 | 28 | 38 | 621
2 | 4000金+2水晶
 flying Undead
Skeletal Fear
如果说，三代中骨龙能力的低下，是对强大的骷髅海战术的一种补偿的话，那么在四代有招魂吸血鬼存在的情况下，骨龙的强大就显得比较无理了。本就不弱的攻防能力，加上引起恐惧技能的助纣为虐，骨龙排在顶级兵的前几位乃是必然结果。在面对有生命的敌人部队时，引起恐惧技能多数时候可以等同于不受反击。而远程防御力翻倍，也可以看作是对引起恐惧唯一不良后果的补偿（若不然，在面对近战杀伤减半的远程部队时，打退敌人只能给自己惹麻烦）。只是这种补偿效果实在有些过头，让骨龙变成了远程部队的噩梦。


自然城堡生物

自然城堡

妖精（Sprite）
1-2 | 10 | N/A | N/A
7 | 10 | 10 | N/A
6 | 29 | 40 | 7
23 | 22金
 flying No Retaliation
高移动力和不受反击的特点，使得早期战斗常常可以用妖精来执行游击战术。半羊人的振奋和水元素的流沙，可以进一步强化此战术的效果。但是为了拥有高移动力和不受反击特性，妖精所付出的代价就是攻防实力设定偏低。如果一场战斗是以妖精为主力来进行的话，其战斗过程基本上都会十分漫长，容易令人厌烦。
如恶魔之子那样，在捡矿、探地图等方面妖精的作用也是不可替代的。

狼（Wolf）
2-3 | 9 | N/A | N/A
12 | 9 | 9 | N/A
7 | 21 | 22 | 11
15 | 36金
 Two Attacks
狼的实力，在一级兵中无疑是名列前茅的。可惜战场移动力虽然不错，但还是有点不够的感觉，本族的妖精既不能帮忙骗反击，又习惯打了就跑，影响了狼的战斗表现。若有英雄召唤魔法和加速魔法的辅助，狼的实力便能充分发挥了。

精灵（Elf）
3-4 | 8 | 16 | N/A
18 | 16 | 16 | 24
6 | 19 | 18 | 43
7 | 190金
 Ranged Shoot Twice
Ranged First Strike
不错的攻击实力、脆弱的生命力，一直是历代游戏中精灵的特点。虽然四代的精灵被削弱了，连射两箭的威力才能赶上同级兵打一下的威力，但是战场的扩大以及本族魔法的配合，使精灵仍然是比较好用的兵种。若不是建筑前提要求高（资金是一大因素，但对木材的需求才是最要命的），恐怕多数时候我还是愿意选择精灵。虽然其地图移动力低，但多数二级兵的作用一般也就存在于中前期，后期被带的可能性不高，部队推进速度在短期内被拖慢还是可以接受的。

白虎（White Tiger）
6-8 | 19 | N/A | N/A
35 | 19 | 19 | N/A
8 | 24 | 28 | 53
6 | 220金
 First Strike
二级兵中实力最强的兵种之一，虽然伤害值和生命值一般，但高达19点的攻击防御力是不能忽视的，只是在面对魔法攻击时显得比较脆弱。野外的白虎相当难对付，高速、高移动力和先攻技能都令人头疼。但作为城内招募的兵种，白虎的作用却不如想像中那么强。因为产量因素，要积攒相当数量是比较难的，若没有数量优势，在遭受敌人反击时就难以避免损失。城内出白虎不少时候都是无奈选择，但若有一定野外招募地配合，白虎有望一跃成为前期主战力量。

独角兽（Unicorn）
12-20 | 20 | N/A | N/A
80 | 20 | 20 | N/A
6 | 25 | 30 | 120
5 | 650金
 Blinding
实力一般的三级兵，失明特技一定程度提升了其作用，但仍不能对其实力起实质性影响。因为本族发展要点是尽快出生物召唤门和四级兵，因此建造条件低的独角兽，往往成为自然城堡的必然选择，但上阵率并不高。

狮鹫（Griffin）
16-22 | 19 | N/A | N/A
95 | 19 | 19 | N/A
6 | 29 | 40 | 154
4 | 800金
 flying Unlimited Retaliation
狮鹫的实力在四代中实现了飞跃，将许多原先强于它的兵种抛在了身后。无限反击特性是最大优点，如配合蛇击魔法，表现更佳。可惜由于产量因素，加上抗打击能力并不十分出色，无法成为本族发展的关键因素。既然在战略价值上无法绝对超越独角兽（否则砸锅卖铁也要造出来），加上建筑前提需求太高，只好无奈地被舍弃了。其实四代有不少这样的兵种，因为最高难度下野兵数量多，而不能真正发挥实力，在选择中遭弃。从这一点来说，四代的平衡性明显有所欠缺。
但在召唤魔法中，因为少了担心损失这一后顾之忧，狮鹫的优势便能充分体现出来了，召唤一些后朝敌人堆中一猛子扎进去，是非常快意的事情。

仙女龙（Faerie Dragon）
34-50 | 15 | N/A | 40
220 | 29 | 29 | N/A
7 | 29 | 40 | 612
2 | 4000金+2宝石
 flying Spellcaster
Magic Mirror
仙女龙可施展的魔法包括混乱、火环、火球和闪电，威力为魔法基本威力×仙女龙数量×0.94
攻防实力一般却具备极强战略价值的兵种，混乱魔法的作用比灯神的和平之歌更强，而40点魔法值令魔法的使用次数更多。但与灯神相比，作为顶级兵的低产量是其劣势，一定时间内很难做到像灯神那样，分多组单个的部队后，仍然有足够数量组织一队主力。而且将顶级兵的用途集中在控制上，部队的整体战斗力便会削弱，必须依靠螳螂和英雄的实力来弥补。
作为野兵来说，如果英雄有宗师抗魔，仙女龙就是小菜，否则便会比其余四级兵更加难对付，其魔镜特性会让我方在施展魔法时有很大顾忌。

凤凰（Phoenix）
45-65 | 28 | N/A | 12
275 | 28 | 28 | N/A
12 | 30 | 45 | 609
2 | 4000金+2水银
 flying Breath Attack
Fire Resistance Rebirth
在战略价值上来说，凤凰是不如仙女龙的。虽然攻防实力强，又有重生，但仍然不能像用仙女龙那样有效减少部队整体损失。但若对手的部队对仙女龙的魔法有很强抗性，那么凤凰便是更好选择。
在凤凰数量少时，分多组单个的凤凰，是比较理想的用法。单个凤凰被打死之后可以保证重生，虽然复生出来的生命值只剩55点，但只要指挥得当便可避免损失。火抵抗特性使得凤凰在围着敌人互吹时不必担心误伤问题，与黑龙相比，这是一个优势。


力量城堡生物

力量城堡

狂暴者（Berserker）
2-3 | 12 | N/A | N/A
18 | 8 | 8 | N/A
6 | 20 | 20 | 8
19 | 20金
 Two Attacks Berserk
连击两下的能力，令狂暴者成为单兵攻击实力最强的一级兵，连半人马都要自叹弗如，更何况狂暴者还有产量上的优势。狂暴的特性令狂暴者的好用程度打了不少折扣，不能最大限度减少损失。在游戏推出的初期，力量城堡是公认最难用的种族，原因就在于这个疯老头。但自从有人发现“堵狂暴者”的战术之后，狂暴者的战斗存活率就提高了，而力量城堡的发展难度也降低了许多。
“堵狂暴者”战术，简单说就是利用环状阵型，将狂暴者堵在4号位，等敌人接近后再放出来，避免其乱冲乱蹿造成无谓损失。一般说来，放其身前（3号位）的部队，是单个半人马，负责在敌人接近时骗反击。虽然半人马速度低于狂暴者，但因为四代中反击的机理发生了变化，半人马骗反击的效果延续到下一回合狂暴者行动时，是不成问题的。而在阵型的两个肩部（1号位和5号位），一般也是单个的半人马，负责在后续回合中继续骗反击，或是利用高移动力的特性将部分敌人引开。
综合产量因素，狂暴者的攻击实力甚至强于二级兵，这就使得他在相当一段时间内都是本族的主力。即使独眼出来之后，狂暴者的作用仍不可忽略。虽然在正确指挥下仍然难以避免损失，但每周19的产量，就算元气大伤也很容易重新集聚起战斗力。
作为野外敌人来说，狂暴者的经验值设定低使数量变多，无疑是最难对付的一级野兵。

半人马（Centaur）
3-5 | 10 | 10 | N/A
20 | 10 | 10 | 4
4 | 25 | 30 | 18
9 | 40金
 Ranged Normal Melee
Short Range
实力上看无疑是一级兵的王者，但考虑到产量因素，并没有鹤立鸡群的地位。而从实战来看，甚至有鸡肋的感觉。短程射击是非常讨厌的特性，而偏慢的速度令高移动力的优势根本没法充分发挥。半兽人还有盗贼帮助骗反击，而在力量城堡中，半人马只能负责帮狂暴者骗反击，委屈啊。产量本来就不高，骗反击、诱敌，经常一仗就损几个，很难积累起数量。如果有个精准或加速魔法，半人马会好用许多，可惜对于力量城堡来说，绝大多数时候都只是奢望。这么强的兵种沦落为鸡肋，有点悲哀的感觉。如果能力降低，产量相应提高，说不定还好用些（在使用策略上，低级兵与高级兵不同：低级兵不怕损失，数量多一些更好用；而高级兵死一两个都会心痛，降低产量兵相应提高抗打击能力，会比较有利于持续作战）。

鹰身女妖（Harpy）
4-5 | 16 | N/A | N/A
24 | 15 | 15 | N/A
5 | 28 | 38 | 39
8 | 110金
 flying No Retaliation
Strike and Return
鸟妖和妖精相似，为出众的技能付出了降低指数的代价，但仍然是相当好用的兵种。攻击后返回，使得其可用战术比妖精更丰富。攻城时打城门是一把好手，而利用电脑AI上的弱智，守城部队若不出城，鸟妖可以呆在城外一小格的位置上将敌人慢慢打死。
速度上的缺点，让鸟妖在游击战术中的作用不如妖精，毕竟速度低于5的兵种还是不多的。返回的特性，有时候会带来反效果，特别是在被敌人逼入角落时。不过此时四代的优越性就体现出来了，就是在攻击时可以选择攻击方式，适当的时候选择近身攻击（Melee），而不是攻击后返回，可以避免尴尬局面的出现。
虽然好用，但城堡内造鸟妖的情况还是处于少数，建筑前提太高了。即使是打算今后造雷鸟，可以帮助省下造大本营的费用，鸟妖仍然不是必然选择。因本族发展关键是三级的独眼，在资金不足情况下，造鸟妖就意味着迟5天时间出独眼（多花3500金，城堡收入一般是750），有时是很难令人忍受的。

游牧人（Nomad）
6-9 | 16 | N/A | N/A
45 | 13 | 13 | N/A
8 | 27 | 36 | 52
6 | 150金
 First Strike
攻防实力出众的游牧人，比起前几代来说是有了不小提高。虽然好用程度不如鸟妖，但因为本族前期主力是血比较厚的狂暴者，游牧人呆在旁边捡个便宜不难，相对其他种族的类似兵种来说，体现战斗力的机会要多得多，实用性也算不错了。在不是特别富裕的情况下，游牧人的上镜率要高于鸟妖。

食人魔法师（Ogre Mage）
12-18 | 18 | N/A | 6
85 | 16 | 16 | N/A
4 | 19 | 18 | 101
6 | 350金
 Bloodlust
综合产量因素来看，食人魔法师无疑是个狠角色，加了嗜血状态后就更加生猛。而且嗜血可以施放在本方其余部队身上，想想加了嗜血的狂暴者或是四级兵，不能不让人心动啊。可惜与战略地位卓越的独眼巨人相比，食人魔法师只能乖乖地挪位。独眼巨人有那么几个就可以拉出去好好打几仗了，对发展帮助很大，而同期所生产的食人魔法师却没有这种作用。如果选择食人魔法师，有可能会迟一两周甚至更多时间出四级兵，那么就算加了嗜血又有多少用处呢？不过如果有野外招募地，招那么几个食人魔法师来用，我还是很愿意的。

独眼巨人（Cyclops）
12-18 | 15 | 30 | N/A
95 | 24 | 24 | 8
4 | 21 | 22 | 203
3 | 750金
 Ranged Area Attack
三级兵中最具战略价值的三大巨头之一，范围攻击能力是其最重要武器。可以大约算一下，如果范围攻击波及三支部队，独眼的攻击威力是(12+18)÷2×30×3＝1350，比泰坦的威力（(34+50)÷2×32=1344）还强。而在玩家的操纵下，同时攻击多队敌人并不难实现，由此也可以想出独眼巨人对战斗有多么大帮助了。而范围攻击一大特性：对于视线外被波及的敌人可以造成完全伤害，使得独眼可以很轻易地对敌人后排射手、英雄造成重创，进一步增强了实战价值。
独眼的缺点是速度偏慢，而且弹药数偏少。在与野外独眼交战时，充分利用这些缺点，可以衍生出一些应对方案。

雷鸟（Thunderbird）
28-40 | 30 | N/A | N/A
170 | 30 | 30 | N/A
6 | 29 | 40 | 406
3 | 1800金+2水银
 flying Lightning Attack
从二代的大鹏到四代的雷鸟，这个兵种每一代实力都有很大提升。比上一代强化了许多的闪电攻击，令雷鸟在攻击高防御兵种时表现比巨兽更出众。和精英骑士相似，抗打击能力偏低一定程度制约了雷鸟的使用，很多时候若没有英雄帮忙骗反击，雷鸟还是比较脆弱的。

巨兽（Behemoth）
55-80 | 36 | N/A | N/A
240 | 34 | 34 | N/A
6 | 21 | 22 | 630
2 | 2750金+2水晶
 Strength
虽然伤害力如此出众，但巨兽的可怕程度比起三代来说还是有所下降，主要是特技效果不同了。地面部队的特性是巨兽与雷鸟比较时的一大劣势，但也不足以完全决定两者的优劣。由于独眼巨人的存在，力量族在很多战斗中是不急于冲上去与敌人决斗的，而巨兽的速度与雷鸟一样，在近距离接触战中根本没什么劣势，单体生命值高的优点就比较突出了。因此在不少时候，两者都是地位相当的可行选择。


召唤门生物

生物召唤门生物

    自然城堡内可以建造生物召唤门，里面有以下8种生物供招募。所能招募的生物，按每天100点经验值的速度累积。下面所列出的产量，实际上是相应野外招募地产量的两倍。

丛林妖精（Leprechaun）
1-2 | 10 | N/A | 3
8 | 10 | 10 | N/A
6 | 19 | 18 | 7
22 | 24金
 Fortune
作为游戏中攻击实力并列最差的兵种之一，丛林妖精即使积攒相当数量也不会有什么威力可言，因此几乎没有花钱去购买的必要。它的存在价值，就是施展幸运魔法来保护我方主力部队，有那么一两个就够了。印象中，我还从来没有招募过这小东西，从来都是用魔法把它召唤出来的。

半羊人（Satyr）
5-8 | 14 | N/A | 6
36 | 13 | 13 | N/A
6 | 20 | 20 | 39
8 | 170金
 Mirth
振奋魔法的使用，不仅可以提高部队行动优先度，还可以提高攻击力。在一般地图中造好生物召唤门之后，我会习惯性地招一个半羊人出来带着，两次振奋魔法对战斗的帮助还是挺大的。
作为野外敌人来说，半羊人的攻击表现可比其表面指数强多了。如果没有好的魔法，四级兵不小心被它们搞死一个都并非不可能。

风元素（Air Elemental）
6-10 | 16 | N/A | N/A
40 | 32 | 32 | N/A
7 | 29 | 40 | 74
6 | 350金
 Elemental flying
Insubstantial
高防御力和高移动力，加上元素属性不吃绝大多数精神类魔法，风元素也算是一种不太容易对付的敌人。虽然被招出来用的时候不多，但利用其特性来压制远程部队，是某些时候可以考虑的选择。

土元素（Earth Elemental）
9-14 | 18 | N/A | N/A
50 | 20 | 20 | N/A
1 | 18 | 14 | 77
6 | 375金
 Elemental Magic Resistance
虽然经验值在四大元素中排名第一，攻击实力也是第一，但土元素的实用性无疑是最差的。低下的速度和移动力令其攻击实力根本发挥不出来，即使作为敌人也非常容易对付。与金人相比，土元素应该感到羞愧。这样的垃圾兵，有人愿意花钱去招么？
利用其魔法抗性，在面对以杀伤魔法为主的敌人英雄时，用魔法召唤土元素挡在身前，是对土元素屈指可数的利用之一。

火元素（Fire Elemental）
7-10 | 10 | 20 | N/A
50 | 18 | 18 | 20
6 | 20 | 20 | 75
6 | 350金
 Elemental Ranged
Fire Resistance Fire Attack
不吃绝大多数精神类魔法的远程部队，光是这一点就足以让火元素自傲了，与它们交战并不是随随便便就能搞定的。其攻击实力与经验值的比例中规中矩，虽然不常被招募，但那只是因为召唤门的经验值共享，招火元素必然影响招螳螂，所以只好被舍弃，并不是它太差。

水元素（Water Elemental）
6-9 | 17 | N/A | 24
38 | 17 | 17 | N/A
5 | 19 | 18 | 73
6 | 350金
 Elemental Spellcaster
Cold Attack Cold Resistance
水元素可施展的魔法包括疲劳、冰箭、流沙和虚弱，冰箭威力为40×水元素数量×0.29，流沙长度则是恒定的20英尺（但可通过本族奇迹建筑延长）。
虽然经验值在四大元素中排名最低，但实用性却是最高的。疲劳魔法可以对大部分生物起效，流沙更是所有地面部队的天敌。造好召唤门之后，我习惯招3到4个水元素来用，虽然不能对付所有种类的敌人，但至少能对付相当一部分。在妖精快速探开地图、看清周围野兵配置的情况下，水元素的使用可以做到有的放矢。虽然地图移动力稍微有点低，但只要能够成功渡过瓶颈期，靠抢来的资源出四级兵，水元素差不多也就可以功成身退了。此后水元素的应用，多半是在召唤魔法中。
作为野兵，水元素的难对付程度与风元素仿佛相当，有些时候还更强一些。
值得注意的是，冰抵抗特性的存在，让水元素在对付灯神时能发挥奇效。同样是冰箭魔法，却有“只许州官放火，不许百姓点灯”的味道。召唤水元素，是英雄没抗魔能力时对付野外灯神的好方法之一。

毒蜂草（Waspwort）
10-14 | 11 | 22 | N/A
60 | 22 | 22 | 20
4 | 15 | 8 | 105
6 | 550金
 Ranged Weakness
从攻防实力上来看，看不出毒蜂草经验值设定比僧侣低的理由，而其虚弱特技也显然比僧侣的死亡抵御有用得多。或许速度低是唯一因素吧？但差距仅有1，都没有达到临界速度（6），两者并没有什么实质差别。和螳螂争经验值，以及地图移动力慢，是平常不招毒蜂草的最大原因，但若有召唤魔法，还是很强的。

螳螂（Mantis）
34-50 | 34 | N/A | N/A
210 | 34 | 34 | N/A
8 | 29 | 40 | 614
2 | 4000金+2宝石
 flying First Strike
Binding
尤记得在前瞻中，我是多么讨厌螳螂，无法理解一只大昆虫（不管有多大）怎么能比我一直喜欢的泰坦更强呢？但如今这只大虫子已是人见人爱了，缠身特技无论是对保护英雄还是其余部队都有相当大的作用。虽然产量低，但缠身的攻击力减半效果已经相当程度弥补了这一缺陷。由于本族四级兵多数时候选择仙女龙，螳螂和英雄就成为了部队中的主战力量。在使用上，要避免其遭受围攻，因为缠身只对其攻击的最后一个目标起作用。
在对付野外螳螂的时候，用一个疯狂让它们互相定住，是很有趣的打法。


中立生物

农民（Peasant）
2-3 | 6 | N/A | N/A
10 | 7 | 7 | N/A
2 | 18 | 14 | 4
36 | 15金
 TaxPayer
虽然不再是所有指数纯为1的白痴兵种，但农民伯伯还是只能安分地呆在兵种实力排名的最后一位上。如果在游戏刚开始时能够招募那么几十人，多少是有点用处的，但谁也不会傻到在中后期还指望农民的战斗力。不过若有殉难或牺牲魔法，农民还算不错的生命值就会有用武之地。
纳税是个比较没用的特技，一是至少15天才能收回成本，二是按产量来说对王国的贡献实在太有限。若能用外交和魅惑招降一群，或许还可以考虑。需要注意的一点是，把农民放在城内或是矿场内，虽然在王国总览里看不到产钱效果，实际上还是默默在作贡献的。英雄若有产钱产矿技能或是宝物，也是一样。

海盗（Pirate）
1-2 | 11 | N/A | N/A
10 | 9 | 9 | N/A
5 | 19 | 18 | 7
24 | 22金
 Bonuses at Sea
海盗的战斗力，只有在海上时才能充分发挥，登陆后就成了非常平庸的兵种了。由于出现地点的局限性，无论是招他来用，还是与之交战，都不太常见。

穴居人（Troglodyte）
2-3 | 11 | N/A | N/A
14 | 9 | 9 | N/A
5 | 19 | 18 | 8
19 | 28金
 Immune to Visual Attacks
实力还算不错的一级兵，因为是中立兵种，招来使用的情况比较少。免疫视觉攻击是基于其基本特征（没眼睛，用红外线感受周围环境），多数时候不会有用。除此之外就没有战斗加强的技能了，穴居人的地位也就仅限于一级中游。

僵尸（Zombie）
2-4 | 8 | N/A | N/A
24 | 10 | 10 | N/A
1 | 18 | 14 | 10
15 | 35金
 Undead Toughness
慢和生命值高一向是僵尸的特点，四代中也不例外。虽然慢，但生命值翻倍的影响力毕竟不能忽略。在早期战斗中要消灭僵尸会比想象中困难些，经常打了半天还剩不少。

石像鬼（Gargoyle）
4-6 | 14 | N/A | N/A
22 | 16 | 16 | N/A
7 | 29 | 40 | 38
8 | 160金
 Elemental flying
Stoneskin
虽然看上去攻击力不强，但高移动力和元素属性，却让石像鬼在早期战斗中经常会对英雄的安全造成大威胁。如果自身实力不强，还是别惹它为好。

木乃伊（Mummy）
5-8 | 15 | N/A | N/A
30 | 16 | 16 | N/A
4 | 19 | 18 | 39
8 | 170金
 Undead Curse
木乃伊的实力比起前两代有了一定程度的强化，诅咒如今是必出的效果，除了受魔法抗性制约外，对亡灵一样可以起作用。硬碰硬地打并不是好的选择，战术上的合理安排，才是对付此类兵种的首要原则。

美人鱼（Mermaid）
5-8 | 15 | N/A | N/A
38 | 13 | 13 | N/A
5 | 19 | 18 | 39
N/A | N/A
 Hypnotize
催眠特技是美人鱼最可怕的地方，连宗师抗魔英雄都不能完全避免受控制。与这样的怪物交战，时刻都要打起十二分注意力，稍有不慎便会损失惨重。好在她们基本上只在海上出现，让我们游戏时少了一份提心吊胆。无法招募是完全必要的设计，否则真是太强。

邪眼魔（Evil Eye）
3-7 | 8 | 16 | N/A
26 | 15 | 15 | 15
6 | 19 | 18 | 51
6 | 220金
 Ranged flying
Random Harmful Spells
邪眼的攻防实力不强，但攻击时随机附带的诅咒类魔法却大大增强了其战斗力和实用性。如果游戏开始时城堡附近有个邪眼巢，那对初期发展可是极有帮助的。战斗时带上多组单个的邪眼，即使不打出疲劳效果，随便出些诅咒类效果也能大幅度削弱敌人实力，为以弱胜强创造条件。用远程兵去与邪眼配合，相对而言更好些。
另外要注意邪眼攻击附带的废除效果，和废除、驱散魔法一样，可以去掉宗师抗魔英雄身上的正面魔法，不可不防啊。另外废除效果可以直接消灭幻象（幻影）副本以及操纵的尸体，也是与之交战时需要留意的一点。

洞穴巨人（Troll）
6-12 | 16 | N/A | N/A
45 | 15 | 15 | N/A
3 | 18 | 14 | 54
6 | 230金
 Regeneration
指数较强的兵种，但实际上却不怎么样。低移动力是最大弱点，实在有太多方法可以加以戏弄。再生的特性在最高难度游戏中其实没太大作用。回忆起一代中同一兵种（当时还在扔石头，中文版译名巨魔）的风光，经常用高防御英雄带着几个就敢去单挑野外六级兵，实在有恍如隔世的感觉。

冰魔（Ice Demon）
12-16 | 30 | N/A | N/A
70 | 30 | 30 | N/A
5 | 19 | 18 | 157
4 | 850金
 Cold Attack Cold Resistance
Freezing Attack
冰魔本身的实力就已经相当强了，冷冻攻击更是增强了其实用性。被冷冻的敌人不仅两回合无法行动，而且打不还手。如果资金条件许可的话，野外的冰魔可以考虑招几个来用用。

海怪（Sea Monster）
45-65 | 35 | N/A | N/A
275 | 34 | 34 | N/A
5 | 24 | 28 | 624
N/A | N/A
 Devouring
大嘴吃四方的灯笼鱼还真是好胃口，什么东西都能吞下去，亡灵、机械、元素之类的也来者不拒，更无视魔法抗性，宗师抗魔的英雄和免疫魔法的黑龙都不能避免被吞。被它吞食的部队，不但无法复活（包括吸血复生），而且也失却了利用价值，不能再用来驱役亡灵或是制造尸体。
即使不考虑吞食能力，海怪仍然是实力出众的顶级兵，攻防实力强，移动力也不错，其实它应该排在黑龙之后位居榜眼才对。如果没有控制类魔法、流沙和各种召唤术，打这种怪物是非常头疼的，幸亏它基本只出现在海上。


『阴云密布』新增生物

    在资料片『阴云密布』中新增了四种生物，实力强大但无法招募。而在第二个资料片『战风』中，新增了几个野外设施，这四种生物便可以在相应的野外招募地里进行招募，但产量为这里列出数据的一半（因为野外招募地的产量比城堡中的减半）。
    大耳怪骑士所属阵营为混乱，邪魔女所属阵营为守序，恐甲兽所属阵营为自然，暗黑骑士所属阵营为死亡。

大耳怪骑士（Goblin Knight）
16-30 | 20 | N/A | N/A
120 | 26 | 26 | N/A
7 | 27 | 36 | 157
4 | 1000金
 Magic Resistance Stoneskin
Negate First Strike
大耳怪骑士的攻防实力已经超过了原版中所有的三级兵，而在地面部队中名列前茅的战场移动力，使其更为强悍。原先还可以用诅咒类魔法与之周旋，但随着其50%的魔法抗性在『战风』中由假变真，使大耳怪骑士几乎成为了最难缠的三级野兵。否定先攻技能是对其实力的锦上添花，这样的兵种经验值只有157，老实说实在有点委屈了（经验值设定低，就意味着在野外出现时数量较多）。

邪魔女（Evil Sorceress）
20-34 | 28 | N/A | 50
100 | 28 | 28 | N/A
7 | 30 | 150 | 750
2 | 4000金+2水银
 Teleport Spellcaster
Magic Mirror
邪魔女可施展的魔法包括群体废除、群体迟缓、驱逐和爆裂，爆裂威力为90×邪魔女数量。
又一个英雄杀手，与恶魔相比，可以说是各有所长。恐怖的魔法杀伤力对许多部队都是巨大威胁；即使英雄有宗师抗魔或是有部队帮助阻挡视线，但仍然要提防其瞬间移动过来的直接攻击。虽然邪魔女的近战攻击能力在四级兵中位居最末席，也绝对不可以小瞧。魔镜能力令常用的控制战术在邪魔女面前也无法奏效。宗师抗魔+控制/召唤战术，或是催眠，才可以比较好地对付她们，否则惨重损失在所难免。幸亏其生命值只有区区100点……
但是若由玩家来操纵，邪魔女却又不那么好用，主要是缺少控制类魔法。群体迟缓虽然很有用，但不少时候都比不上仙女龙的混乱，战略价值稍逊一筹。

恐甲兽（Gargantuan）
28-40 | 32 | 32 | N/A
300 | 32 | 32 | 16
4 | 21 | 22 | 800
2 | 4000金+2水晶
 Ranged Normal Melee
Shoot Twice Area Attack
近战伤害不减、连射两箭、范围攻击，简直就是一个完美的远程兵种，在这位老大的面前，泰坦也只能甘拜下风。除了速度偏慢，比较容易用遗忘或是控制类法术对付外，找不出什么缺点了。由玩家来操纵也非常好用，很容易超越双倍、甚至三倍泰坦的表现。

暗黑骑士（Dark Champion）
30-42 | 40 | N/A | 18
200 | 40 | 40 | N/A
6 | 30 | 45 | 1000
2 | 4000金+4矿石
 Undead Terror
Regeneration Charge
虽然伤害值和生命值都偏低，但等同于黑龙的攻击防御力已经让人无法小觑暗黑骑士。高移动力配合冲锋技能，大大提高了其攻击实力，而再生技能则提升了其抗打击能力，恐怖魔法更是冷不丁地会给战局带来重大影响。亡灵特性使得暗黑骑士更加难以对付，1000点的经验值真是实至名归。除了迟缓+流沙，很难再想出好的方法来对付它了，单纯的水元素召唤还是不够的，20英尺长的流沙对阻挡暗黑骑士来说，根本没多少作用。
在玩家手中，这也是一个相当好用的兵种，基本上有1个就可以去打二级野兵了。在大军团作战中，缺乏先攻能力是暗黑骑士的一大弱点，若挨一下反击就有损失，再生的作用就无从谈起。此时，恐惧结界、先攻或是吸血鬼接触魔法，会给它们以极大帮助。


『战风』新增生物

    在第二个资料片『战风』中又新增了三种实力强大的新兵种，凶牙兽和投石车可以在相应的野外招募地招募（但产量为这里列出数据的一半），巨龙则无法招募。
    投石车所属阵营为生命，凶牙兽所属阵营为力量，巨龙所属阵营为混乱。

投石车（Catapult）
20-34 | 14 | 28 | N/A
200 | 28 | 28 | 12
0 | 17 | 12 | 800
3 | 3000金+6木材+2矿石
 Mechanical Ranged
Siege Capable Greek Fire
弩车的极度强化版，射击范围略大于地狱火，移动力低的部队与之交战，有一种送死的感觉。机械特性使得精神控制类法术对其不起作用，但可以利用其速度慢、攻击实力其实并不太高的弱点，用快速精锐部队突击取胜。防御力高的英雄单人上阵，用传送魔法与之缠斗，也是比较理想的打法（但若投石车与其余部队混编，此种战术使用时便需慎重，更好的选择是使用失明魔法）。
由玩家控制的投石车，是相当好用的，毕竟玩家与电脑的操纵、走位水准相比，绝对是高出几个档次的。

凶牙兽（Frenzied Gnasher）
40-55 | 40 | N/A | N/A
300 | 40 | 40 | N/A
4 | 21 | 22 | 800
2 | 4000金+2水晶
 Immune to Magic Berserk
和黑龙一样免疫所有魔法的凶牙兽，有着强于多数四级兵的攻击实力，以及更胜一筹的防御实力，无疑是强悍的。但与投石车相反，凶牙兽在作为敌人时相当难对付，交给玩家时却又难以顺心指挥，只因为它和狂暴者一样具有狂暴的特性，只能用堵4号位的方法尽量约束其行动。打打二级野兵还可以，不攒到5头的话，连三级兵都不大敢去碰——太容易损失了。反正其实用性肯定低于表面数值。

巨龙（MegaDragon）
50-100 | 50 | N/A | N/A
1000 | 50 | 50 | N/A
7 | 30 | 45 | 1500
N/A | N/A
 Magic Resistance Arc Breath Attack
比黑龙更胜一筹的攻击防御力，还有远胜于黑龙的生命值，巨龙的强度实际上已经把黑龙甩开了不少距离，1500的经验值是有点委屈它了。50%魔法抗性既使其对诅咒类魔法有相当程度的抵抗力，又使得它可以享受黑龙所不能触及的特权——各种祝福类魔法的强化作用。弧形焰息技能，再搭配以合适的祝福魔法，很容易产生两倍、三倍甚至更多倍黑龙的效果。所以巨龙无法招募（只能靠事件获得）就完全可以理解了，否则实在太破坏平衡。
在对付野外巨龙时，多队兵一拥而上是不够明智的选择，很容易被弧形焰息的巨大攻击范围笼罩进去。利用其不会飞行的特性，巧妙走位，引诱其喷火误伤自家人，是可以考虑的一种战术。


生物特技总览

三头攻击（3-Headed Attack）
相关生物：地狱犬
    可以同时攻击部队正面以及侧前方所有相邻的敌人

老化（Aging）
相关生物：幽灵
    攻击时能够老化敌人，被老化的敌人攻击力下降25%，近战和远程防御下降20%，速度和战场移动力减半。老化的减速效果能够与其余减速类效果（迟缓，疲劳，粘结剂或蛛丝箭的束缚效果）叠加，使部队的速度和战场移动力降低到原先的1/4。后面那些减速类效果相互之间是不能叠加的。

弧形焰息（Arc Breath Attack）
相关生物：巨龙
    气息攻击的加强版本，相当于气息攻击和三头攻击两个技能的结合体，可以影响一个很大的扇形区域

范围攻击（Area Attack）
相关生物：独眼巨人、恐甲兽
    用巨石进行远程攻击，同时伤害半径5英尺（包括中心在内，直径为11英尺）近似圆形范围内的多个目标，部队所占区域只要有一部分进入此范围，便会受攻击所波及，不分敌我。射击不会受到反击
    如果某攻击对象原本不在射击视线内（鼠标直接指上去是近战的剑图标，而不是远程的弓箭图标，或者是躲在城墙内部不能直接射击的目标），只是被范围攻击波及到，那么对此对象造成的远程伤害为完全伤害，不受距离和障碍物等因素制约
    与其余类型的远程攻击不同，范围攻击的最后一箭是不能忽略距离、障碍等伤害衰减因素的。

狂暴（Berserk）
相关生物：狂暴者、凶牙兽
    战斗中不受操纵，会自己行动，不会等待，并且不受恐惧类效果（包括骨龙的“引起恐惧”技能、梦魇兽和黑骑的恐惧魔法，还有恐惧结界魔法以及相关宝物）影响

缠身（Binding）
相关生物：螳螂
    定住所攻击的最后一个敌人，被定身的敌人不能移动，攻击力减半。此特技对于具有“虚无”能力的部队（幽灵和风元素）无效

失明（Blinding）
相关生物：独角兽
    攻击时有30%几率让敌人失明三回合

格挡（Block）
相关生物：牛头怪
    能够有30%几率格挡敌人的物理攻击，如果格挡成功将不会受到任何伤害

嗜血（Bloodlust）
相关生物：食人魔法师
    可以在战斗中使用嗜血魔法

海上战斗奖励（Bonuses at Sea）
相关生物：海盗
    在海上战斗中获得额外的战斗力，攻击防御加半，速度和战场移动力+2

气息攻击（Breath Attack）
相关生物：黑龙、凤凰
    沿着攻击方向，9英尺×3英尺范围内的部队都会受到气息攻击的伤害。直接攻击目标遭受的攻击类型为火属性攻击，如有火抵抗技能所受伤害就会减半；在直接攻击目标身后，被气息波及到的部队，所受伤害类似于火魔法，如果有火抵抗技能则可完全不受伤。抗魔和免疫魔法的能力对气息攻击的伤害完全没有影响，能起作用的只是火抵抗技能。

混乱抵御（Chaos Ward）
相关生物：泰坦
    对混乱系魔法有50%抗性，遭混乱系生物攻击时近战防御力和远程防御力提高50%（也就是只受2/3伤害）

冲锋（Charge）
相关生物：精英骑士、暗黑骑士
    移动攻击获得额外杀伤力。
    杀伤加成比例的计算公式为：(移动距离-5.4)×20%÷7。移动距离的单位为英尺。若计算出的结果为负数，则加成比例取0。也就是说，当移动距离未达到6英尺的时候，冲锋技能是没有效果的。

冰属性攻击（Cold Attack）
相关生物：冰魔、水元素
    生物的攻击属于冰系攻击，如果对方有冰抵抗能力则所受伤害减半。

冰抵抗（Cold Resistance）
相关生物：冰魔、水元素
    生物对冰系魔法免疫，在遭受冰属性物理攻击时所受伤害减半。

诅咒（Curse）
相关生物：木乃伊
    攻击时诅咒敌人，使敌人伤害力最小化。

死亡抵御（Death Ward）
相关生物：十字军、僧侣
    对死亡系魔法有50%抗性，遭死亡系生物攻击时近战防御力和远程防御力提高50%

吞食（Devouring）
相关生物：海怪
    攻击时一定几率直接吞食几个敌人，不受抗魔能力和魔法免疫力制约，被吞食的敌人不能复活
    海怪的吞食规律与三代的蛮牛一样：单个海怪有10%的概率吞食1个敌人；要吞食n个敌人，海怪数量至少要达到(n-1)×10+1个

元素（Elemental）
相关生物：风元素、火元素、水元素、土元素、石像鬼
    元素生物属于无生命生物，在魔法免疫力上与亡灵和机械相似，但是又有所区别。具体免疫的魔法/技能是：绝大部分精神类魔法/技能（精准、群体精准、嗜血和血暴除外），吸血（可以吸人但不会被吸），复活，治疗类魔法，毒害，瘟疫，石化，老化，牺牲，操纵尸体，驱役亡灵。另外，元素生物虽然不吃振奋与悲泣魔法，但却会受士气影响。

引起恐惧（Fear）
相关生物：骨龙
    攻击敌人部队时会使敌人恐惧，使其向后退出两格。如果是主动攻击造成恐惧，敌人将不能反击（即使敌人有先攻能力）。
    恐惧对无生命的部队（包括机械、元素、亡灵、操纵的尸体和幻象副本）和狂暴者无效。具有“死亡抵御”能力的部队，在遭受攻击时可以反击（如果此部队有先攻能力，则反击在攻击之前进行），但反击完成后也会被震退。除此之外，不具备100%抗魔能力的部队，都不能够抵抗恐惧。

火属性攻击（Fire Attack）
相关生物：火怪、火元素
    生物的攻击属于火系攻击，如果对方有火抵抗能力则所受伤害减半。

火抵抗（Fire Resistance）
相关生物：火怪、火元素、凤凰
    生物对火系魔法免疫，在遭受火属性物理攻击时所受伤害减半。

火盾（Fire Shield）
相关生物：火怪
    遭受近身攻击时，自动将所受伤害的25%反弹给攻击者。除了黑龙和具有火抵抗能力的生物/英雄以外，任何部队都无法抵抗火盾的反弹，包括宗师抗魔的英雄。

抢先攻击（First Strike）
相关生物：精英骑士、傀儡龙、游牧人、蟑螂、白虎
    在近战中，主动攻击或反击时可以抢在敌人之前出手。两个拥有先攻能力的部队相遇，技能效果将抵消（除非像傀儡龙那样，同时还拥有“否定先攻”的技能作辅助）。
    没有先攻能力的部队，如果在战斗中不移动、直接站在原地主动攻击具有先攻能力的敌人，则此时敌人的先攻能力也将失效。

飞行（Flying）
相关生物：风元素、天使、邪眼魔、黑龙、骨龙、火怪、仙女龙、幽灵、灯神、石像鬼、狮鹫、鹰身女妖、恶魔之子、螳螂、凤凰、妖精、雷鸟、吸血鬼
    赋予生物飞行的能力，在战场上可以飞越城墙等障碍，也可以飞越部队。

幸运（Fortune）
相关生物：从林妖精
    可以在战斗中使用幸运魔法

冷冻攻击（Freezing Attack）
相关生物：冰魔
    攻击时有30%几率冻住敌人两回合

巨人杀手（Giantslayer）
相关生物：半身人
    在攻击4级生物的时候可以造成双倍伤害

希腊之火（Greek Fire）
相关生物：投石车
    与范围攻击类似，射击多个目标并且不受反击，但影响范围更大，影响区域半径为8英尺（直径17英尺）。射击的中心点为火属性攻击，对具备火抵抗能力的部队只能造成一半伤害；周围波及范围造成的伤害类似于火魔法，对于具备火抵抗能力的部队毫无伤害力

催眠（Hypnotize）
相关生物：美人鱼
    攻击时一定几率催眠敌人，让他们受控制一回合。不受抗魔能力制约

免疫魔法（Immune to Magic）
相关生物：黑龙、凶牙兽
    不受所有魔法影响，不论是有益的还是有害的。

免疫视觉攻击（Immune to Visual Attacks）
相关生物：穴居人
    因为穴居人没有眼睛，所以一切依靠视觉才能发挥效应的攻击或魔法都不能影响穴居人，例如失明魔法、美杜莎的石化凝视

虚无（Insubstantial）
相关生物：风元素、幽灵
    生物无实际形体，因此物理攻击难以杀伤他们，于是近战和远程防御力加倍（直接反映在兵种数据中）

吸血（Life Draining）
相关生物：吸血鬼
    将攻击所造成伤害的一半吸取到自己身上。吸血对机械、元素和亡灵生物无效，并且在遭遇具有“死亡抵御”能力的敌人时，效果减半。宝物、魔法或职业附加的吸血能力也要受到同样制约。

生命抵御（Life Ward）
相关生物：恶魔
    对生命系魔法有50%抗性，遭生命系生物攻击时近战防御力和远程防御力提高50%

闪电攻击（Lightning Attack）
相关生物：雷鸟
    攻击时附带闪电伤害，伤害值是雷鸟数量×30

长程射击（Long Range）
相关生物：弩手、弩车
    远程攻击时伤害不会因距离远而衰减

长武器攻击（Long Weapon）
相关生物：枪兵
    使枪兵可以在6英尺外攻击对手，从而不会受到对方的反击（除非对方部队也具有长武器特性）。

魔镜（Magic Mirror）
相关生物：仙女龙、邪魔女
    在遭受敌人魔法攻击时，自动将1/2的伤害反射给施法的敌人，本身所受的魔法伤害不会因此减少；在承受诅咒类魔法时，自动使施法者获得同样的受诅咒状态，不能反弹的诅咒类魔法只有催眠、和平之歌和驱逐这少数几种。如果部队直接被魔法消灭，反弹将不会发生。

抗魔（Magic Resistance）
相关生物：矮人、金人、土元素、大耳怪骑士、巨龙
    受魔法攻击时降低所受伤害，另外有一定几率躲避诅咒类魔法。效果看具体生物

吸取魔力（Mana Leech）
相关生物：恶魔之子
    吸取敌人2点魔法值，转移给我方魔法值消耗比例最大的部队（英雄或施法生物）。所吸取的魔法值，来自于在恶魔之子视线内、并离其最近的敌方部队。吸取成功率受相关魔法抗性制约，宗师抗魔或是附加了反魔法的部队不被算在吸取对象之列。死亡城堡的奇迹建筑可让吸取效果提高到3点

机械（Mechanical）
相关生物：金人、傀儡龙、弩车、投石车
    机械兵种属于无生命兵种，在魔法免疫力上与亡灵和元素相似，但是又有所区别。具体免疫的魔法/技能是：精神类魔法/技能，吸血（可以吸人但不会被吸），复活，治疗类魔法，毒害，瘟疫，石化，老化，牺牲，操纵尸体，驱役亡灵，蜂群，疲劳。

振奋（Mirth）
相关生物：半羊人
    允许在战斗中使用振奋魔法，提高部队士气

多重攻击（Multiple Attack）
相关生物：九头蛇
    攻击身边的所有敌人部队。

否定抢先攻击（Negate First Strike）
相关生物：傀儡龙、枪兵、大耳怪骑士
    近战中（攻击或反击时）忽略对方的抢先攻击能力

忽略障碍物（No Obstacle Penalty）
相关生物：弩车
    远程攻击造成的伤害不受城墙等障碍物的影响。不能伤害躲在城堡内部的敌人，但射击紧贴着城墙的敌人时，伤害不会减半。

不受反击（No Retaliation）
相关生物：地狱犬、鹰身女妖、九头蛇、蛇妖、妖精、吸血鬼
    攻击时敌人不能反击。

近战伤害不减（Normal Melee）
相关生物：半人马、美杜莎、半兽人、泰坦、恐甲兽
    少数远程兵种拥有的技能，近身攻击时伤害不减半（与远程攻击相比）

毒击（Posion）
相关生物：食尸怪
    攻击时使敌人中毒，每回合自动损失一定生命值。除非受攻击的部队拥有100%的魔法抗性，否则毒的威力将恒定为食尸怪第一次攻击伤害的1/4。

随机负面魔法（Random Harmful Spells）
相关生物：邪眼魔
    攻击时附带一个诅咒类魔法，从下述魔法中随机选取一个：诅咒、废除、瓦解射线、怯懦、疲劳、厄运、虚弱、悲泣和遗忘。

远程攻击（Ranged）
相关生物：弩车、邪眼魔、半人马、弩手、独眼巨人、精灵、半身人、美杜莎、僧侣、半兽人、泰坦、食尸怪、火元素、毒蜂草、恐甲兽、投石车
    拥有此技能的生物才能进行远程攻击。如果没有“近战伤害不减”技能的辅助，那么在近身攻击中杀伤会减半（也就是近战攻击力为远程攻击力的一半）。
    射程如果超过40英尺，射击威力将减半（长程射击与短程射击除外，它们有各自的规律）。如果射击路线上有灌木树丛、烟雾之类的障碍物阻隔，射击威力也将减半。射击在城堡内部紧贴着城墙的敌人时，伤害也将减半（早期版本中有Bug，伤害不减半，2.0及更高版本中已经修正了这个错误）。
    除范围攻击外，其余类型的远程部队，在弹药耗完之前的最后一箭，威力都不会受到射击距离和障碍物的影响。

抢先射击（Ranged First Strike）
相关生物：精灵
    主动射击时可以抢在敌人之前出手。两个具有抢先射击能力的部队相遇，技能效果将抵消。

重生（Rebirth）
相关生物：凤凰
    可以对自身使用，消耗12点魔法值，复活本队死亡的凤凰，复活生命值为本队凤凰总数×55（基本上相当于其生命总值的20%）；如果还没有来得及使用就被完全击倒，那么会自动复活20%，魔法值耗完。与天使复活不同，这里的20%是按原始数量计算的，而天使的复活按残存数量计算

再生（Regeneration）
相关生物：洞穴巨人、暗黑骑士
    每回合自动恢复50点生命值，但不能复活阵亡部分

复活（Resurrection）
相关生物：天使
    可复活本方部队（生物或英雄），消耗20点魔法值，复活生命值是天使残存数量×92（基本相当于其生命值的40%）

连射两箭（Shoot Twice）
相关生物：精灵、恐甲兽
    主动射击时连射两箭

短程射击（Short Range）
相关生物：半人马、半兽人
    因为这两种部队所用的武器限制，所以威力难以及远，射击远处敌人时会有很强的伤害衰减。射程超过20英尺伤害减半，如果超过40英尺伤害会减为原来的1/4。

攻城（Siege Capable）
相关生物：投石车
    射击伤害不受距离和障碍物影响。此技能实际上就是长程射击和忽略障碍物两个技能的合体，因为生物特技总共只有四个空位，为了给投石车的其余技能腾出位置，所以才把上述两个技能合并成攻城技能。

骨骼（Skeletal）
相关生物：骷髅兵、骨龙
    生物由骨骼组成，因此有一定几率躲避箭枝，所以远程防御力加倍（直接反映在兵种数据中）

施法（Spellcaster）
相关生物：仙女龙、灯神、法师、水元素、邪魔女
    生物拥有自己的魔法书，可以从里面选取魔法来使用。具体可使用的魔法、以及魔法威力，由生物自身决定

潜行（Stealth）
相关生物：盗贼
    相当于英雄的高级潜行技能。在冒险地图上能够不被1-2级生物和只掌握了基础侦察术的敌英雄发现，但在靠近2级生物或有基础侦察术的敌英雄时，隐身会失效。

石化凝视（Stone Gaze）
相关生物：美杜莎
    一定几率石化敌人的一部分，被石化的那部分相当于被直接杀死。
    石化的详细规律请看黑孔雀的研究。

护体石肤（Stoneskin）
相关生物：石像鬼、大耳怪骑士
    在战斗中始终有护体石肤护身，近战和远程防御力提高25%。不能再对其使用护体石肤魔法

强力（Strength）
相关生物：巨兽
    将生物的战斗杀伤力提高50%，已经直接反映在生物数据中。就是说可以这样理解：巨兽原先的杀伤力是37-53，与其他周产量2的四级生物差不多，有强力技能后杀伤才达到我们所看到的55-80。

攻击后返回（Strike and Return）
相关生物：鹰身女妖
    攻击敌人后自动飞回原位

晕击（Stun）
相关生物：侍从
    攻击时一定几率击晕敌人，让敌人一个回合无法行动（包括反击）。
    出现几率的计算公式为：(攻击造成的伤害÷攻击目标的总生命值)×100%－5%。也就是说，当伤害与对象总生命值比例低于5%时，击晕的现象不可能出现。

召唤冰魔（Summon Demons）
相关生物：恶魔
    使恶魔能够在战斗中召唤冰魔，消耗8点魔法值，召唤的冰魔数量等于恶魔自身数量。死亡城堡的奇迹建筑可将召唤数量加半

纳税（TaxPayer）
相关生物：农民
    每个农民每天给王国交纳1金

传送（Teleport）
相关生物：恶魔、邪魔女
    部队在战斗中以自我传送的方式移动。这种移动方式与飞行相似，但更高级。因为飞行部队在攻城的时候，想进入城堡内部，必须先飞到城墙边，下一回合才能飞进去，而且只能飞进去一格。而传送移动不受任何限制。

恐惧（Terror）
相关生物：梦魇兽、暗黑骑士
    允许在战斗中施展恐怖魔法（消耗6点魔法值），使单队敌人两个回合不能行动

健壮（Toughness）
相关生物：僵尸
    生命值加倍，已经直接反映在兵种数据中

连击两下（Two Attacks）
相关生物：狂暴者、狼、十字军
    近战中主动攻击时连击2下。若敌人能反击，在攻击同时遭到敌人反击（没有蛇击、先攻等魔法附加状态情况下），然后再击第二下。

亡灵（Undead）
相关生物：骨龙、幽灵、木乃伊、骷髅、僵尸、吸血鬼、暗黑骑士
    亡灵生物属于无生命生物，在魔法免疫力上与机械和元素相似，但是又有所区别。具体免疫的魔法/技能是：精神类魔法/技能，吸血（可以吸人但不会被吸），复活，治疗类魔法，毒害，瘟疫，石化，老化，蜂群，疲劳，失明，祝福。

无限反击（Unlimited Retaliation）
相关生物：狮鹫
    可以无限反击敌人的近身攻击，除非对方有不受反击技能

无限弹药（Unlimited Shots）
相关生物：美杜莎
    美杜莎的弹药数没有限制

虚弱（Weakness）
相关生物：毒蜂草
    攻击时能使敌人陷入虚弱状态。与虚弱魔法不同，毒蜂草的虚弱不能影响无生命部队（机械、亡灵和元素）


生物经验值统计

    在英雄无敌4里，每个生物都有一项经验值属性，这个数值一方面是表示英雄击败生物后所能获得的经验值；另一方面可能也是表明了生物的实力排名。有些英雄技能的运算也是看生物的经验值，而不是生命值，例如招魂、外交、媚惑这几种技能；召唤魔法一般也是按照经验值计算的。

生物经验值排名
名次 | 生物 | 经验值
1 | 黑龙 | 1233
2 | 巨兽 | 630
2 | 傀儡龙 | 630
4 | 海怪 | 624
5 | 骨龙 | 621
6 | 天使 | 620
7 | 九头蛇 | 617
8 | 泰坦 | 616
9 | 恶魔 | 614
9 | 螳螂 | 614
11 | 仙女龙 | 612
12 | 凤凰 | 609
13 | 雷鸟 | 406
14 | 精英骑士 | 320
15 | 吸血鬼 | 205
16 | 独眼巨人 | 203
17 | 食尸怪 | 201
18 | 火怪 | 161
19 | 蛇妖 | 157
19 | 冰魔 | 157
21 | 狮鹫 | 154
22 | 梦魇兽 | 148
23 | 十字军 | 124

名次 | 生物 | 经验值
24 | 独角兽 | 120
25 | 僧侣 | 107
26 | 灯神 | 105
26 | 毒蜂草 | 105
28 | 食人魔法师 | 101
29 | 土元素 | 77
30 | 火元素 | 75
31 | 风元素 | 74
32 | 水元素 | 73
33 | 金人 | 56
34 | 洞穴巨人 | 54
35 | 牛头怪 | 53
35 | 白虎 | 53
37 | 美杜莎 | 52
37 | 游牧人 | 52
39 | 邪眼魔 | 51
40 | 弩车 | 44
40 | 地狱犬 | 44
42 | 精灵 | 43
43 | 半羊人 | 39
43 | 鹰身女妖 | 39
43 | 木乃伊 | 39
43 | 美人鱼 | 39

名次 | 生物 | 经验值
47 | 法师 | 38
47 | 石像鬼 | 38
49 | 枪兵 | 35
50 | 幽灵 | 33
51 | 半人马 | 18
52 | 狼 | 11
53 | 半兽人 | 10
53 | 僵尸 | 10
55 | 弩手 | 9
56 | 狂暴者 | 8
56 | 矮人 | 8
56 | 穴居人 | 8
59 | 侍从 | 7
59 | 半身人 | 7
59 | 妖精 | 7
59 | 丛林妖精 | 7
59 | 海盗 | 7
64 | 盗贼 | 6
64 | 骷髅兵 | 6
66 | 恶魔之子 | 5
67 | 农民 | 4

周经验总值排名

    同一个等级的生物，经验值的差距有时会很大。不过如果考虑到生物产量的因素，那么同级生物的综合实力基本还是均衡的。从下面的表中可以看出，四级生物周经验总值基本上是1200出头，三级生物是600出头，二级生物300出头，一级生物150左右。这里面例外的是风火水土四种元素，周经验总值介于三级与二级之间。

四级生物

名次 | 生物 | 经验值 | 产量 | 周经验 总值
1 | 精英骑士 | 320 | 4 | 1280
2 | 巨兽 | 630 | 2 | 1260
2 | 傀儡龙 | 630 | 2 | 1260
- | 海怪 | 624 | - | ---
5 | 骨龙 | 621 | 2 | 1242
6 | 天使 | 620 | 2 | 1240
7 | 九头蛇 | 617 | 2 | 1234
8 | 黑龙 | 1233 | 1 | 1233
9 | 泰坦 | 616 | 2 | 1232
10 | 恶魔 | 614 | 2 | 1228
10 | 螳螂 | 614 | 2 | 1228
12 | 仙女龙 | 612 | 2 | 1224
13 | 凤凰 | 609 | 2 | 1218
13 | 雷鸟 | 406 | 3 | 1218

三级生物

名次 | 生物 | 经验值 | 产量 | 周经验 总值
15 | 火怪 | 161 | 4 | 644
16 | 僧侣 | 107 | 6 | 642
17 | 灯神 | 105 | 6 | 630
17 | 毒蜂草 | 105 | 6 | 630
19 | 蛇妖 | 157 | 4 | 628
19 | 冰魔 | 157 | 4 | 628
21 | 十字军 | 124 | 5 | 620
22 | 狮鹫 | 154 | 4 | 616
23 | 吸血鬼 | 205 | 3 | 615
24 | 独眼巨人 | 203 | 3 | 609
25 | 食人魔 法师 | 101 | 6 | 606
26 | 食尸怪 | 201 | 3 | 603
27 | 独角兽 | 120 | 5 | 600
28 | 梦魇兽 | 148 | 4 | 592
29 | 土元素 | 77 | 6 | 462
30 | 火元素 | 75 | 6 | 450
31 | 风元素 | 74 | 6 | 444
32 | 水元素 | 73 | 6 | 438

二级生物

名次 | 生物 | 经验值 | 产量 | 周经验 总值
33 | 金人 | 56 | 6 | 336
34 | 洞穴巨人 | 54 | 6 | 324
35 | 牛头怪 | 53 | 6 | 318
35 | 白虎 | 53 | 6 | 318
37 | 枪兵 | 35 | 9 | 315
38 | 美杜莎 | 52 | 6 | 312
38 | 游牧人 | 52 | 6 | 312
38 | 半羊人 | 39 | 8 | 312
38 | 鹰身女妖 | 39 | 8 | 312
38 | 木乃伊 | 39 | 8 | 312
-- | 美人鱼 | 39 | - | ---
44 | 弩车 | 44 | 7 | 308
44 | 地狱犬 | 44 | 7 | 308
46 | 邪眼魔 | 51 | 6 | 306
47 | 法师 | 38 | 8 | 304
47 | 石像鬼 | 38 | 8 | 304
49 | 精灵 | 43 | 7 | 301
50 | 幽灵 | 33 | 9 | 297

一级生物

名次 | 生物 | 经验值 | 产量 | 周经验 总值
51 | 海盗 | 7 | 24 | 168
52 | 狼 | 11 | 15 | 165
53 | 半人马 | 18 | 9 | 162
54 | 半身人 | 7 | 23 | 161
54 | 妖精 | 7 | 23 | 161
56 | 半兽人 | 10 | 16 | 160
57 | 盗贼 | 6 | 26 | 156
58 | 丛林妖精 | 7 | 22 | 154
59 | 狂暴者 | 8 | 19 | 152
59 | 穴居人 | 8 | 19 | 152
61 | 僵尸 | 10 | 15 | 150
61 | 骷髅兵 | 6 | 25 | 150
63 | 侍从 | 7 | 21 | 147
64 | 矮人 | 8 | 18 | 144
64 | 弩手 | 9 | 16 | 144
64 | 农民 | 4 | 36 | 144
67 | 恶魔之子 | 5 | 28 | 140


英雄技能

    在英雄无敌4里面，英雄的能力（属性）可以分为状态（Stat）和技能（Skill）两大类，而技能又可以分为主要技能（Primary Skill，共9项）和二级技能（Second Skill，共27项）。主要技能与二级技能有着主从关系。每一项主要技能对应着3项二级技能，英雄只有掌握了特定主要技能之后，才能开始学习相应的二级技能。因此，可以根据主要技能将36项技能分为9个派系：

    战术系：与英雄的领导能力有关，即影响英雄率领生物的效果，对英雄本人和部队里其他英雄没有任何影响。

    战斗系：强化英雄本身的战斗能力，对所率领的部队没有任何影响。

    侦察系：有利于在地图上的行动。

    贵族系：与生物产量以及金钱等资源收入有关。

    生命系：生命魔法以及相关技能。

    死亡系：死亡魔法以及相关技能。

    守序系：守序魔法以及相关技能。

    混乱系：混乱魔法以及相关技能。

    自然系：自然魔法以及相关技能。

    每个技能都分为五级，从低到高依次是：基础（Basic）、高级（Advenced）、专家（Expert）、大师（Master）和宗师（Grand Master）。


战术系技能

战术（Tactics）
主要技能
基本作用：提高生物的速度和战场移动力。
    基础：部队速度+1，战场移动力+1
    高级：部队速度+2，战场移动力+1.5
    专家：部队速度+3，战场移动力+2。学习前提：基础攻击，基础防御
    大师：部队速度+4，战场移动力+2.5。学习前提：高级攻击，高级防御
    宗师：部队速度+5，战场移动力+3。学习前提：专家攻击，专家防御

攻击（Offense）
二级技能
基本作用：提高生物的近战和远程攻击力。
    基础：部队近战攻击力和远程攻击力+10%。学习前提：基础战术
    高级：部队近战攻击力和远程攻击力+20%。
    专家：部队近战攻击力和远程攻击力+30%。学习前提：高级战术
    大师：部队近战攻击力和远程攻击力+40%。
    宗师：部队近战攻击力和远程攻击力+50%。学习前提：专家战术

防御（Defense）
二级技能
基本作用：提高生物的近战和远程防御力。
    基础：部队近战防御力和远程防御力+10%。学习前提：基础战术
    高级：部队近战防御力和远程防御力+20%。
    专家：部队近战防御力和远程防御力+30%。学习前提：高级战术
    大师：部队近战防御力和远程防御力+40%。
    宗师：部队近战防御力和远程防御力+50%。学习前提：专家战术

领导（Leadership）
二级技能
基本作用：提高生物的士气值和幸运值。
    基础：部队士气+1，幸运+1。学习前提：基础战术
    高级：部队士气+2，幸运+2。
    专家：部队士气+3，幸运+3。学习前提：高级战术
    大师：部队士气+4，幸运+4。
    宗师：部队士气+5，幸运+5。学习前提：专家战术


战斗系技能

战斗（Combat）
主要技能
基本作用：提高英雄的近战和远程防御力。
    基础：英雄近战防御力和远程防御力提高到15（无战斗技能的英雄防御力为10）
    高级：英雄近战防御力和远程防御力提高到20
    专家：英雄近战防御力和远程防御力提高到30
    大师：英雄近战防御力和远程防御力提高到40
    宗师：英雄近战防御力和远程防御力提高到60

肉搏（Melee）
二级技能
基本作用：提高英雄的近战攻击力，并在攻击时忽略敌人的一部分近战防御力。宗师级肉搏技能还能使英雄在主动攻击时连击两下。
    基础：英雄近战攻击力提高到15（无肉搏技能的英雄近战攻击力为10）。攻击时忽略敌人三分之一的近战防御力。忽略防御力这项特性在攻击敌人英雄或是防御力低于10的生物时不起作用，对于防御力高于10的生物，最多将其忽略到10（以下同，包括箭术技能）。学习前提：基础战斗
    高级：英雄近战攻击力提高到20，攻击时忽略敌人一半近战防御力。
    专家：英雄近战攻击力提高到30，攻击时忽略敌人三分之二近战防御力，攻击附带“抢先攻击”属性，即主动攻击和反击时可以抢在对方之前出手。学习前提：高级战斗
    大师：英雄近战攻击力提高到40，攻击时忽略敌人四分之三近战防御力。
    宗师：主动攻击时连击两下，带抢先攻击属性，其他属性同大师级。学习前提：专家战斗

    这里需要注意一点：忽略特性只能将敌幽灵/风元素的近战防御力忽略到20，而不是10，就是先将原始防御力15/16忽略到10，然后再加上“虚无”技能的效果，成为20。

箭术（Archery）
二级技能
基本作用：提高英雄的远程攻击力，并在射击时忽略敌人的一部分远程防御力。等级提高后，英雄的射击伤害不会受到距离、障碍等因素影响，宗师级箭术技能还能使英雄在主动射击时连射两箭。
    基础：英雄远程攻击力提高到10（无箭术技能的英雄如果没有装备相应宝物，将不能进行远程攻击，隐藏的攻击力为7）。学习前提：基础战斗
    高级：英雄远程攻击力提高到15，射击时忽略敌人三分之一的远程防御力。射击伤害不受城墙等障碍物影响。
    专家：英雄远程攻击力提高到20，射击时忽略敌人一半远程防御力，射击伤害不受障碍物和距离的影响。学习前提：高级战斗
    大师：英雄远程攻击力提高到30，射击时忽略敌人一半远程防御力，射击伤害不受障碍物和距离的影响。获得抢先射击属性。
    宗师：主动射击时连射两箭，其他属性同大师级。学习前提：专家战斗

    这里需要注意一点：忽略特性只能将敌骷髅/幽灵/风元素的远程防御力忽略到20，而不是12/15/16，就是先将原始防御力12/15/16忽略到10，然后再加上“骨骼”和“虚无”技能的效果，成为20。

抗魔（Magic Resistance）
二级技能
基本作用：提高英雄的魔法抗性。四代的魔法抗性比较特殊，以基础抗魔为例，30%的魔法抗性，意思是英雄有30%的几率躲避敌人的诅咒类魔法影响，不能够躲避杀伤类魔法，但是所受伤害减少30%。
    基础：英雄获得30%的魔法抗性。学习前提：基础战斗
    高级：英雄获得50%的魔法抗性。
    专家：英雄获得70%的魔法抗性。学习前提：高级战斗
    大师：英雄获得80%的魔法抗性。
    宗师：英雄魔法抗性达到100%，比黑龙还优秀的能力，因为黑龙抵抗一切魔法，包括本方的祝福加强类魔法，而英雄还可以享受正面魔法的帮助。学习前提：专家战斗


侦察系技能

侦察（Scouting）
主要技能
基本作用：加大英雄视野范围，可查看敌人详细状态，并且可以发现隐身的敌人。
    基础：英雄视野范围+1，查看地图上冒险目标信息，比如法师匣里的宝物、技能屋教授的技能以及废矿守兵种类和粗略数量，可以发现只掌握了基础潜行技能的敌英雄
    高级：英雄视野范围+2，查看敌军确切数量，可发现只掌握了高级潜行技能的敌英雄
    专家：英雄视野范围+3，提供战果预测，可发现只掌握了专家潜行技能的敌英雄。学习前提：基础探路
    大师：英雄视野范围+4，查看敌方英雄最高5项技能及其他所有属性、敌方兵种属性（不能进入军队界面），可发现只掌握了大师潜行技能的敌英雄。学习前提：高级探路
    宗师：英雄视野范围+5，可进入敌人军队与城镇界面查看所有详细情况，可以发现掌握了宗师潜行技能的敌英雄。学习前提：大师探路

探路（Pathfinding）
二级技能
基本作用：消除部队在不良地形上移动时所受的额外移动力损耗。当探路技能达到大师和宗师级的时候，还可以提高部队的地面移动力。
    基础：消除不良地形对移动的25%损耗。学习前提：基础侦察
    高级：消除不良地形对移动的50%损耗。
    专家：完全消除不良地形对移动的影响。学习前提：高级侦察
    大师：完全消除不良地形对移动的影响，部队中所有单位（英雄及生物）地图移动力+25%。
    宗师：完全消除不良地形对移动的影响，部队中所有单位（英雄及生物）地图移动力+50%。学习前提：专家侦察

航海（Seamanship）
二级技能
基本作用：提高部队在海上的移动力，并且在海上战斗中提高部队中生物的攻击、防御、速度和战场移动力。
    基础：海上移动力+25%，海上战斗中英雄获得基础战术、攻击和防御。学习前提：基础侦察
    高级：海上移动力+50%，海上战斗中英雄获得高级战术、攻击和防御。
    专家：海上移动力+100%，海上战斗中英雄获得专家战术、攻击和防御。学习前提：高级侦察
    大师：海上移动力+150%，海上战斗中英雄获得大师战术、攻击和防御。
    宗师：海上移动力+200%，海上战斗中英雄获得宗师战术、攻击和防御。学习前提：专家侦察

潜行（Stealth）
二级技能
基本作用：能够使英雄本人在地图上不会被生物或敌人英雄发现，效果看等级。掌握宗师级潜行技能的英雄，可以大摇大摆的从四级生物身边走过，不但不会被攻击，还能够得到经验值（战斗所获经验值的1/4）。
    基础：能使英雄不被1级生物和没有侦察术的敌英雄发现，但在靠近时隐形会失效。学习前提：基础侦察
    高级：能使英雄不被1-2级生物和只掌握了基础侦察术的敌英雄发现，但在靠近2级生物或有基础侦察术的敌英雄时，隐形会失效。学习前提：高级侦察
    专家：能使英雄不被1-3级生物和只掌握了高级侦察术的敌英雄发现，但在靠近3级生物或有高级侦察术的敌英雄时，隐形会失效。学习前提：专家侦察
    大师：能使英雄不被生物和只掌握了专家侦察术的敌英雄发现，但在靠近4级生物或有专家侦察术的敌英雄时，隐形会失效。学习前提：大师侦察
    宗师：能使英雄不被生物和只掌握了大师侦察术的敌英雄发现，但在靠近有大师侦察术的敌英雄时，隐形会失效。学习前提：宗师侦察

    潜行技能的效果在2.0及更高版本的游戏中被削弱了。原先偷经验值的比例与游戏难度无关，恒为对象部队经验总值的1/4。考虑到在最高难度游戏中战斗所获经验值仅为对象部队经验总值的1/3，那么潜行所偷的经验值便是最高难度下战斗所获经验值的3/4。而在偷盗经验值比例与难度挂钩后，盗贼英雄的升级难度就比从前高了许多，其作用也被大大限制了。


贵族系技能

贵族（Nobility）
主要技能
基本作用：提高英雄所管理城堡的生物产量。指定英雄所管理的城堡后，英雄无论在地图上什么位置都可以起作用。有贵族技能的英雄访问城堡时，可以指定其为该城堡的管理者（城堡画面内按L键，或是在城堡菜单里选择Choose Governor指令）
    基础：英雄所管理城堡生物产量+10%
    高级：英雄所管理城堡生物产量+20%
    专家：英雄所管理城堡生物产量+30%。学习前提：基础理财，基础采矿
    大师：英雄所管理城堡生物产量+40%。学习前提：高级理财，高级采矿
    宗师：英雄所管理城堡生物产量+50%。学习前提：专家理财，专家采矿

理财（Estates）
二级技能
基本作用：增加王国的金钱收入，效果不仅与技能等级有关，还与英雄自身的等级有关。
    基础：每天生产100金。英雄每升一级效果附加10%（以1级为起始点，注意与魔法效果计算的区别，魔法效果计算时是以0级为起始点的。以下同）。学习前提：基础贵族
    高级：每天生产200金
    专家：每天生产300金。学习前提：高级贵族
    大师：每天生产400金
    宗师：每天生产500金。学习前提：专家贵族

采矿（Mining）
二级技能
基本作用：增加王国的资源收入，效果同样与英雄自身的等级有关。
    基础：每5天生产2木材和2矿石。英雄每升一级效果附加10%（以1级为起始点。以下同）。学习前提：基础贵族
    高级：每5天生产2木材、2矿石和其他资源2个。
    专家：每5天生产2木材和2矿石和其他资源4个。学习前提：高级贵族
    大师：每5天生产3木材和3矿石和其他资源5个。
    宗师：每5天生产4木材、4矿石和其他资源6个。学习前提：专家贵族

外交（Diplomacy）
二级技能
基本作用：在部队战斗力足够强的前提下，在与野兵或敌人部队（即使是有英雄带领的）交战前，有可能花半价收购其中的一部分生物。另外可以降低战斗中部队投降的费用。
    基础：有可能花半价收购30%的敌部队，所购买部队的经验总值上限是120。英雄每升一级，能购买的上限提高10%；不能购买敌对派系的生物（以下同）。部队投降的费用相当于正常费用的80%。学习前提：基础贵族
    高级：半价收购40%敌部队，收购生物的经验总值上限是240，投降费用70%。
    专家：半价收购50%敌部队，收购生物的经验总值上限是360，投降费用60%。学习前提：高级贵族
    大师：半价收购60%敌部队，收购生物的经验总值上限是480，投降费用55%。
    宗师：半价收购70%敌部队，收购生物的经验总值上限是600，投降费用50%。学习前提：专家贵族


生命系技能

生命魔法（Life Magic）
主要技能
基本作用：允许英雄学习和使用生命系魔法，要到宗师级才能学习生命系的5级魔法。生命系魔法主要是起加强、治疗和保护作用的，5级魔法中的神圣介入和守护天使都可以复活英雄。
    基础：允许英雄学习和使用一级生命魔法，掌握技能后自动学会一种一级生命魔法
    高级：允许英雄学习和使用二级生命魔法。学习前提：基础治疗
    专家：允许英雄学习和使用三级生命魔法。学习前提：高级治疗，基础精神
    大师：允许英雄学习和使用四级生命魔法。学习前提：专家治疗，专家精神
    宗师：允许英雄学习和使用五级生命魔法。学习前提：宗师治疗，宗师精神

治疗（Healing）
二级技能
基本作用：提高英雄的魔法值上限，并且使每天魔法值的恢复速度加快。
    基础：英雄魔法值+10，每天回复2点魔法值。学习前提：基础生命魔法
    高级：英雄魔法值+20，每天回复4点魔法值。学习前提：高级生命魔法
    专家：英雄魔法值+30，每天回复6点魔法值。学习前提：专家生命魔法
    大师：英雄魔法值+40，每天回复8点魔法值。学习前提：大师生命魔法
    宗师：英雄魔法值+50，每天回复10点魔法值

精神（Spirituality）
二级技能
基本作用：加强生命系魔法的效果。
    基础：生命魔法效果+20%。学习前提：高级生命魔法
    高级：生命魔法效果+40%。学习前提：专家生命魔法
    专家：生命魔法效果+60%
    大师：生命魔法效果+80%。学习前提：大师生命魔法
    宗师：生命魔法效果+100%

复活（Resurrection）
二级技能
基本作用：在战斗结束后自动复活一部分的阵亡生物，机械、元素和亡灵生物不能被复活。
    基础：战斗获胜后自动复活20%的本方阵亡部队。学习前提：基础生命魔法
    高级：战斗获胜后自动复活30%的本方阵亡部队。
    专家：战斗获胜后自动复活40%的本方阵亡部队。学习前提：高级生命魔法
    大师：战斗获胜后自动复活45%的本方阵亡部队。
    宗师：战斗获胜后自动复活50%的本方阵亡部队。学习前提：专家生命魔法


死亡系技能

死亡魔法（Death Magic）
主要技能
基本作用：允许英雄学习和使用死亡系魔法。死亡系魔法主要是削弱敌人实力的，也可以复活敌方或我方的阵亡部队来用，或是从阵亡部队身上召唤亡灵生物。
    基础：允许英雄学习和使用一级死亡魔法，掌握技能后自动学会一种一级死亡魔法
    高级：允许英雄学习和使用二级死亡魔法。学习前提：基础神秘
    专家：允许英雄学习和使用三级死亡魔法。学习前提：高级神秘，基础鬼神学
    大师：允许英雄学习和使用四级死亡魔法。学习前提：专家神秘，专家鬼神学
    宗师：允许英雄学习和使用五级死亡魔法。学习前提：宗师神秘，宗师鬼神学

神秘（Occultism）
二级技能
基本作用：提高英雄的魔法值上限，并且使每天魔法值的恢复速度加快。
    基础：英雄魔法值+10，每天回复2点魔法值。学习前提：基础死亡魔法
    高级：英雄魔法值+20，每天回复4点魔法值。学习前提：高级死亡魔法
    专家：英雄魔法值+30，每天回复6点魔法值。学习前提：专家死亡魔法
    大师：英雄魔法值+40，每天回复8点魔法值。学习前提：大师死亡魔法
    宗师：英雄魔法值+50，每天回复10点魔法值

鬼神学（Demonology）
二级技能
基本作用：加强死亡系魔法的效果。另外同时修炼自然魔法技能和鬼神学技能，就会自动学会魔鬼类生物的召唤魔法，这几种召唤魔法不会在任何城堡的魔法塔里出现，威力很强。
    基础：死亡魔法效果+20%。学习前提：高级死亡魔法
    高级：死亡魔法效果+40%。学习前提：专家死亡魔法
    专家：死亡魔法效果+60%
    大师：死亡魔法效果+80%。学习前提：大师死亡魔法
    宗师：死亡魔法效果+100%

    基础自然魔法＋基础鬼神学＝召唤恶魔之子，高级自然魔法＋高级鬼神学＝召唤地狱犬，专家自然魔法＋专家鬼神学＝召唤冰魔，大师自然魔法＋大师鬼神学＝召唤食尸怪，宗师自然魔法＋宗师鬼神学＝召唤恶魔。

招魂（Necromancy）
二级技能
基本作用：战斗获胜后，按比例将所杀死的敌人生物转化为亡灵生物加入部队。敌人的无生命部队（包括机械、元素和亡灵生物）不被计算在招魂效果内。
    基础：战斗获胜后，按照生物经验值（而不是数量）换算，将所杀死敌人的10%转化为骷髅兵，制造的骷髅兵经验总值上限是40。制造骷髅兵的数量不能超过杀死的敌人生物数量；英雄每升一级，招魂经验值上限提高10%（以下同）。学习前提：基础死亡魔法
    高级：战斗获胜后将所杀死敌人的15%转化为骷髅兵，制造的骷髅兵经验总值上限是80。
    专家：战斗获胜后将所杀死敌人的20%转化为幽灵或骷髅兵（如果总值都不足以制造1个幽灵，则制造骷髅兵），制造的亡灵生物经验总值上限是120。学习前提：高级死亡魔法
    大师：战斗获胜后将所杀死敌人的25%转化为幽灵或骷髅兵，制造的亡灵生物经验总值上限是160。
    宗师：战斗获胜后将所杀死敌人的30%转化为吸血鬼或幽灵或骷髅兵，制造的亡灵生物经验总值上限是200。学习前提：专家死亡魔法


守序系技能

守序魔法（Order Magic）
主要技能
基本作用：允许英雄学习和使用守序系魔法。守序系魔法主要是精神控制类的，例如失明、催眠、疯狂、遗忘等，也有幻象、幻影这样的变相召唤魔法，还有迟缓、精准、推移、战场传送等实用魔法。
    基础：允许英雄学习和使用一级守序魔法，掌握技能后自动学会一种一级守序魔法
    高级：允许英雄学习和使用二级守序魔法。学习前提：基础魅力
    专家：允许英雄学习和使用三级守序魔法。学习前提：高级魅力，基础魔力
    大师：允许英雄学习和使用四级守序魔法。学习前提：专家魅力，专家魔力
    宗师：允许英雄学习和使用五级守序魔法。学习前提：宗师魅力，宗师魔力

魅力（Enchantment）
二级技能
基本作用：提高英雄的魔法值上限，并且使每天魔法值的恢复速度加快。
    基础：英雄魔法值+10，每天回复2点魔法值。学习前提：基础守序魔法
    高级：英雄魔法值+20，每天回复4点魔法值。学习前提：高级守序魔法
    专家：英雄魔法值+30，每天回复6点魔法值。学习前提：专家守序魔法
    大师：英雄魔法值+40，每天回复8点魔法值。学习前提：大师守序魔法
    宗师：英雄魔法值+50，每天回复10点魔法值

魔力（Wizardry）
二级技能
基本作用：加强守序系魔法的效果。
    基础：守序魔法效果+20%。学习前提：高级守序魔法
    高级：守序魔法效果+40%。学习前提：专家守序魔法
    专家：守序魔法效果+60%
    大师：守序魔法效果+80%。学习前提：大师守序魔法
    宗师：守序魔法效果+100%

媚惑（Charm）
二级技能
基本作用：与外交术相似，也是招降生物用的。招降的比例比外交术低，但却是免费的。同样可以降低战斗中部队投降的费用，并且可以在不征得敌人同意的情况下投降。
    基础：如果你的部队战力足够强，在与野兵或敌人部队（即使是有英雄带领的）交战前，有可能免费招降其中15%的部队（不包括无生命的部队），所招降部队的经验总值上限是60。英雄每升一级，招降上限提高10%（以下同）。英雄所带部队投降时，花费为正常费用的90%。学习前提：基础守序魔法
    高级：招降20%敌部队，招降经验总值上限是120。投降花费为正常的80%。
    专家：招降25%敌部队，招降经验总值上限是180。投降花费为正常的75%。学习前提：高级守序魔法
    大师：招降30%敌部队，招降经验总值上限是240。投降花费为正常的70%。
    宗师：招降35%敌部队，招降经验总值上限是300。投降花费为正常的65%。学习前提：专家守序魔法


混乱系技能

混乱魔法（Chaos Magic）
主要技能
基本作用：允许英雄学习和使用混乱系魔法。混乱系魔法主要是大杀伤力的直接攻击魔法，例如闪电、爆裂、连环闪电、碎裂、末日审判等，而剩下魔法多为增强攻击杀伤能力的祝福类魔法。
    基础：允许英雄学习和使用一级混乱魔法，掌握技能后自动学会一种一级混乱魔法
    高级：允许英雄学习和使用二级混乱魔法。学习前提：基础咒法
    专家：允许英雄学习和使用三级混乱魔法。学习前提：高级咒法，基础占火
    大师：允许英雄学习和使用四级混乱魔法。学习前提：专家咒法，专家占火
    宗师：允许英雄学习和使用五级混乱魔法。学习前提：宗师咒法，宗师占火

咒法（Conjuration）
二级技能
基本作用：提高英雄的魔法值上限，并且使每天魔法值的恢复速度加快。
    基础：英雄魔法值+10，每天回复2点魔法值。学习前提：基础混乱魔法
    高级：英雄魔法值+20，每天回复4点魔法值。学习前提：高级混乱魔法
    专家：英雄魔法值+30，每天回复6点魔法值。学习前提：专家混乱魔法
    大师：英雄魔法值+40，每天回复8点魔法值。学习前提：大师混乱魔法
    宗师：英雄魔法值+50，每天回复10点魔法值

占火（Pyromancy）
二级技能
基本作用：加强混乱系魔法的效果。
    基础：混乱魔法效果+20%。学习前提：高级混乱魔法
    高级：混乱魔法效果+40%。学习前提：专家混乱魔法
    专家：混乱魔法效果+60%
    大师：混乱魔法效果+80%。学习前提：大师混乱魔法
    宗师：混乱魔法效果+100%

巫术（Sorcery）
二级技能
基本作用：加强所有杀伤类魔法的杀伤力，无论此魔法属何魔法派系。
    基础：所有杀伤类魔法杀伤力增强20%。学习前提：基础混乱魔法
    高级：所有杀伤类魔法杀伤力增强40%。
    专家：所有杀伤类魔法杀伤力增强60%。学习前提：高级混乱魔法
    大师：所有杀伤类魔法杀伤力增强80%。
    宗师：所有杀伤类魔法杀伤力增强100%。学习前提：专家混乱魔法


自然系技能

自然魔法（Nature Magic）
主要技能
基本作用：允许英雄学习和使用自然系魔法。自然系魔法主要是各种各样的召唤魔法，从最低级的妖精到最高级的凤凰、仙女龙等等。其余实用魔法还有蜂群、流沙、群体加速、蛇击、龙之力量等。
    基础：允许英雄学习和使用一级自然魔法，掌握技能后自动学会一种一级自然魔法
    高级：允许英雄学习和使用二级自然魔法。学习前提：基础草药学
    专家：允许英雄学习和使用三级自然魔法。学习前提：高级草药学，基础冥想
    大师：允许英雄学习和使用四级自然魔法。学习前提：专家草药学，专家冥想
    宗师：允许英雄学习和使用五级自然魔法。学习前提：宗师草药学，宗师冥想

草药学（Herbalism）
二级技能
基本作用：提高英雄的魔法值上限，并且使每天魔法值的恢复速度加快。
    基础：英雄魔法值+10，每天回复2点魔法值。学习前提：基础自然魔法
    高级：英雄魔法值+20，每天回复4点魔法值。学习前提：高级自然魔法
    专家：英雄魔法值+30，每天回复6点魔法值。学习前提：专家自然魔法
    大师：英雄魔法值+40，每天回复8点魔法值。学习前提：大师自然魔法
    宗师：英雄魔法值+50，每天回复10点魔法值

冥想（Meditation）
二级技能
基本作用：加强自然系魔法的效果。
    基础：自然魔法效果+20%。学习前提：高级自然魔法
    高级：自然魔法效果+40%。学习前提：专家自然魔法
    专家：自然魔法效果+60%
    大师：自然魔法效果+80%。学习前提：大师自然魔法
    宗师：自然魔法效果+100%

召唤（Summoning）
二级技能
基本作用：每天自动召唤一些生物加入本方部队。
    基础：英雄每天都会自动召唤丛林妖精、妖精或狼加入部队，召唤的生物，按每天10点经验值的速度累积。学习前提：基础自然魔法
    高级：自动召唤丛林妖精、妖精或狼加入部队，召唤的生物，按每天20点经验值的速度累积。
    专家：自动召唤精灵、半羊人或白虎加入部队，召唤的生物，按每天30点经验值的速度累积。学习前提：高级自然魔法
    大师：自动召唤精灵、半羊人或白虎加入部队，召唤的生物，按每天40点经验值的速度累积。
    宗师：自动召唤风火水土四种元素加入部队，召唤的生物，按每天50点经验值的速度累积。学习前提：专家自然魔法


英雄职业

    英雄只要修炼了两个派系的技能，并达到转职条件，就可以进行转职。

转职条件
    1.初级职业向高级职业转职：初始英雄一般只掌握一个派系的技能，如果他修炼别派技能达到两级，那么就可以进行相应的转职。举例：盗贼的初始技能是侦察系的，如果他学习战斗系技能两级（战斗技能两级，或是战斗技能一级＋肉搏技能一级，等等，总之加起来有两级就可以了），那么他就可以转职为游侠。
    2.高级职业之间的转职：高级职业的英雄可以转职为新的高级职业，只要新职业所要求的技能之和超过原有职业即可。还是上面这个例子，如果这个英雄后来的技能是四级侦察系技能，三级混乱系技能，战斗系技能还是两级，则侦察＋混乱＝4＋3＝7＞侦察＋战斗＝4＋2＝6，则这个英雄可以转职为占火师。如果以后他又学了两级战斗系技能，4＋4＞4＋3，那么这个英雄会再次转职回游侠。
    3.高级职业转为大法师：表中唯一没有列出的就是大法师这个职业，因为此职业至少需要英雄学习三个魔法派系的技能才能转职。所有已掌握的魔法派系技能之和必须大于等于原职业技能之和＋3。例如上面那个英雄，侦察四级、战斗四级、混乱三级，职业是游侠，此后如果再学习四级死亡系技能，四级自然系技能，那么混乱＋死亡＋自然＝11＝侦察＋战斗＋3＝4＋4＋3，这个英雄此时就可以转职为大法师。


职业列表及特性说明

    职业对技能的要求如下表。

 | 战术 | 战斗 | 侦察 | 高贵 | 生命 魔法 | 守序 魔法 | 死亡 魔法 | 混乱 魔法 | 自然 魔法
战术 | 骑士/死亡骑士 | 将军 | 陆军 元帅 | 领主 指挥官 | 十字军 | 幻术师 | 掠夺者 | 纵火者 | 守卫者
战斗 | 将军 | 野蛮人 /射手 | 游侠 | 战神 | 圣骑士 | 战斗 法师 | 刺客 | 烈火 战士 | 驯兽师
侦察 | 陆军 元帅 | 游侠 | 盗贼 | 公会 首领 | 预言者 | 先知 | 忍者 | 占火师 | 吟游 诗人
高贵 | 领主 指挥官 | 战神 | 公会 首领 | 领主 | 红衣 主教 | 法王 | 暗黑 领主 | 巫王 | 驯兽 领主
生命 魔法 | 十字军 | 圣骑士 | 预言者 | 红衣 主教 | 牧师 | 僧侣 | 黑暗 牧师 | 异教徒 | 召唤师
守序 魔法 | 幻术师 | 战斗 法师 | 先知 | 法王 | 僧侣 | 法师 | 阴影 法师 | 术士 | 附魔师
死亡 魔法 | 掠夺者 | 刺客 | 忍者 | 暗黑 领主 | 黑暗 牧师 | 阴影 法师 | 亡灵 巫师 | 尸巫 | 鬼神使
混乱 魔法 | 纵火者 | 烈火 战士 | 占火师 | 巫王 | 异教徒 | 术士 | 尸巫 | 巫师 | 魔导师
自然 魔法 | 守卫者 | 驯兽师 | 吟游 诗人 | 驯兽 领主 | 召唤师 | 附魔师 | 鬼神使 | 魔导师 | 德鲁伊

职业特性说明

骑士（Knight）
    骑士堡力量英雄，初始技能是基础战术和基础防御。

死亡骑士（Dead Knight）
    死亡族力量英雄，初始技能是基础战术和基础攻击。

野蛮人（Barbarian）
    兽人族英雄，初始技能是基础战斗、基础肉搏和基础抗魔。

射手（Archer）
    森林族力量英雄，初始技能是基础战斗和基础箭术。

盗贼（Thief）
    庇护所力量英雄，初始技能是基础侦察和基础潜行。

领主（Lord）
    学院族力量英雄，初始技能是基础贵族和基础理财。

牧师（Priest）
    骑士堡魔法英雄，初始技能是基础生命魔法和基础治疗。

法师（Mage）
    学院族魔法英雄，初始技能是基础守序魔法和基础魅力。

亡灵巫师（Necromancer）
    死亡族魔法英雄，初始技能是基础死亡魔法和基础神秘。

巫师（Sorcerer）
    庇护所魔法英雄，初始技能是基础混乱魔法和基础咒法。

德鲁伊（Druid）
    森林族魔法英雄，初始技能是基础自然魔法和基础草药学。

将军（General）
    所在部队整体士气+1，影响英雄及生物

陆军元帅（Field Marshal）
    所率领生物近战和远程攻击力额外提高10%

领主指挥官（Lord Commander）
    所在部队整体士气+2，影响英雄及生物

十字军（Crusader）
    英雄本人始终保持最高士气（+10）

幻术师（Illusionist）
    英雄施展制造幻象、镜像魔法时，效果提高20%

掠夺者（Reaver）
    英雄本人始终保持嗜血状态（近战攻击伤害提高25%）

纵火者（Pyromancer）
    英雄本人始终有火盾护身，在近战中自动将所受伤害的25%发射给攻击者。英雄所受伤害不会因此减少，反射伤害为火属性

守卫者（Warden）
    所率领生物近战防御力和远程防御力额外提高10%

游侠（Ranger）
    英雄获得远程攻击的能力（即使不会箭术），并且远程攻击力+5

战神（Warlord）
    英雄近战攻击力+5

圣骑士（Paladin）
    英雄本人始终保持“死亡抵御”状态，对死亡魔法有50%抗性，遭受死亡系部队攻击时防御力临时提高50%

战斗法师（Battle Mage）
    英雄自动学会魔法拳魔法，并且在施展魔法拳和冰箭时杀伤力提高20%

刺客（Assassin）
    英雄的速度和战场移动力+3

烈火战士（Fireguard）
    英雄具备火抵抗能力，对火系魔法免疫，并且在遭受火属性物理攻击时所受伤害减半

驯兽师（Beastmaster）
    英雄施展召唤狼魔法时效果提高20%

公会首领（Guildmaster）
    英雄近身攻击时一定几率击晕敌人，被击晕的敌人一回合不能行动（包括反击）

预言者（Prophet）
    英雄本人始终有精神护甲护身（近战和远程防御力提高25%）

先知（Seer）
    英雄地图上视野范围+2

忍者（Ninja）
    英雄武器带毒，中毒的敌人每回合会自动损失一定生命值

占火师（Fire Diviner）
    英雄施展火系魔法时，效果提高20%。火系魔法包括火矢、火球、火环和地狱火，不包括火花和末日审判

吟游诗人（Bard）
    英雄本人始终保持最大幸运（+10）

红衣主教（Cardinal）
    英雄复活技能提高5%

法王（Wizard King）
    英雄近身或远程攻击时使敌人幸运值降到最低（-10）

暗黑领主（Dark Lord）
    英雄近身或远程攻击时使敌人士气值降到最低（-10）

巫王（Witch King）
    英雄攻击时能够让敌人恐惧，敌人不能反击并且会向后退几步

驯兽领主（Beast Lord）
    英雄施展召唤狼和召唤白虎魔法时效果提高20%

僧侣（Monk）
    英雄本人始终保持“混乱抵御”状态，对混乱魔法有50%抗性，遭受混乱系部队攻击时防御力临时提高50%

黑暗牧师（Dark Priest）
    英雄本人自动获得“吸血鬼接触”技能，近战攻击时能够将敌人损血的一半吸取到自己身上

异教徒（Heretic）
    英雄攻击或施法时忽略敌人的一切“抵御”状态（守序抵御、混乱抵御、生命抵御、死亡抵御和自然抵御），包括圣骑士和僧侣的抵御状态

召唤师（Summoner）
    提高英雄召唤技能的效果，每天召唤生物的经验总值提高20点

阴影法师（Shadow Mage）
    英雄远程防御力提高50%

术士（Wizard）
    英雄施展魔法时少消耗2点魔法值（至少要消耗1点）

附魔师（Enchanter）
    英雄施展召唤魔法和幻象、镜像魔法时，效果提高20%

尸巫（Lich）
    英雄在近身攻击时能够老化敌人，被老化的敌人攻击力降低25%，防御力降低20%，速度和战场移动力减半

鬼神使（Demonologist）
    英雄施展魔鬼类召唤术（召唤恶魔之子、地狱犬、冰魔、食尸怪或恶魔）时效果提高50%

魔导师（Warlock）
    英雄魔法值+10，每天多恢复1点魔法值

大法师（Archmage）
    英雄施法效果提高20%


英雄职业与技能学习

    英雄在升级时所能学习的技能，与英雄的职业密切相关。

    一、英雄升级时一般会出现三个技能供选择，只有少数情况例外，例如一级魔法英雄或是技能学习已经太多的英雄。
      1.三个技能中，上面两个技能是职业组成部分的技能，例如牧师是生命系技能，烈火战士是混乱系技能和战斗系技能。如果职业组成部分的技能已经全部提满，或者是只剩一个可以提升，多余出来的两个或一个技能学习空位就会交给别派系的技能。
      2.三个技能中的最后一个技能，从第四级开始将锁定为战斗技能（注意，不是战斗系技能），一直到战斗技能宗师、或者是英雄职业转化为与战斗系技能相关的职业（例如混乱与战斗结合的烈火战士）、或者是英雄五个主技能位置被填满（无论五个主技能中是否包含战斗，以下同）为止。如转职后战斗技能依然未达到宗师，则每升三级至少出现一次，但不一定会占据第三个位置。
      3.如果英雄已掌握的各个派系技能等级平均值不小于6，并且五个主技能位置还没有被全部填满，则第三个位置上将会出现一种新的主技能供学习。但如果平均值不小于6、战斗技能未达到宗师，并且英雄职业与战斗系技能无关，则这个位置仍然会留给战斗技能，而不是新的主技能。
      4.关于战斗技能是否一定在升级时出现，以上只是一般规律，实际上还有例外情况。规律实在太复杂，仍然在研究中……

    举例：假设有这样一个英雄，技能情况是混乱系13级，守序系5级，战斗系10级，职业为烈火战士（混乱+战斗）。因为其技能总值为28，平均值超过6，所以在升级时出现的三个技能将会是：一个混乱系技能、一个战斗系技能和一个新的主技能。如果这个英雄不学习新的主技能，将5个主技能位置填满，永远也没有机会提升守序系技能（除非是访问野外设施或在城内花钱学技能，发生转职；或是提升混乱和战斗系技能，使两派系可学技能少于2）。

    二、关于魔法技能的学习
      1.如果英雄职业组成部分中有一个魔法派系，就不能在升级时学习敌对的魔法派系技能，例如牧师（生命）、圣骑士（生命+战斗）、十字军（生命+战术）都不能在升级时学习死亡技能和混乱系技能。如果职业组成部分里有两个相邻的魔法派系，就不能学习两个派系公共的敌对派系，例如尸巫（死亡+混乱）不能学习生命技能。
      2.如果职业组成部分里面没有魔法技能，那么要区别对待：
      初始职业，例如骑士、射手、死亡骑士等等，其技能学习的限制依据英雄所属阵营决定。骑士是生命阵营的，所以就不能学死亡和混乱。野蛮人比较特殊，任何魔法技能都不能在升级时学到，需要等转职后才能学。
      如果是转职后的高级职业，例如将军（General，战术+战斗），在魔法技能的学习上没有限制。
      3.如果职业组成部分里面有两个敌对的魔法派系，例如术士（守序+混乱），在魔法技能的学习上基本没有限制。这里面有少数例外，例如鬼神使（自然+死亡）在升级时是学不会生命系技能的。大法师这个职业因为至少要三派系的魔法技能才能组成，其中一定会有敌对派系，所以在魔法技能的学习上也没有限制。
      4.以上所说的仅仅是完全靠英雄升级来学习技能的情况，如果有访问野外设施或是在城内学习魔法技能的机会，那么情况便会不同。例如圣骑士，本来不能学死亡技能，但是访问野外建筑时学会了基础死亡魔法技能，以后他再学习死亡技能便不会再受限制，所要注意的仅仅是几个派系技能的平均等级。


魔法

    英雄无敌4已经打破了前一代中按元素属性划分魔法派系的做法，重新整合魔法系统，将魔法分为守序、混乱、生命、死亡和自然5个派系，感觉这种划分方法比前一代更为合理。各个派系的魔法绝大部分是不同的，但也有极少数的魔法跨系，例如混乱系的抢先攻击和自然系的蛇击，只是名称不同，作用完全一样。

魔法的分类标准

    除了按派系把魔法分为5类外，还可以按照魔法的使用场所，分为冒险类魔法（在地图上使用）和战斗魔法（在战场上使用）两类。而战斗魔法按照作用，又可以分为直接杀伤类魔法（简称杀伤类魔法）、祝福类魔法、诅咒类魔法和召唤类魔法共4类。
    此外还有一些特殊的分类标准，与特定宝物、技能的作用范围有关，所以必须要提一下。
    精神魔法：包括精准、群体精准、怯懦、遗忘、疯狂、催眠、混乱、混乱云、嗜血、血暴、和平之歌、振奋、群体振奋、悲泣、群体悲泣和（梦魇兽与暗黑骑士的）恐惧魔法。鉴别精神类魔法的最标准方法，是看用精神护盾这个宝物能不能防住。恐惧结界魔法给部队攻击时附带的效果，以及骨龙的引起恐惧技能，都和精神类魔法相似，相关宝物给英雄附加的能力，也是一样。
    治疗类魔法：包括疗伤、医疗、再生、群体医疗和神圣介入。治疗类魔法对无生命的部队（包括机械、元素和亡灵）无效，暗黑骑士的再生技能则比较特殊，与再生魔法有本质区别。
    火魔法：包括火矢、火球、火环和地狱火。此外与火魔法相类似（同样对火抵抗部队无伤害能力）的还有火焰结界的附加伤害，火盾反弹，以及气息攻击与希腊之火的波及攻击。
    冰魔法：其实也就是一个冰箭而已。

魔法效果的计算

    四代已经取消了英雄法力这项属性，魔法的效果现在由英雄等级、相关技能、职业以及宝物决定，具体公式请看这里。

    魔法说明中所提到的“魔法参数”，前一个是公式中的“基本威力”，后一个则是公式中的“效果提升率”（也就是英雄升级对魔法威力的加成）。


魔法派系

    魔法派系与种族有着直接对应关系。

    守序魔法：以诅咒类魔法为主，主要是精神控制和减缓敌人行动。另外还有与远程攻击有关的一些魔法。
    混乱魔法：主要是大杀伤力的攻击魔法，此外还包括一些祝福类魔法，全部都是用于增强部队攻击实力的。
    生命魔法：基本都是祝福类魔法，以治疗类魔法和加强部队抗打击能力的魔法为主，少部分魔法也可以加强部队攻击实力。
    死亡魔法：主要是削弱敌人攻防实力的诅咒类魔法，还包括了与操纵亡灵有关的魔法。
    自然魔法：主要是各种各样的召唤魔法，以及一些增强部队攻防能力的祝福类魔法。

    各个魔法派系之间并不是孤立的，而是有着一定的关联关系。每个魔法派系都有2个相邻的魔法派系，也都有着2个敌对的魔法派系。魔法派系的这种关系影响到了魔法公会里出现的魔法、英雄技能学习的限制和城堡内可招募到的英雄类型等等。


守序魔法

一级魔法

模糊（Blur）
派系：守序
类型：祝福类
    使单个部队的远程防御力提高50%。
    看起来效果比较强的一个魔法，远程防御力提高50%也就是相当于受远程攻击时只会受到2/3伤害（1÷(1+50%)）。在游戏早期如果遇到低级野外射手，可以考虑施放在矮人或是英雄身上，有效减少伤亡。到中后期这个魔法就不太常用了，一是因为是单体魔法，二是因为作用场合有局限性，三是守序系好魔法实在太多，而且还有灯神的存在。

驱散（Dispel）
派系：守序
类型：祝福类/诅咒类
    解除我方或敌方单个部队身上附着的状态魔法，无论是正面还是负面的。但是不能用来解除中毒和瘟疫状态。可以用来直接驱除操纵的尸体和幻象副本。
    驱散时不分好坏的特性，需要特别加以关注。因为守序魔法最重要的那些状态魔法都是诅咒性质的，在对敌人部队使用驱散时很可能反而便宜了敌人，投鼠忌器而使驱散派不上用场，从这一点来说，明显不如死亡系的废除；而对本方使用时，因为守序魔法祝福性质的并不多，相对而言顾忌就少一点，多数时候并不见得比生命系的驱魔差。对我方或敌方部队都能产生作用，是驱散的最大优点，但使用之前必须考虑清楚，不能像用废除或驱魔时那样义无反顾。
    不能用来去除防魔魔法，是驱散魔法与三代相比唯一的不足之处。但是可以用来去除敌人宗师抗魔英雄身上的正面魔法，加上四代状态魔法持续时间的无限性，令驱散的作用在某些时候变得不可替代。

推移（Displacement）
派系：守序
类型：祝福类/诅咒类
    将（我方或敌方）单个部队推开两格，推移的方向由施法者选择。
    虽然对本方或敌方部队都可以产生效果，但推移的实战应用多数还是用来推敌人。因为视线规则的存在，在某些时候将敌人用来保护英雄或远程的部队推开，就是非常重要的事情。将站在箭塔上的强力远程推下塔，也是推移常见应用之一。虽然后期主力英雄一般都腾不出手干这种活，但因为是一级魔法，随便招个副英雄就可以用了，所以派上用场的时候还不少。用来欺负电脑比较容易，但对人作战时作用便有所限制，因为一般玩家都会习惯于用紧密阵型，部队相互间的阻挡令推移很难一次就达到预期效果。
    在早期版本的游戏中，推移在使用上没有多少限制。从2.0版本开始，新增了魔法抗性影响因素，令这个魔法的作用有所下降。

魔法拳（Magic Fist）
派系：守序
类型：杀伤类
    攻击单个敌人，魔法参数：20/2，计算出的数值为魔法杀伤力
    杀伤力低下的魔法，在最高难度游戏中几乎无用。当然这是对于英雄而言，法师兵种使用魔法拳，还是不可小视的。

精准（Precision）
派系：守序
类型：祝福类
    使单个部队远程攻击力提高25%，并使远程攻击伤害不受距离、障碍、城墙的影响。（不能伤害躲在城堡内部的敌人，但射击紧贴着城墙的敌人时，伤害不会减半）。
    相当实用的一种魔法，早期游戏中常常要对半身人使用。而在后期，当泰坦身上同时附着精准和振奋（灯神所加）状态时，其威力是相当强的。可惜此魔法是精神类魔法，不能对灯神复制出来的泰坦幻象使用，不能不说是遗憾。

真视（Visions）
派系：守序
类型：冒险魔法
    显示敌人部队里的生物数量和英雄技能。
    除了不能增加视野范围外，基本相当于大师侦察技能的作用。这对实战来说相当有帮助，特别是在不允许取进度的对战中，有利于做好战前预判工作。另外可以看到电脑对战斗结果的预测（专家侦察技能就有的效果），也颇有文章可作。电脑预测出来的结果，一般会与你使用快速战斗（Quick Combat）打出的结果相当。虽然电脑的AI远不如人脑，但在某些特殊情况下，快速战斗的结果却比手动指挥更好，这是因为快速战斗时忽略了敌人的某些特性，如吸血鬼的吸血，法师、灯神的魔法等等。当然，若有人认为在这种情况下使用快速战斗等于利用Bug，而不屑于使用的话，那还是不要用好了。

二级魔法

怯懦（Cowardice）
派系：守序
类型：诅咒类
    对单个敌人部队使用，使其在3回合之内不能对生命总值超过其自身的部队进行主动攻击或施法
    因为在最高难度游戏下，野兵的数量非常多，其生命总值自然也大，因此怯懦的使用对象就十分鲜明了：绝大多数时候都会指向敌方英雄。在与野外灯神交战时，估计很多人都曾体会到中了怯懦后有劲使不出的郁闷感觉，那么这种郁闷感觉在适当的时候也应该让对手去尝尝。想想敌人一个杀伤魔法威力巨大的混乱巫师，在中了怯懦后无法解除的情景，会有多么快意？对兵种使用怯懦的情形相对较少，但在合适状况下，让灯神使用怯懦，会比用和平歌更省魔法值。

飞行（Flight）
派系：守序
类型：祝福类
    赋予部队飞行能力直到战斗结束
    让步兵变成飞行部队，那可是实质性的变化。虽然守序没有加速魔法，但飞行魔法却在不少时候比加速更好用，战场上障碍物越多，飞行的优越性就越能体现出来。利用障碍让飞行的英雄与中了迟缓的敌人周旋，或是飞行后的强力部队（如傀儡龙）快速冲上去压制敌人，都是比较常见的应用。

冰箭（Ice Bolt）
派系：守序
类型：杀伤类
    对单个敌人造成冰属性伤害，魔法参数：40/4，计算出的数值为魔法杀伤力
    守序系的杀伤魔法总共才两种，杀伤力与混乱系的同级魔法本来就有差距，又缺少巫术技能的支持，所以实在是没有多少实用价值。水元素和灯神用冰箭是正常的，英雄用冰箭的情形就比较少见了，基本上也就是用来杀敌人英雄。

制造幻象（Create Illusion）
派系：守序
类型：召唤类
    制造我方或敌方部队的副本。重复使用此魔法，会在第一组幻象上叠加数量。魔法参数：40/4，计算出的数值为副本的生命值。
    幻象魔法与前两代中的镜像/克隆魔法不同，不是直接制造与原部队数量一样、但一受攻击就立刻消失的副本，而是按照法术威力来制造一定数量的部队。虽然每次制造的数量不多，但重复使用可以逐渐增强其战力，灯神的辅助作用可以给这个有点长的积累过程以一定的安全期。与普通召唤魔法按部队经验值计算不同，按生命值计算的幻象最适合用来复制高级兵。因为可以复制敌人，即使没有四级兵助阵，一定数量的灯神也敢于去挑战四级野兵。但或许正是因为灯神可以使用这种魔法，因此驱散或废除可以直接用来驱除幻象副本，这可以看作是维护游戏平衡性的一个设计。
    对英雄来说，幻象魔法不是不好，但多数时候使用特权都会被灯神抢去，英雄用它的机会大大减少了。若守序之外的种族捡到了幻象法仗，倒是可以产生相当有趣的打法。

迟缓（Slow）
派系：守序
类型：诅咒类
    使单个敌人部队速度和战场移动力减半
    在最高难度游戏下，绝大多数时候都要以弱战强，因此降低敌人行动能力的迟缓要比单纯的加速更加重要，魔法等级高一级也是完全合理的设计。魔法延续时间上的无限性，极度夸大了迟缓魔法的重要性，也使其成为守序族的优势之一。

能量损耗（Power Drain）
派系：守序
类型：诅咒类
    使敌人部队（英雄或生物）施法时需要消耗双倍魔法值
    使用优先度不怎么高的一种魔法，因为其效果多数时候都不会立刻显现出来。如果能够充分发挥其让敌人施法次数减半的作用，那么还是值得使用的。自身安全和部队可持续战力是最需要预先考虑的因素，如果条件不合适，还是先用别的可改变战局走向的魔法吧。对付野外施法兵种时，有时会非常有用。

窃魔（Steal Enchantment）
派系：守序
类型：诅咒类
    吸取单个敌人部队身上附着的一个正面魔法状态，转移到随机选取的本方部队身上
    有点无赖的一种魔法。对于祝福类魔法比较紧缺的守序系来说，窃取敌人一个强力正面魔法有时会让人忍不住笑出声来。但是因为每次只能窃取一个，还是随机的，如果敌人身上有很多正面魔法附加时，窃魔的效果就难尽人意了。而且窃取回来的状态加在哪个部队身上，也是随机的，所以其效果根本没有想象中那么强，有时还不如用一个驱散去直接废掉敌人的祝福状态。
    需要注意的是，敌人那些由职业、宝物附加的魔法状态，也能够窃取，但窃取完成后敌人的状态并不会消失。

三级魔法

驱逐（Banish）
派系：守序
类型：诅咒类
    专门打击敌人用召唤类魔法制作出来的部队，魔法参数：110/11，计算出的数值为魔法杀伤力。
    召唤类魔法可分为召唤、幻象/幻影、驱役亡灵、亡灵复生（操纵尸体和死亡呼唤）几类，幻象/幻影、亡灵复生和驱役吸血鬼都可以直接用驱散来解决，驱役骷髅和驱役幽灵又不太强，因此驱逐魔法可以看作是专门用来对付自然系那些召唤魔法的。其魔法参数与最强的杀伤魔法碎裂相同，但少了巫术技能后，实际效果却差不少。在没有催眠或疯狂的情况下，驱逐用来对付召唤生物还是不错的，但若对手不是自然族，那么就是白占魔法塔一个位置了。
    另外需要注意的是，虽然是以生命值来计算魔法杀伤，但身为诅咒类魔法的驱逐，还是与一般的杀伤魔法不同，其效果最终是要落到“个”这个单位上来的。例如魔法计算出来的威力是352点，但在对狮鹫使用时其威力只有285点（3个狮鹫的生命值），剩余的67点被舍却了。
    注意到驱逐魔法的效果也要受到幸运/厄运的影响，当幸运/厄运发生作用时，驱逐的效果是先按前面所说的以完整的“个”来计算威力，然后把计算出来的伤害值直接加半或是减少1/3，这时便无须再考虑“个”的问题了。

遗忘（Forgetfulness）
派系：守序
类型：诅咒类
    使敌方单个部队无法进行远程攻击，一直到战斗结束。
    遗忘是一个改变敌人兵种性质的魔法，持续时间无限性进一步强化了作用。近战伤害不减的远程兵种还稍微好些，普通远程兵中了遗忘之后，其处境只能用“凄惨”来形容。虽然说精神魔法属性给这个魔法带来了一些限制条件，但不吃它的远程兵实际上只有弩车、火元素区区两种而已（不算资料片中的投石车），这两种兵也不算太强，所以遗忘在多数时候还是无比有用的。复生的尸体和幻象副本才稍微让人有点麻烦感觉，但一个驱散就足以对付了。

群体模糊（Mass Blur）
派系：守序
类型：祝福类
    本方所有部队获得模糊状态
    群体模糊的实用性要比单体的模糊高许多，当你有多支部队需要保护的时候，你就能体会到群体魔法的优越性了。在面对强力远程兵时，群体模糊常常是不错的选择。

群体驱散（Mass Dispel）
派系：守序
类型：祝福类/诅咒类
    解除所有部队（包括敌我）身上附着的状态魔法，无论是正面还是负面的。其余特性与单体驱散相同。
    群体驱散是一个毁誉参半的魔法，有时极度有用，有时却因投鼠忌器而变为鸡肋，一切都要看实战的情况而定。对于中了怯懦的英雄来说，群体驱散有时会是相当不错的选择。

群体精准（Mass Precision）
派系：守序
类型：祝福类
    使本方所有远程部队获得精准状态。
    罕见的使用率不及单体魔法的一个群体魔法。因为守序本身就只有半身人和泰坦两种远程，英雄一般也不会去修炼箭术，因此这个魔法很难体现其群体性质的优越性。很多时候，看见群体精准在魔法塔中出现，都会有宝贵的魔法位置被白占一个的感觉，令人愤懑。可以说这是最差的三级守序魔法之一。

传送（Teleport）
派系：守序
类型：祝福类/诅咒类
    将部队传送到战场上的指定位置，可以用来传送敌人部队。
    飞行魔法依然不能完全弥补某些部队在移动力上的缺陷，这时便需要传送魔法出场了。传送本方部队多是为了躲避敌人的围攻，而传送敌方部队则为我方围攻敌人创造了条件。对视线没有要求，令传送成为对付敌人远程部队或英雄最好的方法之一。而在攻城战中，传送的优点就更加突出。
    在早期版本游戏中，传送敌人没有多少限制条件。从2.0版本开始，对其增加了魔法抗性影响因素，虽一定程度削弱了其作用，但这仍然是一个可超越三级地位的实用魔法。

回城（Town Gate）
派系：守序
类型：祝福类/冒险魔法
    使施法英雄及其带领的整支部队回到最近的本方城堡，可以在战场上使用。
    又是一个体现守序系特权的魔法，可以说相当不公平。当灯神魔法值耗完时回城，是此魔法的一种应用，可以让某些原本无法打赢的战斗分几次来完成。堵城门使用或是在城堡附近战斗中使用，可以让部队回到较远的城堡里。合理综合利用上述规则，甚至可以使回城魔法有前两代中大回城的效果，这样守序族调动兵力就变得很容易实现，这是其他种族所难以企及的优势（其他族只能用战斗中逃跑的方法来调动英雄）。生命城堡和死亡城堡有些时候还可以跟着沾点光，其余种族可就只能眼睁睁面对不公平待遇了。

四级魔法

疯狂（Berserk）
派系：守序
类型：诅咒类
    迫使单个敌方部队追击离他最近的部队（不分敌我），攻击后疯狂状态解除
    给敌人强力部队施放后，等着看敌人内讧，是非常快意的一件事情。虽然比催眠差不少，但也已经非常强了，经常可以改变双方的战力对比，只是要算清楚敌人部队的行动顺序，来决定使用的时机与对象。

失明（Blind）
派系：守序
类型：诅咒类
    使敌方部队在3个回合内无法行动，如果遭受伤害，失明状态将解除。施法对象必须在英雄视线内
    虽然只能持续三个回合，又有视线要求，但在规则改变的四代中，失明仍然不愧是一个称职的四级魔法。让敌人主力部队或英雄三个回合不能行动，我方可以腾出足够的时间来做别的事情，而且如今失明已经不像前几代那样容易被解除（比如说，英雄中招了，或是没有驱散、驱魔、防魔魔法）。
    需要注意的是，失明如今已经不是精神类魔法，在与元素或机械部队交战时，它常常能够发挥奇效。

幻影（Phantom Image）
派系：守序
类型：召唤类
    制造部队的副本，细节与制造幻象魔法相似，但魔法参数是80/8
    效果为幻象两倍的幻影，若与迟缓魔法结合，可以产生不错的效果。但与其余四级守序魔法相比，作用偏差了些，多少有点不称职的感觉。很多时候它只能作为对灯神幻象的一种补充，但不是决定性因素。
    早期版本中，对同一类兵使用幻影和幻象，会产生两队副本。但后来此缺陷已经被弥补了，制造出来的副本是叠加在一起的。

群体迟缓（Mass Slow）
派系：守序
类型：诅咒类
    使敌人所有部队速度和战场移动力减半
    在面对高移动力兵种时，群体迟缓有时候会与单体迟缓产生本质区别，特别是在某些因敌人组成而被迫要采用分散阵型的时候。

五级魔法

催眠（Hypnotize）
派系：守序
类型：诅咒类
    使敌人单个部队在三回合内受我方控制，对于部队的强度没有限制条件。控制对方部队后，不能对其进行远程攻击（范围攻击除外）；可以近身攻击，但会遭到反击。
    整个游戏中最为无耻的魔法，既无战力要求，又无视线要求，对平衡性的破坏实在太大，以至于一些新编地图干脆把它给禁用了。在早期版本中，可以对被催眠的部队使用牺牲或殉难，使催眠的无耻程度进一步加剧。从2.0版本开始，催眠+牺牲已经被禁用，而催眠到期后殉难状态也将自动消失。
    除了死亡族外，任何种族在面对守序族时都存着三分忌惮，就算英雄有宗师抗魔，仍然需要提防强力部队被催眠后给本方造成惨重损失。混乱的黑龙和自然的魔法，是对付催眠的利器，而英雄施法的时机，是需要重点参详的因素。

痛苦之镜（Pain Mirror）
派系：守序
类型：祝福类
    对本方单个部队使用，使其在遭受物理攻击或魔法攻击时，自动把一半伤害反射给攻击者，部队本身所受的伤害并不会减少。反弹效果会受敌人抗魔能力的影响
    单机游戏中基本无用，对战中有发挥余地的一个魔法。反弹一切伤害（无论是近身肉搏，远程射击，还是魔法杀伤），在兵力相当的战斗中会起到巨大作用。虽然对付数量巨大的野兵时作用有限，但反弹的比例确实是不能再加强了，否则敌人使用此魔法、又无法将其解除时，该怎么办？奇怪的是，电脑从来不用这个魔法，让玩家的顾忌少了许多。

通法盗窃（Steal All Enchantments）
派系：守序
类型：诅咒类
    窃取敌方所有部队身上附着的所有正面魔法状态，转移到随机选取的本方部队身上
    窃取敌人所有正面魔法状态，此魔法与其单体版本的区别可比一般群体/单体的区别大多了。与痛苦之镜相仿，通法盗窃的对战价值也大于单机价值。虽然生命、自然和混乱系都有不少强效祝福类魔法可偷，但以电脑AI的弱智程度，兵力常常还不如玩家，根本没必要动用偷窃手段来对付。


混乱魔法

一级魔法

魔箭（Magic Arrow）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：30/3，计算出的数值为魔法杀伤力
    作为一级魔法来说，其威力已经不小了，虽然在最高难度游戏中用处有限，但也不是完全没价值。

火花（Sparks）
派系：混乱
类型：杀伤类
    英雄在施展此魔法时，会走到施法对象面前，使出的魔法同时攻击面前以及恻前方与自己相邻的部队（不分敌我）。施法对象必须在英雄的移动攻击范围内。魔法参数：20/2，计算出的数值为魔法杀伤力
    相当特殊的一个魔法，其使用方式独一无二。实战中可利用率极低，因为其威力决定了只能在早期使用，早期英雄的防御力不会强，离开部队保护走上去几乎意味着送死。或许在巫师群战术中还能发挥作用，但也要能同时攻击三组敌人才比火矢合算。

嗜血（Bloodlust）
派系：混乱
类型：祝福类
    使部队的近战攻击力提高25%
    与守序的精准相对应，这个魔法是用来加强近战的，实用率也相当高。在游戏早期，就算兵力不多，施加嗜血后的杀伤增幅也相当不错，即使赶不上火矢的伤害，几回合攻击累积下来后就可以超越了，适合在战斗早期使用。

火焰结界（Fire Aura）
派系：混乱
类型：祝福类
    对本方部队使用，该部队在对敌人进行近身攻击时，会附带少量的火属性额外伤害。额外伤害的大小与本方部队的数量和能力无关，只与施法者有关。魔法参数：10/1，计算出的数值为火焰伤害的威力
    威力太低，在尽量提升杀伤能力时会将其考虑进去，但施法优先度无疑是排名末尾的。

疾速（Haste）
派系：混乱
类型：祝福类
    单个部队速度和战场移动力+3
    在最高难度下，疾速的效果显然不如迟缓。因为一般来说野兵战力都会远强于我方实力，用迟缓可以有充分时间慢慢折磨敌人，而加速之后该怎么办，冲上去硬碰硬么？当然不是不行，但要以微小损失歼灭敌人，我方与敌方部队的战力比例就要高于有迟缓魔法的情况，就是说，面对同样的敌人，有迟缓魔法可以比单有疾速魔法用更少兵将敌人消灭。
    因为速度是决定出手优先度的最重要因素，因此疾速魔法的应用还是非常广泛的。但就战略发展地位来说，不如迟缓。

杀戮（Slayer）
派系：混乱
类型：祝福类
    使部队在攻击4级生物时能够造成50%的额外伤害
    在面对四级生物时，这个魔法非常管用，算是一个相当不错的一级魔法。

二级魔法

火矢（Fire Bolt）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：50/5，计算出的数值为魔法杀伤力
    杀伤力相当不错的魔法，只是最高难度游戏限制了其作用。单用效果有限，需要有其他因素来配合，在巫师群战术中比较常见。

法术枷锁（Spell Shackle）
派系：混乱
类型：诅咒类
    对单个敌人部队（英雄或生物）使用，使其在施法时每消耗1点魔法值就要受到10点伤害
    魔法威力已经决定了法术枷锁基本上只在对付英雄时有作用，诅咒类的性质决定了不必考虑视线问题，这是其优势，一般英雄中了之后没几回合就该倒下了。虽然不常用，但在合适条件下可以考虑。与电脑打的时候倒是常常会中这个魔法，如果不能解除的话，在施法时就会有束手束脚的感觉。

混乱（Confusion）
派系：混乱
类型：诅咒类
    使敌人部队丧失一回合的行动机会，施法对象必须在英雄视线内
    与和平歌算是作用相近的魔法吧，但要强上不少，仙女龙的好用，其实也就是靠这个东西。只能维持一回合看上去太少，但若配合魔力闪光，每次消耗只有1点，四个低级巫师配合很容易就把野兵控制个三、四十回合（要考虑到战斗中有敌人部队被消灭后，腾出手来的巫师就可以留着魔法值后面用），配合美杜莎的无限弹药、石化凝视，很多强敌都可以干掉了。

抢先攻击（First Strike）
派系：混乱
类型：祝福类
    使本方部队获得“抢先攻击”状态
    在规则改变的四代里，能在攻击或反击时抢在敌人之前出手，往往意味着损失的大幅度减少，甚至改变胜败结果。抢先攻击魔法的重要性也就不言自明。

魔力闪光（Mana Flare）
派系：混乱
类型：祝福类
    使战场上所有部队（包括我方和敌方）在施法时少消耗2点魔法值（但最少要消耗1点）
    一个非常好用的魔法，使用后二级魔法只要消耗1点魔法值，极大增加了可用次数。此魔法是巫师群战术可行性的最重要因素，否则控制敌人的回合数便会大大减少，以弱胜强的效果会打上不少折扣。如果可能的话，将魔力闪光与灯神、水元素、仙女龙相结合，可以大幅度提升这些兵种的威力。

厄运（Misfortune）
派系：混乱
类型：诅咒类
    使敌人单个部队幸运降到最低。
    幸运最低（－10）的敌人受物理攻击和闪电、爆裂、碎裂、圣言、圣唱、驱逐魔法时，会多遭受1/2的伤害。有些时候可以近似认为我方部队增加了一半，这个提升比例可着实不小，宗师攻击技能的效果也不过如此。

三级魔法

火环（Fire Ring）
派系：混乱
类型：杀伤类
    对半径4英尺（直径9英尺）范围内的部队造成杀伤（无论敌我），位居中心的部队不受伤害。魔法参数：40/4，计算出的数值为魔法杀伤力
    除了中心部队不受伤害外，其余属性与火球一样。高防御英雄站中心，对周围敌人用火环，似乎是个不错的想法。但混乱系加战斗系技能会产生烈火战士职业，火抵抗能力本来就不怕火魔法，所以这种想法也就失却了相当的可行性。

火球（Fireball）
派系：混乱
类型：杀伤类
    对半径4英尺范围内的部队造成杀伤，魔法参数：40/4，计算出的数值为魔法杀伤力
    利用其大范围的特性，让敌人多分组后加以杀伤，是使用火球的基本常识。然而火球的作用范围要比独眼的范围攻击小一点，想同时攻击三队敌人没那么容易，因此很多时候都不如有灾祸魔法配合的闪电。

血暴（Blood Fenzy）
派系：混乱
类型：祝福类
    使本方所有部队的近战伤害提高25%
    嗜血的群体版本，在大兵团作战中相当有用。

闪电（Lightning）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：70/7，计算出的数值为魔法杀伤力
    威力原本就不弱，如果再配合灾祸魔法，杀伤值的基本基数可以达到105点，很强了。若同时学会闪电和灾祸的话，我一般情况下都会让英雄暂时停止混乱系技能的学习，改而去学战斗技能，闪电在相当长一段时间内都足以撑起门面了。

魔镜（Magic Mirror）
派系：混乱
类型：祝福类
    对本方部队使用。该部队在遭受敌人魔法攻击时，自动将1/2的伤害反射给施法的敌人，部队本身所受的魔法伤害不会因此减少；在承受诅咒类魔法时，自动使施法者获得同样的受诅咒状态，不能反弹的诅咒类魔法只有催眠、和平之歌和驱逐这少数几种。部队如果直接被魔法消灭，反弹将不会发生。
    想靠反弹魔法伤害来消灭敌人英雄，并不是什么好方法，若双方等级、技能相当，直接丢个火球就比用魔镜效果好，反正二者的效果都要受魔法抗性制约。反弹诅咒魔法的特性倒是比较有用些，但因为是单体魔法，因此作用就打了折扣，经常不能取得预期中的效果。
    作为兵种特技而言，仙女龙的魔镜倒是相当有用，让一些战术在面对它的时候都要打些折扣。对它使用混乱会让施法者也陷入混乱，同样一回合不能行动，却有本质区别：施法者本回合已经行动过（用魔法）了，混乱效果持续到下个回合，而仙女龙下个回合就可以醒过来，这可有点受不了。

群体杀戮（Mass Slayer）
派系：混乱
类型：祝福类
    使本方所有部队在攻击4级生物时能够造成50%的额外伤害
    杀戮魔法的群体版本，其作用无需细述。

四级魔法

爆裂（Implosion）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：90/9，计算出的数值为魔法杀伤力
    从杀伤力与魔法值消耗的比例来看，效率显然不如闪电，如果同有魔力闪光辅助，缺点就更明显了。但有时能越快速打击对手，就对战局越有利，毕竟战斗并不是总能慢慢施法去细细计较效率的。

地狱火（Inferno）
派系：混乱
类型：杀伤类
    对半径7英尺（直径15英尺）范围内的敌人造成杀伤，魔法参数：40/4，计算出的数值为魔法杀伤力
    范围大是地狱火的最大优点，常常能够同时影响三、四支敌人部队，总体杀伤力是相当不错的。如果敌人部队实力比较平均，没有那一队需要急切消灭，那么地狱火显然要比爆裂更好用。但若敌人有快速部队，可以迅速移动到英雄身前的话，在视线被遮时地狱火的着点选择就变得比较困难，这种情况不可不防。

群体抢先攻击（Mass First Strike）
派系：混乱
类型：祝福类
    使本方所有部队获得“抢先攻击”状态
    抢先攻击的群体版本，虽然并不直接提升攻击伤害，但攻击或反击的优先可以比血暴更加有效地减少损失，其实也就提高了持续战斗力。

灵猫反射（Cat Reflexes）
派系：混乱
类型：祝福类
    使我方部队在主动攻击时可以多打一下，如果是原来就可以连击两下的部队，加了灵猫反射之后，主动攻击时可以连打三下。
    混乱系祝福类魔法的最高境界，集中体现了这一系列魔法强化杀伤能力的特色。单就对攻击的强化效果而言，不比自然的龙之力量魔法差多少，而且连击特性在对付喝了不朽药水的敌人英雄时，有着独特优势。越强力的部队，就越能发挥灵猫反射的作用，在后期可比什么杀伤类魔法都强得多。如果四级兵选择黑龙，这么好的魔法就享受不到了，实在遗憾，可惜很多时候却仍然要做这种无奈的选择。

混乱云（Cloud of Confusion）
派系：混乱
类型：诅咒类
    让英雄视线内半径4英尺区域里的所有敌人丧失一回合的行动机会
    不用说当然是好魔法，可惜作用范围稍微有点小，如果不结合分兵引诱战术，不能完全发挥威力。从效率上来看，不如单体混乱。但如果始终用巫师群战术，难免会造成英雄等级整体不高的局面，关键时刻缺少一个挑大梁者，而混乱云的出现，正好可以促使玩家作出决断，在合适时刻放弃一些英雄。

群体厄运（Mass Misfortune）
派系：混乱
类型：诅咒类
    使敌人所有部队幸运降到最低
    通过降低幸运的方法增加敌人所受伤害，其实也就等于是提高了我方部队的杀伤能力。既然与血暴有类似效果，作用面更广（对远程攻击也起作用），增强比例还更大，群体厄运作为四级魔法也是实至名归了。

五级魔法

末日审判（Armageddon）
派系：混乱
类型：杀伤类
    攻击战场上的所有部队，不分敌我，不包括施法者本人在内。魔法参数：40/4，计算出的数值为魔法杀伤力。此魔法使用时不消耗魔法值
    虽然很多人对四代中末日的威力都颇有微词，但在英雄上阵的现实下，能够攻击全屏的末日，威力基数确实很难再加强了。与野兵交战时，带几队杂兵让敌人分组，然后狂放末日的战术相当常用，不耗魔法值大大提高了其实用性，在攻城时也有很好表现。不能享受魔法祝福的黑龙，在末日战术中则可以充分体现重要性。

连环闪电（Chain Lightning）
派系：混乱
类型：杀伤类
    攻击敌人部队以及邻近的几只部队，伤害力逐次减半。魔法参数：80/8，计算出的数值为对所攻击的第一支部队的杀伤力
    作为五级魔法来说，连闪的威力设定得有点低，不能与灾祸魔法相结合，是最大遗憾。在实用性上，位居末日与碎裂之后是毫无疑问的。

碎裂（Disintegrate）
派系：混乱
类型：杀伤类
    攻击单个敌人的魔法，被碎裂杀死的敌人将不能复活或是用来制造亡灵。魔法参数：110/11，计算出的数值为魔法杀伤力
    碎裂的杀伤力无疑是巨大的，配合灾祸就更加恐怖。充分利用其杀掉敌人无法复活的特性，可以给敌人的既定计划以沉重打击。
    在双方兵力都不是非常强的情况下，碎裂无疑可以发挥重要作用。但若是战事拖延时间较长，兵力积攒到一定程度之后，其表现就不如那些祝福类、诅咒类魔法了。不过这也是所有杀伤类魔法的通病，而且并不是四代所独有的问题。对于这个陈年问题，大家都已是心知肚明，实在没有必要再老生常谈了……


生命魔法

一级魔法

疗伤（Bind Wound）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，魔法参数：30/3，计算出的数值为治疗的生命点数
    疗伤的作用在于延长部队存活的时间，其效果的实际大小并不仅仅看法术的威力，而且还要看受治疗部队的防御力。生物或英雄的防御力越高，疗伤的使用就显得越加有价值。虽然法术参数与魔箭相当，但对防御力远高于敌人攻击力的部队来说，受到救助比直接消灭那么点敌人更加合算。
    生命族若在开始阶段有高防御的英雄（可以考虑招募邻族的射手），配以适时的治疗类魔法，便可大胆前去牵制敌人部队，为我方部队（主要是远程）的攻击争取到足够的时间。

祝福（Bless）
派系：生命
类型：祝福类
    让单个部队伤害力最大化，此魔法对亡灵生物无效
    生命族部队的伤害值上下限一般都遵循2：3的比例，伤害值最大化也就意味着杀伤能力提高(3-2.5)÷2.5×100%＝20%，这个提高比例要低于精准或嗜血的25%。但考虑到祝福对近战和远程部队都能起作用，用处还是基本相当的。

驱魔（Exorcism）
派系：生命
类型：祝福类
    解除本方单个部队身上的所有负面魔法。但是不能用来解除中毒和瘟疫状态。
    解除本方部队所中的诅咒类魔法，充分体现了生命系魔法以保护为主要作用的特色。因为本族状态类魔法几乎全是祝福性质的，因此驱魔在使用上的有的放矢便可发挥最佳作用。

（Spiritual Armor）
派系：生命
类型：祝福类
    使单个部队近战防御力和远程防御力提高25%
    虽然从效果上来看不如模糊，但同时增加近战和远程防御力却使精神护甲的适用范围要大大强于模糊，因此25%这个比例还是可以令人满意的。此类魔法的使用，可以间接提升疗伤类魔法的效用。

圣言（Holy Word）
派系：生命
类型：杀伤类
    打击单个死亡系生物，魔法参数：45/4，计算出的数值为魔法杀伤力
    单从伤害力来看，无疑是一级魔法的翘楚。不过因为使用对象有严格要求，因此这个设定也可以让人接受。用来杀伤防御力高生命值低的幽灵，是最合适不过了。需要注意的是其打击对象并不仅限于亡灵，死亡系的其余生物也包括在内。

召船（Summon Ship）
派系：生命
类型：冒险魔法
    召唤一艘船，要求本方必须有船
    本方必须有船的前提条件，令此魔法不像三代那样神通广大，只能算是一个普通的一级魔法。但在有些战役中，为了维护剧情的严谨性，会特意去禁止这个魔法。

二级魔法

天堂之盾（Heavenly Shield）
派系：生命
类型：祝福类
    在战斗中制造一面护盾保护施法者本人，所受的伤害由护盾承受。魔法参数：50/5，计算出的数值为护盾的生命点数
    魔法威力与医疗相当，但有些时候却更加好用。因为医疗不能超越英雄生命值上限，如有多余的点数，只能被舍弃，天堂之盾就不存在这个缺点（但如果敌人会驱散或废除，优点就变成了缺点）。因为只保护英雄自身，其实际价值完全要看英雄防御力的高低来决定。

防护（Defender）
派系：生命
类型：祝福类
    使本方所有部队在采取防御姿态时近战和远程防御力提高50%。采取防御姿态原本就可以提高25%防御力，再加防护魔法，提高的防御力是125%×150%-1=87.5%
    相当有争议的一个魔法。只能在采取防御姿态时起作用已经决定了其局限性，在不少情况下都是无用的魔法，但在条件合适时却无疑是个好魔法。
    高防御部队顶上前去牵制敌人，后方远程部队奋力射击；部队整体移动力不足，或是攻城的时候，靠高防御部队站前排挡箭，等敌人弹药耗光时再作行动；面对强敌时高防御英雄上阵，加一堆保护类魔法后躲到角落里，靠反击磨死敌人……以上都是生命族在兵力不强时可以考虑使用的战术，稍加变化还可以衍生出更多战术。在这些战术中，降低所受伤害的魔法和治疗类魔法是令战术意图最终实现的必要条件，受伤速度和治疗速度的比例，决定了这些战术是否具备可行性。作为能降低所受伤害的魔法中的一员，防护对实现战术意图有着重要的影响。有时正是这一个因素的加入，令不可能变得可能；或者至少起个降低魔法值消耗的作用，延伸部队的可持续战斗力。
    在使用防护时，需要注意一些问题。若高防御英雄与生命魔法英雄是同一人，那么再生魔法很多时候是必要的，否则时不时放弃防御状态来治疗，会令防护的作用大打折扣。如果有两个英雄分别负责牵制和治疗，那么防护的适用范围就会大很多。魔法等级低恰恰是防护魔法的一大优势，随便招个副英雄来用，或许就能给主英雄以很大帮助。
    总而言之，防护在一定条件下是对相似作用魔法的一种有益补充，要有合适魔法、英雄的配合才能充分发挥作用，否则就是废魔法。对英雄使用，比对生物使用更好，因为英雄可以达到更高的防御力。用它来对付野兵，比对付有英雄带领的部队效果好。虽然在与人对战的决战中起不到作用，但对战中其实大部分时间也是在与野兵交战，对付野兵有效也许就意味着发展快，意味着在决战时兵力能够占优。从这个意义上来看，可以算一个好魔法。

医疗（Heal）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，另外解除部队的中毒与瘟疫状态，魔法参数：50/5，计算出的数值为治疗的生命点数
    作为疗伤的强化版本，医疗在效率上更胜一筹，并且拥有解除中毒与瘟疫状态的效果，无疑是重要的二级魔法。

报偿（Retribution）
派系：生命
类型：祝福类
    使敌人部队攻击本方部队时也要遭受一定伤害。与三代的火盾相似，但火盾是按比例将所受伤害的一部分反射给敌人，而报偿所反射的伤害只与施法者能力有关，与所承受的伤害大小无关。魔法参数：10/1，计算出的数值为反射伤害的威力
    魔法威力与火焰结界相同，但报偿的作用却更强一些。因为一般兵种一回合顶多能有一次攻击加一次反击，而受攻击的次数完全可能多于两次。高防御英雄配合保护和治疗类魔法，即使站在敌人堆中也可以坚持很长时间，多个回合下来之后，报偿所累积的伤害值也是相当可观的。尽管如此，作为二级魔法，感觉威力还是偏低了一点，如果能设高些，会更加好用。

殉难（Martyr）
派系：生命
类型：祝福类
    将本方一支部队承受的伤害转移到另一支部队身上
    利用本方不同部队防御力上的区别，来选择转嫁伤害的对象，是使用此魔法的基本准则。四级兵、十字军或是英雄冲锋陷阵时，将所受伤害转嫁到后方侍从或农民身上，是最常见的用法，可以有效减少高级兵的损失。
    对于掌握了召唤魔法的高防御英雄来说，用殉难来配合召唤是相当好的一个战术，可以大大加强英雄的抗打击能力。当然，召唤出来的生物首先要能够保证自身安全，否则容易成为被追打对象，因此与殉难配合的召唤生物基本上都是高速的飞兵。

混乱抵御（Chaos Ward）
派系：生命
类型：祝福类
    使部队对混乱魔法有50%抗性，并且在面对混乱系部队攻击时，近战防御力和远程防御力提高50%
    效果很强、却带着明显局限性的魔法，如果你的主要敌人不是混乱族，那么这个魔法有什么用处呢？二级魔法塔总共才3个位置，生命二级魔法却有足足11种，出现了不想要的Ward魔法时，简直会让人产生把魔法塔拆掉的冲动。其余几种抵御，包括它们的群体版本，也存在同样问题，所以没有必要逐一加以详细解说。

死亡抵御（Death Ward）
派系：生命
类型：祝福类
    使部队对死亡魔法有50%抗性，并且在面对死亡系部队攻击时，近战防御力和远程防御力提高50%

自然抵御（Nature Ward）
派系：生命
类型：祝福类
    使部队对自然魔法有50%抗性，并且在面对自然系部队攻击时，近战防御力和远程防御力提高50%

守序抵御（Order Ward）
派系：生命
类型：祝福类
    使部队对守序魔法有50%抗性，并且在面对守序系部队攻击时，近战防御力和远程防御力提高50%

和平之歌（Song of Peace）
派系：生命
类型：诅咒类
    影响英雄视野范围内的单个生物，使其一回合不能主动攻击和施展诅咒类魔法
    虽然是生命魔法，但这个魔法的出名却是因为守序的灯神。英雄使用时，不具备灯神那种每仗过后魔法值就自动补满的优势。而且缺少魔力闪光配合，生命族也很难向混乱族看齐，组织起所谓的“牧师群”。
    与作用相似的混乱、蜂群魔法相比，和平之歌不能真正封住敌人行动是最大劣势，唯一优势只剩下不会被魔镜反弹这一项了吧？但不管怎么说，能够压制敌人一部分实力的发挥，和平之歌还是一个好魔法，只是可持续使用性不强。

振奋（Mirth）
派系：生命
类型：祝福类
    使单个部队获得最高士气（+10）
    部队士气最高，也就意味着保证出现士气高涨，不但提升行动优先顺序，而且还加强了攻击力。行动优先度提高，结合等待战术，实在有太多利用价值，因此振奋魔法的重要性也就勿需质疑。

三级魔法

天国护甲（Celestial Armor）
派系：生命
类型：祝福类
    使本方所有部队近战防御力和远程防御力提高25%
    精神护甲的群体版本，加强防御力也就是降低所受伤害，让部队的生存时间得到了延长。

圣唱（Holy Shout）
派系：生命
类型：杀伤类
    对战场上所有死亡系生物造成伤害（不分敌我），魔法参数：30/3，计算出的数值为魔法杀伤力
    威力居然比位居一级的单体魔法更低，感觉有点奇怪，为什么不像火球那样将基础威力定为40呢？虽然是攻击所有部队，但不能伤害到英雄，还是不能和末日审判相比较，因此参数设高点也不见得会影响平衡。而生命系与死亡系的实力差距，正需要一个比较强的针对性魔法来弥补。

群体祝福（Mass Bless）
派系：生命
类型：祝福类
    使本方所有部队的伤害力最大化。
    对近战或远程部队都能起作用的优势，在群体魔法中就充分体现出来了。从本族兵种的搭配情况来看，群体祝福的效果与血暴基本相当，实用性都要明显强过群体精准。

群体医疗（Mass Heal）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：25/2，计算出的数值为治疗的生命点数
    魔法威力稍微有点低。但既然不能复活部队，那么这样的威力也就算是可以了，反正四级兵也不见得有多少血。能够给全体解毒是其最大用处，正好用来对付死亡系的瘟疫。

再生（Regeneration）
派系：生命
类型：祝福类
    使部队每回合自动恢复一定生命值，魔法参数：20/2，计算出的数值为每回合自动恢复的生命点数
    因为威力较低，所以加给高防御的英雄要比加给兵种更合适。每回合都能恢复的持续性，是再生魔法的最大亮点。如果与一堆保护类魔法相结合，有可能产生敌人打的速度还没再生恢复速度快的局面，这也就意味着英雄永远打不死了。若能做到，兵就没必要带了，避免决战前的无谓损失。

四级魔法

群体驱魔（Mass Exorcism）
派系：生命
类型：祝福类
    解除本方所有部队所附着的负面魔法。但是不能用来解除中毒和瘟疫状态。
    在驱除类魔法（驱散、驱魔、废除）中，这是唯一一个4级魔法，感觉并不公平。群体驱散是把双刃剑，设为三级尚无可厚非，但群体废除有什么理由比群体驱魔低一级呢？而且身在生命魔法塔的群体驱魔，还要和一堆不知道有用没用的群体抵御抢位置，无趣了点。

群体振奋（Mass Fervor）
派系：生命
类型：祝福类
    将本方所有部队的士气提到最高点。
    可以说是最有用的生命四级魔法了，全体提高行动优先度，意味着常常可以在等待后全员连续围攻敌人两次，给敌人造成的打击是相当沉重的。

祈祷（Prayer）
派系：生命
类型：祝福类
    战场上所有生命系部队生命值和攻击力提高25%，不分敌我
    感觉作用比群体振奋稍差一些。祝福时不分敌我倒是小问题，注意点就好了。提高攻击力25%和振奋的作用是一样的，而提高生命值25%感觉就不如提高行动优先度来得有效。如果祈祷同时还能有加速效果的话，那就完美了。

群体混乱抵御（Mass Chaos Ward）
派系：生命
类型：祝福类
    使本方所有部队获得混乱抵御状态

群体死亡抵御（Mass Death Ward）
派系：生命
类型：祝福类
    使本方所有部队获得死亡抵御状态

群体自然抵御（Mass Nature Ward）
派系：生命
类型：祝福类
    使本方所有部队获得自然抵御状态

群体守序抵御（Mass Order Ward）
派系：生命
类型：祝福类
    使本方所有部队获得守序抵御状态

五级魔法

神圣介入（Divine Intervention）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：50/5，计算出的数值为治疗的生命点数。不复活死亡部队，复活英雄，但要在魔法威力超过英雄生命值上限的情况下才能复活。如果部队接受治疗（前提是有损血），那么在补生命值同时会解除身上所有负面魔法状态，包括中毒和瘟疫。
    怎么说呢？一个作用强大，但利用率却不高的魔法吧。因为使用此魔法，需要至少有2个高等级英雄（包括生命系这个）才会有意义，这在一般地图中不容易出现，而战役中敌人又太弱了，根本用不到。可能在一些变态地图中，神圣介入才会找到施展拳脚的最好舞台。

守护天使（Guardian Angel）
派系：生命
类型：祝福类
    对一支本方部队使用后，部队获得额外的生命数。部队数量不会增加，但在遭受攻击时，被打死多少，就从“额外生命数”中取多少来复活，直至额外生命数耗完为止。魔法参数：1/0.1，计算出的数值为额外生命数。增加的额外生命数不能超过部队本身的生命数
    基本上可以说是一般地图里最有用的生命五级魔法，虽然比不上真正的复活魔法，但对四级兵使用时效果也接近了，可以大大减小战斗损失。其作用机理为：先计算损失（以剩余数量来封顶，不透支生命数），然后再从额外生命数中取相应数量来复活。
    额外生命数不能超过部队本身的生命数，是守护天使对英雄使用一次后，英雄只能自动复活一次的原因所在。不朽药水的作用，其实就是给英雄附加守护天使。

庇护（Sanctuary）
派系：生命
类型：祝福类
    使用后保护本方所有部队，受保护的部队不会遭到敌人攻击，也不会受到（我方或敌方）魔法影响。受保护部队只能做移动、等待、防御这几个动作，否则保护效果将消失。
    原先生命五级魔法中最有用的庇护，因为从2.0版本开始增加了回合限制（只维持6回合，并且在到期后3回合内不能再次使用），实用性降低了。用杂兵将箭术或魔法英雄围在角落里，避免敌人近身攻击，或是对敌人下毒后再用庇护一直防御，都是从前的实用战术。如今虽然有了回合限制，但6回合的时间也算较长了，安排得当的话能做不少事情。庇护后全体部队扎进敌阵，看准时机给敌人英雄或主力部队以重创，是庇护在对战中的应用之一。


死亡魔法

一级魔法

诅咒（Curse）
派系：死亡
类型：诅咒类
    对敌人单个部队使用，使其伤害力最小化
    诅咒魔法的实际效果，要视施法对象而定。对于最常见的伤害值上下限3：2的部队来说，就是将其杀伤力降低了20%。而受诅咒影响最大的种族是混乱城，多数兵种伤害值上下限2：1，中诅咒后杀伤力降低1/3，嗜血都补不回来。而盗贼和半兽人中招的话，杀伤力更是受损一半。
    在前两代中，诅咒魔法一直是不能对亡灵起效的，但如今这一限制条件已被取消。而祝福魔法却仍然对亡灵无效，似乎有点不公平的感觉。不过对实力强大的死亡城来说，这么一点点的不公平也不算什么。

瓦解射线（Disrupting Ray）
派系：死亡
类型：诅咒类
    使敌人部队近战和远程防御力降低20%
    20%这个比例，和诅咒对一般兵种杀伤力的降低幅度一样。一个降攻，一个降防，两个魔法还真是配。

毒害（Poison）
派系：死亡
类型：杀伤类/诅咒类
    使敌人部队每回合自动损失一定生命值，从施法的当前回合开始生效。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值
    虽然伤害值不高，但毒害还是很实用的一级魔法。对于敌人受保护的后排射手或英雄施毒，虽然对敌人总体战力的损伤速度较慢，但还是有用的。而若是配合二级魔法疲劳，单英雄上阵便可以耗死强大的敌人，虽然基本上只能用来对付有生命的步兵，但依然具备相当实用性，只是战斗过程未免太漫长了些。

驱役骷髅（Raise Skeletons）
派系：死亡
类型：召唤类
    利用我方或敌方的阵亡部队制造骷髅，可以对尸体或是损失了一部分的部队使用。制造出的骷髅数量不能超过阵亡部队的数量，骷髅生命总值也不能超过阵亡部队的生命总值，战斗结束后制造出的骷髅会自动消失。魔法参数：40/4，计算出的数值为驱役出的骷髅的经验总值。
    驱役骷髅的效果与自然的一级召唤魔法差不多。骷髅本身实力是很弱的，指望英雄制造出来的那点骷髅与对方死拼，是很难有理想结果的（一定数量的法师来制造还差不多）。此魔法的可用价值基本上就是那么一点：利用骷髅的高远程防御力来抵挡箭枝，对付低级远程兵效果还是不错的。

废除（Cancellation）
派系：死亡
类型：诅咒类
    解除敌人单个部队身上附着的所有正面魔法，可以用来直接驱除敌人操纵的尸体和幻象副本。可以用来去除敌人宗师抗魔英雄身上的正面魔法
    与驱魔类似，魔法作用切合了本派系其余魔法的特点。死亡系状态魔法以诅咒类为主，削弱敌人实力后又用废除打压敌人东山再起的希望，让敌人辛辛苦苦积攒起来的祝福类魔法瞬间消失，作用也未免太强了些。

二级魔法

疲劳（Fatigue）
派系：死亡
类型：诅咒类
    使敌人单个部队速度和战场移动力减半，适用范围比迟缓窄，因不能影响亡灵和机械，但可影响元素
    好用程度不及迟缓，但很多时候也是非常有用的。适用范围上的限制条件，使得死亡城最不愿意面对的敌人恰恰就是亡灵，想起来都有点好笑。

邪恶之歌（Unholy Song）
派系：死亡
类型：诅咒类
    使战场上所有的生命系部队攻击力和防御力减少20%，不分敌我
    虽然也叫“歌”，但与和平之歌不同，不是精神类魔法，因此在使用上不受多少限制，只是对弩车无效而已。在面对生命系敌人时，可以近似看作同时具备群体诅咒和群体瓦解射线（虽然没有这个魔法）的效果，作用显然超乎其二级地位，一个字：强！适用范围太窄是魔法等级不高的根本原因。

吸取生命（Life Drain）
派系：死亡
类型：杀伤类
    对战场上所有生命系和自然系部队造成伤害，不分敌我，损失的生命值全部吸取到施法者身上，可以累加超过施法者的生命值上限。魔法参数：10/1，计算出的数值为每个部队所受的伤害
    适合给防御高的英雄使用，当敌人分组多的时候，效果可以超过医疗魔法。不过亡灵巫师的升级常常是直奔宗师招魂而去的，在此之前很少考虑战斗技能，加上使用对象有限制，此魔法的使用率并不高。

操纵尸体（Animate Dead）
派系：死亡
类型：召唤类
    复活敌方或我方阵亡的生物，可以对尸体或是损失了一部分的部队使用。复活出的生物属性为亡灵生物，受我方控制，战斗结束后自动消失。魔法参数：50/5，计算出的数值为复活的生物的生命值。
    和守序的幻象魔法相似，都是以生命值来计算魔法效果的，魔法参数稍高一些。但因为只能对阵亡部队使用，不像幻象可以凭空制造，因此两者效果还是基本相当的。法术威力本身并不太高，需要阵亡部队有不错的特技或魔法时，操纵尸体才会有比较强的使用价值。

泥潭（Mire）
派系：死亡
类型：冒险魔法
    使敌方部队在地图上的移动力减半，只能对施法者附近的敌人使用，效果维持一天
    死亡系的优势魔法之一，降低敌方部队地图移动力，对于追击或是逃避追击都有极强的实用性。而敌人中招之后没有任何办法可以消除其不良影响。

虚弱（Weakness）
派系：死亡
类型：诅咒类
    使敌人单个部队攻击力减少25%
    从结果上来看，降低敌人攻击力，可以近似认为减少本方所受伤害。与幸运的1/3相比，虚弱的减少25%有点偏弱了，不算一个很称职的二级魔法。当然，两种魔法的作用对象不同，有时是不能这样简单比较的。

悲泣（Sorrow）
派系：死亡
类型：诅咒类
    使敌方单个部队士气降到最低（-10）
    从降低攻击力的角度来看，只是20%，不如虚弱。但降低敌人出手优先度所带来的影响，可绝不是这区区5%差别所能够体现的。因此悲泣魔法的使用优先程度往往要高于虚弱，对无生命部队一样可以产生效果是虚弱的唯一优势。

三级魔法

群体诅咒（Mass Curse）
派系：死亡
类型：诅咒类
    使敌人所有部队处于受诅咒状态
    具体效果大小视施法对象而定，有时会比四级的群体虚弱更强。

瘟疫（Plague）
派系：死亡
类型：杀伤类/诅咒类
    使战场上所有部队中毒，不分敌我，包括施法者在内。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值。此魔法对无生命的部队或死亡系部队无效
    瘟疫的实用性可比毒害强多了。毒害多半用来制造无赖打法，而近似于群体毒害的瘟疫，却可以切切实实地给敌人部队以实质性影响，解除上的不易（只有几个治疗类魔法可消除），令瘟疫很容易延续较长时间，从而累积出相当不错的伤害值。另外，瘟疫和毒害状态是可以同时存在的，这就容易给敌人更大打击。在没有什么杀伤类魔法的死亡城，战斗一开始就使用瘟疫是个不错的选择。

驱役幽灵（Raise Ghost）
派系：死亡
类型：召唤类
    利用阵亡部队制造幽灵，魔法参数：150/15，计算出的数值为驱役出的幽灵的经验总值，其他细节与驱役骷髅相似
    基本上就是死亡系最实用的三级魔法。制造幽灵的目的，几乎都是看重其老化能力。与疲劳之类的减速类效果相配合，可以把高移动力兵种玩弄于股掌之上。

恐惧结界（Aura of Fear）
派系：死亡
类型：祝福类
    对本方单个部队使用，使其在攻击时可以不受敌人反击，除非敌人对死亡魔法、恐惧或精神类魔法有抗性。此魔法效果类似于骨龙的“引起恐惧”技能，但不能使敌人后退，在反击时不具备“引起恐惧”的奇效。
    许多时候可以产生不受反击的效果，是个很好的魔法，最适合与具备满屏移动能力的恶魔相配合。

群体废除（Mass Cancelation）
派系：死亡
类型：诅咒类
    解除敌人所有部队身上附着的正面魔法，可以用来直接驱除敌人操纵的尸体和幻象副本
    设定得有些失当的魔法。不管对方的正面魔法等级多少，就算是守护天使、龙之力量这样的高级货，一样难逃一抓，而且这还只是一个3级魔法。即使等级设定再高，其效果也是过分了的，因为不少高级祝福魔法都只是单体的，辛辛苦苦练半天，难道就是为了挨这一抓么？而且要注意，废除是可以用来解除宗师抗魔英雄身上的正面魔法的。
    其实驱除类魔法都存在效果过强的问题，只是在废除上体现得更加明显而已。如果将其作用改为：第一次使用时只把对象魔法效果减半（例如龙之力量减为生命值、伤害值加半，守护天使附加生命值减半等等），在此状态下再次使用驱除类魔法才能将对象魔法效果完全解除，可能会更合理些。当然，这只是我的瞎想而已。

榨取魔力（Magic Leech）
派系：死亡
类型：诅咒类
    使敌人部队在施法时要花双倍魔法值，并且将所消耗魔法值的一半转移到施法者身上
    与守序的能量损耗相仿，不能立刻产生实质性效果，需要在充分考虑战局走向后再使用。能够有吸取效果是其优势所在，此消彼长后敌人魔法英雄的作用就大大受抑制了。利用吸血鬼群产生的压迫力令对方英雄无暇去解除此魔法，使榨取魔力的实用性要高于能量损耗。单机游戏中，常常能看到电脑英雄使用，有时还是非常令人讨厌的。

四级魔法

群体虚弱（Mass Weakness）
派系：死亡
类型：诅咒类
    使敌人所有部队处于虚弱状态
    总觉得作为四级魔法稍微有点不够格，如果对攻击力的降低比例再提高些，可能会比较好。

群体悲泣（Mass Sorrow）
派系：死亡
类型：诅咒类
    使敌人所有部队士气降到最低
    作为与群体振奋效果对冲的魔法，其相克性是十分明显的，使用时机得当的话，可以产生比预期中更好的效果。

死亡呼唤（Death Calls）
派系：死亡
类型：召唤类
    作用与操纵尸体相似，但魔法参数是90/9
    操纵尸体魔法的加强版本。和操纵尸体一样，复生阵亡部队时看重的往往不是其战力，而是其辅助特性。亡灵复生类魔法和驱役类魔法一样，都切忌对本方损失一部分的吸血鬼使用，因为那会减少吸血鬼的尸体数量，从而使其在吸血后无法恢复到原始数量。

吸血鬼接触（Vampiric Touch）
派系：死亡
类型：祝福类
    对本方部队使用，使该部队在对敌人进行近身攻击时自动治疗创伤，恢复的生命值是攻击伤害的一半
    死亡魔法少有的祝福类魔法之一，但却是整个游戏中最强的祝福类魔法之一。给强力部队增加吸血能力，在英雄复活魔法已经取消的四代里，有着极其独特的优越性。使用对象的无限制性，可以让原本连治疗都不能享受的亡灵、元素、机械获得复活的能力，不管怎么说也太变态了一点。幸亏对于攻击对象还有要求，对方必须有生命，才能从它身上吸血。在大兵团作战中，吸血鬼接触有着无可替代的作用，即使提升为五级魔法，也不为过。

五级魔法

牺牲（Sacrifice）
派系：死亡
类型：祝福类
    消灭本方一只部队来复活其他部队，复活的生命值是消灭部队生命值的两倍。所消灭的部队不能是召唤类魔法制作出来的生物
    魔法效果是强的，但不能牺牲召唤出来的生物，限制了魔法的作用。牺牲低级部队来复活高级部队，是很自然的使用方法，但死亡城低级部队生命值都太低，一周生产的低级兵也仅够用来复活那么几个高级兵，很难持续使用。或许这个魔法仅在艰苦决战中才会充分体现价值，能复活英雄也是其少数亮点之一。

驱役吸血鬼（Raise Vampires）
派系：死亡
类型：召唤类
    利用阵亡部队制造吸血鬼，魔法参数：375/37，计算出的数值为驱役出的吸血鬼的经验总值，其他细节与驱役骷髅相似
    魔法参数和五级召唤魔法一样，但作用就差了那么点。主要是必须先制造阵亡部队，然后才能加以驱役，有时候差这么一回合是很要命的。而且驱役吸血鬼是三种驱役魔法中唯一可以被直接驱散、废除的，进一步降低了实用价值。

死亡之手（Hand of Death）
派系：死亡
类型：诅咒类
    直接杀死一定数量的敌人，施法对象必须在英雄视线内。魔法参数：1/0.1，计算出的数值为所能杀死的敌人数量
    在对付四级兵的时候，其杀伤效果往往比碎裂更强。其作用与守护天使相比，刚好一反一正，威力相同，充分体现了死亡与生命的对立。但是死亡之手的出镜机会还是比守护天使差一些，因为亡灵巫师基本上都要投5个技能点在招魂技能上，没那么容易达到魔法宗师。而且若敌人也是死亡城，死亡之手便很难有用处了。


自然魔法

一级魔法

寻路（Pathfinding）
派系：自然
类型：冒险魔法
    使部队在任何地形上移动时都不会受到额外的损耗
    相当好用的辅助魔法，进一步强化了自然城行军快速的特点。每天使用一次便能对整支部队产生影响，只是在部队有新成员加入时需要再次施法，避免新成员拖慢整支部队的行动。

加速（Speed）
派系：自然
类型：祝福类
    使部队速度和战场移动力+3
    效果和混乱系的疾速完全相同，二者不可叠加。由于妖精的存在，自然英雄战斗中给自己加速，逃避敌人追击是常有的事情，魔法使用率比混乱城高。

护体石肤（Stoneskin）
派系：自然
类型：祝福类
    使单个部队近战和远程防御力提高25%
    和生命的精神护甲效果相当，但两者可叠加。若不学治疗类魔法，作用要比在生命城堡中的小一些。

地形认知（Terrain Walk）
派系：自然
类型：祝福类
    使部队在战场上移动时不会受到不良地形的额外损耗，可以忽略流沙的阻挡效果。
    在雪地、沼泽、沙漠等不良地形上战斗时，地面部队的移动范围要大大受影响，此时地形认知可以给它们以相当大的帮助。但这还不算是地形认知的最佳应用，与流沙配合方能将其作用发挥到极致。用流沙阻挡敌人时，也限制了本方部队的移动范围，被渐渐逼入死角的感觉可不好受。为了调动敌人，经常要让妖精到处飞来飞去，步骤十分烦琐。有了地形认知后，一切便都省心了。

召唤丛林妖精（Summon Leprachaun）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的丛林妖精，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的丛林妖精的经验总值。
    召唤丛林妖精来使用幸运魔法，不仅仅是节省1点魔法值的区别，在利用了其幸运之后，还可以用来挡箭或是骗反击，充分榨干其每一分利用价值。这个魔法，算是最常用的一级召唤魔法了。

召唤妖精（Summon Sprite）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的妖精，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的妖精的经验总值。
    妖精的高移动力和不受反击特性，常常被利用来与低移动力步兵打游击战。偏低的攻击力使得这种游击战往往过程漫长，这时英雄若能召妖精，便会大大加快战斗的进程。当然，这种场合下最好要有加速或是流沙相辅助，以保证英雄安全。
    在英雄与野兵的单挑中，利用妖精的高移动力来调动敌人（飞到敌人后方送死，将敌人向远处调动）是常有的事情，即使在后期战斗中这个一级召唤魔法也相当有用。

召唤狼（Summon Wolf）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的狼，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的狼的经验总值。
    狼的实力较强，但经验值也相应较高，在以经验值为准绳的召唤魔法中，召唤狼的数量要比召唤妖精的数量少不少。召唤次数少时，根本形不成威力；要持续召唤，又必须现实条件配合（敌人移动力低，或是有加速、流沙魔法保证英雄安全）。与妖精“有多少便可用多少”的情形不同，狼的数量若达不到一定规模，就不敢与敌人交火，这使得召唤狼的实用性比召唤妖精差了不少。在合适时发挥骗反击的效果，才是召唤狼的常见用途。

召唤恶魔之子（Summon Imps）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的恶魔之子，战斗结束后召唤的恶魔之子自动消失。魔法参数：125/12，计算出的数值为召唤出的恶魔之子的经验总值。
    最基本的魔鬼类召唤魔法，虽然是一级魔法，但从施法消耗和魔法威力上来看，都是与三级魔法相当的。效率上已经比普通一级召唤魔法高了，而魔法威力大使得召唤出来的恶魔之子可以很快形成数量上的优势，不需要漫长的积累过程，能较快地派出去与敌人交火。吸取魔力的特技有时会有用处，而利用恶魔之子生命值与经验值比例较高的特性，将其作为殉难魔法伤害转嫁的对象，也是常见应用之一。
    由于学习前提要求太高，魔鬼类召唤魔法在实战中出现的机会并不多。但只要有机会学到，利用率是相当高的。

二级魔法

巨人力量（Giant Strength）
派系：自然
类型：祝福类
    使单个部队生命值和伤害力提高25%
    很多时候，巨人力量的效果比祝福和护体石肤两个魔法的效果综合起来还高一些，因此其定位为二级魔法是完全恰当的。

幸运（Fortune）
派系：自然
类型：祝福类
    将单个部队幸运提升到最高（+10）
    相当于将部队的抗打击能力提高了1/2，效果相当强劲的一个魔法。

流沙（Quicksand）
派系：自然
类型：--
    在战场上制造一定长度的流沙，敌人地面部队踩上流沙之后将会停止移动。所有站在流沙上的部队，近战攻击力下降25%（远程攻击力不受影响），防御力下降20%。流沙的基本长度是20英尺。
    可以大大阻碍地面部队行动的魔法，虽然应用范围有局限性，但仍然是游戏中最出色的魔法之一。游戏早期若由英雄来用，效果不是太好，因为流沙长度不够而对高移动力步兵产生不了太大的阻碍作用，而且连续施放魔法值消耗太大。中早期流沙的作用主要由水元素来体现，既可以分多组进行施放，又有疲劳魔法加以辅助。如果有足够耐心，从理论上来说配合妖精就可以消灭几乎所有类型的步兵了。当然在布沙方面也要讲求技巧，满屏流沙是完全没有必要的，一般情况是在战场中央布较厚一层，然后在战场右上角布较薄一层，利用妖精里外来回飞行令敌人走位无所适从，确保战场下方我方主力的安全。到了游戏后期，技能出众的英雄可以布出40英尺左右的流沙，其作用要明显强于水元素的流沙。但水元素仍然在很多时候需要用到，一般是利用召唤魔法获得。

蜂群（Wasp Swarm）
派系：自然
类型：诅咒类
    使敌人部队丧失一回合的行动机会，不能影响机械或亡灵生物，但是可影响元素
    在相似的几个魔法中，是最强的了，与混乱相比，多出了元素这一作用对象。用此魔法，要注意尽量别让敌人最主要部队分组，以便于单独控制，我方其余部队杀掉较弱敌人后，最后再集中围攻最强的一队。

蛇击（Snake Strike）
派系：自然
类型：祝福类
    使本方单个部队获得“抢先攻击”状态
    作用与混乱系的抢先攻击魔法完全一样，只是因为属于不同派系，所以才换了一个名字。

召唤精灵（Summon Elf）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的精灵，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的精灵的经验总值。
    因为只是二级召唤魔法，威力并不大。早期一般就只能召唤那么几个精灵，若没有水元素的流沙战术配合，很难在敌人接近前积累起足够数量。与流沙战术配合，倒是很实用的，但在精灵积累一定数量之前，尽量不要出手，以免无谓消耗弹药数。

召唤白虎（Summon White Tiger）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的白虎，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的白虎的经验总值。
    与一级的召唤狼相类似，兵种实力强但难以积累数量是最大不利因素。但白虎的高移动力却比狼更有可用性，在对付野外低级远程部队时，召唤白虎扑上去，其余部队跟在后面推进，是一种可行的应用。

召唤半羊人（Summon Satyr）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的半羊人，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的半羊人的经验总值。
    相当实用的魔法。与召唤丛林妖精相似，召唤并不是看重兵种本身的战力，而是看重了其魔法。振奋对行动顺序影响的重要性不多说了，半羊人能够施展两次振奋，让这个召唤变得相当合算。

召唤地狱犬（Summon Cerberi）
派系：自然
类型：召唤类
    在战斗中召唤一定数量地狱犬，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的地狱犬的经验总值。
    威力相当大，相当于普通的四级召唤魔法。合理安排战术，可以在敌人冲到我方附近之前积累差不多三次地狱犬，充分利用地狱犬的三头攻击，战胜实力两倍于其的敌人，不是太困难。相信对于此魔法的好用程度，打过半生者战役的玩家都应该有印象。

三级魔法

防魔（Anti-Magic）
派系：自然
类型：祝福类
    使单个部队在战斗中免疫所有魔法，使用后原先附着在该部队身上的魔法状态会立即消失（不包括宝物、职业附加的状态，此外也不能去除中毒与瘟疫），附加在幻象副本或是操纵的尸体上时，会让它们立刻消失。
    敌人若有强力杀伤魔法，或是强力诅咒类魔法，防魔的重要性便无可替代。虽然会让部队无法享受祝福类魔法的帮助，但权衡利弊，有时是必须作出的抉择。需要注意的是，对英雄使用后就会消除不朽药水的守护天使效果，若战死便不能复活了，一定要更加谨慎地加以保护。

群体加速（Mass Speed）
派系：自然
类型：祝福类
    使本方所有部队速度和战场移动力+3
    单体的加速魔法，混乱系与自然系都有，但群体加速就只是自然系所独享的了，从这一点来说，是自然的一个优势。

招魂抵御（Necromancy Ward）
派系：自然
类型：祝福类
    阻止操纵尸体和驱役亡灵类魔法在战场上的使用。
    使用此魔法后，不仅禁止了上述两类魔法的使用，而且已经操纵或驱役出来的部队，也会立刻消失。看得出，此魔法是专门用来克制死亡城的，正如守序的驱逐专门用来克制自然城一样。在游戏前瞻中，此魔法同时属于自然系和生命系，不知道为什么最后会从生命魔法中被剔除。

召唤火元素（Fire Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的火元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的火元素的经验总值。
    三级召唤魔法的威力是二级召唤的两倍，也就是从这一级开始，召唤部队的战力开始体现。作为远程部队，召唤出来的火元素表现还是相当不错的。虽然射击威力很多时候都不如水元素的冰箭，但水元素经常都有很多事要做，两种元素都召，可以形成不错的搭配组合。

召唤水元素（Water Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的水元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的水元素的经验总值。
    最为重要的召唤魔法之一，其战略价值比起五级召唤术也不会差上多少。疲劳和流沙是步兵的天敌，而如果合理配合召唤妖精（妖精调动敌人+水元素疲劳+冰箭），可以轻易对付除凤凰/仙女龙/黑龙/骨龙/吸血鬼/幽灵之外的所有飞兵，这样水元素所不能对付的敌人就相当少了。而在面对远程部队时，适时召一次水元素，疲劳+虚弱，对战斗也是有相当帮助的。注意重复召唤水元素时，其魔法值会自动补满，因此其冰箭魔法的可持续杀伤力是相当强的。

召唤风元素（Air Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的风元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的风元素的经验总值。
    风元素高防御、高移动力的特征，最适合用来压制敌人远程部队。综合防御力来看，其战斗实力也是相当不错的。

召唤土元素（Earth Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的土元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的土元素的经验总值。
    防御实力不如风元素，拉出去打架又太慢，召唤土元素可以说是四大元素召唤中最不实用的了。唯一可以利用的只有其抗魔特性，用来挡敌人杀伤类魔法还有点用处。

召唤冰魔（Summon Ice Demon）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的冰魔，战斗结束后自动消失。魔法参数：350/35，计算出的数值为召唤出的冰魔的经验总值。
    相当于五级召唤魔法，冷冻成功是最希望出现的事情，但总的来说，不如一般的五级召唤魔法。

四级魔法

群体幸运（Mass Fortune）
派系：自然
类型：祝福类
    将本方所有部队幸运值提到最高
    自然系唯一的群体保护性魔法，重要性不言而喻

群体蛇击（Mass Snake Strike）
派系：自然
类型：祝福类
    使本方所有部队获得“抢先攻击”状态
    如果本族四级兵选择仙女龙，那么这个魔法的作用就比较有限（螳螂本来就有先攻），不如将施法机会让给同级的召唤魔法。

召唤狮鹫（Summon Griffin）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的狮鹫，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的狮鹫的经验总值。
    在暂时学不到五级召唤魔法的时候，这是个不错的选择。利用其无限反击的特性，召唤后丢进敌人丛中，有不错的战斗表现。

召唤独角兽（Summon Unicorn）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的独角兽，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的独角兽的经验总值。
    实用性比召唤狮鹫略逊一筹，都是在没有五级召唤时可以考虑使用的好魔法。虽然是地面部队，但战场移动力不错的独角兽，一样可以用来压制远程部队，其失明能力能够给战斗进程带来一些潜在帮助。

召唤毒蜂草（Summon Waspwort）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的毒蜂草，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的毒蜂草的经验总值。
    除了特殊的召唤食尸怪外，这就是最强的远程部队召唤术了。毒蜂草本身的实力就不错，远程特性若配合流沙魔法，可望充分发挥每一箭的威力，是个效率不错的召唤魔法。

召唤食尸怪（Summon Venom Spawn）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的食尸怪，战斗结束后自动消失。魔法参数：525/52，计算出的数值为召唤出的食尸怪的经验总值。
    施法消耗比一般五级魔法还要多，召出来的部队绝对实力也更强一些，但是学习前提实在太高，而且在施法效率上感觉不如召唤螳螂和召唤仙女龙。

五级魔法

龙之力量（Dragon Strength）
派系：自然
类型：祝福类
    使本方单个部队生命值和伤害力加倍
    祝福类魔法的颠峰之作，龙之力量的效果相当于让单个强力部队数量翻了倍，无须细说便能看出这有多么有用了。自然系的祝福类魔法虽然不多，但实用价值却都很高，夹在以保护见长的生命系和以进攻见长的混乱系之间，自然的祝福类魔法同时具备攻防两方面强化作用，这个特色在龙之力量上得以汇总。

召唤凤凰（Summon Phoenix）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的凤凰，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的凤凰的经验总值。
    单论攻防实力，凤凰并不特别出众，但利用其重生特性，可以产生一系列的应用手段。被击倒后自动重生，等于可以多吸引敌人主力部队一回合的攻击火力，为我方其余部队的行动争取到时间。而重复使用召唤凤凰，其重生数量会逐步叠加，到最后会形成战斗力相当强的一支部队。
    另外要注意到凤凰的生命值要比仙女龙和螳螂高许多，加上有复生能力，与殉难魔法配合时效果特别好。

召唤仙女龙（Summon Faerie Dragon）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的仙女龙，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的仙女龙的经验总值。
    仙女龙的主要作用在于牵制，如果要靠法术攻击的话，只能用8次魔法未免有点少。但五级召唤魔法只是作为牵制力量，感觉比较尴尬，如果能够与招募来的仙女龙相配合，就比较好。战斗开始时召唤一次牵制敌人，在战局进行到一定阶段时（敌人分队被消灭一两组），能够腾出手来就改用闪电，反正再次召唤后魔法值会补满，累加下来闪电伤害是非常可观的。

召唤螳螂（Summon Mantis）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的巨型螳螂，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的螳螂的经验总值。
    螳螂的缠身技能，不仅能够保护英雄的安全，而且也使螳螂的生存时间相对较长，便于重复召唤迅速积累数量，并能较快腾出手来使用龙力之类的祝福魔法。虽然攻击能力相对不高，但在很多时候螳螂的召唤都是最为好用的五级召唤魔法。

召唤恶魔（Summon Devils）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的恶魔，战斗结束后自动消失。魔法参数：675/67，计算出的数值为召唤出的恶魔的经验总值。
    全屏移动加上召唤数量多，用召唤恶魔来秒杀英雄是再好也没有了。但至少需要27个技能点才能学会召唤恶魔，过程实在太漫长，而且初始发展就不容易走上这条道路，要靠地图特殊设定或是天降好运了。


战斗魔法

    战斗魔法按照作用，可以分为杀伤类魔法、祝福类魔法、诅咒类魔法和召唤类魔法共4类。

    杀伤类魔法：直接对敌人造成魔法杀伤。抗魔能力如果没有提高到100%，则不能躲避杀伤类魔法，但是会降低魔法的杀伤力
    祝福类魔法：加强或保护、治疗本方部队
    诅咒类魔法：削弱敌人部队能力。抗魔能力能够使部队有一定几率躲避诅咒类魔法的影响
    召唤类魔法：直接召唤生物，或是利用阵亡部队驱役亡灵，或者是复制战场上部队的副本

    大部分的杀伤类魔法，要求施展时施法者的视线不能被阻拦，也就是说施法者与施法对象之间的直线上不能有敌人部队。单体杀伤性魔法（火矢、闪电等）都要受视线制约，而一些大范围的魔法（火球、地狱火等）虽然可以打击施法者视线外的敌人，但也要求施法中心在施法者视线内。一些全屏杀伤性魔法（末日审判、圣唱和瘟疫等）不受此限制。某些诅咒类魔法（死亡之手、失明等）也有视线制约。


杀伤类魔法

一级魔法

魔法拳（Magic Fist）
派系：守序
类型：杀伤类
    攻击单个敌人，魔法参数：20/2，计算出的数值为魔法杀伤力
    杀伤力低下的魔法，在最高难度游戏中几乎无用。当然这是对于英雄而言，法师兵种使用魔法拳，还是不可小视的。

魔箭（Magic Arrow）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：30/3，计算出的数值为魔法杀伤力
    作为一级魔法来说，其威力已经不小了，虽然在最高难度游戏中用处有限，但也不是完全没价值。

火花（Sparks）
派系：混乱
类型：杀伤类
    英雄在施展此魔法时，会走到施法对象面前，使出的魔法同时攻击面前以及恻前方与自己相邻的部队（不分敌我）。施法对象必须在英雄的移动攻击范围内。魔法参数：20/2，计算出的数值为魔法杀伤力
    相当特殊的一个魔法，其使用方式独一无二。实战中可利用率极低，因为其威力决定了只能在早期使用，早期英雄的防御力不会强，离开部队保护走上去几乎意味着送死。或许在巫师群战术中还能发挥作用，但也要能同时攻击三组敌人才比火矢合算。

圣言（Holy Word）
派系：生命
类型：杀伤类
    打击单个死亡系生物，魔法参数：45/4，计算出的数值为魔法杀伤力
    单从伤害力来看，无疑是一级魔法的翘楚。不过因为使用对象有严格要求，因此这个设定也可以让人接受。用来杀伤防御力高生命值低的幽灵，是最合适不过了。需要注意的是其打击对象并不仅限于亡灵，死亡系的其余生物也包括在内。

毒害（Poison）
派系：死亡
类型：杀伤类/诅咒类
    使敌人部队每回合自动损失一定生命值，从施法的当前回合开始生效。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值
    虽然伤害值不高，但毒害还是很实用的一级魔法。对于敌人受保护的后排射手或英雄施毒，虽然对敌人总体战力的损伤速度较慢，但还是有用的。而若是配合二级魔法疲劳，单英雄上阵便可以耗死强大的敌人，虽然基本上只能用来对付有生命的步兵，但依然具备相当实用性，只是战斗过程未免太漫长了些。

二级魔法

冰箭（Ice Bolt）
派系：守序
类型：杀伤类
    对单个敌人造成冰属性伤害，魔法参数：40/4，计算出的数值为魔法杀伤力
    守序系的杀伤魔法总共才两种，杀伤力与混乱系的同级魔法本来就有差距，又缺少巫术技能的支持，所以实在是没有多少实用价值。水元素和灯神用冰箭是正常的，英雄用冰箭的情形就比较少见了，基本上也就是用来杀敌人英雄。

火矢（Fire Bolt）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：50/5，计算出的数值为魔法杀伤力
    杀伤力相当不错的魔法，只是最高难度游戏限制了其作用。单用效果有限，需要有其他因素来配合，在巫师群战术中相当常见。

吸取生命（Life Drain）
派系：死亡
类型：杀伤类
    对战场上所有生命系和自然系部队造成伤害，不分敌我，损失的生命值全部吸取到施法者身上，可以累加超过施法者的生命值上限。魔法参数：10/1，计算出的数值为每个部队所受的伤害
    适合给防御高的英雄使用，当敌人分组多的时候，效果可以超过医疗魔法。不过亡灵巫师的升级常常是直奔宗师招魂而去的，在此之前很少考虑战斗技能，加上使用对象有限制，此魔法的使用率并不高。

三级魔法

火环（Fire Ring）
派系：混乱
类型：杀伤类
    对半径4英尺（直径9英尺）范围内的部队造成杀伤（无论敌我），位居中心的部队不受伤害。魔法参数：40/4，计算出的数值为魔法杀伤力
    除了中心部队不受伤害外，其余属性与火球一样。高防御英雄站中心，对周围敌人用火环，似乎是个不错的想法。但混乱系加战斗系技能会产生烈火战士职业，火抵抗能力本来就不怕火魔法，所以这种想法也就失却了相当的可行性。

火球（Fireball）
派系：混乱
类型：杀伤类
    对半径4英尺范围内的部队造成杀伤，魔法参数：40/4，计算出的数值为魔法杀伤力
    利用其大范围的特性，让敌人多分组后加以杀伤，是使用火球的基本常识。然而火球的作用范围要比独眼的范围攻击小一点，想同时攻击三队敌人没那么容易，因此很多时候都不如有灾祸魔法配合的闪电。

闪电（Lightning）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：70/7，计算出的数值为魔法杀伤力
    威力原本就不弱，如果再配合灾祸魔法，杀伤值的基本基数可以达到105点，很强了。若同时学会闪电和灾祸的话，我一般情况下都会让英雄暂时停止混乱系技能的学习，改而去学战斗技能，闪电在相当长一段时间内都足以撑起门面了。

圣唱（Holy Shout）
派系：生命
类型：杀伤类
    对战场上所有死亡系生物造成伤害（不分敌我），魔法参数：30/3，计算出的数值为魔法杀伤力
    威力居然比位居一级的单体魔法更低，感觉有点奇怪，为什么不像火球那样将基础威力定为40呢？虽然是攻击所有部队，但不能伤害到英雄，还是不能和末日审判相比较，因此参数设高点也不见得会影响平衡。而生命系与死亡系的实力差距，正需要一个比较强的针对性魔法来弥补。

瘟疫（Plague）
派系：死亡
类型：杀伤类/诅咒类
    使战场上所有部队中毒，不分敌我，包括施法者在内。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值。此魔法对无生命的部队或死亡系部队无效
    瘟疫的实用性可比毒害强多了。毒害多半用来制造无赖打法，而近似于群体毒害的瘟疫，却可以切切实实地给敌人部队以实质性影响，解除上的不易（只有几个治疗类魔法可消除），令瘟疫很容易延续较长时间，从而累积出相当不错的伤害值。另外，瘟疫和毒害状态是可以同时存在的，这就容易给敌人更大打击。在没有什么杀伤类魔法的死亡城，战斗一开始就使用瘟疫是个不错的选择。

四级魔法

爆裂（Implosion）
派系：混乱
类型：杀伤类
    攻击单个敌人，魔法参数：90/9，计算出的数值为魔法杀伤力
    从杀伤力与魔法值消耗的比例来看，效率显然不如闪电，如果同有魔力闪光辅助，缺点就更明显了。但有时能越快速打击对手，就对战局越有利，毕竟战斗并不是总能慢慢施法去细细计较效率的。

地狱火（Inferno）
派系：混乱
类型：杀伤类
    对半径7英尺（直径15英尺）范围内的敌人造成杀伤，魔法参数：40/4，计算出的数值为魔法杀伤力
    范围大是地狱火的最大优点，常常能够同时影响三、四支敌人部队，总体杀伤力是相当不错的。如果敌人部队实力比较平均，没有那一队需要急切消灭，那么地狱火显然要比爆裂更好用。但若敌人有快速部队，可以迅速移动到英雄身前的话，在视线被遮时地狱火的着点选择就变得比较困难，这种情况不可不防。

五级魔法

末日审判（Armageddon）
派系：混乱
类型：杀伤类
    攻击战场上的所有部队，不分敌我，不包括施法者本人在内。魔法参数：40/4，计算出的数值为魔法杀伤力。此魔法使用时不消耗魔法值
    虽然很多人对四代中末日的威力都颇有微词，但在英雄上阵的现实下，能够攻击全屏的末日，威力基数确实很难再加强了。与野兵交战时，带几队杂兵让敌人分组，然后狂放末日的战术相当常用，不耗魔法值大大提高了其实用性，在攻城时也有很好表现。不能享受魔法祝福的黑龙，在末日战术中则可以充分体现重要性。

连环闪电（Chain Lightning）
派系：混乱
类型：杀伤类
    攻击敌人部队以及邻近的几只部队，伤害力逐次减半。魔法参数：80/8，计算出的数值为对所攻击的第一支部队的杀伤力
    作为五级魔法来说，连闪的威力设定得有点低，不能与灾祸魔法相结合，是最大遗憾。在实用性上，位居末日与碎裂之后是毫无疑问的。

碎裂（Disintegrate）
派系：混乱
类型：杀伤类
    攻击单个敌人的魔法，被碎裂杀死的敌人将不能复活或是用来制造亡灵。魔法参数：110/11，计算出的数值为魔法杀伤力
    碎裂的杀伤力无疑是巨大的，配合灾祸就更加恐怖。充分利用其杀掉敌人无法复活的特性，可以给敌人的既定计划以沉重打击。
    在双方兵力都不是非常强的情况下，碎裂无疑可以发挥重要作用。但若是战事拖延时间较长，兵力积攒到一定程度之后，其表现就不如那些祝福类、诅咒类魔法了。不过这也是所有杀伤类魔法的通病，而且并不是四代所独有的问题。对于这个陈年问题，大家都已是心知肚明，实在没有必要再老生常谈了……


祝福类魔法

一级魔法

模糊（Blur）
派系：守序
类型：祝福类
    使单个部队的远程防御力提高50%。
    看起来效果比较强的一个魔法，远程防御力提高50%也就是相当于受远程攻击时只会受到2/3伤害（1÷(1+50%)）。在游戏早期如果遇到低级野外射手，可以考虑施放在矮人或是英雄身上，有效减少伤亡。到中后期这个魔法就不太常用了，一是因为是单体魔法，二是因为作用场合有局限性，三是守序系好魔法实在太多，而且还有灯神的存在。

驱散（Dispel）
派系：守序
类型：祝福类/诅咒类
    解除我方或敌方单个部队身上附着的状态魔法，无论是正面还是负面的。但是不能用来解除中毒和瘟疫状态。可以用来直接驱除操纵的尸体和幻象副本。
    驱散时不分好坏的特性，需要特别加以关注。因为守序魔法最重要的那些状态魔法都是诅咒性质的，在对敌人部队使用驱散时很可能反而便宜了敌人，投鼠忌器而使驱散派不上用场，从这一点来说，明显不如死亡系的废除；而对本方使用时，因为守序魔法祝福性质的并不多，相对而言顾忌就少一点，多数时候并不见得比生命系的驱魔差。对我方或敌方部队都能产生作用，是驱散的最大优点，但使用之前必须考虑清楚，不能像用废除或驱魔时那样义无反顾。
    不能用来去除防魔魔法，是驱散魔法与三代相比唯一的不足之处。但是可以用来去除敌人宗师抗魔英雄身上的正面魔法，加上四代状态魔法持续时间的无限性，令驱散的作用在某些时候变得不可替代。

推移（Displacement）
派系：守序
类型：祝福类/诅咒类
    将（我方或敌方）单个部队推开两格，推移的方向由施法者选择。
    虽然对本方或敌方部队都可以产生效果，但推移的实战应用多数还是用来推敌人。因为视线规则的存在，在某些时候将敌人用来保护英雄或远程的部队推开，就是非常重要的事情。将站在箭塔上的强力远程推下塔，也是推移常见应用之一。虽然后期主力英雄一般都腾不出手干这种活，但因为是一级魔法，随便招个副英雄就可以用了，所以派上用场的时候还不少。用来欺负电脑比较容易，但对人作战时作用便有所限制，因为一般玩家都会习惯于用紧密阵型，部队相互间的阻挡令推移很难一次就达到预期效果。
    在早期版本的游戏中，推移在使用上没有多少限制。从2.0版本开始，新增了魔法抗性影响因素，令这个魔法的作用有所下降。

精准（Precision）
派系：守序
类型：祝福类
    使单个部队远程攻击力提高25%，并使远程攻击伤害不受距离、障碍、城墙的影响。（不能伤害躲在城堡内部的敌人，但射击紧贴着城墙的敌人时，伤害不会减半）。
    相当实用的一种魔法，早期游戏中常常要对半身人使用。而在后期，当泰坦身上同时附着精准和振奋（灯神所加）状态时，其威力是相当强的。可惜此魔法是精神类魔法，不能对灯神复制出来的泰坦幻象使用，不能不说是遗憾。

嗜血（Bloodlust）
派系：混乱
类型：祝福类
    使部队的近战攻击力提高25%
    与守序的精准相对应，这个魔法是用来加强近战的，实用率也相当高。在游戏早期，就算兵力不多，施加嗜血后的杀伤增幅也相当不错，即使赶不上火矢的伤害，几回合攻击累积下来后就可以超越了，适合在战斗早期使用。

火焰结界（Fire Aura）
派系：混乱
类型：祝福类
    对本方部队使用，该部队在对敌人进行近身攻击时，会附带少量的火属性额外伤害。额外伤害的大小与本方部队的数量和能力无关，只与施法者有关。魔法参数：10/1，计算出的数值为火焰伤害的威力
    威力太低，在尽量提升杀伤能力时会将其考虑进去，但施法优先度无疑是排名末尾的。

疾速（Haste）
派系：混乱
类型：祝福类
    单个部队速度和战场移动力+3
    在最高难度下，疾速的效果显然不如迟缓。因为一般来说野兵战力都会远强于我方实力，用迟缓可以有充分时间慢慢折磨敌人，而加速之后该怎么办，冲上去硬碰硬么？当然不是不行，但要以微小损失歼灭敌人，我方与敌方部队的战力比例就要高于有迟缓魔法的情况，就是说，面对同样的敌人，有迟缓魔法可以比单有疾速魔法用更少兵将敌人消灭。
    因为速度是决定出手优先度的最重要因素，因此疾速魔法的应用还是非常广泛的。但就战略发展地位来说，不如迟缓。

杀戮（Slayer）
派系：混乱
类型：祝福类
    使部队在攻击4级生物时能够造成50%的额外伤害
    在面对四级生物时，这个魔法非常管用，算是一个相当不错的一级魔法。

疗伤（Bind Wound）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，魔法参数：30/3，计算出的数值为治疗的生命点数
    疗伤的作用在于延长部队存活的时间，其效果的实际大小并不仅仅看法术的威力，而且还要看受治疗部队的防御力。生物或英雄的防御力越高，疗伤的使用就显得越加有价值。虽然法术参数与魔箭相当，但对防御力远高于敌人攻击力的部队来说，受到救助比直接消灭那么点敌人更加合算。
    生命族若在开始阶段有高防御的英雄（可以考虑招募邻族的射手），配以适时的治疗类魔法，便可大胆前去牵制敌人部队，为我方部队（主要是远程）的攻击争取到足够的时间。

祝福（Bless）
派系：生命
类型：祝福类
    让单个部队伤害力最大化，此魔法对亡灵生物无效
    生命族部队的伤害值上下限一般都遵循2：3的比例，伤害值最大化也就意味着杀伤能力提高(3-2.5)÷2.5×100%＝20%，这个提高比例要低于精准或嗜血的25%。但考虑到祝福对近战和远程部队都能起作用，用处还是基本相当的。

驱魔（Exorcism）
派系：生命
类型：祝福类
    解除本方单个部队身上的所有负面魔法。但是不能用来解除中毒和瘟疫状态。
    解除本方部队所中的诅咒类魔法，充分体现了生命系魔法以保护为主要作用的特色。因为本族状态类魔法几乎全是祝福性质的，因此驱魔在使用上的有的放矢便可发挥最佳作用。

精神护甲（Spiritual Armor）
派系：生命
类型：祝福类
    使单个部队近战防御力和远程防御力提高25%
    虽然从效果上来看不如模糊，但同时增加近战和远程防御力却使精神护甲的适用范围要大大强于模糊，因此25%这个比例还是可以令人满意的。此类魔法的使用，可以间接提升疗伤类魔法的效用。

加速（Speed）
派系：自然
类型：祝福类
    使部队速度和战场移动力+3
    效果和混乱系的疾速完全相同，二者不可叠加。由于妖精的存在，自然英雄战斗中给自己加速，逃避敌人追击是常有的事情，魔法使用率比混乱城高。

护体石肤（Stoneskin）
派系：自然
类型：祝福类
    使单个部队近战和远程防御力提高25%
    和生命的精神护甲效果相当，但两者可叠加。若不学治疗类魔法，作用要比在生命城堡中的小一些。

地形认知（Terrain Walk）
派系：自然
类型：祝福类
    使部队在战场上移动时不会受到不良地形的额外损耗，可以忽略流沙的阻挡效果。
    在雪地、沼泽、沙漠等不良地形上战斗时，地面部队的移动范围要大大受影响，此时地形认知可以给它们以相当大的帮助。但这还不算是地形认知的最佳应用，与流沙配合方能将其作用发挥到极致。用流沙阻挡敌人时，也限制了本方部队的移动范围，被渐渐逼入死角的感觉可不好受。为了调动敌人，经常要让妖精到处飞来飞去，步骤十分烦琐。有了地形认知后，一切便都省心了。

二级魔法

飞行（Flight）
派系：守序
类型：祝福类
    赋予部队飞行能力直到战斗结束
    让步兵变成飞行部队，那可是实质性的变化。虽然守序没有加速魔法，但飞行魔法却在不少时候比加速更好用，战场上障碍物越多，飞行的优越性就越能体现出来。利用障碍让飞行的英雄与中了迟缓的敌人周旋，或是飞行后的强力部队（如傀儡龙）快速冲上去压制敌人，都是比较常见的应用。

抢先攻击（First Strike）
派系：混乱
类型：祝福类
    使本方部队获得“抢先攻击”状态
    在规则改变的四代里，能在攻击或反击时抢在敌人之前出手，往往意味着损失的大幅度减少，甚至改变胜败结果。抢先攻击魔法的重要性也就不言自明。

魔力闪光（Mana Flare）
派系：混乱
类型：祝福类
    使战场上所有部队（包括我方和敌方）在施法时少消耗2点魔法值（但最少要消耗1点）
    一个非常好用的魔法，使用后二级魔法只要消耗1点魔法值，极大增加了可用次数。此魔法是巫师群战术可行性的最重要因素，否则控制敌人的回合数便会大大减少，以弱胜强的效果会打上不少折扣。如果可能的话，将魔力闪光与灯神、水元素、仙女龙相结合，可以大幅度提升这些兵种的威力。

天堂之盾（Heavenly Shield）
派系：生命
类型：祝福类
    在战斗中制造一面护盾保护施法者本人，所受的伤害由护盾承受。魔法参数：50/5，计算出的数值为护盾的生命点数
    魔法威力与医疗相当，但有些时候却更加好用。因为医疗不能超越英雄生命值上限，如有多余的点数，只能被舍弃，天堂之盾就不存在这个缺点（但如果敌人会驱散或废除，优点就变成了缺点）。因为只保护英雄自身，其实际价值完全要看英雄防御力的高低来决定。

防护（Defender）
派系：生命
类型：祝福类
    使本方所有部队在采取防御姿态时近战和远程防御力提高50%。采取防御姿态原本就可以提高25%防御力，再加防护魔法，提高的防御力是125%×150%-1=87.5%
    相当有争议的一个魔法。只能在采取防御姿态时起作用已经决定了其局限性，在不少情况下都是无用的魔法，但在条件合适时却无疑是个好魔法。
    高防御部队顶上前去牵制敌人，后方远程部队奋力射击；部队整体移动力不足，或是攻城的时候，靠高防御部队站前排挡箭，等敌人弹药耗光时再作行动；面对强敌时高防御英雄上阵，加一堆保护类魔法后躲到角落里，靠反击磨死敌人……以上都是生命族在兵力不强时可以考虑使用的战术，稍加变化还可以衍生出更多战术。在这些战术中，降低所受伤害的魔法和治疗类魔法是令战术意图最终实现的必要条件，受伤速度和治疗速度的比例，决定了这些战术是否具备可行性。作为能降低所受伤害的魔法中的一员，防护对实现战术意图有着重要的影响。有时正是这一个因素的加入，令不可能变得可能；或者至少起个降低魔法值消耗的作用，延伸部队的可持续战斗力。
    在使用防护时，需要注意一些问题。若高防御英雄与生命魔法英雄是同一人，那么再生魔法很多时候是必要的，否则时不时放弃防御状态来治疗，会令防护的作用大打折扣。如果有两个英雄分别负责牵制和治疗，那么防护的适用范围就会大很多。魔法等级低恰恰是防护魔法的一大优势，随便招个副英雄来用，或许就能给主英雄以很大帮助。
    总而言之，防护在一定条件下是对相似作用魔法的一种有益补充，要有合适魔法、英雄的配合才能充分发挥作用，否则就是废魔法。对英雄使用，比对生物使用更好，因为英雄可以达到更高的防御力。用它来对付野兵，比对付有英雄带领的部队效果好。虽然在与人对战的决战中起不到作用，但对战中其实大部分时间也是在与野兵交战，对付野兵有效也许就意味着发展快，意味着在决战时兵力能够占优。从这个意义上来看，可以算一个好魔法。

医疗（Heal）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，另外解除部队的中毒与瘟疫状态，魔法参数：50/5，计算出的数值为治疗的生命点数
    作为疗伤的强化版本，医疗在效率上更胜一筹，并且拥有解除中毒与瘟疫状态的效果，无疑是重要的二级魔法。

报偿（Retribution）
派系：生命
类型：祝福类
    使敌人部队攻击本方部队时也要遭受一定伤害。与三代的火盾相似，但火盾是按比例将所受伤害的一部分反射给敌人，而报偿所反射的伤害只与施法者能力有关，与所承受的伤害大小无关。魔法参数：10/1，计算出的数值为反射伤害的威力
    魔法威力与火焰结界相同，但报偿的作用却更强一些。因为一般兵种一回合顶多能有一次攻击加一次反击，而受攻击的次数完全可能多于两次。高防御英雄配合保护和治疗类魔法，即使站在敌人堆中也可以坚持很长时间，多个回合下来之后，报偿所累积的伤害值也是相当可观的。尽管如此，作为二级魔法，感觉威力还是偏低了一点，如果能设高些，会更加好用。

殉难（Martyr）
派系：生命
类型：祝福类
    将本方一支部队承受的伤害转移到另一支部队身上
    利用本方不同部队防御力上的区别，来选择转嫁伤害的对象，是使用此魔法的基本准则。四级兵、十字军或是英雄冲锋陷阵时，将所受伤害转嫁到后方侍从或农民身上，是最常见的用法，可以有效减少高级兵的损失。
    对于掌握了召唤魔法的高防御英雄来说，用殉难来配合召唤是相当好的一个战术，可以大大加强英雄的抗打击能力。当然，召唤出来的生物首先要能够保证自身安全，否则容易成为被追打对象，因此与殉难配合的召唤生物基本上都是高速的飞兵。

混乱抵御（Chaos Ward）
派系：生命
类型：祝福类
    使部队对混乱魔法有50%抗性，并且在面对混乱系部队攻击时，近战防御力和远程防御力提高50%
    效果很强、却带着明显局限性的魔法，如果你的主要敌人不是混乱族，那么这个魔法有什么用处呢？二级魔法塔总共才3个位置，生命二级魔法却有足足11种，出现了不想要的Ward魔法时，简直会让人产生把魔法塔拆掉的冲动。其余几种抵御，包括它们的群体版本，也存在同样问题，所以没有必要逐一加以详细解说。

死亡抵御（Death Ward）
派系：生命
类型：祝福类
    使部队对死亡魔法有50%抗性，并且在面对死亡系部队攻击时，近战防御力和远程防御力提高50%

自然抵御（Nature Ward）
派系：生命
类型：祝福类
    使部队对自然魔法有50%抗性，并且在面对自然系部队攻击时，近战防御力和远程防御力提高50%

守序抵御（Order Ward）
派系：生命
类型：祝福类
    使部队对守序魔法有50%抗性，并且在面对守序系部队攻击时，近战防御力和远程防御力提高50%

振奋（Mirth）
派系：生命
类型：祝福类
    使单个部队获得最高士气（+10）
    部队士气最高，也就意味着保证出现士气高涨，不但提升行动优先顺序，而且还加强了攻击力。行动优先度提高，结合等待战术，实在有太多利用价值，因此振奋魔法的重要性也就勿需质疑。

巨人力量（Giant Strength）
派系：自然
类型：祝福类
    使单个部队生命值和伤害力提高25%
    很多时候，巨人力量的效果比祝福和护体石肤两个魔法的效果综合起来还高一些，因此其定位为二级魔法是完全恰当的。

幸运（Fortune）
派系：自然
类型：祝福类
    将单个部队幸运提升到最高（+10）
    相当于将部队的抗打击能力提高了1/2，效果相当强劲的一个魔法。

蛇击（Snake Strike）
派系：自然
类型：祝福类
    使本方单个部队获得“抢先攻击”状态
    作用与混乱系的抢先攻击魔法完全一样，只是因为属于不同派系，所以才换了一个名字。

三级魔法

群体模糊（Mass Blur）
派系：守序
类型：祝福类
    本方所有部队获得模糊状态
    群体模糊的实用性要比单体的模糊高许多，当你有多支部队需要保护的时候，你就能体会到群体魔法的优越性了。在面对强力远程兵时，群体模糊常常是不错的选择。

群体驱散（Mass Dispel）
派系：守序
类型：祝福类/诅咒类
    解除所有部队（包括敌我）身上附着的状态魔法，无论是正面还是负面的。其余特性与单体驱散相同。
    群体驱散是一个毁誉参半的魔法，有时极度有用，有时却因投鼠忌器而变为鸡肋，一切都要看实战的情况而定。对于中了怯懦的英雄来说，群体驱散有时会是相当不错的选择。

群体精准（Mass Precision）
派系：守序
类型：祝福类
    使本方所有远程部队获得精准状态。
    罕见的使用率不及单体魔法的一个群体魔法。因为守序本身就只有半身人和泰坦两种远程，英雄一般也不会去修炼箭术，因此这个魔法很难体现其群体性质的优越性。很多时候，看见群体精准在魔法塔中出现，都会有宝贵的魔法位置被白占一个的感觉，令人愤懑。可以说这是最差的三级守序魔法之一。

传送（Teleport）
派系：守序
类型：祝福类/诅咒类
    将部队传送到战场上的指定位置，可以用来传送敌人部队。
    飞行魔法依然不能完全弥补某些部队在移动力上的缺陷，这时便需要传送魔法出场了。传送本方部队多是为了躲避敌人的围攻，而传送敌方部队则为我方围攻敌人创造了条件。对视线没有要求，令传送成为对付敌人远程部队或英雄最好的方法之一。而在攻城战中，传送的优点就更加突出。
    在早期版本游戏中，传送敌人没有多少限制条件。从2.0版本开始，对其增加了魔法抗性影响因素，虽一定程度削弱了其作用，但这仍然是一个可超越三级地位的实用魔法。

回城（Town Gate）
派系：守序
类型：祝福类/冒险魔法
    使施法英雄及其带领的整支部队回到最近的本方城堡，可以在战场上使用。
    又是一个体现守序系特权的魔法，可以说相当不公平。当灯神魔法值耗完时回城，是此魔法的一种应用，可以让某些原本无法打赢的战斗分几次来完成。堵城门使用或是在城堡附近战斗中使用，可以让部队回到较远的城堡里。合理综合利用上述规则，甚至可以使回城魔法有前两代中大回城的效果，这样守序族调动兵力就变得很容易实现，这是其他种族所难以企及的优势（其他族只能用战斗中逃跑的方法来调动英雄）。生命城堡和死亡城堡有些时候还可以跟着沾点光，其余种族可就只能眼睁睁面对不公平待遇了。

血暴（Blood Fenzy）
派系：混乱
类型：祝福类
    使本方所有部队的近战伤害提高25%
    嗜血的群体版本，在大兵团作战中相当有用。

魔镜（Magic Mirror）
派系：混乱
类型：祝福类
    对本方部队使用。该部队在遭受敌人魔法攻击时，自动将1/2的伤害反射给施法的敌人，部队本身所受的魔法伤害不会因此减少；在承受诅咒类魔法时，自动使施法者获得同样的受诅咒状态，不能反弹的诅咒类魔法只有催眠、和平之歌和驱逐这少数几种。部队如果直接被魔法消灭，反弹将不会发生。
    想靠反弹魔法伤害来消灭敌人英雄，并不是什么好方法，若双方等级、技能相当，直接丢个火球就比用魔镜效果好，反正二者的效果都要受魔法抗性制约。反弹诅咒魔法的特性倒是比较有用些，但因为是单体魔法，因此作用就打了折扣，经常不能取得预期中的效果。
    作为兵种特技而言，仙女龙的魔镜倒是相当有用，让一些战术在面对它的时候都要打些折扣。对它使用混乱会让施法者也陷入混乱，同样一回合不能行动，却有本质区别：施法者本回合已经行动过（用魔法）了，混乱效果持续到下个回合，而仙女龙下个回合就可以醒过来，这可有点受不了。

群体杀戮（Mass Slayer）
派系：混乱
类型：祝福类
    使本方所有部队在攻击4级生物时能够造成50%的额外伤害
    杀戮魔法的群体版本，其作用无需细述。

天国护甲（Celestial Armor）
派系：生命
类型：祝福类
    使本方所有部队近战防御力和远程防御力提高25%
    精神护甲的群体版本，加强防御力也就是降低所受伤害，让部队的生存时间得到了延长。

群体祝福（Mass Bless）
派系：生命
类型：祝福类
    使本方所有部队的伤害力最大化。
    对近战或远程部队都能起作用的优势，在群体魔法中就充分体现出来了。从本族兵种的搭配情况来看，群体祝福的效果与血暴基本相当，实用性都要明显强过群体精准。

群体医疗（Mass Heal）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：25/2，计算出的数值为治疗的生命点数
    魔法威力稍微有点低。但既然不能复活部队，那么这样的威力也就算是可以了，反正四级兵也不见得有多少血。能够给全体解毒是其最大用处，正好用来对付死亡系的瘟疫。

再生（Regeneration）
派系：生命
类型：祝福类
    使部队每回合自动恢复一定生命值，魔法参数：20/2，计算出的数值为每回合自动恢复的生命点数
    因为威力较低，所以加给高防御的英雄要比加给兵种更合适。每回合都能恢复的持续性，是再生魔法的最大亮点。如果与一堆保护类魔法相结合，有可能产生敌人打的速度还没再生恢复速度快的局面，这也就意味着英雄永远打不死了。若能做到，兵就没必要带了，避免决战前的无谓损失。

恐惧结界（Aura of Fear）
派系：死亡
类型：祝福类
    对本方单个部队使用，使其在攻击时可以不受敌人反击，除非敌人对死亡魔法、恐惧或精神类魔法有抗性。此魔法效果类似于骨龙的“引起恐惧”技能，但不能使敌人后退，在反击时不具备“引起恐惧”的奇效。
    许多时候可以产生不受反击的效果，是个很好的魔法，最适合与具备满屏移动能力的恶魔相配合。

防魔（Anti-Magic）
派系：自然
类型：祝福类
    使单个部队在战斗中免疫所有魔法，使用后原先附着在该部队身上的魔法状态会立即消失（不包括宝物、职业附加的状态，此外也不能去除中毒与瘟疫），附加在幻象副本或是操纵的尸体上时，会让它们立刻消失。
    敌人若有强力杀伤魔法，或是强力诅咒类魔法，防魔的重要性便无可替代。虽然会让部队无法享受祝福类魔法的帮助，但权衡利弊，有时是必须作出的抉择。需要注意的是，对英雄使用后就会消除不朽药水的守护天使效果，若战死便不能复活了，一定要更加谨慎地加以保护。

群体加速（Mass Speed）
派系：自然
类型：祝福类
    使本方所有部队速度和战场移动力+3
    单体的加速魔法，混乱系与自然系都有，但群体加速就只是自然系所独享的了，从这一点来说，是自然的一个优势。

招魂抵御（Necromancy Ward）
派系：自然
类型：祝福类
    阻止操纵尸体和驱役亡灵类魔法在战场上的使用。
    使用此魔法后，不仅禁止了上述两类魔法的使用，而且已经操纵或驱役出来的部队，也会立刻消失。看得出，此魔法是专门用来克制死亡城的，正如守序的驱逐专门用来克制自然城一样。在游戏前瞻中，此魔法同时属于自然系和生命系，不知道为什么最后会从生命魔法中被剔除。

四级魔法

群体抢先攻击（Mass First Strike）
派系：混乱
类型：祝福类
    使本方所有部队获得“抢先攻击”状态
    抢先攻击的群体版本，虽然并不直接提升攻击伤害，但攻击或反击的优先可以比血暴更加有效地减少损失，其实也就提高了持续战斗力。

灵猫反射（Cat Reflexes）
派系：混乱
类型：祝福类
    使我方部队在主动攻击时可以多打一下，如果是原来就可以连击两下的部队，加了灵猫反射之后，主动攻击时可以连打三下。
    混乱系祝福类魔法的最高境界，集中体现了这一系列魔法强化杀伤能力的特色。单就对攻击的强化效果而言，不比自然的龙之力量魔法差多少，而且连击特性在对付喝了不朽药水的敌人英雄时，有着独特优势。越强力的部队，就越能发挥灵猫反射的作用，在后期可比什么杀伤类魔法都强得多。如果四级兵选择黑龙，这么好的魔法就享受不到了，实在遗憾，可惜很多时候却仍然要做这种无奈的选择。

群体驱魔（Mass Exorcism）
派系：生命
类型：祝福类
    解除本方所有部队所附着的负面魔法。但是不能用来解除中毒和瘟疫状态。
    在驱除类魔法（驱散、驱魔、废除）中，这是唯一一个4级魔法，感觉并不公平。群体驱散是把双刃剑，设为三级尚无可厚非，但群体废除有什么理由比群体驱魔低一级呢？而且身在生命魔法塔的群体驱魔，还要和一堆不知道有用没用的群体抵御抢位置，无趣了点。

群体振奋（Mass Fervor）
派系：生命
类型：祝福类
    将本方所有部队的士气提到最高点。
    可以说是最有用的生命四级魔法了，全体提高行动优先度，意味着常常可以在等待后全员连续围攻敌人两次，给敌人造成的打击是相当沉重的。

祈祷（Prayer）
派系：生命
类型：祝福类
    战场上所有生命系部队生命值和攻击力提高25%，不分敌我
    感觉作用比群体振奋稍差一些。祝福时不分敌我倒是小问题，注意点就好了。提高攻击力25%和振奋的作用是一样的，而提高生命值25%感觉就不如提高行动优先度来得有效。如果祈祷同时还能有加速效果的话，那就完美了。

群体混乱抵御（Mass Chaos Ward）
派系：生命
类型：祝福类
    使本方所有部队获得混乱抵御状态

群体死亡抵御（Mass Death Ward）
派系：生命
类型：祝福类
    使本方所有部队获得死亡抵御状态

群体自然抵御（Mass Nature Ward）
派系：生命
类型：祝福类
    使本方所有部队获得自然抵御状态

群体守序抵御（Mass Order Ward）
派系：生命
类型：祝福类
    使本方所有部队获得守序抵御状态

吸血鬼接触（Vampiric Touch）
派系：死亡
类型：祝福类
    对本方部队使用，使该部队在对敌人进行近身攻击时自动治疗创伤，恢复的生命值是攻击伤害的一半
    死亡魔法少有的祝福类魔法之一，但却是整个游戏中最强的祝福类魔法之一。给强力部队增加吸血能力，在英雄复活魔法已经取消的四代里，有着极其独特的优越性。使用对象的无限制性，可以让原本连治疗都不能享受的亡灵、元素、机械获得复活的能力，不管怎么说也太变态了一点。幸亏对于攻击对象还有要求，对方必须有生命，才能从它身上吸血。在大兵团作战中，吸血鬼接触有着无可替代的作用，即使提升为五级魔法，也不为过。

群体幸运（Mass Fortune）
派系：自然
类型：祝福类
    将本方所有部队幸运值提到最高
    自然系唯一的群体保护性魔法，重要性不言而喻

群体蛇击（Mass Snake Strike）
派系：自然
类型：祝福类
    使本方所有部队获得“抢先攻击”状态
    如果本族四级兵选择仙女龙，那么这个魔法的作用就比较有限（螳螂本来就有先攻），不如将施法机会让给同级的召唤魔法。

五级魔法

痛苦之镜（Pain Mirror）
派系：守序
类型：祝福类
    对本方单个部队使用，使其在遭受物理攻击或魔法攻击时，自动把一半伤害反射给攻击者，部队本身所受的伤害并不会减少。反弹效果会受敌人抗魔能力的影响
    单机游戏中基本无用，对战中有发挥余地的一个魔法。反弹一切伤害（无论是近身肉搏，远程射击，还是魔法杀伤），在兵力相当的战斗中会起到巨大作用。虽然对付数量巨大的野兵时作用有限，但反弹的比例确实是不能再加强了，否则敌人使用此魔法、又无法将其解除时，该怎么办？奇怪的是，电脑从来不用这个魔法，让玩家的顾忌少了许多。

神圣介入（Divine Intervention）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：50/5，计算出的数值为治疗的生命点数。不复活死亡部队，复活英雄，但要在魔法威力超过英雄生命值上限的情况下才能复活。如果部队接受治疗（前提是有损血），那么在补生命值同时会解除身上所有负面魔法状态，包括中毒和瘟疫。
    怎么说呢？一个作用强大，但利用率却不高的魔法吧。因为使用此魔法，需要至少有2个高等级英雄（包括生命系这个）才会有意义，这在一般地图中不容易出现，而战役中敌人又太弱了，根本用不到。可能在一些变态地图中，神圣介入才会找到施展拳脚的最好舞台。

守护天使（Guardian Angel）
派系：生命
类型：祝福类
    对一支本方部队使用后，部队获得额外的生命数。部队数量不会增加，但在遭受攻击时，被打死多少，就从“额外生命数”中取多少来复活，直至额外生命数耗完为止。魔法参数：1/0.1，计算出的数值为额外生命数。增加的额外生命数不能超过部队本身的生命数
    基本上可以说是一般地图里最有用的生命五级魔法，虽然比不上真正的复活魔法，但对四级兵使用时效果也接近了，可以大大减小战斗损失。其作用机理为：先计算损失（以剩余数量来封顶，不透支生命数），然后再从额外生命数中取相应数量来复活。
    额外生命数不能超过部队本身的生命数，是守护天使对英雄使用一次后，英雄只能自动复活一次的原因所在。不朽药水的作用，其实就是给英雄附加守护天使。

庇护（Sanctuary）
派系：生命
类型：祝福类
    使用后保护本方所有部队，受保护的部队不会遭到敌人攻击，也不会受到（我方或敌方）魔法影响。受保护部队只能做移动、等待、防御这几个动作，否则保护效果将消失。
    原先生命五级魔法中最有用的庇护，因为从2.0版本开始增加了回合限制（只维持6回合，并且在到期后3回合内不能再次使用），实用性降低了。用杂兵将箭术或魔法英雄围在角落里，避免敌人近身攻击，或是对敌人下毒后再用庇护一直防御，都是从前的实用战术。如今虽然有了回合限制，但6回合的时间也算较长了，安排得当的话能做不少事情。庇护后全体部队扎进敌阵，看准时机给敌人英雄或主力部队以重创，是庇护在对战中的应用之一。

牺牲（Sacrifice）
派系：死亡
类型：祝福类
    消灭本方一只部队来复活其他部队，复活的生命值是消灭部队生命值的两倍。所消灭的部队不能是召唤类魔法制作出来的生物
    魔法效果是强的，但不能牺牲召唤出来的生物，限制了魔法的作用。牺牲低级部队来复活高级部队，是很自然的使用方法，但死亡城低级部队生命值都太低，一周生产的低级兵也仅够用来复活那么几个高级兵，很难持续使用。或许这个魔法仅在艰苦决战中才会充分体现价值，能复活英雄也是其少数亮点之一。

龙之力量（Dragon Strength）
派系：自然
类型：祝福类
    使本方单个部队生命值和伤害力加倍
    祝福类魔法的颠峰之作，龙之力量的效果相当于让单个强力部队数量翻了倍，无须细说便能看出这有多么有用了。自然系的祝福类魔法虽然不多，但实用价值却都很高，夹在以保护见长的生命系和以进攻见长的混乱系之间，自然的祝福类魔法同时具备攻防两方面强化作用，这个特色在龙之力量上得以汇总。


诅咒类魔法

一级魔法

驱散（Dispel）
派系：守序
类型：祝福类/诅咒类
    解除我方或敌方单个部队身上附着的状态魔法，无论是正面还是负面的。但是不能用来解除中毒和瘟疫状态。可以用来直接驱除操纵的尸体和幻象副本。
    驱散时不分好坏的特性，需要特别加以关注。因为守序魔法最重要的那些状态魔法都是诅咒性质的，在对敌人部队使用驱散时很可能反而便宜了敌人，投鼠忌器而使驱散派不上用场，从这一点来说，明显不如死亡系的废除；而对本方使用时，因为守序魔法祝福性质的并不多，相对而言顾忌就少一点，多数时候并不见得比生命系的驱魔差。对我方或敌方部队都能产生作用，是驱散的最大优点，但使用之前必须考虑清楚，不能像用废除或驱魔时那样义无反顾。
    不能用来去除防魔魔法，是驱散魔法与三代相比唯一的不足之处。但是可以用来去除敌人宗师抗魔英雄身上的正面魔法，加上四代状态魔法持续时间的无限性，令驱散的作用在某些时候变得不可替代。

推移（Displacement）
派系：守序
类型：祝福类/诅咒类
    将（我方或敌方）单个部队推开两格，推移的方向由施法者选择。
    虽然对本方或敌方部队都可以产生效果，但推移的实战应用多数还是用来推敌人。因为视线规则的存在，在某些时候将敌人用来保护英雄或远程的部队推开，就是非常重要的事情。将站在箭塔上的强力远程推下塔，也是推移常见应用之一。虽然后期主力英雄一般都腾不出手干这种活，但因为是一级魔法，随便招个副英雄就可以用了，所以派上用场的时候还不少。用来欺负电脑比较容易，但对人作战时作用便有所限制，因为一般玩家都会习惯于用紧密阵型，部队相互间的阻挡令推移很难一次就达到预期效果。
    在早期版本的游戏中，推移在使用上没有多少限制。从2.0版本开始，新增了魔法抗性影响因素，令这个魔法的作用有所下降。

诅咒（Curse）
派系：死亡
类型：诅咒类
    对敌人单个部队使用，使其伤害力最小化
    诅咒魔法的实际效果，要视施法对象而定。对于最常见的伤害值上下限3：2的部队来说，就是将其杀伤力降低了20%。而受诅咒影响最大的种族是混乱城，多数兵种伤害值上下限2：1，中诅咒后杀伤力降低1/3，嗜血都补不回来。而盗贼和半兽人中招的话，杀伤力更是受损一半。
    在前两代中，诅咒魔法一直是不能对亡灵起效的，但如今这一限制条件已被取消。而祝福魔法却仍然对亡灵无效，似乎有点不公平的感觉。不过对实力强大的死亡城来说，这么一点点的不公平也不算什么。

瓦解射线（Disrupting Ray）
派系：死亡
类型：诅咒类
    使敌人部队近战和远程防御力降低20%
    20%这个比例，和诅咒对一般兵种杀伤力的降低幅度一样。一个降攻，一个降防，两个魔法还真是配。

毒害（Poison）
派系：死亡
类型：杀伤类/诅咒类
    使敌人部队每回合自动损失一定生命值，从施法的当前回合开始生效。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值
    虽然伤害值不高，但毒害还是很实用的一级魔法。对于敌人受保护的后排射手或英雄施毒，虽然对敌人总体战力的损伤速度较慢，但还是有用的。而若是配合二级魔法疲劳，单英雄上阵便可以耗死强大的敌人，虽然基本上只能用来对付有生命的步兵，但依然具备相当实用性，只是战斗过程未免太漫长了些。

废除（Cancellation）
派系：死亡
类型：诅咒类
    解除敌人单个部队身上附着的所有正面魔法，可以用来直接驱除敌人操纵的尸体和幻象副本。可以用来去除敌人宗师抗魔英雄身上的正面魔法
    与驱魔类似，魔法作用切合了本派系其余魔法的特点。死亡系状态魔法以诅咒类为主，削弱敌人实力后又用废除打压敌人东山再起的希望，让敌人辛辛苦苦积攒起来的祝福类魔法瞬间消失，作用也未免太强了些。

二级魔法

怯懦（Cowardice）
派系：守序
类型：诅咒类
    对单个敌人部队使用，使其在3回合之内不能对生命总值超过其自身的部队进行主动攻击或施法
    因为在最高难度游戏下，野兵的数量非常多，其生命总值自然也大，因此怯懦的使用对象就十分鲜明了：绝大多数时候都会指向敌方英雄。在与野外灯神交战时，估计很多人都曾体会到中了怯懦后有劲使不出的郁闷感觉，那么这种郁闷感觉在适当的时候也应该让对手去尝尝。想想敌人一个杀伤魔法威力巨大的混乱巫师，在中了怯懦后无法解除的情景，会有多么快意？对兵种使用怯懦的情形相对较少，但在合适状况下，让灯神使用怯懦，会比用和平歌更省魔法值。

迟缓（Slow）
派系：守序
类型：诅咒类
    使单个敌人部队速度和战场移动力减半
    在最高难度游戏下，绝大多数时候都要以弱战强，因此降低敌人行动能力的迟缓要比单纯的加速更加重要，魔法等级高一级也是完全合理的设计。魔法延续时间上的无限性，极度夸大了迟缓魔法的重要性，也使其成为守序族的优势之一。

能量损耗（Power Drain）
派系：守序
类型：诅咒类
    使敌人部队（英雄或生物）施法时需要消耗双倍魔法值
    使用优先度不怎么高的一种魔法，因为其效果多数时候都不会立刻显现出来。如果能够充分发挥其让敌人施法次数减半的作用，那么还是值得使用的。自身安全和部队可持续战力是最需要预先考虑的因素，如果条件不合适，还是先用别的可改变战局走向的魔法吧。对付野外施法兵种时，有时会非常有用。

窃魔（Steal Enchantment）
派系：守序
类型：诅咒类
    吸取单个敌人部队身上附着的一个正面魔法状态，转移到随机选取的本方部队身上
    有点无赖的一种魔法。对于祝福类魔法比较紧缺的守序系来说，窃取敌人一个强力正面魔法有时会让人忍不住笑出声来。但是因为每次只能窃取一个，还是随机的，如果敌人身上有很多正面魔法附加时，窃魔的效果就难尽人意了。而且窃取回来的状态加在哪个部队身上，也是随机的，所以其效果根本没有想象中那么强，有时还不如用一个驱散去直接废掉敌人的祝福状态。
    需要注意的是，敌人那些由职业、宝物附加的魔法状态，也能够窃取，但窃取完成后敌人的状态并不会消失。

法术枷锁（Spell Shackle）
派系：混乱
类型：诅咒类
    对单个敌人部队（英雄或生物）使用，使其在施法时每消耗1点魔法值就要受到10点伤害
    魔法威力已经决定了法术枷锁基本上只在对付英雄时有作用，诅咒类的性质决定了不必考虑视线问题，这是其优势，一般英雄中了之后没几回合就该倒下了。虽然不常用，但在合适条件下可以考虑。与电脑打的时候倒是常常会中这个魔法，如果不能解除的话，在施法时就会有束手束脚的感觉。

混乱（Confusion）
派系：混乱
类型：诅咒类
    使敌人部队丧失一回合的行动机会，施法对象必须在英雄视线内
    与和平歌算是作用相近的魔法吧，但要强上不少，仙女龙的好用，其实也就是靠这个东西。只能维持一回合看上去太少，但若配合魔力闪光，每次消耗只有1点，四个低级巫师配合很容易就把野兵控制个三、四十回合（要考虑到战斗中有敌人部队被消灭后，腾出手来的巫师就可以留着魔法值后面用），配合美杜莎的无限弹药、石化凝视，很多强敌都可以干掉了。

厄运（Misfortune）
派系：混乱
类型：诅咒类
    使敌人单个部队幸运降到最低。
    幸运最低（－10）的敌人受物理攻击和闪电、爆裂、碎裂、圣言、圣唱、驱逐魔法时，会多遭受1/2的伤害。有些时候可以近似认为我方部队增加了一半，这个提升比例可着实不小，宗师攻击技能的效果也不过如此。

和平之歌（Song of Peace）
派系：生命
类型：诅咒类
    影响英雄视野范围内的单个生物，使其一回合不能主动攻击和施展诅咒类魔法
    虽然是生命魔法，但这个魔法的出名却是因为守序的灯神。英雄使用时，不具备灯神那种每仗过后魔法值就自动补满的优势。而且缺少魔力闪光配合，生命族也很难向混乱族看齐，组织起所谓的“牧师群”。
    与作用相似的混乱、蜂群魔法相比，和平之歌不能真正封住敌人行动是最大劣势，唯一优势只剩下不会被魔镜反弹这一项了吧？但不管怎么说，能够压制敌人一部分实力的发挥，和平之歌还是一个好魔法，只是可持续使用性不强。

疲劳（Fatigue）
派系：死亡
类型：诅咒类
    使敌人单个部队速度和战场移动力减半，适用范围比迟缓窄，因不能影响亡灵和机械，但可影响元素
    好用程度不及迟缓，但很多时候也是非常有用的。适用范围上的限制条件，使得死亡城最不愿意面对的敌人恰恰就是亡灵，想起来都有点好笑。

邪恶之歌（Unholy Song）
派系：死亡
类型：诅咒类
    使战场上所有的生命系部队攻击力和防御力减少20%，不分敌我
    虽然也叫“歌”，但与和平之歌不同，不是精神类魔法，因此在使用上不受多少限制，只是对弩车无效而已。在面对生命系敌人时，可以近似看作同时具备群体诅咒和群体瓦解射线（虽然没有这个魔法）的效果，作用显然超乎其二级地位，一个字：强！适用范围太窄是魔法等级不高的根本原因。

虚弱（Weakness）
派系：死亡
类型：诅咒类
    使敌人单个部队攻击力减少25%
    从结果上来看，降低敌人攻击力，可以近似认为减少本方所受伤害。与幸运的1/3相比，虚弱的减少25%有点偏弱了，不算一个很称职的二级魔法。当然，两种魔法的作用对象不同，有时是不能这样简单比较的。

悲泣（Sorrow）
派系：死亡
类型：诅咒类
    使敌方单个部队士气降到最低（-10）
    从降低攻击力的角度来看，只是20%，不如虚弱。但降低敌人出手优先度所带来的影响，可绝不是这区区5%差别所能够体现的。因此悲泣魔法的使用优先程度往往要高于虚弱，对无生命部队一样可以产生效果是虚弱的唯一优势。

蜂群（Wasp Swarm）
派系：自然
类型：诅咒类
    使敌人部队丧失一回合的行动机会，不能影响机械或亡灵生物，但是可影响元素
    在相似的几个魔法中，是最强的了，与混乱相比，多出了元素这一作用对象。用此魔法，要注意尽量别让敌人最主要部队分组，以便于单独控制，我方其余部队杀掉较弱敌人后，最后再集中围攻最强的一队。

三级魔法

驱逐（Banish）
派系：守序
类型：诅咒类
    专门打击敌人用召唤类魔法制作出来的部队，魔法参数：110/11，计算出的数值为魔法杀伤力。
    召唤类魔法可分为召唤、幻象/幻影、驱役亡灵、亡灵复生（操纵尸体和死亡呼唤）几类，幻象/幻影、亡灵复生和驱役吸血鬼都可以直接用驱散来解决，驱役骷髅和驱役幽灵又不太强，因此驱逐魔法可以看作是专门用来对付自然系那些召唤魔法的。其魔法参数与最强的杀伤魔法碎裂相同，但少了巫术技能后，实际效果却差不少。在没有催眠或疯狂的情况下，驱逐用来对付召唤生物还是不错的，但若对手不是自然族，那么就是白占魔法塔一个位置了。
    另外需要注意的是，虽然是以生命值来计算魔法杀伤，但身为诅咒类魔法的驱逐，还是与一般的杀伤魔法不同，其效果最终是要落到“个”这个单位上来的。例如魔法计算出来的威力是352点，但在对狮鹫使用时其威力只有285点（3个狮鹫的生命值），剩余的67点被舍却了。
    注意到驱逐魔法的效果也要受到幸运/厄运的影响，当幸运/厄运发生作用时，驱逐的效果是先按前面所说的以完整的“个”来计算威力，然后把计算出来的伤害值直接加半或是减少1/3，这时便无须再考虑“个”的问题了。

遗忘（Forgetfulness）
派系：守序
类型：诅咒类
    使敌方单个部队无法进行远程攻击，一直到战斗结束。
    遗忘是一个改变敌人兵种性质的魔法，持续时间无限性进一步强化了作用。近战伤害不减的远程兵种还稍微好些，普通远程兵中了遗忘之后，其处境只能用“凄惨”来形容。虽然说精神魔法属性给这个魔法带来了一些限制条件，但不吃它的远程兵实际上只有弩车、火元素区区两种而已（不算资料片中的投石车），这两种兵也不算太强，所以遗忘在多数时候还是无比有用的。复生的尸体和幻象副本才稍微让人有点麻烦感觉，但一个驱散就足以对付了。

群体驱散（Mass Dispel）
派系：守序
类型：祝福类/诅咒类
    解除所有部队（包括敌我）身上附着的状态魔法，无论是正面还是负面的。其余特性与单体驱散相同。
    群体驱散是一个毁誉参半的魔法，有时极度有用，有时却因投鼠忌器而变为鸡肋，一切都要看实战的情况而定。对于中了怯懦的英雄来说，群体驱散有时会是相当不错的选择。

传送（Teleport）
派系：守序
类型：祝福类/诅咒类
    将部队传送到战场上的指定位置，可以用来传送敌人部队。
    飞行魔法依然不能完全弥补某些部队在移动力上的缺陷，这时便需要传送魔法出场了。传送本方部队多是为了躲避敌人的围攻，而传送敌方部队则为我方围攻敌人创造了条件。对视线没有要求，令传送成为对付敌人远程部队或英雄最好的方法之一。而在攻城战中，传送的优点就更加突出。
    在早期版本游戏中，传送敌人没有多少限制条件。从2.0版本开始，对其增加了魔法抗性影响因素，虽一定程度削弱了其作用，但这仍然是一个可超越三级地位的实用魔法。

群体诅咒（Mass Curse）
派系：死亡
类型：诅咒类
    使敌人所有部队处于受诅咒状态
    具体效果大小视施法对象而定，有时会比四级的群体虚弱更强。

瘟疫（Plague）
派系：死亡
类型：杀伤类/诅咒类
    使战场上所有部队中毒，不分敌我，包括施法者在内。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值。此魔法对无生命的部队或死亡系部队无效
    瘟疫的实用性可比毒害强多了。毒害多半用来制造无赖打法，而近似于群体毒害的瘟疫，却可以切切实实地给敌人部队以实质性影响，解除上的不易（只有几个治疗类魔法可消除），令瘟疫很容易延续较长时间，从而累积出相当不错的伤害值。另外，瘟疫和毒害状态是可以同时存在的，这就容易给敌人更大打击。在没有什么杀伤类魔法的死亡城，战斗一开始就使用瘟疫是个不错的选择。

群体废除（Mass Cancelation）
派系：死亡
类型：诅咒类
    解除敌人所有部队身上附着的正面魔法，可以用来直接驱除敌人操纵的尸体和幻象副本
    设定得有些失当的魔法。不管对方的正面魔法等级多少，就算是守护天使、龙之力量这样的高级货，一样难逃一抓，而且这还只是一个3级魔法。即使等级设定再高，其效果也是过分了的，因为不少高级祝福魔法都只是单体的，辛辛苦苦练半天，难道就是为了挨这一抓么？而且要注意，废除是可以用来解除宗师抗魔英雄身上的正面魔法的。
    其实驱除类魔法都存在效果过强的问题，只是在废除上体现得更加明显而已。如果将其作用改为：第一次使用时只把对象魔法效果减半（例如龙之力量减为生命值、伤害值加半，守护天使附加生命值减半等等），在此状态下再次使用驱除类魔法才能将对象魔法效果完全解除，可能会更合理些。当然，这只是我的瞎想而已。

榨取魔力（Magic Leech）
派系：死亡
类型：诅咒类
    使敌人部队在施法时要花双倍魔法值，并且将所消耗魔法值的一半转移到施法者身上
    与守序的能量损耗相仿，不能立刻产生实质性效果，需要在充分考虑战局走向后再使用。能够有吸取效果是其优势所在，此消彼长后敌人魔法英雄的作用就大大受抑制了。利用吸血鬼群产生的压迫力令对方英雄无暇去解除此魔法，使榨取魔力的实用性要高于能量损耗。单机游戏中，常常能看到电脑英雄使用，有时还是非常令人讨厌的。

四级魔法

疯狂（Berserk）
派系：守序
类型：诅咒类
    迫使单个敌方部队追击离他最近的部队（不分敌我），攻击后疯狂状态解除
    给敌人强力部队施放后，等着看敌人内讧，是非常快意的一件事情。虽然比催眠差不少，但也已经非常强了，经常可以改变双方的战力对比，只是要算清楚敌人部队的行动顺序，来决定使用的时机与对象。

失明（Blind）
派系：守序
类型：诅咒类
    使敌方部队在3个回合内无法行动，如果遭受伤害，失明状态将解除。施法对象必须在英雄视线内
    虽然只能持续三个回合，又有视线要求，但在规则改变的四代中，失明仍然不愧是一个称职的四级魔法。让敌人主力部队或英雄三个回合不能行动，我方可以腾出足够的时间来做别的事情，而且如今失明已经不像前几代那样容易被解除（比如说，英雄中招了，或是没有驱散、驱魔、防魔魔法）。
    需要注意的是，失明如今已经不是精神类魔法，在与元素或机械部队交战时，它常常能够发挥奇效。

群体迟缓（Mass Slow）
派系：守序
类型：诅咒类
    使敌人所有部队速度和战场移动力减半
    在面对高移动力兵种时，群体迟缓有时候会与单体迟缓产生本质区别，特别是在某些因敌人组成而被迫要采用分散阵型的时候。

混乱云（Cloud of Confusion）
派系：混乱
类型：诅咒类
    让英雄视线内半径4英尺区域里的所有敌人丧失一回合的行动机会
    不用说当然是好魔法，可惜作用范围稍微有点小，如果不结合分兵引诱战术，不能完全发挥威力。从效率上来看，不如单体混乱。但如果始终用巫师群战术，难免会造成英雄等级整体不高的局面，关键时刻缺少一个挑大梁者，而混乱云的出现，正好可以促使玩家作出决断，在合适时刻放弃一些英雄。

群体厄运（Mass Misfortune）
派系：混乱
类型：诅咒类
    使敌人所有部队幸运降到最低
    通过降低幸运的方法增加敌人所受伤害，其实也就等于是提高了我方部队的杀伤能力。既然与血暴有类似效果，作用面更广（对远程攻击也起作用），增强比例还更大，群体厄运作为四级魔法也是实至名归了。

群体虚弱（Mass Weakness）
派系：死亡
类型：诅咒类
    使敌人所有部队处于虚弱状态
    总觉得作为四级魔法稍微有点不够格，如果对攻击力的降低比例再提高些，可能会比较好。

群体悲泣（Mass Sorrow）
派系：死亡
类型：诅咒类
    使敌人所有部队士气降到最低
    作为与群体振奋效果对冲的魔法，其相克性是十分明显的，使用时机得当的话，可以产生比预期中更好的效果。

五级魔法

催眠（Hypnotize）
派系：守序
类型：诅咒类
    使敌人单个部队在三回合内受我方控制，对于部队的强度没有限制条件。控制对方部队后，不能对其进行远程攻击（范围攻击除外）；可以近身攻击，但会遭到反击。
    整个游戏中最为无耻的魔法，既无战力要求，又无视线要求，对平衡性的破坏实在太大，以至于一些新编地图干脆把它给禁用了。在早期版本中，可以对被催眠的部队使用牺牲或殉难，使催眠的无耻程度进一步加剧。从2.0版本开始，催眠+牺牲已经被禁用，而催眠到期后殉难状态也将自动消失。
    除了死亡族外，任何种族在面对守序族时都存着三分忌惮，就算英雄有宗师抗魔，仍然需要提防强力部队被催眠后给本方造成惨重损失。混乱的黑龙和自然的魔法，是对付催眠的利器，而英雄施法的时机，是需要重点参详的因素。

通法盗窃（Steal All Enchantments）
派系：守序
类型：诅咒类
    窃取敌方所有部队身上附着的所有正面魔法状态，转移到随机选取的本方部队身上
    窃取敌人所有正面魔法状态，此魔法与其单体版本的区别可比一般群体/单体的区别大多了。与痛苦之镜相仿，通法盗窃的对战价值也大于单机价值。虽然生命、自然和混乱系都有不少强效祝福类魔法可偷，但以电脑AI的弱智程度，兵力常常还不如玩家，根本没必要动用偷窃手段来对付。

死亡之手（Hand of Death）
派系：死亡
类型：诅咒类
    直接杀死一定数量的敌人，施法对象必须在英雄视线内。魔法参数：1/0.1，计算出的数值为所能杀死的敌人数量
    在对付四级兵的时候，其杀伤效果往往比碎裂更强。其作用与守护天使相比，刚好一反一正，威力相同，充分体现了死亡与生命的对立。但是死亡之手的出镜机会还是比守护天使差一些，因为亡灵巫师基本上都要投5个技能点在招魂技能上，没那么容易达到魔法宗师。而且若敌人也是死亡城，死亡之手便很难有用处了。


召唤类魔法

    魔鬼类召唤魔法（召唤恶魔之子、召唤地狱犬、召唤冰魔、召唤食尸怪和召唤恶魔），不会在任何城堡的魔法公会中出现，要学习只能靠同时修炼自然魔法技能和鬼神学技能。使用这几种魔法需要消耗许多魔法值（依次是5、8、12、18、24），但是威力也非常强。虽然看图标是死亡魔法，实际上却是自然魔法，效果受冥想技能影响，而与鬼神学技能无关。

一级魔法

驱役骷髅（Raise Skeletons）
派系：死亡
类型：召唤类
    利用我方或敌方的阵亡部队制造骷髅，可以对尸体或是损失了一部分的部队使用。制造出的骷髅数量不能超过阵亡部队的数量，骷髅生命总值也不能超过阵亡部队的生命总值，战斗结束后制造出的骷髅会自动消失。魔法参数：40/4，计算出的数值为驱役出的骷髅的经验总值。
    驱役骷髅的效果与自然的一级召唤魔法差不多。骷髅本身实力是很弱的，指望英雄制造出来的那点骷髅与对方死拼，是很难有理想结果的（一定数量的法师来制造还差不多）。此魔法的可用价值基本上就是那么一点：利用骷髅的高远程防御力来抵挡箭枝，对付低级远程兵效果还是不错的。

召唤丛林妖精（Summon Leprachaun）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的丛林妖精，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的丛林妖精的经验总值。
    召唤丛林妖精来使用幸运魔法，不仅仅是节省1点魔法值的区别，在利用了其幸运之后，还可以用来挡箭或是骗反击，充分榨干其每一分利用价值。这个魔法，算是最常用的一级召唤魔法了。

召唤妖精（Summon Sprite）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的妖精，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的妖精的经验总值。
    妖精的高移动力和不受反击特性，常常被利用来与低移动力步兵打游击战。偏低的攻击力使得这种游击战往往过程漫长，这时英雄若能召妖精，便会大大加快战斗的进程。当然，这种场合下最好要有加速或是流沙相辅助，以保证英雄安全。
    在英雄与野兵的单挑中，利用妖精的高移动力来调动敌人（飞到敌人后方送死，将敌人向远处调动）是常有的事情，即使在后期战斗中这个一级召唤魔法也相当有用。

召唤狼（Summon Wolf）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的狼，战斗结束后自动消失。魔法参数：40/3，计算出的数值为召唤出的狼的经验总值。
    狼的实力较强，但经验值也相应较高，在以经验值为准绳的召唤魔法中，召唤狼的数量要比召唤妖精的数量少不少。召唤次数少时，根本形不成威力；要持续召唤，又必须现实条件配合（敌人移动力低，或是有加速、流沙魔法保证英雄安全）。与妖精“有多少便可用多少”的情形不同，狼的数量若达不到一定规模，就不敢与敌人交火，这使得召唤狼的实用性比召唤妖精差了不少。在合适时发挥骗反击的效果，才是召唤狼的常见用途。

召唤恶魔之子（Summon Imps）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的恶魔之子，战斗结束后召唤的恶魔之子自动消失。魔法参数：125/12，计算出的数值为召唤出的恶魔之子的经验总值。
    最基本的魔鬼类召唤魔法，虽然是一级魔法，但从施法消耗和魔法威力上来看，都是与三级魔法相当的。效率上已经比普通一级召唤魔法高了，而魔法威力大使得召唤出来的恶魔之子可以很快形成数量上的优势，不需要漫长的积累过程，能较快地派出去与敌人交火。吸取魔力的特技有时会有用处，而利用恶魔之子生命值与经验值比例较高的特性，将其作为殉难魔法伤害转嫁的对象，也是常见应用之一。
    由于学习前提要求太高，魔鬼类召唤魔法在实战中出现的机会并不多。但只要有机会学到，利用率是相当高的。

二级魔法

制造幻象（Create Illusion）
派系：守序
类型：召唤类
    制造我方或敌方部队的副本。重复使用此魔法，会在第一组幻象上叠加数量。魔法参数：40/4，计算出的数值为副本的生命值。
    幻象魔法与前两代中的镜像/克隆魔法不同，不是直接制造与原部队数量一样、但一受攻击就立刻消失的副本，而是按照法术威力来制造一定数量的部队，虽然每次制造的数量不多。但重复使用可以逐渐增强其战力，灯神的辅助作用可以给这个有点长的积累过程以一定的安全期。与普通召唤魔法按部队经验值计算不同，按生命值计算的幻象最适合用来复制高级兵。因为可以复制敌人，即使没有四级兵助阵，一定数量的灯神也敢于去挑战四级野兵。但或许正是因为灯神可以使用这种魔法，因此驱散或废除可以直接用来驱除幻象副本，这可以看作是维护游戏平衡性的一个设计。
    对英雄来说，幻象魔法不是不好，但多数时候使用特权都会被灯神抢去，英雄用它的机会大大减少了。若守序之外的种族捡到了幻象法仗，倒是可以产生相当有趣的打法。

操纵尸体（Animate Dead）
派系：死亡
类型：召唤类
    复活敌方或我方阵亡的生物，可以对尸体或是损失了一部分的部队使用。复活出的生物属性为亡灵生物，受我方控制，战斗结束后自动消失。魔法参数：50/5，计算出的数值为复活的生物的生命值。
    和守序的幻象魔法相似，都是以生命值来计算魔法效果的，魔法参数稍高一些。但因为只能对阵亡部队使用，不像幻象可以凭空制造，因此两者效果还是基本相当的。法术威力本身并不太高，需要阵亡部队有不错的特技或魔法时，操纵尸体才会有比较强的使用价值。

召唤精灵（Summon Elf）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的精灵，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的精灵的经验总值。
    因为只是二级召唤魔法，威力并不大。早期一般就只能召唤那么几个精灵，若没有水元素的流沙战术配合，很难在敌人接近前积累起足够数量。与流沙战术配合，倒是很实用的，但在精灵积累一定数量之前，尽量不要出手，以免无谓消耗弹药数。

召唤白虎（Summon White Tiger）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的白虎，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的白虎的经验总值。
    与一级的召唤狼相类似，兵种实力强但难以积累数量是最大不利因素。但白虎的高移动力却比狼更有可用性，在对付野外低级远程部队时，召唤白虎扑上去，其余部队跟在后面推进，是一种可行的应用。

召唤半羊人（Summon Satyr）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的半羊人，战斗结束后自动消失。魔法参数：75/7，计算出的数值为召唤出的半羊人的经验总值。
    相当实用的魔法。与召唤丛林妖精相似，召唤并不是看重兵种本身的战力，而是看重了其魔法。振奋对行动顺序影响的重要性不多说了，半羊人能够施展两次振奋，让这个召唤变得相当合算。

召唤地狱犬（Summon Cerberi）
派系：自然
类型：召唤类
    在战斗中召唤一定数量地狱犬，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的地狱犬的经验总值。
    威力相当大，相当于普通的四级召唤魔法。合理安排战术，可以在敌人冲到我方附近之前积累差不多三次地狱犬，充分利用地狱犬的三头攻击，战胜实力两倍于其的敌人，不是太困难。相信对于此魔法的好用程度，打过半生者战役的玩家都应该有印象。

三级魔法

驱役幽灵（Raise Ghost）
派系：死亡
类型：召唤类
    利用阵亡部队制造幽灵，魔法参数：150/15，计算出的数值为驱役出的幽灵的经验总值，其他细节与驱役骷髅相似
    基本上就是死亡系最实用的三级魔法。制造幽灵的目的，几乎都是看重其老化能力。与疲劳之类的减速类效果相配合，可以把高移动力兵种玩弄于股掌之上。

召唤火元素（Fire Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的火元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的火元素的经验总值。
    三级召唤魔法的威力是二级召唤的两倍，也就是从这一级开始，召唤部队的战力开始体现。作为远程部队，召唤出来的火元素表现还是相当不错的。虽然射击威力很多时候都不如水元素的冰箭，但水元素经常都有很多事要做，两种元素都召，可以形成不错的搭配组合。

召唤水元素（Water Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的水元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的水元素的经验总值。
    最为重要的召唤魔法之一，其战略价值比起五级召唤术也不会差上多少。疲劳和流沙是步兵的天敌，而如果合理配合召唤妖精（妖精调动敌人+水元素疲劳+冰箭），可以轻易对付除凤凰/仙女龙/黑龙/骨龙/吸血鬼/幽灵之外的所有飞兵，这样水元素所不能对付的敌人就相当少了。而在面对远程部队时，适时召一次水元素，疲劳+虚弱，对战斗也是有相当帮助的。注意重复召唤水元素时，其魔法值会自动补满，因此其冰箭魔法的可持续杀伤力是相当强的。

召唤风元素（Air Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的风元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的风元素的经验总值。
    风元素高防御、高移动力的特征，最适合用来压制敌人远程部队。综合防御力来看，其战斗实力也是相当不错的。

召唤土元素（Earth Elemental）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的土元素，战斗结束后自动消失。魔法参数：150/15，计算出的数值为召唤出的土元素的经验总值。
    防御实力不如风元素，拉出去打架又太慢，召唤土元素可以说是四大元素召唤中最不实用的了。唯一可以利用的只有其抗魔特性，用来挡敌人杀伤类魔法还有点用处。

召唤冰魔（Summon Ice Demon）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的冰魔，战斗结束后自动消失。魔法参数：350/35，计算出的数值为召唤出的冰魔的经验总值。
    相当于五级召唤魔法，冷冻成功是最希望出现的事情，但总的来说，不如一般的五级召唤魔法。

四级魔法

幻影（Phantom Image）
派系：守序
类型：召唤类
    制造部队的副本，细节与制造幻象魔法相似，但魔法参数是80/8
    效果为幻象两倍的幻影，若与迟缓魔法结合，可以产生不错的效果。但与其余四级守序魔法相比，作用偏差了些，多少有点不称职的感觉。很多时候它只能作为对灯神幻象的一种补充，但不是决定性因素。
    早期版本中，对同一类兵使用幻影和幻象，会产生两队副本。但后来此缺陷已经被弥补了，制造出来的副本是叠加在一起的。

死亡呼唤（Death Calls）
派系：死亡
类型：召唤类
    作用与操纵尸体相似，但魔法参数是90/9
    操纵尸体魔法的加强版本。和操纵尸体一样，复生阵亡部队时看重的往往不是其战力，而是其辅助特性。亡灵复生类魔法和驱役类魔法一样，都切忌对本方损失一部分的吸血鬼使用，因为那会减少吸血鬼的尸体数量，从而使其在吸血后无法恢复到原始数量。

召唤狮鹫（Summon Griffin）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的狮鹫，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的狮鹫的经验总值。
    在暂时学不到五级召唤魔法的时候，这是个不错的选择。利用其无限反击的特性，召唤后丢进敌人丛中，有不错的战斗表现。

召唤独角兽（Summon Unicorn）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的独角兽，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的独角兽的经验总值。
    实用性比召唤狮鹫略逊一筹，都是在没有五级召唤时可以考虑使用的好魔法。虽然是地面部队，但战场移动力不错的独角兽，一样可以用来压制远程部队，其失明能力能够给战斗进程带来一些潜在帮助。

召唤毒蜂草（Summon Waspwort）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的毒蜂草，战斗结束后自动消失。魔法参数：250/25，计算出的数值为召唤出的毒蜂草的经验总值。
    除了特殊的召唤食尸怪外，这就是最强的远程部队召唤术了。毒蜂草本身的实力就不错，远程特性若配合流沙魔法，可望充分发挥每一箭的威力，是个效率不错的召唤魔法。

召唤食尸怪（Summon Venom Spawn）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的食尸怪，战斗结束后自动消失。魔法参数：525/52，计算出的数值为召唤出的食尸怪的经验总值。
    施法消耗比一般五级魔法还要多，召出来的部队绝对实力也更强一些，但是学习前提实在太高，而且在施法效率上感觉不如召唤螳螂和召唤仙女龙。

五级魔法

驱役吸血鬼（Raise Vampires）
派系：死亡
类型：召唤类
    利用阵亡部队制造吸血鬼，魔法参数：375/37，计算出的数值为驱役出的吸血鬼的经验总值，其他细节与驱役骷髅相似
    魔法参数和五级召唤魔法一样，但作用就差了那么点。主要是必须先制造阵亡部队，然后才能加以驱役，有时候差这么一回合是很要命的。而且驱役吸血鬼是三种驱役魔法中唯一可以被直接驱散、废除的，进一步降低了实用价值。

召唤凤凰（Summon Phoenix）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的凤凰，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的凤凰的经验总值。
    单论攻防实力，凤凰并不特别出众，但利用其重生特性，可以产生一系列的应用手段。被击倒后自动重生，等于可以多吸引敌人主力部队一回合的攻击火力，为我方其余部队的行动争取到时间。而重复使用召唤凤凰，其重生数量会逐步叠加，到最后会形成战斗力相当强的一支部队。
    另外要注意到凤凰的生命值要比仙女龙和螳螂高许多，加上有复生能力，与殉难魔法配合时效果特别好。

召唤仙女龙（Summon Faerie Dragon）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的仙女龙，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的仙女龙的经验总值。
    仙女龙的主要作用在于牵制，如果要靠法术攻击的话，只能用8次魔法未免有点少。但五级召唤魔法只是作为牵制力量，感觉比较尴尬，如果能够与招募来的仙女龙相配合，就比较好。战斗开始时召唤一次牵制敌人，在战局进行到一定阶段时（敌人分队被消灭一两组），能够腾出手来就改用闪电，反正再次召唤后魔法值会补满，累加下来闪电伤害是非常可观的。

召唤螳螂（Summon Mantis）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的巨型螳螂，战斗结束后自动消失。魔法参数：375/37，计算出的数值为召唤出的螳螂的经验总值。
    螳螂的缠身技能，不仅能够保护英雄的安全，而且也使螳螂的生存时间相对较长，便于重复召唤迅速积累数量，并能较快腾出手来使用龙力之类的祝福魔法。虽然攻击能力相对不高，但在很多时候螳螂的召唤都是最为好用的五级召唤魔法。

召唤恶魔（Summon Devils）
派系：自然
类型：召唤类
    在战斗中召唤一定数量的恶魔，战斗结束后自动消失。魔法参数：675/67，计算出的数值为召唤出的恶魔的经验总值。
    全屏移动加上召唤数量多，用召唤恶魔来秒杀英雄是再好也没有了。但至少需要27个技能点才能学会召唤恶魔，过程实在太漫长，而且初始发展就不容易走上这条道路，要靠地图特殊设定或是天降好运了。


冒险魔法

有少数魔法既可以在战场上使用，又可以在地图上使用

一级魔法

真视（Visions）
派系：守序
类型：冒险魔法
    显示敌人部队里的生物数量和英雄技能。
    除了不能增加视野范围外，基本相当于大师侦察技能的作用。这对实战来说相当有帮助，特别是在不允许取进度的对战中，有利于做好战前预判工作。另外可以看到电脑对战斗结果的预测（专家侦察技能就有的效果），也颇有文章可作。电脑预测出来的结果，一般会与你使用快速战斗（Quick Combat）打出的结果相当。虽然电脑的AI远不如人脑，但在某些特殊情况下，快速战斗的结果却比手动指挥更好，这是因为快速战斗时忽略了敌人的某些特性，如吸血鬼的吸血，法师、灯神的魔法等等。当然，若有人认为在这种情况下使用快速战斗等于利用Bug，而不屑于使用的话，那还是不要用好了。

疗伤（Bind Wound）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，魔法参数：30/3，计算出的数值为治疗的生命点数
    疗伤的作用在于延长部队存活的时间，其效果的实际大小并不仅仅看法术的威力，而且还要看受治疗部队的防御力。生物或英雄的防御力越高，疗伤的使用就显得越加有价值。虽然法术参数与魔箭相当，但对防御力远高于敌人攻击力的部队来说，受到救助比直接消灭那么点敌人更加合算。
    生命族若在开始阶段有高防御的英雄（可以考虑招募邻族的射手），配以适时的治疗类魔法，便可大胆前去牵制敌人部队，为我方部队（主要是远程）的攻击争取到足够的时间。

召船（Summon Ship）
派系：生命
类型：冒险魔法
    召唤一艘船，要求本方必须有船
    本方必须有船的前提条件，令此魔法不像三代那样神通广大，只能算是一个普通的一级魔法。但在有些战役中，为了维护剧情的严谨性，会特意去禁止这个魔法。

寻路（Pathfinding）
派系：自然
类型：冒险魔法
    使部队在任何地形上移动时都不会受到额外的损耗
    相当好用的辅助魔法，进一步强化了自然城行军快速的特点。每天使用一次便能对整支部队产生影响，只是在部队有新成员加入时需要再次施法，避免新成员拖慢整支部队的行动。

二级魔法

医疗（Heal）
派系：生命
类型：祝福类
    恢复本方单个部队一定生命值，另外解除部队的中毒与瘟疫状态，魔法参数：50/5，计算出的数值为治疗的生命点数
    作为疗伤的强化版本，医疗在效率上更胜一筹，并且拥有解除中毒与瘟疫状态的效果，无疑是重要的二级魔法。

泥潭（Mire）
派系：死亡
类型：冒险魔法
    使敌方部队在地图上的移动力减半，只能对施法者附近的敌人使用，效果维持一天
    死亡系的优势魔法之一，降低敌方部队地图移动力，对于追击或是逃避追击都有极强的实用性。而敌人中招之后没有任何办法可以消除其不良影响。

三级魔法

回城（Town Gate）
派系：守序
类型：祝福类/冒险魔法
    使施法英雄及其带领的整支部队回到最近的本方城堡，可以在战场上使用。
    又是一个体现守序系特权的魔法，可以说相当不公平。当灯神魔法值耗完时回城，是此魔法的一种应用，可以让某些原本无法打赢的战斗分几次来完成。堵城门使用或是在城堡附近战斗中使用，可以让部队回到较远的城堡里。合理综合利用上述规则，甚至可以使回城魔法有前两代中大回城的效果，这样守序族调动兵力就变得很容易实现，这是其他种族所难以企及的优势（其他族只能用战斗中逃跑的方法来调动英雄）。生命城堡和死亡城堡有些时候还可以跟着沾点光，其余种族可就只能眼睁睁面对不公平待遇了。

群体医疗（Mass Heal）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：25/2，计算出的数值为治疗的生命点数
    魔法威力稍微有点低。但既然不能复活部队，那么这样的威力也就算是可以了，反正四级兵也不见得有多少血。能够给全体解毒是其最大用处，正好用来对付死亡系的瘟疫。

再生（Regeneration）
派系：生命
类型：祝福类
    使部队每回合自动恢复一定生命值，魔法参数：20/2，计算出的数值为每回合自动恢复的生命点数
    因为威力较低，所以加给高防御的英雄要比加给兵种更合适。每回合都能恢复的持续性，是再生魔法的最大亮点。如果与一堆保护类魔法相结合，有可能产生敌人打的速度还没再生恢复速度快的局面，这也就意味着英雄永远打不死了。若能做到，兵就没必要带了，避免决战前的无谓损失。

五级魔法

神圣介入（Divine Intervention）
派系：生命
类型：祝福类
    治疗本方所有部队，魔法参数：50/5，计算出的数值为治疗的生命点数。不复活死亡部队，复活英雄，但要在魔法威力超过英雄生命值上限的情况下才能复活。如果部队接受治疗（前提是有损血），那么在补生命值同时会解除身上所有负面魔法状态，包括中毒和瘟疫。
    怎么说呢？一个作用强大，但利用率却不高的魔法吧。因为使用此魔法，需要至少有2个高等级英雄（包括生命系这个）才会有意义，这在一般地图中不容易出现，而战役中敌人又太弱了，根本用不到。可能在一些变态地图中，神圣介入才会找到施展拳脚的最好舞台。


宝物

    四代的宝物基本分为五个等级，从低到高依次是：道具（Item）、财宝（Treasure）、二流宝物（Minor）、一流宝物（Major）和神器（Relic）。如果不计算道具，那么宝物的分级是和三代一样的，从财宝到神器我们依次称为初级宝物、中极宝物、高级宝物和超级宝物。

    除一般宝物外，还有四代所新增的药水（Potion），药水绝大多数是用来强化英雄能力的，只能对英雄本人起作用，此外也有少部分药水可以起到杀伤或削弱敌人的作用。道具也只能对英雄产生作用，不影响率领的生物，一部分道具和药水可以在铁匠铺里直接买到。

    在游戏开发的过程中，开发者曾经设计了威力极其强大的合成宝物，例如抵抗之盾（Shield of Resistance）：在战斗中禁止所有魔法的使用；力量系部队速度+2，生命值和伤害值加半；其他族部队生命值和伤害值减少1/3，移动力-1。很可惜合成宝物后来在开发过程中被取消，也许是因为觉得作用太强，破坏平衡吧？同时被取消的还有可以提高生物产量的军团宝物。


药水

图标 | 名称 | 装备位置 | 说明
 | 绝望烟雾瓶 Cloud of Despair | 背包 | 投掷后影响半径4英尺（直径9英尺）范围内的多支敌方部队，使它们士气降到最低（-10）
 | 恶魔之火瓶 Demon Fire | 背包 | 对半径4英尺范围内的敌方部队进行攻击，效果同火球魔法
 | 圣水 Holy Water | 背包 | 对敌人使用时，相当于圣词（Holy Word）魔法；对英雄本人使用时，相当于死亡抵御魔法和祝福魔法（早期版本有Bug，不能对英雄本人使用，2.0以及更高版本已经修正错误）
 | 寒冷药水 Potion of Cold | 背包 | 英雄饮用药水后，近战攻击时有可能将敌人冻结两回合。可在地图上饮用
 | 耐力药水 Potion of Endurance | 背包 | 部队地图移动力+3（如果还有加移动的技能或宝物，同比例提升），每天每支部队只能饮用一瓶此药水
 | 防火药水 Potion of Fire Resistance | 背包 | 获得火抵抗效果
 | 康复药水 Potion of Healing | 背包 | 只能对英雄本人使用，完全治愈，同时解除所受的中毒和瘟疫状态。可在地图上饮用
 | 不朽药水 Potion of Immortality | 背包 | 英雄饮用后，在战场上阵亡时可自动复活一次。可以在战前或战斗中使用
 | 幸运药水 Potion of Luck | 背包 | 饮用后英雄幸运值提到最高（+10）
 | 魔力药水 Potion of Mana | 背包 | 在战斗中或地图上使用，提高英雄魔力值25点，可以超过上限。
 | 振奋药水 Potion of Mirth | 背包 | 饮用后英雄士气值提到最高（+10）
 | 急速药水 Potion of Quickness | 背包 | 英雄饮用药水后在主动攻击时可以多打一下，效果延续两回合（从喝药水的下一回合开始算）
 | 抵抗药水 Potion of Resistance | 背包 | 英雄在战斗中饮用后，提高50%抗魔能力
 | 恢复药水 Potion of Restoration | 背包 | 解除英雄身上的所有负面魔法
 | 速度药水 Potion of Speed | 背包 | 在战斗中提高英雄速度3点
 | 力量药水 Potion of Strength | 背包 | 英雄伤害力提升25%。可在地图上饮用
 | 强壮药水 Potion of Toughness | 背包 | 英雄生命值上限提升25%。可在地图上饮用
 | 酸液瓶 Vial of Acid | 背包 | 对敌人部队使用，可以使其近战和远程防御力降低20%；对倒在地上的部队尸体使用，可以将尸体毁去
 | 粘结剂瓶 Vial of Binding Liquid | 背包 | 只能对敌人飞行部队使用，使其丧失飞行能力，并且速度与战场移动力减半
 | 迷雾瓶 Vial of Blinding Smoke | 背包 | 在半径4范围内制造迷雾。迷雾不影响部队的移动，只是对远程攻击而言，相当于普通障碍物，对一般远程攻击有伤害减半效果
 | 毒气瓶 Vial of Choking Gas | 背包 | 投掷后影响半径4英尺范围内的多支敌方部队，使其攻击力和防御力下降15%
 | 毒液瓶 Vial of Poison | 背包 | 英雄饮用后，攻击时能使对方部队中毒


道具

图标 | 名称 | 装备位置 | 说明
 | 战斧 Axe | 右手 | 英雄近战攻击力+8，但速度-1
 | 锁甲 Chain Mail | 躯体 | 英雄近战防御力和远程防御力+8，但战场移动力-1，施法消耗+1
 | 钢甲 Plate Mail | 躯体 | 英雄近战防御力和远程防御力+10，但战场移动力-2，施法消耗+2
 | 弩 CrossBow | 弓弩 | 英雄远程攻击力+3，远程攻击不受距离损耗。英雄即使不会箭术技能，装备后仍然可以射击
 | 巨剑 Great Sword | 双手 | 英雄近战攻击力+12.5。
 | 皮甲 Leather Armor | 躯体 | 英雄近战防御力和远程防御力+5
 | 长弓 Longbow | 弓弩 | 英雄远程攻击力+5，即使不会箭术技能，装备后仍然可以射击
 | 长剑 Long Sword | 右手 | 英雄近战攻击力和近战防御力+3
 | 法师杖 Mage's Staff | 双手 | 英雄施法消耗-1（最少要消耗1）
 | 盾牌 Shield | 左手 | 英雄近战防御力和远程防御力+3
 | 望远镜 Telescope | 杂物 | 英雄在地图上视野半径+1


初级宝物

图标 | 名称 | 装备位置 | 说明
 | 学徒手册 Apprentice's Handbook | 左手 | 包含了所有一级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 晕击箭 Arrow of Stunning | 杂物 | 英雄射击时一定几率击晕射击对象，让其一回合无法行动和反击。成功率计算公式同侍从晕击技能
 | 勇气徽章 Badge of Courage | 杂物 | 使英雄所带领的生物不受恐惧类效果（包括骨龙的“引起恐惧”技能、梦魇兽和黑骑的恐惧魔法，还有恐惧结界魔法以及相关宝物）影响
 | 黄金袋 Bag of Gold | 杂物 | 装备后每天生产500金
 | 知识之帽 Cap of Knowledge | 头部 | 英雄魔法值上限+5，并且每天多恢复1点魔法值
 | 木材马车 Cart of Lumber | 杂物 | 装备后每天生产2木材
 | 矿石马车 Cart of Ore | 杂物 | 装备后每天生产2铁矿石
 | 英勇徽章 Crest of Valor | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）士气+1
 | 记忆水晶 Crystal of Memory | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）不受健忘魔法影响
 | 大卫投石索 David's Sling | 弓弩 | 英雄所带领的生物在射击四级生物时可造成双倍伤害。英雄即使不会箭术，装备后仍然可以射击
 | 矮人战锤 Dwarven Hammer | 右手 | 英雄近战攻击力+10
 | 矮人圆盾 Dwarven Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高20%，英雄本人近战和远程防御力+3
 | 精灵锁甲 Elven Chain Mail | 躯体 | 英雄近战和远程防御力+10
 | 四叶草 Four Leaf Clover | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 赌徒之牌 Gambler's Deck | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 视力头盔 Helm of Seeing | 头部 | 英雄及其带领的所有部队（包括生物和英雄）对失明魔法免疫
 | 马蹄铁 Horseshoe | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 羊皮纸 Parchment | 左手 | 记载一种魔法，英雄只要掌握了相应的魔法技能，装备后就能够学会此魔法。学会之后羊皮纸自动消失
 | 黄金包 Purse of Gold | 杂物 | 装备后每天生产250金
 | 健康指环 Ring of Health | 戒指 | 英雄生命值+50%
 | 保护指环 Ring of Protection | 戒指 | 英雄带领的所有生物近战和远程防御力提高20%
 | 力量指环 Ring of Strength | 戒指 | 英雄近战和远程攻击力+5
 | 守卫长袍 Cloak of Warding | 肩 | 英雄抗魔能力提高30%
 | 魔法卷轴 Scroll | 左手 | 装备后使英雄能够施展所记载的魔法，相应消耗减半，无论英雄是否已掌握相关技能
 | 六分仪 Sextant | 杂物 | 海上行动力提高50%
 | 蛛丝箭 Spider's Silk Arrows | 杂物 | 英雄射击敌飞行部队时，让其丧失飞行能力，并且速度和战场移动力减半。
 | 水晶球 Viewing Crystal | 杂物 | 英雄在地图上视野半径+2
 | 战争投石索 War Sling | 弓弩 | 英雄远程攻击力+10，即使不会箭术技能，装备后仍然可以射击
 | 战神指环 Warlord's Ring | 戒指 | 英雄带领的所有生物近战和远程攻击力提高20%
 | 术士指环 Wizard's Ring | 戒指 | 英雄魔法值上限+5，并且每天多恢复1点魔法值


中级宝物

图标 | 名称 | 装备位置 | 说明
 | 恐惧护身符 Amulet of Fear | 颈部 | 作用类似于恐惧结界魔法
 | 天使之刃 Angle's Blade | 右手 | 英雄本人近战攻击力和近战防御力+3。英雄及其带领的所有部队攻击死亡系部队时，可以额外造成50%伤害（事实上不会有任何效果）
 | 死亡护身符 Amulet of the Undertaker | 颈部 | 英雄招魂技能+10%。如果英雄不会招魂技能，那么装备此护身符后相当于掌握了基础招魂
 | 圣十字 Ankh of Life | 颈部 | 英雄复活技能+5%。如果英雄不会复活技能，那么装备圣十字后相当于掌握了基础复活
 | 杀戮之箭 Arrow of Slaying | 杂物 | 让英雄本人在射击四级生物时可造成双倍伤害
 | 野蛮人投棍 Barbarian Throwing Club | 弓弩 | 英雄近战和远程攻击力+5，有一定几率击晕敌人，即使不会箭术技能，装备后仍然可以射击
 | 鳄皮靴 Boots of Crocodile | 脚部 | 在沼泽地形上移动时，不需要额外损耗行动力
 | 硫磺火盆 Brazier of Sulfur | 杂物 | 装备后每天生产1硫磺
 | 保护长袍 Cape of Protection | 肩部 | 英雄带领的所有生物（不包括英雄）抗魔能力+30%。
 | 智慧头冠 Circlet of Wisdom | 头部 | 英雄魔法值上限+10，并且每天多回复2点魔法值
 | 分心斗篷 Cloak of Distraction | 肩部 | 按说明，是让英雄无视敌部队的震慑范围。但无论是在战斗中还是地图上，都没有效果
 | 抵抗斗篷 Cowl of Resistance | 肩部 | 英雄抗魔能力提高50%
 | 附魔王冠 Crown of Enchantment | 头部 | 装备后可以对免疫精神魔法的生物使用精神魔法
 | 十字军锤棍 Crusader's Mace | 右手 | 英雄带领的所有生物近战和远程攻击力30%
 | 水晶雕像 Crystal Figurine | 杂物 | 装备后每天生产1水晶
 | 鬼神宝典 Demonary | 左手 | 所有恶魔召唤术效果提高100%
 | 龙鳞盾牌 Dragon Scale Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高25%，并获得火抵抗状态。火抵抗状态不是一直持续，变化规律同灾祸项圈
 | 德鲁伊锁链 Druid's Chain | 颈部 | 英雄召唤技能效果提高10点。如果英雄不会召唤技能，那么装备后相当于掌握了基础召唤
 | 骑兵手套 Equestrian Gloves | 戒指 | 部队陆地移动力提高25%
 | 防火靴 Fireproof Boots | 脚部 | 在熔岩地形上移动时，不需要额外损耗行动力
 | 水银瓶 Flast of Mercury | 杂物 | 装备后每天生产1水银
 | 宝石箱 Gem Casket | 杂物 | 装备后每天生产1宝石
 | 巨人杀手之剑 Giant Slayer | 右手 | 英雄近战攻击力和近战防御力+3，并且在对四级生物进行近身攻击时，伤害力加倍
 | 镀金钢甲 Golden Plate Mail | 躯体 | 英雄近战和远程防御力提高25%，但施法消耗+1
 | 敏捷战戟 Halberd of the Swiftwatch | 双手 | 英雄近战攻击力+25，速度+2，忽略敌人的抢先攻击能力，并获得长武器攻击能力
 | 丑陋面具 Hideous Mask | 头部 | 赋予英雄以骨龙的“引起恐惧”能力（参考生物特技页面）
 | 学徒笔记 Journeyman Notebook | 左手 | 包含了所有二级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 丛林妖精指环 Leprechaun's Ring | 戒指 | 英雄及其带领的所有部队（包括生物和英雄）幸运值+2
 | 航海日志 Logbook of the Master Sailer | 左手 | 海上移动力提高50%。海上战斗中所率领生物攻击防御力提高20%
 | 法师长袍 Mage's Robe | 肩部 | 英雄施法消耗-1
 | 魔法头饰 Magic Amplifier | 头部 | 英雄带领的所有生物施法消耗减少1/3
 | 荣誉勋章 Medal of Honor | 颈部 | 英雄及其带领的所有部队（包括生物和英雄）士气值+2
 | 精神护盾 Mind Shield | 头部 | 使英雄及其带领的所有部队（包括生物和英雄）免受精神类魔法/技能影响
 | 领导头盔 Mullich's Helm of Leadership | 头部 | 英雄及其带领的所有部队（包括生物和英雄）士气+2，所带领的生物速度+1
 | 媚惑项链 Necklace of Charm | 颈部 | 英雄媚惑技能提高5%。如果英雄不会媚惑技能，那么装备此项链后相当于掌握了基础媚惑
 | 毒箭 Poison Arrow | 杂物 | 英雄远程攻击时能使敌人中毒，作用与死亡魔法的施毒术相同
 | 吝啬鬼钱包 Purse of Penny Pinching | 杂物 | 装备此宝物的英雄招募部队时花费降低10%
 | 眼镜蛇指环 Ring of the Cobra | 戒指 | 英雄攻击时能使敌人中毒，作用与死亡魔法的施毒术相同
 | 元素指环 Ring of the Elementals | 戒指 | 元素召唤术效果加100%
 | 小否定指环 Ring of Lesser Negation | 戒指 | 英雄施法时忽略敌人的所有抵御（Ward）技能或状态
 | 永恒指环 Ring of Permanency | 戒指 | 保证英雄及其带领的所有部队（包括生物和英雄）身上附着的正面魔法不被敌人驱散、废除或窃取
 | 速度指环 Ring of Speed | 戒指 | 英雄本人及其带领的生物速度+2，不影响部队里其他英雄
 | 黄金麻袋 Sack of Gold | 杂物 | 装备后每天生产750金
 | 沙漠草鞋 Sandwalker Sandals | 脚部 | 在沙漠上移动时，不需要额外损耗行动力
 | 狙击弩 Sniper's Crossbow | 弓弩 | 英雄远程攻击力+3，本人及所带领的远程生物射击时伤害不受射击距离影响。英雄即使不会箭术技能，装备后仍然可以射击
 | 雪地之鞋 Snowshoes | 脚部 | 在雪地上移动时，不需要额外损耗行动力
 | 政治家勋章 Statesman's Medal | 颈部 | 英雄外交技能提高10%。如果英雄不会外交技能，那么装备此勋章后相当于掌握了基础外交
 | 坚定盾牌 Steadfast Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高30%，英雄本人近战和远程防御力+3
 | 稳当之靴 Surefooted Boots | 脚部 | 在粗糙之地上移动时，不需要额外损耗行动力
 | 投枪 Throwing Spear | 弓弩 | 英雄近战和远程攻击力+7.5，即使不会箭术技能，装备后仍然可以射击
 | 懒惰之弓 Valder's Bow of Sloth | 弓弩 | 英雄远程攻击力+5，即使不会箭术技能，装备后仍然可以射击。射击时附带疲劳魔法效果
 | 操纵尸体权杖 Wand of Animating Dead | 右手 | 允许英雄使用操纵尸体魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点。施法消耗的魔法值是权杖本身的魔法值，不是英雄的，以下同
 | 祝福权杖 Wand of Blesses | 右手 | 允许英雄使用祝福魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 诅咒权杖 Wand of Curses | 右手 | 允许英雄使用诅咒魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 火权杖 Wand of Fire | 右手 | 允许英雄使用火矢魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 火球权杖 Wand of Fireballs | 右手 | 允许英雄使用火球魔法。战斗开始时，权杖有6点魔法值，另外每回合恢复2点
 | 疾行权杖 Wand of Haste | 右手 | 允许英雄使用疾行魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 医疗权杖 Wand of Healing | 右手 | 允许英雄使用医疗魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 冰权杖 Wand of Ice | 右手 | 允许英雄使用冰箭魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 幻象权杖 Wand of Illusion | 右手 | 允许英雄使用制造幻象魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 虚弱权杖 Wand of Weakness | 右手 | 允许英雄使用虚弱魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点


高级宝物

图标 | 名称 | 装备位置 | 说明
 | 混乱护甲 Armor of Chaos | 躯体 | 英雄近战和远程防御力+20，并获得守序抵御状态
 | 死亡护甲 Armor of Death | 躯体 | 英雄近战和远程防御力+20，并获得生命抵御状态
 | 生命护甲 Armor of Life | 躯体 | 英雄近战和远程防御力+20，并获得死亡抵御状态
 | 守序护甲 Armor of Order | 躯体 | 英雄近战和远程防御力+20，并获得混乱抵御状态
 | 传说战斧 Axe of Legends | 右手 | 英雄近战攻击力+7.5，所带领生物的近战和远程攻击力提高40%
 | 探险家之靴 Boots of the Explorer | 脚部 | 在所有特殊地形上移动时，都不需要额外损耗行动力
 | 旅行之靴 Boots of Travel | 脚部 | 部队陆地移动力提高50%
 | 再生胸甲 Breastplate of Regeneration | 躯体 | 英雄近战和远程防御力+20，并且每回合自动恢复20点生命值。英雄每升一级，每回合还可以多恢复2点
 | 硫磺胸甲 Brimstone Breastplate | 躯体 | 英雄近战和远程防御力+20，并且会有火盾护身
 | 灾祸项圈 Collar of Misfortune | 颈部 | 自动对敌人所有部队（100%抗魔的除外）附加灾祸状态。敌人部队移动一次后灾祸解除，再移动一次又被附加灾祸……循环反复。若部队在原地不动，无论是防御、施法还是攻击，灾祸/无灾祸的状态都不发生翻转
 | 死亡护盾 Death Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得生命抵御状态。生命抵御不是一直持续，变化规律同灾祸项圈
 | 龙鳞铠甲 Dragon Scale Armor | 躯体 | 英雄近战和远程防御力+25，并且获得火抵抗状态
 | 珠宝弓 Emerald Bow | 弓弩 | 英雄远程攻击力+30
 | 火炎之剑 Flaming Sword | 右手 | 英雄近战攻击力和近战防御力+3，攻击时附带30点的火属性伤害。英雄每升一级，附带伤害还会加3点
 | 格里冯哈特钢甲 Gryponheart's Plate Mail | 躯体 | 英雄近战防御力和远程防御力+30
 | 公会首领之书 Guildmaster's Compendium | 左手 | 包含了所有四级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 指挥头盔 Helm of Command | 头部 | 英雄带领的所有部队近战和远程防御力、近战和远程攻击力提高20%，速度+1
 | 能量头盔 Helm of Power | 头部 | 英雄魔法值上限+20，并且每天多回复4点魔法值
 | 生命护盾 Life Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得死亡抵御状态。死亡抵御不是一直持续，变化规律同灾祸项圈
 | 勇气狮盾 Lion's Shield of Courage | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高40%
 | 法术转向斗篷 Mantle of Spell Turning | 肩部 | 英雄抗魔能力提高70%
 | 马兰迪酒杯 Maranthea's Mug | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）士气+3
 | 大师魔法书 Master's Spellbook | 左手 | 包含了所有三级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 伤害法杖 Mayhem Staff | 双手 | 混乱魔法伤害加50%（火球魔法例外）
 | 报复之镜 Mirror of Revenge | 颈部 | 装备之后英雄获得魔镜状态
 | 再生指环 Ring of Regeneration | 戒指 | 每回合自动恢复20点生命值。英雄每升一级，每回合还可以多恢复2点
 | 守护者长袍 Robe of the Guardian | 肩部 | 每场战斗英雄所遭受的前三次伤害都被视为无效伤害
 | 圣徒法杖 Saint Ranan's Staff | 双手 | 所有治疗类法术效果提高100%，战斗结束后自动复活20%阵亡部队
 | 力量鳞甲 Scale Mail of Strength | 躯体 | 英雄近战和远程防御力、近战和远程攻击力+10
 | 海员帽 Seaman's Hat | 头部 | 上下船时只消耗少量行动力（相当于移动一格）
 | 战争枷锁 Shackles of War | 杂物 | 在战场上禁止双方投降或逃跑
 | 混乱护盾 Shield of Chaos | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得守序抵御状态。守序抵御不是一直持续，变化规律同灾祸项圈
 | 守序护盾 Shield of Order | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得混乱抵御状态。混乱抵御不是一直持续，变化规律同灾祸项圈
 | 夺魂剑 Soul Stealer | 右手 | 英雄近战攻击力和近战防御力+4。近身攻击时将敌人损失生命值的一半吸到自己身上
 | 半人马标枪 Spear of the Centaur | 弓弩 | 英雄近战和远程攻击力+7.5，英雄带领的所有远程部队近战杀伤不减半
 | 死亡法杖 Staff of Death | 双手 | 死亡魔法效果加50%
 | 能量法杖 Staff of Power | 双手 | 施法消耗减少1/3（最少消耗1点）
 | 召唤法杖 Staff of Summoning | 双手 | 召唤魔法消耗减半（最少消耗1点）
 | 魔力法杖 Staff of Wizardry | 双手 | 守序魔法消耗减半（最少消耗1点）
 | 敏捷之剑 Sword of Swiftness | 右手 | 英雄近战攻击力和近战防御力+6，主动近身攻击时能够多打一下
 | 混乱魔法宝典 Tome of Chaos | 左手 | 包含了所有混乱魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 死亡魔法宝典 Tome of Death | 左手 | 包含了所有死亡魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 生命魔法宝典 Tome of Life | 左手 | 包含了所有生命魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 自然魔法宝典 Tome of Nature | 左手 | 包含了所有自然魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 守序魔法宝典 Tome of Order | 左手 | 包含了所有守序魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 泰南匕首 Tynan's Dagger | 右手 | 近身攻击时给对手附加悲泣状态
 | 反自然护甲 Unnatural Armor | 躯体 | 英雄近战和远程防御力+20，并获得自然抵御状态
 | 反自然护盾 Unnatural Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得自然抵御状态。自然抵御不是一直持续，变化规律同灾祸项圈
 | 飞翼便鞋 Winged Sandals | 脚部 | 英雄带领的所有生物战场移动力+2（码）


超级宝物

图标 | 名称 | 装备位置 | 说明
 | 合金护甲 Adamantine Armor | 躯体 | 英雄近战和远程防御力+50
 | 合金护盾 Adamantine Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高50%，英雄本人近战和远程防御力+3
 | 大法师宝典 Archmage's Codex | 左手 | 包含了所有五级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 精灵王之弓 Bow of the Elf King | 弓弩 | 英雄远程攻击力+5，即使不会箭术，仍然可以进行射击。所带领的所有生物在射击时能多射一下
 | 公牛战斧 Bull Rune Battleaxe | 右手 | 英雄近战攻击力+50
 | 火炎之箭 Flaming Arrow | 杂物 | 装备后使英雄的射击带范围攻击属性。在3.0版本的游戏中，除射击中心之外，周围波及范围造成的伤害类似于火魔法，不能损伤具备火抵抗能力的部队。
 | 角弓 Horned Bow | 弓弩 | 英雄远程攻击力+50
 | 无伤害斗篷 Neener's Invulnerable Cloak | 肩部 | 使英雄抗魔能力达到100%
 | 强烈否定指环 Ring of Greater Negation | 杂物 | 去除战场上敌我所有部队的魔法抵抗力和免疫力
 | 召唤圣甲虫 Scarab of Summoning | 颈部 | 召唤类魔法（包括召唤、幻象、制造亡灵等）效果提高100%
 | 法师王冠 Supreme Crown of the Magi | 头部 | 英雄魔法值上限+50，并且每天多回复10点魔法值
 | 众神之剑 Sword of the Gods | 右手 | 英雄近战攻击力和近战防御力+3，所带领的生物近战和远程攻击力提高50%
 | 雷电战锤 Thunder Hammer | 双手 | 英雄近战攻击力+7.5，近战攻击时附带70点闪电伤害。英雄每升一级，闪电伤害还会提高7点


战役宝物

并非威力巨大的特殊宝物，只不过是在战役中出现，而一般地图中找不到这些宝物罢了。

图标 | 名称 | 装备位置 | 说明
 | 小鹰 Breeze the Falcon | 左手 | 英雄在地图上视野半径+1
 | 伪·狮鹫心之刃 False Gryphonheart Blade | 右手 | 英雄近战攻击力和近战防御力+8
 | 真·狮鹫心之刃 True Gryphonheart Blade | 右手 | 英雄近战攻击力和近战防御力+8，所带领的生物近战和远程攻击力提高40%
 | 游牧人黑弓 Nomad Blackbow | 弓弩 | 英雄远程攻击力+20，即使不会箭术技能，装备后仍然可以射击
 | 死木法杖 Deadwood Staff | 双手 | 允许英雄使用死亡之手魔法。战斗开始时，法杖有12点魔法值，另外每回合恢复2点


阴云密布宝物

阴云密布新增宝物

    以下宝物都是资料片阴云密布战役中所出现的新宝物，虽然作用有高低之分，但宝物等级却都是超级（神器，Relic），也就是说在一般地图中很难得到。

图标 | 名称 | 装备位置 | 说明
 | 行路之靴 Wayfaring Boots | 脚部 | 英雄魔法值+10，部队的地图移动力提高25%，并且在地图上移动时忽略特殊地形对移动力的额外损耗。
 | 大法师之帽 Archmage's Hat | 头部 | 英雄魔法值+10，每天多恢复2点魔法值，并且始终保持模糊状态（受远程攻击时伤害减少1/3）。
 | 天使羽毛斗篷 Angelfeather Cloak | 肩部 | 英雄魔法值+10，在战场上自动获得飞行状态，并且有天堂之盾护身
 | 闪光指环 Ring of Flares | 戒指 | 英雄魔法值+10，施法消耗-2
 | 瓦解法杖 Staff of Disruption | 右手 | 英雄魔法值+10，忽视敌方所有抵御（Ward）状态（无论是本身的技能、职业特性，还是用宝物或魔法附加的）
以上五件宝物组合在一起就是大法师套装。一个英雄如果同时装备这些宝物，在轮到他行动时便会忽略战场上所有部队的魔法抵抗力。这里忽略的只是魔法抵抗力（Magic Resistance），像矮人、金人、土元素的技能，以及英雄的抗魔技能，不忽略魔法免疫力（Immune to Magic），像黑龙免疫所有魔法、亡灵免疫精神类魔法的能力，大法师套装就忽略不掉。
 | 混乱火盆 Flame of Chaos | 右手 | 混乱魔法施法消耗-2，并且让英雄获得“守序抵御”和“冰抵抗”状态
 | 寒冰天平 Ice Scales | 左手 | 守序魔法施法消耗-2，并且让英雄获得“混乱抵御”和“火抵抗”状态
 | 平衡项链 Necklace of Balance | 颈部 | 守序魔法和混乱魔法的效果提高25%
以上三件宝物组合在一起就是术士套装，同时装备这三件宝物，英雄就会获得魔镜护身。
 | 和谐锁甲 Harmonic Chainmail | 躯体 | 英雄防御力+15，并且获得“振奋”状态（士气保持+10）
 | 缪斯项链 Necklace of Muses | 颈部 | 英雄魔法值+15，每天多恢复5点魔法值
 | 艾菲曼陀林 Aiffe's Mandolin | 左手 | 可以让英雄施展和平之歌、邪恶之歌、群体振奋几种魔法，并且这几种魔法施法消耗减半
以上三件宝物组合在一起就是吟游诗人套装，同时装备这三件宝物，英雄在攻击敌人时会自动附带和平之歌效果。
 | 冰霜战锤 Frost Hammer | 右手 | 英雄近战攻击力+25，攻击时有一定几率将敌人冰冻2回合
 | 猛虎胸甲 Tiger Armor | 躯体 | 英雄近战和远程防御+25，速度+2，战场移动力+2
 | 猛虎头盔 Tiger Helm | 头部 | 英雄近战和远程防御力+5，近战和远程伤害+5（增加伤害的效果是虚假的，在战斗中不起作用），否定敌人的抢先攻击
以上三件宝物组合在一起就是野蛮人套装，同时装备后英雄将会自动获得再生以及龙之力量状态。
 | 光明指环 Ring of Light | 戒指 | 让英雄获得死亡抵御状态，近战和远程伤害+10（增加伤害的效果是虚假的，在战斗中不起作用），生命魔法效果提高25%
 | 黑暗斗篷 Cloak of Darkness | 肩部 | 让英雄获得生命抵御状态，近战和远程防御力+10，死亡魔法效果提高25%
以上两件宝物组合在一起就是黑暗牧师套装，同时装备两件宝物的英雄，在战斗开始时会自动获得一个守护天使。


装备在头部的宝物

图标 | 名称 | 装备位置 | 说明
初级宝物
 | 知识之帽 Cap of Knowledge | 头部 | 英雄魔法值上限+5，并且每天多恢复1点魔法值
 | 视力头盔 Helm of Seeing | 头部 | 英雄及其带领的所有部队（包括生物和英雄）对失明魔法免疫
中级宝物
 | 智慧头冠 Circlet of Wisdom | 头部 | 英雄魔法值上限+10，并且每天多回复2点魔法值
 | 附魔王冠 Crown of Enchantment | 头部 | 装备后可以对免疫精神魔法的生物使用精神魔法
 | 丑陋面具 Hideous Mask | 头部 | 赋予英雄以骨龙的“引起恐惧”能力（参考生物特技页面）
 | 魔法头饰 Magic Amplifier | 头部 | 英雄带领的所有生物施法消耗减少1/3
 | 精神护盾 Mind Shield | 头部 | 使英雄及其带领的所有部队（包括生物和英雄）免受精神类魔法/技能影响
 | 领导头盔 Mullich's Helm of Leadership | 头部 | 英雄及其带领的所有部队（包括生物和英雄）士气+2，所带领的生物速度+1
高级宝物
 | 指挥头盔 Helm of Command | 头部 | 英雄带领的所有部队近战和远程防御力、近战和远程攻击力提高20%，速度+1
 | 能量头盔 Helm of Power | 头部 | 英雄魔法值上限+20，并且每天多回复4点魔法值
 | 海员帽 Seaman's Hat | 头部 | 上下船时只消耗少量行动力（相当于移动一格）
超级宝物
 | 法师王冠 Supreme Crown of the Magi | 头部 | 英雄魔法值上限+50，并且每天多回复10点魔法值
阴云密布新增宝物
 | 大法师之帽 Archmage's Hat | 头部 | 英雄魔法值+10，每天多恢复2点魔法值，并且始终保持模糊状态（受远程攻击时伤害减少1/3）。
 | 猛虎头盔 Tiger Helm | 头部 | 英雄近战和远程防御力+5，近战和远程伤害+5（增加伤害的效果是虚假的，在战斗中不起作用），否定敌人的抢先攻击


装备在颈部的宝物

图标 | 名称 | 装备位置 | 说明
中级宝物
 | 恐惧护身符 Amulet of Fear | 颈部 | 作用类似于恐惧结界魔法
 | 死亡护身符 Amulet of the Undertaker | 颈部 | 英雄招魂技能+10%。如果英雄不会招魂技能，那么装备此护身符后相当于掌握了基础招魂
 | 圣十字 Ankh of Life | 颈部 | 英雄复活技能+5%。如果英雄不会复活技能，那么装备圣十字后相当于掌握了基础复活
 | 德鲁伊锁链 Druid's Chain | 颈部 | 英雄召唤技能效果提高10点。如果英雄不会召唤技能，那么装备后相当于掌握了基础召唤
 | 荣誉勋章 Medal of Honor | 颈部 | 英雄及其带领的所有部队（包括生物和英雄）士气值+2
 | 媚惑项链 Necklace of Charm | 颈部 | 英雄媚惑技能提高5%。如果英雄不会媚惑技能，那么装备此项链后相当于掌握了基础媚惑
 | 政治家勋章 Statesman's Medal | 颈部 | 英雄外交技能提高10%。如果英雄不会外交技能，那么装备此勋章后相当于掌握了基础外交
高级宝物
 | 灾祸项圈 Collar of Misfortune | 颈部 | 自动对敌人所有部队（100%抗魔的除外）附加灾祸状态。敌人部队移动一次后灾祸解除，再移动一次又被附加灾祸……循环反复。若部队在原地不动，无论是防御、施法还是攻击，灾祸/无灾祸的状态都不发生翻转
 | 报复之镜 Mirror of Revenge | 颈部 | 装备之后英雄获得魔镜状态
超级宝物
 | 召唤圣甲虫 Scarab of Summoning | 颈部 | 召唤类魔法（包括召唤、幻象、制造亡灵等）效果提高100%
阴云密布新增宝物
 | 平衡项链 Necklace of Balance | 颈部 | 守序魔法和混乱魔法的效果提高25%
 | 缪斯项链 Necklace of Muses | 颈部 | 英雄魔法值+15，每天多恢复5点魔法值


装备在躯体的宝物

图标 | 名称 | 装备位置 | 说明
道具
 | 锁甲 Chain Mail | 躯体 | 英雄近战防御力和远程防御力+8，但战场移动力-1，施法消耗+1
 | 钢甲 Plate Mail | 躯体 | 英雄近战防御力和远程防御力+10，但战场移动力-2，施法消耗+2
 | 皮甲 Leather Armor | 躯体 | 英雄近战防御力和远程防御力+5
初级宝物
 | 精灵锁甲 Elven Chain Mail | 躯体 | 英雄近战和远程防御力+10
中级宝物
 | 镀金钢甲 Golden Plate Mail | 躯体 | 英雄近战和远程防御力提高25%，但施法消耗+1
高级宝物
 | 混乱护甲 Armor of Chaos | 躯体 | 英雄近战和远程防御力+20，并获得守序抵御状态
 | 死亡护甲 Armor of Death | 躯体 | 英雄近战和远程防御力+20，并获得生命抵御状态
 | 生命护甲 Armor of Life | 躯体 | 英雄近战和远程防御力+20，并获得死亡抵御状态
 | 守序护甲 Armor of Order | 躯体 | 英雄近战和远程防御力+20，并获得混乱抵御状态
 | 再生胸甲 Breastplate of Regeneration | 躯体 | 英雄近战和远程防御力+20，并且每回合自动恢复20点生命值。英雄每升一级，每回合还可以多恢复2点
 | 硫磺胸甲 Brimstone Breastplate | 躯体 | 英雄近战和远程防御力+20，并且会有火盾护身
 | 龙鳞铠甲 Dragon Scale Armor | 躯体 | 英雄近战和远程防御力+25，并且获得火抵抗状态
 | 格里冯哈特钢甲 Gryponheart's Plate Mail | 躯体 | 英雄近战防御力和远程防御力+30
 | 力量鳞甲 Scale Mail of Strength | 躯体 | 英雄近战和远程防御力、近战和远程攻击力+10
 | 反自然护甲 Unnatural Armor | 躯体 | 英雄近战和远程防御力+20，并获得自然抵御状态
超级宝物
 | 合金护甲 Adamantine Armor | 躯体 | 英雄近战和远程防御力+50
阴云密布新增宝物
 | 和谐锁甲 Harmonic Chainmail | 躯体 | 英雄防御力+15，并且获得“振奋”状态（士气保持+10）
 | 猛虎胸甲 Tiger Armor | 躯体 | 英雄近战和远程防御+25，速度+2，战场移动力+2


装备在左手的宝物

图标 | 名称 | 装备位置 | 说明
道具
 | 盾牌 Shield | 左手 | 英雄近战防御力和远程防御力+3
初级宝物
 | 学徒手册 Apprentice's Handbook | 左手 | 包含了所有一级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 矮人圆盾 Dwarven Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高20%，英雄本人近战和远程防御力+3
 | 羊皮纸 Parchment | 左手 | 记载一种魔法，英雄只要掌握了相应的魔法技能，装备后就能够学会此魔法。学会之后羊皮纸自动消失
 | 魔法卷轴 Scroll | 左手 | 装备后使英雄能够施展所记载的魔法，相应消耗减半，无论英雄是否已掌握相关技能
中级宝物
 | 鬼神宝典 Demonary | 左手 | 所有恶魔召唤术效果提高100%
 | 龙鳞盾牌 Dragon Scale Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高25%，并获得火抵抗状态。火抵抗状态不是一直持续，变化规律同灾祸项圈
 | 学徒笔记 Journeyman Notebook | 左手 | 包含了所有二级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 航海日志 Logbook of the Master Sailer | 左手 | 海上移动力提高50%。海上战斗中所率领生物攻击防御力提高20%
 | 坚定盾牌 Steadfast Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高30%，英雄本人近战和远程防御力+3
高级宝物
 | 死亡护盾 Death Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得生命抵御状态。生命抵御不是一直持续，变化规律同灾祸项圈
 | 公会首领之书 Guildmaster's Compendium | 左手 | 包含了所有四级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 生命护盾 Life Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得死亡抵御状态。死亡抵御不是一直持续，变化规律同灾祸项圈
 | 勇气狮盾 Lion's Shield of Courage | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高40%
 | 大师魔法书 Master's Spellbook | 左手 | 包含了所有三级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 混乱护盾 Shield of Chaos | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得守序抵御状态。守序抵御不是一直持续，变化规律同灾祸项圈
 | 守序护盾 Shield of Order | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得混乱抵御状态。混乱抵御不是一直持续，变化规律同灾祸项圈
 | 混乱魔法宝典 Tome of Chaos | 左手 | 包含了所有混乱魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 死亡魔法宝典 Tome of Death | 左手 | 包含了所有死亡魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 生命魔法宝典 Tome of Life | 左手 | 包含了所有生命魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 自然魔法宝典 Tome of Nature | 左手 | 包含了所有自然魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 守序魔法宝典 Tome of Order | 左手 | 包含了所有守序魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
 | 反自然护盾 Unnatural Shield | 左手 | 英雄近战和远程防御力+3，所带领部队近战和远程防御力提高30%，并获得自然抵御状态。自然抵御不是一直持续，变化规律同灾祸项圈
超级宝物
 | 合金护盾 Adamantine Shield | 左手 | 英雄带领的所有生物近战和远程防御力提高50%，英雄本人近战和远程防御力+3
 | 大法师宝典 Archmage's Codex | 左手 | 包含了所有五级魔法，英雄只要掌握了相应魔法技能就能够施展这些魔法
战役宝物
 | 小鹰 Breeze the Falcon | 左手 | 英雄在地图上视野半径+1
阴云密布新增宝物
 | 寒冰天平 Ice Scales | 左手 | 守序魔法施法消耗-2，并且让英雄获得“混乱抵御”和“火抵抗”状态
 | 艾菲曼陀林 Aiffe's Mandolin | 左手 | 可以让英雄施展和平之歌、邪恶之歌、群体振奋几种魔法，并且这几种魔法施法消耗减半


装备在右手的宝物

图标 | 名称 | 装备位置 | 说明
道具
 | 战斧 Axe | 右手 | 英雄近战攻击力+8，但速度-1
 | 长剑 Long Sword | 右手 | 英雄近战攻击力和近战防御力+3
初级宝物
 | 矮人战锤 Dwarven Hammer | 右手 | 英雄近战攻击力+10
中级宝物
 | 天使之刃 Angle's Blade | 右手 | 英雄本人近战攻击力和近战防御力+3。英雄及其带领的所有部队攻击死亡系部队时，可以额外造成50%伤害（事实上不会有任何效果）
 | 十字军锤棍 Crusader's Mace | 右手 | 英雄带领的所有生物近战和远程攻击力30%
 | 巨人杀手之剑 Giant Slayer | 右手 | 英雄近战攻击力和近战防御力+3，并且在对四级生物进行近身攻击时，伤害力加倍
 | 操纵尸体权杖 Wand of Animating Dead | 右手 | 允许英雄使用操纵尸体魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点。施法消耗的魔法值是权杖本身的魔法值，不是英雄的，以下同
 | 祝福权杖 Wand of Blesses | 右手 | 允许英雄使用祝福魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 诅咒权杖 Wand of Curses | 右手 | 允许英雄使用诅咒魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 火权杖 Wand of Fire | 右手 | 允许英雄使用火矢魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 火球权杖 Wand of Fireballs | 右手 | 允许英雄使用火球魔法。战斗开始时，权杖有6点魔法值，另外每回合恢复2点
 | 疾行权杖 Wand of Haste | 右手 | 允许英雄使用疾行魔法。战斗开始时，权杖有2点魔法值，另外每回合恢复2点
 | 医疗权杖 Wand of Healing | 右手 | 允许英雄使用医疗魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 冰权杖 Wand of Ice | 右手 | 允许英雄使用冰箭魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 幻象权杖 Wand of Illusion | 右手 | 允许英雄使用制造幻象魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
 | 虚弱权杖 Wand of Weakness | 右手 | 允许英雄使用虚弱魔法。战斗开始时，权杖有4点魔法值，另外每回合恢复2点
高级宝物
 | 传说战斧 Axe of Legends | 右手 | 英雄近战攻击力+7.5，所带领生物的近战和远程攻击力提高40%
 | 火炎之剑 Flaming Sword | 右手 | 英雄近战攻击力和近战防御力+3，攻击时附带30点的火属性伤害。英雄每升一级，附带伤害还会加3点
 | 夺魂剑 Soul Stealer | 右手 | 英雄近战攻击力和近战防御力+4。近身攻击时将敌人损失生命值的一半吸到自己身上
 | 敏捷之剑 Sword of Swiftness | 右手 | 英雄近战攻击力和近战防御力+6，主动近身攻击时能够多打一下
 | 泰南匕首 Tynan's Dagger | 右手 | 近身攻击时给对手附加悲泣状态
超级宝物
 | 公牛战斧 Bull Rune Battleaxe | 右手 | 英雄近战攻击力+50
 | 众神之剑 Sword of the Gods | 右手 | 英雄近战攻击力和近战防御力+3，所带领的生物近战和远程攻击力提高50%
战役宝物
 | 伪·狮鹫心之刃 False Gryphonheart Blade | 右手 | 英雄近战攻击力和近战防御力+8
 | 真·狮鹫心之刃 True Gryphonheart Blade | 右手 | 英雄近战攻击力和近战防御力+8，所带领的生物近战和远程攻击力提高40%
阴云密布新增宝物
 | 瓦解法杖 Staff of Disruption | 右手 | 英雄魔法值+10，忽视敌方所有抵御（Ward）状态（无论是本身的技能、职业特性，还是用宝物或魔法附加的）
 | 混乱火盆 Flame of Chaos | 右手 | 混乱魔法施法消耗-2，并且让英雄获得“守序抵御”和“冰抵抗”状态
 | 冰霜战锤 Frost Hammer | 右手 | 英雄近战攻击力+25，攻击时有一定几率将敌人冰冻2回合


装备在双手的宝物

图标 | 名称 | 装备位置 | 说明
道具
 | 巨剑 Great Sword | 双手 | 英雄近战攻击力+12.5。
 | 法师杖 Mage's Staff | 双手 | 英雄施法消耗-1（最少要消耗1）
中级宝物
 | 敏捷战戟 Halberd of the Swiftwatch | 双手 | 英雄近战攻击力+25，速度+2，忽略敌人的抢先攻击能力，并获得长武器攻击能力
高级宝物
 | 伤害法杖 Mayhem Staff | 双手 | 混乱魔法伤害加50%（火球魔法例外）
 | 圣徒法杖 Saint Ranan's Staff | 双手 | 所有治疗类法术效果提高100%，战斗结束后自动复活20%阵亡部队
 | 死亡法杖 Staff of Death | 双手 | 死亡魔法效果加50%
 | 能量法杖 Staff of Power | 双手 | 施法消耗减少1/3（最少消耗1点）
 | 召唤法杖 Staff of Summoning | 双手 | 召唤魔法消耗减半（最少消耗1点）
 | 魔力法杖 Staff of Wizardry | 双手 | 守序魔法消耗减半（最少消耗1点）
超级宝物
 | 雷电战锤 Thunder Hammer | 双手 | 英雄近战攻击力+7.5，近战攻击时附带70点闪电伤害。英雄每升一级，闪电伤害还会提高7点
战役宝物
 | 死木法杖 Deadwood Staff | 双手 | 允许英雄使用死亡之手魔法。战斗开始时，法杖有12点魔法值，另外每回合恢复2点


远程武器

图标 | 名称 | 装备位置 | 说明
道具
 | 弩 CrossBow | 弓弩 | 英雄远程攻击力+3，远程攻击不受距离损耗。英雄即使不会箭术技能，装备后仍然可以射击
 | 长弓 Longbow | 弓弩 | 英雄远程攻击力+5，即使不会箭术技能，装备后仍然可以射击
初级宝物
 | 大卫投石索 David's Sling | 弓弩 | 英雄所带领的生物在射击四级生物时可造成双倍伤害。英雄即使不会箭术，装备后仍然可以射击
 | 战争投石索 War Sling | 弓弩 | 英雄远程攻击力+10，即使不会箭术技能，装备后仍然可以射击
中级宝物
 | 野蛮人投棍 Barbarian Throwing Club | 弓弩 | 英雄近战和远程攻击力+5，有一定几率击晕敌人，即使不会箭术技能，装备后仍然可以射击
 | 狙击弩 Sniper's Crossbow | 弓弩 | 英雄远程攻击力+3，本人及所带领的远程生物射击时伤害不受射击距离影响。英雄即使不会箭术技能，装备后仍然可以射击
 | 投枪 Throwing Spear | 弓弩 | 英雄近战和远程攻击力+7.5，即使不会箭术技能，装备后仍然可以射击
 | 懒惰之弓 Valder's Bow of Sloth | 弓弩 | 英雄远程攻击力+5，即使不会箭术技能，装备后仍然可以射击。射击时附带疲劳魔法效果
高级宝物
 | 珠宝弓 Emerald Bow | 弓弩 | 英雄远程攻击力+30
 | 半人马标枪 Spear of the Centaur | 弓弩 | 英雄近战和远程攻击力+7.5，英雄带领的所有远程部队近战杀伤不减半
超级宝物
 | 精灵王之弓 Bow of the Elf King | 弓弩 | 英雄远程攻击力+5，即使不会箭术，仍然可以进行射击。所带领的所有生物在射击时能多射一下
 | 角弓 Horned Bow | 弓弩 | 英雄远程攻击力+50
战役宝物
 | 游牧人黑弓 Nomad Blackbow | 弓弩 | 英雄远程攻击力+20，即使不会箭术技能，装备后仍然可以射击


装备在肩部的宝物

图标 | 名称 | 装备位置 | 说明
初级宝物
 | 守卫长袍 Cloak of Warding | 肩 | 英雄抗魔能力提高30%
中级宝物
 | 保护长袍 Cape of Protection | 肩部 | 英雄带领的所有生物（不包括英雄）抗魔能力+30%。
 | 分心斗篷 Cloak of Distraction | 肩部 | 按说明，是让英雄无视敌部队的震慑范围。但无论是在战斗中还是地图上，都没有效果
 | 抵抗斗篷 Cowl of Resistance | 肩部 | 英雄抗魔能力提高50%
 | 法师长袍 Mage's Robe | 肩部 | 英雄施法消耗-1
高级宝物
 | 法术转向斗篷 Mantle of Spell Turning | 肩部 | 英雄抗魔能力提高70%
 | 守护者长袍 Robe of the Guardian | 肩部 | 每场战斗英雄所遭受的前三次伤害都被视为无效伤害
超级宝物
 | 无伤害斗篷 Neener's Invulnerable Cloak | 肩部 | 使英雄抗魔能力达到100%
阴云密布新增宝物
 | 天使羽毛斗篷 Angelfeather Cloak | 肩部 | 英雄魔法值+10，在战场上自动获得飞行状态，并且有天堂之盾护身
 | 黑暗斗篷 Cloak of Darkness | 肩部 | 让英雄获得生命抵御状态，近战和远程防御力+10，死亡魔法效果提高25%


戒指

图标 | 名称 | 装备位置 | 说明
初级宝物
 | 健康指环 Ring of Health | 戒指 | 英雄生命值+50%
 | 保护指环 Ring of Protection | 戒指 | 英雄带领的所有生物近战和远程防御力提高20%
 | 力量指环 Ring of Strength | 戒指 | 英雄近战和远程攻击力+5
 | 战神指环 Warlord's Ring | 戒指 | 英雄带领的所有生物近战和远程攻击力提高20%
 | 术士指环 Wizard's Ring | 戒指 | 英雄魔法值上限+5，并且每天多恢复1点魔法值
中级宝物
 | 骑兵手套 Equestrian Gloves | 戒指 | 部队陆地移动力提高25%
 | 丛林妖精指环 Leprechaun's Ring | 戒指 | 英雄及其带领的所有部队（包括生物和英雄）幸运值+2
 | 眼镜蛇指环 Ring of the Cobra | 戒指 | 英雄攻击时能使敌人中毒，作用与死亡魔法的施毒术相同
 | 元素指环 Ring of the Elementals | 戒指 | 元素召唤术效果加100%
 | 小否定指环 Ring of Lesser Negation | 戒指 | 英雄施法时忽略敌人的所有抵御（Ward）技能或状态
 | 永恒指环 Ring of Permanency | 戒指 | 保证英雄及其带领的所有部队（包括生物和英雄）身上附着的正面魔法不被敌人驱散、废除或窃取
 | 速度指环 Ring of Speed | 戒指 | 英雄本人及其带领的生物速度+2，不影响部队里其他英雄
高级宝物
 | 再生指环 Ring of Regeneration | 戒指 | 每回合自动恢复20点生命值。英雄每升一级，每回合还可以多恢复2点
超级宝物
 | 强烈否定指环 Ring of Greater Negation | 杂物 | 去除战场上敌我所有部队的魔法抵抗力和免疫力
阴云密布新增宝物
 | 闪光指环 Ring of Flares | 戒指 | 英雄魔法值+10，施法消耗-2
 | 光明指环 Ring of Light | 戒指 | 让英雄获得死亡抵御状态，近战和远程伤害+10（增加伤害的效果是虚假的，在战斗中不起作用），生命魔法效果提高25%


鞋子

图标 | 名称 | 装备位置 | 说明
中级宝物
 | 鳄皮靴 Boots of Crocodile | 脚部 | 在沼泽地形上移动时，不需要额外损耗行动力
 | 防火靴 Fireproof Boots | 脚部 | 在熔岩地形上移动时，不需要额外损耗行动力
 | 沙漠草鞋 Sandwalker Sandals | 脚部 | 在沙漠上移动时，不需要额外损耗行动力
 | 雪地之鞋 Snowshoes | 脚部 | 在雪地上移动时，不需要额外损耗行动力
 | 稳当之靴 Surefooted Boots | 脚部 | 在粗糙之地上移动时，不需要额外损耗行动力
高级宝物
 | 探险家之靴 Boots of the Explorer | 脚部 | 在所有特殊地形上移动时，都不需要额外损耗行动力
 | 旅行之靴 Boots of Travel | 脚部 | 部队陆地移动力提高50%
 | 飞翼便鞋 Winged Sandals | 脚部 | 英雄带领的所有生物战场移动力+2（码）
阴云密布新增宝物
 | 行路之靴 Wayfaring Boots | 脚部 | 英雄魔法值+10，部队的地图移动力提高25%，并且在地图上移动时忽略特殊地形对移动力的额外损耗。


杂物

图标 | 名称 | 装备位置 | 说明
道具
 | 望远镜 Telescope | 杂物 | 英雄在地图上视野半径+1
初级宝物
 | 晕击箭 Arrow of Stunning | 杂物 | 英雄射击时一定几率击晕射击对象，让其一回合无法行动和反击。成功率计算公式同侍从晕击技能
 | 勇气徽章 Badge of Courage | 杂物 | 使英雄所带领的生物不受恐惧类效果（包括骨龙的“引起恐惧”技能、梦魇兽和黑骑的恐惧魔法，还有恐惧结界魔法以及相关宝物）影响
 | 黄金袋 Bag of Gold | 杂物 | 装备后每天生产500金
 | 木材马车 Cart of Lumber | 杂物 | 装备后每天生产2木材
 | 矿石马车 Cart of Ore | 杂物 | 装备后每天生产2铁矿石
 | 英勇徽章 Crest of Valor | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）士气+1
 | 记忆水晶 Crystal of Memory | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）不受健忘魔法影响
 | 四叶草 Four Leaf Clover | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 赌徒之牌 Gambler's Deck | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 马蹄铁 Horseshoe | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）幸运+1
 | 黄金包 Purse of Gold | 杂物 | 装备后每天生产250金
 | 六分仪 Sextant | 杂物 | 海上行动力提高50%
 | 蛛丝箭 Spider's Silk Arrows | 杂物 | 英雄射击敌飞行部队时，让其丧失飞行能力，并且速度和战场移动力减半。
 | 水晶球 Viewing Crystal | 杂物 | 英雄在地图上视野半径+2
中级宝物
 | 杀戮之箭 Arrow of Slaying | 杂物 | 让英雄本人在射击四级生物时可造成双倍伤害
 | 硫磺火盆 Brazier of Sulfur | 杂物 | 装备后每天生产1硫磺
 | 水晶雕像 Crystal Figurine | 杂物 | 装备后每天生产1水晶
 | 水银瓶 Flast of Mercury | 杂物 | 装备后每天生产1水银
 | 宝石箱 Gem Casket | 杂物 | 装备后每天生产1宝石
 | 毒箭 Poison Arrow | 杂物 | 英雄远程攻击时能使敌人中毒，作用与死亡魔法的施毒术相同
 | 吝啬鬼钱包 Purse of Penny Pinching | 杂物 | 装备此宝物的英雄招募部队时花费降低10%
 | 黄金麻袋 Sack of Gold | 杂物 | 装备后每天生产750金
高级宝物
 | 马兰迪酒杯 Maranthea's Mug | 杂物 | 英雄及其带领的所有部队（包括生物和英雄）士气+3
 | 战争枷锁 Shackles of War | 杂物 | 在战场上禁止双方投降或逃跑
超级宝物
 | 火炎之箭 Flaming Arrow | 杂物 | 装备后使英雄的射击带范围攻击属性。在3.0版本的游戏中，除射击中心之外，周围波及范围造成的伤害类似于火魔法，不能损伤具备火抵抗能力的部队。


建筑

    英雄无敌4总共有6个种族。从总体布局上来说，作用相同或相似的建筑，在不同种族城堡里的位置是一样的，例如奇迹建筑都在左上角，城堡都在右上角，船厂都在右下角，等等。偏死板的一种设定，让游戏有赶工的感觉。

    四代中有的建筑是可以选择建造的，那就是2到4级的生物招募地。6个种族，每个种族8种生物，1到4级各两种。两种1级生物的招募地是可以同时建造的，而2到4级生物的招募地，就必须从两者中选择其一进行建造，造了其中一个，就不能在本城堡中造另一个。同级的生物，实力并不一定相近，有的相差还很多，但是考虑到生物产量的因素，同级两种生物的综合价值还是基本相当的。例如混乱城堡的4级生物九头蛇和黑龙，实力有极大差距，九头蛇战斗力基本上是黑龙的一半，但每周产量也是黑龙的两倍。在游戏中需要根据周围资源、对手种族等各方面情况来选择自己的建造方案。

    而在生物产量方面，除了力量城堡的“育种棚”和奇迹建筑“生命祭祀”以外，再也没有任何建筑可以提高产量了，城堡也不行，这与前几代区别非常大。不过英雄的“贵族”技能可以提高产量。

    以下是6个种族城堡的总体布局图片。而各建筑的具体作用、建造条件、资源需求可以在公共建筑、相似建筑、生物驻地、特殊建筑这四个页面中可以看到。
    公共建筑：在不同种族城堡里，无论名称、作用还是建造条件、资源需求都相同的建筑，只是造型不同。
    相似建筑：作用相似，但是在不同种族城堡里名称不同，建造条件和资源需求也有所区别。也包括了挖宝后才能建造的奇迹建筑在内。
    生物驻地：每个种族8个，一个城堡中最多可以建造5个（1级两个，2到4级各一个）。
    特殊建筑：各个种族特有的建筑。

守序城堡

混乱城堡

生命城堡

死亡城堡

自然城堡

力量城堡


公共建筑

    在不同种族城堡里，无论名称、作用还是建造条件、资源需求都相同的建筑，只是造型不同。

名称 | 作用 | 建造前提 | 资源需求
村庄大厅 Village Hall | 每天生产500金 | 每个城堡的基本设施，自动拥有 | 无
市镇大厅 Town Hall | 每天生产750金 村庄大厅的升级版本 | 村庄大厅 | 2500金，10木材/矿石
城市大厅 City Hall | 每天生产1000金 市镇大厅的升级版本 | 市镇大厅 | 2500金，10木材/矿石，5水晶/宝石
堡垒 Fort | 给城堡提供城墙。这也是许多建筑的建造前提 | 村庄大厅 | 5000金，20木材/矿石
大本营 Citadel | 给城堡提供护城河 堡垒的升级版本 | 堡垒 | 7500金，10木材/矿石
城堡 Castle | 给城堡提供箭塔 大本营的升级版本 | 大本营 | 7500金，10木材/矿石
酒馆 Tavern | 允许招募英雄。招募英雄后要过7天才能在同一城堡的酒馆里再次招募 | 村庄大厅 | 500金，2木材
车队基地 Caravan | 允许在城堡与城堡之间免费运送部队，也可以直接从本方野外兵营招兵 | 堡垒 | 4000金，10木材
船厂 Shipyard | 允许造船 | 堡垒 | 2000金，20木材
监狱 Prison | 战斗获胜后，可以将对方英雄囚禁起来 | 所有城堡都自动拥有的建筑 | 无


相似建筑

    作用相似，但是在不同种族城堡里名称不同，建造条件和资源需求也有所区别。

魔法公会与图书馆

    6个种族中有5个是魔法种族，分别有对应的魔法派系，要塞（力量城堡）是唯一没有对应魔法的城堡类型。

    5个魔法种族可以在城堡里建造各自的魔法公会，在不造图书馆的前提下，魔法公会里只会会出现本派系的魔法，数量是一级、二级魔法各3个，三级、四级魔法各2个，还有1个五级魔法。另外，在魔法公会旁边可以建造相邻魔法派系的图书馆，让魔法公会中多出几个相应派系的魔法，数量是一级、二级、三级魔法各2个，四级、五级魔法各1个。

    举例：守序魔法的相邻魔法派系是生命魔法和死亡魔法，那么在守序城堡里建设了五级魔法公会和生命、死亡魔法图书馆之后，魔法公会里所出现的魔法是：一级魔法，3个守序魔法，2个生命魔法，2个死亡魔法；二级魔法，3个守序魔法，2个生命魔法，2个死亡魔法；三级魔法，2个守序魔法，2个生命魔法，2个死亡魔法；四级魔法，2个守序魔法，1个生命魔法，1个死亡魔法；五级魔法，守序魔法、生命魔法、死亡魔法各1个。

    另外，英雄访问城堡时，一级魔法公会最多可以将英雄的魔法值恢复到上限的35%，二级是50%，三级65%，四级80%，五级补满。英雄如果回合结束时呆在城堡里，无论魔法公会等级如何，下一天魔法值都会完全补满。

名称 | 作用 | 建造前提 | 资源需求
守序城堡
魔法学院 Institute of Magic | 守序系魔法公会 | 村庄大厅 | 一级：1000金，2木材/矿石， 1宝石 以后每级1000金，1宝石
牧师图书馆 Clerical Library | 即守序城堡生命魔法图书馆 | 魔法学院 | 2500金，4木材/矿石
招魂师图书馆 Necromantic Library | 即守序城堡死亡魔法图书馆 | 魔法学院 | 2500金，2木材/矿石/2硫磺
混乱城堡
巫师公会 Sorcerer's Guild | 混乱系魔法公会 | 村庄大厅 | 一级：1000金，2木材/矿石， 1水银 以后每级1000金，1水银
巫医殿堂 Witch Hall | 即混乱城堡自然魔法图书馆 | 巫师公会 | 2500金，2木材/矿石/水晶
死者殿堂 Hall of the Dead | 即混乱城堡死亡魔法图书馆 | 巫师公会 | 2500金，2木材/矿石/硫磺
生命城堡
神圣大教堂 Holy Cathedral | 生命系魔法公会 | 村庄大厅 | 一级：1000金，3木材/矿石 以后每级1000金，1木材/矿石
自然序列 Order of Nature | 即生命城堡自然魔法图书馆 | 神圣大教堂 | 2500金，2木材/矿石/水晶
幻术序列 Order of Enchantment | 即生命城堡守序魔法图书馆 | 神圣大教堂 | 2500金，2木材/矿石/宝石
死亡城堡
黑暗之塔 Tower of Darkness | 死亡系魔法公会 | 村庄大厅 | 一级：1000金，2木材/矿石， 1硫磺 以后每级1000金，1硫磺
混乱侧廊 Chaos Annex | 即死亡城堡混乱魔法图书馆 | 黑暗之塔 | 2500金，2木材/矿石/水银
魔力侧廊 Annex of Wizardry | 即死亡城堡守序魔法图书馆 | 黑暗之塔 | 2500金，2木材/矿石/宝石
自然城堡
德鲁伊殿堂 Druid's Hall | 自然系魔法公会 | 村庄大厅 | 一级：1000金，2木材/矿石， 1水晶 以后每级1000金，1水晶
混乱学院 Conservatory of Chaos | 即自然城堡混乱魔法图书馆 | 德鲁伊殿堂 | 2500金，2木材/矿石/水银
生命学院 Conservatory of Life | 即自然城堡生命魔法图书馆 | 德鲁伊殿堂 | 2500金，4木材/矿石

铁匠铺

出售道具（Item）和药水。道具也就是一级宝，只能对英雄本人起作用的宝物。

种族 | 名称 | 作用 | 建造前提 | 资源需求
守序城堡 | 炼金术士商店 Alchemist's Shop | 出售望远镜、法师杖、锁甲，以及恢复药水、不朽药水、寒冷药水、防火药水和粘结剂 | 村庄大厅 | 3000金，4木材/矿石，其他资源各1
混乱城堡 | 流氓公会 Rogue's Guild | 出售巨剑、弩，以及恢复药水、不朽药水、魔力药水、酸液和恶魔之火 | 村庄大厅 | 3000金，4木材，10矿石
生命城堡 | 圣武士序列 Order of Paladins | 出售长剑、钢甲，以及恢复药水、不朽药水、康复药水、欢笑药水和圣水 | 村庄大厅 | 3000金，14矿石
死亡城堡 | 军械库 Armory | 出售长剑、锁甲、小盾，以及恢复药水、绝望烟雾、毒液瓶、毒气瓶和不朽药水 | 村庄大厅 | 3000金，4木材，10矿石
自然城堡 | 游侠公会 Ranger's Guild | 出售长弓、皮甲、小盾，以及恢复药水、不朽药水、力量药水、强壮药水和魔力药水 | 村庄大厅 | 3500金，20木材
力量城堡 | 兵工厂 Arsenal | 出售战斧、巨剑、皮甲、小盾，以及不朽药水、恢复药水、抵抗药水、耐力药水、急速药水 | 村庄大厅 | 5000金，12木材/矿石

奇迹建筑

    终极建筑，看藏宝图并挖到圣杯后才能建造的建筑，不需要花费资源，建造完成后圣杯自动消失。

种族 | 名称 | 作用
守序城堡 | 大图书馆 Great Library | 每天生产3000金，守序系魔法效果提高50%，魔法学院恢复英雄魔法值的效果增加25%。本方所有守序城堡城堡都会出现1-5级魔法，即使魔法学院只有一级。
混乱城堡 | 混乱之眼 Eye of Chaos | 每天生产3000金，混乱系魔法效果提高50%
生命城堡 | 天神化身 Holy Avatar | 每天生产3000金，生命系魔法效果提高50%
死亡城堡 | 死神雕像 Infernal Effigy | 每天生产3000金，死亡系魔法效果提高50%。招魂术效果提高10%，招魂的数量上限提高50%
自然城堡 | 召唤之石 Summoning Stone | 每天生产3000金，自然系魔法效果提高25%
力量城堡 | 生命祭祀 Festival of Life | 每天生产3000金，本城生物产量提高100%，本方其他城堡生物产量提高25%


生物驻地

招募生物的建筑，每个种族8个，一个城堡中最多可以建造5个（1级两个，2到4级各一个）。

守序城堡

名称 | 建造前提 | 资源需求
半身人地穴 Halfling Burrow 半身人招募地 | 堡垒 | 1500金
矮人矿山 Dwarven Mines 矮人招募地 | 堡垒 | 1500金
法师塔 Mage Tower 法师招募地 | 半身人地穴或矮人矿山 魔法学院 堡垒 | 2750金，水晶、硫磺、水银、宝石各1
傀儡工厂 Golem Factory 金人招募地 | 半身人地穴或矮人矿山 魔法学院 堡垒 | 3000金，6矿石
祈愿祭坛 Altar of Wishes 灯神招募地 | 法师塔或傀儡工厂 牧师图书馆 堡垒 | 6250金，12宝石
黄金帐篷 Golden Pavilion 蛇妖招募地 | 法师塔或傀儡工厂 国库 堡垒 | 6250金，8木材/矿石，4水晶
云城堡 Cloud Castle 泰坦招募地 | 祈愿祭坛或黄金帐篷 城堡 | 14000金，16木材/矿石，20宝石
龙工厂 Dragon Factory 傀儡龙招募地 | 祈愿祭坛或黄金帐篷 炼金术士商店 大学 堡垒 | 14000金，12木材，30矿石，水晶、硫磺、水银、宝石各4

混乱城堡

名称 | 建造前提 | 资源需求
盗贼巢穴 Den of Thieves 盗贼招募地 | 堡垒 | 1500金
半兽人塔 Orc Towers 半兽人招募地 | 堡垒 | 1500金
雕像花园 Statuary Garden 美杜莎招募地 | 盗贼巢穴或半兽人塔 巫师公会 堡垒 | 3000金，6矿石
迷宫 Labyrinth 牛头怪招募地 | 盗贼巢穴或半兽人塔 小偷训练场 堡垒 | 3000金，3宝石
黑树林 Black Wood 梦魇兽招募地 | 雕像花园或迷宫 车队基地 堡垒 | 6250金，14木材，5水银
火山口 Volcanic Vent 火怪招募地 | 雕像花园或迷宫 流氓公会 堡垒 | 6250金，14矿石，5硫磺
九头蛇池塘 Hydra Pond 九头蛇招募地 | 黑树林或火山口 巫医殿堂 堡垒 | 14000金，16木材，4水晶，6硫磺，20水银
龙穴 Dragon Cave 黑龙招募地 | 黑树林或火山口 死者殿堂 堡垒 | 14000金，6木材/矿石，30硫磺

生命城堡

名称 | 建造前提 | 资源需求
侍从公会 Squires Guild 侍从招募地 | 堡垒 | 1500金
射箭场 Archery Range 弩手招募地 | 堡垒 | 1500金
卫兵室 Guardhouse 枪兵招募地 | 侍从公会或射箭场 酒馆 堡垒 | 3000金，3木材/矿石
弩车作坊 Ballista Works 弩车招募地 | 侍从公会或射箭场 堡垒 | 3000金，6矿石
兵营 Barracks 十字军招募地 | 卫兵室或弩车作坊 圣武士序列 堡垒 | 6250金，12木材/矿石
僧侣院 Monastery 僧侣招募地 | 卫兵室或弩车作坊 修道院 堡垒 | 6250金，4木材/矿石，8水晶
骑士教堂 Knights Chapter 精英骑士招募地 | 兵营或僧侣院 马厩 圣武士序列 堡垒 | 14000金，40木材，32矿石
光明圣坛 Altar of Light 天使招募地 | 兵营或僧侣院 神学院 堡垒 | 14000金，12木材，10矿石，15水晶，12宝石

死亡城堡

名称 | 建造前提 | 资源需求
刑室 Torture Chamber 恶魔之子招募地 | 堡垒 | 1500金
墓地 Cemetery 骷髅兵招募地 | 堡垒 | 1500金
狗舍 Kennels 地狱犬招募地 | 刑室 堡垒 | 3000金，4木材，1硫磺
幽灵土墩 Barrow Mound 幽灵招募地 | 墓地 亡灵转化器 堡垒 | 3250金，3水晶
产卵坑 Spawning Pit 食尸怪招募地 | 狗舍或幽灵土墩 黑暗之塔 堡垒 | 6250金，8矿石，8水银
大厦 Mansion 吸血鬼招募地 | 狗舍或幽灵土墩 酒馆 堡垒 | 6250金，8木材，8水晶
诅咒殿堂 Temple of the Damned 恶魔招募地 | 产卵坑或大厦 混乱侧廊 堡垒 | 14000金，6木材，8矿石，20硫磺，10宝石
龙墓 Dragon Graveyard 骨龙招募地 | 产卵坑或大厦 招魂塔 堡垒 | 14000金，12木材，14矿石，其他资源各6

自然城堡

名称 | 建造前提 | 资源需求
妖精树 Fae Trees 妖精招募地 | 堡垒 | 1500金
狼穴 Wolf Den 狼招募地 | 堡垒 | 1500金
树顶小屋 Treetop Lodge 精灵招募地 | 妖精树或狼穴 游侠公会 堡垒 | 3000金，6木材
虎穴 Tiger Den 白虎招募地 | 妖精树或狼穴 宗教祭坛 堡垒 | 3000金，6矿石
独角兽林地 Unicorn Glade 独角兽招募地 | 树顶小屋或虎穴 彩虹 堡垒 | 6250金，12木材，6宝石
狮鹫巢 Griffin Cliffs 狮鹫招募地 | 树顶小屋或虎穴 大本营 | 6250金，6木材，10矿石，4水晶
魔法树林 Magic Forest 仙女龙招募地 | 独角兽林地或狮鹫巢 混乱学院 堡垒 | 14000金，14木材，6矿石，其他资源各7
火堆 Pyre 凤凰招募地 | 独角兽林地或狮鹫巢 生物门 堡垒 | 14000金，16木材，10硫磺，20水银

力量城堡

名称 | 建造前提 | 资源需求
长屋 Longhouse 狂暴者招募地 | 堡垒 | 1500金
半人马厩 Centaur Stables 半人马招募地 | 堡垒 | 1500金
鸟妖山峰 Harpy Peak 鹰身女妖招募地 | 长屋或半人马厩 大本营 | 3000金，4木材，1水银
游牧人帐篷 Nomad Tents 游牧人招募地 | 长屋或半人马厩 车队基地 堡垒 | 3000金，6木材
食人魔堡垒 Ogre Fort 食人魔法师招募地 | 鸟妖山峰或游牧人帐篷 酒馆 堡垒 | 6250金，8木材/矿石，水晶、水银、宝石各1
独眼巨人洞穴 Cyclops Cave 独眼巨人招募地 | 鸟妖山峰或游牧人帐篷 摔跤场 堡垒 | 6500金，4矿石，10水晶
悬崖鹰巢 Cliff Nest 雷鸟招募地 | 食人魔堡垒或独眼巨人洞穴 城堡 | 14000金，20木材，6水晶/硫磺，16水银
巨兽峭壁 Behemoth Crag 巨兽招募地 | 食人魔堡垒或独眼巨人洞穴 兵工厂 荣誉竞技场 堡垒 | 14000金，6木材，20矿石，24水晶


特殊建筑

各个种族特有的建筑。

守序城堡

名称 | 作用 | 建造前提 | 资源需求
大学 University | 随机出现四种二级技能让英雄学习，学习一项技能需要花费2000金。出现的技能属于贵族、侦察、守序、生命和死亡5个派系 | 堡垒 | 5750金，5木材/矿石，2硫磺/宝石
国库 Treasury | 每周额外提供10%的资金（实际上每天都能产钱，是前一天剩余资金的1.43%左右） | 市镇大厅 堡垒 | 6000金，5木材，10矿石

混乱城堡

名称 | 作用 | 建造前提 | 资源需求
魔力漩涡 Mana Vortex | 每7天让一个英雄魔法值加倍一次 | 二级巫师公会 | 1000金，水晶、硫磺、水银、宝石各1
战斗学院 Battle Academy | 英雄经验值增加1000 | 堡垒 | 2000金，5木材/矿石
小偷训练场 Thieves Gauntlet | 英雄近战攻击力+3，远程攻击力+2.1 | 堡垒 | 1000金，6矿石

生命城堡

名称 | 作用 | 建造前提 | 资源需求
修道院 Abbey | 提高部队2点临时士气，打完一仗后效果消失 | 堡垒 | 1000金，4木材/矿石
神学院 Seminary | 随机出现四种二级技能让英雄学习，学习一项技能需要花费2000金。出现的技能属于战术、战斗、生命、守序和自然5个派系 | 修道院 | 5750金，5木材/矿石，2水晶/宝石
马厩 Stables | 部队7天内地图移动力+5 | 村庄大厅 | 2750金，10木材

死亡城堡

名称 | 作用 | 建造前提 | 资源需求
亡灵转化器 Undead Transformer | 将1、2级生物转化为骷髅兵，3级生物转化为幽灵，黑龙和仙女龙转化为骨龙，其他4级生物转化为吸血鬼 | 墓地 | 2500金，10矿石，5水银
招魂塔 Necromancy Amplifier | 英雄招魂比例提高10% | 堡垒 黑暗之塔 | 1000金，6矿石，3硫磺/水银

自然城堡

名称 | 作用 | 建造前提 | 资源需求
生物门 Creature Portal | 里面有丛林妖精、半羊人、风元素、土元素、火元素、水元素、毒蜂草和螳螂8种生物供招募。可招募的生物，按每天100点经验值的速度累积 | 德鲁伊殿堂 独角兽林地或狮鹫巢 | 6500金，10矿石，5宝石
彩虹 Rainbow | 提高部队2点临时幸运，打完一仗后效果消失 | 村庄大厅 | 1500金，1水晶/宝石
宗教祭坛 Sacred Grove | 英雄魔法值上限+3 | 村庄大厅 | 1000金，4木材，1水晶

力量城堡

名称 | 作用 | 建造前提 | 资源需求
摔跤场 Wrestling Pits | 英雄近战攻击力+3，远程攻击力+2.1 | 村庄大厅 | 1000金，6矿石
荣誉竞技场 Arena of Honor | 英雄近战和远程防御力+3 | 堡垒 | 1000金，6矿石
魔法干扰器 Magic Dampener | 本方所有英雄魔法抗性提高10%，如多城建造，则效果为1-(1-10%)*(1-10%)*(1-10%)*...，不是简单的叠加，而是联合起作用。 | 堡垒 | 2000金，10矿石
育种棚 Breeding Pens | 本城生物产量提高50% | 食人魔堡垒或独眼巨人洞穴 | 15000金，10木材，30矿石


野外设施

    关于野外设施，好像没有什么比较成规的划分方法。这里参考地图编辑器的分类方式，把一部分的野外设施划分为矿场、能力强化、行动辅助、魔法学习、宝库、其他几类，进行分类介绍。


矿场

图标 | 名称 | 说明
 | 木材堆 Wood Pile | 可以花费2500金将其建设成为正常的锯木场
 | 锯木场 Sawmill | 占领后每天生产2单位木材
 | 荒弃锯木场 Abandoned Sawmill | 由一定量部队看守的锯木场，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是狼、盗贼、或是骷髅+幽灵的组合，守军强度（经验总值）基本上介于随机的一级野兵到二级野兵之间（最低高于一级野兵强度上限，最高相当于二级野兵平均强度）
 | 矿石矿藏 Ore Deposit | 可以花费2500金将其建设成为正常的矿石坑
 | 矿石坑 Ore Pit | 占领后每天生产2单位铁矿石
 | 荒弃矿石坑 Abandoned Ore Pit | 由一定量部队看守的矿石坑，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是洞穴巨人、石像鬼、穴居人、或是骷髅+幽灵的组合，守军强度基本上介于随机的一级野兵到二级野兵之间
 | 金矿脉 Gold Vein | 可以花费15000金+20木材+20矿石将其建设成为正常的金矿场
 | 金矿场 Gold Mine | 占领后每天生产1000金
 | 荒弃金矿场 Abandoned Gold Mine | 由一定量部队看守的金矿场，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是洞穴巨人、石像鬼、穴居人、或是骷髅+幽灵的组合，守军强度高于随机的三级野兵
 | 水银矿藏 Cinnabar Deposit | 可以花费5000金将其建设成为正常的炼金实验室
 | 炼金实验室 Alchemist's Lab | 占领后每天生产1单位水银
 | 荒弃炼金实验室 Abandoned Alchemist's Lab | 由一定量部队看守的炼金实验室，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是半兽人、恶魔之子、或是骷髅+幽灵的组合，守军强度基本上介于随机的二级野兵到三级野兵之间
 | 水晶矿脉 Crystal Vein | 可以花费4000金+10木材将其建设成为正常的水晶矿场
 | 水晶矿场 Crystal Mine | 占领后每天生产1单位水晶
 | 荒弃水晶矿场Abandoned Crystal Mine | 由一定量部队看守的水晶矿场，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是洞穴巨人、石像鬼、穴居人、或是骷髅+幽灵的组合，守军强度基本上介于随机的二级野兵到三级野兵之间
 | 宝石矿脉 Gem Vein | 可以花费4000金+10木材将其建设成为正常的宝石矿场
 | 宝石矿场 Gem Mine | 占领后每天生产1单位宝石
 | 荒弃宝石矿场 Abandoned Gem Mine | 由一定量部队看守的宝石矿场，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是洞穴巨人、石像鬼、穴居人、或是骷髅+幽灵的组合，守军强度基本上介于随机的二级野兵到三级野兵之间
 | 硫磺矿脉 Sulfur Vein | 可以花费4000金+10木材将其建设成为正常的硫磺矿场
 | 硫磺矿场 Sulfur Mine | 占领后每天生产1单位硫磺
 | 荒弃硫磺矿场 Abandoned Sulfur Mine | 由一定量部队看守的硫磺矿场，击败守军后才能占领。可以在地图编辑器中设定守军，如果不设定，守军将是洞穴巨人、石像鬼、穴居人、或是骷髅+幽灵的组合，守军强度基本上介于随机的二级野兵到三级野兵之间
 | 矿工公会 Miner's Guild | 每周生产10单位矿石或是500金。占领后会自动生产，不需要每周都来访问一次
 | 伐木者小屋 Woodcutter's Cottage | 每周生产10单位木材或是500金。占领后会自动生产，不需要每周都来访问一次
 | 学徒实验室 Apprentice's Lab | 每周生产5单位水银或是500金。占领后会自动生产，不需要每周都来访问一次
 | 水晶池 Crystal Pool | 每周生产5单位水晶或是500金。占领后会自动生产，不需要每周都来访问一次
 | 小鬼陷坑 Imp Pit | 每周生产5单位硫磺或是500金。占领后会自动生产，不需要每周都来访问一次
 | 妖精花园 Leprechaun | 每周生产5单位宝石或是500金。占领后会自动生产，不需要每周都来访问一次
 | 水车 Water Wheel | 每周生产1000金。占领后会自动生产，不需要每周都来访问一次
 | 风车 Windmill | 每周生产4-6单位的水银、水晶、硫磺或是宝石（四者取其一）。占领后会自动生产，不需要每周都来访问一次


能力强化相关的野外设施

图标 | 名称 | 说明
 | 竞技场 Arena | 访问后英雄近战和远程防御力+3
 | 佣兵营帐 Mercenary Camp | 访问后英雄速度+1
 | 神圣喷泉 Sacred Fountain | 访问后英雄魔法值上限+3
 | 训练场 Training Grounds | 访问后英雄近战攻击力+3，远程攻击力+2
 | 学习石碑 Learning Stone | 访问后英雄经验值+1000
 | 梦幻教师 Dream Teacher | 访问后英雄经验值+500。如果一关内有多个梦幻教师，访问第二个时经验值+1000，访问第三个时经验值+1500，以下类推……
 | 知识树 Tree of Knowledge | 花费2500金或是5宝石，让英雄等级提高一级
 | 速度泉水 Spring of Speed | 访问后英雄速度+3，效果只能维持一场战斗
 | 能量池 Pool of Power | 访问后英雄生命值+25%，伤害值+25%，效果只能维持一场战斗
 | 活力喷泉 Fountain of Vigor | 访问后英雄生命值+25%，效果只能维持一场战斗
 | 力量喷泉 Fountain of Strength | 访问后英雄伤害值+25%，效果只能维持一场战斗
 | 防御蓝宝石 Sapphire of Defense | 访问后英雄近战和远程防御力+6，只能提升一个英雄的能力，提升后宝石会消失
 | 魔法猫眼石 Opal of Magic | 访问后英雄魔法值上限+6，只能提升一个英雄的能力，提升后宝石会消失
 | 速度翡翠 Emerald of Speed | 访问后英雄速度+2，只能提升一个英雄的能力，提升后宝石会消失
 | 攻击红宝石 Ruby of Offense | 访问后英雄近战攻击力+6，远程攻击力+4，只能提升一个英雄的能力，提升后宝石会消失
 | 战争学校 School of War | 随机出现两个非魔法系（战斗、战术、侦察或贵族）的主技能供英雄学习，只能选择其一，学习花费2000金
 | 魔法学校 School of Magic | 随机出现两个魔法主技能供英雄学习，只能选择其一，学习花费2000金
 | 战争大学 War University | 随机出现四个非魔法系（战斗、战术、侦察或贵族）的二级技能供英雄学习，学习一项技能需要花费2000金
 | 魔法大学 Magic University | 随机出现四个魔法二级技能供英雄学习，学习一项技能需要花费2000金
 | 老兵公会 Veteran's Guild | 花费2000金，将英雄某个非魔法系技能提升一级。只能提升技能等级，不能学会新技能
 | 图书馆 Library | 花费2000金，将英雄某个魔法技能提升一级。只能提升技能等级，不能学会新技能
 | 驯兽师小屋 Beastmaster's Hut | 随机出现一个非魔法系主技能供英雄免费学习
 | 女巫小屋 Witch's Hut | 随机出现一个魔法主技能供英雄免费学习
 | 战术祭坛 Altar of Tactics | 使英雄获得一个战术系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 战斗祭坛 Altar of Combat | 使英雄获得一个战斗系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 侦察祭坛 Altar of Scouting | 使英雄获得一个侦察系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 贵族祭坛 Altar of Nobility | 使英雄获得一个贵族系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 生命祭坛 Altar of Life Magic | 使英雄获得一个生命魔法系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 死亡祭坛 Altar of Death Magic | 使英雄获得一个死亡魔法系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 守序祭坛 Altar of Order Magic | 使英雄获得一个守序魔法系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 混乱祭坛 Altar of Chaos Magic | 使英雄获得一个混乱魔法系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 自然祭坛 Altar of Nature Magic | 使英雄获得一个自然魔法系技能等级（学会新技能或是已有技能提升一级），只能给一个英雄提升，提升完成后祭坛消失
 | 三叶草地 Clover Filed | 访问后部队所有成员幸运+1，效果维持一场战斗
 | 仙子之环 Faerie Ring | 访问后部队所有成员幸运+1，效果维持一场战斗
 | 幸运喷泉 Fountain of Fortune | 访问后部队所有成员幸运+1，效果维持一场战斗
 | 青春喷泉 Fountain of Youth | 访问后部队所有成员士气+1，效果维持一场战斗
 | 幸运偶像 Idol of Fortune | 访问后部队所有成员幸运+1，效果维持一场战斗
 | 祝福石 Blessing Stone | 访问后部队所有成员士气+1，幸运+1，效果维持一场战斗
 | 彩虹 Rainbow | 访问后部队所有成员幸运+2，效果维持一场战斗
 | 混乱神庙 Temple of Chaos | 访问后部队内混乱派系的成员士气+2，死亡和自然派系的成员士气+1，效果维持一场战斗
 | 死亡神庙 Temple of Death | 访问后部队内死亡派系的成员士气+2，混乱和守序派系的成员士气+1，效果维持一场战斗
 | 生命神庙 Temple of Life | 访问后部队内生命派系的成员士气+2，守序和自然派系的成员士气+1，效果维持一场战斗
 | 自然神庙 Temple of Nature | 访问后部队内自然派系的成员士气+2，混乱和生命派系的成员士气+1，效果维持一场战斗
 | 守序神庙 Temple of Order | 访问后部队内守序派系的成员士气+2，死亡和生命派系的成员士气+1，效果维持一场战斗


行动辅助的野外设施

    以下所说的“移动力+2”、“移动力+5”之类，都是指所加的基本值，如果有提升地图移动力的宝物或技能，则所加的移动力要按比例提升。

图标 | 名称 | 说明
 | 硫磺旅馆 Brimstone Lodge | 访问后部队所有成员地图移动力+2，在熔岩地形上行走时每走一格只消耗1点移动力（相当于死亡系部队）。效果持续7天，但访问当天只增加移动力上限，不增加当前移动力
 | 沙漠小屋 Desert Hut | 访问后部队所有成员地图移动力+2，在沙漠地形上行走时每走一格只消耗1点移动力。效果持续7天，但访问当天只增加移动力上限，不增加当前移动力
 | 湿木客栈 Wet Log Inn | 访问后部队所有成员地图移动力+2，在沼泽地形上行走时每走一格只消耗1.5点移动力（相当于混乱系部队）。效果持续7天，但访问当天只增加移动力上限，不增加当前移动力
 | 寒冬旅馆 Winter Lodge | 访问后部队所有成员地图移动力+2，在冰雪地形上行走时每走一格只消耗1.25点移动力（相当于守序系部队）。效果持续7天，但访问当天只增加移动力上限，不增加当前移动力
 | 野蛮人营地 Barbarian's Camp | 访问后部队所有成员地图移动力+2，在粗糙地形上行走时每走一格只消耗1点移动力（相当于力量系部队）。效果持续7天，但访问当天只增加移动力上限，不增加当前移动力
 | 水槽 Trough | 访问后部队所有成员当天的地图移动力+7.5
 | 马厩 Stables | 访问后部队所有成员地图移动力+5，效果持续7天
 | 集合旗帜 Rally Flag | 访问后部队所有成员地图移动力+1，效果持续一个月（28天）
 | 绿洲 Oasis | 访问后部队所有成员当天的地图移动力+10
 | 灯塔 Lighthouse | 占领后本方所有部队在海上的地图移动力+10。 占领多个效果不累加


魔法学习相关的野外设施

图标 | 名称 | 说明
 | 一级生命神祠 Level 1 Life Shrine | 随机产生一种一级生命魔法攻英雄学习，英雄必须掌握基础生命魔法技能才能学习这个魔法
 | 二级生命神祠 Level 2 Life Shrine | 随机产生一种二级生命魔法攻英雄学习，英雄必须掌握高级生命魔法技能才能学习这个魔法
 | 三级生命神祠 Level 3 Life Shrine | 随机产生一种三级生命魔法攻英雄学习，英雄必须掌握专家生命魔法技能才能学习这个魔法
 | 四级生命神祠 Level 4 Life Shrine | 随机产生一种四级生命魔法攻英雄学习，英雄必须掌握大师生命魔法技能才能学习这个魔法
 | 五级生命神祠 Level 5 Life Shrine | 随机产生一种五级生命魔法攻英雄学习，英雄必须掌握宗师生命魔法技能才能学习这个魔法
 | 一级死亡神祠 Level 1 Death Shrine | 随机产生一种一级死亡魔法攻英雄学习，英雄必须掌握基础死亡魔法技能才能学习这个魔法
 | 二级死亡神祠 Level 2 Death Shrine | 随机产生一种二级死亡魔法攻英雄学习，英雄必须掌握高级死亡魔法技能才能学习这个魔法
 | 三级死亡神祠 Level 3 Death Shrine | 随机产生一种三级死亡魔法攻英雄学习，英雄必须掌握专家死亡魔法技能才能学习这个魔法
 | 四级死亡神祠 Level 4 Death Shrine | 随机产生一种四级死亡魔法攻英雄学习，英雄必须掌握大师死亡魔法技能才能学习这个魔法
 | 五级死亡神祠 Level 5 Death Shrine | 随机产生一种五级死亡魔法攻英雄学习，英雄必须掌握宗师死亡魔法技能才能学习这个魔法
 | 一级混乱神祠 Level 1 Chaos Shrine | 随机产生一种一级混乱魔法攻英雄学习，英雄必须掌握基础混乱魔法技能才能学习这个魔法
 | 二级混乱神祠 Level 2 Chaos Shrine | 随机产生一种二级混乱魔法攻英雄学习，英雄必须掌握高级混乱魔法技能才能学习这个魔法
 | 三级混乱神祠 Level 3 Chaos Shrine | 随机产生一种三级混乱魔法攻英雄学习，英雄必须掌握专家混乱魔法技能才能学习这个魔法
 | 四级混乱神祠 Level 4 Chaos Shrine | 随机产生一种四级混乱魔法攻英雄学习，英雄必须掌握大师混乱魔法技能才能学习这个魔法
 | 五级混乱神祠 Level 5 Chaos Shrine | 随机产生一种五级混乱魔法攻英雄学习，英雄必须掌握宗师混乱魔法技能才能学习这个魔法
 | 一级自然神祠 Level 1 Nature Shrine | 随机产生一种一级自然魔法攻英雄学习，英雄必须掌握基础自然魔法技能才能学习这个魔法
 | 二级自然神祠 Level 2 Nature Shrine | 随机产生一种二级自然魔法攻英雄学习，英雄必须掌握专家自然魔法技能才能学习这个魔法
 | 三级自然神祠 Level 3 Nature Shrine | 随机产生一种三级自然魔法攻英雄学习，英雄必须掌握专家自然魔法技能才能学习这个魔法
 | 四级自然神祠 Level 4 Nature Shrine | 随机产生一种四级自然魔法攻英雄学习，英雄必须掌握大师自然魔法技能才能学习这个魔法
 | 五级自然神祠 Level 5 Nature Shrine | 随机产生一种五级自然魔法攻英雄学习，英雄必须掌握宗师自然魔法技能才能学习这个魔法
 | 一级守序神祠 Level 1 Order Shrine | 随机产生一种五级守序魔法攻英雄学习，英雄必须掌握宗师守序魔法技能才能学习这个魔法
 | 二级守序神祠 Level 2 Order Shrine | 随机产生一种二级守序魔法攻英雄学习，英雄必须掌握高级守序魔法技能才能学习这个魔法
 | 三级守序神祠 Level 3 Order Shrine | 随机产生一种三级守序魔法攻英雄学习，英雄必须掌握专家守序魔法技能才能学习这个魔法
 | 四级守序神祠 Level 4 Order Shrine | 随机产生一种四级守序魔法攻英雄学习，英雄必须掌握大师守序魔法技能才能学习这个魔法
 | 五级守序神祠 Level 5 Order Shrine | 随机产生一种五级守序魔法攻英雄学习，英雄必须掌握宗师守序魔法技能才能学习这个魔法


宝库

    以下的野外设施，都是要与一定数量的守军交战，然后拿到相应的资源或宝物。守军的数量有一定的随机性，数量上限会根据游戏难度不同而发生变化，而数量下限则是保持不变的。宝库的守军数量会随着时间的推移而慢慢增加，增加的速度与原始数量无关，只与宝库类型有关。守军数量增加后，战斗获胜所取得的奖励也相应提升，不仅是得到的金钱增加，所得到的宝物等级或数量也会上升。只得金钱不得资源的隐匿处，在守军数量增加后有可能会给战胜者提供宝物。
    宝库清空后，过一段时间（一个月零一天）守军会重新出现，此时守军数量虽然非常少，但战胜后拿到的奖励却不少，相当于从守军重新出现的那一天起，以上一次被清空时的奖励为基础，在此基础上进行积累。
    以下所给出的数据，都是在最高难度下第一天时的情况。

图标 | 名称 | 说明
 | 隐匿处 Hideout | 由盗贼看守的宝库。盗贼数量的下限是40，战斗获胜后可以得到1500金；数量上限是145，获胜后可以得到3500金
 | 陵墓 Mausoleum | 由骷髅、幽灵和吸血鬼看守的宝库。守军的下限是50骷髅+10幽灵，战斗获胜后可以得到2750金；守军上限是181骷髅+36幽灵+10吸血鬼，获胜后可以得到9750金+中级宝物一个
 | 龙城 Dragon City | 由黑龙看守的宝库。黑龙数量的下限是3，战斗获胜后可以得到8000金+中级宝一个；数量上限是11，获胜后可以得到21500金+中级宝三个+高级宝一个
 | 神秘花园 Mystical Garden | 由妖精和丛林妖精看守的宝库。守军的下限是40妖精+40丛林妖精，战斗获胜后可以得到750金+7水晶；守军上限是145妖精+145丛林妖精，获胜后可以得到2500金+18水晶
 | 格伦森林 Forest Glenn | 由狼和白虎看守的宝库。守军的下限是40狼+10白虎，战斗获胜后可以得到2000金+15木材；守军上限是145狼+36白虎，获胜后可以得到5750金+46木材
 | 墓地 Graveyard | 由僵尸看守的宝库。僵尸数量的下限是50，战斗获胜后可以得到2500金；数量上限是181，获胜后可以得到4250金+初级宝一个
 | 狮鹫巢 Griffin Nest | 由狮鹫看守的宝库。狮鹫数量的下限是10，战斗获胜后可以得到750金+37木材；数量上限是36，获胜后可以得到7000金+85木材
 | 鸟妖巢 Harpy Nest | 由鹰身女妖看守的宝库。鹰身女妖数量的下限是20，战斗获胜后可以得到1750金+6水银；数量上限是72，获胜后可以得到4750金+18水银
 | 小鬼窖藏 Imp Cache | 由恶魔之子看守的宝库。恶魔之子数量的下限是40，战斗获胜后可以得到500金+4硫磺；数量上限是145，获胜后可以得到1000金+8硫磺
 | 象牙塔 Ivory Tower | 由法师看守的宝库。法师数量的下限是20，战斗获胜后可以得到1250金+1、2、3级魔法羊皮纸各一张+1级魔法卷轴1个；数量上限是72，战斗获胜后可以得到3000金+1、2、3、4级魔法羊皮纸各一张+1、2、3级魔法卷轴各一个。以上只是一般规律，有时会有细小差异
 | 碉堡 Keep | 由弩手和枪兵看守的宝库。守军的下限是20弩手+10枪兵，战斗获胜后可以得到1500金+2件道具或药水；守军上限是72弩手+36枪兵，获胜后可以得到3500金+6件道具或药水
 | 巢穴 Lair | 由邪眼魔看守的宝库。邪眼魔数量的下限是20，战斗获胜后可以得到1件道具或药水+1件初级宝物；数量上限是72，获胜后可以得到6250金+1件道具或药水+1件初级宝物
 | 迷宫 Maze | 由牛头怪看守的宝库。牛头怪数量的下限是20，战斗获胜后可以得到8宝石+1件初级宝物；数量上限是72，获胜后可以得到33宝石+2件初级宝物
 | 金字塔 Pyramid | 由木乃伊看守的宝库。木乃伊数量的下限是40，战斗获胜后可以得到2件初级宝物；数量上限是145，获胜后可以得到6750金+2件初级宝物+1件中级宝物
 | 红矮人矿坑 Red Dwarf Mines | 由矮人看守的宝库。矮人数量的下限是40，战斗获胜后可以得到250金+13矿石；数量上限是145，获胜后可以得到1000金+26矿石
 | 废墟 Ruins | 由半兽人看守的宝库。半兽人数量的下限是45，战斗获胜后可以得到2250金；数量上限是163，获胜后可以得到5750金
 | 圣殿 Sacred Temple | 由僧侣看守的宝库。僧侣数量的下限是10，战斗获胜后可以得到2500金+1、2级魔法羊皮纸各一张+1级魔法卷轴1个+1瓶药水；数量上限是36，战斗获胜后可以得到7250金+3、4级魔法羊皮纸各一张+1、2级魔法卷轴各一个+3瓶药水。
 | 抛弃船 Derelict Ship | 由水元素看守的宝库。水元素数量的下限是20，战斗获胜后可以得5250金；数量上限是72，获胜后可以得到10750金+初级宝物一件+中级宝物一件
 | 沉船 Ship Wreck | 由幽灵看守的宝库。幽灵数量的下限是25，战斗获胜后可以得3250金；数量上限是91，获胜后可以得到8000金+初级宝物一件
 | 海盗岛 Pirate Islands | 由海盗看守的宝库。海盗数量的下限是50，战斗获胜后可以得2000金；数量上限是181，获胜后可以得到4000金+3宝石


其他野外设施

图标 | 名称 | 说明
 | 财宝箱 Treasure Chest | 打开宝箱时得到的结果会是以下四种其中之一： 捡到2000金，如果不要钱，可以得到1500经验值 捡到1500金，如果不要钱，可以得到1000经验值 捡到1000金，如果不要钱，可以得到500经验值 捡到随机的初级宝物一件
 | 医疗马车 Medicine Wagon | 可以捡到随机的药水2或3瓶
 | 背包 Backpack | 可以捡到随机的道具或药水一件
 | 骷髅 Skeleton | 可以捡到随机的初级宝物一件
 | 法师的箱子 Mage's Chest | 可以捡到随机的中级宝物一件
 | 废材堆 Flotsam | 有可能捡到10木材，或是9木材+100金，或是8木材+200金，或是7木材+300金，或是6木材+400金，或是5木材+500金
 | 海上箱子 Sea Chest | 财宝箱的海上版本，但是不能将里面的钱转化为经验值
 | 沉船生还者 Shipwreck Survivor | 可以捡到随机的初级宝物一件
 | 交易站 Trading Post | 可以在这里进行资源交易，兑换率比市场便宜1/3
 | 避难所 Sanctuary | 访问后补满英雄的生命值，并且复活阵亡的英雄。可以让部队驻扎在里面，免受敌人攻击，但每呆一天要花费200金
 | 海上避难所 Sea Sanctuary | 避难所的海上版本


阴云密布新增野外设施

图标 | 名称 | 说明
 | 力量竞技场 Coliseum of Might | 英雄进入后单挑一定数量的黑龙，如获胜等级将提升一级。黑龙数量与难度有关，最高难度是正常难度的3倍。正常难度下，数量是英雄当前等级÷12。综合难度因素之后，将计算出来的结果进行四舍五入（但与真正四舍五入有区别，0.5是被舍弃的）
 | 魔法竞技场 Coliseum of Magic | 英雄进入后单挑一定数量的仙女龙，如获胜等级将提升一级。仙女龙数量的公式与上面相似，但计算时要把英雄当前等级÷6。（此规律由白菜总结）
 | 混乱学院 Conservatory of Chaos | 随机出现混乱派系魔法的羊皮纸供购买，其中1-4级魔法各两种，5级魔法一种
 | 死亡学院 Conservatory of Death | 随机出现死亡派系魔法的羊皮纸供购买，其中1-4级魔法各两种，5级魔法一种
 | 生命学院 Conservatory of Life | 随机出现生命派系魔法的羊皮纸供购买，其中1-4级魔法各两种，5级魔法一种
 | 自然学院 Conservatory of Natrue | 随机出现自然派系魔法的羊皮纸供购买，其中1-4级魔法各两种，5级魔法一种
 | 守序学院 Conservatory of Order | 随机出现守序派系魔法的羊皮纸供购买，其中1-4级魔法各两种，5级魔法一种


战术研究

    骑士堡初期战术修改版
    守序族的开局打法
    自然城的初期打法

    Death战役首关流程
    战役单关最高分
    野人战役首关的打法
    再论原版野蛮人战役开局
    原版守序战役的简便打法
    海盗女儿战役第一关的问题
    阴云密布第二个战役（wizard）最省现实时间的打法
    《阴云密布》Opposites Attract第一关最高难度四周过关心得
    Opposites Attract（异性相吸）第二关最高难度2周过关心得
    阴云野蛮人战役的另一种打法
    The Last Bastion（『战风』最后一关） 应该这样打

    『毕欧伍夫的传说』76天过关说明
    63天，The Beowulf Tales最高难度
    阴云地图“三女王”最高难度1周过关打法
    2个星期内过Siren’s song的心得
    Forest Frenzy 最高难度5天过关心得

    对战研究：（River Crossing，即穿越横河）
    H4随机大图Order vs Death

    浅谈H4微操作


战例分析

    用好疯老头的方法
    灯神使用的一些技巧
    打野灯神的方法
    关于打野灯神的一点补充

    资料片《阴云密布》中，吟游诗人打雷鸟
    再谈召水打飞兵
    在BT地图中打大量魔法型部队时使用的一个战术
    魔法补充的BT方法

    在《和平的代价》中，击败黑龙的方法
    再谈如何杀黑龙
    还谈一谈杀黑龙，测试结果令人吃惊
    耗龙法的研究
    杀黑龙的方法总结

    丑陋面具的应用
    三个英雄的奇遇
    再谈等待的运用


游戏破解

    游戏难度和获取的经验值的关系
    多英雄分经验值的规律
    游戏得分的算法
    生物能力的1：5原则
    士气与幸运的作用详解

    关于兵种体积的初步研究
    战场上部队行动的先后顺序以及反击的规律
    攻击被冰冻生物的研究
    竞技场龙的数量
    在野外拆分队伍的规律
    野兵的增长率
    宝库测试
    驱役类魔法详解
    地图移动力决定战场移动力
    英雄可自动学会的魔法

    有关战斗中无法撤退的解答
    “大回城术”
    节省移动力的出城法

    攻城的简易方法
    如何在战斗中改变随机数
    快速战斗（quickcombat）的研究
    盗贼堵人大法

    英雄升级时出现的技能选项规律
    英雄转职的匹配问题
    各种职业升级时的新主技能，补充
    阴云密布中怎么培养一个鬼神使？
    外交与魅惑的作用
    招魂术的计算

    生物特技测试过程中的一些发现
    生物特技成功率的计算
    宗师抗魔特技究竟对什么生物特技（魔法）不免疫？
    有关巨人杀手魔法
    海怪的吞噬
    美杜莎的石化凝视

    魔法效果的计算
    【H4研究】叠加效果原理！
    攻击术与宝物的叠加
    陆地移动力详解
    攻击伤害的上下限
    H4完整伤害计算公式
    伤害力取值的原理

    战场行动要点若干
    战场操作汇总

    英雄无敌4脚本详解
    地图编辑器的一个技巧：修改英雄的基本技能

    heroesⅣ中英文版共存的方法
    修改急速风暴中文版字体大小的方法
    内存修改

    英雄带兵能力的Bug大揭密
    奇异现象搜集


游戏畅谈

    国外玩家Saurus的AI测试
    神器（relic）宝物简评

    小议自编地图
    制图内幕

    初学浅谈（一）：英雄无敌四种族之Life篇
    初学浅谈（二）：英雄无敌四种族之Death篇
    初学浅谈（三）：英雄无敌四种族之Order篇
    初学浅谈（四）：英雄无敌四种族之Chaos篇
    初学浅谈（五）：英雄无敌四种族之Nature篇
    初学浅谈（六）：英雄无敌四种族之Might篇

    英雄无敌4与魔兽的异同


疑难解答

    游戏运行中音乐时断时续，并且有时在战斗结束时死机，怎么解决？
    游戏中鼠标变成白色方块怎么办？
    修改分辨率以后，显示器不支持，不能进入游戏
    资料片中一进入力量竞技场或是魔法竞技场，游戏就出错退出，如何解决？
    过关需要击败的英雄被野兵杀了，怎么办？
    为什么不能分兵了（部队无法出城了）？
    怎样使用S/L大法？
    流沙魔法怎么施放？
    如何界定火魔法、精神类魔法/技能？
    打开藏宝图，却没有标明地点怎么办？
    死亡战役的最后一关为何无法过关？
    为何无法自动存档？
    在哪里修改才能去掉已经通关战役的勾标记？
    在被攻城时，怎样才能把指定的兵站到箭塔上？
    地图编辑器使用技巧
    如何使用“对象刷”
    各语言版本的升级
    英雄无敌2.2官方升级说明
    英雄无敌四更改头像（翻译）
    如何鉴别英雄的技能等级？


卷轴版本历史

版本：1.4标准版（2005年9月3日）

    在1.4简装版的基础上增加了战役攻略

『魔法主宰』战役：
    最后一关，去掉闪光指环的说明（在高版本中，闪光指环可直接与魔力闪光叠加，3.0版本测试通过。因此原先的说明已无效）

『吟游诗人传奇』战役：
    第三关，挖宝无需Agraynel亲自进行，最后一战役艾菲曼陀林会跑到Bohn手上。（由黑孔雀指正）

『胜者为王』战役：
    修正第一关有关建废矿的说明。废矿用兵就可以建，不用英雄（由fireway指正）

『高贵者』战役：
    修正剧情介绍的错误（最后未找到永生的秘密）

版本：1.4简装版（2005年9月3日）

    增加『心得体会』与『疑难解答』两个部分

生物：
    生物的战场移动力，单位由“码”改为“英尺”，数值相应更改
    盗贼产量修正为26，经验值修正为6（由黑孔雀指正）
    修正元素魔法抗性的说明（元素不免疫精准、嗜血）
    修正恐惧的说明。不完全的抗魔对恐惧没有任何抵抗力（由绝对零度指正）
    对于精英骑士的评价，去掉“围着一个敌人部队转圈打的战术并没有想象中那么强”等字样（此评价有点想当然，其实并不正确）

职业部分：
    游侠不能学死亡，修正之

魔法：
    将晕击从精神类中剔除
    流沙不影响远程攻击力（由绝对零度指正）
    修正祈祷的说明（加攻击力，非杀伤）

宝物：
    修正航海日志的作用说明
    关于厄运项链和阵营盾的效果翻转，施法和原地攻击也不会引起翻转，并不只是采取防御姿态。只要不移动就行了
    修正保护长袍的说明（对英雄无效）

野外设施：
    宝库页面，修正格伦森林和废墟的说明（由黑孔雀指正）
    修正集合旗帜的说明，效果持续一个月（由zhouxiao指正）

野外设施和城内建筑：
    远程攻击力+2、+4的说明修正为+2.1、+4.2

版本：1.32标准版（2004年11月24日）

    在1.32简装版的基础上增加了战役攻略

『魔法主宰』战役：
    第三关，修正胜利条件

『吟游诗人传奇』战役：
    第三关，增加挖宝的说明（必须主英雄亲自去挖宝，才能将曼陀林带到最后战役）

版本：1.32简装版（2004年11月24日）

生物：
    对范围攻击的特性进行补充说明（最后一箭不能忽略衰减因素）

技能：
    修正部分二级技能的学习前提

魔法：
    圣言、圣唱和驱逐三个魔法的效果会受到幸运的影响（由phinex指正）

野外设施：
    修正废矿的守军说明
    修正速度泉水、能量池、活力喷泉和力量喷泉的作用说明（由fireway指正）

版本：1.31标准版（2004年10月29日）

    在1.31简装版的基础上增加了战役攻略

『真刃』战役：
    第一关，去除士气对防护效果的影响说明，并去除地图难度与野兵生长速度的说明（好像都只是我的错觉而已，并不正确）。

『岁月的荣光』战役：
    第三关，修正沃扎克学习魔法技能的建议（生命主技能在此战役已经被屏蔽，不可能在升级时学会）。

『艾尔文与莎娜』战役：
    第一关，修正图片标号的错误

『半生者』战役：
    第一关的流程进行更加详细的说明（其实完全是参照水云的打法）。
    第五关流程作更改（城堡L可以在比较早的时候打下来）。对阴云密布（急速风暴）中文版存在的错误作一说明。

『魔法主宰』战役：
    第二关增加法师打魔法竞技场的方法说明

『异性相吸』战役：
    第一关，增加挖宝的说明
    第二关，修改箭术英雄打独眼时的方法说明
    第三关，修正魔法井的作用说明

『 吟游诗人传奇』战役：
    第一关，游戏进程作些修改，并增加打力量竞技场和魔法竞技场的说明
    第二关，提出另一种开局方法。
    第三关，详细说明打60黑龙的方法。

『死亡进行曲』战役：
    第一关，对游戏的流程作更加详细的说明（因为有玩家反映说无法按攻略所说速度完成）

此外还有多处表述方式上的小调整，不再一一列明

版本：1.31简装版（2004年10月28日）

生物：
    修正邪眼魔的评价文字（去除宗师抗魔英雄身上的正面魔法，并非邪眼攻击附带废除效果的特权，而是废除魔法本身就有的特性）
    修正机械的魔法抗性说明（机械不免疫失明）

魔法：
    修正失明魔法的作用说明
    对殉难和召唤凤凰两种魔法的价值重新作评价
    对驱散和废除魔法的作用进行补充说明（可以用来去除宗师抗魔英雄身上的正面魔法）

野外设施：
    对硫磺旅馆、沙漠小屋、湿木客栈、寒冬旅馆、野蛮人营地的作用进行补充说明

此外还有多处表述方式上的小调整，不再一一列明

版本：1.3简装版（2004年10月18日）

    对兵种和魔法增加了评价说明文字

生物部分：
    以派系来命名种族（原先的种族表述自己都觉得很别扭，改了）
    改变表格样式

生物页面：
    增加(平均伤害力×攻击力)÷(生命值×防御力)≈0.2公式，并附带相关说明
    修正仙女龙法力系数

生物特技总览页面：
    修正三头攻击的说明
    对老化的作用进行补充说明
    修正并补充范围攻击的作用说明
    失明技能，指明其出现几率
    格挡技能，指明其出现几率
    气息攻击的作用说明略作调整
    对冲锋技能的作用进行补充说明
    修正吞食技能的作用说明
    冷冻攻击技能，指明其出现几率
    对长武器攻击的作用进行补充说明
    修正吸取魔力的作用说明
    修正石化凝视的规律
    晕击技能，指明其出现几率
    对毒蜂草的虚弱技能进行补充说明

宝物：
    修正魔力药水作用说明
    对迷雾瓶的作用说明作些许调整
    对保护长袍的作用进行补充说明
    修正火球权杖、医疗权杖的作用说明
    对灾祸项圈、龙鳞盾、死亡护盾、生命护盾、混乱护盾、守序护盾和反自然护盾的作用进行补充说明
    对火炎之箭的作用进行补充说明
    修正小鹰的作用说明
    路人之靴更名为行路之靴
    修正猛虎头盔和光明指环的作用说明

魔法：
    增加精神魔法、治疗类魔法、火魔法和冰魔法几个分类，并将嗜血和血暴补充进精神魔法分类中
    修正火花魔法作用说明
    修正嗜血魔法作用说明
    对神圣介入的作用作补充说明
    修正守护天使作用机理的说明

建筑：
    修正幽灵土墩的建筑前提
    修正树顶小屋的资源需求
    国库的作用说明详细化

野外设施：
    补全某些遗漏的中文名称
    对硫磺旅馆、沙漠小屋、湿木客栈、寒冬旅馆、野蛮人营地的作用进行补充说明
    对灯塔的作用进行补充说明
    修正自然神祠的作用说明
    修正力量竞技场和魔法竞技场的作用说明

技能：
    潜行技能偷经验值的说明详细化

英雄职业与技能学习：
    对“一、2.”进行部分修改
    “关于魔法技能的学习”第3点，阴影法师作为例子显然不当（守序和死亡根本不是敌对派系），换掉。

此外还有多处表述方式上的小调整，不再一一列明

版本：1.21完整版（2002年11月20日）

    在1.21简装版的基础上增加了战役攻略

版本：1.21简装版（2002年11月20日）

    修正侦察技能的作用说明
    修正龙鳞盾的作用说明
    修正大法师套装的作用说明
    修正勇气徽章的作用说明
    修正半羊人的产量
    对Anti-Magic魔法的作用进行补充说明
    修正英雄技能学习规律的某些说明

版本：1.2简装版（2002年11月11日）

    新增“野外设施”部分

    对资料片阴云密布（the Gathering Storm）新增的生物、宝物和野外设施进行介绍

生物页面：
    将战场移动力的解说详细化
    修正幸运的作用说明
    补充说明了士气的影响因素

种族页面
    关于各种族的简单分析略作改动

生物详细资料页面
    修正金人、狂暴者的经验值
    修正恶魔、仙女龙、凤凰的魔法值

生物特技总览页面：
    对缠身技能的作用进行补充说明
    对气息攻击的作用进行补充说明
    对引起恐惧技能的作用进行补充说明
    修正火抵抗技能的说明
    火盾的说明详细化
    对抢先攻击技能的作用进行补充说明
    修正巨人杀手技能的说明
    对吸血技能的作用进行补充说明
    修正闪电攻击技能的说明
    修正毒击技能的说明
    补充并修正远程攻击和短程射击两个技能的说明
    对元素、机械、亡灵所免疫的魔法/技能进行详细说明

技能页面：
    对肉搏和箭术技能的作用进行补充说明
    修正魔法派系各技能的学习前提
    魅惑技能作用说明详细化

职业页面：
    增加了“英雄职业与技能学习”页面
    修正法王与暗黑领主的职业特性说明
    修正召唤师的职业特性说明

魔法页面：
    修正魔法效果的计算公式及各魔法参数
    对驱散和废除魔法的作用进行补充说明
    修正“窃魔”魔法的说明
    对推移、传送、催眠魔法的说明进行补充及修正
    对末日审判魔法的作用进行补充说明
    对庇护魔法的作用进行补充说明
    对吸取生命魔法的作用进行补充说明
    对牺牲魔法的作用进行补充说明
    对地形认知和流沙魔法的作用进行补充说明

宝物页面：
    修正部分宝物的图标
    修正寒冷药水的作用说明
    修正耐力药水的作用说明
    修正急速药水的作用说明
    修正大卫投石索的作用说明
    修正力量指环的作用说明
    修正龙鳞盾牌的宝物等级
    修正屠杀之箭的作用说明
    修正敏捷战戟的说明
    修正速度指环的作用说明
    修正懒惰之弓的说明
    修正航海日志的说明
    修正巨剑、投枪、半人马标枪、传说战斧、雷电战锤的作用说明
    修正狙击弩的作用说明
    修正政治家勋章的装备位置
    修正灾祸项圈的作用说明
    修正格里冯哈特钢甲的作用说明
    修正火炎之箭的作用说明

版本：1.12版（2002年4月16日）

    补全职业说明所遗漏的一段文字。

版本：1.11版（2002年4月16日）

    修正了枪兵特技的说明，并去除了几处乱码。

版本：1.1版（2002年4月15日）

    英雄无敌4东方卷轴第一个正式版本，因为在此之前水寒曾经根据前瞻资料制作了一款东方卷轴（此名称就是水寒想出来的），所以此版本的版本号定为1.1，而不是1.0。卷轴资料包括生物、技能、职业、魔法、宝物和建筑各部分。


关于

版 本 ： | 1.4简装版
整理日期： | 2005年9月3日

整理/制作： | DarkRain.cn
特别鸣谢： | 游侠创作室·水寒

    声明：本文件为英雄无敌4的详尽资料集、心得集。请尊重作者劳动，切勿抄袭用于盈利；欢迎转载，转载时请务必注明来自于英雄世界。

    本文件中某些名词的翻译与正版说明书和中文版不一致，敬请原谅！


游戏运行中音乐时断时续，并且有时在战斗结束时死机，怎么解决？

这是因为声卡不够好的缘故，一般发生在使用板载AC97声卡的时候。运行DirectX诊断程序（Windows开始菜单中选择“运行”，输入DxDiag，确定），将声音的硬件加速完全关闭。


游戏中鼠标变成白色方块怎么办？

这是因为所用的显卡与四代不够兼容。打开显示的设置（控制面板中选“显示”，或是在桌面上单击鼠标右键，点属性），在“设置”中选“高级”，找到“硬件加速”的设置，将加速级别向下调一两级试试。


修改分辨率以后，显示器不支持，不能进入游戏

使用注册表修改器regedit。寻找项：“Heroes of Might and Magic IV”。找到后，可以看到右面有一个键叫resolution，数值是你当前分辨率，改成你需要的。注意用十进制。


资料片中一进入力量竞技场或是魔法竞技场，游戏就出错退出，如何解决？

发生这种情况的原因是因为使用了不完整的硬盘版，需要找到完整的Music.h4r文件（任意版本的都可以，大小是七十几兆），覆盖到资料片的安装目录Data子目录下。
或者是到本站相关下载栏目中，下载音乐文件补丁。


过关需要击败的英雄被野兵杀了，怎么办？

如果敌人还有城堡（说不定野外有神庙，敌人还有部队也可以），就把墓碑周围的野兵清干净，走到远一点的地方等。过不久敌人就会把墓碑搬回城复活。然后你再上去把那英雄再杀一次。 如果什么都被你清干净了，就重读取以前的进度吧。


为什么不能分兵了（部队无法出城了）？

你在野外的部队太多了，已经达到最大数额8支部队。解散、合并，或者让一些进城，就可以重新分兵，以前城里出不来的部队也可以出来了。


怎样使用S/L大法？

英雄无敌四代中，一个进度被重新读取以后，再读取，随机产生的东西就不变了，永远和第一次读取的结果一样。想获得好的结果，读取一个进度不满意后，要重新再读取一遍，然后立即再存一次（是否同名无所谓）。然后再读取新保存的进度。 另外，一般战斗中的进度可以在任何时候读取，但是英雄进入竞技场战斗的进度，只能在竞技场战斗中读取，在其他地方读取，会被告知：“文件格式错误”。


流沙魔法怎么施放？

出现沙漏点一下，然后开始移动光标（最好移慢点，比较准确），移动过程不要碰到障碍物，可以拐弯，移到足够的长度流沙就会出现了。另外，流沙有一个特性，就是站在上面的部队，近战攻击力降低25%，防御力降低20%！


流沙魔法怎么施放？

如何界定火魔法、精神类魔法/技能？

1、凡是有火抵抗技能的部队能防住的魔法就是火魔法。

2、凡是用精神护盾（Mind Shield）能够防住的就是精神类魔法/技能。


打开藏宝图，却没有标明地点怎么办？

可能是被树丛，或者其他什么东西挡住了（3D贴图的错误）。找准藏宝图的中间，在附近勇敢地挖吧！

如果仍然挖不出来，就取出访问最后一个神像前的游戏进度，用L/S/L的方法让宝藏埋藏的位置发生变化。

另外要注意一点，挖宝是需要满行动力的。移动到正确位置之后，休息一天，然后才可以挖。


死亡战役的最后一关为何无法过关？

    这个现象仅仅存在于阴云密布中文版（正版名称『急速风暴』）中。因为地图错误，摧毁障碍物的一个事件中没有把“人类玩家”选项选上，导致障碍物不会消失，因此也无法过关。这是阴云密布中文版所独有的错误，英文版或是原始中文版中均不存在此问题。

    解决的方法是用资源查看器H4ResEx（相关下载栏目中有这个工具）将updates.h4r中的所有文件导出，修改游戏地图之后，用资源查看器的Mod Maker这个插件重新生成updates.h4r。过程比较繁琐，不详细讲述了。


为何无法自动存档？

这是因为游戏安装目录下缺少一个games子目录，手动建立一个就行了。


在哪里修改才能去掉已经通关战役的勾标记？

如果想去除，可以到Data子目录中删除carryover.dat这个文件，所有的勾就会全部消失（包括资料片中战役完成时的英雄能力记录）。如果想恢复，记得事先备份。


在被攻城时，怎样才能把指定的兵站到箭塔上？

站偶数格的兵在箭楼上。队伍显示成两排的时候，后面一排在箭楼上。


地图编辑器使用技巧

1、地图编辑器中的设施，宝物等被误删除，有个重置（Reset）按钮可以恢复

2、地图编辑器的拷贝可以通过按住ctrl键拖动物体实现（可以窗口间拷贝）


如何使用“对象刷”

WOW版本的地图编辑器中有个有趣的功能叫对象刷。你可以自己画一些景物，建筑，然后把它们存成文件（.h4b），以后需要用的时候，直接作为一个对象使用。这里简要说一下怎么使用，试过就知道，和Photoshop里面那个图章很相似。 大家在编辑地图的时候，选菜单中的Tools->Forest/Mountain Tool，或者点工具栏中的倒数第二个（显示的说明是Object Painter，粗制滥造，处处可见！），如示例中A。然后在左边的下拉列表（B）中选择你想要填充的物体，可以是地形，景物，建筑等等。当然，也可以选择刷子的大小（C）。接下来，用鼠标在地图中标出你需要填充的地方，最后点那个小山按钮（D），相应的对象就被填充进你选定的区域。选定的区域可以是任何形状，地图编辑器有算法变形和延伸。图中E是选定区域，F是填充以后的样子。

地图编辑器里面已经预先准备好了几个对象。我们可以下载新的h4b文件，输入系统。选菜单Tools->Customize...，然后会弹出对话框，选择Obstacle Brushes（第三个名字了，faint...），点按钮Import Brush,就可以选择相应的h4b文件。如果你想自己制作对象，可以点Add Brush，会弹出新的对话框。右边可以选择景物等类型（1），左边是个棋盘一样的东西（2），把你选择的物体拖动到棋盘上。过程比较简单，需要注意的是你可以有不同的层次（3），以便重叠等，二是有扩散范围（4）；三可以设定填充的时候填多满（5）。


各语言版本的升级

在中国买的原版游戏是UK版本，但资料片是US版本。不装资料片就没有新战役，没有新生物、宝物和野外设施。

原版的升级补丁和资料片升级补丁是不同的，两者不可通用。原版游戏要原版的2.0到2.2升级补丁，不管是US还是UK；资料片升级要资料片的2.0到2.2升级补丁，也是不管US或UK。之所以站上原版游戏提供UK升级补丁，资料片提供US升级补丁，是因为目前只有原版UK的“原始程序”（就是正常安装完或是升级后产生的主文件，没有打过免CD补丁的，免CD的主程序升级补丁不承认），资料片US的“原始程序”。

升级补丁要选对US和UK版本，否则升级无法正确完成。就是说，如果你没有资料片2.0-UK的“原始程序”，那么就算给你资料片UK 2.0到2.2的升级补丁，也没有任何用处。反过来说，如果你有资料片2.0 UK的“原始程序，那么那个升级补丁就可以派上用场。

好像太罗嗦了………………简单说，就是一个配套问题。 无论原先是什么版本，1.0也无所谓，直接安装资料片，就成为阴云密布2.0了，然后使用阴云密布2.0到2.2升级补丁，升级成为阴云密布2.2。


英雄无敌2.2官方升级说明

升级简要说明

更正了：在对战模式+自动战斗中，攻城偶尔导致程序崩溃。
更正了：对战模式下，一方的英雄通过潜行经验升级时，另一方会在“等待对方行动”的对话框中死机。
更正了：对战模式+自动战斗中，如果一支弱的军队进攻强的军队，并得到投降的机会时，程序死机。
更正了：对战模式下，解雇英雄造成程序死机。
驻军信息画面中，不能再使用[Shift]+ [空格]键复制军队。
王国信息画面中，不能再移动军队在城市中转移。

已知问题

决大部分有关音效的问题都可以通过调低声音的硬件加速来解决。在开始菜单中选择“运行”，输入：DXDIAG。当DirectX工具对话框出现后，选择“声音”。然后拖动“硬件加速”滚动条，使后退一到两格。

升级指导

升级英雄无敌四:阴云密布 如果你的英雄无敌四是北美版本，并安装了北美版本的英雄无敌四:阴云密布，使用： Heroes IV The Gathering Storm - 2.2 US English update. 2.16 MB 如果你的英雄无敌四是英国版本，并安装了北美版本的英雄无敌四:阴云密布，使用： Heroes IV The Gathering Storm - 2.2 UK English patch. 2.16 MB
升级英雄无敌四 如果你安装了北美版本的英雄无敌四（不含阴云密布资料片） Heroes IV 2.0 - 2.2 US English update. 2.16 MB 如果你安装的版本是北美1.0或者1.3，升级到2.2之前请先升级到2.0 Heroes IV 1.0 - 1.3 US English Update 16.2 MB Heroes IV 1.3 - 2.0 US English Multiplayer Update 8.46 MB 如果你安装了英国版本的英雄无敌四（不含阴云密布资料片） Heroes IV 2.0 - 2.2 UK English patch. 2.16 MB 如果你安装的版本是英国1.0或者1.3，升级到2.2之前请先升级到2.0 Heroes IV 1.0 - 1.3 UK English patch 16.1 MB Heroes IV 1.3 - 2.0 UK English patch 8.47 MB
升级英雄无敌四战役编辑器2.1 英雄无敌四战役编辑器2.1并不是必须的,但是如果你想自编、修改英雄无敌四（原版，不是资料片）地图,我们强烈建议你安装这个升级补丁。要使用这个补丁，你现在的英雄无敌四版本必须是2.0或以上。 Campaign Editor version 2.1 All Languages 300 KB（适用于所有版本）

SSZ注：这是翻译的3DO的官方网页内容。3DO太差了，小小一点升级说明都写得错误百出，一看就是copy/paste的，而且还不检查！大部分明显笔误的地方我已经改了，但是一些程序的名字不统一的地方我没有动，便于大家以后对照查询。所有的升级补丁以及免CD补丁都可以在本站下载到。


英雄无敌四更改头像（翻译）

以前论坛上有人介绍了一个可以修改英雄无敌四英雄头像的网站。现在把它上面的说明给大家翻译一下：
说明： 你可以通过这个软件修改英雄无敌四的英雄头像、姓名、性别、种族和自传。现在的版本支持拖放鼠标操作。

安装：

下载英雄无敌四头像工具包安装程序。（工具名为H4FaceKit，用Google之类的搜索引擎可以搜索到）运行。

手册：

一、如何加入自定义头像：

首先在你的绘图（看图）工具中选中你想要的图片（注意要选择Ctrl+C），然后按头像工具包中的“”按钮。
在任何地方，拖放头像图片文件（不能是快捷方式）到头像工具包窗口。

二、选项：

“Lock original image aspect ratio”：如果你加入的头像不是1：1的（比如三代的头像），本工具包会自动拉伸，使图象变胖（瘦）。如果选择了这个选项，则图象会被裁剪，而不是拉伸。
“Use X/Y Range”：如果你加入的图象有你不想要的部分（如手、脚），可以通过拖动它来确定裁剪范围，而不用在绘图工具中处理。
按“MakeSFX”按钮，工具包会在英雄无敌四的目录下面创建一个“H4FKSFX.EXE”文件，包括你所有添加的头像和说明。
当你保存你的头像时，文件会增大。“Wipe”按钮可以重新改写文件，保证文件最小。 当你选择了“Auto-ring”这个选项以后，当引入透明背景，或者背景色为紫色的图片，工具包可以自动换成合适的（根据种族确定）背景。
“Auto S.Face Copy”自动根据大头像生成小头像。这个是系统的缺省选项，可以在“选项” 窗口中关闭。


如何鉴别英雄的技能等级？

其实方法很简单。看英雄技能的图标，如果四个角上都没有特殊颜色，这个技能就是基础级的；如果只有右上角有颜色，就是高级的；如果右上和右下角都有颜色，就是专家级；左下角也有颜色的话，就是大师级；四个角上全部有颜色，就是宗师级。


骑士堡初期战术修改版
作者：刑天

    传说骑士堡很弱，我在冠军难度打了几关觉得其实没有想象中的困难甚至可以说好用。初期困扰发展的不过是资源紧缺和野兵较多而已，其实你只要发展二级魔法和一级兵就可以完成发展了。重点在于魔法和战术的配合，充分利用人类防守反击的优势，抢占大部分资源都可以不损兵。

    二级魔法要求学会生命魔法：防护+报偿
    战斗技能专家级一定要学。

    基本打法是防护+报偿。不是远程就去让他们死吧，机械、亡灵、打人不反击也不行。有天堂之盾更加好用，不掉自己的血，加的hp>50可比自己的hp禁打。Defender提高的防御力是87.5%。几十3级兵也打不动7、8级的英雄。因为专家的防御+30的防御（4级兵才有的啊）表面上看某些2、3级兵伤害很高，可是他们打你时只能发挥5-13%的伤害，我基本上让他们的伤害在10%以下。实际上打不动你的。

    精神护甲，各系抵御有就更好。反正大不了就医疗一下，瓶子用得不多，省钱又好用，真是经济实惠。

    关键在于战斗时先给自己加报偿，和defender 然后英雄前走几步。防守、防守、再防守。野兵都围住英雄打，你可以用远程慢慢来。呵呵。打的时候把弓箭手多分几组，这样敌人也分组，每个人打你都被反击等于你的伤害提高了好几倍。

    建2级魔法工会须2000G 4木4铁，再加上射箭场1500G，弩车作坊3000G，6铁。初期就无敌了，等到高级法术+4级兵出来就不用我教你了吧。在初期财力不宽裕的情况下，这是骑士们唯一的出路。我们要发扬骑士的奉献精神-----“你过来打我呀！！”弓箭手\弩车都无视距离超好用。

    英雄花3级左右加战斗，其他的进攻，箭术统统不要。生命魔法学到2级，如果你觉得不满足可以s/l几次学精神，就是加生命魔法效果的那一个。

    不论是理论还是实践，这种战术都是确属可行的。上面写的只是基本战术，指导思想就是想尽手段加英雄防御和生命魔法效果。更高级的战术要结合具体地图去分析，毕竟兵无常法，唯一心而已。


守序族的开局打法
作者：antidevil

    个人意见是，H4里数量BT的野兵设定使得战略上的选择变得十分狭窄。对很多种族来说，可能魔法塔里缺了一个必要的魔法会使得整个局面十分被动，若是单机玩家，还可以用RESTART来解决，但若想对战那就要有用最烂的魔法对付最难缠敌人的决心。

    想必大家对常规战术欺负电脑都很熟悉了。我想说点自己用守序和自然在开局和中局阶段对付尴尬局面的经验。例如开局就遇见一大堆盗贼、妖精或小鬼这类快速肉搏兵守着木石矿，对大多人公认的强种族守序和死亡，穷地图遇到矿被这种人看着局面非常被动。

    先说守序，先看一下开局。常规战术是利用半身人+精准来对付大多地面部队。1级魔法里对守序来说最重要的是精准精准，无论这个魔法是不是会，都要尽快把英雄升1级学会2级魔法，因为2级里可能会有减速。升到2级，如果有减速就万事大吉，否则有冰箭和幻象也不错。如果都没有而附近的钱又不多，那根据RP原理很可能3级行会里有非常不错的魔法（说不定遗忘，传送，回城中的2个）而其中任何一个都有可能改变战斗的走向。

    事实上因为敌人数量很多，一定要把自身实力发挥到极点才有可能会胜利，所以半身人的10箭如果射不死2/3以上的敌人，这战斗基本是没有小损失胜利的希望的。另一方面，基于完全发挥自身实力这个原则，在2级兵的选择上法师要优于金人。况且2级兵不可能囤积，刚出几个就要立即投入战斗，这时4-6个法师就可以在半身人的攻击后迅速招出10多个骷髅来吸引敌人。

    开局阶段2种常见的难过局面（指关键性的金矿、副城或路口由这些部队把守）

    1.弩车+枪兵或弩车+侍卫。

    对付一般的弓箭手可以用密集阵型引诱他走过来或着升级到5级用遗忘，但弩车不吃这招~~先看你的魔法塔里有什么魔法，如果敌人有枪兵你却没有减速，那我觉得还是等灯神出来算了。如果有减速，再看有没有传送（加上镜象最理想，没有就要牺牲矮人），如果没有传送，我觉得用初级兵+2级兵对付弩车希望几乎没有，因为魔法师招出来的骷髅被一炮就打死了。弩车的弹药又很多，耗是耗不完的。如果都齐了，就把矮人都招募出来，一共排5队，半身人+英雄+矮人大队+矮人小队（1个）+魔法师，密集阵型，上来英雄等待，魔法师走到最后去，1个矮人走到最前面，其他等待。等枪兵走上来以后，英雄减速离弩车最近的枪兵，然后下回合把矮人传送到弩车后面一定距离（不是前面）去。因为枪兵打不到矮人会继续前进，矮人面对弩车（不用打但面一定要朝弩车），然后魔法师用诅咒有效减少矮人的损失后对枪兵放毒。敌人的枪兵有限（2级兵经验有上限）而且有4队，半身人2次攻击就可以差不多打掉1队，60个以上的矮人可以有效抗住弩车（英雄要是会冰箭就拼命放了，不然镜象枪兵也可以）。这样可以用几十个矮人作为代价换取胜利，在ICE AGE这个地图上我成功地用这个战术打掉了守副城的弩车。

    这个战术对付弩车+侍卫同样有效。方法也差不多，缺点是侍卫移动速度快容易冲到前面，所以魔法师要在半身人攻击后招骷髅冲上去而不是放毒，在对付1级兵的时候，魔法师放毒没什么用处。但在面对光弩车时这个办法不灵，因为3队弩车只能逼住其中1队，而另2队会轻易消灭大队的矮人。

    2.狼、盗贼/妖精、小鬼

    快速一级近战兵在初期是守序的大敌，一旦有了灯神这些都是小菜，但若守卫的是宝石或木石矿，那就很棘手了。要说明的是，在初期基本不可能打赢2级快速兵如游牧人。
    对于狼和盗贼，如果英雄有减速就比较简单一些。（如果不会减速，那就只有用矮人+英雄硬拼了）会减速的话，记得用开放阵型，半身人要放在6号位，英雄4号位，这是由于英雄比狼和盗贼的速度低1，只能放一次减速。而矮人占据的1、2、3、5号位在第一回合（对方一般会等待）走到前面排成松散的位置，可以有效防止敌人在第二回合就突入攻击你的半身人和英雄。第一回合英雄对对方第3个放减速，因为他离你最近最快，从顺序上看将最有可能打到你的后排。第二回合英雄对第二个放减速，因为这个人有可能打死你的英雄。魔法师我一般在7号位，对盗贼来说，诅咒可以降低一半的攻击力，故倾向于用一个魔法师放诅咒。但面对狼就要全上啦，尽可能多招骷髅，否则矮人是打不过的。事实上这种战斗如果你不save/LOAD的话，几乎很难不损失魔法师。

    至于妖精和小鬼，由于是飞兵，所以可以在第一回合冲到你面前，尔后围着你的半身人打，这就完全不一样了。但好在这2种兵都血少防低，只要英雄不死损失都不会很大，所以如果你非要一开始就打这些家伙的话最好给英雄加点防（晚学一点3级魔法没关系）。记得还是要排分散队型否则你会很郁闷，密集阵型中的半身人永远都不能射击。第一回合开始所有矮人部队靠向半身人，英雄放精准，半身人射击，魔法师招骷髅。从第二回合开始，英雄不停丢减速，半身人先等待后射击，可以2个回合打一下，一定要保证半身人边上有矮人否则他会是攻击对象。如果英雄不会减速，那就看看附近有没有铁匠铺之类的建筑可以买到2个粘结剂的。钱多的话自己也可以建一个，顺便买IMMORTAL（当然这可能性不大，除非你要打金矿，否则初期用这么多钱去打一个木矿是不值得的）

    3.一级远程兵/近远结合

    这个应该说不算真正的麻烦，因为守序在对付多数1级远程兵时，都可以用矮人站最前的密集阵型，半身人精准以后在敌人的尸体上招骷髅加模糊来抗。如果敌人的远程兵并不射击而是向前走，那自然不用客气射死后招骷髅和他拼命了。唯一麻烦的是半人马，这家伙走得很快，所以遇到半人马的时候记得主力矮人向前走或者英雄先不用精准用减速。
    敌人如果是远近结合，那只要记得用半身人狠狠打近战兵就好，不要用魔法师去放毒，那没什么意思。魔法师最大的价值在招骷髅上去拼命。

    关于经济，我感觉守序初期可以抢到的宝库有碉堡、矮人矿坑、废墟、隐匿处和神秘花园。碉堡里面的枪兵和弓箭手是守序比较擅长对付的家伙，用魔法师招骷髅+模糊（魔法师自己也会）可以让弓箭手向前移动，用半身人可以消灭枪兵。另外几种都是一级兵，废墟里的ORC怕骷髅，隐匿处里的盗贼数量不是很多。而神秘花园里的妖精并不很多，丛林怪物走得很慢。我不推荐打小鬼窖藏和墓地，前者是因为钱少而小鬼有可能打掉你的英雄和部分半身人，后者是你因为即使把箭射完可能只死了60个僵尸还有近100你的矮人是打不完的。

    再说中局，守序的中局（我的定义）就是有一些但不是很多的灯神（4-8个）。其实大家都很清楚就是灯神的减速+和平歌，但在遇到有些敌人时还是会有一些麻烦。

    1.石象鬼、幽灵
    如果这种部队守卫着金矿那是十分棘手的，在初期这些部队不可能打掉。而守序刚造好祈愿祭坛的时候经济最窘困，必须立即设法抢下金矿才能缓解。但这些部队即使被减速也无法在2个回合内消灭。所以唯一的办法就是用镜象把他们引开。注意这时如果你已经有地方买粘结剂是最好不过，但没有的话千万别去设法造了，因为这时每天750金的任务就是把一个550的灯神招募出来。
    站位是开放阵型，灯神要站在247位，其中有一队要是2个。半身人6号位，第一回合用减速，第二回合开始灯神开始做镜象，注意到1个灯神正好可以做一个敌人的镜象，注意下镜象的走位，最好往左上飞，幸运的是你的镜象是没有被减速的，所以往左上走可以走很远，然后2个灯神做自己的镜象，往右边飞，这样可以吸引敌人2支部队，剩下2只就只能硬拼了。一般英雄这时可以挡几下，然后矮人可以拼一下，可以考虑不带魔法师，因为这里他们的用处不如半身人，在2级兵面前威力很小而且很难把大量的魔法师招出来。剩下的那队灯神如果只有1个就放士气高涨！+25%的攻击力是很重要的，如果有几个就用冰剑吧。这样打下来可能有损失，只要灯神的主力半身人基本保全就好。这里重要的一点是一定要有一队2个灯神，因为一个灯神是做不出自己的镜象的。
    （如果都用敌人来做镜象的话，2次镜象会重合在一起，会在一个回合里被敌人一支部队打掉，就不能起到牵制敌人2支部队的作用。做自己的镜象是因为灯神是这个战场上机动力唯一能超过减速后敌人的部队，如果你做矮人/魔法师的话，敌人可以在打掉你的镜象以后打到你其他部队，这是他就不理睬镜象了。）

    2.各种元素
    说是各种元素，其实最讨厌的还是空气元素和水元素，元素令人痛苦的地方在于他们不吃和平歌。而水元素是强力魔法师、空气元素走得特别快。
    对于土元素，没什么好说的，减速+弓箭+镜象了。如果你的半身人不够多的话，考虑下灯神2个一组减速后做土元素的镜象，土元素有1/2的抗魔，所以减速容易不成功，还是镜象比较实惠一些毕竟这种东西本来就很慢。英雄在战斗中如果有镜象能力最好don't stop.
    对于空气元素，需要有一定数量的灯神，2个一队，一队做空气元素的镜象另一队做灯神的镜象，其他打法类似于石象鬼和幽灵。优点是风元素防御很高，一下还能打不死所以可以吸引3队。缺点也是风元素防御很高通常半身人打不死几个，要英雄和其他灯神不停地放冰箭。
    对于火元素，他和弩车一样属于不愿意前进又不吃遗忘的恶心弓箭手。我一般的做法是用密集阵型英雄灯神魔法师站成一列（3，4，7位）灯神镜象火元素站在最前面，魔法师给火元素加模糊，随后给敌人的火元素放诅咒意义不大一般我就直接打拳。英雄丢冰箭或者一起放镜象。由于火元素是火属性的，对火元素的攻击有抗性所以可以顶很长时间，效果比骷髅要好很多。这样给了英雄和灯神在后面杀伤的空间。可惜镜像的火元素不吃精准，不然就直接用他打了。要求你的灯神数量足够多而且英雄有一定能力。当然如果你的英雄防御够高的话，到道具店里去买个抗火的瓶子吃下去然后叫魔法师用模糊可以抵挡很长时间的。
    水元素类似于火元素，区别是只能带2支部队，英雄和灯神，这样敌人也只有2支部队，否则3支部队的话你无法防止敌人的水元素前进后拉开角度打你。英雄要放减速，灯神做水元素的镜象挡在最前面。这样敌人的水元素会先对你放疲劳然后向前移动，所以需要你的英雄和灯神一起做镜象。记住英雄和灯神在镜象和敌方水元素打起来要随时形成3点一线。实在不行可以做一下灯神的镜象挡一下然后让水元素镜象走到位置。这战术需要大量的灯神，可以说中期一般是没什么机会打水元素的。

    3.魔法部队
    魔法师可以用和平歌解决，就是他招魂的骷髅比较烦，记得减速，先打魔法师再打骷髅。
    邪眼也算半个魔法师，用邪眼镜象+和平歌可以搞得他很郁闷。
    灯神的打法可以参照东方卷轴中守序原版战役第一关的说明，矮人在最前面，1/3以上的灯神。

    中期的守序几乎可以抢下所有宝库，除了木乃伊的宝库由于攻击力的问题需要稍微等一阵外，只要英雄会镜象100个半身人、10+个魔法师和4个灯神就可以去抢狮鹫巢穴，方法就是减速+射箭+放毒+和平歌。墓园中的吸血鬼很多，一时是打不掉的，也抢不到。（总体而言守序比较怕亡灵)。
    在4级兵的选择上我感情上倾向于泰坦，但实际上我不得不承认傀儡龙更有优势。地图移动速度快而且前提建筑有用得多。尤其在面对黑龙时，虽然泰坦有CHAOS WARD实战效果反而不如傀儡龙。在和灯神的配合上更是镜象傀儡龙效果更明显。

    我想和大家探讨的问题是，如果一时没学到遗忘，怎么对付2级或3级远程部队？我一般的做法仍然是招骷髅+模糊，但由于对方是高级兵种，招出来的骷髅常常一下子就全部死光了。还有就是在守序擅长对付高级慢速近战兵如蛇妖、九头蛇。我曾经发现只需要1/4的灯神就可以搞死蛇妖，有谁测试过知道搞定这些兵种的最小数量灯神是多少？另外的一点是，大家都是在有多少灯神以后，放弃半身人和魔法师的？我一般是12个。

    DarkRain.cn注：本文的最大价值是在开局条件不理想的情况下如何作战及发展，非常具有指导意义。原文中的名词有很多是英文，有人反映看起来累，我都给改成中文了。


自然城的初期打法
作者：antidevil

    和之前写的ORDER攻略目的为对应，主要讲在面对不利局面下如何开局。我个人是非常喜欢NATURE族的，因为以前和人家打对战，用ORDER赢了人家就说：“ORDER强呀”，搞得我不爽，后来就开发了一套比较成型的NATURE战术。这套战术由于是为了对战，所以排除SAVE/LOAD，这样就有一个宗旨“留有余量”，而不是在S/L中寻找10%的运气来。同时我尽可能强调一般性，毕竟对战地图很多都很穷（BORING MOUNTAIN），不可能2天就出吸血鬼或是5天出仙女龙这样的。如今时间长了很多我现在记得不算很清楚，希望高手指正。

    NATURE一定要以魔法英雄为主，即使开局是个弓箭英雄也要再招魔法英雄，就象DEATH和ORDER一样。
    开始就要把魔法塔升级到3级，因为这关联到整个战略部署。如果有水元素，那就全力升级英雄吧，有风元素也可以以英雄为主。要是3级魔法太垃圾，那就升级到2级NATURE，其他都拿钱准备出兵。

开局阶段

    NATURE的开局是几个种族里最复杂的。因为一级兵没有远程，而1、2级魔法也没有对战术能形成极大改观的（如SLOW），所以初期的重点在于：用开始的1级兵解决尽可能多的1级兵，让英雄升到expert nature（3级nature魔法）。这道理很简单，3级魔法有招元素，尤其是水元素，即使没有，其他3种元素也能立即形成战斗力对战斗有很大改观。

    一、面对近战兵
    NATURE的初期主力是狼。（别迷信妖精的H/R战术，一则对战不允许二则敌人一开始士气高涨是常有的事）狼的数量比较少，一开始英雄带城里有加上招出来的也就45条。但是要知道狼的攻击很高，45条狼一下子就能打掉大半队敌人（如果一共有4队的话）。所以只要让敌人部队之间有一定间距，一个一个重创之就可以以比较小的代价消灭敌人。

    1、慢速近战兵（矮人，骷髅、丛林妖怪等）
    这些是最容易的对付的。首先把狼分成3队（1、1和其他）英雄一队，妖精3队（也是1、1和其他），1个的妖精放在1、3号位。英雄最好是魔法英雄，否则就去招一个（NATURE的魔法英雄强过弓箭太多）。
    1个妖精的作用是拖延敌人，第一回合英雄能用加速的话给自己加速，不然招点丛林妖精给主力狼队用幸运。在敌人等待或行动之后，把妖精移动到敌人身边甚至身后（若已经移动过），可以拖延他前进一个回合，甚至在某些地形上拖延2个回合（挡住其他队伍的路）。无论敌人行动次序，除非他一下就都冲上来（一般不会这样的），妖精都是等待以后再往上飞，尽量能飞2下引诱敌人左边的部队，最好一左一右把敌人2支部队尽量引开（和另2支拉开距离）。然后英雄可以做一下肉盾（一点COMBAT就是2下），1队1个的狼可以再做一下，后面的狼和妖精合力解决一队后，敌人行动很可能落后，不管如何，狼的速度是7，会在几乎所有一级兵之前行动，继续灭掉另一队。这时敌人后面的2队移动过来了。重复刚才的办法，招一些丛林或狼骗反击/做肉盾，唯一要记得的是英雄一定要严加保护。
    这个做法的重点是拉开敌人队伍之间的距离，分而歼之。如果你不会招狼/妖精，可以用招妖精去牵制敌人，再不会就没辄了，有什么用什么硬拼吧。

    （再说下妖精的H/R。本来我觉得费时而且难操作，因为妖精加英雄有2队，要一次跳过2个骷髅的距离。Darkrain老大说可以不带英雄上阵速度会快很多。确实如此，也就2、3分钟时间，是可以接受的。以前也这么打过，但总舍不得那么一点经验，其实要是骷髅守木矿的话，这么打确实要比硬拼来得值，1级兵的经验并不算多。）

    2、快速近战兵（IMP，SPIRIT及混合部队）
    初期任何种族都不善于对付这样的部队，遇到几乎必然损失不小，建议尽量先解决慢速近战兵再解决快速近战兵。指导思想和上面一样，尽量让敌人部队冲到你面前有个时间差（其实每个种族都一样），一支一支解决。
    如果是全飞兵，配置和上文类似，需要考虑的一点是敌人的速度都是6，和妖精一样，所以绝对不可以WAIT，1、3位的妖精一能行动马上就要飞过去打敌人一下。这样可以让2个队的敌人滞后一个回合。将狼和英雄集结到己方中间靠右，你会发现第二回合只有敌人的第4队打得到你，自然努力消灭之。英雄第一回合招丛林精灵，不会就给主力妖精加速，再不会的话招妖精上去牵制也可以。第二回合开始会招妖精的话一定要再招出来立即冲上去吸引2、3队敌人中一个。因为你接下来将面临2队敌人的进攻，第一回合有招丛林妖精的话给狼放幸运，2号位的狼上去骗一下反击后就尽可能重创一队敌人。狼的行动次序在飞兵前，所以往后一回合还是你先动，这时你骗反击的人很可能死光了，就别管那么多了主动上去咬吧（所以要用幸运）。事实上实际战斗中可能会遇到地形阻碍等等，但原则不变，就是利用单个妖精的牵制尽量让敌人一队一队冲上来。一拥而上是肯定没希望的。
    如果是快慢结合就好办点，可以用妖精牵制一队快一队慢。如果敌人的步阵是把飞兵放在3、4位即可以直接攻击到你的话，就先牵制一快速部队，另一个妖精后退一点（他就打不到你了），然后全力灭掉冲上来的快速部队，保护好单个妖精，往后还可以再让他去牵制一队慢的或者替你挡一下敌人一个整队的进攻。我的经验是一般会损失6个狼8个妖精左右的实力，也就是各让对方打一下。

    （二）面对远程兵
    远程兵（包括近远混合）
    原则上来说，纯1级远程部队都可以用密集阵型，1、3、5位置上放单个兵来勾引他一步一步向前走的方法来解决，但有时你没有远程部队的时候他会不前进硬打你，所以一般而言，还是推荐前面3个位置放妖精，英雄最后。第一回合招丛林妖精挡在前面，给狼加幸运，等敌人慢慢挪上来以后单个妖精上去牵制主力部队上去强袭。但一定要记得，万一敌人“感觉”自己比较强，第一回合就对你射击而不是等待的话，立即给狼加速往上冲，再等是没意义的。这种情况往往出现在双方实力差距太大的时候。
    如果是远近混合的话比较麻烦，我观察发现一旦远近结合的话，除非远程兵是短程射击的半兽人或半人马，否则远程兵很难会往前移动。我推荐在初期不要去对付这样的组合，等老虎出来或者英雄会招元素会比较好办。如果一定要拼命，建议带上全部的部队，总数控制在5队（远程兵只有1队而近战兵有4队）。如果敌人不是半兽人或半人马的话，由于这种组合往往是同族，和弓箭手一起的是侍卫，和侏儒一起的是矮人都是慢速兵种，可以利用妖精的速度优势来压制远程部队。具体方法是用密集阵型。前3个都用狼，2队单个的（因为狼可以在侏儒前面行动）。开始后立即把单个狼换到最前面去。这样不管侏儒还是弓箭手是射击还是移动，英雄都给妖精加速。等敌人的近程向前移动后，下个回合妖精一下冲到远程后面去压制他，同时给狼加速。敌人的近程只有一队会回救，其他往往会继续前进。狼加速后移动还是很快的，让英雄和招出来的杂兵去吸引3队慢速兵（由于经验上限的影响，往往不会很多）。狼和妖精尽快解决远程兵，之后就好办了。

    和ORDER完全不同的是，NATURE的开局阶段基本依靠的是2个1级兵，2级兵基本没多大作用（无论精灵还是老虎都不如会招骷髅的法师），所以积攒金钱是最重要的。英雄要尽快升级到3级NATURE魔法学会招元素，虽说其他元素威力远不及水元素，但只要舍得魔法值，风元素和土元素还是具备相当的战斗力的，火元素可以非常好地配合水元素，如果英雄会流沙的话火元素也是值得考虑的对象。当然，要是4种元素3级魔法一个都没出……自求多福吧。
    NATURE初期可以抢矿坑和隐秘处。神秘花园和小鬼窖藏可能会让你损失不小，但要是能让你出高级兵也是值得的。打NATURE和ORDER不一样，千万别怕损失，开始时一边打一边补充就是了。反正有水元素，螳螂，仙女龙以后就不需要这些部队配合。

中期

    中期战斗分2种情况：会招水元素魔法却没有生物门，不会招水元素刚有生物门。要记住即使全军出动，NATURE的英雄会招水元素的话战斗力在这个时期在整个部队里占75%以上，所以基本上英雄死=战斗结束。（其实若魔法出现概率平均，2个城出招水的概率也是1-（6/7）*（5/7）*（6/7）*（5/7）=62.5%，再加上野外学得魔法或得到卷轴，概率是相当高的）

    （一）会招水元素
    这当然是最开心的了，水元素的疲劳和流沙加上冰箭可以对付大多数地面部队，在恶劣地形（沼泽或沙漠）上甚至可以对付慢速3级兵。一般情况下都是英雄带一点点妖精上阵

    1、地面近战兵
    慢速近战兵：疲劳，流沙，冰箭就解决了
    快速近战兵：如果敌人只有一种兵，那就英雄一个人上。会地图辨识就简单了，用水元素放一堆流沙，英雄放地图辨识，可能的话再给个加速可以带着敌人慢慢挪动，等水元素魔法值用完了再招一次又满了。如果不会地图辨识的话，由于敌人只有一队，可以考虑招些妖精，等水元素放完几个流沙后，让妖精带敌人走。有时敌人会不理睬妖精，那就走到他打得到却是流沙的地方。等他打死妖精后陷入流沙，再招一队妖精就又可以带他走了。这种方法在对付游牧民，白虎等兵种的时候效果非常明显。
    不能被疲劳的地面近战兵其实就是骷髅，金人，僵尸，土元素和木乃伊。都是速度本来就很慢的家伙，即使不用疲劳也同样可以对付。（还有什么我没考虑到的请各位补充）

    2、飞行近战兵
    其实基本上是没办法对付的，只有少数的几种可以解决。
    幽灵：一句话，硬拼！幽灵的血很少，建议带4支部队去，其中3支是单个妖精，另一个是英雄，用密集阵型全部站在后排。开始后英雄招水元素开打，妖精上去挡一下攻击。第二回合英雄招丛林妖精放幸运，这时一般英雄会COMBAT也不会很高吧，所以加幸运还是必须的。第三回合开始补充水元素。根据我的经验，如果英雄有能力一次招5个水元素，就有胜利的机会，否则基本无望。这主要是因为幽灵的战斗力强在物理防御上，他的攻很低血也少，水元素正是他的克星，但一次招水元素太少的话，出来就被打死了。注意要是你的英雄一点COMBAT也不会就不要去打了，英雄必死无疑，死后水元素得不到补充，你就是所有部队一起上损失也很大。

    3、远程兵
    1级远程兵都可以用比较低廉的方法解决了，就是水元素+丛林妖精。面对2级远程兵的时候，可以让主英雄带几个妖精上用密集阵型，招出水元素以后，让妖精挡在前面封死路。敌人多数会射击，那就能挺几个回合挺几个回合，直到英雄受到攻击逃回家。也有种可能是敌人傻乎乎向前走，那就不客气，疲劳流沙（别太急着用冰箭）后用冰箭一个一个灭掉。
    在遇到魔法师的时候就跑吧。一般来说你是没有任何机会在不死英雄的情况下打赢的，除非你的魔法防御很高了。以前有人说可以打GENIE，我自己实验过多次是打不过的，你没有办法可以不让GENIE做他自己的镜象，更严重的是，等他魔法值用完自己冲上来你还是挡不住。英雄被几十个GENIE打一下就不行了

    有个打魔法师的方法比较冒险.英雄带6个妖精上，排密集阵型英雄最后。上来对自己放ANTIMAGIC防止魔法师放毒然后第二排妖精向前走一点省得水元素招出来位置不对.随后魔法师看到打不到你的英雄会向前走成功!你招水元素去灭他们就得了水元素要在妖精后面不然被魔法师打一回合就死了.这样首先不能出现魔法师士气高涨的情况其次有时魔法师会BS你一下不往前走直接打你的妖精.遇到特殊情况要立即逃命英雄被杀就完完了

    （二）不会水元素但是刚有生物门
    如果是这样的情况的话，此时会遇到非常严重的经济危机，所以推荐只招2个水元素。当然，既然不会招水元素那就肯定学过几级COMBAT了。这时的主力将是你能用魔法招出来的另一种元素，最好是火元素。如果什么都不会……我也不知道怎么办了，花钱从生物门招募水元素吧。不管怎么样这时的策略就所不同，因为水元素不能死了……不能硬拼，还有魔法放完不能补充。水元素如东方卷轴上所说，一定要分开使用，在战斗前加入阵营否则极其影响行军速度。这时用水元素有个区别就是，所有部队要一起上。
    其实这里我要说一点，生物门里未必一定要招水元素。如果你发现不得不面对一群石象鬼守护金矿的话，招空气元素效果会好很多。换句话说，面对飞行部队的时候水元素的作用只有减速而已，硬拼的话带一个就够了。我常常在生物门里招一个半羊人和一个水元素，然后就靠这些加上开始积攒的部队继续推进直到可以招螳螂或仙女龙为止。

    1、地面近战兵。
    请参照会水元素魔法的战斗方法，两者大同小异，记得保护好水元素就是了。

    2、飞行近战兵。
    可以打鸟身女巫，减速，算准位置让他跳到面前，然后后让狼上去狠狠咬。水元素放虚弱，流沙放的位置在英雄或其他鸟身女巫可能会打的人前面，可以让他打你的时候跳进去再减些攻击。鸟身女巫很奇怪，他常常不会攻击正在攻击他的敌人，你可以利用这一点让英雄去吸引他的火力而让狼攻击。
    还可以打幽灵，方法和会招水元素差不多，但会损失不少水元素。所以如果不是能得到大笔回报的话最好慎重，打仗并不仅仅是为了经验。

    3、远程兵。
    这时你的战斗力在面对远程兵的时候没有多大加强。所以还是以1级远程兵为主要欺负对象，要是遇到2级远程兵的话，不想损失就避免战斗，如果非打不可就把水元素分2队，不停地使用疲劳和虚弱。其他部队就上去拼吧，记得把2级的白虎/大精灵和3级的独角兽招出来一起上。

    另一种思路是招毒蜂草，我尝试过，但这种植物机动力实在太差了！简直寸步难移。而且他不象水元素1个就能起到作用，效果非常不好。

    当经验积攒到一定程度的时候，可以招募螳螂了，但我更主张建造仙女龙营地优先。仙女龙也是属于1个就能发挥作用的兵种，而单个螳螂在对付2级兵的时候还是很容易死的。

    中期可以考虑去抢劫除墓园以外全部的宝库，利用水元素的疲劳可以腾出很多时间来让你的英雄招兵。推荐元素优先，不管哪种元素威力都比2级兵大得多。中期常常是抢下2个宝库局面就大大改观，让你有机会去建造些大型建筑或是征出很多兵。

    总结来说，虽然不会招水元素对NATURE打击很大，但考虑到野外或副城还有学习的机会，NATURE的速度优势还是值得一用的。NATURE的瓶颈在于金钱严重短缺，但他在速度尤其是地图机动力方面有相当明显的优势，补充了这一缺陷。此外NATURE可以用最快的速度出4级兵种（螳螂），而主力4级兵种仙女龙更是威力无穷。很多地图到了第四个星期就会有仙女龙攒出来，虽然2、3级兵往往在前面都拼掉了或者根本没钱招募，但此时加上螳螂一起冲向敌人基地万难抵挡。而在一般地图中，这时的DEATH仅仅刚出GM级招魂不久ORDER的机器龙也就刚出，此时展开决战对NATURE十分有利。

    补充一点NATURE招第二个英雄的时机很有讲究.一般我喜欢招个CHAOS英雄放魔力闪光但这条件就非常苛刻了。不然的话我就直接双DRUID,一个用辅助一个召唤部队。

    DarkRain.cn评注：

    1、其实自然城许多战术都要依托妖精的。对战中不用，一是时间问题，二是士气问题。但一切都要看实际情况的，如果耗时不长，妖精的h/r在某些时候可以考虑一用。比较典型的是打骷髅，妖精行动顺序定为：等待-->攻击-->飞行-->飞行-->等待-->攻击-->……，连飞两次的好处是不用担心被追上，省去了用右键看敌人行动范围的步骤，节省现实时间。60妖精打170骷髅，实际测试耗时不到2分钟，比大部分战斗都快。打矮人、侍从之类的慢速一级兵时，如果妖精一击就可以干掉敌人1/10，则不必考虑士气问题。当然，如果之前没有派英雄来召唤消耗兵力的话，这个比例基本不可能达到，但一般可以达到1/20～1/15（妖精60几个的时候），两击就可以解决士气问题，某些情况下值得冒险。

    2、可以看出召水对自然城是非常重要的，所以开始要先造3级魔法塔，看有没有召水来决定发展策略。如果有召水，英雄可以考虑宝箱转经验直冲专家自然，甚至可以考虑强出铁匠铺。用召水可以对付绝大多数的地面部队，以及相当一部分的飞兵，如果打完仗之后回报丰富的话，可以把先期的投资收回来。

    3、单英雄召水打灯神，单机游戏比较容易实现，但对战就不太行了。因为召唤的位置是不完全确定的，许多时候召唤出来的水元素不能保护住英雄，英雄一下就会被冰箭打死。改良打法是英雄带单个妖精上，环状阵型，4、7号位，这样妖精可以保护住英雄。灯神开始有一组会先怯懦英雄，此时召水疲劳另一组灯神，第二回合英雄召妖精，上去打灯神，水继续疲劳。在召唤的妖精攻击灯神的情况下，灯神不会继续向前飞，会先振奋后镜像水元素。布几道流沙稍微阻拦一下镜像，然后英雄尽量召水，用冰箭杀灯神。只要注意保护英雄不死就可以，如果召水的数量可以达到一次5个，一仗下来消耗十几二十个灯神没问题。

    4、早期与低级兵的配合，确实是魔法英雄较好。但是中期以后，如果邻系没有好魔法的话，可以考虑培养射手。图书馆建一个就要2500，招英雄至少多花500（如果初始英雄就是射手的话，则多花2000），资金花费的差距非常明显。而且有召唤门的水元素之后，打地面兵练副英雄是比较简单的，射手培养可以考虑直冲箭术，攻击能力提升非常快，能够很快帮上主英雄的忙，战斗技能后面升不迟。当然，这对地图规模有一定要求，如果不适合，还是随便招个德鲁伊稍微起点辅助作用就好了。地图规模太小太大都不行，太小则没有足够时间培养副英雄，太大的话靠的是兵力与魔法，箭术和肉搏技能作用有限。这一点是我这个没有对战经验的人的纸上谈兵，姑妄言之，大家也姑妄听之好了，不必当作准则，有兴趣的人可以去实战中尝试一下。


Death战役首关流程
作者：水云

    没有什么苟刻的条件，前三个箱子平均有1000 exp也就够了。如果你想在这一关new一个比较理想的条件，那就让自然城出现召水/拳头/探路吧，对于本关是没有影响的，只是为下一关作打算。

D1，损3骨头攻下主城。
D2，捡箱子升级成鬼神使。
D3，打人马，招一野人英雄占木石矿。
D4，打游牧民窝，左走吃箱子，学会召唤小叉叉，打人马吃A+6
D5，逃回主城，其它兵走回来，副英雄打下第二座城。
D6，带1幽灵打疯老头，进地下向左边箱子前进。
D7，吃过箱子打墓地逃回主城，副英雄买不朽药水和移动药水送过来。
w2d1，6游牧，4幽灵，27僵尸，50骨头打下吸血鬼。
w2d2，单身打下魔法塔。
W2D3，绕路去喝魔法水，顺便打下游牧民。
W2D4，打下鸟巫和食人魔法师。
w2d5，打雷鸟。
w2d6，带5吸血打下32投石怪。
w2d7，打下自然城和金字塔。
w3d1，打下46独角兽开了地下哨站回地面。
w3d3，结束。

    几个关键处的说明：

    1.开始的箱子要经验值，矿留着没用，第一天换成钱用来招兵。两个城里只要造加攻防的，不造兵。要让敌人帮你把第二座城的铁匠铺盖起来。

    2.D3打人马时，几个骨头站前排，让人马走过来，召唤妖精缠住一组，幽灵、骨头、僵尸围攻落单的，战斗损失很小。

    3.打魔法塔前要先喝不朽药水，一开始就召唤小叉叉来挡在身前以免挨拳头。中毒死里回生后，魔法师一般不会再对你下毒了，通常这时会复活骷髅（因为毒死了很多小叉叉），不用管它，一直等待，等到魔法师被吸光mana，也等到小叉叉完全死光，再重新召唤小叉叉上去打。

    4.打投石怪用分散队型，战前先用不朽药水。第一回合吸血鬼先wait，半死人对投石怪用curse。第二回合吸血鬼缠住一组，半死人用不朽药水，循环这一步，抽空再把另一组投石怪也curse了，安全以后就开始召唤小叉叉，但不要太快上去缠投石怪，那样吸血鬼会被两组围殴，自己量力吧。

    5.金字塔的打法：仅用吸血鬼+召唤地狱犬就可以打下150个的，带上5组小妖精让木乃伊分成四组，先wait，召犬，然后把妖精飞到后面去当炮灰，第二/三回合再召犬（这时木乃伊相当于第一回合），wait，然后上前咬，第四回合再召再咬。召三次犬咬一次，召四次犬咬一次，而且是双咬（控制得好应该是三咬），这时才轮到木乃伊出手，肯定能打过，而且还有几只吸血帮忙（第二关开始时只有1只，照打可矣），20木乃伊一击打不死1吸血。

    6.用召犬照样可以打下独角，但须有鬼魂和水元素（建召唤门或魔法有）助阵。阵形可以用3水2鬼或1水4鬼，总之起码让两组独角中了疲劳+老化才会比较安全。一组交给吸血去单挑，另一组可以用流沙拦一拦，等地狱犬形成数量就可以出手了。这个办法听起来好象挺复杂，不过打起来很很快就能解决。
    还有一个听起来比较简单，但打起来却相当烦的：用流沙+地形认知，让独角兽永远没有出手的机会，你可以用N种方法来灭它，比如召几只小妖精出来h/r，但无论是那一种方法，结果都是非常浪费现实时间，这个办法同样可以用来打金字塔。


战役单关最高分
作者：DarkRain.cn

    此最高分出现在原版死亡战役的最后一关，如果打的好可以超过1700。

    按原先攻略里说，开始回到地面世界后，向左走过任务门背后的单向传送门，去攻打左边的中立城堡；然后救英雄，过地面上方中间的单向传送门到地下，攻打地下的敌人城堡，还要注意不能让敌人主英雄逃跑或投降；杀掉敌人主英雄后，地面右边敌人城堡前的障碍物会消失，此时再返回地面，攻打敌人城堡过关。
    其实这里面有错。过第一道单向传送门之后，地面右边敌人城堡前的障碍物已经消失了，已可攻打。当然，如果你让主英雄去过单向传送门，就没办法走回头路去端敌人城堡，正确的选择是过任务门（需要主英雄带着，或是队伍中有黄金袋，右上金矿前可以捡到。捡黄金袋太浪费时间，一般顾不上）后，不要继续往前走，分个兵过单向门即可，然后主力回身攻打敌人城堡。攻城后招个英雄，配合少数吸血鬼过单向门去打左边中立城堡，然后主英雄用回城术到左边城堡，直接完成任务（救英雄）后再用回城术返回右边城堡，过城堡左边的双向传送门去灭敌人主力。

    要上1700，有几个条件必须满足：

    1、英雄有宗师探路、回城魔法，否则肯定赶不及在一周内过关。
    2、第二天捡到的蓝箱子必须是手套。
    3、第一天顺路的背包里，或者是第三天敌人城堡前的药水包中至少捡到一瓶耐力药水。
    4、英雄必须有宗师招魂，为了第一天打地狱犬时造吸血鬼，一方面提高移动力，另一方面可以让副英雄带着去攻打左边中立城堡，避免浪费主力移动力。
    5、英雄必须有一定等级的战斗技能，有相当防御力，另外有传送+遗忘，用来打敌人主力用。召唤恶魔也很强，但是如果学了召唤恶魔，技能点肯定不足，不够升宗师探路+专家守序的。

    1、4、5是英雄自身的能力。我打到这一关的时候，英雄技能情况主要是：大师战斗+专家死亡+宗师招魂+专家守序+高级自然+宗师探路，职业为忍者（死亡+侦察）。按理说，技能在精不在多，这个英雄从某种角度来看是个半垃圾英雄，不过在本战役中不仅已经足够用，而且还比较好用。

    2、3是需要Restrat出来的条件，其实不算苛刻。

进程：

    D1：打地狱犬造吸血鬼，直接沿路向下走（路上打骷髅）。
    D2：转向左上，捡蓝箱子得手套，过传送门到地面，向左走。
    D3：碰水槽，过任务门（只要过一步就行了，不要多走），分2吸血鬼过单向门触发事件，炸掉几处障碍物。主力回身向右，捡药水包，喝耐力药水加移动力，攻打敌人城堡。攻城后招募一个英雄，向左走。
    D4：2吸血鬼打败守路骷髅，副英雄跟上，带吸血鬼灭掉城堡里的守军（守军如果是地狱犬带队，很好打。如果是幽灵带队，麻烦一点，必须要有英雄施展诅咒魔法来辅助，对战斗的指挥水平也有要求）。主力用回城术到左边救英雄，救完后再返回右边城堡，向城堡左边双向传送门前进。
    D5：到地下后，向下走去完成任务。半路上可以把吸血鬼分出来，只带恶魔，这样可以多走4步。
    D6：完成任务后，回城术返回地面右边城堡，再走双向门下地。
    D7：攻打敌人城堡过关。

    最终得分是1710分，比我预想的少了30分左右，不知道是损在战斗分还是城堡分上面。有可能是最后一战获胜后，系统判定击败敌人英雄就算过关，还没来得及把这个城堡算进去。

    SSZ评注：各位喜欢BT的可以照这个试试。另外《阴云密布》中，最后一个战役的第二关，也可以很轻松地打上1500分左右。没有任何难度。


野人战役首关的打法
作者：水云

    一般来说，最高难度下野人战役首关比其他战役要难，但也不是高不可攀。开局条件不是很重要，关键还是打好每一场仗，当你可以把损失减到最低，你就不会为死去的部队而伤心。

    第一场仗面临的应该是守人马窝的人马，正常发展应该是在第三天打，我开局的时候唯一的条件就是让这里的人马数量尽可能地少，我打的是45个，不过实际上没必要这么少。基本的原则就是让英雄去挨3*15人马的前三箭，最后一箭（忽视距离，伤害力一般是四倍，英雄受不了）由单个的人马挨，如果野人马数量少，可以由单个人马来分担前三箭的一部分，不死就行了，还可以主动射击诱使野人马反射，让三队野人马的箭支数量产生差额，这样它们冲上来的时间也不同，有利于实现分歼。这时找个适当时机把疯老头放出来就是了。应该采用紧缩阵形，用半人马把疯老头包在中间，等到合适的时机放出来。

    SSZ评注：这是一个经典的问题。野人战役（单关其实也一样）开局的困难，关键就在疯老头身上。不听话的乱冲，使它很容易成炮灰，积攒不起来。然而初级兵种中，它还算指数可以的，还打两下，用好了其实可以当主力。水云这里用的几个方法在对付电脑的时候很有针对性，很多情况都适用。第一是包围疯老头，等敌人薄弱、或者自己骗了反击以后再放出来。这样避免了疯老头硬碰敌人最强盛的部队，和在半路上被消耗。第二是肉盾，肉盾在骗反击、阻挡敌方视线、保护远程兵种，和远程兵种对射当盾牌的时候都很有用，要么用皮粗肉厚、但不是主力的兵（英雄）当，要么用单个垃圾兵。第三是分歼：常用的手法包括骗远程兵种弹药、用高机动兵来回调动，或者用魔法来回调动。


再论原版野蛮人战役开局
作者：fireway

    RESTART了几次，出现以下局面：
    英雄旁边的箱子吃过后涨1000经验，骷髅（在开始半人马的右上那格）出健康指环。符合我给自己定的目标。
    不过守的人马有55个，太多了点，50个以下就理想了。
    不过难得再重新开局了，就这样打吧。
    喝水拿狂暴和人马，在D2用48狂暴23人马打55人马，用4个人马2个狂暴的代价打下。
    吃箱子升战斗，拿指环再喝口水，留下一个狂暴，直奔人马营。
    D4召9人马，共47狂暴28人马。发现守人马营的野人马是44个，打下后肯定可以增加人马。但英雄喝过的水就没用了，决定不打，在这里存一个进度，如果后面实在打不过再读档。
    D6冲到海边，用47狂暴28人马打下128盗贼和128海盗，死了3个人马，英雄只有3点血，险……
    此时可以回头打骷髅兵，升专家战斗，而且另一个骷髅上捡到的是精灵甲，足足可以加20的防。不过为了速度，决定不打，直接打矿石车。在这里存了一个档，如果打不过可以先打骷髅兵，再接后面跟来的部队，铁定可以打下矿石车。
    D7吃钱下海，后面的4狂暴差一步上不了船，晕……
    W2D1上岸。
    W2D2用47狂暴25人马打下敌3级英雄、200海盗和100盗贼。英雄还有1点血，呼……。真有点RPWT，不过其实我还有13人马，英雄少挨一下也能过的。
    当天访问帐篷，吃过矿车后回船。
    W2D3回到海边。

    我想这已经是很快的进度了吧？

打法：

一、人马
    其实可以RESTART到少于50人马，狂暴就不损了。
    打法和我前面讲的差不多。紧密阵型。
    第一排：1人马、英雄、1人马
    第二排：19人马、48狂暴、1人马
    第三排：1人马
    除第三排的人马外每组人马都挨了一轻箭，不过一只也没死，其它5只轻箭英雄接了。
    两个还有1-2点血的人马主动射击，接了两发重箭。还有一发英雄咬牙受了。
    利用人马箭数的差别使人马一组组的向我军冲锋，一一被狂暴打死，最后一组人马没有合适的人盾骗反击，不得不死了两个狂暴。 二、海边盗贼和海盗
    阵型相同，要点是用一只单个人马把一组盗贼和两组海盗引开，尽量用英雄做肉盾，尽量少损兵。
    早知后续的4狂暴上不了船就不召了，多一狂暴好打不少。
    二组盗贼被攻后一组还有1个，另一组2个，还得让人马来解决，麻烦。

三、打矿石车
    阵型照旧，也要用一只人马做诱饵，不过这一战不用惜兵，所以相对好打。

    DarkRain.cn注：此打法是给有兴趣挑战极限的少数玩家作参考的，不面对大部分玩家。


原版守序战役的简便打法
作者：Mia

    伊梅丽娅技能选侦察+战斗+生命+守序+混乱，可以用潜行升级，第二关开始就能单打独斗了，要是没把握用偷到的宝物，魔法，药水协助便足够。

    第一关有两座守序城+两野外大学+两驯兽师小屋。最多可学到侦察3项，守序专家(2魔力+2祭坛)，生命高级(不到也无所谓，往后有的是守序。生命城可学)，混乱高级。基础战斗。另有1图书馆(升混乱较好)。14项升级技能优先侦察。剩下给混乱(务必努力到高级，光"厄运"就很好用的)。

    第一关主要学技能，以后全部战斗都可1人完成，打不过就别打，光潜行经验值就很多了(无关难度1/4，最高难度打掉才1/3，越难越好打！)，其实到后面根本没有打不过的问题，超强了。

    这样打较容易也快(宗师探路可用，用潜行不用造兵，省事呢。

    索里尔没好的捷径走，死打了，不过一旦伊梅里娅加入，他也没大用了，培养到能过自己的关就行了。

    侦察实在是个好东西，原版自然战役也可利用此方法，只是初始条件不如守序好。

    以上是我的打法。个人觉得比一般网上普遍推广的攻略更方便。

    DarkRain.cn注：其实这个打法zyd很早以前就提到过，两个英雄都学到了宗师潜行，完成8关的战役仅用时4小时左右。当然，这是针对于原版程序，2.0以后的版本限制了潜行偷经验的比例，想打这么快已经不可能了，但仍不失为大量节省现实时间的好办法。


海盗女儿战役第一关的问题
作者：DarkRain.cn

    在游家论坛挖旧贴的时候，看到clikme在一年多以前曾经对此关的攻略有些疑问，因此专门写这篇文章来作解答。

    1、攻略是写给大部分玩家看的，因此不是非常紧凑。像是兜圈子去招海盗和盗贼的行动，就是针对城内守军由美杜莎带队的情况。如果在游戏开始时Restart，完全可以使城内守军由牛头怪来带队，这样攻城的难度就小了很多，至少海上的海盗和盗贼是不再需要去招了。

    2、开始岛上的行动。
    派盗贼去偷船长帽的时候，不要单派一个去，至少多跟1～2个用来进行传递，这样第2天主力就可以得到船长帽。
    第1天分1个海盗出来坐船，第2天移动到岛上方，登陆后解散，这样主力上船后就节省了许多移动力。
    英雄若先访问石碑后打硫磺矿，则访问石碑时不要带海盗，因为海盗地图移动力偏低。操作无误的话，大队人马第1天占完硫磺矿之后，几乎可以走到第2天海盗登陆点了。

    3、如果一定要招海盗，可以用些矿换钱，不需要兜圈子捡资源后再来。

    4、前期行动的紧凑程度，影响到达野人城堡的时间早晚。我打的时候，敌人英雄都还没有回城，偷城很容易。

    5、本关资源还算比较丰富，可以把黑龙和野人城的四级兵都造出来，总体战斗力是比较强的。如果有好魔法，可以考虑培养些副英雄来协助作战。如果是纯粹追求天数的打法，可以考虑Restart的时候让灯塔上方不远处的蓝箱子出现懒惰弓。

    中后期进程的变数就比较多了，主要是英雄培养有好几个方向可选，但似乎没有特别优秀的。一般战役我都会重玩，但这个战役却没有，就是因为一直想不好英雄的确切培养方向……


阴云密布第二个战役（wizard）最省现实时间的打法
作者：zyd

    champion难度

    第一关，出来先占掉旁边的两个矿，召个小偷英雄带着。派个小偷兵出去，到门口。牛头会加入，这个时候英雄带着城里的兵到和牛头会合，那个野兵的势力范围本来过不去，但是两边的兵能接触，英雄就能换到牛头那边 就过去了 出去以后打往左走，打中间那城，（把牛头分成1，1，1，1，n，quick combat就可以了，自己打损失也不小，而且关系不大），然后召了兵接着打地图左下，左中的城，再返回经过中间打右上，上面的城，基本上打下一座城找了召了兵就走，一路quick combat就能打下所有城。然后小偷英雄分出来占矿骗经验，见到宝箱自己吃经验算了，很快就能到gm隐身。此同时召一个death knight到各个城转一圈（每个城1000exp）带上所有兵和主英雄一起扫荡了（这里注意，电脑一般造牛头，你也造牛头算了，三级兵造火怪，一个城造梦魇就可以了，我打的时候左上有一个取消射击惩罚的弓，小偷偷回来交给主hero，这时几百的orc和加了先攻的火怪是打仗主力，梦魇一般就施一次魔法就够了，反正很快就有六七十火怪，可以横扫，损失很小了。记着先攻魔法很重要，另外战术英雄优先升offence，另外就是主英雄升combat转成fireguard吧，这样升魔防也方便。Chaos魔法到master，暂时不要升sorcery和order（order已经有的两项先升了，没有的wizardry还是到第三关学比较划算）。吃完所有祭坛，学校，加强的，小偷也该挖到卷轴了（有的时候拜访了所有的像，出来了的图没有地点，就在那个地图正中间，画一下对角线交点，不行多试几次吧）

    第二关，出来确定城里魔法塔已经有confusion，最好还有魔力闪光，没有就restart。先占了附近三座矿（一个要打，单hero搞定），然后hit/run下面守传送门的独眼，雷鸟，先劈独眼，放个lighting就逃，与此同时分两个小偷兵捡钱。城里出了city hall就出个chaos法师hero，修训练场，这样这个hero就会二级chaos魔法了 ，带着他一起打下面的雷鸟。他使confusion就可以，注意两人位置，最好让独眼砸主hero，如果没把握一次搞定，不要杀完独眼，留一个，杀雷鸟吧，最多跑两次就能干掉，然后过传送门杀比蒙，也是一样打法，三次搞定。然后就去占chaos城吧，对方唯一有威胁的高级hero奈何不了已是fire guard、不怕火系魔法的你，嘿嘿 然后两个城每周都召chaos法师（可以召一个小偷），都学会confusion，然后一堆hero通过传送门去打野人城（两边各一个），就是不停confusion住独眼和没毒杀，慢慢劈，记得先在城里给主hero魔法加倍，而且开仗后用一次魔力闪光（其实如果是wizard职业，这时闪电只耗一点mp，不过综合还是fireguard吧，不然魔防半天不出来，这可是最后一个战役必备）没魔法就跑吧，不缺这点经验值。打下两个城，憋独眼，召个战术hero，后面就很简单了，记得给独眼加灵猫反射。还有自己城还是和另外那个城造兵一样吧（多半是没毒杀，火怪，hydra）没关系啦，不然兵带不下，反正很简单。这关可以把魔防升满，chaos魔法也到grand master吧，下关有个chaos祭坛，不要把sorcey升满了，最后学买到的魔法最好是末日，不然分解也可以，因为只有这个和下关那个城能学到5级chaos魔法。

    第三关，开始条件是城里造魔法塔（作弊回退一下啦）五级是分解或者末日，你又没学过的（链电不好，最后一战役，分解攻击最强，而末日不耗mana，而且攻城巨爽）。一开始两个hero分开占了右边和左下的木和矿，直接往下打下两座order城，在城里或者城外那个大学学了order第三技能，再右上打下order城，不要记着去那个图书馆拿宝物过关，练满三十级吧。记得全力升order，到城里学些初级的death，life（有life黑龙试练场好打些，不过没有也能过，加上slayer和cat，刚好能赢，可没学melee，archer的哦），而且很容易转成archmage，出order比fireguard容易，不然取进度太麻烦了（第一关学两级order是为了此关转archmage方便）。过关时该是order三项两个master一个expert。

    最后一关，先到右边杀螳螂，升级树升一级，再上面占金矿，吃加攻防的和order祭坛，然后左上走打下野人城，接着往左order城，旁边可以加一级魔法，给order。然后打下左下两order城，这时还有一颗树，一个黑龙试练场可以升满order，多的一级，呃，我给melee了，城里该把order魔法学全了，^_^，会催眠了（城里的大学好好利用，我升到第二级的life，death，没浪费升级点的哦。最后从野人城出发往上再往左打下order城，再干掉boss就可以了。这关只靠hero一人就可以了，前面用分解和末日就很轻松，最后一仗先催眠邪恶女巫，然后立刻用她爆掉对方hero，然后剩下的兵慢慢催眠让他们自相残杀吧，哈哈。

    最后过关，很容易拿到黑龙评价的，而且练出来的英雄也算很不错了。

    DarkRain注：此打法与战役攻略栏目中的攻略相比，因为第一、二关都是采用了攻下敌城后攒兵再打的方法，所以游戏中时间要多费很多天。而好处就是非常省现实时间（第一关早期还用了自动战斗），据说整个战役通关只用了4个小时。此外，本打法中英雄技能的学习顺序也很值得参考。


《阴云密布》Opposites Attract第一关最高难度四周过关心得
作者：过客

    本关要四周过关并不难,难在要将J的图书馆和M,L,N,K,O五处的混乱祭坛都访问完.由于上述地点除K外,其余均远离城镇,运兵方面要注意统筹安排.下面是本人过关的大体流程(有关字母的地点可参看DarkRain的攻略).

    1、前两天城里做第二级魔法塔和加经验的建筑,两英雄第二天才从城里出发--学会二级魔法(魔力闪光,混乱,火矢),路上顺便把加能力的地方访问了,损失一些兵也要打(以后再来会费时).
    2、过了B点后(B点左上加能力的地方第二英雄不要去),兵分两路,第二英雄-->F(W1D6),h/r到D,-->E;Kozuss-->D,h/r到F(W1D7),-->G-->H.灭敌在两周内是没问题的.
    3、第三英雄出来后,h/r升级(D-->F-->G-->H),第二英雄也h/r到H.集合后把I处的食尸怪灭了拿靴子,然后打挡路的梦魔,到J点加技能后,h/r到E.然后打M,L,h/r到F(打完M后分一个英雄去P点挖宝,h/r回H).打N后h/r到A,打K,再h/r到G.这阶段最烦!
    4、Kozuss去Q-->R,其余英雄占矿和打D点附近的鹰和九头蛇拿宝物.

    DarkRain的攻略中提到的技巧这里不再重复,下面谈一下其它的:

    1、A,E,F附近的穴居人和G附近的食人魔法师留着h/r用(因为近,这些地点本城是不用堵的--因为做梦魔缺木材,我把E处的灭了,影响好像不大)
    2、战斗方面,我用的是梦魔:梦魔开始施恐怖,英雄集中火力先干掉一队敌人,然后视情况处理.3梦魔+4英雄的战斗是稳赢的,不说了.下面说几种典型的情况:
        I点处,我2梦魔+3英雄+杂兵(赶时间,等不到3梦魔)-Vs-电脑3X12(加减1,下同)食尸怪,环形布阵,英雄在后,由于食尸怪会往前走一至两次,所以比较轻松.
        我3梦魔+3英雄+1杂兵-Vs-电脑4X12梦魔,环形布阵,英雄在后,梦魔开始对敌人施恐怖,之后关键是引诱敌梦魔对我梦魔施恐怖(拖住其前冲速度).
        J点处,我3梦魔+3英雄+1盗贼(我的火怪到E去了,准备下一天的带路工作)-Vs-电脑4X7九头蛇,盗贼第一回合先等待,待第1队九头蛇往前走后再走到其身边,第二回合直接往前走,这样第1队九头蛇就会被拖回去,之后视情况用梦魔往两边引九头蛇,梦魔牺牲掉也无所谓,反正要h/r旁边的火怪回E城.
        我3梦魔+3英雄+1杂兵(火怪或盗贼)-Vs-电脑4X12火怪时,第一回合一般搞不定敌人1队,这队敌人数量多时,第二回合可能要S/L到我方英雄士气高涨然后用闪电劈(此时用混乱的话,后面会很被动),这队敌人数量少时,用梦魔拼,英雄不用管它.
    3、O点的祭坛要去的话,倒数第六天Kozuss就要上船,不去的话可以省3天.
    4、造兵方面,G和E造梦魔,H造火怪(带路用)
    5、经济方面,敌人投降最好接受.一般前三周会紧张一点(造梦魔和买魔法药水),但最后一周,通过打宝库等方法可以补回来,不用担心分数.

    SSZ评注：这个心得的关键在于分兵和走位。


Opposites Attract（异性相吸）第二关最高难度2周过关心得
作者：过客

    我的Kozuss是宗师箭+宗师战斗，混乱系技能是3331（如果后面想成有序宗师，前面可考虑升成3214），感觉本关，还是箭比魔法管用一点。

    此关有两个特点要注意：
    1。本关地图不富饶，城又少，保库方面只有一个邪眼魔看守的巢穴，我最后打才1500金，不爽。总的说来，资金比较短缺
    2。野兵不多（不同开局，野兵的数量变动居然很大，以挡路的独眼为例，数量从25~33不等，郁闷），英雄要升10级（16~25，4个升级点要Kozuss升到21级再去，否则，你要走更多的路杀更多的野兵，还不一定够野兵可以升到25级），两个兽人城还要去两次（加能力）

    开局方面，鉴于前述原因，最好restart一个野兵多的；B城（有关字母的地点可参看DarkRain的攻略，下同）二级魔法要求有混乱（其余最好是灾祸，魔力闪光）。具体行程可能因人而异，但应注意前述两个特点。

    下面是大体行程（概括地说，就是顺时针转一圈，再逆时针转一圈，然后跑升级点）：
    W1D1：占铁矿后直接往C处赶，路上的训练场以后再来（回合结束时，应与鹰身女妖能打上）
    W1D2：过D往E赶（应可与M城左边的守矿兵打上了）
    W1D3：-->E-->FG所在小岛的金矿正下方（回合结束时，应与洞穴巨人，独眼，巨兽能打上）
    W1D4：-->把岛上守神像和靴子的九头蛇搞定，上回合末盗贼走位好的话，回合结束前可以拿到靴子手套钱袋
    W1D5：本来走得好的话，可以到K点了，但电脑会作弊，B城的敌人都会回城躲着不出来了----没办法让它投降赚钱，所以还是打N城岛上守神像的独眼
    W1D6：应该可以在B城右面的锯木场附近碰上敌人（我几个开局都是在这里碰上，死板的AI），打，让其投降大赚一把，往右下打守神像的食人魔法师
    W1D7：打下B城，出第三英雄占附近的木矿和水晶矿，第二英雄往B城赶，主英雄打B城左下看传送门的巨兽，拿了再生指环后h/r雷鸟回B城，马上出来尽力往上走（准备下回合打上面牛头和食人魔法师）
    W2D1：A城出第四英雄，h/r到B城，Kozuss打B城上面牛头和食人魔法师，K附近的矿，水元素
    W2D2：打下N城-->I-->H，Kozuss把岛上的黑龙和火元素全灭
    W2D3：G-->F-->E（顺便把火怪和守神像的独眼灭了）-->打下M城，然后，到首城的岛上杀怪拿经验，够21级后就是转一圈跑升级点。

    战斗方面：除M，N两座城外，基本是单挑（带路的盗贼和火怪分不分出来，看实力对比而定，九头蛇和巨兽都是单干--加速，精准，灾祸，杀戮）；水元素没有宗师抗魔有再生指环时就加个盗贼必要时挡一下；守戒指的雷鸟+独眼h/r用就算了；开始打守传送门的独眼时，盗贼的作用优劣顺序应该是：贴住独眼（被射都无法反击），挡主动攻击，挡反击（有野蛮人投棍后，盗贼用得好，满血是有可能可以不吃药的）
    经济方面（最最重要的一点）：一定要B城的敌人投降（先把两个英雄干掉，让敌人逃不了，然后慢慢耗），一般可以收到14000左右（我几个开局都差不多是这个数）。所有城造兵的建筑一个不做（火怪B城出就够了）。如果不是想要混乱宗师就不要盖魔法塔。首城加钱的建筑也不要盖（算一下就知道划不来）。再抠一点，加能力的建筑也不盖了（不建议）。注意矿石较缺，不要随便换了。过关时，城里的兵不够用，就跑到外面去买。
    记分方面，本关理论最高分应该是1080.5（部队算24分，地图算12分--估计实际最高就8~10分）。其它的分，该有的应该都是满分。我的最高分是1058，感觉分数跟有怎样的开局关系很大（药品我一般只用3不死4魔法）。


阴云野蛮人战役的另一种打法
作者：fireway

    阴云野蛮人战役开局是很难的，东方卷轴里已有详解。在打的过程中要靠敌人和周围的野兵交战造成大的损失才能攻城，如果敌人躲在城里不出来或者野兵太弱敌人消耗不大，那就变成了一个极之糟糕的开局了。

    前一阵重打该战役时，发现一个新的打法，也是要靠运气的，不过是RESTART的运气。
    条件只有一个，就是在敌领地鹰身女妖招募地的下方，有一队食人魔法师看守的法师箱内出懒惰弓。

    占狂战士巢后，把英雄和部队分开，英雄尽快去招鹰身女妖，速度慢一些的部队在后面跟上。
    有鹰身女妖后，只用鹰身女妖用H/R打下食人魔法师，拿到懒惰弓，再和后续的部队汇合攻城。
    攻城时英雄是否死亡并不重要，其它兵力也不重要，只要在这些兵死光前保证敌人全部中了疲劳，人马的箭被耗光，敌人会箭术的英雄被打死。其它的利用鹰身女妖的高移动力和打人不还手，可以用H/R灭掉敌人。
    之后，全以鹰身女妖做主力，马上可以只用英雄和鹰身女妖攻下中立野人城，在中立城也造鹰身女妖。主力带上所有能赶得上的鹰身女妖使用先疲劳再H/R的方法扫清周围野兵，一些箱子适当转为经验，使英雄能做有效的肉盾，再回头占最后一个野人城，再往回打，杀桥头的九头龙到敌人的领地。

    这个方法的好处是鹰身女妖移动力高，部队跑得快，而且是杀九头出关，不用等40个狂战士去开关，所以完成时间会大大加快。第一个中立城前期不用造独眼，省下钱来可以买药水。经验方面，由于有大批九头可杀，得经验值是很快的。

    独眼最后钱太多也可以造的，只为了打最后一战轻松点。


The Last Bastion（『战风』最后一关）应该这样打
作者：Illusionist

    先打中央的Life, 拿物品！拿到 Robe of the Guardian, Bow of the Elf King, 三次打击无效很强的！然后，五个城同出 Monk! 加 Bow of the Elf King 啦！~~~~~

    按DarkRain攻略上的方法，太麻烦了……先打那四个征服者挺痛苦的，有了宝就不一样了！

    DarkRain.cn注：我自己打的时候，没觉得有多麻烦啊？可能是英雄培养上的不同吧？不管怎么说，这是一个好的思路。


『毕欧伍夫的传说』76天过关说明
作者：黑孔雀

    很早以前打过几遍，都没有打过。后来看到clikme的操纵尸体和蛛丝箭的打法，也想不出新的方法，就没有打。昨晚手痒了，时间不多，想找个小地图玩，就打了毕欧伍夫的传说这张图。没有用restart，本想多花点游戏天数，多攒点兵打过去就是了。但是中间突然发现可以学一个魔法，结果没有用太多的兵，只攒到39个独眼，中间S/L多了点。

    1，一开始就是检资源，砸锅卖铁出独眼。摸经验石学一个箭术，在独眼出来之前，就靠箭术去耗守铁矿的一级兵。我遇到的是半兽人和盗贼组合，耗起来难度大一些。等独眼出来了，买了两个，就打下铁矿了。记得多带狂暴者，每打一战上五个，让野兵多分组，所以每战死五个疯子，后面不再提此事。

    2，然后买第三个独眼，打掉守昏击棍的另一组半兽人和盗贼组合和挡路的蝴蝶向上走，打掉农民，看见了一个战术祭坛，觉得不错。先看旁边的战争大学，采矿，领导，进攻，寻路。眼下缺钱，就吃了战术祭坛，买下一级贵族，把英雄分出，碰野兵回家去催生。

    3，又买了两个独眼，和原来的三个汇合，打下守攻击+6的洞穴人和盗贼组合，再打守的靴子牛头怪，中间免不了要S/L，让独眼扔石头时，不出现格挡。前进占了水晶矿，矿里藏身躲过火怪和枪兵的夹击，下一天打掉船厂下方的木乃伊，回过头下来打了家门口的金人和骷髅，升到宗师箭术。

    4，可以去耗狮鹫了。同时攒钱出饲养棚。按照clikme的打法，每次带六个半人马，英雄第一回合等待，被一组精灵射时，反击射一组狮鹫，然后英雄再射同一组狮鹫。第二回合逃跑，这样每次可以射死六个狮鹫。

    5，砸锅卖铁出了饲养棚，买到21个独眼，打过狮鹫和精灵组合，捡了个勇气徽章，免疫恐惧了:P 从现在起着重升战术系技能了，尤其是进攻。

    6，缺钱，只买了4个游牧民和6个半人马，去打副城。6巨兽，60+斜眼，70+Harpy，100+半兽人。半人马分四组站前排，第一回合会死两三组。游牧人等待之后，两下打开城门。半人马档住斜眼的视线，它就飞出城攻击游牧人了。独眼等待，巨兽和半兽人出城，和斜眼挤成一团，砸。Harpy攻击不到目标，也飞了出来，再砸几次，加上英雄的宗师箭术，不损独眼即可。

    7，守金矿的是风和水，狮鹫和白虎守的是硫簧火盆，眼下打不过。决定回去打枪兵守的碉堡，一方面升级，另一方面弄点钱建副城，当时还得到了一个士气+1的英勇徽章。升级到资深战术，独眼速度7，比火怪快了，可以连砸两次火怪，于是打掉火怪。

    8，升级时发现可以学新主技能了！出现的是混乱魔法。一般在战斗没到宗师前不能学新主技能的，不过《东方卷轴》也说有例外，没总结出来。回头找时间测试一下这些个例外。但这时出现了一个重要的想法：既然可以学混乱，应当也可以学有序！那就可以学精确了，有了精确就不用攒太多的兵了！

    9，市场里换5个宝石，下去摸升级树，果然每次都又出现了新主技能！S/L几十次，直到出现有序，并且领悟出的一级魔法是精确。

    10，这时连副城建的有30独眼了，打金矿时少带一个半人马，让水只分两队，保证一砸全灭。半人马跑动吸引风挤到一起，可以砸三组，这样英雄就扛得住风的攻击了，不损独眼打过。再打掉狮鹫和白虎，还有雷鸟巢下的那加，升宗师进攻。

    11，为了确认兵力是否已经够了，打雷鸟巢试验。这时确定了打高移动力飞兵的打法：带五个游牧民，S/L到开阔地形，以及独眼的士气高涨（目前独眼士气+4）。游牧民跑到左边从上到下排成一列，独眼等待，英雄给它加精确。雷鸟被吸引到左边也从上到下排列，独眼一次可以砸三组，连砸两次全倒。剩下一组在最上方，还够打不到我们，第三回合再砸一次，英雄已经扛得住一击了。

    12，砸锅卖铁起全兵。共计39独眼，70+游牧民，10+半人马，150+疯子，雷鸟太贵不买了。杀奔船厂而去。同样方法打过雷鸟，造两艘船出海。

    13，一艘船上英雄带39独眼和5半人马打海怪+美人鱼。无非就是半人马跑动吸引敌人，加了精确的独眼砸就是了。

    14，攻城时，就是半人马分组站前排，加了精确的独眼先砸魔法英雄，后砸美渡莎和半兽人。只剩下火怪和黑龙了。火怪需要砸两下，黑龙要砸三下。站到适当位置之后，游牧民用几个回合：等待+打门+回来，打开城门。等火怪出来，砸死。黑龙不敢出来了，英雄换到适当位置也射得到它。

    15，然后是打螳螂，和打雷鸟一样的方法，注意不要把战场选在沼泽地上，否则游牧民跑得不够远。攻第二座城比第一座还容易，不提了。

    16，守宝石匣的螳螂和狮鹫数量太多，损失了两个独眼，但是用宝石匣可以换到10个独眼，划得来。

    17，现在需要算时间了，H4是以周来计算分数的，当时是周五，必须三天结束，算了算，还来得及打守火焰剑的巨兽，但是就不能吃弩车守的攻击+6和独角兽守的魔法+3了。

    18，决战，21级将军：战术系3514，战斗系5151，高贵1，有序1。47独眼，70游牧民，7半人马，150+疯子。
    对20级将军，4黑龙，10巨兽，40独眼，100疯子。
    第一次就砸死了英雄，轻松取胜，死了100个疯子和7个半人马。

    这个地图的关键是战术系，和平时打惯的单英雄狂练战斗有所不同。打的时候基本不让敌兵攻击到独眼，因此战术系中的防御没有用处，练一级就够了。魔法上有序的精确是最好的，其次是生命的祝福。如果不学魔法，单纯靠战术，估计多攒两三周的兵也够了


63天，The Beowulf Tales最高难度
作者：clikme

    这是我第三次打这张图，发现真的很有意思。

    要点是蛛丝箭＋操纵尸体权杖。下面捡关键的说：

    1，敌人一般会在你有几个独眼的时候过来。我这次更早，只有2个独眼（刚造出独眼巢的第二天）他就来了。但他来的早的话兵力也就不强，主要的威胁是2只九头蛇，5个火怪，和18只梅毒杀。但这个兵力他也不敢来打我，反倒是往上走去攻击二级野兵，并会死掉不少兵力，关键是火怪都死掉了。我方主要倚重独眼，没有了火怪的快速接近威胁，独眼火力能够尽情发挥。这一仗，要求英雄升级的时候先加Combat，提高自身的生存能力和肉盾能力。

    2，附近的一级、二级野兵，只需要英雄带很少量的独眼就可以拿下，不需要其他部队。关键是要把独眼也分队，使得电脑部队分成4队，这样很容易造成独眼能够同时砸3个目标的情况，火力极其凶猛。如果野兵是远程，把独眼藏在英雄后面，英雄选择防御，它们就会选择先走过来。独眼就能尽情扔垃圾了。

    3，船厂旁边有个战争大学，要充分利用。例如里面通常会出Melee和箭术，还有战术类的。旁边还有一个祭坛，会是贵族、侦察、战斗、战术类的，也要利用起来。我new出最好的一次，从这两个设施里学到了两级箭术，一级战术，一级贵族，一级Offense（提升部队攻击力的那个）。

    4，英雄的培养上，我认为是首要提升箭术（兜了几个圈子，还是回到这点。我曾经试过专升Combat，专升Melee，发现还是箭术优先），因为这个地图主要的时间障碍是那队49。49是无限反击的，靠肉搏砍，一个照面就得回家。用箭术则可以多坚持一回合。而到了后期，Combat，Melee，箭术是肯定可以都升满的。

    5，重点！当英雄升到Expert箭术（Master更好，GM就太久了），就可以去对付49了。用英雄带3只人马。第一回合全体等待，箭手射死一只人马，3队49飞过来。英雄射击，能射死1－2只，有运气成分。第二回合，英雄再射击同一队49，此时共干掉3－4只了，剩下的2队人马都被干掉，英雄也挨了2下打击，其中反击一次又干掉1只49（这里要注意选择，让你反击的那队49就是你之前两箭射击的那队，这样能多杀1只），hp也基本上没有了，下回合就逃跑（要注意存档，以免英雄士气低落或者对方士气高涨）。这样第一次就可以干掉4－5只49。然后照着做3次，第二次也是4－5只，第三次就能杀6只（因为49数量减少，英雄能再挨1回合），第四次甚至能杀7只。经过这4次冲击，49就剩下10几只了，带上全部兵力（游牧人也全部招出），共计是11独眼，30游牧，能够无损（或者损失1－2只游牧）突破。

    6，接着是攻副城。由于这次进展很快，副城的兵力变得比较难对付。60只邪眼的影响可大可小！我是通过反复S/L，使得每次邪眼打英雄都被抗魔，或者是中一些不要紧的诅咒，例如Slow等。
    打副城有很多技巧。大家不妨自己试一下，如何以8级的野蛮英雄＋11独眼＋30游牧，去攻打一座守军为6巨兽，60斜眼，72Harpy，102半兽人的城堡。
    我发现的技巧是这样的：
    我方四队，英雄＋独眼＋1游牧＋剩下的游牧
    英雄挡住独眼，1只的游牧挡住大队的游牧，1只的游牧防御，英雄不能选择防御。这样敌人的两队远程都会选择打英雄。英雄射击邪眼，靠S/L来抵抗魔法。独眼只扔一次石头，是砸门口的半兽人（是直箭，如果射击邪眼则只有1/2。这一次就砸掉大半的半兽人。），之后一直沉默，留着石头，后面才能赢。就靠英雄的攻击和反击，把60邪眼与半兽人干掉。
    远程干掉后，敌人的6巨兽和72Harpy会不动。我方不能贸然砸开城门，以我方现在的攻击力，还不能在巨兽走近之前干掉它，必定会损失惨重。方法是用那只单独的游牧砍开城门，其他人不要帮忙。城门破后，单只的游牧就站在那里不动，这样巨兽和Harpy都不会动！英雄和独眼走到能够射击的地方就行了，可以把箭全部射光！要注意的是先杀巨兽，否则Harpy损失到一定程度的时候巨兽会动手的。

    7，之后是抢夺操纵尸体权杖。由于打的太快，守卫的三级兵也不好对付，但这不是重点就略过了。

    8，有了蛛丝箭和操纵尸体权杖，就可以英雄孤身打下雷鸟巢。带上3只雷鸟走人，全军直指船厂，记得带多一些不朽药水，尽量买吧，此后不怎么需要钱了（我买了20瓶）。顺带清掉那个弩手和长枪兵的仓库，好多钱和道具呢。

    9，英雄孤身打下码头雷鸟，带上4只人马上船。其余部队岸边待命。

    10，4只人马分成4队，攻击海怪！这样的队形会让敌人分为2队海怪，美人鱼不分队。首先射击美人鱼，两只人马冲上去顶住海怪（否则海怪移动距离太远了，很快就到面前），两只人马待命。第二回合马上操纵美人鱼尸体，存档，攻击美人鱼。如果无法催眠美人鱼，则Load。如果成功，save，用美人鱼攻击一队海怪。美人鱼被吃掉大半，海怪被催眠，如果无法催眠，又Load。用催眠的海怪与另一队海怪对咬，互相大餐一顿。派一只人马顶住没被催眠的那队海怪。第三回合再次操纵美人鱼尸体，重复上述过程，最后一只人马也上前顶位，壮烈牺牲。头三个回合下来，我方只剩英雄，对方美人鱼全灭，海怪互相耗掉一半甚至更多。
    第四回合操纵尸体权杖没有法力，英雄射击一次。海怪靠近（但还打不到）。第五、第六回合继续操纵美人鱼的尸体，又是两轮大吃大喝（这两个回合英雄都会被咬一口，要小心被吃掉），海怪就差不多死光了。

    11，上岸。直扑敌城（当然吃掉路上的一些加能力的东西，经验石就免了）。敌人兵力比较雄厚，但不难打，主要是弱兵站前排挡视线。这次打的好快，敌人竟然还没占下城堡旁边的金矿，不过我也不占了。

    12，英雄再次孤身干掉守路的螳螂，全军下地底，直扑敌方第二城。敌人又把大部队带走通过传送门去打我的主城，正中下怀！极其薄弱的城防使我轻松取下敌方第二城，全军马上转身，矛头直向最终Boss（顺路打了经验石旁边的巨兽，45只，我只有25独眼，3雷鸟，40游牧，0损失。拿到了一把火焰剑）。

    13，兵力差距比较大！20级将军对20级将军，25独眼对40独眼，3雷鸟对4黑龙，40游牧对10巨兽 100狂暴。。。。。。
    一开始我尝试用老办法，杀掉它英雄就逃跑。结果发现打不死。敌人的英雄防御力太高了，我英雄能一次射死一条黑龙，但只能射他几十点血。多次失败后，改变方法，先杀他兵，经过多次S/L（主要是防止我方英雄士气低落被连续攻击2回合死掉），竟然被我成功杀掉他其他所有兵，独眼也没箭了。此时战场上就剩下敌我两个英雄，还有对方33只没箭的独眼（而且还很远），单挑你就打不过我了，我有火焰剑呢嘿嘿。

    顺利过关。63天完成，得分1345，评价黑龙。

    补充一下：英雄的培养上，我把箭术和Combat升满后，就开始加战术系。因为英雄用到Melee的机会太少了（几乎是没有），战斗主力都是靠独眼，因此把Tactic、Offense升高是很有用处的。我升到了Master的Tactic和Offense，Expert的Defense。

    学1级贵族（通常就是那个战争大学里学到了）是有用的。这样主城能够出产多10％的独眼，实际上就是增加2－3只左右（我出海的时候是25只独眼）。

    雷鸟实际上招不招都差不多。3只雷鸟实际上没有起过什么作用，省下的钱多买几瓶不朽药水，效果更好。当然钱够的话是来者不拒了。（钱应该是够的）

    另外，主城造不造繁殖场也是一个问题。造的时候已经比较晚，多增加的独眼数量可能也是很少的。我想应该比不上15瓶不朽药水好用。

DarkRain.cn注：

    The Beowulf Tales，就是『毕欧伍夫的传说』，这是官方地图中唯一标注为Impossible的，也确实有难度，很多人都打不过去。这篇63天过关的说明，可以和前面76天的对照看，最值得看的是关键点的打法思路。两个打法都大量使用了S/L，但其实只要方法正确，不S/L或只是稍微用那么几次也是可以过关的，四个月左右算是正常吧。在普通的打法里，战术系在本关的作用要强于战斗系。

    之后网友Lipton参考了这两个打法，取得了49天过关的成绩，应该接近极限了。下面是他的发言：

    1、蛛丝箭+控尸杖（有了它英雄可孤身干掉雷鸟、食人鱼、螳螂）

    2、英雄转职！！
    一开始英雄不要慌着去战争大学买技能，只修COMBAT系，到一定级别后修Tactic，Tactic系升2级后转职为将军。再修到技能等级平均值不小于6时就可以学新主技能了。我用了几十次LSL学到了ORDER的精准魔法。这样对独眼的数量要求就大大的降低了。

    3、流程和前面高手写的大致相同，我利用电脑来帮我修建筑，先让电脑打下主城，过3天抢回来，所有建筑都修好了。

    4、决战：
    18级将军、17独眼、40游牧 VS 20级将军、4黑龙、10比蒙、40独眼、100疯子。（COMBAT5151、TACTICS3420、NOBILITY1、ORDER1）
    打法很无奈（无赖？），杀了英雄闪人，势力太悬殊。
    游牧分4个一只的，挡对方独眼视野，散开阵型。
    游游游游（36）
    英游独（17）
    1回合：3个一游牧中间站一排，一游牧和36游牧到右边，黑龙飞来喷英雄剩几十点血，英雄给己方独眼加精准，独眼等待。比蒙杀一 游牧，敌独眼砸英雄，死，复活。敌英雄出。
    2回合：独眼砸敌英雄和100疯子，疯子剩2个，36游牧砍敌英雄，剩一百多点血，一游牧贴敌独眼，一游牧杀疯子。振奋，独眼出 手KO敌英雄，跑之。

    49天，1425分，评价巨龙（我是战风版）。倒数第4天副城不小心被下了。


阴云地图“三女王”最高难度1周过关打法
作者：Mia, baoshanbo

    该图3玩家:死亡。秩序。力量。各有1地下的监狱英雄。12XX骷髅看守。死亡死骑。大师战斗+宗师箭术。宝物懒惰弓；秩序领主。专家战斗+宗师肉博。矮人锤；力量最夸张。大师战斗+宗师肉博+专家抗魔！此外还附送专家混乱魔法！宝物迅视戟。魔法有血暴，法力桎梏等(明显是针对水元素的)。

Mia的死亡打法

    初始条件:因死亡英雄无抗魔，守卫3岛通道的80+水元素无法在1周内歼灭。所以用死亡必须尽快坐船到野蛮岛，放出野蛮人帮忙。而海路必须通过2帐篷。各有1队随机3级兵守。此图用死亡战斗难点就在以3吸灭这两队。所以最好L出两队比较好打对象。诸如:灯神，火怪，元素之类当然是免谈的。另金矿对开头很重要，2级兵守，只要不是没肉的3吸基本可轻松搞定。以上3队为初始重点。其他么，最好随机资源能多几堆金咯。Wink

    以下介绍具体流程安排:
    (为了2天内放出死亡英雄，前两天行动力必须绝对精准。差半步都会够不到，我也试了很多次才算到正好。)
    D1:换1石买2小鬼捡钱，把所有1天能够到的全捡来(包括地下)，城造1级塔。用盗贼英雄，买下3吸。我试了几次把矿换钱，基本刚好够。不过至少要留1硫黄给2级塔哦。死亡师退1步，开城市画面。合并双英雄。3吸。一些杂兵(基本用小鬼，便宜吗，守兵有魔力的更要多分几对。)移动部队到城外。访问石碑。注意:按碑出现的路线多了1步，走到与碑平行就停，再按石碑也可以访问。绝对不要多走。盗贼的目标是高级潜行，2级升高级侦察。3级升高潜。不用S/L，绝对可出。死亡2级高级。3级招魂增加军队分。攻击金矿。有左右两个位置攻击。我都选右边正对矿口的位置。不清楚行动力上是否有差别。还是推荐右位。这队2级兵不难解决。我打时是42精灵+1XX绿帽。魔法出了废除，瓦解。3吸先等待再争取连两次贴住远程，基本就差不多了。若被先射会很不利。战斗尾声务必让死亡师上前打掉几个小兵顺便慷慨就义(让出此战经验给盗贼)占矿。找小鬼把矿口的几堆金捡掉。沿石路(0.75每步的那种)以矿口左边的位置占矿。此处务必如此，若直线占矿会少1步。从城里买小鬼(若有幸存就不必)，并入主队，顺便移出3吸。(这里提一下，前两天最关键就是盗贼英雄的行动力，所以所有的发起合兵，移动军队必须其他部队完成，绝对不能动盗贼！)回城。3吸沿路回城，会经过石矿1级兵，不用管，3个吸呢，你怕谁?也可以直接打掉他。普通1级兵150以内有死亡师1吸就可解决。狼，狂暴麻烦点。主队(盗贼，死亡师墓碑，1小鬼)去攻桥上的水元素。盗贼靠后站，能动马上按"逃跑"。注意:这里最好在分出3吸时就走。3吸靠在主队下方时给出的路线正好够。如果严格按以上所说，此时回到城的盗贼还有一个行动力，带1小鬼对准传送门走。不要小看这1步，关键就在这里。否则以第二天28步无论如何也够不到监狱！！我也是试过N回才挤出这1步的。死亡师城里睡觉补魔。

    D2:城出2级塔，3吸并入盗贼队，对准传送门走几步，可以向右1步攻击木矿1级兵的地方停。这里的1级兵要打掉，加上之前一战的经验应该够升高潜了。一般还有多。(我打时不太好，撞150骷髅。虽然3吸可以无损打，但保不住英雄。只好叫死亡师带了些小兵出来帮忙。)升到高潜盗贼就带1小鬼直奔地下监狱。先把3吸和其他人马移出。中途让捡到长弓和地下1个宝的小鬼把东西传给她。(这里最好情况能出矮人盾，保护戒指等。可惜我只出了个记忆水晶。Cry真垃圾。)走到最后一步再解散1小鬼，如此正好可以放出监狱英雄。放出就逃回城，这没问题吧?死亡师看看门口几个魔法塔能不能学的，还有死亡温室等等。行动力够就占个木矿。不要离城过远，要保证第三天能上船。

    D3:城出铁匠铺(有信心也可以不造，多省钱得分高点)。看钱够买点什么。有个降攻防的不错。再带上20左右小鬼。骷髅若干。整队出发。合并3英雄3吸。先打水晶矿(不打也行)，再打帐篷。我此处L到21黑马+29牛头，算不错了。先杀一回黑马驱役来用。再加懒惰弓和疲劳。总算有惊无险过了。死伤5小鬼。这里注意敌人过来的话一定要找些小兵挡死骑，死骑没肉博，被近身就完了。第三天开始3英雄每战都不能死。没时间回去复活了。打完捡鞋上船。要是小鬼死太多，就再买点补。一定要留一点。后面还有力量的食人魔呢。

    D4:船往下开到力量帐篷出。攻击3级兵上岸。我这里挺好，L出69食人魔，杂兵没有。损1小鬼解决。

    D5:捡鞋给死骑(之前给盗贼)，分1、2个小鬼附近捡捡。到传送门口把盗贼分出来。下去放力量英雄(顺便把地下也收干净)。主队可以考虑先打树和游牧屋。然后去打力量城。打下后盗贼放英雄回城。主队继续向秩序岛方向走。

    D6:野蛮人和盗贼出发，先买个抗魔药。捎上死骑，带几个小鬼就好冲水元素了。这里超好打。野蛮前面挡，后面排一串。不多说了。打完野蛮收拾金矿。主队向上直冲秩序城。沿路把树和矿解决掉。钱多也可以打蛇妖屋买兵。盗贼下地放出领主，先把钱收一收，然后把力量城门堵掉放领主回死亡城，准备第二天收拾本岛的树和地下监狱旁没来得及拿的钱。

    D7:领主和盗贼往传送门方向，领主去打树，盗贼下地收拾。有鞋子加50%绝对够。把能打能捡的都解决。全部完成后主队打秩序。当然是超轻松的，OVER！

    按以上打出的分数:1387。

baoshanbo的野蛮打法

    打一队一级（木或石旁），再打招游牧，再打一队二级（水银或知识树旁）就有1000经验。关键就是这两队不能太强。打石旁和水银旁可以节约一天，不然至少也得7天。

    第一天：女王招城边人马，单个狂暴者捡钱，派2狂暴者往时空们方向准备第二天捡钱。所有矿换钱。招盗贼英雄，招完兵。两英雄集合部队打石旁一级，弓给盗贼后面射，女王偏反击。女王死（一般会死，除非遇太弱的），狂暴者拖回复活（顺便加防3）。盗贼带人马不占矿直奔经验碑，再奔游牧处。复活的女王也直奔经验碑，再奔游牧处。其余部队也奔游牧处。

    第二天：先打游牧，尽量完胜。再打水银二级。老战术，死多点没关系，盗贼英雄须活着。盗贼英雄带人马直奔地下，盗贼救火卫士逃回（如差一点可用耐力）。

    第三、四天：打鞋旁三级和知识树。最好升出大师抗魔。建抗魔塔，买抗魔药。第四天打之后用了捡的治疗药。前面站个炮灰打通死亡水元素，先喝抗魔药，再用血暴，待机，被用上疲劳后水元素打掉炮灰，英雄冲过去打水元素。跑到前面去看见敌人，生命不多了，忙退两步，后面部队加入。敌人不敢来打。

    第五天：敌人没回城，打掉（回城也没事，只要没城堡）。一举打下城。盗贼救死亡将军，逃回死亡城。

    第六天：打通往秩序水元素，轻松多了。再过去探路，消灭秩序。

    最后得分：1288

    SSZ注：略有删节。另外，Mia的打法前两天走位不很好，可以参考baoshanbo的走位，应该很轻松拿下。


2个星期内过Siren’s song的心得
作者：antidevil

    一直觉得HERO有2种玩法，一种是对战模式，一个人训练就是不LOAD不RESTART。还有一种就是孽待电脑获得高分，这时就无所不用极啦。这里我介绍一下打一张官方地图的高分经验与诸君同乐。

    Siren's song，wind of war里M单层地图，地图难度expert，玩家1个城，2个电脑，均2个城。这个地图很富裕，敌人虽然很强，但在IMPOSSIBLE难度下没什么可怕的，2周内打完可以出高分（我基本上打完了所有开始有城的地图，感觉就这个地图最容易拿高分）

    由于M地图需要在2周内打完才能得高分，个人意见是LIFE和ORDER不可能，机动力太差（请不要鄙视本人的LIFE和ORDER）；MIGHT和CHAOS可能性不大，前者盖本人无法用4天的MIGHT兵去打守路的NAGA，后者是机动力差劲而且常规战术打无法打快，若有高手实现请不吝赐教；DEATH轻松搞定，相信DEATH高手应该都能轻松搞定；NATURE不太容易需要一点运气。

    我先简单说说DEATH的进程，这个似乎太简单：

    第一天城里小鬼出去抢钱，左上4个右上3个左下2个右下1个，英雄身上骷髅分出来拣点东西就回城，小鬼留一个其他分出来。英雄吃最近的2个箱子升级（本人郁闷，500+1000经验），不要吃离你2格的，吃木矿边的箱子升级，小鬼拿走金矿前的金子，留与守兵最近的一块，英雄不要去占领木矿正好可以占领金矿，被守兵打，逃回城里，城里起地狱犬建筑。

    第二天右上的小鬼每2个之间间隔1天路程，最快的小鬼尽量向上走，你会看到。。。一个手套和箱子，守兵打不到你，尽快去拿。这个很重要，没这个很可能来不及。英雄带小鬼1个吃剩下的箱子，占领木矿，然后走到金矿边的守兵附近，小鬼拣钱。这天有点浪费，不过一是这天就算全力出VAMPIRE，换光了矿也招不出来，其次是这天要是出去，就没有2级魔法了。城里建设2级魔法塔，有疲劳最好，没有也无所谓，要是你钱多也可以做MANSION，反正我为了高分是基本没换矿。结束行动后守兵打英雄，逃回城里。

    第三天小鬼把手套交回来，一个一个传递（DarkRain.cn注：其实开始应该用个英雄捡手套，捡到后逃跑回家，可以早一天交给主英雄），英雄招募出2个VAMPIRE打宝石矿，一路向下都是1级兵看着，没有任何问题，招出骷髅别带身上，招募一个英雄带一个小鬼，占领石矿后跟主英雄，不用合兵。

    第四天继续向下，城市造什么其实无所谓了，因为没时间回来啦。这里有很多箱子，经过就不要错过，尽快把英雄升级出5级NEC，有一队2级兵，我遇到的是半羊人，英雄会疲劳，轻松搞定了。

    第五天打NAGA，这里的守军必定是NAGA，用VAMPIRE+疲劳就搞定了，其实这之前一定已经会招幽灵，用幽灵好了。

    之后没什么好说的了，因为已经差不多会招吸血鬼了。一路冲过去，主英雄势如破竹~~，后面的进程基本可以参照nature，基本上13天就可以搞定了，你要给英雄加点能力的话就是14天。总体而言这是非常简单的，唯一要注意的是千万别读记录，否则就没有战斗分数了，我到后来英雄不小心死了一次，LOAD后连续5战斗只得了10分，因为兵力太多了。所以提醒诸位在打下敌人第一个主城之后至少买2个IMMORTAL，我当时打下的是人类城，买了2个IMMORTAL和3个血瓶，后来果然遇到了魔法师。

    再说NATURE

    本来我想先写出NATURE的基本打法再写这个的，但最近NATURE经验写了一半遇到点困难，我意外发现以前的一个针对性打法属于投机行为，失去了一般性，正着手开发解决问题的方法（希望NATURE高手不吝赐教）暂时没什么进展，无聊就先写这个，应该说还是比较典型的NATURE开局和中局打法（2个星期的开局呵呵）
    NATURE最大的问题是缺钱，这个地图由于富裕得恐怖，所以NATURE可以打得非常舒服，可惜为了及时过关，顶级部队基本没什么出场机会。为了打出最高分我RESTART几次，不过条件其实很低只有3个
    （1）主英雄不能有第四技能（召唤技能）
    （2）4个宝箱能让他从3级升到5级（2600EXP）
    （3）城里的魔法行会里有水元素。

    OK，let's set off！

    第一天，英雄身上的狼放回去，小精灵只带一个。小精灵出去拿钱拿矿，记得右上至少派2个去拿鞋，小精灵在草地上的移动力要超过IMP一点，2个就足够了。其他类似于DEATH，小精灵移动能力多一点，在这个地图上往左下可以走到硫磺矿后面去不被打到，第二天可多拿些钱，其他都差不多。英雄不拿离自己2格的箱子，白偷一个金矿，逃回，城里造魔法塔，有个装宝物的箱子可以去拿，我拿到的是ANGEL'SBLADE，垃圾啊！第一天就要招英雄去占领木矿，你的钱是足够的。

    第二天，小兵继续拣钱，右上的小精灵拿到手套以后回来传递，把手套交给主英雄。出三级行会，然后主英雄带上剩下小精灵去打宝石矿，别忘记碰一下绿洲~，我另一个三级魔法是火元素，不赖，不过是其他的也无所谓，只要有水元素就可以了。这时你应该有30点魔法值，所以可以打2仗，继续向下有个水银矿，殴之。在主英雄后面一天的路程放一个小精灵。副英雄紧跟占矿。

    第三天，从今天开始如果你会PATHFINDING每天不要忘记放，昨天不放是因为30点魔法值正好够用。（我打的时候一开始不会55555）。城里出流浪者工会，招小精灵买几个魔法瓶传递给主英雄，主英雄下水晶矿，吃下面的箱子。副英雄跟上

    第四天，从今天开始城里的目标就是造仙女龙和生物门（其实不造也无所谓），但是为了高分，我推荐只造一个，因为你就算同时造2个也不会给你加分的。主英雄打2级兵（我遇到的是牛头），碰2个经验碑吃箱子，可以暴升级，千万别学COMBAT，这会延误你的进攻，暂时没有人打得到你的。尽量升级你的药草和冥想，可以多招些水元素。这里附近有不少装药的包裹，叫小精灵全部拣过来交给主英雄。副英雄的任务是占矿，不用合兵分主英雄的经验。

    第五天，主英雄走到经验箱子和宝物箱前放下精灵，先吃宝物箱看看有什么（我拿到的是FIREBALL的杖子，COOL），好就装备然后吃经验箱子。这里是沼泽，NAGA走得很慢，加上水元素的减速几乎动不了，用等水元素的魔法值用完再招的方法，英雄走到前面去带着NAGA走。一般招3次就搞定了。小精灵和英雄合兵，冲过路口，后面的人一定要跟上。不行就冲过以后分一个小精灵出来。你会看到敌人的阵地里到处都是没来得及拣的钱和箱子。。。不用客气了。但下面有个加3魔法值的地方去不去随便你，去的话可能会晚一天到敌人阵地里，所以我没去，直接去吃经验箱了。

    第六天，小精灵走到前面去可以看到一个NATURE的魔法学院！这是我在这个地图用NATURE的重要原因之一。买魔法书吧，我当时在这里花了一堆钱，学了PATHFINDING、WaspSwarm（蜂群），空气元素等，还买了5级的召唤仙女龙备用，这里基本没可能学到5级NATURE吧。当时我很希望有个4级召唤，结果没有。。。郁闷啊
    总之这是最重要的学魔法的地方，有钱就尽量花吧，附近还能拣到很多钱和矿，今天不造东西也无所谓的。我在敌人城门口还白吃了3个经验箱^_^，如果走得好的话，今天正好能打到敌人的城，用水元素灭之，但是小精灵千万别死光了。当然实在死光了就算了，后面的赶快跟上来。我打到这里的时候正好机动力用完了，就造了2级魔法塔，如果你机动力还有多，那造魔力旋涡也是不错的。打下城后招一个盗贼英雄可以去把下面的矿都占领了，副英雄要跟着主英雄。

    第七天，英雄魔法值翻番以后冲锋(向上），顺路有加经验的都别错过了，最好能升级到5级NATURE。有个学魔法的地方可以去，一般这时副英雄已经滞后了。这条路上的箱子一般都被拿走了，但是会剩下一些钱和一个+2speed的宝物(如果被拿走也多半在攻城的时候得到，能拿到的宝物不要放弃）。路上还有升级树，最好去一次，否则要学到5级NATURE还是很困难的。

    第八天，路上有一个森林宝库可以去抢，因为这时会比较缺钱，还是抢了吧，不然仙女龙建筑和生物门很难造出来。往上走，看看你的英雄战斗力如何，我到这里的时候差3000多经验升级，NATURE差一点到5级，就打了一些敌人后钻传送门，消灭掉敌人后攻占城堡（友情提醒不要忘记放PATHFINDING，雪地里没有这个不是好玩的），造魔法塔和NUTARE附属建筑吧，我的进度在前面拐了个弯，今天正好走到。这时升级我就加了一点COMBAT，因为附近还有一个老兵工会，而再前面有一个图书馆可以利用。副英雄跟上去拿金矿。

    第九天，我的进度是城里出3级，主英雄访问经验碑升级学COMBAT，去老兵工会升级，再去知识树升级，这样就有3点COMBAT啦。副英雄上来拿金矿，盗贼兵（bandit）走到传送门这边的老兵工会等地方抢钱。从今天开始不要再读记录了，否则会影响你的得分。

    第十天，英雄从左上角返回，无视魔法大学和老兵工会，直接向左冲锋到图书馆，升级到5级NATURE学会纸上的招唤仙女龙，继续向左上可以看到另一个传送门。我当时遇到的是石像鬼和幽灵，这里有2种方法，我2次尝试中第一次走得慢了点，没走到这个传送门，于是第十一天为了抓紧时间就用牺牲SPIRIT+召唤仙女龙+蜂群的战术解决了守在那里的2级兵，然后就再没回城，第二次优化了路程，正好走到，就没打直接回家了。因为家里的5级有DRAGONFORCE，4级有召唤植物。记得在进传送门之前看看清楚有没有逃到这里的蓝色，一般有也是少数，请副英雄灭之。

    第十一天，如果第十天没走到传送门的话，请用召唤打那里的2级兵（无论条件如何，你在NATURE学校里可以买到2个4级1个5级，无论是什么5级召唤还是DRAGONFORCE总归打得过吧），然后一路向右上移动。如果走到并和我一样回家了，请招出一个螳螂或仙女龙，这时你应该已经会很多4、5级魔法了，碰一下马廊，解决掉战争大学前的小兵（学不学无所谓，请别多花钱），碰一下水漕，向上移动到另一个传送门。

    第十二天，攻击那里的墓穴宝库，守卫传送门的2级兵，杀进最后一家的地盘里。加上今天共余下3天时间，够你解决他了。这时他还没能力出海，所以可以一举消灭他（要是出海还得等3天就没希望了，所以前面要仔细看有没有剩余的蓝色），先打上面的，因为有一个水槽而且上面有可能电脑已经在着手突破守船厂的人了。

    第十三十四天，没什么可说的了，电脑在最右下，消灭他就可以过关。节约点钱，不要随便把矿便宜卖掉，照这个顺序打出1500以上的高分，应该是不成问题的。

    DarkRain.cn注：此关资源丰富，感觉完全与地图本身的预设难度不相符。在四代所有官方地图中，此关应该是过关后得分最高的了。我曾用死亡族打出过1557的分数，用守序也试过，耗时12天，比死亡还快一天，但因为财富和部队分的不足，总分少了45分。论坛里也有人贴出了用混乱两周过关的说明，利用的还是潜行技能。


Forest Frenzy 最高难度5天过关心得
作者：windfan

    地图描述：官方地图，小地图，地上2个自然城堡（可以任选，我选了兰色的），地下一个混乱城（有关卡拦着，过不去）。两个自然城初始英雄都 是5级，玩家会专家自然魔法，不过电脑的是个5级弓手。

    胜利条件：任意选一个自然城，灭掉另外一个自然城就胜利，无须打混乱城

过关流程：

    D1：分出队伍里的小狼拣城堡前面的火（最好是钱+木头的组合）和神圣喷泉下的资源，英雄带小妖精碰神圣喷泉+3魔法上限后再碰 给珠宝的小妖（这个怎么说来着），然后回城。城里把木头和水晶外的所有矿换钱并且出2级魔法

    D2：城里3级魔法出招水（没有？RESTART吧），最好还要有群加速或单体加速。然后英雄带小妖去打守传送门的白虎和精灵（大概35和24的组合），打的时候换上小狼（留4条以后要靠它传药水），小妖就不去了。这一仗只求打赢，但英雄不能挂，狼肯定保不住。战斗时紧凑阵型，英雄7号位，10+头狼3号位，那英雄招出的水刚好在狼和英雄中间（这里可能要多S/L几次，有时候狼档不住精灵的视线，其次地形上最好有障碍物挡住精灵），狼在前面吃精灵的箭，这个生猛啊，RP不好只能顶一回合。水人第一回合先迟缓白虎，第2回合用冰箭杀精灵，以后自己随机应变吧，流沙招小精灵什么的可能都会用到，杀完精灵后和白虎周旋就简单了（友情提示：英雄只有33的魔法，省着用）。打完后小妖和英雄会合过传送门，分组的4头狼也3头过传送门。

    D3：英雄碰向下路边泉水后往左去打130+鞋精灵，打这个就很简单，小妖不参加战斗，招3次水就可以解决了。打完后带小妖往左 一直前进，别忘了3头小狼分2头继续跟过来，另一头原地待命。

    D4：英雄队伍分一个小妖出来后继续想左上敌人城堡挺进（顺便拣路上的珠宝和水晶），刚好可以打到守路口的白虎和精灵，不过不打 ，反正打了也灭不了敌人了，差好多步。城堡应该可以出游侠工会了吧，出不了等第2天也无妨。

    D5：出游侠工会并买魔力水叫一路上待命的狼和小妖传给英雄，英雄喝了后容光焕发，老树发芽，轻松做掉守路的白虎和精灵（有这么多魔法点战术上比第2天的就好安排多了啊，妖精这次可要上阵挡箭了）。成功后端到敌人城堡过关，敌人守军一般是20+妖精，10+狼，1个5级英雄，1个1级英雄，没什么难度拉。


对战研究：（River Crossing，即穿越横河）
作者：panda000

    先来介绍一下地图,TGS2.2中专为多人游戏设计的,River Crossing即穿越横河，种族限定有三家~力量 自然秩序。三家基本上是在三个三角州上~中间有横河一条隔开~可以通过两对传送门~河旁有渡口和船坞（有兵守）过合。对战双方选择力量和自然，电脑为秩序~冠军难度。局域网双电脑对战~不能偷看到对方的电脑,时间限定是2分钟一回合。战报如下：

    本游戏开始是双英雄都3级。力量：城市建设为750，有篷车，一级生物，双野蛮人。宝物有魔鬼屠杀者,长弓+5,有全体部队远程距离不受限制的狙击弩。自然：城市建设为750，有一级魔法塔一级生物，3级弓箭手3级德卢伊(随机给出基础召唤~垃圾!)。宝物为法师手杖，长弓，十字弓(英雄长攻击不受限制)。门口有4个宝箱,一个战斗祭坛.一日路程内有木材矿(无人守)、金矿一个、铁矿一个(1级生物守冠军难度数量为一群)。

    第一个星期：

    1D：力量开局.一近一远培养法.一英雄抢拿4个箱子的经验吃祭坛狂升箭术和作战吃完是7.8级吧~箭术大师(开始没想写战报 就没记那么清楚),分垃圾狂暴出去抢钱抢资源,家里造摔交场准备抢出独眼(水晶不多不造都市1000钱)。
    自然开局,拿了两箱子钱造都市大厅1000钱,分小妖精出去探路抢钱.弓手和法师平均升级。

    2D：力量，招所有一级兵连下金矿和铁矿(双英雄混合为一队).继续偷抢资源.钱不够未造建筑。
    自然：造小林,双英雄分队裸奔探路抢资源吃箱.

    3D：力量,出游牧,双英雄扫荡一级兵。
    自然,出白虎,英雄继续游荡,拿到小钱包每天多250.

    4D：力量，钱不够只造了竞技场。
    自然，造彩虹,英雄继续游荡.小妖精出去探路抢钱.

    5D：力量,出独眼,英雄裸体偷到骑士手套回程。
    自然，出独角.英雄继续游荡,小妖精出去探路抢钱.

    6D：力量,两独眼+双英雄+半人马开始扫荡。
    自然，英雄逃跑回家招兵准备打矿。

    7D：力量，出催生婆(贵族拉),主力扫荡。
    自然，下铁矿下金矿.

    2周具体趋势(一天天写太累了我也没记得那么详细)
    力量，兵力边增加边扫荡中,贵族吃经验树到高级20%产量增加,英雄一专肉盾作战宗师另外一主英雄箭术宗师。
    自然,出螳螂,扫荡中.德卢伊3级魔法城中出水元素魔法,弓箭手箭术宗师。

    3周具体趋势：
    力量，资源不够未出巨兽。出饲养栏准备以独眼为主。第三个野蛮人出山吃箱子到6级。
    自然，差点资源未出仙女龙。扫荡中。弓箭手作战宗师。

    4周：
    力量，扫光所有生物。三英雄等级11 9.7（下同）
    自然，出仙女龙；德卢伊4级魔法,城内有狮鹫魔法。双英雄9.9。1螳螂野战损失。

    5周：
    力量出传送门，连吃升级树。14 12 11。独眼14个，半人马14个(打废金矿损失掉很多)。
    自然，双英雄未吃树 10.10
    最后决战野战，力量三野蛮人14 12.11，全部都作战宗师防御70。14独眼14半人马，抗魔都在50%以上。自然3仙女龙+1螳螂+德卢伊有4级魔法(主要魔法有召唤水元素召唤狮鹫黄蜂群)，弓箭手转将军。实力对比差太多，力量获得胜利！

    对地图感想：野蛮实力太强加有狙击弩的帮忙强很多,实战中野蛮打法基本正常吧.自然亏在没早出金矿,4级生物出的不多,打野兵较 晚获得的经验少,所以等级上没野蛮强,个人认为如果把力量的开始调整下,比如棚车和狙击弩换掉的话可能会平衡点。

    另外还有单机情况下，无S/L的对三个种族的近似模拟：

    野蛮：
    我刚才试着打了一下野蛮。没有S/L，没有RENEW，开局我也选择吃箱子，但是才升到5级。7、8级的真是RP好啊。
    大概的进程是第一天下金矿，第二天下石头。第一个星期出独眼，英雄在周末逃跑回城带领全兵出发。
    第二个星期一路扫荡，主力大概是9级和7级（记不清了）。打掉绝大部分矿和钱。
    第三个星期跳过第一个传送门，周末过桥。主力一个是肉搏宗师，战斗宗师，职业将军，另一个是抗魔宗师，肉搏宗师。第三个英雄 好像高级肉搏？大家都挺抗魔。大概真的打，这个时候该接火了吧。

    自然：
    我又试验了一下用自然的情况。开局没有管其他的条件，RENEW到得鲁依的初始技能有基础召唤为止。大概过程是这样的：
    1D：分单个妖精吃钱、箱子和资源。主力合兵下石头矿，好像损失极其小。城里起二级魔法（但是实际没有好魔法）。
    2D：主力吃祭坛，访问石碑，往金矿走；起1000金。
    3D：主力下金矿。
    ......妖精和狼不断偷、抢资源，城里建设按部就班。
    6D：英雄分出来，逃跑回城，带白马出去打右边的矿。出生物门。
    8D：英雄打下右边的矿，连吃带换，出凤凰。
    ......一路扫荡。
    W3D5：到达地图最上面，面临选择往上走到角上吃树还是过桥，选择过桥。
    W3D6：传送门。

    打到这里我就没有打了。实际感觉自然的优势在于速度。英雄方面一个是三级自然，带专家草药。另外一个是宗师肉搏带专家抗魔（我根本不想要抗魔，但是吃祭坛什么的就是只升抗魔）和高级箭术。兵力为4凤凰、2螳螂和9（大概）白马，100＋妖精。和昨天我自己打的野蛮比一下，大概发展速度差不多，好像还稍微好一点。兵力明显比野蛮强盛，英雄能力不足。

    守序：
    最后终于试验了守序，和以前一样，没有S/L，也没有RENEW。
    D1、打下宝石，箱子变钱，单个兵到处拣资源。
    D2（3）、下金矿，半身人损失过半。
    D5、出灯神，下硫磺矿。
    ......疯狂开图，拣资源。英雄也参与拣资源。
    W2D5、出泰坦，主力带队，开始扫荡。兵力雄厚，英雄连连升级。
    W3D7、传送门。主力英雄四级守序，高级肉搏，初级战术，会疯狂和全减速。死亡魔法中有废除和诅咒，所有召了一个初级死亡 英雄随军。主力兵力为3泰坦，15(?)灯神。

    SSZ评注：感觉野蛮没有魔法还是挺弱，自然的速度有极大的优势,四级兵的速度非常快。守序如果发展条件好，突破了BT的建筑关，实力的确很强。


H4随机大图Order vs Death
作者：mlb1979

    过年放假准备回家前和朋友一起网吧包夜，聊天中我说h4的鬼在大地图上恐怕无敌了，朋友是秩序fans说秩序才强呢，最后就说让事实说话吧，网吧正好有h4急速，就搞了个随机图来玩，规模选了large，他红秩序我蓝死亡难度200，开局我在下方偏右

    w1d1 四下一望，木头是农民守铁是侍从，再看魔法塔，诅咒下毒瓦解……没有废除让我怎么打灯神 .派4队小鬼探路偷，捡资源，城里造死灵转化器，起全部骨头和小鬼共70+排骨和65小鬼下木，排骨剩了38小鬼51，探路小鬼 偷到跑鞋
    w1d2 下铁矿骨头死光小鬼剩20多，英雄往城里走拿跑鞋，造750
    w1d3 走位失误损失一队探路小鬼，发现右边有各种资源矿，其他都好办惟独金矿是石像鬼守……英雄往上方探路一仗没打，兵不够
    w1d4 探路小鬼又损失两队，经济吃紧，造幽灵英雄继续游荡
    w1d5 重大失误:钱只够造吸吸，招不出来，对小鬼的偷功又期望过高造了+1000，结果小鬼没摸到多少，明天算算还是招不出来……英雄发现上方有魔法学院和战斗学院.
    w1d6 砸锅卖铁造吸吸，还剩100多钱，矿卖光.只好再等一天，小恶魔偷到手套
    w1d7 终于招到2吸血鬼，英雄逃回城集合，打下狼守的经验石，心怀大畅连升2级，小鬼摸一钱箱城里造2级魔法，出泥潭，疲劳，虚弱.英雄回走.
    w2d1 英雄回城学魔法，考虑是去右边开矿还是去上边加能力，因为金打不下选择加能力，就往上走，没钱什么也没造
    w2d2 城里招出1吸吸加入队伍，横扫周围1，2级兵，英雄升2级有了专家招魂，探路的多了两对招出的骷髅
    w2d3 打下白虎看的三个箱子，全部转经验，仗着行动力高连打守水晶湖和风车的枪兵，出大师招魂和基本鬼神，还有三级就能招吸吸了
    w2d4 探路小鬼发现右边一队黑马守着路口，英雄打下精灵守的魔法学院，秩序和混乱二选一，想到灯神的复制，就学了秩序，英雄一拍脑袋， 悟出精准，城里赶快造秩序--精准和转移.顿时凉了半截……
    w2d5 英雄边扫荡边往回走，城里再招cc准备会合，又升一级，想到无法对付复制，心情沉重.
    w2d6 合兵向右扫荡，先下了美度纱守的硫磺，在一堆箱子面前停下，守兵是枪，预计明天可以招cc了
    w2d7 打下枪兵，吃箱子后抢劫了牛头守的宝石矿，升到9级出招魂宗师，附近还有一个迷宫，也去打下来，兵力已有6cc50+幽灵，打野 兵已是小菜一碟
    w3d1 打下所有矿藏，惟独金矿的一群石像逍遥法外，看着一天1000的金子拿不到，咬牙切齿又无可奈何.不过探路小鬼传来好消息，偷到 250钱袋，地图已经开了快一半，还不见敌人踪影，估计在左边
    w3d2 守右边路口的黑马好多，一时不敢惹，英雄回走，城里招个贵族当催生婆，命令小鬼分一个回来交钱袋
    w3d3 英雄小鬼都在回城路上，贵族带一小鬼去碰经验石出高级贵族
    w3d4 英雄回城招兵，cc已有15+，幽灵损失了10个左右，决定再去上面打野兵聚cc，下周再打开黑马守的路口
    w3d5 往上直走，周围早被清空一仗未打，小鬼回城交出钱袋
    w3d6 扫荡开始，一天打了3仗招了6吸，城里造3级塔(其实早该造了，老忘记)，没有望眼欲穿的全体废除，只有垃圾魔法:魔法水蛭，还 有驱役幽灵，昏迷中……城里出了回城和群体精准，决定以后主升秩序魔法，英雄转成暗影法师
    w3d7 扫荡中，去战斗学院买到基础战斗和抗魔.准备回城打开路口，派一队小鬼去左边探路，看见一堆好宝物:+750，耐火靴(城周围地 形是熔岩)，死亡护甲，谗涎欲滴看守兵，一副巨大的骨架顶着两只红眼睛，骨龙，又昏迷30秒
    w4d1 英雄兜了个圈子往回走，黑影中出现一金矿!!!白虎守着 ，马上打下，发现一条近路回城，有一窝法师守着，就把吸吸分出来和他单挑，无损杀之，明天就能回家了，而且还能造出大恶魔，激动 中，预先派三队小鬼到黑马处集中
    w4d2 回城起大恶魔，卖矿招之，英雄13级暗影法师，高级秩序基本法觉基本获法，高级战斗基本抗魔，雄心勃勃，招一死亡骑士做副英雄上 路挑黑马
    w4d3 挑黑马+摸经验石，死骑3级升高级战术和进攻，打开路口后小鬼一涌而入抢资源，主英雄升了高级获法
    w4d4 小鬼发现一副城，是混乱城，主力下之，进城第一件事就是造死亡大厅，念念有词:废除废除废除…….睁开眼-废除!!!
    w4d5 扫荡新领地，副城造经验学院，死骑升级出基本防御，兵力如滚雪球般越打越多，计快40的吸吸，一大恶魔，30多幽灵，主英雄升级 出专家秩序.
    w4d6 继续扫荡又下一金矿，资金宽裕准备造副城出黑龙，主力开始往主城方向走
    w4d7 主力继续回走，副城造美度纱，出三英雄盗贼(精选一plmm)游荡吃箱升级

    以后记不大清了，一周周的说吧

    w5 枪兵月，主力回城学到回城魔法后向上杀新出的野兵，去战斗学院买战斗和抗魔，副英雄转职将军，学基本混乱魔法，盗贼mm6级全加 侦察也向主城走
    w6 持续扫荡上方，重点培养主力战斗技能，箱子全部喂主力英雄，吃到两棵升级树修得专家战斗专家抗魔，副城出黑龙，英雄拿到节省钱包 ，钱越来越多
    w7 主英雄如愿修到抗魔宗师转职暗杀者，拜访到魔法大学学得基础生命和自然，可惜没疗伤魔法，白学了生命，将军学基本混乱，副城出女 巫大厅有寻路，死亡法术出恐惧气氛
    w8 回副城招出2黑龙学魔法，吸吸150，兵力强盛不可一世，盗贼mm四处摸经验修到大师潜行，派往上面继续修炼，买到基础生命领悟 疗伤-给主力多好!还买了战斗抗魔转职游侠
    w9 盗贼mm去左下，发现红方踪迹，还差一级修得宗师潜行，主力往左下赶，顺便回两城招黑龙和大恶魔，吸吸200多
    w10 盗贼mm发现红空城无人守，偷之!，招出城里的2泰坦5灯神，红方大哭，主力赶来，红方夺回城后龟缩防守，兵力计120灯，不到 20泰坦
    w11 将红方压在城里，自己在周围游荡继续招魂，又招出黑龙，大恶魔，吸吸若干赶来，有盗贼mm在红方根本不敢出头，发现对方是双秩序 城，难怪灯神这么多
    w12 下红副秩序城，学得驱散，但没学到最想要的传送，将军买到基本秩序，这时天已快亮，建议出城决战，红见龟缩无胜算，同意决战，遂 对决于野外。

    红方秩序:26级战斗法师，宗师抗魔宗师战斗，宗师秩序，高级生命，14级魔法师，大师秩序，20+泰坦，125+灯神，60多 金人，1灯神，1灯神，会传送，催眠，疯狂

    蓝方死亡:27级暗杀者，宗师抗魔宗师战斗，大师死亡，专家秩序，基本生命高级自然，18级将军，大师战术大师进攻，基本混乱基 本秩序，15大恶魔，6黑龙，150吸吸，104吸吸，43幽灵，1幽灵.魔法有吸血鬼之触，恐惧气氛，废除，疲劳，加速

    双方都喝了不朽

    第一回合:暗杀加速恶魔，恶魔杀魔法师，法师重生，将军等待，战斗法师试着催眠恶魔，150吸吸杀金人，秒之，100吸吸打泰坦，杀掉6个，幽灵往前冲，灯神迟缓吸血鬼，复制泰坦，真泰坦防御，复制打吸血鬼，魔法师迟缓另一队吸吸，将军驱散恶魔的催眠

    第2回合:暗杀加速恶魔，杀掉魔法师，将军驱散镜像，灯神复制泰坦打吸吸，损失很大，幽灵冲上去老化了泰坦和灯神，吸吸消灭单个 灯神，打主力灯神，灯神在大师进攻的100吸吸面前死伤大半，以后的比赛彻底成了屠杀，红方大败

    这是小弟第一次玩hero对战，失误好多，其实胜利差不多完全是靠种族优势，想不到亡灵在large地图上这么厉害，大家多多指教战报也是第一次写，就当给大家新年娱乐一下

    SSZ评注：两个教训：第一，随时注意守城部队，以及尽量保持多的部队在野外，保证视野！第二，禁鬼！


浅谈H4微操作
作者：fireway

    好多即时战略游戏都讲就微操作，其实在英雄无敌里面也有一些微操作，在一些特定的情况下能起到很大的作用。
    由于本人水平有限，而研究H3的高人太多，所以不用献丑了，讲讲H4吧。
    H4战斗的情况又太多太复杂，就讲讲大地图的微操作吧--希望能抛砖引玉，让各高手都发表自己的看法。

    在大地图上，能做的主要就是走路、加能力、触发事件、占矿、收集物资宝物，合理的利用各种微操作，可以加快英雄的移动，更快的完成游戏，得到更高的评价。
    第一项操作就是分工合作，最大限度的保证主力的移动力。

    主力：加能力、触发事件（不使用额外移动力、特定英雄触发）
    副英雄：占矿
    散兵：收集物资宝物传给英雄、触发事件、开塔等等。

    其中散兵的应用非常重要的，最有用的是盗贼和招魂招出的骷髅。
    盗贼最大的用处是可以偷到一级兵看守的所有物资及传兵。
    骷髅在一场大战后刚召出，行动力是满的，一只只分出去，把周围的物资捡完，宝物传到英雄身上，再全部解散，英雄一点移动力也不浪费。
    招魂技能提升后幽灵的行动范围更大，当然更好用了。
    再就是召唤技能每天召的几个自然生物，不过实用性要差一点，当然如果是妖精的话可以提高移动力那也不错。

    另：散兵也是可以占矿。有一种矿是还未建成的，要用资源建矿，这种矿不用英雄一样可以占。
    大部分的事件和任务都可以用散兵来完成，极个别的任务和事件指定了英雄触发。

    对于英雄本身，增加移动力的因素大概有以下一些：
    魔法、技能、宝物、生物、增加移动力的设施。
    魔法：寻路、回城。
    寻路，在探路技能不到专家的情况下，每天用一次是非常值得的。
    另：在队伍中用过寻路后，分一个散兵出来，这个散兵继续受寻路影响。(此点由phinex测试，多谢）。（DarkRain.cn注：但分出来的散兵必须是原先的分队，如果是从分队中再分兵，例如从一组10个的妖精中分出单独的1个，那么寻路是不起作用的。）
    回城，非常非常有用的魔法，配合堵城门（我最喜欢两格宽和三格宽的城门了）可以做到大范围的转移。而且，这个魔法不耗移动力的。
    另：战斗画面逃跑应该也算是一种变向回城，缺点是逃跑后没什么移动力了，优点是不用会回城魔法，而且在城边上开战的话，可以逃得比回城魔法更远。
    又另：如果同时有回城和召唤类魔法的话更好，可以召唤之后回城，原理和h/r战术一样。
    再另：有一些城门边有中立生物，城门的一格或更多是在中立生物的攻击点上的。也就是说要走到城门的这个位置就一定得和生物战斗。这样的生物最好不要打，就算后面有几个箱子也别打。因为在使用回城魔法时，不会回到这样的城门点上，相当于变相的拥有了一个三格宽的城。
    这样的情况不是太多，但也决非罕见，在阴云大法师战役中最突出。
    例一：阴云大法师第二关，打过泰坦后的那个守序城边就有野兵，可以当做三格城门来用。配合第二个精灵城（三格城门），可以在五个城间任意往来，这样就可以大大加快过关进程。一开始就不断扩张，不用等城里出各种魔法，只要能打过泰坦，就一口气把全部城都占下来。在此过程中对前期的城进行建设，出加能力的建筑和魔法塔，占最后一个城后，使用回城魔法，只需7步移动力就能把这些城全部访问一次，把该学该加的一次搞定。而不能一步到的两个城刚好是敌人的主城，占下后这些建筑都造好了，也没必要第二次访问了。
    例二：阴云大法师第五关，这关开始有4个混乱城，其中有两个城边都有野兵，利用此点，这4个城可以任意来往，无论是加能力还是调动部队访问马廊什么的都非常方便。

    技能：侦察系的探路、航海。
    在战役里，特别是在多英雄的战役里，学习探路技能是完全必要的，6-8个技能点（看能否买到基础技能）的回报非常丰厚，我本人经常放弃箭术和防魔先升探路。单关地图副英雄学应该就可以了。
    航海技能的加成其实比探路高多了，不过实用性太小，除非地图有大片的海域，一般不用去学。
    宝物：手套、鞋子和耐力药水。
    手套、鞋子没什么好说的。只要注意这些宝物是可以加成的，两个手套可以起到双效，所有这些宝物应该同时装备在探路技能最高的英雄身上。
    耐力药水我准备在后面专门讨论。
    生物：英雄原本的移动力是22，但如果队伍中有移动力超过22的生物，英雄的移动力就等于队伍中移动力最高的生物。
    因此，英雄想跑得快，就得带移动力高的生物，一般来讲，就是指飞兵了。不过节飞兵的速度也不同，最好的是凤凰、黑龙之类的。
    增加移动力的设施：灯塔、马廊、旅馆、集合旗、水槽、绿洲。
    灯塔最好让副英雄去占，其它的顺道访问就行了。
    也有另类的打法，条件是水槽、绿洲之类的比较多。

    所有这些提高移动力的因素加起来效果是很惊人的，理论上，陆地移动力最高应该是166，我本人试过在移动力一栏上显示为144。
    海洋的移动力还未仔细测试，不过灯塔加10点移动力的效果不能累加（由时间猫提醒）。

    以下是我自己在实战在一些常用到的微操作（通常节省的都是几步移动力，的确是“微”）
    1、小心召唤：以小仙子提高移动力时，如果已经访问过马廊、旅馆、集合旗，在当天结束时存盘，保证召唤技能在第二天不要召到小仙子。
    2、城门移动：城门有4格宽，在城门内移动也是要移动力的，可以把队伍全放在城里，让城内一只杂兵出来，移动到相应的位置，再和城里的主力交换位置。
    3、半堵城门：堵城门大家都会的，但一个玩家在外面只能有8只队伍，所以除非城门的宽度不正常，否则只能堵一个城门，但我们可以把另外一个城的城门堵住三格,以增加和这个城的距离。
    例：有A----B-C三个城，英雄在B城，目标是到A城。
    一般只能堵住B城，再走到A和C的中点，向A再走一步，使用回城魔法，才能到达A城。
    如果再把C城离A城近的三个城门都堵上，这样还不用走到A和C的中心点，已经可以使用回城魔法到达A城了。
    4、耐力药水：耐力药水看起来很简单，一天一次增加3点移动力。但这个药水是我的最爱，有野人城或野外铁匠铺可以买时我都会尽量多买。
    这个药水增加的是基本移动力，所以有手套和探路技能之类的是可以加成的，最多可以多走8步，这已经很可观了。
    使用时要注意：如果想让分出的部队受药水影响，就要先使用此药水，再分部队。
    除上述情况外，一定到无法移动时再用此药水。
    因为此药水有一个非常大的特点：在没有海员帽时，是唯一能使英雄在上下船后继续移动的方法。

    听起来也就是移动几点，好象没什么大用，现举几个实例：
    A、上岸攻城法：
    H4的AI是比较低的，但如果电脑玩家发现对手在一天内可以攻到己方城镇，还是会召兵并让英雄回防的，这可能会给攻城战造成很大麻烦。
    如果英雄在海上，电脑判断英雄最快还有两天才能攻城，此时选择离敌城足够近的地方登陆（最好有路），使用耐力药水后就能发起出奇不意的进攻了。
    B、占灯塔大法：
    这种情况并不少见，我方没有航海技能，在海里慢得象蜗牛，海里有灯塔，可上岸要一天，下船还要一天，非常不合算，想让副英雄占塔吧，一来时效上不一定来得及，二来说不定塔前还有守卫，副英雄打不过！
    这时耐力药水就大显神通了，在离灯塔最近的地方上岸，一般会和守卫自动打一架，再喝药水，占塔回船刚刚好。
    这样的微操作其实已经不只是省几步路了，结省的时间是以天计的。
    虽然这个方法取名叫占塔，其实在海上好多小岛上都有非常重要的访问点，同样都可以使用这样的方法。（不过很可能必须要手套、鞋子、探路技能的配合）
    比如：要访问的帐篷、加攻防的建筑、高级魔法、任务小屋、宝石、祭坛等等。

    以上是本人的一点心得，写得匆忙，请多指教，共同提高H4的研究水平。

    再加点分合兵的微操作：
    合兵：
    合兵的动作是一队向相邻的另一队做出合兵动作，然后出现合兵画面，这时把兵合在任何一队都可以，位置不动的那一队不费移动力。
    但是一般人较少注意的是：合兵的动作也是要浪费移动力的，和走一步的移动力相同。
    合兵时两队兵的地图移动力很可能不一样，但合为一队后移动力就以最低的那一队来计算了，所以应该由移动力高的一支部队来完成合兵动作。
    这在英雄裸奔时出现的机率很大，英雄带了一支加移动力的部队，打仗时不能带，要分出去，打完后再合在一起。如果不注意合兵的动作，很可能出现英雄还有十几二十的移动力，加速兵反而没移动力了。
    举个实例：
    阴云最后一关，有五个英雄要合兵，动作合理的话，合兵后还有33、34的移动力，不合理的话，可能只有26、27了。

    分兵：
    分兵前先用寻路魔法，这在前面已经讲过了，现在讲讲其它的。
    分兵一般是分在原部队的右手边，如果目标在左手边怎么办呢？
    这里有一个小窃门，先从最不重要的生物里分出一只来，走到原部队的左边，对原部队发起合兵动作，把希望分到左边的兵调入左边的部队，把走路的那只开除（或放在原部队中一个单独的位置让它再跑一次路分第二次兵），这样就把兵分到了原部队的左手边。
    例：
    在天界英雄4的第一关，主英雄和女法师合兵后可以攻打幽灵营，打下后召的幽灵是一只只分出去捡物资和完成任务的。其中完成任务的幽灵如果是直接分出去，是走不到任务小屋的，就要使用上述方法，用一只幽灵做传递专家，把完成任务的幽灵分在大部队的左边，这样就能刚好完成任务。再把任务所得的矮人分出来去占城，这样在第三天就能占到城了，这应该是最快的占城速度了。

    又想到一点：召唤访问帐篷法。
    一般在船上的部队是不能分的，但如果船在岸边，则可以把部队分到岸上。
    一般有帐篷的小岛都有兵把守（没有当然就更方便），但小岛太小，好些时候在海上即可与守军发生战斗；胜利后，如果有召魂技能，就可分新召的骷髅上岛，第二天用骷髅访问帐篷，就能结省两天时间；再不就得在战斗中保住一两个不重要的兵——比如当天召唤来的小仙子之类的，把它们分出去访问；如果都没有，而又有召唤技能，就在周围转转打打沉船什么的，最好当天靠在岸边，等第二天的召唤生物到了再分上岸去，也能省一天时间。
    例：在天界英雄4的第五关，第一天合兵打完岛上的生物后下海，由于有召唤技能，第二天就有几个自然生物，带上后就在岸边打败守帐篷的吸血鬼和食尸怪，把这几个自然生物分上小岛去访问帐篷。在打完海上所有沉船、弃船的情况下，还能在第四天开红色关卡上岸。


用好疯老头的方法
作者：clicli

我想野蛮人战役开始的难度很大程度上是由那个疯子———berserker造成的。如果不是他不听指挥，他不会那么容易牺牲。每次看到那个疯老头提着把斧子冲进company的敌人的包围圈，我的心都不禁一阵刺痛。年纪一大把了，怎么还那么冲动呢？为什么不能先wait呢？为什么不等我派个半人马先替你赚个反击呢？如果他听我的，这关的难度就降低了一半！所以这关的一个重点就是要想办法保护好和利用好berserker。

我的方法是，采用三角阵形，用半人马把berserker包在中间，等到合适的时机，就开门、放狗！这点说来容易，在真正战斗时，很难把握，好在打仗时可以存盘读盘，那就勤快点吧。

DarkRain.cn注：这是clicli所写的野蛮战役首关打法的一部分，是论坛里第一次有人详细提到“堵狂暴者”的战术。但实际上在此之前半个月shaka就提到过这个战术，但语焉不详。在clicli之前sloth和sharpshooter也分别提到过此战术。


灯神使用的一些技巧
作者：DarkRain.cn

    一般情况下，灯神分组总是越多越好，但在有些时候却需要刻意减少分组，这涉及到野兵的分组规律。

    野兵分组数会随着我方部队分组数的增加而增加。如果野兵是由单一兵种组成，则分组数有上限，非远程部队（地面或飞行）最多分4组，远程部队最多分3组（法师、灯神、水元素、仙女龙这4种魔法部队视同远程部队），那么此时我方灯神分组当然是越多越好。但野兵不只由一种兵种组成的时候，情况就复杂了：一种非远程+一种远程，我方部队分7组的情况下，野兵也会分7组，而且远程部队会分3组，并且站在后排，前排的非远程部队会阻碍到我方灯神的施法视线。此时我方部队最好只分5组，这样敌人分组情况便会是4组非远程+1组远程，我方采用分散阵型，站在1号和2号位的灯神都可以对敌人远程施展和平之歌。如果野兵由3种或是更多的兵种组成，分组情况会更加复杂。

    我方阵型排布需要根据敌人的情况而变化。像前面提到的非远程+远程混编的情况，我方应该采用分散阵型；如果敌人是速度和战场移动力都比较高的飞行部队，那么我方应该采用紧缩阵型或是环状阵型，以避免敌人第一回合就飞过来攻击，让灯神有时间施展迟缓魔法。

    用灯神，最不愿意见到的情况就是敌人胡乱移动，挡住灯神的施法视线，或者是敌人士气高昂，在灯神之前出手，破坏我方原有计划。所以很多时候，都至少要留1、2队灯神等待，等敌人行动过后再根据实际情况选择使用振奋魔法或是移动到更合适的位置上。


打野灯神的方法
作者：水云，DarkRain.cn

    关键就是驱散或废除（必备魔法）。紧缩阵型，几个垃圾兵站前面做保护（最好是矮人这样移动力低的），中间放灯神，英雄。野灯神的魔法只能攻击到垃圾兵，所以它不感兴趣，改用辅助魔法，有可能是对我方使用懦弱，或者是复制。我方灯神数量至少要不小于敌人的38%，保证三次冰箭可以灭掉敌人一组。在敌人复制出来的兵走到跟前的时候，英雄在驱散了自身中的懦弱魔法后，把它们驱散掉就是了。

    如果我方灯神数量不够，但是有回城魔法，可以用h/r消耗敌人。开始灯神对英雄使振奋，保证英雄先于灯神行动。在敌灯神加了振奋、我方中了怯懦和迟缓之后，每回合开始时敌灯神一般会先等待，然后轮到英雄行动，用驱散除去灯神的怯懦，然后灯神冰箭。轮到敌方的灯神（等待后）行动时，两组会给我方灯神加迟缓和怯懦，剩下一组可能会用幻象。一次战斗下来大约可以损耗我方灯神两倍左右的敌灯神，然后用回城术逃跑，多折腾几次，一直到我方灯神数量大于敌人的38%为止。

    SSZ评注：这个问题以前讨论过很多，刚刚放上网页以后又引发了讨论。其实这里的情况是很多的，主要的想法是让野灯神不停用怯懦，振奋，幻想等非直接杀伤性魔法，消耗它们的魔法值。相应的，我方就要有驱散、废除、驱魔（不用全有）等魔法，如果有群体驱散魔法就再好不过。为了不让野灯神直接用冰箭，就得用垃圾兵在前排保护。这种保护战术经常用到，很多时候对远程兵也有用。


关于打野灯神的一点补充
作者：fireway

    这是很早之前的心得了，刚刚忽然又想起了………………

    灯神在H4里是非常强悍的生物，特别对初学者来说，打灯神简直是恶梦。
    据我所知最早打灯神的方法是水云提出来的，后来这个方法被Darkrain在东方卷轴原版有序战役攻略里使用，已经成为一般人打灯神的正解了。

    这个方法是这样的：
    紧密阵型
    第一排：1矮人，1矮人，1矮人
    第二排：1灯神，主力灯神，1灯神
    第三排：英雄
    要求：英雄会驱散魔法，灯神数大于野灯神的38%。

    实战时，野灯神不会用冰箭来杀矮人，而会复制或用其它魔法，英雄驱散幻像，主力灯神每三箭杀一组灯神，最后还剩下的一点灯神用矮人骗反击杀死。

    当我打原版有序时，打到野灯神前时，发现野灯神是76只，38%就是29只，但我只有16灯神+8那加，家里也就2、3只灯神，如果按攻略的做法，必须再等10天以上的时间才可能打过这组野灯神，太耗时间了。
    于是我对原打法进行了研究，发现：
    三个矮人不是必须的，灯神不进攻矮人，不是因为矮人的抗魔能力，而是因为电脑判断复制能给自己带来更大的好处，那么把三个矮人换为三个单组的灯神是可行的。
只要把那加放入部队，让电脑感觉复制一队那加远胜于杀死一只灯神，就可以达到目的了。
    我把阵型变成:
    第一排：1灯神，1灯神，1灯神
    第二排：1灯神，12灯神，英雄
    第三排：8那加
    单个灯神迟缓野灯神和复制出的那加，给自己全部加上振奋，英雄驱散幻相那加，主力灯神复制那加。
    等野灯神用完魔法后，再用那加进攻，单个灯神给野灯神加和平歌。

    用这个方法，很轻松就以16灯神打下了76灯神，其实更少的灯神也能打过。

    另外，野灯神不能太少了，少到一定程度，它就会放弃复制转而用冰箭杀单个灯神了。


资料片《阴云密布》中，吟游诗人打雷鸟
作者：DarkRain.cn

    本战役中，第二关地图中间有不少雷鸟。打法是：环状（紧缩）阵型，英雄单人七号位，第一回合招水，雷鸟速度比水快，但是打不到英雄和水，于是就等待。疲劳雷鸟后它两回合打不到英雄，所以第二回合招妖精是可以把雷鸟向后引一点的（不等待直接飞到其身后），水元素看站位，如果不安全第二回合就要跑开。第三回合继续招妖精，这次不用直接飞到雷鸟身后了，等待，第四回合再去引，能把雷鸟一直引到右上角。英雄和水则在第四回合跑开。第五回合应该安全了，可以使魔力闪光，然后就是水元素冰箭，间或招妖精引雷鸟，有魔力闪光魔法值肯定够用。招妖精两、三回合用一次已经足够。这里面有一个问题，就是关键的第四回合，如果雷鸟士气高涨的话会很麻烦。第三关中间有随机的四级兵。如果是单独的雷鸟，如上。如果还混了独眼，多带一只仙女龙过去就可以了。


再谈召水打飞兵
作者：DarkRain.cn

    很早以前就提出过这个打法了，但感觉至今仍有不少人没有掌握。这其中有两个问题：一是我当初讲得比较粗略，造成有些人理解错误；二是有些人没有体会到这个打法的适用范围有多宽，所以不够重视。因此，有必要再详细讲述一遍。

    一般召水打飞兵是针对单独的飞兵，没有兵种混搭的情况下，单英雄上阵，站环状阵型的7号位。

    第一回合：敌人打不到英雄，会先等待，英雄召水，水疲劳飞兵。
    第二回合：水往旁边走，英雄召妖精，妖精等待后冲上去攻击。
    第三回合：英雄站7号位的情况下，只要敌飞兵不是天使、凤凰这样移动力15码的，则此回合敌人仍然打不到英雄，英雄可以等待。妖精尽量往敌人身后飞，但注意要在其攻击范围内。妖精被敌人打死后，英雄再召一队妖精。
    第四回合：妖精再把敌人勾引远。同样，必须要送死，这样才能成功地把敌人向后吸引。
    此后就是每2回合召一次妖精，等待后用送死的方式将敌人牵制住，水元素不断用冰箭进行攻击。平常打步兵的时候，是等水元素魔法值消耗完后再召水，但打飞兵的时候，因为需要每2回合召唤一次妖精，8回合下来就要消耗8点魔法值，比召水的花费多，因此在低数量水元素的阶段停留太长时间就显得不划算。可以根据敌兵生命总值，预先算出一个合适的数值，尽量快地把水元素数量增加到那个值，然后再慢慢消耗。

    可以看出来，除了召水之外，召妖精也是必要的魔法，利用的是妖精的高移动力。再往上，有这么高移动力的召唤就只有风、狮鹫等等了，那样魔法值消耗太大。不过如果有幻象或是操尸权杖，就可以利用敌人来直接产生高移动力的诱饵，可以不用召妖精，省不少魔法值。

    前面打法中特别提到了天使，天使并不是不能对付，只是打法需要稍作修改，第三回合英雄和水元素都要跑开。而对付凤凰时，因为其疲劳后速度仍然有6，勾引它的就只有速度7的风元素可以胜任了。不过凤凰死一部分后会发呆（站在原地使用复生魔法，但总是失败），相对还更容易些。

    每2回合召唤一次妖精，看起来魔法的消耗会非常大，实际上并不是。我曾经测试过，5级德鲁伊，召水一次3个，打35狮鹫时耗费41点魔法值。

    如果从省魔法值的角度来看，其实还有更好的打法，就是配合加速。加速过的英雄等待后连走两次，可以轻松逃避已被疲劳的飞兵。但此时妖精的召唤仍然必要，因为水元素的魔法有用完的时候，有妖精的牵制作用，才能让英雄有空余回合来继续召唤。配合加速魔法，召唤妖精的次数可以减少不少，像前面所说的那个例子，大约可以省6点魔法值。

    不过加速打法我本人是不推荐的，因为操作控制上要求高一点，有点费事。另外在敌人士气尚未降为0的时候，加速打法是存在风险的，就是说战斗开始阶段最好别用。而纯粹的召水+召妖精打法，即使敌人士气高涨也不会有多大问题，只是要多消耗一些魔法值。加速打法一般只在特殊情况下使用，例如魔法值紧缺的时候。另外一个应用则是用来对付鸟妖，因为鸟妖攻击返回的特性，纯召水+召妖精打法对付不了，但是考虑到其移动力只有12码（38英尺），加速后摆脱它相当容易。

    以上讨论的都是打单飞兵的情况，如果敌人是多兵种混编，则很多时候需要带1仙女龙来辅助，才能够打。

    总体来看，召水打法的适用范围是非常广的，除了众所周知的打步兵用途外，亡灵类和黑龙、仙女龙之外的飞兵都可以打，包括灯神（只是打灯神会比较累，很可能无法一次搞定）。亡灵类的飞兵，加上迟缓魔法或是蛛丝箭之类的就可以打了，而如果有“反魔法”（Anti-Magic），并且英雄抗魔宗师，仙女龙也好对付。

    召水的另外一个优点就是前提要求不高。曾经看到有人评价说：“何必那么麻烦，召唤仙女龙或是催眠就可以了”，但那都是五级魔法，而召水仅仅是一个三级魔法而已。像前面举到的例子，换另外一个5级英雄来，在没有特殊宝物的情况下，打35狮鹫需要带多少兵呢？而一个召水数量每次7个的英雄，打55雷鸟只要消耗50点左右魔法值，这难道不令人心动么？对于英雄个人来说，战斗技能、肉搏技能等等在召水打法里完全可以不加考虑，所以召水打法的实现是很容易的。

    召水打法的唯一问题就在于魔法值，因此在交战之前要牢记一个原则：量力而为！英雄等级、技能是开打前必须要考虑的，战斗获胜后能得到多少回报也是要考虑的，不可盲目。像是建铁匠铺买魔力药水的事情，就必须在探开周围地图后，对先期投资能够在多长时间内得到回报作一个大致的判断。

    魔力闪光对召水的帮助是很大的，但最好是主力亲自学到才比较有用。双英雄上阵，对付步兵没有什么问题，但在召水对付飞兵时，因为敌人分组增加，会徒增许多困难，往往导致打不赢。


在BT地图中打大量魔法型部队时使用的一个战术
作者：zcr

    1、英雄带上一定数量的灯神，使用魔力闪光。
    2、灯神不断幻象自己，制造的幻象达到一定数量或超过原有的灯神或后也开始幻象自己。
    3、其他英雄或单个灯神对敌人（部队或英雄）使用和平之歌或致盲之类的控制魔法，使其不能攻击己方或行动。
    4、让队伍中自带或用各种魔法召唤出来的恶魔之子吸取敌人魔力补充给灯神。（如果条件允许，英雄在战前应该尽可能提高自己的魔法点数 ，使吸来的魔力不会传给自己。）

    这样，产生的效果相当惊人，灯神的数量以1.3 指数方式增长，很容易制造出几十万个灯神，而且制造出来的灯神是有法力点数的！一次冰箭有几百万点的杀伤力，如果有强力战术英雄的支持，肉搏杀伤力也很惊人，我的550个灯神造出的五十几万灯神幻象打人鱼野兵一次伤害值达一千五百多万点，这时如果有更强力的兵种在战场上可供制造幻象更好。

    这种“zcr式幻象”是兵力膨胀最快速的方法了。缺点在于：敌方有邪眼或有机会使出单体或群体驱散、废除魔法时此法就比较脆弱、冒险了；灯神数量达到477218 个就不能再幻象灯神了，而应该幻象其他兵或发冰箭，否则幻象的灯神的冰箭和幻象的点数将会突然变成负值，不能再使用幻象，冰箭的 杀伤力也会无效。

    受此启发，对天使、法师、灯神、邪恶女巫、恶魔、凤凰、仙女龙的法术杀伤力进行了测试，发现各种魔法都有一定的上限，达到上限后 开始便复或变1，特点如下：

    幻象、复活、重生、攻击类魔法达到某一数值时都会突然变负值，随着队伍中数量的增长又增长变零直到达到上限值再次突然变负值…呈现“百叶窗式”的曲线。
    法师的驱役骷髅和恶魔的召唤冰魔数量在达到上限后变为1。保持为1个一段之后，法师数量达到某一数值时开始增加再次达到上限，变1个…循环。而冰魔数量保持1个一段，恶魔数量增长达到某一数值时招出的冰魔会突然从1个变为上限的43%，然后增长到上限，再变成1个，保持1个一段后开始到达下一个增长点，才完成一个循环。
    效果上限多与基本效果*214748有关，之后每到这个数值又开始下一循环。基本效果参照英雄施展时来计算而不是根据魔法兵种的杀伤力算，如灯神和水 元素的冰箭都是40，而不是18和11.2。
    负数魔法效果和1召唤效果在战斗中只取决于参战前队伍中生物的数量，若在战斗中有损失，效果不变。具体结果见图表。
    攻击类魔法：灯神和水元素的冰箭，法师的魔法拳和下毒，仙女龙的火球火环闪电，邪恶女巫的爆裂（驱逐仍不受部队数量的影响），在向敌人施放时敌人会出现中招的动作，但不会有任何的数字显示，没有效果，可被魔镜反弹，也不会对自己造成伤害。但被下了无效毒的 部队接着又被下有效毒的话，则不能再对它下无效毒了。
    复活类魔法情况之一：当凤凰的重生点数为负数时，部队若伤亡了一部分使用重生，则生命值会显示这个负数（但显示不完，如-21474812只能显示-2147 ），而天使复活部分伤亡的部队效果也类似。此时若对其使用正效果的复活或治疗或吸魔给它后再重生，都可以用但会无效，如果使用负 值的复活，则负生命会继续加上负数的复活点数，重复使用，则负值不断扩大，生命变负后，使用巨龙之力或巨人之力，不会改变负值大 小，只会改变单个个体的生命上限，若受到负伤害效果的魔法攻击不会造成影响；而受到有效攻击（魔法、肉搏或远程）则会用相应的正 数生命抵消负生命再减掉有效攻击造成的伤害，所以会出现1灯神秒8万多天使或1恶魔之子秒14 万凤凰的情况，理论上任何的有效伤害可以瞬间杀掉任意数量的部队，只要这支部队的负生命绝对值够大。负生命恢复正数的一个办法： 使用吸血鬼之触+恐惧气氛吸血吸回来。
    复活类魔法情况之二：当凤凰的重生点数为负数时，若队伍还可用重生时被全灭，则尸体会出现重生的动作，站起0 个凤凰（存档再读档后不显示部队数量），实际上仍是完全等于尸体，此时只有对尸体可用的魔法对其有效，如果其他部队被全灭，则显 示战败。天使的负数复活效果复活全灭的部队同上。这种“站着的尸体”可以被酸液摧毁，可以被驱尸类魔法用作驱尸材料，可以受抵抗 死灵魔法影响，可以被复活，但无论用正效果还是负数效果的复活魔法，只会使它再次倒地然后再次站起 0个，其它部队可以站在它的位置，站上去后就不能对它使用复活魔法了。

    上述情况在中文TGS2.2和英文WOW3.0中测试，测试得并不完全，例如大量雷鸟攻击时附带的闪电伤害和食尸怪的毒击效果就没有测试，希望有爱好者加以测试，也希望有高手 对上述怪异现象加以分析、解释。

    SSZ评注：这个战术中值得学习的是灯神的滚雪球的复制办法。恶魔之子是一个关键，不然无法滚起来。至于里面的数值波动，是内存高位溢出，修改了另外数据的符号位造成的。


魔法补充的BT方法
作者：fireway

    不是全BT，只是最后一条。

    英雄有一定级别后，一般一天要打好几次战斗，如果没有城和泉水补充魔法，魔法值是一个比较大的问题。

    解决方法有几种：

    1、买魔法水喝，又简单又快捷，不过有的地图没地方买，或者没钱，就受限了。

    2、多英雄时，在有五级魔法塔的城中，调整装备，可以增加很多魔力。
    如果有较多加魔法宝物，一般一会分给几个英雄用。
    比如：闪光戒指、法师王冠、缪斯项链一般都是召唤英雄使用。
    天使羽毛斗篷一般是肉博英雄用。
    行路之靴是探路英雄穿。
    在一个有五级魔法塔的城里，把这些加魔法的物品全穿在一个英雄的身上，可以增加近百点的魔力。
    然后再全穿在第二个英雄的身上，退出城镇画面，再进入城镇画面，又增加了近百魔力。
    以此类推，可以让全队英雄都增加大量魔力，而且不用一点移动力。

    此法对喝泉水也有效，但要消耗移动力。
    此法对单英雄也有一定意义。

    3、用召唤的恶魔之子吸魔法
    恶魔之子吸魔法，一般是用来对付魔法兵种，用防魔兵种挡在前面，吸光魔法后再进攻。
    但在英雄魔力不够的情况下，也可以做为魔力的一种来源。

    A、打有魔力的野兵
    尽量让野兵多分队，最好再用魔力闪光，让野兵少耗魔法，然后召唤、镜象恶魔之子，加上操尸，尽快吸干魔力。
    一队水元素，基本能为英雄提供约50点的魔力，不算少了。

    B、在战斗中，控制对方的的魔力冰种，直到吸干魔力再杀。
    这种情况下，邪恶女巫、仙女龙最有用，一次可加几十点魔力，其次是灯神，再次是水元素，其它的就得看情况了。
    梦魇兽、恶魔魔力太少，如果只有这一种魔法生物，没必要吸魔；黑骑的魔法值不算少，可是难以控制。
    控制方面，肉兵以加了恐惧气氛的冰魔冰冻是完美的打法；黑骑就只能迟缓后加流沙；水元素威力不大，搞个镜象水挡前面就行了。 　　C、在战斗中，如果敌有恶魔之子和魔法兵种。
    就清光其它部队，控制魔法兵种，给恶魔之子加迟缓和老化，用快兵调动它。
    然后，每次打死一只魔法兵，用操纵尸体操纵起来；操尸部队是满魔法的，让恶魔之子吸它的魔法给敌魔法兵，我方的恶魔之子再吸对方魔法兵的魔力。
    理论上，如果对方有100只邪魔女，可以给英雄吸5000的魔法值；不过实际操作上太耗现实时间了。
    所以，此法只是在不得已的情况下才使用，但在特定的时候，会有极其大的威力。

    BTW：此法我只使用过一次，一天之内要打六战，当时是第五战，魔力已经见底，准备打完就回城休息了。
    灵机一动，用此法得了200多魔力，结果第六战打得很爽。


在《和平的代价》中，击败黑龙的方法
作者：水云

    第三关最后的20黑龙，其实纯用守序魔法也可以打的，就是传送。

    带上一个泰坦（打龙别带多，会有损失的，用一个来镜像就够了），最重要的是英雄要保证速度达到全场最高，别受士气影响就行了。

    一开始让英雄等待，灯神镜像泰坦（第一回合龙打不到的地方），等龙飞过来后，英雄把灯神传送到龙打不到的地方，第二回合再把英雄自己也传送过去就行了（如果你的英雄可以单挑两条龙，就不必了）镜像会一直吸引着龙，英雄和灯神继续扩充镜像即可（原版游戏中，英雄跟灯神要用同一种魔法，因为二级、四级两种幻象魔法产生出来的部队不能合并。而在1.2及更高版本游戏中就不再存在这种情况）。

    众人的附加讨论：如果英雄速度实在太慢，第一回合英雄可以复制泰坦，灯神对英雄用振奋，第二回合一开始英雄就可以把灯神传送出去。这就是英雄速度不如黑龙快的方法，就算速度比黑龙快，也可以预防黑龙士气高涨，但是要求英雄有一定抗打击能力，能够保证第二回合不死。如果不行，第二回合只好传送自己，要牺牲部分灯神。


再谈如何杀黑龙
作者：fireway

    以前讨论过如何杀1000条或以上的黑龙。一般结论有两个：

    一是用大否定戒指使黑龙受魔法，然后可用多种方法杀之。
    二是用强力英雄带无限不朽药水，喝药水单用反击打死黑龙。（要注意秩序，不要被黑龙连打两下。）

    后经过一些BT地图的考验，本人对此总结了两条实用的打法：

    方法一：击败几千条黑龙的条件是有四-五个英雄，其中至少有三个会神圣介入，全部会召唤一些自然的小生物（二级即可）以及传送魔法及足够魔力（好象200点就够了），再有一个强力英雄，宗师肉博。
    第一回合先等待，等黑龙行动过之后，召各种生物；
    第二回合把三个会神圣介入的英雄分别传送到地图的三个角上，把各种生物分散，不要被黑龙一网打尽。此时要注意两个诱饵英雄的位置 ，做到能被两队黑龙打死，而两队黑龙处在可互吹的位置上。用未行动的小生物（小仙子除外）在合适的位置攻击黑龙，造成黑龙巨大的损失。
    第三回合复活英雄，再来一次，当黑龙数量不多时，用强力英雄解决之。
    注意事项：尽量先杀死一队黑龙，三队黑龙的威胁性小多了。千万别让三队黑龙盯上三个会神圣介入的英雄。此方法脱胎于H3的耗龙战术，由于本人H3的水平不高，语言表达能力也一般，说得可能不太清楚，见笑。

    方法二：此打法在实战中还未使用过，是本人因方法一打得太累，苦思而出的方法。窃以为要求简单，使用方便，比较精细。要求：英雄会召螳螂、召狼、推移、传送魔法，有一瓶不朽药水，魔力值足够，英雄速度快过黑龙（8就足够了）。方法：英雄单人站四号位紧缩阵型（其实并不重要，增加点气氛……），黑龙只有一队。
    第一回合：英雄等待；黑龙飞；英雄召螳螂，螳螂向右上角飞。
    第二回合：英雄等待，螳螂飞到右上角；黑龙杀英雄；英雄复活后传送自己到右上（不要太边了，黑龙打不到就行）。
    第三回合：英雄召狼（狼不要士气啊），螳螂等待，狼等待；黑龙向右上飞；狼骗反击，螳螂攻黑龙，定身。
    第四回合：英雄用推移把螳螂推开，螳螂防守（以后螳螂也只能做这个动作）；黑龙……黑龙……定住了！
    第五回合及之后：爱怎么打怎么打……

    注意事项：
    不要用传送把螳螂送走，不然你会后悔的。
    前四个回合别让黑龙士气。（这还用说吗？）
    注意魔法值，特别是召远程兵打时，要召到多少才开打要算好，不然没箭就惨大了。
    螳螂走了以后龙旁边不要有它够得着的目标，不然它一攻击就有能动了。

    SSZ评注：两种打法都是很常用。第一个打法在非BT地图里面，用小兵耗守路的龙是很好的选择。另外传送也是一个关键。一个魔法补血，一个强力肉搏的组合，再配合第二个回合一开始的传送，是最常用的杀龙办法。最后，本文说到的定身实际是个BUG，螳螂定住龙以后存个盘，下回合直接飞走就可以了。如果定不住，读进度以后再飞走就一定能定住。


还谈一谈杀黑龙，测试结果令人吃惊
作者：fireway

    “龙是极难宰杀的，因为它们的厚皮里渗透着古代魔法，只有最强大的魔咒才能穿透……”——摘自哈利·波特与火焰杯

    确实，除非有大否定，我们无法给黑龙施法，连大法师套装都不行，所以杀龙真是很难。

    但……龙生来就是给英雄杀的。^_^

    七个40级的英雄，全部不会神圣介入，所有装备只有一个龙鳞甲、二个健康戒指、六瓶不朽药水、健康药水和力量药水各一；队伍中最强的英雄穿上龙鳞甲后攻为90、防为160；队伍士气为+1，所有人的魔法值不超过50。
    他们还能杀多少黑龙？先想一想吧，本文最后我们能找到答案吗？

    我们讨论的是杀纯龙军，也就是说，没有其它可供疯狂、催眠的生物。

    我打黑龙的方法其实也很一般，是很早前从英雄世界学来的。
    就是带散兵让黑龙分四队，再L/S/L地形，找一个只有一队黑龙能打到的地方（如果有传送魔法，这个地形出现在地图任何一个角都可以，左上最好），给自己加上生命和自然的低级防御魔法，轮流和每一队黑龙单挑。
    这些魔法包括：振奋、幸运、重生、精神甲、石肤、巨人力、混乱抵御、防护、天堂盾、祝福。
    这个方法的优点是条件简单、英雄易培养，如果有足够的技能买，那只要升两级就能学到专家生命+高级自然。
    这个方法的缺点是要加的魔法太多，而黑龙第二轮就能打到英雄，英雄忙于治疗，没机会给自己加魔法。缺点是如此的明显，以至于大大减少了英雄能挑战黑龙的数量。

    为此，我做了一点小小的改进，
    1、散兵不是乱选，而是用丛林妖精和半羊人，这样它们就能帮英雄放两个极重要的魔法。丛林妖精可以通过召唤技能每天召到，半羊人就只能从生物门召，并提前走到黑龙附近了。
    （这里振奋是极其重要的，它提供的25%额外进攻力已经很不错了，更重要的是保证黑龙无法连打英雄两下。）
    2、战前喝力量药水和健康药水，战斗中喝医疗药水治疗，这样基本一瓶医疗药水就可以保证英雄施一个防御魔法了。至于不朽药水，反而没必要了，因为一旦被黑龙打死，所有防御魔法全没了，复活了也没用。
    （SSZ笑我是药罐子，还是有道理的……^_^）

    第一次测试：
    1、英雄使用40级、攻40防160（已穿龙鳞甲）；另外我给英雄加了一个健康戒指，这是我最喜欢的宝物之一。
    A：打400黑龙，结果是极轻松，用魔35点、医疗药水2瓶。
    B：打500黑龙，初期黑龙不能连出两次高攻击，用魔38点、医疗药水4瓶。
    C：打600黑龙，基本打不过。
    D：打550黑龙，极难打过。
    结论：这样的英雄杀龙数在500-550之间。这比我想象中已经好很多了。
    2、由于一般英雄没有这么高防，我把阴云5个英雄的攻防取了个均值，结果是攻90防90（穿龙鳞甲后115），其它条件一样。
    A：打400黑龙，能过，用魔4x点、医疗药水5瓶。
    B：打450黑龙，医疗药水用完，来不及治疗而被杀。

    结论：
    1、就算英雄不太强，也能杀好多黑龙。
    2、像杀区区78黑龙完全没必要用召凤凰来杀。测试时我使用了阴云大法师的攻防，攻67防49、30级、取消健康戒指、把龙鳞甲换成生命甲、多给一个抗火药水，结果一样是很轻松杀78龙。
    另外，在这次测试中，还有两次出现了耗龙机会，其中一次刚好是打600黑龙中第一队进攻龙被耗，所以这次是打过去了，但毕竟机会很少。
    但如果我方英雄有战术技能或加生物行动力的宝物，那这种机会就是可以创造的了，应该会好打一些。

    第二次测试：总的结论是不是就是说英雄战法和召唤战法差不多，只不过一个用魔法水，一个用医疗水呢？不是，因为英雄战法还有改进的空间。
    英雄法讲究分队，除了二队有用的散兵外，还可以加副英雄来帮主英雄加魔法。
    所以加了一个只会高级生命的副英雄，其它条件和第一次一样。
    测试结果是相对第一次可挑战的黑龙数都有增加，但增加的数量不太大，关键是因为重生的生命值（只有基础灵性，每回合恢复120点生命）在很多时候跟不上，而我测试的英雄只带了5瓶医疗药水，所以结果总是药尽人亡。
    如果我没记错的话，160防的也就能杀到650-700的黑龙，防115的只能杀450-500。

    结论：增加副英雄可以解决太多魔法来不及加的问题，但无法解决每回合恢复生命小于黑龙伤害值的瓶颈，这个瓶颈就是英雄能对付的黑龙数。
    BTW：此时如果用重生的宝物就更惨，因为连基础灵性的20%加成都没了，每回合只能恢复100点生命。

    第三次测试：
    本来这中间可以进行多次测试的，但没时间了，就进行了最终测试。
    穿龙鳞甲英雄90攻160防，这和我阴云生死战役的英雄最后数值差不多，英雄带2个健康戒指，其它同上。
    魔法方面，开放了所有高级魔法，包括龙力和吸血。
    副英雄方面，安排了两个低等的副英雄加魔法。
    测试令人吃惊：
    由于吸血的出现，英雄完全突破了重生魔法量的限制，英雄有没有重生魔法已经不重要了。
    加了龙力、巨人力和祈祷后，英雄每一击可以吸血25XX，而600黑龙只能造成约900的伤害。
    只要英雄可以受黑龙两击，有时间加上吸血魔法，就立于不败之地了。
    结果是非人族英雄可以挑战2000只黑龙，而人族英雄更可挑战2500只黑龙而面无惧色！
    这个结果是我完全没想到的，这还是黑龙游击队吗？2500黑龙在任何地图上都是一个大军团了！

    结论：这次的测试有了一个极大的突破。

    第四次测试：
    本文开头提到的题目，我们将向最高的极限冲击。
    在使用高级副英雄加魔法的情况下，能对付多少黑龙呢？（神圣介入不在考虑之列，有了它多少黑龙都没问题--只要魔法值够）
    由于高级英雄的加入，主英雄不用受黑龙两击来施魔法，最好主英雄一直处于防御的状态，这样可挑战的黑龙数是一个极大的数值。
    理论上，我计算到可以单挑10K黑龙！

    （DarkRain注：吸血打法有一个重要的缺陷，就是黑龙士气高昂或低落时会导致英雄在某回合无法反击，也就无法反击吸血。具体规律可以参照回合与反击规律的说明。必须要时刻关注黑龙的士气，在不反击状况可能出现的时候，用传送来避免。）

    总体结论：1、召唤魔法能对付的黑龙应用简单的英雄战法即可对付，而英雄战法的潜力长久以来被严重低估。虽然还有些地方不太清楚，但单就已知的情况，已经大大超过了其它方法。
    2、凤凰打法还是有其存在的价值，对于一个防极低的英雄（20以下），只要有足够魔力值，也能对付黑龙。
    3、在测试中使用了40级英雄，在普通战役里，这个级别有点高，只要按血量比例减掉相应的黑龙数就行了；在BT战役里，级别会比这个高好多，按相应比例可以增加挑战黑龙的数量。

    在测试中一直使用龙鳞甲，这个宝物可以使英雄挑战的黑龙加倍，有的人可能不以为然，觉得这个宝出现机会不大。
    其实这也就是一个火抵抗的获得问题。
    寒冰天平：让英雄获得“混乱抵御”和“火抵抗”状态，这是打黑龙的极品啊，装上后黑龙伤害就降为原值的1/3了！可惜，此物只应天上有，人间难得几回见。
    龙鳞甲：这见得多些了，不过也不是想有就有，完全要看人品了。
    抗火药剂：这个可就是平常百姓家就有的了。秩序城可以造、野外铺子也可能买、打宝库可以抢，路上、马车上都能找到，来源很多。
    所以，火抵抗并不是难于得到的状态。而穿秩序甲喝抗火药跟穿龙鳞甲用混乱抵御魔法，差别很有限。

    用到的其它宝物，也就是健康戒指和药水，都是常见的。另外，如果实在找不到药水，找个能量池喝口水也一样。


耗龙法的研究
作者：fireway

    不过没图，要多用点想象力

    耗龙法，就是用实力远不及黑龙的生物攻打黑龙，利用黑龙气息攻击的特点，骗黑龙在反击时误伤同伴，黑龙越强，误伤也就越严重。
    对另一个气息攻击的生物——凤凰，此法无用，因为它是火抵抗的，气息攻击的波及对它无效。

    耗龙有几种情况：
    1、英雄耗龙
    2、英雄带生物耗龙
    3、生物耗龙

    第1、2两种情况应用面不广，只是在一些特殊情况下才比较好。
    其中：英雄耗龙，应该总是以一个回城魔法或者一个逃跑做为结束，对付就在城边的龙比较有用。
    英雄带生物，应该只是起战术作用，目的是在没有耗龙生物的情况下用战术技能或者宝物提高所带生物的行动力，变成可耗龙的生物。
    这两个方法都因为英雄行动力的限制而难以做到连续耗龙，应算耗龙法里的偏门。

    第3个方法，也就是生物耗龙，应该是耗龙法的正解，现对此做一点研究。

    耗龙生物：
    1、比龙快或者至少和龙一样快的生物才有可能耗龙，其它的免谈。
    2、便宜、量多的生物才有耗龙的本钱，象凤凰、螳螂、天使之流不知要多少时间才能凑够耗龙的数量。
    3、有“打人不还手”恶习的生物不能耗龙。妖精、吸血鬼、那加都不是好同志。

    经以上条件限制，能组成敢死队的生物如下：
    比龙快的：白虎、游牧人
    一样快的：盗贼、十字军、狼、风元素、石像鬼

    耗龙效率：
    黑龙每次误伤，平均可耗5%黑龙。
    如果一次耗龙误伤一次，那么14次耗龙后可使黑龙减半，用生物98个；
    如果一次耗龙误伤两次，那么7次耗龙后可使黑龙减半，用生物49个;
    如果一次耗龙误伤三次，那么4次耗龙后可使黑龙减半，用生物28个;
    如果一次耗龙误伤四次……报歉，我还没打出来过。

    耗龙条件：
    1、我方地形平坦，树、花、石等杂物越少越好。
    2、最右边的那两条黑龙不要士气。

    耗龙方法详解：（在此讲双方无士气的方法，如有士气，适当调整）

    1、比黑龙快的生物
    白虎和游牧人：速度比黑龙快，把三个前排的生物和第二排最左的生物走前一些，并分得比较开。
    或者用第二种阵型，把前四个分开，也可以。
    其它等待，黑龙攻击之后，相互之间的距离满足以下条件就算成功：
    A：在气息攻击范围内（3大格、9小格）
    B：中间的距离能让我方生物钻进去。

    让等待后的生物进攻，注意控制进攻点，让进攻的箭头和身后的黑龙联成一线。
    其它的生物再寻找类似的空间。

    使用熟练之后，90%都能做到至少误伤一次，战场环境好的话，误伤两次也不难做到。

    在这两者之中，感觉白虎的身材更苗条，好象成功率也高一点，不过相差有限。

    2、一样快的生物——飞兵
    风元素和石像鬼：也是把前排兵送死，但因为速度一样，所以和黑龙是以梅花间竹的方式行动的。
    第一兵冲，黑龙飞过来杀；
    第二兵飞到合适位置，引黑龙杀过之后就形成互吹位置；
    第三兵攻击让一队黑龙互吹，或者再调度第三黑龙的位置；
    第四兵找合适位置攻黑龙，第四黑龙什么也打不到，只能向前飞；
    其它兵看情况找反击点。

    由于飞兵的活动范围很大，可找的机会极多。
    大部分都可以找到误伤两次的机会，误伤三次的机会也不是太难。

    同样，我觉得苗条的石像鬼更容易找到让黑龙互吹的机会。
    事实上，在测试时，我已经用石像鬼找到过第四个互吹点，不过可惜——这两队黑龙都反击过了。

    3、一样快的生物--步兵
    盗贼、十字军、狼：方法和2是一样的，可惜效果就完全两样了。
    由于这些生物行动范围的限制，难以找到机会，而且对身前的地形要求极高，所以打起来比较累。
    唯一比较好一点的是狼，由于比较小，得到互吹位的机会比另两种生物大得多。
    实测中，感觉狼有30%-40%的机会能造成一次误伤，而盗贼、十字军的机率在10%以下。
    刚才又多测试了一下，发现盗贼的成功率其实也是不错的，也许比狼差一点，但比十字军要好多了。
    如果运用得好，狼和盗贼都应该有50%以上的成功率。

    由以上实测中，我总结的耗龙兵排名：
    石像鬼、风元素、白虎、游牧人、狼、盗贼、十字军。

    其中石像鬼是中立生物，除了野外，没地方找得到，其它四个比较有效的生物中有三个是自然族的!
    再联想到前面提到的杀龙方法，有一个是纯自然，一个是自然+死亡，一个是自然+生命+力量。
    看来自然对耗龙、杀龙都很有一手啊。
    经过这两次测试，自然族在我心中的地位急剧提高。

    BTW:测试时我都使用了海量的黑龙，这样可以找一些吸引眼球的标题，比如：
    头条：7风元素轻松搞定15K黑龙！
    号外：7自杀石像鬼昨袭黑龙塔，死30000，伤者无数！


杀黑龙的方法总结
作者：DarkRain.cn

    为什么要谈杀黑龙的方法呢？因为黑龙免疫魔法和飞行的特性，让它成为最难杀的野兵之一。如果能够解决杀黑龙的问题，杀其他大部分兵种都可以迎刃而解了。

方法一：大否定戒指

    此方法最为特殊，因为去掉了黑龙的看家本领：免疫所有魔法，黑龙的个性就没了。在这种情况下，杀黑龙随便怎么杀都可以，这里只举一个消耗时间最少的方法：

    第一回合，迟缓黑龙。
    第二回合，召唤狼。
    第三回合，催眠黑龙。
    第四回合，祝福黑龙。
    第五回合，殉难，用黑龙来保护狼。狼等待后冲上去咬黑龙，黑龙被转嫁的伤害完全杀死。

    此方法脱胎于phinex打泰坦的方法，用来对付顶级兵效果不错。对付一般的顶级兵，光祝福是不太够的，一般还要用嗜血、振奋等魔法来加强敌人，催眠的次数也要增加。像是我重玩阴云密布战役时，最后一关一路上的邪魔女都是这么干掉的，非常节省现实时间。

方法二：狂喝药水

    就是单英雄上阵，依靠大量的不朽药水来消耗黑龙。因为需求药水太多，因此这个方法实用性是非常差的。

方法三：召唤凤凰

    此方法由晶欣提出。

    第一轮：英雄召唤凤凰，然后凤凰飞到黑龙跟前，黑龙咬死凤凰，凤凰复活。
    第二轮：凤凰飞到地图最远端，英雄走到地图最下角，黑龙咬死凤凰。（要点：黑龙一回合走不到英雄跟前，这样它就会一直咬凤凰，而不会咬英雄。）
    第三轮：英雄召唤凤凰，然后凤凰飞到黑龙跟前，黑龙咬死凤凰，凤凰复活。
    第四轮：英雄召唤凤凰，凤凰防守，黑龙咬死凤凰，凤凰复活。
    第五轮：英雄召唤凤凰，凤凰防守，黑龙咬死凤凰，凤凰复活。
    ……
    第N轮：英雄召唤凤凰，凤凰复活自己。（要点：当黑龙一口咬不死被复活过的凤凰时，才能让凤凰复活自己，否则凤凰继续防守）。
    第N+1轮：英雄召唤凤凰，凤凰复活自己，黑龙已经一口咬不死凤凰了。
    第N+2轮：英雄召唤凤凰，凤凰复活自己，黑龙已经一口咬不死凤凰了。
    ……
    第M轮：战斗已经结束了。

    召唤凤凰的好处之一，是凤凰被打死后会复生一次，这样可以多牵制黑龙一回合。好处之二，是重复召唤凤凰后，其复生的数量是根据总召唤量来决定的，积累下来相当可观。

    其中“凤凰复活自己”这个动作，注意别太急着用。因为凤凰放弃防守姿态后，25%防御力加成就消失了，并且还要考虑到黑龙伤害力会有波动。因此在黑龙一口吹不死凤凰之后，还要等几个回合，以免发生意外。

方法四：召唤凤凰的改良

    方法三其实是有缺陷的，就是无法完全保证英雄的安全，第三回合黑龙如果攻击英雄就完蛋了。这个与游戏的版本有关，在中文版（TGS 2.2）中，黑龙对召唤出来的凤凰更有兴趣；但在3.0的英文版中，黑龙则会追着英雄打。

    保证英雄安全的方法，最容易想到的就是利用传送。晶欣的方法其实我早就想到过，并且把传送魔法作为必备条件写到了攻略里（1.21版的卷轴中可以看到）。

    如果没有传送魔法呢？经过试验，找到了替代方案。凤凰向上飞的时候，不是随便飞，而要向战场左上方飞，紧靠左边停下。这样黑龙攻击凤凰的时候，就会从上方吹，而不像平常那样从下方吹。吹完凤凰之后，黑龙的移动范围不会将英雄覆盖在内，因此英雄是完全安全的。

方法五：召唤凤凰+螳螂

    召唤凤凰的缺点，就是凤凰复生后，原先身上附着的所有魔法状态都会消失，因此无法用魔法来加强凤凰。

    利用凤凰复生的特性，其实每两回合召唤一次就可以牵制住黑龙了，多余出来的回合可以召唤螳螂并且加上各种各样的祝福魔法。当螳螂积累到一定实力后，再放出去与黑龙单挑。

方法六：召唤+殉难

    召唤+殉难的打法，其实很早就有人提出了，但是我一直没有给予足够重视，直到看到AntiqueWhiteKat的帖子：

    喝了不朽药剂、魔法瓶，去挑200黑龙。先招恶魔，恶魔就自己躲到谁也打不着的角落里。接着对恶魔用龙力，随后英雄应该被秒了一次了。（指数还算“正常”的高等级英雄，呵呵）自动复活后就用殉难恶魔来保护英雄。英雄就不停召唤恶魔吧，不用多久恶魔数量就上来了，此消彼涨，差不多了就蹦回来合殴黑龙，顺便还可招冰魔助战。这种方法对于没学战斗的大法师，比如bob，也适用。

    简单说，就是利用英雄的高防御，把伤害转嫁到防御较低（与英雄相比）、但血多的召唤生物上。只要黑龙一击所伤的血小于一次召唤的（上面的例子还给恶魔加了龙力，血翻倍），那么就可以一直维持下去，直到召唤生物积累到一定数量后再围殴黑龙。

    并且这个方法还可以与上面的召唤凤凰相结合，不要让黑龙一开始就打到英雄，利用凤凰复生的机会，给召唤生物加血（龙力或是巨人之力）、给英雄自己加防御。

    最适合召唤来殉难的，就是恶魔了，因为单次召唤数量多，并且高移动力可以确保自身安全。其次是凤凰，速度快、血较多，并且还有复生能力。

方法七：再生

    这是一个相当常用的打法，就是带杂兵让黑龙分为四组，然后找一个站进去只会被一组黑龙攻击到的角落，用再生和各种加强防御的魔法来对抗黑龙。纯粹靠反击来消耗黑龙，似乎要花很长时间，但因为进入稳定状态后英雄只要防御就可以，因此对现实时间的消耗其实并不长。

    再生打法需要注意的就是补血速度与伤血速度的比较，如果再生的血不够补，那么这个方法就不可行。而在前几回合，各种加强类魔法还没有完全用出来，英雄在这个过渡阶段是比较脆弱的。解决的方法是带几个副英雄或是丛林妖精、半羊人这样的兵，来尽快缩短过渡阶段。

    另外，用再生打法必须要知道的一点就是，“站进去只会被一组黑龙攻击到的角落”在一般的战场上是不存在的，除非是某个角落里有点障碍物。因此，这个方法常常要结合L/S/L方法（用来改变战场地形）。

方法八：耗龙

    由fireway提出。就是用些兵送死来引诱黑龙的站位，然后再用攻击一组黑龙，让它反击的气息误伤另外一组黑龙，从而大大消耗黑龙的数量。要在实战中采用这个方法，平时的练习是必不可少的，可以参考fireway两篇心得中的详细说明。

总结：

    上述方法中，第一种和第二种都太特殊，第一种需要一个罕见的宝物，第二种实用性极差。因此在这个总结里只比较其余方法的优劣。

    在黑龙数量非常非常多的时候，方法八显然是最好的，因为可以很快速的消耗黑龙数量。但当几仗后黑龙数量被消耗到一定程度的时候，就应该用别的方法来收拾，因为此时耗龙的效果降低，并且这些经验值丢了实在可惜。

    剩下那些方法，都要看实际条件来进行选择。

    fireway曾经说过，改良后的再生打法（加副英雄等）是最好的，但我并不这么认为。就拿方法三、方法四来说，其前提只有两点：1、召唤凤凰；2、魔法值（可以用魔法药水来解决）。只要这两个前提满足就行了，英雄本身的防御力根本不重要。而再生打法中，除开英雄本身的防御力，那些加强防御的魔法也是非常必要，少学一个都会令可以挑战的黑龙数量大大降低。吟游诗人战役最后一关那挡路的60黑龙，第5天就被我灭掉了。当时我不会再生魔法，也没有生物门，由于资源问题，魔法塔也没怎么建造。因此，在这种条件下，召唤凤凰就是最好的解决方法，再生打法只能靠边站，因为即使英雄此时已经掌握再生，没有副英雄和丛林妖精、半羊人配合也是白搭，根本不够打。

    而对于方法五来说，虽然在魔法值的消耗上会比单纯的召唤凤凰节省许多，但却平添了召唤螳螂、各种保护类魔法等前提要求，因此不能说它绝对比单纯召唤凤凰优越，还是要看实际情况。

    在召唤+殉难方法中也存在类似问题。如果不考虑实际情况，召唤恶魔当然比召唤凤凰优越。但召唤恶魔至少要27个技能点才能学会，召唤凤凰只要15个技能点，因此反而是召唤凤凰更为实用些。从理论上来说更强的方法，有时候会因为前提要求太高而出镜率低；而稍弱一些的方法，却因为要求低而更常被采用，这类情况其实非常常见。

    另外召唤+殉难方法有一个很大的优越性，就是英雄单人对抗混编敌兵时依然可以采用，只要敌人中间不混杂着远程部队就可以。而召唤凤凰的打法，或者是召唤凤凰+螳螂的打法，都只能在单挑中起作用。因为如果敌人至少有两队兵都具备打死凤凰的能力的话，凤凰复生牵制敌人的作用就无法发挥了。

    在实战中，要根据敌兵数量以及本方英雄的能力、技能、魔法、宝物各方面状况，来选定最合适的打法。不要因为觉得某种方法最好，就对其他的方法不屑一顾。打法提出来，并不是为了制造一些死硬的思维定势，而是用来提供一些临机应变的选择。

附注：

    上述方法都是可以用来打数十乃至上百、上千黑龙的，并且不需要多少兵，主要是英雄和魔法。对付常规数量（或者比常规数量稍多的）黑龙时，可以考虑用水云提出的灯神镜像+传送打法。


丑陋面具的应用

    同时具备先攻与引起恐惧能力的部队，在遭受敌人攻击时，反击不仅可以在敌人攻击之前进行，而且会直接打退敌人，让敌人根本没有机会出手，于是自己也就不会遭到攻击伤害。
    这个规律的最典型应用，就是掌握专家以上级别肉搏技能的英雄，装备丑陋面具去打无混编的野兵，控制得好可以毫发无伤消灭敌人。应用时注意敌人不能是远程兵种，并且不具备“先攻”、“否定先攻”或者是“不受反击”这几项能力，也不能抵抗恐惧。另外注意敌人主动攻击英雄时，若已经处在退无可退的位置上，则击退功能不起作用，这时无法确保英雄安全。
    巫王（Witch King）这个职业，自带了丑陋面具的效果。但这个职业的肉搏能力一般不会太强，因此用上述战术效果一般不会太好。


三个英雄的奇遇
作者：fireway

    清晨，马蹄声远远的响起。神气活现、时间猫、Fireway三位英雄相继从帐篷里钻出来，向响声处看去。一队军队从远方而来，当先正是火鸡，火鸡到了离三英雄差二十步远的地方一个立定，下马，开始支帐篷。“靠！火鸡没移动力了！”时间猫说，看向Fireway，“怎么办？”Fireway是H4王国的德鲁伊，神气活现和时间猫也是德鲁伊，不过三人的修行不同：
    神气活现：宗师战斗系，宗师生命、秩序、混乱，基本自然。
    时间猫：宗师战斗系，宗师生命、秩序、自然。
    Fireway：宗师侦察系，宗师生命、混乱，专家死亡（宗师招魂），基本自然。

    所以，关于移动、侦察的事，一向由Fireway负责。“嗯，火鸡有鞋子和两个手套，还有海量的不朽药，如果去他那里拿，一来一回什么事都做不了。”Fireway看了看跟班（一只螳螂），“但如果我们只带这支部队上路，可能会有危险啊。”“这样吧，”神气活现说：“到前面塔上看看，如有危险就闪，不然就向前探，明天火鸡肯定能赶上来，别忘了他也是宗师探路啊。”
    三人赶到塔上一看……“啊！一座有序城！而且是已经建到最高级的城！而且没有守军！”Fireway兴奋的大叫。其它两人也非常高兴，因为他们几乎能会的魔法都会了，就差以下这些：
    和平歌、避难所、神圣介入、守护天使
    迟缓、疯狂、群迟、失明、催眠、疲劳、驱役幽灵、蜂群、召仙女龙、混乱、混乱云
    而这其中大部份都可能在前面的有序城里出现。如果学全了这些魔法，那么仅仅三个人就是王国内一只不可抵挡的力量！

    “真没守军吗？”兴奋之余，时间猫问。Fireway拿出望远镜，四周扫视，“没有，有形的隐形的都没有，这我敢肯定。”快到城门，突然，时间似乎停顿了，紧接着，三人被拖入了战斗画面。“啊！事件！！”Fireway痛苦的说：“就算我有大宗师的侦察技能也看不到啊！”
    对面，站着四队凤凰，每队1000只，没有士气。“嗯，还好，敌人不算太强”神气活现说：“主要是军种太单一，不然就麻烦了。”“不过，也不弱啊……”时间猫说。“嘿嘿，昨晚我们斗酒，每人喝了100瓶（魔力药水），还怕它们？”Fireway说：“就象以前那样，开始吧……”Fireway拿出蛛丝箭，动作停住了……“谁拿了我的角弓（号叫弓）”Fireway惨叫。“啊，可能昨晚喝醉拿错了，怎么在我这里……”神气活现摸着肩头的弓说，脸色开始发白。良久……
    “你不会箭术，我们不可能打过的。”神气活现说：“能想的办法我都想过了，怎么办？”“还能怎么办？闪人啦！”Fireway没好气说：“时间猫，你来放魔法，我不会回城……又要耽误两天的路了，要被火鸡笑死了 ……喂！时间猫！”
    “我想我可能也喝醉了，平常我都把它放行囊里的……”时间猫惨兮兮的说，伸出一只手，拿着一只手铐……“咚！”神气活现和Fireway同时倒地，时间猫也慢慢软倒……在地上英雄们看了看自己的装备：
    神气活现：角弓、马兰迪杯子X3、荣誉奖章、闪光戒指、能量法杖、虎盔、虎甲。
    时间猫：魔法头饰、闪光戒指、能量法杖、再生甲、圣甲虫。
    Fireway：健康戒指、蛛丝箭、闪光戒指、能量法杖。
    还有其它各种宝物、药水无数--在跟班螳螂的身上。
    三人同时叹了一口气，饮酒误事啊！

    “要是火鸡在就好了，他带的部队是仙女龙，有80000只呢！”“废话，我最恨火鸡了！”“喔？”“对面那些凤凰，也叫火鸡！至少在H3没升级前这么叫。”“怎么办？上一次进度是什么时候？”“W1D1……”“太好了，今天才W1D2啊……”“是啊，不过那是M1的，现在是M8！”“自动存档呢？”“你喝晕了，你忘了大神（玩家）没上英雄世界和游戏人的家进修，又不买正版，在他的H4目录下没GAMES子目录！有个屁的存档啊！......还好，在H4的世界里，先动的部队不出手，后动的部队是不能动的，所以……6只人眼+2只螳螂眼和8000只凤凰眼干瞪着……突然，神气活现坐了起来，看看自己的魔法书，又看看各人的位置，脸色开始发亮……Fireway看着神气活现，又看看自己的魔法书，又看看各人的位置，站了起来。“居然有这样的好事？？！！”“什么？”时间猫转过头，看着面前两个狂喜的朋友，又看看自己的魔法书，又看看各人的位置，跳了起来。“太好了！……。不过，如果凤凰士气……哪……”“它们的士气只有+1，哪有那么容易出？而且……不能自动存档，手动存档总是可以的，是不是？……嘿嘿嘿。。”“它们这回合没士气，是不是？下回合士气应该已经不重要了吧？”

    经过了一场艰苦的战斗，英雄们击败了凤凰，进了城……城里真的有五级魔法塔，有神圣介入、群体迟缓、催眠……哇！爽呆了！！！

    请问三位英雄是怎么打败凤凰的呢？

    答案在下面，用白色字写的。大家想不出来了再看不迟。（用Ctrl-A全选文字，可以比较清楚地看到）

    第一，排位问题。这点在题目内已有提示：首先，是FIREWAY抽箭，所以第一个动的是FIREWAY，然后，FIREWAY让时间猫施魔法，所 以时间猫应该第二个动，不然应该让神气活现放回城了。综上所述，最好的排位是螳螂、FIREWAY、时间猫、神气活现分别排在2、4、6、7号位，紧密阵形，第一排全空。

    第二，本题要点。
    镜象的魔法生物也是有魔法书的，只不过因为没魔法值，平时大家不注意罢了。
一个英雄召唤生物时，生物出现的位置是不固定的，有可能在英雄的正前方或右前方。

    第三，战斗过程。第一合：FIREWAY召恶魔之子，注意最好召在FIREWAY的右前方，也就是时间猫的正前方。时间猫召水，如果刚才恶魔之子在时间猫的前方，水就一定在时间猫的右前方，否则只有1/2的机会。如果水在时间猫的正前方，那么将被凤凰一回合攻击，战斗也就失败了。这是本答案唯一可能要用到S/L的地方，不过机会不太大。再下来神气活现镜象水元素，由于有3个杯子和勋章，召唤出的生物士气为10+，所以一定比凤凰先动，而镜象没有士气会比凤凰迟动，这点要注意。然后螳螂尽量向上飞，延迟一组凤凰的行动；恶魔之子行动时100%会把吸到的魔法值给镜象水元素，然后向后飞到水镜象旁边；水元素迟缓最右边的一组凤凰；凤凰会一组攻击螳螂，二组飞到我方阵前，另一组中了迟缓在半路上；最后镜象水行动，已经有2点魔力值，而英雄有魔法头饰，所以镜象水刚好能够使用迟缓魔法，对攻螳螂的那组凤凰进行迟缓。
    第二回合：时间猫和神气活现把阵前的两组凤凰传送走，水和镜象水再分别对它们进行迟缓。FIREWAY召小仙子向上飞引开一组凤 凰以保证英雄和水的绝对安全，如果安全没问题，那么此回合也可以放魔力闪光。
    第三合之后，水元素后退到安全地方，FIREWAY每合都用驱役死灵，把螳螂或凤凰复活飞到战场最左上角，吸引一组凤凰，单靠神气活现一个人已经可以把其它三组被迟缓的凤凰玩于手掌之中了，时间猫每回合都召水或其它的进攻生物，这完全看自己的喜爱了，我测试时用了水元素，最后召了2.1K水。
    如果召箭兵要注意一点：召唤新的生物不会使该生物的箭数恢复，而召魔法生物将使该生物的魔法值全满。

    最后，本战法用时约一小时，使用魔法值80点。

    SSZ评注：吸收魔力，还是吸收魔力。


再谈等待的运用
作者：DarkRain.cn

    等待（wait）是在三代中新增加的一个指令，在四代中因为反击机理的变化而得到了进一步加强。等待的基本作用，就是让速度快的部队在等待后可以迟于速度慢的部队行动。这样对于快速部队来说，在本回合的等待阶段以及下回合的正常行动阶段，可以连续行动两次，充分发挥速度的优势。

    虽然等待是一个基本的指令，但仍然会出现有些玩家“玩了很长时间游戏，还是不知道有这么个东西”的现象。即使是知道等待的用法，也未必就能合理适当地利用它。

    下面举三个例子来讲述其应用：

一、单英雄靠药水耗黑龙的例子

    这是很早以前有人提出来打海量黑龙的一个方法，实战价值不高（需要太多药水了），但可以拿来作个讨论。

    一般人的思路是让英雄比黑龙快。被黑龙打倒后，下一回合英雄先行动，喝不朽药水，然后再让黑龙打倒自己，靠反击慢慢消耗黑龙。但是如果遇上黑龙士气高涨的情况，还没来得及喝药水就会被黑龙多打一下，阵亡了。

    于是又有人提出要保证英雄比黑龙慢，就是保证英雄速度6。但是这个方法有个缺陷，就是黑龙损失一部分之后会士气低落，到时候英雄可能还是会比黑龙先出手。并且，能够给英雄提高速度的机会，难道也要放弃么？似乎得不偿失。

    其实解决的方法很简单，就是利用等待指令来实现“比黑龙后出手”的目的。在英雄喝了药水、并且会被黑龙打到的情况下，不要把希望寄托在“下一回合先出手”而浪费这次行动机会。用等待的方式让黑龙来打英雄，英雄复活后本回合还没有过去，英雄可以喝药水来进入下一回合。如果黑龙士气高涨，没什么大不了的，复活后直接喝药水就行了，反正我们原本就打算在黑龙之后出手的。 　　总而言之，无论英雄速度比黑龙快还是慢，无论黑龙是士气高涨还是低落，用等待的方式都可以解决。

二、召凤凰+螳螂打黑龙的例子

    又是一个打黑龙的例子。具体方法是：利用凤凰死后复生的特性，召一次凤凰可以吸引黑龙两回合，腾出的一回合就可以用来做别的事情。

    一般操作是这样：
    第一回合，英雄召凤凰，凤凰向左上飞，靠边停下，此时黑龙会从上方攻击凤凰，英雄不在黑龙攻击范围内。
    第二回合，凤凰向右上飞，引开黑龙。英雄召螳螂，螳螂飞到角落安全处。
    第三回合，原先的凤凰已死，英雄再召凤凰，还是往左上飞，靠边停下。
    第四回合，凤凰再向右上飞，英雄对螳螂使用祝福类魔法。
    第五回合，再召凤凰。
    第六回合，对螳螂使用祝福类魔法。
    以下重复，直到召出来的螳螂加了各种祝福类魔法，并且积累了一定数量为止，放螳螂出去与黑龙单挑。

    但是上述的操作忽略了一个因素，就是黑龙的士气。例如黑龙第三个回合士气高涨，那么就会出现这种情况：英雄还没来得及召一队新的凤凰，黑龙就先飞下来了，在战场中央附近的黑龙基本上移动范围可以覆盖整个战场，英雄就不安全了。

    解决的方法就是用等待：第二回合英雄不要召螳螂，而是等凤凰被吹死后再召凤凰；第三回合召螳螂；第四回合等待后召凤凰；第五回合加祝福；第六回合又是等待后召凤凰……如此操作，可以完全避免黑龙士气高涨所带来的意外。

三、丑陋面具打海怪的例子

    丑陋面具+宗师肉搏技能，是非常无赖的一种打法，可以毫发无伤的消灭敌人。因为海怪的吞噬特技，平常不大敢惹，但用这个方法可以轻松地消灭它们。

    用这个方法的关键就是要保证每次都有反击，这样才能抢在敌人出手前将敌人打退。但实战进行中，有时却会出现无法反击的状况。例如海怪某一回合士气低落，攻击英雄受反击；下一回合没有士气低落，攻击时机提前了，英雄反击的一回合没有过去，就无法对这次攻击作出反击。如果有迟缓、蜂群之类的魔法或是泰南匕首什么的，可以解决这个问题。但，如果没有呢？

    于是，又到了应用等待战术的机会了。

    英雄每一次攻击都不要主动发起，先等待。如果海怪没受士气影响，等待后冲上去打。如果海怪士气低落（没看清楚的时候，可以观察其攻击力，士气低落攻击力降低20%），那么就等待后连续移动两次，应该可以逃出海怪的追击范围了。


游戏难度和获取的经验值的关系
作者：DarkRain.cn

野外生物数量和战斗获取的经验值与游戏难度成反比。最高难度野兵数量为普通难度3倍，战斗所获经验值为对象生物经验总值的1/3；次高难度野兵数量为普通难度2倍，战斗所获经验值为对象生物经验总值的1/2；其余类推。


多英雄分经验值的规律
作者：DarkRain.cn

如果一支部队中不止存在一个英雄，那么在战斗获胜或是捡宝箱化经验值的时候，就要涉及到分经验值的规律了。

首先，总的经验值是不会随着英雄数量改变的，和单英雄来时获得的一样。
其次，死亡的英雄不参与经验值的分摊。
再次，如果部队中的某一个英雄经验值已经达到上限（战役中一般每一关都会设定英雄等级上限），那么他也不参与经验值的分摊。

详细的计算方法是：所有英雄等级各自加2以后，按照加出来的数值按比例进行分配。例如主角18级，3个英雄各自3级，则主角能够得到(18+2)÷(18+2+3+2+3+2+3+2)=4/7的经验值，其余3个英雄每人分走1/7。


游戏得分的算法
作者：DarkRain.cn、SSZ

游戏难度包括地图难度和游戏难度：

地图难度Ｍ分五级，分别为： 0.5/0.75/1/1.25/1.5。游戏难度也分五级，但是每一级的数值Ｅ跟地图大小有关：

地图 | 初级 | 中级 | 高级 | 专家 | 冠军
小 | 0.5 | 1 | 1 | 4 | 7.5
中 | 0.75 | 1.25 | 2.25 | 4.2 | 7
大 | 0.9 | 1.5 | 2.5 | 4.4 | 6.5
超大 | 1 | 2 | 3 | 4.5 | 6

总分：总分＝时间＋战斗＋部队＋财富＋任务＋宝物＋地图＋英雄＋城堡

时间：这里３ＤＯ把胜利时间按周为单位计算，并以胜利时的总周数按照阶段评分。第一阶段得分为100ｘＭｘ（Ｅ＋2.5）；第二阶段得分扣除150ｘＭ；第三阶段再扣除50ｘＭ；第四阶段再扣除50ｘＭ；以后每阶段扣除5ｘＥｘＭ。分数下限为30ｘＥｘＭ。

阶段的划分：小地图一至三周每周为一个阶段，第四周到第八周是第四个阶段；以后每周一个阶段。中地图，大地图和超大地图的阶段划分和小地图类似，但是每个阶段的时间跨度相应地乘以：2、4、6。

战斗：与野兵交战也算分。按战斗时敌我双方的实力对比，每一场战斗得分从0到60不等，满分是72分。战斗得分和任务得分，在取进度后都会归0。

部队：把部队按照招募价格换算，上限24分。小地图每分价值1000金，中地图价值2000，大和超大地图在中地图基础上依次翻倍。

财富：上限48分。小地图每分价值500金，中、大和超大地图每分的价值依次翻倍。过关时会自动将矿换算为金钱（木材、矿石每单位62.5金，其余资源每单位125金，换算率与野外交易站几乎一样），同时将本关初始资源也按同样换算率换算为金钱，两者相减才是可换算为分数的财富。

任务：上限96分。小地图每个任务48分，中、大地图任务价值依次减半，超大地图一个价值任务只值8分。

宝物：上限76分。小、中、大地图的初级宝到超级宝算分。小地图中，每种宝物的分数依次是10/20/40/80，中地图为5/10/20/45，大地图的宝物分数是 1/5/10/45，超大地图中，中级宝物到超级宝物才算分，每种宝物依次为3/8/30分。

地图：按照探开的百分比乘以12。

英雄：满分76分，和英雄等级有关。假设英雄等级为Ｌ，得分为（Ｌ－ａ）ｘｂ。小地图上ａ＝3，ｂ＝10；中地图ａ＝4，ｂ＝6；大地图ａ＝5，ｂ＝5；超大地图ａ＝6，ｂ＝3。

城堡：满分 120。小地图每个城堡30分，中地图每个15分，大地图和超大地图每个10分。


生物能力的1：5原则
作者：DarkRain.cn

    四代一点比较特殊的设计，是所有生物都遵循这样一条公式：(平均伤害力×攻击力)÷(生命值×防御力)≈0.2(1：5)。平均伤害力取的是伤害力上下限的平均值。而生物的特技并不包含在此公式的考虑因素中，因此拥有某些强力特技的生物，其杀伤能力（伤害力×攻击力×攻击次数）或者抗打击能力（生命值×防御力）是特别强的。这样就比较好理解：为什么石像鬼要设定一个“护体石肤”特技，而不是直接将其防御力设为20。巨兽强力特技的效果是增加伤害力50%，僵尸健壮特技的效果是生命值加倍，这里的“50%”和“加倍”都是套用以上公式后计算出来的。
    远程部队的主要攻击方式是射击，将其远程攻击力带入上述公式可以得出吻合的结果。多数远程部队近战攻击力都是远程攻击力的一半（真实数值的一半，未必是游戏中看到的那个值，例如弩手和弩车的近战攻击力分别是4.5和7.5，并不是4和8），施法部队（法师、灯神、水元素、仙女龙）也被近似认为是远程部队，主要攻击方式被认定为杀伤类魔法，因此其(平均伤害力×近战攻击力)÷(生命值×防御力)≈0.1（只有水元素例外）。施法部队的主要杀伤魔法（如仙女龙的闪电、灯神的冰箭），其杀伤力相当于自身生命值的30%，这个比例明显高于上述公式的最后结果（0.2），因此施法部队在面对高防御的敌人时，其魔法杀伤的表现是相当不错的。
    资料片新增的生物，则基本上都不遵循上述公式。这些新增生物破坏了许多规律，很多时候需要拿出来作特殊讨论，所以生物经验值统计页面中，也并未将它们收录在内。


士气与幸运的作用详解
作者：DarkRain.cn

    士气与幸运的作用在游戏中发生了很大变化。士气高昂，不表示部队一回合可以行动两次，而是让部队在战斗中可以优先行动（即使是速度慢的部队，士气高昂后行动次序依然优先于所有速度快、但没有士气高昂的部队），另外部队攻击力提高25%。士气低落时，部队在战斗中会推迟出手时机，并且攻击力降低20%。有幸运保护的部队，在接受物理攻击时只会受到2/3伤害。而厄运缠身的部队，在遭受物理攻击时会多受50%伤害。其实受幸运影响的不仅仅是物理攻击，还包括了闪电、爆裂、碎裂、圣言、圣唱这几种攻击魔法，还有驱逐这个诅咒魔法。
    士气与幸运的正负数值代表了士气高昂、士气低落、幸运保护和厄运随身的出现几率（即士气/幸运数值×10%）。士气+10表示100%几率出现士气高昂，士气-10表示100%几率出现士气低落，幸运+10表示100%几率出现幸运保护，而幸运-10表示100%几率有厄运随身。在游戏中，士气显示的数值有可能超过±10，但其效果还是按照+10或-10来计算。
    除了完全不受士气影响的部队（亡灵、机械）外，其余部队在混编时士气都要受到队伍组成的影响。原始士气为+1；有一个相邻派系部队混编，士气-1；有一个敌对派系部队混编，士气-5；非力量系部队与力量系部队混编，士气分别-2；非死亡系部队与亡灵混编，士气-2。如果有一支部队，包括了所有6个种族的兵种，其中还有亡灵，则其中亡灵的士气为0，力量系部队士气为+1-2*5-2=-11，死亡系非亡灵生物士气为+1-1*2-5*2-2=-13，其余部队士气为+1-1*2-5*2-2-2=-15。
    需要注意的是，英雄也有阵营/派系属性，对士气的影响效果与生物是一样的。英雄所属的派系看其初始职业，而不是转职后的职业。看英雄派系其实还有一个简便的方法，就是看英雄头像周围那一圈的颜色，对比一下生物头像就明白了。

    在战斗进行过程中，将双方的损失情况作一个比较，总体战力多损失10%的一方，整体士气会-1。例如交战双方A和B，战斗过程中，A方总体战力损失了15%，B方总体战力损失了55%，则A方整体士气保持战斗开始时的状况不变，B方整体士气则要下降4点。召唤类魔法制作出来的部队，不影响整体士气，本身士气也不受整体士气的影响。


关于兵种体积的初步研究
作者：DarkDragon

在英雄无敌四中，兵种的占地比较复杂，不再是三代那样的一格或两格那么简单。但是以前由于没有网格，所以兵种的占地无法深入研究，只能有个大概印象，比如妖精的体积小于狼。现在的补丁有了网格，于是可以对兵种体积作出详细一点的研究。

通过观察发现，h4里的兵种共有5种体形，我给这5种体形从小到大命名为：“小型”、“中型”、“大型”、“特大型”、“超大型”（嘿嘿，这个命名权我抢定了，^^）。以下是五种体形的具体大小。（DarkRain.cn注：原文是以图片形式表示，但图片以失效，所以改用文字方式描述。总体来说，形状尽量接近于圆形）

小型兵种：3×3的方格

中型兵种：4×4的方格

大型兵种：5×5的方格，在四个角上各挖去1小格

特大型兵种：6×6的方格，在四个角上各挖去1小格

超大型兵种：7×7的方格，在四个角上各挖去3小格


战场上部队行动的先后顺序以及反击的规律
作者：DarkRain.cn

因为士气高涨/低落的作用发生变化，所以四代部队在战场上的行动顺序规律变得比前三代都复杂。为了说明方便，这里将一个回合划分为A、B、C、D、E、F六个阶段。

A：士气高涨部队行动的阶段。
B：一般部队（未发生士气高涨/低落情况）行动的阶段。
C：士气低落部队行动的阶段。
D：士气低落部队等待后行动的阶段。
E：一般部队等待后行动的阶段。
F：士气高涨部队等待后行动的阶段。
一个速度6的部队，在正常情况下行动发生在阶段B，这里把该部队行动的“时刻”定义为B6。如果此部队士气高涨，就会提前行动，行动将会发生在阶段A，其行动的“时刻”定义为A6。其余情况类推：士气低落时行动的“时刻”为C6；士气低落、并且在等待后再行动，行动“时刻”为D6；速度3的部队，士气高涨的情况下，等待后再行动，行动“时刻”为F3。

假设速度最快的部队速度为20（只是为了讨论方便，事实上有可能超过，但是原理是一样的，不再赘述），则行动的顺序是：A20→A19→A18→…→A2→A1→A0→B20→B19→B18→…→B2→B1→B0→C20→C19→C18→…→C2→C1→C0→D0→D1→D2→…→D18→D19→D20→E0→E1→E2→…→E18→E19→E20→F0→F1→F2→…→F18→F19→F20。也就是说，士气高涨的部队，不管速度怎么低，一定会在未士气高涨的部队行动之前行动；士气低落的部队，不管速度怎么高，一定会在未士气低落的部队行动之后行动；如果不直接行动，而是在等待后行动，行动顺序是相反的。同样士气高昂的部队，等待之前是谁速度快就谁先行动，等待之后是谁速度慢就谁先行动；同样士气低落，或者是同样没有受到士气影响的部队，其行动先后顺序规律也是与前述相似的。

如果有两个速度相同的部队，受到士气影响效果相同（在同一回合，同时士气高涨，或者是同时士气低落，或者是同时没有受到士气影响），则在行动顺序上，谁的排位较“前”，谁就先行动（无论是等待前还是等待后）。这里所说的“前”，指的是比较两部队的站位后，哪一队更接近正上方。如果两部队在面对正上方的同一横线上，无法分出上下，则站位靠左边的部队先行动。在英雄无敌的前三代中，速度相同的部队，行动先后顺序是看战斗开始前部队的排位，无论战斗中部队怎样移动，这个先后次序都不会发生变化。而在四代中，行动先后次序是会随着部队移动而发生变化的，有些人不明白这条规律，觉得四代部队行动次序非常混乱，其实这种这种设定比前三代更为合理，也不难理解。

反击的规律：

部队在战斗中某一回合的特定“时刻”作出反击，则在下一回合的同一“时刻”到来之前，都不能再次作出反击。可以无限反击的狮鹫不受此规律影响。

假设一支部队在第一回合的B4时刻被敌人攻击，作出了反击，那么从本回合的B4时刻开始（如果敌人还有速度4的部队没有行动，则本回合B4时刻还没有马上过去），B3、B2、B1、B0……C全段、D全段、E全段、F全段，一直到第二回合的A全段，B20时刻，B19、B18……B6、B5时刻，这支部队都不能再次作出反击。直到第二回合的B4时刻，此部队的反击限制才被解除，此后会对所遭到的第一次攻击作出反击，不管此时作出攻击的敌人部队是不是第一回合作攻击、遭到反击的那支部队。（假设第二回合的反击发生在E3时刻，则在第三回合的E3时刻到来之前，此部队都不能再次反击，其余情况类推）

反击规律的应用举例

前面罗罗嗦嗦说了一大堆，如果都是废话，那就是白费唇舌了。事实上掌握行动顺序以及反击的规律后，对实战会非常有帮助。

1.等待后攻击。这已经属于基本技巧了。如果在战斗中，没有士气影响的情况下，每回合都不等待就直接攻击，那么每回合攻击的“时刻”都是一样的，就每回合都会遭到一次反击。如果第一回合等待后攻击，让敌人作出反击，而第二回合不等待就直接攻击，则此时敌人本回合反击的时刻还没有到来，无法再次作出反击，那么两回合下来就只会遭受敌人一次反击。如果一直在等待后进行攻击，则每回合攻击的时刻仍然是一样的，还是会每回合遭到一次反击。等待与不等待交替进行，才是最为合理的指挥。 一般人使用等待后攻击的技巧，都是用在速度快的部队上，而忽略了速度慢的部队。当速度比敌人慢的时候，在出手之前已经遭到敌人攻击，此时等待不等待看上去好像没区别，都是打完一次后轮到敌人行动（敌人速度快，进入第二回合后先行动）。事实上区别是非常大的，本回合等待后攻击，下一回合直接攻击便不会遭受反击。所以，等待后攻击绝对不是快速部队的专利。

2.恐惧能力的利用。

这里所说的恐惧，不是指梦魇兽的恐惧魔法，而是骨龙的恐惧技能，宝物丑陋面具和职业巫王（贵族+混乱）都可以给英雄加上恐惧能力。如果英雄同时有恐惧和先攻能力（用魔法或是肉搏技能加上的），那么就有一种很无赖的打法：不带兵，让敌人只有一组（如果敌人是多兵种混编，则此打法不成立）；敌人在攻击英雄的时候，因为先攻能力的作用，英雄的反击会在敌人攻击开始前进行；而反击时恐惧技能又会把敌人直接打退两步，敌人后退后便不能攻击，等于是攻击还没打到英雄身上时就被强行终止；如此反复，当敌人郁闷死去时英雄仍然毫发未伤。

使用这种战术需要注意几点：敌人必须要受恐惧影响，因此此招数不能用来对付元素、亡灵、机械和黑龙、狂暴者等；先攻能力必须发挥作用，因此要求敌人不能拥有先攻、否定先攻、不受反击这几项技能，最好也别是远程兵种；英雄站位要注意，如果敌人在退无可退的角落里打英雄，因为反击后无法将敌人打退，也就无法阻止敌人的主动攻击；另外必须要注意士气的变化。

例如敌人是速度5，每回合都在正常情况下攻击，则每次攻击都发生在B5时刻，我方反击的时刻也发生在B5时刻；但是如果敌人有一回合士气高涨，则攻击会发生在A5时刻，因为我方上一回合反击在B5时刻，本回合B5时刻尚未到来，就无法对敌人A5时刻的攻击作出反击；或者是敌人有一回合士气低落，攻击发生在C5时刻，我方尚可作出反击（C5在B5之后，反击的临界时刻已经过去了），但是下一回合敌人正常行动，在B5时刻攻击，则我方就无法对此次攻击作出反击。

战斗开始时，敌人士气是+1，随着敌人损失的加大，其士气也会逐步下降，降为负数，士气高涨/低落的出现概率是相当高的，所以会导致意外情况经常性的发生。如果要确保安全，可能的情况下要让自己士气保持最高（振奋魔法或是召唤半羊人），就算敌人士气高昂也可以确保我方先行动；在我方先行动的情况下，根据敌人士气的变化作出反应，敌人上一回合正常行动而本回合士气高昂，或者是上一回合士气低落而本回合正常行动，我方本回合都是无法反击的，看见这种情况出现，如果能跑就赶快跑开，如果跑不掉，就用混乱、蜂群之类的魔法阻止敌人一回合的行动。

附加说明：

上面的表述遗漏了一个情况，就是敌我双方有行动优先度相同的部队时，谁可以先出手。其实这个情况从一代到四代都是用同一个原则来处理的，就是战斗开始时攻方先动，然后尽量做到轮流行动。

举个例子（为了简化讨论，这个例子中不涉及士气的影响作用）：
假设攻方所带部队为泰坦（速度6）、灯神（速度6）、金人（速度3），守方带领的部队是食尸怪（速度6）、幽灵（速度6）、骷髅（速度4）。
那么在战斗开始的时候，因为双方最快的部队速度都是6，所以攻方先行动。至于是泰坦先行动，还是灯神先行动，那就要看哪一个排位较“上”了（也就是说，“排位上者先行动”这个原则是对内的）。假设是灯神。
接下来，战场上速度6的部队还有三组（泰坦、食尸怪和幽灵），因为上一次是攻方行动，所以在速度相同情况下，这一次轮到守方行动。假设食尸怪排位靠上，食尸怪先行动。
再接下来，按照轮流原则，速度6的泰坦和幽灵依次行动。
最后轮到骷髅和金人，第一回合行动结束。
第二回合开始时，仍然是速度6的先行动。因为上一回合最后行动的是攻方速度3的金人，因此第二回合就是守方先行动。


攻击被冰冻生物的研究
作者：fireway

这个问题也是讨论过好多次了。
由于以前对回合了解不清，总是搞不明白。
现在又研究了一下，觉得有一定的规律，虽然不知有没有特例，但基本应该不错了。

这个规律就是：

宗师肉博的两下攻击中，第一下是一定要打的，第二下一定要被攻击生物有还击的能力才能打出来。
听起来和以前的一些结论一样，但关键是搞清了什么叫有还击能力。
一队生物，在该生物回合内可能还击和实际还击了，都叫有还击能力。

越讲越乱，还是举例吧：

1、最常见的，英雄配寒冰锤，等待后，第一锤就冻住了对手，但还是能连击四下。
时间顺序是这样的：
英雄第一回合开始，英雄等待；
生物第一回合开始，生物行动；
英雄连打两下，第一下冰冻生物，英雄第一回合结束；
英雄第二回合开始，连打两下冰冻生物，英雄第二回合结束；
生物第一回合结束，生物第二回合开始，被冰冻回合数减一。

在此例中，英雄打的这四下，生物都处在第一回合下，而生物第一回合虽然被冰冻，但还是有反击能力的，所以英雄每次都能打两下。

2、继续1的战斗：
英雄第三回合开始，英雄进攻；
生物第三回合开始，生物解冻；
生物第三回合结束，英雄第三回合结束。
英雄进攻时，生物处于第二回合，属不能反击状态，所以，英雄只能打一下。

3、继续1的战斗：
英雄第三回合开始，英雄等待；
生物第三回合开始，生物解冻；
英雄进攻；英雄第三回合结束；
英雄第四回合开始；英雄行动待定；
生物第三回合结束。

现在我们来看看英雄在第三回合的进攻，英雄进攻时，生物也处于第三回合：
A、如果英雄第一击未能冻住生物，生物将进行反击，由于生物第三回合进行了反击，所以生物第三回合定义为有反击能力，英雄将能进行第二次攻击。这就是传说中的人品问题。
（英雄无专家以上肉博，反击同时发生，或用其它生物骗反击也一样，发生了反击就是具有反击能力。）
B、如果英雄第一击冻住生物，那么生物在第三回合的开始和结束都处于冰冻状态，且未发生反击，所以定义为无反击能力；英雄将无法进行第二次攻击。这就是传说中的一锤子买卖。

好了，现在我们已经明白为什么有时能打冰冻生物两下，有时只能打一下了，下面给出结论及扩展：
1、有还击能力的生物可以被攻击多次，无还击能力的生物不能被攻击多次；
2、除冰冻外，晕击也属于无还击能力；
3、如果攻击方具有恐惧能力（丑陋面具、恐惧护符、恐惧气氛），那么不管生物是否被冰冻，都被视为有反击能力，只是因为恐惧而未能反击；不吃恐惧的当然不在此列；
4、远程攻击部队都视为有反击能力，只不过是不能反击；
5、英雄另外增加的攻击次数，比如迅捷剑、灵猫反射、急速药水，最多可进攻5次；后面的三种攻击次数和宗师肉博第二击是一样的，如果定为无反击能力，全部打不出来，还是只能打一下；
6、生物的额外攻击次数和英雄一样（十字军或加了灵猫的其它生物），不过没这么多时间对所有生物做测试，如果有问题再讨论吧。

以上的研究是在读了回合及反击规律的文章后做的。


竞技场龙的数量
作者：白菜

总结出的规律如下：
数量是和难度有关系的，最高难度是正常难度的3倍
正常难度下，黑龙数量公式应该是 英雄当前等级/12；仙女龙数量是(英雄当前等级+1)/6
（最高难度就要在相应公式上乘3了）
如果除出来的结果并非整数，凡小数部分≤0.5的不进位，>0.5的进一位
计算结果<1，则数量为1。


在野外拆分队伍的规律
作者：过客

第一个分出来的队伍在右上角，以后分出来的顺时针排列，如果中间有其它物体则顺延(如果中途把某支队伍移走了，会重新按以上规律补充位置，然后再排下去)。


野兵的增长率
作者：黑孔雀

测试的结果相当简单，分成两种情况。

一、如果当天的数量不超过10周产量时，到第二天增长1/70。

二、当天数量达到10周产量时，增长量封顶。相当于城里的周产量/7。

比如说，第一天70个农民，到第二天就是71个，第三天是72.014，第四天73.043，依此类推，当然小数点之后是不显示的，但并不等于不存在。看起来每天增长一个，累计到某一天，就会增长出两个来。对于未封顶的情形，其实是所谓的指数增长，不太好算的。
但如果是70架弩车，周产量是7，封顶每天产量1，于是就准确的每天增长一架。1000架弩车也是一天增长一架。
除了周产量为7的弩车，地狱犬，精灵，21的侍从，28的恶魔之子外，其他兵种会有个计算产生的误差。比如说10黑龙，日增长应该是1/7只，七天后应该长出一只，但七天并没有长，要到八天后才长。估计是在计算中四舍五入产生了误差，导致七天后应该有11只，但算出来可能是10.99只，显示就只有10只了。然后到15天后12只，22天后13只。所有周产量不能被7整除的，封顶增长下，在七天后都会少一只，再过一天补上。

三、打仗不会消灭小数位的生物。

就象前面的例子，W1D1的10只黑龙，到W2D1仍然显示10只，但实际上可能是10.99只。现在你去打它，打掉9只后逃跑，还剩下1.99只，第二天变成2只。但如果你把10都打掉了，剩下的0.99只也就报销了。

四、和所选择的难度无关。

比如在最高难度下，野兵的数量是正常的三倍，但增长还是如一、二。但这时候野兵数量一般是够多了，几乎总是按二的封顶产量来增长。

五、关口、矿的驻军和巢穴守军的增长同样遵守以上规律。

这指的是无主的关口、矿和巢穴。然而，无主的城的驻军是不增长的，不遵守以上规律。

六、巢穴守军的初始数量由级别和产量决定（元素例外）。

在普通难度下：

四级：
1 黑龙 2
2 巨兽，傀儡龙，骨龙，天使，九头蛇，泰坦，恶魔，螳螂，仙女龙，凤凰 3
3 雷鸟 5
4 精英骑士 6
三级：
3 吸血鬼，独眼巨人，食尸怪 4
4 火怪，蛇妖，冰魔，狮鹫，梦魇兽 5
5 十字军，独角兽 6
6 僧侣，灯神，毒蜂草，食人魔法师 7
元素：
6 土元素，火元素，风元素，水元素 10
二级：
6 金人，洞穴巨人，牛头怪，白虎，美渡莎，游牧人，邪眼魔 3
7 弩车，地狱犬，精灵 4
8 半羊人，鹰身女妖，木乃伊，法师，石像鬼 4
9 枪兵，幽灵 5
一级：没有守军。

不同难度下按照：2/3，1，3/2，2，3乘以倍数再去掉小数部分。比如说，黑龙在最低难度下是：2*（2/3）=1.33，取整后是1个。在最低难度下，四级兵巢穴的守军刚好是一周的产量。

七、初始的野兵有小数部分。

比如，在地图上设了3只巨兽，在3/2难度下，一开始是9/2=4.5头，显示4头，但实际上那半头是存在的，它会影响到后来的增长。


宝库测试
作者：黑孔雀

上篇：守军篇

H4总共有20种宝库，出现24种生物。其中沉船有两种，效果是完全一样的。为了，以下讨论方便，先把宝库分成7类，并引进一个叫基数的概念。基数的意义和作用在下文中给出。

基数3：龙城（黑龙）
基数10：狮鹫巢（狮鹫）、圣殿（僧侣）
基数20：鸟妖巢（鹰身女妖）、象牙塔（法师）、碉堡（弩手）、斜眼巢（邪眼魔）、迷宫（牛头怪）、抛弃船（水元素）
基数25：沉船（幽灵）
基数40：隐匿处（盗贼）、神秘花园（妖精）、格伦森林（狼）、小鬼窖藏（恶魔之子）、金字塔（木乃伊）、红矮人矿坑（矮人）
基数45：废墟（半兽人）
基数50：陵墓（骷髅）、墓地（僵尸）、海盗岛（海盗）

一、第一天的守军数量：

第一天的生物数量是最小值和最大值之间随机取值。最小值就是该宝库的基数，最大值随难度改变。不同难度的野兵倍数分别是：2/3，1，3/2，2，3，最大值分别是：

基数3：4，5，7，8，11
基数10：15，18，23，27，36
基数20：31，37，46，55，72
基数25：39，47，58，69，91
基数40：63，75，92，110，145
基数45：71，84，104，124，163
基数50：79，93，115，137，181

比如说，最低难度（2/3）下，抛弃船的守军，水元素，最少是20个，最多是31个；而最高难度（3）下，最少还是20个，最多是72个。有四种宝库有两个以上兵种，上面的值是其中最低级的兵种的取值范围。所有的计算遇到小数部分都是舍去。

碉堡：枪兵的数量是弩手的1/2
神秘花园：妖精和丛林妖精是1：1
格伦森林：白虎的数量是狼的1/4
陵墓：幽灵的数量是骷髅的1/5，吸血鬼的数量很复杂，不同难度下还不一致，大致上是（骷髅数量-50）/13。

上面那张表有一个近似公式：

（最大值-最小值）=7/8×难度系数×基数（3+，10，20，25+，40，45+，50）

对于基数10，20，40，50以上公式是准确的，但对于3，25，45则有误差。产生误差的原因似乎是：这三个基数并不是准确的整数，而是稍大一点，大概要加上1/70，我没有得到准确的误差值。

二、守军随时间的增长：

守军每天都均匀地增长，是带有小数位的，即使第一天的数量也不是准确的整数，小数位不显示，但确实存在。增长速度随难度改变：

守军每天增加个数=1/40×难度系数×基数（3+，10，20，25+，40，45+，50）

比如说，普通难度（1）下，盗贼每天增长1个（1/40×1×40=1）。3/2难度下，法师每天增长3/4个（1/40×20×3/2=3/4），每个月增长21个。

上面的公式仍然是对于10，20，40，50准确，3，25，45大概要加上1/70（仍有微小的误差）再代入公式。枪兵、白虎、陵墓的幽灵基数为10，丛林妖精40。吸血鬼仍然很复杂，只能近似看成是骷髅增长速度的1/13。

三、宝库被打下来之后的增长：

被消灭的是整数的兵力，小数部分仍然留在宝库中。在之后一个月里，增长停止。一个月后继续按前面的增长速度增长。

比如说，1月1日，打掉龙城，里面仍然可能有小数位的黑龙。到2月1日，数量一直没有变化，但开始恢复增长。最低难度下每天增长1/20头黑龙，最多可能要到2月21日才会有一头黑龙，又可以去打龙城了。但如果一开始剩了0.9头黑龙，到2月3日就会有一头。

下篇：奖励篇

按照获胜后得到的奖励的不同，把宝库重新分类：

金：废墟
金+资源：狮鹫巢（木材）、格伦森林（木材）、红矮人矿坑（矿石）、鸟妖巢（水银）、神秘花园（水晶）、小鬼窖藏（硫磺）、海盗岛（宝石）
资源+宝物：迷宫（宝石）
金+宝物：隐匿处、陵墓、龙城、墓地、象牙塔、碉堡、斜眼巢、金字塔、圣殿、抛弃船、沉船

一、获得的奖励只由消灭守军的数量决定，与难度、时间没有直接关系。消灭守军的数量是累计的。

比如，格伦森林，100狼+25白虎，不管是什么难度，当时是哪一天，总是获得4000金+33木材。如果对战特别关心某一种宝库的奖励，就可以事先测试出这个宝库所有数量下的奖励，列一张表。到打仗时，先派一个小兵去打一下，知道了守军的数量，就可以查出奖励是什么了。这样可以决定要不要去打。还可以根据难度算出以后每天的数量和奖励，决定哪天去打。

小数位的守军不能被消灭，所以也不产生奖励。

数量累计有两种情况：
1、以前打过宝库，消灭了一定数量，没有打下来，下次再去打下来了，要把前一次消灭的数量加上。
2、宝库被打下之后，过了一个月，守军开始恢复增长，以后再去打，要把前一次打下时消灭的数量也累计起来。比如说，打下一个33狮鹫的狮鹫巢，奖励6000金+80木材，过一个月零两天，再去打，发现是1狮鹫，奖励要按照34狮鹫来算，是6250金+82木材。（这种情况感觉象BUG）

二、奖励的总价值随守军的经验值增长。

计算总价值需要注意两点：
1、金是以250为单位出现的，不足250的部分不显示，但会累积到以后。
2、资源和宝物按如下换算成金：

木材、矿石：125
水银、水晶、硫磺、宝石：250
道具、药水：500（不管在铁匠铺里卖100的盾，还是卖1000的不朽药水）
宝物：初级2000，中级4000，高级8000，超级宝物不在宝库里出现，无价
1到5级魔法羊皮纸：250，500，875，1500，2625（即250*1，2，3.5，6，10.5）
1到5级魔法卷轴：500，875，1625，3000，5000（即250*2，3.5，6.5，12，20）

最低数量守军的奖励可以从『东方卷轴』上查到，我不知道它们是按什么规律出现的。比较特殊的是：在最低数量下，只有斜眼巢和金字塔的（奖励总价值/守军经验值）小于3，其他宝库这个值都大于3。

除了斜眼巢和金字塔，其他18个宝库在不同守军数量下，有一个规律：

守军经验值每增加1点，奖励的总价值增加3点。

比如说，小鬼窖藏，最低40恶魔之子，奖励500金+4硫磺，总价值1500。127恶魔之子，经验值增加87*5=435，总价值应该是：1500+435*3=2805。实际是1000金+7硫磺=2750。多出的55金不显示，累积到以后。

即使在最低数量下，奖励的金也不是准确的250的倍数。比如，50到59海盗奖励2000金，但60海盗就奖励2250金。增加10海盗的经验是70，价值210，说明50海盗的奖励应该是：2040到2060之间。

例外的斜眼巢和金字塔，随守军数量增加时，（增加的总价值/增加的经验值）逐渐上升，越来越接近3，但始终不会到达3。在数量很大时可以近似看成3。

更奇怪的是，金字塔中的宝物的价值比前面给的要少。初级宝物最处的价值只有1000，但随着守军数量的增加，宝物的价值也会增加，比如217个木乃依时的初级宝物的价值是1500，最后可能会增加到正常值2000。斜眼巢在任何数量下的宝物都是1道具/药水+1初级宝，所以无法知道宝物的价值是否不同。

三、没有宝物的宝库

与最低数量时比较，增加的总价值按比例分成金和资源。不够产生1单位资源的，都加到金。
1:0，废墟
2:1，海盗岛
1:1，鸟妖巢，狮鹫巢，格伦森林
1:2，神秘花园
小鬼窖藏和红矮人矿坑的比例比较复杂，大概是1:1.9。
比如，神秘花园，42妖精+丛林妖精，奖励1000金+7水晶，总价值2750。48妖精+丛林妖精增加84经验值，总价值增加252，按1:2的比例，不够产生1水晶，所以都加到金，变成1250金+7水晶。到了49妖精+丛林妖精，总价值增加378，按1:2的比例，250金换1水晶，剩下128金不显示，奖励1000金+8水晶。

四、有宝物的宝库

不知道会把多大比例的总价值换算成宝物。有以下一些规律：

1、每个宝库的宝物有上限，超过上限之后只增加金（迷宫是增加宝石），不增加宝物。 碉堡：7道具/药水
斜眼巢：1道具/药水+1初级宝
陵墓：1中级宝
墓地：1初级宝+1中级宝
抛弃船：1初级宝+1中级宝
沉船：1初级宝+1中级宝
隐匿处：2初级宝+1中级宝
迷宫：2初级宝+3中级宝
金字塔：1初级+2中级宝+2高级宝
龙城：3中级宝+4高级宝
圣殿：三、四、五级羊皮纸+二、三、四、五级卷轴
象牙塔：2五级羊皮纸+1三级卷轴+2四级卷轴+2五级卷轴

2、宝物个数不会超过上限个数。比如金字塔，任何时候宝物都不超过5件。

3、象牙塔只出现羊皮纸和卷轴，圣殿只出现羊皮纸、卷轴和药水，其他宝库都不出现羊皮纸和卷轴。此外，碉堡只出现道具/药水。除了圣殿、碉堡和斜眼巢，其他宝库都不出现道具/药水。

五、宝物的替换

随守军的增加，高级别的宝物会替换掉低级别的宝物。同样价值为500，药水和一级卷轴可以替换二级羊皮纸。没有得到完整的替换规律。如果要替换一个初级宝，就一定是替换最后出现的一个初级宝。

比如说，一开始有一个力量戒指，后来又有一个六分仪，出现高级宝时要替换一个初级宝，就一定是替换六分仪。这种情况下，如果后来又要出现一个初级宝，基本上会再出现六分仪。但这不是绝对的，新出现的宝物都可以用S/L来改变它。因此有一种变态打法：如果特别想要得到某个宝物，比如敏捷战戟，就算好中级宝物在哪天出现（如5黑龙、46木乃伊），在前一天存进度，把它S/L出来。

那么，大家比较关注的五级羊皮纸什么时候出现呢？105法师或53僧侣。五级羊皮纸一共有16个，慢慢S/L吧。

测试过程中参考了『东方卷轴』和二良的宝库测试
http://www.gamerhome.net/main/index.php?showtopic=11828
另外，奖励由守军的数量决定，最先是这里的一位版主提出来的。一并表示感谢！


驱役类魔法详解
作者：DarkRain.cn

这个测试是看了哈雷路亚的帖子后进行的，所以大半功劳应该归他。

原先对此类魔法的表述是：“驱役出的亡灵数量不能超过阵亡部队的数量，亡灵生命总值也不能超过阵亡部队的生命总值”，其实这只是对一次施法的要求，如果累加的话，结果就不一样了。

驱役的关键是要有尸体，无论是被全灭的一组部队，或是损失了一部分的一组部队，都可以。驱役亡灵后尸体就会全部或者部分消失，尸体的消失是按生命值计算的。

举个例子看就明白了。假设阵亡了9头骨龙，英雄驱役吸血鬼一次7头。那么
第一次驱役的时候，产生7吸血鬼，扣除的骨龙尸体是7*75/275=1.91，算2个，骨龙尸体还剩7。
第二次驱役的时候，又产生7吸血鬼，扣除的骨龙尸体还是2个，骨龙尸体还剩5。
第三次驱役的时候，因为尸体只剩5，所以只能产生5吸血鬼，扣除的骨龙尸体是5*75/275=1.36，算2个，骨龙尸体还剩3。
第四次驱役的时候，产生3吸血鬼，扣除的骨龙尸体是3*75/275=0.82，算1个，骨龙尸体还剩2。
第五次驱役的时候，产生2吸血鬼，扣除骨龙尸体1个，还剩1。
第六次驱役的时候，产生1吸血鬼，骨龙尸体扣除完毕。
9头骨龙在这里总共驱役出了7+7+5+3+2+1＝25头吸血鬼。

另外还有一个发现，“亡灵生命总值不能超过阵亡部队的生命总值”，这句话是有点问题的，其实驱役的亡灵生命值可以略超过阵亡部队。例如死亡了13妖精，生命总值91，用来驱役幽灵，7不足，6有余，实际上驱役的幽灵是7个。也就是说，驱役6个后残余的生命值驱役出了完整的1个。


地图移动力决定战场移动力
作者：黑孔雀

地图　　　战场
15---------2
17,18------4
19,20------6
21---------7
22---------8
23,24------9
25--------10
27,28-----12
29--------13
30--------15,50
包括两个资料片的生物都符合，只有车队地图是30，没有战场移动力．

附所有生物的移动力和速度数据如下：

地图移动力：
15：弩车、细腰植物
16：
17：炮车
18：半身人、矮人、土元素、农民、僵尸、洞穴巨人
19：法师、金人、半兽人、美杜莎、牛头怪、侍从、弩手、枪兵、十字军、僧侣、骷髅兵、食尸怪、精灵、
食人魔法师、丛林妖精、水元素、海盗、穴居人、木乃伊、美人鱼、邪眼魔、冰魔
20：蛇妖、狂暴者、半羊人、火元素
21：泰坦、九头蛇、地狱犬、狼、独眼巨人、巨兽、恐甲兽、凶牙兽
22：英雄
23：盗贼、梦魇兽
24：白虎、海怪
25：灯神、精英骑士、独角兽、半人马
26：
27：傀儡龙、游牧人、大耳怪骑士
28：恶魔之子、幽灵、吸血鬼、骨龙、鹰身女妖
29：火怪、妖精、狮鹫、仙女龙、雷鸟、风元素、螳螂、石像鬼
30：黑龙、天使、恶魔、凤凰、黑暗骑士、邪魔女、巨龙、车队

战场移动力（单位为“码”）：
2：弩车、细腰植物
3：
4：炮车、半身人、矮人、土元素、农民、僵尸、洞穴巨人
5：
6：法师、金人、蛇妖、半兽人、美杜莎、牛头怪、侍从、弩手、枪兵、十字军、僧侣、骷髅兵、食尸怪、精灵、
狂暴者、食人魔法师、丛林妖精、半羊人、火元素、水元素、海盗、穴居人、木乃伊、美人鱼、斜眼魔、冰魔
7：泰坦、九头蛇、地狱犬、狼、独眼巨人、巨兽、恐甲兽、凶牙兽
8：英雄
9：盗贼、梦魇兽、白虎、海怪
10：灯神、精英骑士、独角兽、半人马
11：
12：傀儡龙、恶魔之子、幽灵、吸血鬼、骨龙、鹰身女妖、游牧人、大耳怪骑士
13：火怪、妖精、狮鹫、仙女龙、雷鸟、风元素、螳螂、石像鬼
14：
15：黑龙、天使、凤凰、黑暗骑士、巨龙
50：恶魔、邪魔女


英雄可自动学会的魔法
作者：lzkong

当英雄学会某一系魔法技能时，会自动掌握一个1级魔法，但根据我的印象，有些魔法从未出现，应该是不能自动学会的，列举如下，如有错漏，欢迎指正。

守序：可学精准，模糊，魔法拳。不能学驱散，推移和真视。
混乱：可学魔法箭，火花，火焰结界，疾速，嗜血。不能学杀戮。
生命：可学疗伤，祝福，精神甲。不能学驱魔，圣言和招船。
死亡：可学诅咒，瓦解射线，驱役骷髅，毒害。不能学废除。
自然：可学招狼，招妖精，招丛林妖精，加速，石肤。不能学寻路和地形认知。

（DarkRain.cn注：上述规律，不仅影响到掌握基础魔法主技能时所能学到的魔法，也影响英雄从酒馆中招出来时所带的魔法——每个英雄出酒馆时所带的魔法都是随机的。）


有关战斗中无法撤退的解答
作者：会飞的大天使

经过我的总结测试，英雄无法撤退的根本原因是离城太近。
那到底则么才算太近呢？
我来说一下：和城正面9格以内的任何敌人交火，都无法撤退，不管守不守矿。
和城侧面6格以内的任何敌人交火，都无法撤退，不管守不守矿。
和城后方的任何敌人交火，都能撤退。
不过撤退还有一个前提，就是通往城的道路不能被敌人完全封锁。自己人挡住不要紧。


“大回城术”
作者：zaar

现在的回城只能回到最近的城了，真是这样么？我们来试试，假如你有两个城，一个很近，你一个回城，果然回到这个城了。再试一次，找四支部队，并排站在这个城门口的四个点上（一排），然后再来个回城，咦？我怎么回到那个远的城了。。。

百试不爽，大家可以试试，可惜只能有八个部队，不然真成三代的大回城了。

DarkRain.cn附注：

堵城门的方法不但可以与回城魔法结合，也可以与逃跑相结合，让英雄逃到较远的城堡。另外，根据会飞的大天使的研究成果，在城堡正面或侧面很近的地方发生的战斗，就算不堵城门，英雄也会逃跑到较远的城堡。用逃跑法最大缺点是只能带英雄，不能带生物走，回城术显然比逃跑法更有优越性。
有时候，故意留一些在城堡附近的野兵不打，将来逃跑/回城的时候便可以利用上。合理利用城门口的障碍和野兵，在某些地图（特别是官方与守序有关的战役中）可以制造出类似三代大回城的效果，虽然过程比较繁琐。


节省移动力的出城法
作者：水云

======
||A————————> S
||B __—>
城门|| __—
||C __—
||D—
======

从A点出发移动到S点的路程明显要比从D到S要近，我的英雄现在就在D点，我想去S点，你会怎么做？如果我是随便玩玩的，我就直接走过去了，但如果我要追求快速通关呢？
我首先会让D点的英雄进城，然后从城里出一个兵，走到A点，再进城，就在这时把英雄和这个兵的内外位置互换，这时出城就能看到英雄出现在A点，而且这个过程英雄是不会消耗移动力的。

（DarkRain.cn注：这是论坛里第一次有人提到这个技巧，但实际上我开始玩四代后一两周就开始用这招了，算是一个比较基础的微操作吧。）


攻城的简易方法
作者：1+1=?

到电脑城旁边时随便进一个矿，这样电脑就以为你已经远去大肆出城搜索，这时你趁机占了它的城，一般都是castle级的，呵呵。

（DarkRain.cn注：这个方法并不是一定能成功，有时电脑会守在矿旁边，让我方部队无法直接从矿里出来偷城。后来fireway有一个改良的打法，就是安排两支部队躲在矿里，主力部队呆在离城较远的矿场里，而离城较近的矿场放一些杂兵来吸引电脑部队。）


攻城的简易方法

如何在战斗中改变随机数
作者：DarkDragon

BTers（注：指“变态人士”）做事是很有耐心的，他们会反复restart最佳开局，或者s/l大法到最优形势，好让邪眼用出特定魔法或者让牛头的格挡成为100%或0%。不过在h4里有个不方便的设定，就是s/l的时候随机数只改变一次。比如要让邪眼用出迟缓，一旦两次失败，就要退出重打这一仗，随机魔法才会改变。这未免太麻烦了，有没有简单的方法呢，其实这样就可以了：邪眼攻击前存档，一旦两次尝试失败，那么：L，S，L。一般都会改变出现的魔法，最多两三次肯定会改变。牛头格挡同上操作。

此法同样适用于在大地图上改变英雄升级时出现的技能。


快速战斗（quick combat）的研究

快速战斗（quick combat）的研究数
作者：Hotwave，Gelu

自己编了张地图，我方是 200兽人法师。选兽人法师是因为他很“鸡肋”——所有生物的特技都对他有效，且动作慢，但血多，攻击力强。敌方是几种比较厉害的三级兵和四级兵。（都是只分一组）

第一回—我方 200食人魔 VS 100 灯神。
QC—我方死 130，敌方全灭；
手控—我方死67，敌方全灭。
意料之中，AI很弱。

第二回—我方 200食人魔 VS 30骨龙。
QC－我方死82，敌方全灭；
手控－我方全灭，敌方死10！
吃惊中—骨龙的恐惧技极为恐怖，根本没机会反击！此后我试了一下用分兵骗反击的打法，我方死178，敌方全灭。可能在QC中，电脑忽略了骨龙的恐怖特技，手动虽可取胜，但效果毕竟不如QC。

第三回合—我方 200食人魔 VS 100 独眼。
QC－我方全灭，敌方死57；不服气，再次QC－我方死114，敌方全灭。
手动：我方全灭，
唉，别提了。都是自家人，但独眼太强了。唉，当过老大的就是不一样。感觉上QC的战果有时差别会很大。

第四回合—我方 200食人魔 VS 100 食尸兽。
QC－我方全灭，敌方死85。
手动—我方全灭，敌方死32。
速度上食人魔太低，食尸兽又放毒－意料之中。不过QC还是表现好些。

第五回合—我方 200食人魔 VS 100 吸血伯爵。呵呵，相信大家都买伯爵胜吧…
QC—我方全灭，敌方死56；
手动—我方全灭，敌方完胜！呜呜…伯爵太强了…不服，再QC—我方死165，敌方全灭。呵呵，出了口恶气。再手动，分组打、骗反击－我方死60，敌方全灭！呵呵，AI还是不行！这时我又冒出了一个念头，用分兵骗反击的阵行QC如何？就这么一试—哈哈哈！我方死5，敌方全灭！这个战果有哪位大虾能打出来？QC真的很有趣！

大总结：用分兵骗反击的阵行配合QC功能，可以大幅度减少伤亡！就连打独眼时也是一样（不过对骨龙大哥好像没影响）……这个AI，真是奇怪。另外，如果有墓碑的话，墓碑先复活，再计算双方实力。

SSZ注：QC是个好东东，极大提高战斗速度（特别是在战役中），有时候还可以减少战斗损失。我就经常用它，特别在对付鬼、元素等不太吃魔法的部队的时候，电脑经常比人打得好（或者我太臭？）


盗贼堵人大法
作者：ali_fred，emery，zyd

将盗贼紧贴着敌人（一级兵），因为盗贼的隐身特技，不会被攻击。用足够多的盗贼将敌人围个水泄不通。然后英雄就大摇大摆的从敌人身边过去了。虽然理论上最多需要八个贼，但是实际上很多时候四周有障碍物，需要的贼数可以减少一些。

如上图示意：开始盗贼堵路不全，灯神到不了金矿门口，但是来了一个贼帮忙以后，就成功了。

另外有些地方野兵的势力范围阻挡了主力，但是两边都有部队，部队可以互相接触（其中一队或者是绕路过去的，或者是盗贼偷偷跑过去的），就可以把想运过去的兵通过部队交换送过去。


英雄升级时出现的技能选项规律
作者：水云

技能分类：战斗为力量技能，高贵、侦察、战术三类为中立技能，有序、混乱、生命、死亡和自然五类为魔法技能。

魔法和中立英雄达到四级之前，绝对不会出现新主技能，第四级开始出现战斗。

如果学战斗，十二级之前绝对不会再出现新主技能。

如果不学战斗，战斗会一直出现；但必须保持三项可选技能，不然就会出现新主技能补足，且以后战斗不再是必出技能；这时如果学了其他主技能，十二级之前不会再出现除战斗以外的新主技能。

力量英雄有野人和射手两种。

射手达到六级之前，绝对不会出现新主技能。之后如果学新主技能，十二级之前绝对不会再出现新主技能，不学则随机出现。

野人达到五级之前，绝对不会出现新主技能，五级开始出现侦察或战术，如果不学，在战斗系全升满以后可以出现除了高贵以外的任何主技能。

除了野人以外，十二级开始，主技能出现只受职业限制，没有其它条件。

（注：以上所说的，都是完全靠升级获得技能的情况，例如野人五级、射手六级之类的说法，其中起关键作用的还是技能平均值是否到达6，如果可以买，或者到什么地方学习，就是另外一回事情了。就看你有没有钱，或者前提条件、技能空位了。）

SSZ注：英雄都有一定的职业，新技能中，不可能出现和自己职业对立的技能。每个魔法派系都有两个相邻派系，和两个对立派系。如果某个派系和英雄的职业组成中某派系对立，则该派系和英雄的职业对立。具体的说，如果把有序、生命、自然、混乱、死亡五个派系按这个顺序排成一个环，则不相邻的派系之间互相对立。英雄四加入了英雄转职，我个人认为培养一个好英雄的难度加大了，考虑英雄的技能和职业现在成了一个关键问题。我打战役，一般都会开了地图，仔细看看升级条件、加技能的地方、等级条件、允许的魔法以及对手组成等，用以规划升级路线和职业。


英雄转职的匹配问题
作者：tyfon

问题：一个英雄：生命合2级，死亡合2级。此时连续学习3级战斗，该英雄将转职，有两个方向
1、圣骑士（Paladin，生命*2+战斗*3=5）
2、刺客（Assassin，死亡*2+战斗*3=5）
那么他会朝哪一个方向转职？

解答：引入一个“匹配度”的概念，上例中，若英雄转职为圣骑士，说明战斗技能与生命魔法技能的匹配度高于战斗技能与死亡魔法的匹配度；反之则说明战斗与死亡的匹配度较高。
经过测试可以得出所有技能的相互匹配度

A、非魔法技能

所有的非魔法技能优先匹配非魔法技能。例：圣骑士（生命*2+战斗*2）学习3级战术，必转为将军（General）而非十字军（Crusader）。
所有非魔法技能对魔法技能的匹配度都一样，为：自然>混乱>死亡>有序>生命。例：异教徒（混乱*2+生命*2）学习3级高贵，必转为巫王（Witch King）而非红衣主教（Cardinal）。

非魔法技能间的匹配度如下

战术：侦察 > 高贵 > 战斗

战斗：侦察 > 高贵 > 战术

侦察：战术 > 战斗 > 高贵

高贵：战斗 > 战术 > 侦察

B、魔法技能

所有魔法技能优先匹配魔法技能，例：圣骑士（生命*2+战斗*2）学习3级自然，必转为召唤师（Summoner）而非驯兽师（Beastmaster）。
所有魔法技能对非魔法技能的匹配度都一样，为：高贵 > 侦察 > 战斗 > 战术。例：游侠（侦察*2+战斗*2）学习3级死亡，必转为忍者（Ninja）而非刺客（Assassin）。
魔法技能间不存在相互匹配问题，因为会转为大法师。例：僧侣（有序*2+生命*2）学习3级混乱，或3级自然，或3级死亡，均会转为大法师。

SSZ注：英雄转职的详细解答可以参见《东方卷轴》。这里解答的是其中遗漏的部分。从此tyfon功德圆满。


各种职业升级时的新主技能，补充
作者：黑孔雀

《东方卷轴》中给出了各种职业升级时能够出现哪些新主技能的几条规律。但还是有个别的例外的。比如说：《东方卷轴》中提到了，鬼神使不能学生命；去年我也注意到了，游侠不能学死亡。因此怀疑可能还有例外。昨天有空，花了一天时间，测试了所有的职业所可能学的新主技能，发现有七种职业出现了例外的情形。

盗贼，野蛮人，刺客，忍者：不能学高贵；
游侠：不能学死亡；
鬼神使：不能学生命；
大法师：不能学战术，侦察。

参考《东方卷轴》的结论来说：

1、初始职业，共11种。升级时野蛮人不能学魔法，其他十个不能学对立阵营的魔法。因此，五种魔法英雄可以学：两个相邻系魔法，四个非魔法技能，共六种。五种力量英雄可以学：本阵营魔法，两个相邻系魔法，三个非魔法技能，也共六种。
例外的是野蛮人、盗贼不能学高贵。所以

野蛮人能学：战术、侦察
盗贼能学：混乱、死亡、自然、战术、力量

关于这两个是最惊讶的！经常用到的英雄，竟然没发现不能学高贵，可能是因为大家都不爱学高贵，不出现也就注意不到了。只有一种很特殊的情况下，野蛮人可以学高贵，就是一个战斗系全满，没有其他任何技能的时候，升级时要出现三个技能，但现在只有战术和侦察两个，必定会占用前两个选项，这时第三个选项可以是高贵，也可以是五种魔法之一。 顺便提一下，初始职业的英雄怎么学到力量之外的新主技能。如果他的本系技能只有一项可学了，比如亡灵巫师：高级死亡+高级神秘+基础鬼神+大师招魂。升级时本系只能学专家死亡，第二个选项必然是战斗，第三个选项就可以出现其他主技能了。

2、高级职业：一种魔法和一种非魔法技能，共20种。升级时不能学和职业中的魔法相对立的魔法，可以学：两个相邻系魔法，三个非魔法技能，共五种。
例外的是刺客（战斗+死亡）、忍者（侦察+死亡）不能学高贵。
刺客能学：混乱、有序、战术、侦察
忍者能学：混乱、有序、战术、战斗

3、高级职业：两种相邻魔法技能，共5种。升级时不能学和两个都对立的魔法，比如：生命+有序，不能学混乱。可以学：两个魔法，四个非魔法技能，共六种。没有例外。

4、高级职业：两种相对立魔法技能，共5种。升级时可以学所有七种技能。
例外的是鬼神使（死亡+自然）不能学生命。
鬼神使能学：混乱、有序、战术、侦察、高贵、战斗

5、高级职业：两种非魔法技能，共6种。升级时可以学所有七种技能。
例外的是游侠（力量+侦察）不能学死亡。
游侠能学：混乱、自然、生命、有序、战术、高贵

6、大法师：三种以上魔法技能，共16种。不能学战术、侦察。在大的地图和战役中很常见到的职业，出现的时候通常已经有五个派系的技能了，也很难注意到他们还有什么不能学的。


阴云密布中怎么培养一个鬼神使？
作者：kirika

大法师Bohb碰到的祭坛和大学太多，排除
术士Kozuss要专修order和chaos，如果再修death回转为大法师,排除
黑暗牧师Alita Eventide专修life和death，再学nature会转为大法师，排除
野蛮人Dogwoggle只能学到一个派系的魔法技能，排除

最后只剩下吟游诗人Agraynel，但是吟游诗人、驯兽师、游侠都不能学到死亡，此战役也没有地方可以买死亡技能（虽然死亡城堡很多，哎，郁闷……），怎么办呢？

试了一下，这样是可行的：

最初的2个自然祭坛不要碰，先学到专家combat，转为ranger。然后完成宗师潜行的任务，使3个系的技能平均值大于6，这时可以用L/S/L的方法学到基础战术或基础贵族。学到后，既能平均值又小于6了，就一口气学5级战术或贵族，这时会转为陆军元帅或者工会首领，这样升级时才可能学到basic death。
最早也要到16级才能实现一级的death，之后学学自然吧，这关最高也就专家了，不过没关系，第二关照样能学到宗师自然。
一开始的侦查祭坛只要访问一个就够了，这样侦查技能就只是15级，和nature满级时相等，最后死亡学到16级时就可以转为鬼神使了，否则会转为忍者，当然这个战役没希望了，需要等到最后一个战役才可以。

缺点就是学了5级没用的战术或贵族……

DarkRain.cn注：吟游诗人学死亡系其实并不好，既麻烦培养周期又长，实用性不佳。本文只是在技能学习顺序上给大家开拓思路，作参考之用。


外交与魅惑的作用
作者：tyfon

外交技能与魅惑技能的作用相同，都能说服敌人加入自己的队伍。外交技能的作用是同等级魅惑的两倍，但是需要花钱。

基本规律：

1、首先，两种技能都要求敌军的实力（以经验值计。其中英雄的经验公式为100*（英雄等级+1），Intermediate难度下。其余难度类推）低于本军的1/3，否则外交和魅惑都不会起作用。另外，拥有外交技能的英雄无法招降与自己所属阵营敌对的生物；而魅惑技能不会对亡灵和机械部队生效。假如敌军总经验值低于本军的1/3，那么可以招降部分敌军。

2、招降的数量由英雄的魅惑/外交技能等级，以及敌军的数量决定。这部分英雄世界的资料已有说明。招降的经验上限是基础经验上限*[1+（英雄的级别-1）/10]。基础经验上限由英雄的外交/魅惑技能的级别决定，比如说，宗师外交的基础经验上限是600点（魅惑的数值是外交的一半），而一个19级的宗师外交英雄招降的经验上限就是600*[1+（19-1）/10]=1080点。

3、另外，招降的敌军部队不能超过敌军总量的某个百分比，这也是由外交/魅惑的等级决定的。比如，宗师外交可以说得70%的敌军（魅惑的数值是外交的一半）。因此，最终的招降结果由以上两个数值中较小者决定。

4、要注意，招降的结果是每队敌军分开计算的。解释一下，假如敌军由一队盗贼和一队半身人组成，一名领主前往招降，只有半身人会受到外交的作用（因为盗贼和领主是敌对阵营，外交不起作用）；而假如敌军是恶魔之子和骷髅组成，那么只有恶魔之子会被己方的英雄魅惑。

5、假如经验值判定通过，但敌军中也有会外交或者魅惑的英雄，那么招降的结果就要打折扣。这由两方英雄的技能等级之差决定。这里外交和魅惑是相通的，两方的技能相同或不同均可（如果某方既会外交又会魅惑，取等级高者）。
我方技能等级-敌方技能等级=4：只能招降40%的敌军
我方技能等级-敌方技能等级=3：只能招降30%的敌军
我方技能等级-敌方技能等级=2：只能招降20%的敌军
我方技能等级-敌方技能等级=1：只能招降10%的敌军
我方技能等级-敌方技能等级<=0：不可招降
以上是己方为外交技能时的数据，若己方为魅惑，则结果为外交的一半。


招魂术的计算
作者：绝对零度

H4中，绝大多数技能效果都是按照队伍中对应技能效果最强的英雄来计算的，但是招魂术有点不同。

首先，在队伍中有两英雄招魂术等级不同时，是按照技能等级高的那个来，而不管实际效果。比如说有个3级英雄高级招魂+21级初级招魂，前者只能招16个骷髅，后者能招20个，但实际效果是16个。

其次，如果队伍中所有英雄招魂术等级相同时，是按照队伍中靠前的那个来，而不管实际效果。比如说有10级和17级宗师招魂各一，那么把前者放到队首只能招2个吸血鬼，而把后者放到前面就能招3个。

估计是3DO对招魂这种不光和技能等级有关，还和英雄等级有关，并且不能累加的技能没处理好。

此外，外交术和媚惑术也是和英雄等级有关，估计结果和招魂术是差不多的。


生物特技测试过程中的一些发现
作者：tyfon

一、火盾。
火盾不受混乱抵御与抗魔技能的影响，只受抗魔魔法及魔法免疫影响。当骨龙攻击火怪时，先反弹，再恐惧。

二、魔镜。
在生物特技中，只有以下可为仙女龙的魔镜所反弹：
雷鸟的电击；
独角兽的失明（属于有序魔法）；
毒蜂草的虚弱；
梦魇的恐怖（属于死亡魔法）；
木乃伊的诅咒；
邪眼的攻击诅咒（属于各种魔法）。
仙女龙对雷鸟的电击要反弹，最可悲的是被仙女龙反击而死的雷鸟还得被反弹的闪电拉起来再劈一把，鞭尸。若仙女龙受魔法攻击（包括有攻击作用的死亡之手）而死，魔镜就不会起作用（死亡之手的反弹太可怕了）；若仙女龙以魔法攻击另一队仙女龙，反弹只发生一次；假如仙女龙受到连闪攻击，则反弹的也是连闪（恐怖！），但受间接连闪攻击的仙女龙不会反弹。仙女龙的魔镜是可以反弹群体诅咒性魔法的，但是只弹回施法者（就是说相当于弹回一个单体诅咒）。全局魔法（就是那些不分敌我都起作用的魔法，像末日，瘟疫，全驱散，吸取生命等）是无法反弹的。假如有多队仙女龙同时受到魔法攻击（比如说火球），那么每一队都会发生反弹（但是连闪不一样，只有作为直接目标的仙女龙才能反弹）。几个仙女龙一起反弹火球，就成了好几个火球。火球，地狱火这类区域伤害魔法仍反弹为区域伤害魔法，其反弹为发射性，即反弹的魔法可能会被前排生物阻挡；但火环的反弹却只作用于施法者一人，并且不受阻挡，同时各种单体杀伤魔法（火矢，魔法拳，冰箭等）也不受阻挡。对被己方催眠的仙女龙施法不会被反弹，而对方此时对该仙女龙施诅咒或伤害性法术则会被反弹。和平之歌不能被反弹，但狂暴可以反弹。窃魔可以被反弹，但其升级版—通法偷窃却无法被反弹。

三、毒击。
食尸怪的毒击十分特别。在死亡魔法中毒的伤害只与施毒者的等级及相关技能有关，同时受对象抗魔技能影响（抗魔可以减轻毒的伤害）。但食尸怪的毒击与对象的抗魔技能几乎无关，恒为第一次伤害的1/4。然而，当对象变为宗师抗魔的英雄时，毒击便忽然完全没有影响。也就是说，只有宗师抗魔的英雄不会中食尸怪的毒，其余级别的抗魔，以及生物的抗魔，对毒击完全不起作用（此外，抗魔魔法与黑龙的魔法免疫也能使自己免于受到毒击的伤害）。毒击不能被仙女龙的魔镜反弹，而毒魔法却可以。

四、冰冻。
除了冰冷抵抗，抗魔，魔法免疫者不会被冰冻外，火元素和凤凰似乎也无法冰冻，但是火怪却没有对冰冻的免疫。


生物特技成功率的计算
作者：tyfon（翻译）

每队独角兽在攻击时有30%的机会造成失明；

每队牛头怪在被攻击时有30%的机会格挡成功；

美杜莎石化凝视的成功几率随目标生物或英雄的级别增长而降低（具体影响没有说明，也没有提到生命值，不知这一项的影响如何）。并且，假如石化凝视的成功率（杀死一名生物的几率）在50%以下，则石化凝视无效（即不会发生）；

侍从的晕击成功率算法如下：将侍从造成的伤害除以目标的总生命值，再减去5%。这表示侍从的伤害不高于目标生命值的5%时，目标绝不会被击晕；

每队冰魔在攻击时有30%的机会造成冰冻；

每队海怪在攻击时有10%的机会吞噬目标，无论目标为任何等级的生物或英雄（没有说明吞噬的数量）（DarkRain注：不是“每队”海怪有10%的机会吞噬目标，而是“每一只”海怪有10%的概率吞噬1个敌人，其出现规律与三代蛮牛的死亡凝视基本一致）。

SSZ注：这是tyfon翻译的一篇来自Celestial Heaven的文章。


宗师抗魔特技究竟对什么生物特技（魔法）不免疫？
作者：three

邪眼的废除 | 当你学了宗师抗魔以后，邪眼唯一出的一种魔法。这里有两种情况： 一：英雄先喝复活药水，邪眼出现废除，点右键看英雄已没有“守护天使”标志，打死邪眼，什么都不做，打其他生物，点右键看英雄“守护天使”标志出现。打死可以复活。 二：英喝药水，邪眼废除。英雄接下来被打死。不复活。 也就是说，斜眼对英雄的废除仅当时起作用。
火精灵的火盾 | 我宗师抗魔的英雄经常被盾的半死不火的。
海怪的吞噬 | 不过对某些宝物（如守护者长袍）无效。
美人鱼催眠 |
螳螂定身
黑龙和凤凰的气息 | 不过和火盾一样对英雄职业“烈火战士”无效。
其他基本上都免疫的，最特殊的连骨龙的恐惧都免疫。


有关巨人杀手魔法
作者：DarkRain.cn

杀戮（Slayer）与巨人杀手（Giant Slayer）效果不能叠加，只取强的那一种，也就是巨人杀手的100%。半身人的技能与宝物效果实际上是同一个东西，装备了也是白装备。


海怪的吞噬
作者：黑孔雀

一、一个海怪吞噬的概率是10%

任何兵种、英雄都可以被吞噬，一个海怪每次攻击出现吞噬的概率都是10%。这个比美杜莎的石化简单多了，与状态、攻防、城墙、箭塔、级别都没有关系，与抗魔、各种防御也都无关。

二、吞噬n个生物至少要10*n-9个海怪

举例说：
1~10个海怪每次攻击最多吞噬1个生物。
11~20个海怪每次攻击最多吞噬2个生物。
21~30个海怪每次攻击最多吞噬3个生物。
依此类推。

这样就很难得到多个海怪每次攻击吞噬生物个数的平均值了。例如：20海怪vs天使的平均值测得为1.426。而不是20*0.1=2 。因为每次攻击吞噬数量只有：0,1,2，平均值必然小于2。

（DarkRain.cn注：其实吞噬与三代蛮牛的死亡凝视出现概率计算上是一致的，20海怪吞噬的理论平均值为1.49。但吞噬的作用范围比死亡凝视更广，不考虑攻击对象是否有生命。）

三、“操纵尸体”的死亡海怪，及海怪的幻像同样有吞噬能力。
被吞噬的生物不能复活，不能用做死亡系召唤术的原料。
海怪吞噬英雄的概率不容易测得，但认为也是10%应该是合理的。


美杜莎的石化凝视
作者：黑孔雀

一、属性：死亡系魔法

与状态，距离，障碍物，城墙，箭塔，甚至近身肉搏都没有关系。受抗魔能力，死亡抵御影响。不能石化的兵种有：亡灵、元素、机械和黑龙、凶牙兽、穴居人，除非配带大否定戒子。

二、发生石化的概率

每个美杜莎对一、二、三、四级兵的概率分别是：P=25%，10%，5%，2%。矮人、僧侣、十字军、大耳怪骑士和巨龙减半。
多个美杜莎平均每次石化生物个数是：P*美杜莎数量。比如，3个美杜莎射狼，平均每次石化0.25*3=0.75只狼。

三、阈值

平均石化个数低于0.5时不会发生石化。因此发生石化需要最少的美杜莎的数量，称为阈值。一、二、三、四级兵的阈值分别是：2，5，10，25。矮人、僧侣、十字军、大耳怪骑士和巨龙加倍。美杜莎射英雄时也同样有阈值，与英雄级别、抗魔能力、死亡抵御等有关。无抗魔和死亡抵御的个级别英雄阈值如下：
1-12， 2-13， 3-14， 4-15， 5-16， 6-17， 7-18， 8-19， 9-20，10-20，
11-22，12-23，13-24，14-25，15-25，16-27，17-28，18-30，19-30，20-32，
21-32，22-34，23-34，24-36，25-36，26-39，27-39，28-39，29-42，30-42，
31-42，32-46，33-46，34-46，35-46，36-50，37-50，38-50，39-50，40-50，
41-56，42-56，43-56，44-56，45-56，46-63，47-63，48-63，49-63，50-63，
51-63，52-63，53-72，54-72，55-72，56-72，57-72，58-72，59-72，60-72，
61-72，62-84，63-84，64-84，65-84，66-84，67-84，68-84，69-84，70-84。
基础抗魔是30%抗魔，只受70%的魔法，阈值近似为：上列值/0.7 ，但并不准确，对比以下8,9,10级，还有13,14,15级英雄的阈值：
基础抗魔（30%）
1-17， 2-18， 3-20， 4-21， 5-22， 6-24， 7-25， 8-28， 9-28，10-30，
11-32，12-34，13-36，14-36，15-36，...
英雄阈值的确切算法难以发现，放弃了。

四、石化数量的分布

理论上，多个美杜莎的每次攻击的石化个数应该是所谓的“二项分布”。但测得的美杜莎对洞穴巨人，和美杜莎对盗贼的数据并不支持理论。NWC肯定采用了简化的替代算法，但很找到。例如：1000美杜莎对巨龙，每次石化数量都是：0，10，20，30，40...。虽然分布不确定，平均值仍然是可靠的。

五、“操纵尸体”的死亡美杜莎，及美杜莎的幻像同样有石化能力。虽然没有视力的穴居人不能石化，但失明的生物可以石化。米老鼠建议用大否定戒子测试元素，测得气、水、火、土元素的阈值也是10，可以认定p=5%。在大否定戒子下，土元素的抗魔体现不出来了。


魔法效果的计算
作者：DarkRain.cn

    四代已经取消了英雄法力这项属性，魔法的效果现在由英雄等级、相关技能、职业以及宝物决定。

    先说杀伤类魔法。其伤害力的计算公式是：
        最终威力＝（基本威力＋英雄等级×效果提升率）×（1＋相关魔法技能效果＋巫术技能效果＋职业附加效果＋终极建筑附加效果＋宝物效果）
    注解：相关魔法技能。五个魔法派系，分别有一个专门的技能可以提高魔法效果，例如守序系的魔力、混乱系的占火等等（可参考技能页面）。这里所说的“相关魔法技能”就是指魔法所属派系对应的那个可以提高施法效果的技能。
    举例：混乱系的魔法箭，魔法参数是30/3。那么一个等级5、占火技能大师、巫术技能基础的英雄，施展魔法箭可以造成(30+5*3)*(1+80%+20%)=90点杀伤。

    注：这里的公式与原先总结的公式有细小的差异，一般来说，效果提升率都是基本威力的1/10，用来与原先的公式作比较，可以看出计算结果几乎是一样的：
        最终威力＝基本威力×（1＋英雄等级×10%）×（1＋相关魔法技能效果＋巫术技能效果＋职业附加效果＋终极建筑附加效果＋宝物效果）
        在什么情况下会有区别呢？就是在 基本威力≠效果提升率×10 的时候，例如圣言魔法，魔法参数是45/4

    其他魔法，有的效果固定，例如模糊、精确等等；有的效果会受英雄等级、相关技能等因素的影响，例如召唤、治疗等等，这些魔法的效果计算也与杀伤类魔法的计算相似。只不过巫术技能只能对杀伤类魔法起作用，所以在计算召唤、治疗等魔法的效果时，可以完全不考虑巫术技能。
    举例：生命系的守护天使魔法，可以给部队增加额外的生命数，魔法参数是1/0.1。那么一个30级的大法师（所有魔法效果提高20%），宗师级精神技能，魔法效果是(1+30*0.1)*(1+100%+20%)=8.8，去尾取整，也就是可以给部队额外增加8个生命。

    流沙魔法比较特殊，效果与英雄的等级完全没有关系。


【H4研究】叠加效果原理！
作者：白菜

声明：题目虽然是叠加，但效果不只是增加，还包括减少的，而且均指单英雄带领队伍的情况，关于多个英雄之间的效果影响可以看以前的《H4宝物叠加原理》；所涉及到的魔法只用单体魔法做代表，群体的效果相同；另外英雄和生物的叠加情况如没特别说明则原理相同，只是具体能够叠加的效果不同（比如有些宝物是针对英雄有些则是针对生物）

一、血值：

1.可叠加效果列表：
A类：健康指环(Ring of Health) 英雄生命值+50%
B类：强壮药水(Potion of Toughness)或活力喷泉(Fountain of Vigor)或能量池(Pool of Power)英雄生命值+25%
C类：巨人力量(Giant Strength) 生命值+25%，龙之力量(Dragon Strength) 生命值+100%，祈祷(Prayer) 生命系生命值+25%

2.叠加公式：
血值＝原始血值×（1+A类效果）×（1+B类效果）×（1+C类效果）
注意：多个A类效果是相加，多个B或C类效果是相乘，B类的三种形式实际是同一个东西

二、伤害力：

1.可叠加效果列表：
A类：猛虎头盔(Tiger Helm)和光明指环(Ring of Light) 目前版本无效
B类：力量药水(Potion of Strength)或力量喷泉(Fountain of Strength)，或能量池(Pool of Power)，英雄伤害力+25%
C类：巨人力量(Giant Strength) 伤害力+25%，龙之力量(Dragon Strength) 伤害力+100%

2.叠加公式：
伤害力＝原始伤害力×（1+B类效果）×（1+C类效果）
注意：是相乘关系，B类的三种形式实际是同一个东西，祈祷(Prayer)并不增加伤害力只增加伤害

三、攻击力：

(一)英雄：

1.可叠加效果列表：
A类：各种加英雄攻击力的宝物（技能以及各种访问事件任务奖励算做原始攻击力里面去）
B类：毒气(Vial of Choking Gas) 攻击力-15%
C类：精准(Precision) 远程攻击力+25%，嗜血(Bloodlust) 近战攻击力+25%
D类：老化(Aging) 攻击力-25%
E类：士气高涨 攻击力+25%，士气低落 攻击力-20%

2.叠加公式：
攻击力=（原始攻击力+A类效果）×（1+B类效果）×（1+C类效果）×（1+D类效果）×（1+E类效果）
注意：除宝物是直接加之外其余都是乘法关系

(二)生物：

1.可叠加效果列表：
A类：各种各种提高生物攻击力的宝物（都是百分比形式）
B类：毒气(Vial of Choking Gas) 攻击力-15%
C类：精准(Precision) 远程攻击力+25%，嗜血(Bloodlust) 近战攻击力+25%
D类：老化(Aging) 攻击力-25%
E类：士气高涨 攻击力+25%，士气低落 攻击力-20%
F类：攻击技能(Offense) 攻击力+10%－50%，航海术(Seamanship) 攻击力+10%－50%，陆军元帅(Field Marshal) 攻击力+10%
G类：海上战斗奖励(Bonuses at Sea) 攻击力+50%

2.叠加公式：
攻击力=原始攻击力×（1+A类效果+F类效果）×（1+G类效果）×（1+B类效果）×（1+C类效果）×（1+D类效果）×（1+E类效果）
注意：多个A类效果是相加关系，航海术在海上相当于战术但是不能和战术叠加只取其中较高的，航海日志(Logbook of the Master Sailer)以及海盗的特技一定要在海上战斗才显示效果（行驶在海上也看不出，这点和航海术不同），毒气(Vial of Choking Gas)的一句解释"the enemy target does 15% less damage"纯属多余，其实就是攻击力降低15%，而不是另外再降低伤害15%。

四、防御力：

(一)英雄：

1.可叠加效果列表：
A类：各种加英雄防御力的宝物（技能以及各种访问事件任务奖励算做原始攻击力里面去）
B类：毒气(Vial of Choking Gas) 防御力-15%，酸液(Vial of Acid) 防御力-20%
C类：模糊(Precision) 远程防御力+50%，精神护甲(Spiritual Armor) 防御力+25%，护体石肤(Stoneskin) 防御力+25%，防护(Defender) 防御力+50%
D类：老化(Aging) 防御力-20%
E类：防御(Defend) 防御力+25%

2.叠加公式：
防御力=（原始防御力+A类效果）×（1+B类效果）×（1+C类效果）×（1+D类效果）×（1+E类效果）
注意：多个C类效果是相乘关系，防护(Defender)魔法必须在采取防御姿态时才有效

(二)生物：

1.可叠加效果列表：
A类：各种各种提高生物防御力的宝物（都是百分比形式）
B类：毒气(Vial of Choking Gas) 防御力-15%，酸液(Vial of Acid) 防御力-20%
C类：模糊(Precision) 远程防御力+50%，精神护甲(Spiritual Armor) 防御力+25%，护体石肤(Stoneskin) 防御力+25%，防护(Defender) 防御力+50%
D类：老化(Aging) 防御力-20%
E类：防御(Defend) 防御力+25%
F类：防御技能(Defense) 防御力+10%－50%，航海术(Seamanship) 防御力+10%－50%
G类：海上战斗奖励(Bonuses at Sea) 防御力+50%

2.叠加公式：
防御力=原始防御力×（1+A类效果+F类效果）×（1+G类效果）×（1+B类效果）×（1+C类效果）×（1+D类效果）×（1+E类效果）
注意：与生物攻击力需要注意的地方相似

五、物理伤害：

首先说明一下，伤害≠伤害力≠战场上你用鼠标指着敌人所看到的伤害值，这里所说的伤害是当双方攻防以及伤害力确定以后还有可能被改变从而叠加的伤害效果，以下一项一项说明：

1.可叠加效果列表：
A类：杀戮之箭(Arrow of Slaying) 对4级生物远程伤害+100%，大卫投石索(David's Sling) 对4级生物远程伤害+100%，巨人杀手之剑(Giant Slayer) 对4级生物近战伤害+100%，杀戮(Slayer) 对4级生物伤害+50%，巨人杀手(Giantslayer) 对4级生物伤害+100%
B类：天使之刃(Angle's Blade) 目前版本无效
C类：祈祷(Prayer) 生命系伤害+25%
D类：火抵抗(Fire Resistance) 火属性伤害-50%，冰抵抗(Cold Resistance) 冰属性伤害-50%
E类：各种抵御状态(Ward) 相应种族伤害-33.3%
F类：出现幸运 伤害-33.3%，出现厄运 伤害+50%

2.叠加公式：
最终伤害＝攻防计算伤害×（1+A类效果）×（1+C类效果）×（1+D类效果）×（1+E类效果）×（1+F类效果）
注意：多个A类效果只取最高的效果；龙鳞盾牌(Dragon Scale Shield)在目前版本中处于“半无效”状态；在有幸运效果影响的情况下，战场上你用鼠标指着敌人看到的伤害值并不就是实际可能打出来的伤害值，其他情况下是相符合的。

六、魔法有关效果：

(一)基本公式：

魔法效果＝（基本效果＋英雄等级×效果提升率）×（1＋相关魔法技能效果＋巫术技能效果＋职业附加效果＋终极建筑附加效果＋宝物效果）
用基本公式算出来的魔法伤害是你在战斗中打开魔法书所看到的，但是这并不等于施展到对方身上的魔法伤害，必须考虑对方身上所附着的有益状态；

1.可叠加效果列表：
A类：各种抵御状态(Ward) 相应系别魔法伤害 -50%
B类：各种抗魔披风 魔法伤害-30%－100%，抗魔技能(Magic Resistance) 魔法伤害-30%－100%
C类：抵抗药水(Potion of Resistance) 魔法伤害-50%
D类：出现幸运 闪电、爆裂、碎裂伤害-33.3%，出现厄运 闪电、爆裂、碎裂伤害+50%

2.叠加公式：
最终魔法伤害＝基本公式计算伤害×（1+A类效果）×（1+B类效果）×（1+C类效果）×（1+D类效果）
注意：多个B类效果的叠加比较特殊，当抗魔为30%的时候只取最大值，50%及以上时才纳入上面的公式，而且之间是相乘关系；举例来说，一个基础抗魔英雄带抵抗斗篷(Cowl of Resistance)并且战斗中使用抗魔药水，则受到魔法伤害为原来的（1-50%）×（1-50%）=25%，而当他的技能升级为高级抗魔以后，仅受到（1-50%）×（1-50%）×（1-50%）＝12.5%的魔法伤害，而一旦他换守卫长袍(Cloak of Warding)穿上，受到伤害却又变为（1-50%）×（1-50%）=25%。

七、速度和战场移动力：

1.可叠加效果列表：
A类：各种加速度和战场移动力的宝物 速度或战场移动力+1－2，各种减速度和战场移动力的宝物 速度或战场移动力-1－2
B类：战术(Tactics) 速度+1－5 战场移动力+1－3，航海术(Seamanship) 海上战斗中发挥战术效果，海上战斗奖励(Bonuses at Sea) 速度和战场移动力+2，疾速(Haste) 速度和战场移动力+3，加速(Speed) 速度和战场移动力+3
C类：迟缓(Slow) 速度和战场移动力-50%，疲劳(Fatigue) 速度和战场移动力-50%，粘结(包括粘结剂Vial of Binding Liquid和蛛丝箭Spider's Silk Arrows) 速度和战场移动力-50%
D类：老化(Aging) 速度和战场移动力-50%

2.叠加公式：
速度＝（原始速度+A类效果+B类效果）×（1+C类效果）×（1+D类效果）
注意：多个A类效果和B类效果是直接相加关系，B类的两种加速魔法以及C类的三种效果完全等同不互相叠加，计算结果是去尾取整，所以有时候会出现被敌人减速之后再加速也无效果的情况。

八、魔法消耗值：

1.可叠加效果列表：
A类：能量法杖(Staff of Power) 魔法消耗-33.3%，召唤法杖(Staff of Summoning) 召唤魔法消耗-50%，魔力法杖(Staff of Wizardry) 守序魔法消耗-50%，魔法头饰(Magic Amplifier) 生物魔法消耗-33.3%，艾菲曼陀林(Aiffe's Mandolin) 和平之歌、邪恶之歌、群体振奋魔法消耗-50%，各种魔法卷轴(Scroll) 相应魔法消耗-50%
B类：能量损耗(Power Drain) 魔法消耗+100%，榨取魔力(Magic Leech) 魔法消耗+100%
C类：锁甲(Chain Mail) 魔法消耗+1，钢甲(Plate Mail) 魔法消耗+2，法师杖(Mage's Staff) 魔法消耗-1，法师长袍(Mage's Robe) 魔法消耗-1，金质钢甲(Golden Plate Mail) 魔法消耗+1，闪光指环(Ring of Flares) 魔法消耗-2，混乱火盆(Flame of Chaos) 混乱魔法消耗-2，寒冰天平(Ice Scales) 守序魔法消耗-2，魔力闪光(Mana Flare) 魔法消耗-2，术士(Wizard) 魔法消耗-2

2.叠加公式：
最终魔法消耗值＝原始魔法消耗值×（1+A类效果+B类效果）+C类效果
注意：多个A类或B类效果是相加关系，多个C类效果是直接相加关系

九、血值再生效果：

1.可叠加效果列表：
A类：再生胸甲(Breastplate of Regeneration) 每回合血+若干，再生指环(Ring of Regeneration) 每回合血+若干
B类：再生(Regeneration) 每回合血+若干
C类：再生技能(Regeneration) 每回合血+50

2.叠加公式：
血值再生效果是不可叠加的，多个效果因素都存在的时候，英雄以宝物效果为准，生物以特技为准；注意A类的两种宝物效果完全等同。

十、吸血效果：

1.可叠加效果列表：
A类：夺魂剑(Soul Stealer) 吸血50%
B类：吸血鬼接触(Vampiric Touch) 吸血50%
C类：吸血(Life Draining) 吸血50%
D类：黑暗牧师(Dark Priest) 吸血50%

2.叠加公式：
实际以上4类效果都是完全同一的，所以不可叠加。

十一、陆地移动力：

1.可叠加效果列表：
A类：骑兵手套(Equestrian Gloves) 陆地移动力+25%，旅行之靴(Boots of Travel) 陆地移动力+50%，路人之靴(Wayfaring Boots) 陆地移动力+25%
B类：探路(Pathfinding) 陆地移动力+25%－50%
C类：泥潭(Mire) 陆地移动力－50%
D类：各种野外设施的访问奖励 陆地移动力+1－10
E类：耐力药水(Potion of Endurance) 陆地移动力+3

2.叠加公式：
陆地移动力上限＝（原始移动力上限+D类效果）×（1+A类效果+B类效果）
可用陆地移动力＝原移动力上限×（1+C类效果）-已耗移动力+（D类效果+E类效果）×（1+A类效果+B类效果）
注意：多个A类效果是相加关系，多个D类效果是直接相加关系；英雄的原始移动力会变化，以当前队伍中原始移动力上限最高的生物为准，同时满足不小于22；第二个公式中的“原移动力上限”是指在施加Mire魔法前的移动力上限，并不一定等于“原始移动力上限”。

十二、海上移动力：

1.可叠加效果列表：
A类：六分仪(Sextant) 海上移动力+50%
航海日志(Logbook of the Master Sailer) 海上移动力+50%
B类：航海术(Seamanship) 海上移动力+25%－200%
C类：灯塔(Lighthouse) 海上移动力+10

2.叠加公式：
海上移动力上限＝原始海上移动力上限×（1+A类效果+B类效果）+C类效果
注意：多个A类效果是相加关系；多个C类效果不能叠加，与H3不同！

十三、魔法值：

1.可叠加效果列表：
A类：各种增加魔法值上限的宝物
B类：魔力药水(Potion of Mana) 魔法值+25
C类：魔力漩涡(Mana Vortex) 魔法值+100%
D类：神圣喷泉(Sacred Fountain) 魔法值上限+3
E类：各系别增加魔法值上限的技能
F类：各种恢复魔法值的建筑设施

2.叠加公式：
可用魔法值的叠加是所有叠加效果中唯一受顺序影响的，因为魔力漩涡的效果是不管你原来有多少魔法值一律把可用魔法值加到上限的200%，所以魔力药水就要在访问过魔力漩涡之后再使用了，这样 可用魔法值＝魔法值上限×2＋25。

十四、战斗后的复活效果：

1.可叠加效果列表：
A类：圣十字(Ankh of Life) 复活效果+5%，圣徒法杖(Saint Ranan's Staff) 复活效果+20%
B类：复活技能(Resurrection) 复活效果+20%－50%

2.叠加公式：
三种效果都是相加关系

十五、其他：

包括照亮范围，战斗中攻击次数，士气值和幸运值等

叠加公式：这些效果的叠加都是直接相加就可以了。

SSZ评注：
白菜兄果然是测试狂。这篇文章作为资料的总结和查询都是很有用的。如果不愿意记忆那么多东西，比较简单（决大多数情况正确）的方法是：确切数字的直接加，加了以后和按照百分比加的相乘。这种乘法的计算关系，也是英雄四的一个特色了。


攻击术与宝物的叠加
作者：绝对零度

“加生物攻击力的宝物一定要给攻击术最高的英雄，否则是没有最好效果的。”

从部队界面看到的数据如是说。但这是错误的，把宝物分散的话，从部队界面看指数是下降的，不过在战斗中，却不会变。举例来说，英雄A有宗师攻击术，英雄B无战术系技能。那么一个战神指环给A或给B，在部队界面看效果分别是70%和50%，但在战斗中都一样，效果为70%。简单来说，在战斗中，增加生物能力的宝物和战术系技能是完全独立计算，然后再迭加的，但在部队界面中看是不会体现这点的。

当然，每一类宝物之间是服从最强法则的，例如两个战神指环给同一英雄效果是40%，分给两个英雄就只有20%。此外，四个职业的附加能力被认为是宝物(General的M+1，Lord Commander的M+2，Warden的D+10%，Field Marshal的A+10%)。

所以宝刀配英雄该解释成“加生物攻击力的宝物一定要给Field Marshal，否则是
没有最好效果的。”其他类似。:)

另外，关于航海术：

航海术又是H4中的一个打破最强法则的技能。
航海术的加移动力效果没问题，但它的加攻防效果就很有意思乐。

航海术所加的效果是独立于宝物完全迭加的，举例说明吧：

英雄A有专家防御和防御戒指，英雄B有宗师航海；那么在陆上战斗时防御加成是40%；而在海上时，无论防御戒指给谁，防御加成都是70%，而不是根据最强法则的要求，一定要给B才行。区别在于冒险地图上看生物资料，给A时防御加成是50%，给B时防御加成70%，但在战斗中，都一样。

其他诸如攻击，速度，移动力都是如此。效果是宝物+航海(不必是同一个英雄)最简单的说明就是，在海上战斗时，如果有航海术英雄，可以不调整兵种加成宝物。

航海日志和航海术之间，符合最强法则，航海日志+高级航海>专家航海。


陆地移动力详解
作者：DarkRain.cn

首先交待一个问题，游戏中我们看到的移动力都是整数，但实际上有小数存在。所有兵种的基础移动力，除了30的天使、黑龙、凤凰、恶魔等等，都要加上0.5。例如弩车的实际基础移动力为15.5，妖精的实际基础移动力为29.5。

1、英雄移动力等于部队中地图移动力最高的兵种（下限22.5）。也就是说，一般情况下，无论部队组成如何，都不必担心英雄拖慢部队的行动。

2、拖慢部队行动的是部队中地图移动力最慢的兵种。例如部队组成是骷髅（移动力19.5），英雄，恶魔之子（28.5），那么在移动时只要骷髅行动力消耗19，那么整个部队都不能再移动了。但此时英雄与恶魔之子还有9.5点行动力，想继续前进，措施之一是将骷髅解雇，之二是将英雄与恶魔之子分出来。

3、关于分兵和交换的问题，比较复杂。像上面举过的例子，将英雄和恶魔之子分出来时，两者的移动力是不是一样呢？答案是否定的。
分兵时的计算过程是这样的：首先，将英雄行动力恢复上限（从28.5变成22.5），然后当前行动力相应降低（(28.5-19)/28.5*22.5=7.5），减去走一步（分兵出来相当于要走一步）消耗的移动力（7.5-1=6.5），最后再把移动力上限恢复28.5（因为恶魔之子一起跟过来了），当前移动力相应提高（6.5/22.5*28.5=8.23）；此时英雄剩余移动力与恶魔之子的（9.5-1=8.5）差别好像不大，但是在有斜向移动的情况下，却有可能让英雄少走一步（就是恶魔之子“看起来”还有1点移动力的时候，部队就走不动了）。

4、如果英雄有探路技能、或是加移动力的宝物时，原理与上一条相似，但是此时还要注意生物的移动力变化。
例如英雄是宗师探路，带恶魔之子，剩余行动力12，在沼泽地上将英雄连同恶魔之子分兵出来。首先计算英雄移动力，第一步是恢复，必须要忽略探路技能和生物附加的效果，12/42.75*22.5=6.32，然后减一步，6.32-2=4.32（探路技能效果被忽略了，沼泽地上移一步耗两点移动力），最后还原，4.32/22.5*42.75=8.2；接下来计算恶魔之子移动力，第一步也是恢复，12/1.5=8，减一步，8-2=6，还原，6*1.5=9。此时英雄与恶魔之子剩余移动力就产生了明显的区别。

可以看出，在恶劣地形上移动并且英雄有探路技能或相关宝物、魔法效果时，最好不要分兵，那对英雄移动力的损耗是很大的。等移动力低的兵种消耗完移动力后，再分出移动力高的兵种（英雄），不如在移动力低部队还剩2、3点左右移动力的时候，把移动力低的部队分出来，留移动力高的部队和英雄继续前进。

5、在英雄无敌前三代中，都有一个设定：最后一步特殊处理。就是说，平常斜向移动一步，消耗的移动力是直向移动的1.414倍（2开平方）；但是如果部队最后剩余1格移动力，虽然已经不够斜向移动的需要，但部队此时既可以直向移动，也可以斜向移动。
而对于英雄无敌4来说，这一个设定已经被取消了。部队最后剩余移动力超过1.414格的时候，才能够进行斜向移动。

6、关于移动力加成的计算问题，白菜的叠加效果原理中有提到，我在这里单独拿出来讲一下。
建筑和野外设施的效果是直接加在基本移动力上的，相互之间是相加关系。
宝物或是英雄技能的效果，相互之间也是相加关系。
基本移动力附加上宝物或英雄技能所提升的百分比，得出实际移动力。
例如：弩车当前的基本移动力14.5，访问过马厩(+5)和绿洲(+10)，英雄宗师探路(+50%)，有手套。则弩车的实际移动力是(14.5+5+10)*(1+50%+25%)=51.625。


攻击伤害的上下限
作者：老虎

昨天回去作了一下测试。发现英雄攻击力是有上限的。不过这个上限是个变量。

我自己画了一个小地图，两个英雄各带六只兵：傀儡龙，泰坦，那加，金人，矮人，半身人各100个。英雄的攻防都是20000以上(用金山游侠改的)。伤害力是43～64。两个英雄对攻。

我用英雄攻傀儡龙，显示的杀伤数字是860～1280，攻其他的兵种也是这个数。傀儡龙攻击英雄，显示的数据是180～275，泰坦攻击英雄的数据是170～250，那加是70～110，金人是40～60，矮人是10～15，半身人是5～10。

由于4代的杀伤＝伤害力×数量×攻击力/被攻击对象的防御力。所以计算上面的各族数据得出以下结论：
英雄的攻击力若大于被攻击对象的防御力20倍，以20倍计算。
英雄的防御力若大于被攻击对象的攻击力20倍，以20倍计算。
肉搏和远程通用。
如果英雄有肉搏或箭术技能，那么主动攻击时将忽略掉一部分敌人的防御力。英雄的攻击力将不大于敌人剩余防御力的20倍。

如：英雄伤害力是43～64，近战攻击力是250，英雄攻击黑龙，黑龙的近战防御力是40。但由于英雄有宗师肉搏技能，忽略掉敌人3/4的防御。黑龙只剩下10点防御。所以英雄这时的攻击力应该是200。两次可以打黑龙(43～64)×200×2/10=1720～2560。最多可以干掉6只黑龙。

如果你没有肉搏或箭术，攻击力也不超过敌人的防御力的20倍。没试过敌人被老化后防御力下降的情况，但应该是英雄的攻击力随敌人的防御力变化而变化。结果总不大于敌人防御的20倍。英雄的防御力亦同。

所以，英雄的攻防到达敌方生物的20倍以上时(包括箭术和肉搏忽略掉敌人的防御后)，再用药水或者魔法增加攻防就没有意义了。关键视是伤害力。
所以，英雄的防御很高时，50个半身人对英雄的杀伤力要比1个泰坦的杀伤力高。

（DarkRain.cn注：20倍这个限制，即2000%和5%这两个上下限，不仅对英雄有效，对兵与兵之间的物理攻击也有效。只是兵种的攻防基本上不可能达到临界值。）


H4完整伤害计算公式
作者：baoshanbo

完整杀伤计算公式，包含魔法、技能、宝物、地形等的作用

一. 完整近战杀伤计算公式

攻方伤害统计值[*冲锋][*城墙][*杀戮]*攻防比[*冰/火抵抗][*魔法阵营抵御][*幸运/厄运]
[]内没有就不用计算，以下同。（注①）

1. 攻方伤害统计值（the atrracker's Damage statistic）：
一个生物或英雄伤害统计值为伤害范围（Min—Max）内的随机整数，取各整数的概率相等；相当于掷骰子，骰子有（Max-Mi n+1）面。N个生物伤害统计值为对各个生物伤害统计值求和; 相当于掷N个（Max-Min+1）面的色子。（注②）单个伤害值诅咒/祝福后是一个定值，直接乘个数就得出伤害统计值。增大伤害魔法：巨龙力量：*2。巨人力量：*5/4（取整），右键能显示出来。
2. 冲锋：据骑士/死亡骑士移动距离计算（光标放在目标身上显示的伤害已计算冲锋）。
3. 城墙：在城外隔着城墙或城门攻击城内，一级城墙4/5，二级2/3，三级1/2。在城内隔着城墙或城门攻击城外，一级城墙5/4，二级3/2，三级2。与部队属于攻城方还是守城方无关。城门被破坏或倒下城墙也有效。城门相当于生命50防御10的部队（一级城墙，城门只有１层；二级，城门有2层；三级，城门有3层）：从城外打城门，城门在城内 ；从城内打城门，城门在城外。
4. 杀戮：3/2，被攻击方为4级生物且攻击方有杀戮时（巨人杀手则为双倍伤害）。
5. 攻防比：攻方攻击/被攻击方防御。低于1/20时取1/20，高于20时取20。这里的攻击、防御都是最终值，包括生物防御被肉 搏和箭术忽略。英雄和生物的攻击、防御计算在后面详述。（注③）
6. 冰/火抵抗：1/2，被攻击方有冰/火抵抗且攻击方的攻击属性为冰/火时。（注④）
7. 魔法阵营抵御：2/3，被攻击方有攻击方的抵御时。
8. 幸运/厄运：出现幸运时，取值2/3；出现厄运时，取值3/2。

二. 完整远程杀伤计算公式

攻方伤害统计值*攻防比[*距离][*障碍][*魔法阵营抵御][*火抵抗][*杀戮][*幸运/厄运]

1. 距离：远程攻击（Ranged）实际距离如果超过40英尺，取值1/2。短程射击（Short Range）实际距离超过20英尺取值1/2，实际距离超过40英尺取值1/4。长程射击（Long Range）无此项。
2. 障碍：被攻击方在城内紧贴城墙或在箭塔上，攻击方在城外攻击，取值1/2；射击路线上有灌木树丛、烟雾之类的障碍物阻隔，取值也 为1/2。攻击方有忽略障碍物能力则无此项。（注⑤）
3. 火抵抗：被攻击方有火抵抗且攻击方的攻击属性为火时，取值1/2。（注⑥）

三. 生物的防御（包括肉搏和箭术忽略）

DF[*虚无/骨骼][*(1+Defense)][*地形][*瓦解射线][*老化][*邪歌][*精神护甲][*护体石肤][*模糊][*防御][*防护][*海上战斗奖励][*酸液][*Vial of Choking Gas]
DF为生物的原始防御（骷髅/幽灵/风元素为12/15/16）被忽略防御力技能忽略成的一个数。

1. 忽略防御力这技能攻击敌人英雄或是防御力低于10的生物时不起作用，对于防御力高于10的生物，最多将其忽略到10。
2. 虚无/骨骼：2。
3. Defense：战术或航海的Defense、加防御?%宝物、守卫者特殊能力，其叠加为相加，按Defense最大的英雄计算 ，最多为1.7。战术系的Defense和航海术（在海上）的Defense都有时，取其中较高的。航海日志(Logbook of the Master Sailer)要在海上战场上才显示效果，与说明不符，无航海术/战术也有作用。
4. 地形：箭塔2，河/流沙4/5，树丛/草丛5/4。
5. 模糊、防护为3/2，瓦解射线、老化、邪歌为4/5，精神护甲、护体石肤、防御为5/4。
6. 海上战斗奖励：要在海上战场上才显示效果，3/2。
7. 酸液：4/5。Vial of Choking Gas：17/20。

四. 生物的攻击

原始攻击[*近战减半][*(1+Offense)][*地形][*虚弱][*老化][*嗜血/精准][*邪歌][*祈祷][*士气][*海上战斗奖励][*酸液][*Vial of Choking Gas]

1. Offense：战术或航海的Offense、加攻击?%宝物、陆军元帅特殊能力，其叠加为相加，按Offense最大的英雄计 算，最多为1.7。关于航海术与航海日志与Defense同。
2. 近战减半：无近战不减能力的远程生物，1/2。
3. 地形：箭塔2，河/流沙3/4。
4. 老化、虚弱为3/4；邪歌为4/5；嗜血/精准、祈祷为5/4。士气高昂5/4，士气低落4/5。
5. 海上战斗奖励：要在海上战场上才显示效果，3/2。
6. 酸液：4/5。Vial of Choking Gas：17/20。

五. 英雄攻击、防御

用以下面地图上数值代替生物防御、攻击计算公式中的DF或原始攻击。防御、肉搏攻击、远程攻击的极小值为5。地图上英雄肉搏攻击 、防御就是见到的数值。

防御=战斗技能防御[+防御奖励][+宝物防御][+临时防御奖励]。（注⑦）
肉搏攻击=肉搏技能肉搏攻击[+攻击奖励][+宝物肉搏攻击][+战争领主特技][+临时攻击奖励]。
远程攻击=箭术技能远程攻击[+攻击奖励*0.7][+宝物远程攻击][+游侠特技][+临时攻击奖励*0.7]。注意，不能射箭看不到。
防御奖励、攻击奖励在编辑器定制英雄时可设。能力强化建筑也能加。用事件可以加减（临时）防御奖励、攻击奖励（都是有符号4字节 整数）。

注：

①/*程序算法：攻方伤害统计值是整数，攻防比是实数，其余都是分数（即乘一个数，再出一个数）。计算分两步，第一步算到第4 项，前4项的计算结果是整数。最后计算结果也是整数，小数处理：数值较小时用进一法，而数值较大时用舍去法。为减少误差，先算所有乘，再算所有除，以下涉及分数时算法类似。*/

②/*在生物数超过10又不是10的倍数时伤害总值还要经过整定。
生物数量较大时，可能改用一种比较简单的方法：产生一个随机变量，此随机变量的分布为正态分布（不懂的请参阅概率论/工程数学） ；平均伤害值（只有一位小数）为此随机变量的函数；再乘以个数得到伤害统计值（取整）。*/

③ /*攻击、防御也是实数变量，右键显示整数（小数处理为：小于等于0.5舍，大于0.5入；或四舍五入）。英雄和生物的原始攻击 、防御均为整数。*/

④ 气息攻击（Breath Attack），沿着攻击方向9英尺×3英尺范围；WOW弧形焰息（Arc Breath Attack），一个很大的扇形区域。硬接触攻击目标遭受的攻击为火属性攻击。不接触却遭到气息的部队，如有火抵抗不受伤害，如无火抵抗受到的伤害仍按以上计算。

⑤射击时的1/2、1/4等有时是距离，有时是障碍，有时为两者乘积。另外，非范围射击的远程部队，在弹药耗完之前的最后一箭，不计算距离和障碍。对某目标原本不能射击（一般无范围射击能力），但现在因为有范围射击能力能射击，此时不计算距离和障碍；如前面有别的目标挡着（有时是挡一半），又如目标在城内不紧贴城墙。

⑥ 火元素射击火元素、火怪、凤凰、火卫士时，计算火抵抗。在tgs中火焰箭只是将英雄的普通远程攻击变为范围射击，不是火属性。在WOW中火焰箭中心点为普通物理攻击。周围的火焰气息（无硬接触），如有火抵抗不受伤害，如无火抵抗受到的伤害仍按以上远程杀 伤公式计算。WOW中投石车射击是从中心点下手的气息攻击。中心点为火属性攻击（有硬接触）。周围的火焰气息（无硬接触），有火抵抗不受伤害 ，无火抵抗受到的伤害仍按以上远程杀伤公式计算。（……火石向周围冒火，与箭向周围冒火不同。）

⑦战斗技能防御（无，基础，高级，专家，大师，宗师）：10，15，20，30，40，60。肉搏技能肉搏攻击（无，基础，……，宗师）：10，15，20，30，40，40。箭术技能远程攻击（无，基础，……，宗师）：7（=10*0.7），10，15，20，30，30。


伤害力取值的原理
作者：DarkRain.cn

    伤害力取值的问题，在baoshanbo的完整伤害计算公式中曾经提过，但是讲得不是很详细。其实这个研究是两年多以前在游家论坛的讨论，以tempest39910和tyfon的讨论作为开头。后来我提出了当年玩三代时候的一个设想，经初步验证，与事实非常接近。在wangyongqing的参与下，又对计算方式作了进一步的修正，得到了最终公式。最后由三国郝昭从数据追踪（分析程序）的角度，证实了我们共同推导的公式是正确的。下面，以尽量浅显的语言，来描述伤害力取值的原理。

    关于四代的伤害计算，在不考虑其他因素的情况下，简单表述是：
        最终杀伤＝基本杀伤×部队数量×攻击力÷防御力
    基本杀伤与部队数量之间直接使用了乘法，其实这是不正确的。这个公式只能用来计算伤害的上下限，而无法体现伤害力取值的详细过程。

    为什么伤害力取值不能用乘法呢？因为用乘法存在两个明显的弊端：1、非常容易出现过大或是过小的数值，例如100个盗贼的杀伤，只考虑基本杀伤（1～3）和部队数量（100）的情况下，100或是300这样的伤害都非常容易出现。2、整体伤害取值不连续，例如2个兵的杀伤一定是偶数，3个兵的杀伤一定是3的倍数，100个盗贼的杀伤只可能是100、200、300这三种情况。

    实际的伤害力取值是采用“分开取值，最后相加”的方式进行的。例如3个盗贼，第一个盗贼伤害取值2，第二个盗贼伤害取值1，第三个盗贼伤害取值2，则最后杀伤是2+1+2=5。

    对于单个兵来说，伤害力的取值是在其上下限范围内的整数，每个数值的出现概率都相同（平均分布）。例如伤害力范围1～3的盗贼，其伤害力取值是1、2、3三种可能，每种可能的出现概率都是1/3。

    而对于多个兵来说，平均分布的叠加就不再是平均分布。

    2个盗贼：
    1+1=2
    1+2=3
    1+3=4
    2+1=3
    2+2=4
    2+3=5
    3+1=4
    3+2=5
    3+3=6
    可以看出，取值为2的概率是1/9，取值为3的概率是2/9，取值为4的概率是3/9（1/3），取值为5的概率是2/9，取值为6的概率是1/9。

    3个盗贼：
    具体过程不列出了，取值概率是
        3　　1/27
        4　　3/27
        5　　6/27
        6　　7/27
        7　　6/27
        8　　3/27
        9　　1/27

    4个盗贼取值概率是
        4　　 1/81
        5　　 4/81
        6　　10/81
        7　　16/81
        8　　19/81
        9　　16/81
       10　　10/81
       11　　 4/81
       12　　 1/81

    其整体趋势已经相当明显了：兵的个数越多，伤害力取值的概率就越集中于中间部分，并且是左右对称的。

    从概率论上来说，平均分布的不断叠加，其特性会越来越接近于正态分布，类似于下面这张图：

    但是对于程序来说，不可能完全依照“分开取值，最后相加”的方式来进行。如果一组兵有10000个，就要取10000个数值然后进行叠加，这对电脑来说会形成很大的负担。

    因此，NWC在伤害力取值上采用了一个折衷的办法：
    如果兵的个数N不超过10，那么采用“分开取值，最后相加”的方式来取值。
    如果兵的个数N超过10，那么先对10个兵采用“分开取值，最后相加”的方式来取值，然后用[10兵伤害]*N/10，得出N个兵的伤害值。

    由于采样次数不够多（仅有10），因此最终伤害的概率分布还不是真正的正态分布，只是有点接近而已。

    作为实战应用来说，明白了伤害力取值的原理，就会知道打出很大或很小的伤害都是几乎不可能的。在预测的时候，只要考虑平均值附近的结果就可以了。

    最后说一句，英雄无敌系列，从第一代到第四代，都是采用这种取值方式来计算伤害值。这个伤害值计算出来之后，结合攻击、防御、魔法等因素（每一代公式都不一样），来计算最终的物理攻击伤害。


战场行动要点若干
作者：tyfon

1.以兵种当前位置为原点，取沿网格边的方向为x轴及y轴。战场上行动方向即可分为轴向与角向（沿网格对角线的方向）。兵种的行动路线为：先轴向后角向。

2.兵种的移动力以尺（foot）及码（yard）为单位。一尺就是战场上的一小格，一码合三尺。在魔法书中，一般表示战场距离的数字均以码为单位，比如地狱火的作用范围为5*5，即5码*5码，而流沙魔法却以尺为单位。一般情况下看到的兵种战场移动力都是以码为单位，并不准确。以尺为单位的精确移动力数值只有在招募生物时可以看见。

3.不同的地形对战场移动力有不同的影响，但与冒险地图中的影响有所不同。如下：
游戏中共有8种基本地形
a.草地（grass），包括干草地（drygrass）、茂密草地（lushgrass）、魔法平原（magicplains）、生命原野（fieldoflife）、魔幻石地（enchantedstone）、魔法花园（magicgarden）及荣耀原野（fieldofglory），消耗1倍移动力，原住民（生命、自然）消耗1倍移动力；
b.沙地（sand），包括沙漠（desertsand）及沙滩（beachsand），消耗1.5倍移动力；
c.地底（subterranean），包括岩石地底（subterraneanrock）及泥土地底（subterraneandirt），消耗1倍移动力；
d.戈壁（rough），包括岩石戈壁（rockyrough）及龟裂戈壁（sun-bakedrough），消耗1.25倍移动力，原住民（力量）消耗1倍移动力；
e.土地（dirt），包括土地（dirt）及生苔土地（mossydirt），消耗1倍移动力
f.沼泽（swamp），包括浅沼泽（shallowswamp）及深沼泽（deepswamp），消耗1.5倍移动力，原住民（混乱）消耗1.25倍移动力；
g.火山（volcanic），包括死火山（coldvolcanic）、活火山（hotvolcanic）、诅咒之地（cursedground）及焦土（scorchedearth），消耗1.25倍移动力，原住民（死亡）消耗1倍移动力；
h.雪地（snow），包括雪地（snow）及冰地（ice），消耗1.5倍移动力，原住民（守序）消耗1.25倍移动力；
此外，所有的桥面消耗1倍移动力，所有船只的甲板也都消耗1倍移动力，而道路的地形则取决于其附着的地形（比如，沙地上的卵石路，仍然显示沙地地形）。特别的是，冰河（iceriver）并不是雪地地形，而是和道路一样取决于其附着的地形。至于熔岩流（Lavariver），这种地形无法行走，就算是用编辑器覆盖上道路也不行，但是，假如覆盖上前面说过的冰河，便可以行走，并在战斗时显示火山地形。


战场操作汇总
作者：xxdxxd

整理了一下几天的测试结果，放在一起，其中包含及参考了baoshanbo、lzkong等人的结果。

H4的战场为斜45度正方网格，其中每小格的边长为1英尺（见《东方卷轴》）。战场上生物数据中显示的移动距离为码，1码为3英尺，所以显示数据为生物实际移动力除3，小数部分舍去，例如弩车的实际移动力为8英尺=2.6667码，显示数据为2码。

以下所有关于距离的单位皆为英尺（即小格的边长）。

1、生物尺寸

H4中所有生物在战场上占据的位置皆为实心圆形，但被填充至小格（不懂者可参考计算机图形学中关于圆形的像素表示）。共有5种生物尺寸，最小的被填至3*3（结果就变成方形了），最大的直径方向为7格，在四个45度角方向有锯齿。

对于生物尺寸，我作了如下定义：
将不同尺寸的生物按其直径方向实际填充后的格数来称呼，最小的（3*3）称为3格生物，最大的称为7格生物（英雄为4格生物）。生物的半径定义为：（格数+1）/2，例如3格生物半径为2，6格生物半径为3.5。

生物填充（或占据）网格的具体方式为：
3格生物：3*3正方。
4格生物：4*4正方。
5格生物：5*5正方再在四个角上分别去掉一小格。
6格生物：6*6正方再在四个角上分别去掉一小格。
7格生物：7*7正方再在四个角上分别去掉“L”形的三小格（每个角形成双锯齿）。

对于奇数格生物，其中心点在小格的中央；对于偶数格生物，其中心点在网格的格线交点处。

2、生物的移动

对于步行生物，鼠标指针为人型，其目的点（热点）位于前伸臂的肘弯处（你要让部队走到哪格，就要保证肘弯在哪格中）；对于飞行生物，鼠标指针为一对翅膀，其目的点位于翅膀连接处的最下端（尖角）。
生物移动时，只能保证在移动后，目的格一定被占据，至于是被生物填充中的哪一格占据，由程序自动按照最短移动距离来得出。例如，对于3格生物，如果想往正右上移动一格，那么点在生物正右上3格中的任意位置，结果都是一样的。
生物的移动只能有8个方向（沿着格或与格成45度角）。如果起点和终点之间不是正好这8个方向之一，就需要用折线连接起来（即使飞行也不是直线）。生物移动的实际距离就是折线的长度（生物中心点经历的折线），可能保留一定的小数部分（在测试冲锋时发现有非整数情况）。如果有障碍，则需计算绕过障碍的最短距离。这里说的“绕过”，只要保证生物在运动路线上的任何一个位置处，其填充的网格都没有被障碍占据即可，所以当7格生物绕另一个7格生物时，完全可以利用双方锯齿之间的“咬合”来缩短移动距离。
生物移动到目的地后，其面朝的方向为最后一段折线的方向。如果该方向与网格成45度角，则生物自动朝最近的敌人转45度角，与网格方向对齐。生物面朝的方向对贴远程有用（这点还是从lzkong那里知道的）。

3、生物的贴身

生物与生物之间可以做到完全贴身，只要保证相互之间占据的网格不重叠即可，所以对于大型生物，贴身时能够进行锯齿“咬合”。
在贴远程时，只有远程兵的中心位置在贴远程兵的“视线”范围内时才不能射击，所以背对着远程是没有用的，无论贴得多紧（lzkong提出当远程被贴时，找一兵从对方背后攻击，迫使其转身，从而我方远程就能射了）。说得严格一点，只有当双方中心点之间的连线与贴远程的部队所面对的方向之间的夹角不大于90度时（90度可以贴），贴身有效。
如果双方之间尺寸的奇偶性不同（例如用5格兵贴4格兵），则其中心点在两个方向上的相对位置都会有0.5格的差别（一个在格中心，另一个在格线上）。在计算贴远程时，这0.5格被忽略。此时，即使两者中心点的连线比90度再后退半格（已经略大于90度），贴身也有效。
对于贴远程的有效距离（指双方中心点间的距离），等于双方的生物半径之和加2。若双方之间尺寸的奇偶性不同，则额外的半格被忽略。例如，用3格兵贴7格兵，则有效距离为：2+4+2=8。如果双方的中心点之间的相对位置（坐标）为（8，0），能贴；相对位置为（6，5），由于6^2+5^2=61<64=8^2，能贴；相对位置为（7，4），由于7^2+4^2=65>64=8^2，不能贴。如果用4格兵贴7格兵，则有效距离为：2.5+4+2=8.5，略去小数，仍为8。如果双方的中心点之间的相对位置为（8.5，0.5），略去小数为（8，0），能贴。同样，相对位置为（6.5，5.5）能贴，（7.5，4.5）则不能贴。
总的来说，不论哪种情况，如果正贴的话（即相对位置中有一个数为0或0.5），只要双方所占据的网格边界之间的距离不超过3格（3格可以贴），贴身就有效。

4、生物的肉搏攻击

生物在进行肉搏攻击时，需要有一定的战斗距离，不能完全紧贴。这个距离大约是双方的生物半径之和加1（比贴远程的要求小一格）。有一个例外，那就是当攻击方背后有障碍，无法拉开战斗距离时。此时可以进行完全贴身攻击。
攻击时，攻方的位置不是任意的，基本上由剑光标的方向确定，有少数一些情况下，同一剑光标方向，但剑尖点在不同位置（即使在同一小格中），也有两个不同的攻击落点（希望第二次进行原地攻击的朋友要小心）。有时这两个不同的攻击落点（指攻方攻击时所站的位置）反映在剑尖位置上只有一到两个像素的差别。这造成了攻击落点位置的数量常常大于剑光标方向的数量（妖精攻击妖精有14个剑光标方向，却有18个攻击落点）。
具体可能的攻击落点和剑尖方向，依赖于双方的兵种尺寸，不同组合的结果也不同（一共有5*5=25种），包括攻击落点的数量和剑光标方向的数量。目前尚未找出规律。同时，如果攻方背后有障碍，攻击落点也会发生变化（例如紧贴攻击）。另外，攻击落点并不是对称的（可能由于舍入误差引起），甚至剑光标的方向都不对称，例如妖精攻击妖精有14个剑尖方向及18个攻击落点，都无法除4。这就造成了当对方冲过来攻击时，由于两边不对称，我方有可能无法对其进行原地攻击（在对付有先攻技能的对手时比较讨厌，幸亏这种情况似乎并不多见）。可能的解决方法可以靠另一支部队将我方准备攻击的部队抵住，使其无法移动到正常的攻击落点处，从而达到原地攻击的目的，不过具体走位可能需要试若干次，是否一定能达到目的我也不敢保证。
关于肉搏攻击，目前只知道这么多，很多规律都没能总结出来，期待高手予以补充。

5、关于冲锋
参考了baoshanbo关于冲锋的测试结果，我又再做了一些测试，对于冲锋的公式已经比较清楚了（关于冲锋问题，原《东方卷轴》的公式有点误差）：

冲锋伤害=原始伤害*（1+冲锋加成）
其中：
冲锋加成=（D-5.4)*0.2/7，结果保留2位小数，后面的四舍五入。如果小于零，按零计算。
或：
冲锋加成=（D-5.25)*0.2/7，结果保留2位小数，后面的舍去。如果小于零，按零计算。

公式中的D为移动距离（可以有小数，但保留几位不太清楚）。上述两个公式的计算结果完全一样，所以我不确定H4用的哪一个（后一个的可能性较大）。对比《东方卷轴》给出的公式：移动距离×3%-20%，也可把上述公式表达为类似形式：

移动距离×20%/7-108%/7，三位后四舍五入
或：
移动距离×20%/7-15%，三位后舍去。

与《东方卷轴》原来的公式比较，主要差别在于：每步冲锋的加成不是3%，而是20%/7=2.85714%，即7步加20%（是准确的20%）。

baoshanbo提出的公式为：1+0.086*（f-1.83），其中f是“战场移动距离”。但他的这个公式中f的单位实际上是码，也就是我所上面所说的移动距离（单位为英尺）的3倍。令f=3*D，他的公式变为：1+0.028667*（D-5.49）四舍五入，与我的公式基本吻合。

另外，baoshanbo曾提出，围着一个敌人部队转圈打的战术似乎不象原《东方卷轴》中说的那样“并没有想象中那么强”（当然各人关于想象中有多强的感觉可能也不太一样）。根据前面各部分的结果，可以粗略估算一下，理想情况下的绕圈打究竟有多强（在没有其它任何障碍的情况下）：
假定生物都是标准的圆形，那么从被攻方的正面绕到背后，可以认为是攻方的中心绕被攻方中心转了半个圆。当然，由于在起点和终点，双方都需要拉开战斗距离，而在从侧面绕的时候，却可以紧密贴身而过，因此实际上应当是半个椭圆，不过作为估算，这点误差可以忽略。按这种近似，圆的半径为双方的战斗距离，因此冲锋距离为该半径乘PI。骑士和死骑都为6格生物，半径为3.5，于是：
a、绕最小的3格生物（例如妖精），战斗距离为3.5（骑士半径）+2（妖精半径）+1=6.5，冲锋距离为6.5*PI=20.42，得到冲锋加成为43%。
b、绕最大的7格生物，战斗距离为3.5+4+1=8.5，冲锋距离为8.5*PI=26.7，得到冲锋加成为61%。
无论如何，我觉得这个结果还是不错的，尤其是绕小型生物时，居然有40%以上，这是我所没想到的。而且从结果来看，绕大型生物并不比绕小型生物好很多（还不到20%），这主要是骑士本身的体形较大，再加上战斗距离的作用，一定程度上弥补了被攻方的体形不足。
实测的结果与上述值基本接近（多数情况下略小），对于3格生物，实测结果在40%~47%之间，对于7格生物，大约在56%~63%之间（这一结果baoshanbo也提到过）。这中间的误差和波动是由于攻击落点不能随意选择，导致不可能恰好转到被攻方正背后的原因。在有些攻击落点处，结果居然还可以比模型计算值高！

通过对冲锋的验证，觉得自己给出的生物半径、战斗距离等模型基本上是合理的。欢迎大家批评指正（情况太多，测得不太全面，可能有不少漏洞）。

6、特殊兵种的情况

枪兵和拿迅视戟的英雄，其主动进攻时，战斗距离额外加4。同时，贴远程时，其有效范围也加4。


英雄无敌4脚本详解
作者：baoshanbo

脚本详解

英雄4可以用脚本来实现事件。

根据事件发生的时机，可大致分为两类：一类是时间，包括定时事件（每天自动存档前发生）和持续事件（在某些行动后会发生）；一类是地点事件，包括放置事件、任务小屋、任务门、任务警戒塔事件、战斗前后的事件（遭遇的、胜利的、失败的）、进城事件。

数据：时间、资源、生物数等游戏数据和地图定义的变量。
地图定义的变量：与一般编程语言里的变量相同，但只有整型变量和布尔变量。变量名要求是字母数字组合。
整型变量，有符号4字节。编辑器在赋值、运算时能输入的立即数为有符号2字节，有符号2字节相乘结果在有符号4字节之内。还有些立即数范围为9999、99。
但在调整资源时黄金最大9999999，其他资源最大99999，增加经验值最大9999999。这些立即数都是有符号4字节（超出了有符号2字节的范围）。
布尔变量，只有两种取值，即假（0）和真（1）。布尔变量与一些布尔类型数据（如某颜色被消灭）的逻辑运算用来做选择脚本。
整型和布尔类型数据编辑器帮助说的很详细。

对变量的操作：赋值、取值、运算。
运算：整型变量，加（“+”）、减（“－”）、乘（“×”）、除（“/”，做除法运算得商）、求余（mod函数，做除法运算得余数）。除和求余有bug，在平衡补丁里解决了。
布尔变量，与、或、非。

可触发事件：相当于函数，一般被别的脚本调用。本脚本调用可实现循环脚本（原版混乱战役有）。事件名可以用中文

脚本：

触发定制事件：这个脚本根据事件名调用可触发事件。

次序：即有顺序的几个脚本的打包，执行到这里会依次执行里面的脚本。如果里面是空的，什么也不会做（Do Nothing）。

Do Nothing：什么也不做。

有条件的行动：根据条件进入分支，这就是选择脚本。

移除脚本：移除这个事件的脚本。

变量赋值、运算脚本。

下面是看得到的具体行动脚本：

A. 显示信息：只当前玩家能看到。

B. 玩家
失败/胜利、取消标准胜利条件、使标准胜利条件生效、给予/拿走资源
清除/设置失败条件简介、失败信息、胜利条件简介、胜利信息。

C. 更替所有者：城、矿、部队的所有权转移给一个指定的玩家。（不能在英雄身上设）

D. 城
建造房屋：在这个城镇里建造一个建筑。
减小/增加生物产量。

E. 部队
战斗、询问问题，可根据结果进入分支。
减小/增加幸运值、士气、赐予/拿走宝物、给予/拿走生物、增加当前行动力

F. 英雄
减小/增加当前的魔法点数、防御力（tgs有bug）、攻击力、最大魔法点数、速度
给予技能、给予魔法、增加技能。

G. 地图
删除冒险目标（用标记）、移除此物体（放置事件，常用于潘多拉宝盒）。

以下摘自英雄无敌IV战役编辑器帮助文档汉化完整版v1.02(注①）：

布尔变量(条件)类型：

和：允许你在单个事件中建立多种条件。
baoshanbo注：和就是逻辑运算“与”
结盟：检查一支指定的军队是否属于一个特定的结盟。
“结盟”是阵营。
拥有某个英雄：检查一支指定的军队是否拥有一个特定的英雄。
可以给予技能：检查一支军队里的一个或几个英雄是否能够接受某个技能。
相等：检查两个表达式是否相等。
假：检查条件是否为假。
“假”就是布尔类型立即数“假”。
大于：检查一个表达式是否大于另一个。
大于或者等于：检查一个表达式是否大于或者等于另一个。
拥有宝物：检查一支军队是否拥有一个特定的宝物。
某位英雄死亡：检查一个指定姓名的英雄是否已经死亡。
某位英雄在监狱中：检查一个指定姓名的英雄是否被囚禁。
一开始的就有的“监狱英雄”不算，英雄在城的监狱里。
少于：检查一个表达式是否小于另一个。
少于或者等于：检查一个表达式是否小于或者等于另一个。
非：允许你否定一个变量并检查除这个变量以外的其他变量。
或者：允许你创建一个选择性条件，其中两个时间都可为真但不是同时。
或者是逻辑运算“或”，同时为真也可以；这里说成了“异或”
玩家属于某个联盟：检查一个指定的玩家是否属于一个特定的结盟。
“联盟”是阵营。
玩家属于某种颜色：检查一个指定的玩家是否为一个特定的颜色。
玩家为电脑操纵：检查一个指定的玩家是否为电脑玩家。
玩家被消灭：检查一个指定的玩家是否被彻底打败。
玩家由人操纵：检查一个指定的玩家是否为人类玩家。
玩家拥有某位英雄：检查一个特定的玩家是否拥有一个指定姓名的英雄。
玩家拥有某个城镇：检查一个特定的玩家是否拥有一个指定名称的城镇。
真：检查条件是否为真。
“真”就是布尔类型立即数“真”
变量：允许你设置变量名称。
这里“变量”就是布尔变量，取值或赋值用

数字表达式类型：

部队中生物数量：指一支军队里的一定数量的生物类型。
当前日期：指从游戏开始之日起的当日。
本周当前日期：指从游戏开始第一周起的当日所在的周。
分成：允许你将一个表达式被另一个分开。
“分成”是除。
经验等级：指一支军队里的一个或几个英雄的等级。
技能掌握：指一支军队里的一个或几个英雄对一个特定技能的掌握程度。
数量：指一个特定的数量。
数量就是整型立即数。
资源数量：指一定量的资源。
减少：允许你对两个表达式相减。
当前月份：指从游戏开始第一个月起的当日所在的月份。
否定：允许你否定一个数字表达式。
玩家名称：指一个特定玩家。
加上：允许你对两个表达式相加。
随机数量：生成一个随机数并允许你设置最大值和最小值。
剩余量：指两个表达式分成之后所留下的数量。
剩余量是求余运算。
相乘：允许你对两个表达式进行相乘(叠加)。
相乘就是乘法运算。
部队里面生物总数量：仅指一支军队里生物的总数量，包括全部生物类型。
部队里面英雄总数：仅指一支军队里英雄的总数量。
变量：允许你设置变量名称。
这里“变量”是整型变量，取值或赋值用
当前星期：指从游戏开始第一周起到现在所在的周。
本月当前周：指从游戏开始的第一个月起到现在所在的周。
本月当前周：从本月第一周算起。

注①：
制作日期：2003年9月1日
翻译：风夕0149
洞穴人
神气活现！
感谢：tempest39910
制作：神气活现！

更替所有者：

1. 在我方（假设为红色）有城情况下，“比武”后再使对手英雄变为我方。
设一个只有一固定部队的联盟，假设为橙色。
在“比武”对手英雄（假设原为青色）身上设遭遇事件：
(1). “比武”对手英雄变为橙色；
(2). 联盟的原固定部队消失（易帜或被打败）
“比武”胜利后，对手英雄（已是联盟）被关进最近成的监狱，进入城，左键点监狱，对手英雄被放出来，并归我方。

2. 如何让上一关带来的战役英雄（Carrayover_hero）易帜。
Carrayover_hero身上无法设更替所有者事件，可以在旁边放一只部队，身上设更替所有者事件，并将两只部队封在小块空地上出不来。

任务详解

地图编辑器->Adventure Objects->quests页面中的东西。这里主要是指任务小屋、任务门、任务警戒塔。相应颜色的帐篷和门、塔，神谕和挖宝的地点比较简单，这里就不说了。

可分为标准任务和非标准任务。触发脚本项用来编非标准任务，其他项联合起来编标准任务，相互独立。游戏中触发脚本先起作用，然后才是其他项起作用。游戏中右键显示信息时，如某项信息没有填，显示空白。游戏中访问（点左键）时，如某项信息没有填，什么也看不到。评分的任务项是计标准任务。

A. 常规：
A1. 地点名称：在游戏中用不到，方便制图用。
A2. 任务记录条目：
有侦查术时，未访问点右键就看到任务记录条目。
否则未访问点右键显示“这里可以领取任务。”或“谁知道任务门（任务警戒塔）需要什么条件才能通过”。
任务小屋，在访问后，未完成标准任务之前，点右键将看到任务记录条目，点Q键调出所有任务记录条目。
任务门，在访问后，点右键将看到任务记录条目。

B. 触发脚本：功能很强大。最简单使用是作为标准任务的补充。触发脚本可重复触发，因此可以用条件选择来编复杂的任务。其实这和空地上放置的事件是一样的。

C. 提示信息：标准任务中，第一次访问时显示的信息。

D. 前进的信息： 标准任务中，在访问后，还没达到任务要求时访问显示的信息。

E. 任务要求：标准任务中完成任务的需要的条件，一般是一些状态（变量）的逻辑运算。

F. 完成问题：任务门无此项，达到条件就让通过。
如果不填此项，达到任务要求时访问将直接执行完成的脚本。填了，达到任务要求时访问将先显示问题，玩家选钩则执行完成的脚本，选叉暂不完成标准任务。

G. 完成的脚本：
任务门没有这一项，任务门并没有需要“完成”的脚本，任务门随时检查部队是否满足任务要求，以此决定是否让通过。
任务小屋，完成标准任务执行的脚本。一般是交易，有得有失，有时候也可能只有得或只有失。
任务警戒塔，因为最重要的就是消失以让路，完成的脚本不是必需的；如果有一般是“拿走宝物”、“拿走资源”。

H. 空信息：仅任务小屋有此项。完成标准任务之后，再访问时显示的信息。完成标准任务之后点右键显示“这个任务已完成”

单人地图难度控制：

序言（定时事件第一天）里依难度设变量dif为4，6，9，12，18（或其他序列）；设变量dif2=0。

设一个定时事件（或其它事件）。
次序：设变量dif2=dif2+dif*A；
触发事件++。

再设一个可触发事件，名为“++”。
如果dif2>=B，次序：
触发+++；
dif2=dif2-C；
触发++。

然后在一些电脑部队身上设一些可触发事件，名为“+++”，内容为增加电脑部队的实力（如加经验，给几个兵）。同名可触发事件都会被调用。

持续事件和循环触发可触发事件移除脚本问题：

必须这样：

如果“条件”那么：
1. 将条件置反脚本
2. 行动脚本
3. 移除脚本
否则Do Nothing。

否则下面也有脚本游戏中会出错

用战斗来使部队消失，部队消失脚本也没了，也必须这个问题。


地图编辑器的一个技巧：修改英雄的基本技能
作者：mzzwxy

英雄自己的基本技能是不可以删掉的。
我在乱改英雄技能的时候发现，可以先换种族，把技能改好后，再把种族换过来，技能就保留下来了。
不过要是在换种族之前，先选一下技能选项，然后再换种族的话，事先编辑好的技能就都没了。

（注：具体的顺序是这样：选英雄职业-->定制技能-->确认-->再选英雄，直接改职业，不要去看技能-->确认）


heroesⅣ中英文版共存的方法
作者：baoshanbo

目前heroesⅣ的极速风暴中文版和winds of war(英文版)用的比较多。如果想玩两个版本，我觉得共存两个版本比较好。
两版有些文件是一样的，主要是Data文件夹下的较大的文件：

heroes4.h4r（608,978,363B）
movies.h4r（58,326,576B）
Music.h4r（79,375,576B）
storm_override.h4r（37,310,200B）。

其余文件并不大，加起来只有100多MB。上面几个大文件留一份就可，需要玩哪一版，就搬动这几个文件到那一版的Data目录下便可。空间够大也可只共享heroe s4.h4r。

DarkRain.cn注：

用这个方法可以节省不少硬盘空间，但是每次更改语言时都要手动搬移文件，比较麻烦。曾经有人提到过更好的方法，但是忘记是谁说的了，我重新写了一个过程说明：

建立一个heroes4文件夹，然后在下面分别建立cn、en、x三个子文件夹。上面提到的四个大文件放入x子文件夹，而其余的文件，中文版的放入cn文件夹中，英文版的放入en文件夹中。形成这样的结构：

heroes4
└┬─ cn ── heroes4.exe等文件
│ ├ Data ─ carryover.dat等文件
│ ├ Games ─ 存档
│ └ Maps ─ 地图
├─ en ── heroes4.exe等文件
│ ├ Data ─ carryover.dat等文件
│ ├ Games ─ 存档
│ └ Maps ─ 地图
└─ x ── heroes4.h4r、movies.h4r、Music.h4r、storm_override.h4r四大文件

然后用UltraEdit这个工具打开中文版的主程序（cn文件夹下面的Heroes4.exe），查找ASCII字串“Data/heroes4.h4r”，将它更改为“../x/heroes4.h4r”。后面还有一个“Data/heroes4.h4r”，一起改了。而movies.h4r、Music.h4r、storm_override.h4r就跟在下方不远，同样是将之前的“Data/”更改为“../x/”。
保存后关闭。再打开英文版的主程序，如法炮制。这样无论进入中文版还是英文版游戏，都不会有问题，并且也不需要手动搬运程序。中英文版共存的情况下，只占据1G多一点的硬盘空间，节省了不少。

重要提醒！！！：

在使用地图编辑器之前，需要手动将x文件夹中的文件搬回原来位置，否则很可能引起大问题。虽然地图编辑器程序也可以用上述方法进行修改，但却会引起一些后遗症。为安全起见，还是手动搬文件比较好。


修改急速风暴中文版字体大小的方法
作者：匿名人士33768

用二进制编辑工具(如ultraEdit)在heros4.exe中搜索Ascii字符串smallfonts6(注意small和fonts中间有一个空格,fonts和6中间没有),将找到一个结果,后面不远有一系列数字:121416182022…

这些数字代表的是字体大小,修改它们可改变游戏中的字体大小..我比较喜欢小字体,所以全部改成12了,大家可以自己看着办

本人的游戏版本是Heroes of Might and Magic IV:The Gathering Storm 中文版 v2.2.0.1

(此版本的第一个数字首地址在0x6728c9)

DarkRain.cn注：

虽然这个方法可以改变字体大小，但对于Win 98下文字显示不完全的问题，却无能为力。这是因为Win 2000与WinXP所使用的新宋体，在字体上要比Win 98所使用的宋体稍微小一点，于是Win 2000与WinXP下能够正常显示的文字，在Win 98下就会少掉（每行少2个字）。解决的方法是安装字体，用Win 2000与WinXP的新宋体来替换Win 98的宋体。


内存修改
作者：emery，吴大将军

首先当然是搜索经验值了，在经验值后面11×16＋12个字节处，就是第二技能了，正常情况下这里是FF居多：）

每一个技能占用四个字节，FFFFFFFF为不会这项技能，00000000为基本，01000000为高级……04000000为宗师级。排列顺序为：

战术、战斗、侦察、高贵

生命、有序、死亡、混乱

自然、进攻、防御、领导

肉搏、箭术、防魔、探路

航海、隐身、理财、采矿

外交、治疗、精神、复生

施法、魔力、媚惑、神秘

鬼神、招魂、咒语、占卜

巫术、草药、冥想、召唤

修改时，想要哪项技能，只要在相应的位置将其改为00000000～04000000之间的值就可以了，完全不需要管技能的先决条件。如果更狠一点，可以全部改为04000000，这样便会了所有技能，虽然有的显示不出来，但是你实际上是会的。

接下来有24个字节代表魔法，每一位代表1种魔法（1表示会），这样一个字节代表8种，共192种，包括生物的特技和被取消的魔法。魔法后面四个字节表示当前魔法点数。

英雄属性在内存中的存放格式仍然为每项4个字节，依次为幸运、士气、攻击、？（一般为0吧）、防御、？（一般为0）、速度、魔法点数，这些全是基本值，也就是说没有经过任何宝物、技能、临时建筑修正过的值。举例说明：比如英雄目前士气、幸运、攻、防、速、魔为＋1、0、24、80、10、20，没有任何宝物，有宗师战斗（使防御到60），所以英雄基本的士气为0，原来的因为只有一支部队士气＋1；攻击为14，因为英雄一出世就有了10点；防御为20，因为要减去宗师战斗的效果；速度为4，还是因为英雄出世时就已具有6点；同理，魔法点数为10。（这里攻击指的是近战值，魔法点数指的是最大值） 知道了这些，就可以打开FPE，选择32位搜索，输入引号内数字“1,0,14,?,20,?,4,10”，可以一次找到结果。或者也可以现找经验值，然后上翻8页，手工去找。

单英雄无限移动快速改法如下：
1：最开始搜索17677。
2：英雄走完后用低阶搜索“-”，此时应能找到个位数的结果。
3：分析结果，如果某个数大约17000左右，没错，就是它！否则回合结束，下一回合再从步骤1开始。
4：改！把此地址后一字节的数锁定为70--75之间的任一数（十进制，小于67英雄几 乎不能移动，太大容易出问题）。

在城里无限征兵改法：
先用模糊搜索找一低级兵的，开始搜索“?”，招几个搜“-”，过一天搜“+”，一般十来次就行。一种兵4个字节，见下：
xx xx xx xx(一级) xx xx xx xx(一级) 00 00 00 00 xx xx xx xx(二级) xx xx xx xx(三级) 00 00 00 00 00 00 00 00 xx xx xx xx(四级) xx xx xx xx(森林族生物门)
数据起码得上千才行。


英雄带兵能力的Bug大揭密
作者：DarkRain.cn

事情起源于和游家论坛waohily的讨论。他说保护长袍的说明中“英雄死亡后效果依然可以延续”这话有错，但在我的亲身经历中，至少两次遇到过这种情况，并且还因此而打输了一仗。联想到有时候敌人英雄死亡后加攻防的效果不消失，于是就专门进行了一个测试。

测试的结果令人惊讶，原来不关保护长袍的事，而是四代存在一个巨大的Bug！

这个Bug是这样的：如果是在等待后再行动的阶段把英雄打死，那么英雄对部队的影响力不会消失！这里所说的影响力，包括了战术系技能加攻防、速度、士气等的效果，以及类似的宝物的效果，当然也包括保护长袍加所有生物30%抗魔能力的效果在内。


奇异现象搜集
作者：phinex

1、英雄负血：在3.0版本下有两个办法
(1)就是带健康指环的英雄在战斗后脱下健康指环（当然血要被打到一定程度）。负血的英雄在战斗时不会出现，当只有一个英雄遭遇战斗时这个英雄立即输（相当于一个移动的墓碑），但可以用生命魔法为负血的英雄加血，而且第二天时负血的英雄会恢复成满血。两个负血的英雄相遇时就一起完蛋。
(2)穿野蛮人套装的英雄在战斗后（当然血要被打到一定程度）查看英雄资料即可。

2、电尸：英雄对有魔镜的部队施放连闪。当英雄可以被连闪打到并给连闪打死时，等有魔镜的部队（当然不能死）的魔镜产生作用时，死亡的英雄会突然复活并给连闪击中。（火环、火球、地狱火则没有这个现象）

3、打尸：生物或英雄有抢先攻击，攻击火怪，受到火盾的反弹并死亡，这时尸体会复活并给火怪攻击。（这个BUG 3代也有，不知道nwc的人是怎么搞的）

4、尸体凤凰：对凤凰用操纵尸体后制造的凤凰是无法复活的，不过如果直接驱散、废除或施放招魂抵御的话凤凰竟然会复活，（有大否定戒的话也可以复活，但属性仍然是尸体）而且这时的凤凰的属性是召唤的凤凰，不能驱散或废除，可以驱逐，战斗后消失。要是施放抗魔的话，则会显示“The phoenixes are immune magic”然后凤凰头上的数字和颜色标记就会消失，留下一个影象在原地。

5、超强免疫：瘟疫对死亡系的部队无效（即使有大否定戒也一样）。

6、重复的魔镜：可以对仙女龙和邪恶女巫施放魔镜，但只会反弹一次。

7、奇怪的黑龙：幻象和尸体黑龙可被驱散或废除（当时带大否定戒的英雄已死）
以上现象基于TGS3.0

8、复活的吸血鬼：当吸血鬼被雷鸟的闪电杀死后，吸到的血会令吸血鬼复活，然后再被闪电电死（这个BUG在TGS3.0中已经被修改）。

9、被施放了抗魔的英雄在其他英雄施放回城后受回城的效果，不会留在战场，但被施放了抗魔的英雄则不能施放回城。

附：游戏中还有一些不太为人注意的现象/特性，一并贴在这里

1、催眠的天使不能复活完全阵亡（躺在地上成为尸体）的部队。（小咖喱）

2、和平之歌和疯狂，虽都属于诅咒类魔法，但其效果会相互覆盖。（Dogwoggle）

3、伤害法杖增加50%的魔法伤害，但是不知道为什么唯独对火球魔法不起作用。（tyfon）

4、召唤恶魔之子这个魔法有一个很奇怪的特性：召唤出来的恶魔之子会中废除魔法，但废除之后这队兵不消失，只是下一次召唤会产生一队新的恶魔之子，而不会与原先的召唤叠加。

5、守护者长袍可以使英雄所受的前三次伤害成为无效伤害，而海怪的吞噬也算是伤害的一种，因此可以被守护者长袍克制。而死亡之手属于诅咒类魔法，守护者长袍就挡不住。（类似的，失明敌人后用死亡之手去抓，不会导致敌人醒过来）

6、当英雄没有箭术技能的时候，拿着火焰剑，火焰附加伤害会直接叠加在英雄自身的伤害上，导致显示的伤害值常常超过100点。但这只是显示问题，战斗中实际伤害值还是按英雄自身的基础数值来计算的，火焰附加伤害会在攻击后起作用，但是不与攻防结合进行计算。

7、持续两次的疯狂：曾经偶然有几次经历，都是发生在精英骑士身上。被施加疯狂的精英骑士，攻击一次后疯狂状态没有解除，又攻击了一次才解除。其中的规律实在很难找，曾经猜测是与不移动攻击有关，但未能证实。


国外玩家Saurus的AI测试
作者：rivers

    一个叫Saurus的玩家在celestial heaven上发表了AI的测试结果，非常有趣。原文翻译如下：

各位好，

    我花了两天的时间研究了H4的AI（注：人工智能）。我用的是消除战争迷雾的秘籍，所以能完整地观察电脑每一天的行动。测试用的地图是中地图、4个电脑玩家（team 1）和我自己（team 2），自己什么也不做，是轮到自己时就按E结束。

    这就是我的发现：

    A.I 看上去有两种行动模式：主动和被动。A.I 看上去没有记忆能力，它似乎从不留意某个具体地点。我来仔细解释一下：

    在主动模式下，A.I 侦察他附近的情况并且攻击中立的生物，但是非常随机。我曾看到它为了拿一小堆金子而去攻击一队3级生物以致于损失了它大部分的部队，与此同时，就在它边上的一个无人看守的金矿它却碰也没碰。

    我从来没有发现AI的行动有什么逻辑性可言，AI的行动给我的感觉是，无论它做什么，都是刚巧它走到哪里，而不是因为它有计划的走到哪里。

    A.I 从不记忆特定的地点。是的，它也许会很偶然走到一块经验石附近，如果因为附近有守卫AI无法访问经验石的话，除非以后碰巧路过，它再也不会回来。同样的情况包括矿、生物巢穴等等。AI碰巧路过这些地点的时候，也许会占领，也许不会，尽管它可能专门派出一个英雄来做这件事（也许大家都看见过AI连自己城边的矿也没有占领，仅仅因为它忘了自己还没有占领了那个矿）。

    A.I 从不留意野兵的活动范围，大家经常看见的墓碑群往往就源于此。一个回合结束的时候，A.I 的部队过于靠近强大的野兵，被野兵干掉。然后A.I试图让人把墓碑带回城复活，不幸的是，派出的部队仍然因为过于接近野兵被干掉……我观察到一个电脑玩家花了大约9个月的时间重复着这种自杀行为，毫不在意数量庞大的十字军就守在那里，AI竟然根本不能意识到危险！由于它所有的部队都专一地用来自杀，这个电脑玩家在这段时间其他什么事也没有做！这是我观察到AI唯一一个还有逻辑性可言的行为——狂热的自杀。不管怎么说，AI至少还有意识地试图完成某件事，尽管每次都是以牺牲结束。

    A.I不懂得如何使用一艘船。在大多数时间里，它所做的就是上船——在下一回合再下船。也许它会让船走那么一小段路——然后回到原来的位置下船。就这样，上船——下船——什么也不做再上船，你完全能想象是什么样的景象。有时候它下船似乎是为了去捡一些资源或取宝物什么的，但是当到了下一回合的时候，它完全忘了自己下船的目的，什么也不做就又回到了船上。

    然后，忽然之间，A.I的状态换到了被动模式，一切发生的如此突然，没有任何明显的理由。

    在被动模式，A.I所做的唯一一件事就是积攒部队，它的主力部队就那样一动不动的呆着——多半是在城里。

    是的，一动不动，在被动模式下，A.I就是那样一动不动，它就是在那里积攒它的部队。它积攒部队看不出是为了什么明显的目的——我看到离它城非常近的地方有一个大约几十骷髅守着的金矿，而它有数十十字军，但它就是拒绝动哪怕一步！是的，因为它处于被动模式下，它不能动。

    到底发生了什么？到底它看到了什么危险使得它转成被动状态？让人惊讶的事就这样开始，它就那样象冬眠一样过了几天、几个星期、甚至几个月。AI做出冬眠决定的地点会在任何地方，在一片沼泽地、或在船上、或在一个钱箱的边上（我亲眼所见，就在脚边的钱箱AI在几个月内碰也没碰一下）。

    典型的冬眠季节大约持续一个月，但是也有几天或几个月的。我观察到的记录是3个半月，在此期间AI什么也没做，它一定是在午睡。有时候所有的AI会同时进入被动状态。

    实在抱歉，我忍不住要纳闷，NWC的程序员们到底在干些什么？当他们设计AI的时候，他们究竟是怎么想的呢？

    我很乐意听到大家的意见，分享你们的经验。

Saurus


神器（relic）宝物简评
作者：vimp

    Archmage's Codex （大师宝典）：3代中人见人爱的5级魔法帽。只是必须要掌握相应的魔法技能才能使用本系5级魔法。这个设定大大的削弱它对战局影响能力。前期影响能力为0（不要告诉我你一开始就有一个具有*系大师级英雄）。中期为3：这个时候是最能发挥其作用的时间（可是这个时候你应该也起了烂便宜的魔法塔）。后期影响2.3：这个时候你可能会体会到什么叫鸡肋（DarkRain.cn注：未必呀。魔法塔里的魔法是随机出现的，就算到了后期，也不一定能够学到想要的魔法，这种情况下大师宝典还是非常有用的）。对比数：0.3。各种强力盾牌的存在使其在选择上沦于下者，可替换数高。综合评价：5.6。

    Adamantine Armor （白金铠甲），Bull Rune Battleaxe（牛人战斧），Horned Bow（角弓）：极大增强英雄能力的宝物。前期影响：3。快攻成功的保证。强大的力量英雄使你在与黑龙的对决中也不处于弱势。中期影响：3。在前期中就算未能击败对手。但应为自己在游戏中期赢得资源与兵力上优势。后期影响：0.9。完了，你英雄没出手就被4级兵K掉，宝物全成了摆设品。对比数：1。无论怎么比。选择它们并不亏。综合评价：7.9

    Ring of Greater Negation（强烈否定指环）：3代中的受伤魔球。比如对成百上千的黑龙用催眠很好用的东东。去除战场上敌我所有部队的魔法抵抗力和免疫力。补充：可以对泰坦，机器，元素部队使用所有精神魔法和对自己不死部队用祝福魔法。但还是和3代一样不能对不死生物使用精神魔法（DarkRain.cn注：实际上装备这个戒指后，完全可以对亡灵使用精神魔法。另外，泰坦在四代里本来就是不抵抗精神魔法的。）。碰上完全防护斗篷（英雄抗魔+100）也有效。但对于施展反魔法的英雄或生物则无效。同时这个东东是把双仞剑不要没先伤人先伤己。在战斗中自己慢慢体会。综合评价：８。０

    Bow of the Elf King （精灵王之弓）：所有远程兵＋１次射击机会。如果本着效用最大化带着一大票独眼爱人去Ｋ人比带泰坦还爽。前期影响：3。中期影响：3。后期影响：3。对比数：1。综合评分：10。给我什么也不换除非我是自然，生命族的（DarkRain.cn注：为什么“除非”里要提到生命呢？生命系的远程部队还是相当强的，和精灵王之弓非常合拍。）。

    Sword of the Gods（众神之剑），Adamantine Shield（白金盾牌）：麾下生物攻防各加50%，英雄AD+3。因为英雄无敌四中英雄AD不影响生物的攻防，在军团决对中影响生物攻防的宝物倍受亲徕，无论在英雄前期还是后期都对战局有着巨大的影响力。前期影响：2.5。中期影响：2.5。后期影响：2.5。对比数：1。综合评价：8。5

    Neener's Invulnerable Cloak （抗魔披风）：英雄抗魔加100%，不错的反魔球，可惜只对英雄有效。在于施魔能力的生物比如魔法石，仙女龙等等时有特效。但千万别碰强烈否定指环。综合评价：5.0

    Supreme Crown of the Magi（魔法帽）：MP+50。如果是召唤师这个东西还是不错的，哎你有，我等我等，好久啊———还没完？别招了行不？**我不打啦，靠耐力见长的人这个东西还是很好的。前期影响：3。中期影响：2。后期影响：0.8。越到最后越垃圾。对比数0.5。好象也没什么好帽子。综合评价：6.3

    Thunder Hammer（雷电战锤）：英雄近战攻击力+7.5，近战攻击时附带70点闪电伤害。英雄每升一级，闪电伤害还会提高7。很强的宝物可惜占了2格装备，哪怕上满分10，除以为2以后只有5分。可这东西的确好。综合评分：6.5

    Scarab of Summoning（召唤宝石）：召唤类魔法（包括召唤、幻象、制造亡灵等）效果提高100%。好象不如介绍中的好用，战斗中除了召唤、幻象、制造亡灵效果加倍以外，好象也影响招唤技能和招魂技能（DarkRain.cn注：实际上是不影响招魂与召唤技能的，只影响魔法）。不过笔者还是很喜欢的。前期影响：1。中期影响：2。后期影响：3。对比数：0.7。综合评价：6.7

    Flaming Arrow （火炎之箭）：垃圾啊。英雄的远程攻击能够伤害3*3范围内的多个部队。但加点其他的箭呵呵好象还不错。（DarkRain.cn注：火炎箭在宗师箭术的英雄手里，威力绝对巨大，怎么说也不能算是垃圾。“加点其他的箭好象还不错”，这句话倒没说错，即使是箭术技能等级不高的英雄，有蛛丝箭、懒惰弓什么的来配合火炎箭，效果也相当不错。）综合评价：4


小议自编地图
作者：Fenrir

    最近以来，英雄世界的地图下载栏目越来越红火，好地图一个接一个，水平都非常高。我刚好整理GROUP，也看了些上传的地图，加上下了不少俄国网站上的地图，收藏也还不少。看各位的地图，实在是一种享受，看多了，自然就要比较，也有了些想法。如果给我一个地图打分，大概会根据四个方面情节、战斗、严谨和美观。情节是指故事的发展线索；战斗是说作者安排的各场战斗是否有趣、有挑战性；严谨要求一个地图应该考虑到尽可能多的情况，做到平衡；而美观当然就是指地图是不是好看啦。下面我详细地说说我的想法。

一、情节

    一个吸引人的地图，情节是贯穿整个游戏的主线。我玩英雄系列，图的一个是战斗的乐趣，另一个就是主角的发展历程和剧情。英雄四的战役（原版）非常漂亮，还有人翻译了所有剧情，可见其吸引人的地方。对于我们自己编地图，最方便的莫过于找一个经典的故事。写到这里我突然想起原来打的一个游戏《韦小宝-皇城争霸》，很多地方都是按照小说里面写的情节设定，一点细节都不差。当时我和同学还为此专门翻着书打。能够找一个现成的很著名的剧情，会事半功倍。永恒论坛里面有人提到《西游记》，应该是个不错的想法。如果是英雄四的战役，一关出一个主角，猴子、猪、和尚轮着上，最后再合兵。要突出剧情，无外各种RPG式的设定和情节提示。我觉得网友地图的一个突出的弱点就是情节不够鲜明。大多就是开始的时候说几句话，以后就没有声息了。我想这个方面英雄四原版战役是一个非常好的学习榜样。如果是英雄四的地图，正好用上强大的SCRIPT功能，可以编出很好的RPG风格的剧情。另外一点就是我觉得一个地图的中心应该放在如何＂完成任务＂上，而不是如何＂触发任务＂．前一向有个地图叫Knightmare，编得很细致，但是缺点就是让人把时间大部分花在找路，找东西上面，而情节和战斗太简单．

二、战斗

    我认为一个好的地图中应该存在多种战术，战斗有足够的难度，可以保证微观上打法的多样和宏观上发展的可选择性。地图如果打法太单一了，很容易让人失去兴趣，甚至对这一类的地图都失去兴趣（这几乎是所有地图的通病，而且影响平衡）。拿英雄三做例子，如果让你从头到尾力盾泰坦，很快就腻了。我觉得另一个容易被忽略，也是不容易调整好的问题是始终保证战斗的难度。有难度的战斗，让你S/L上一阵子，琢磨很多办法，最后终于打过了，无疑是玩家的乐趣。让这种乐趣贯穿游戏的始终，会是非常美妙的。Aqiao刚发了一个帖子，居然利用电脑会复活魔法，打赢了一场艰巨的战斗！（匪夷所思！非常有启发！）以前看见过一个地图，很早就让英雄拿到大否定戒指，然后一路上的上K的野兵都成了经验值。一路催眠非常无趣，其实如果把七队5K的矮人，改成5K和1K间隔的，战斗就又不同了。战斗的难度非常不好控制，一个是英雄四敌方有英雄的部队AI太低，另一个就是培养好了的英雄能力太强。我认为《死亡森林》中失败条件对此做了一些设定，比较好的限制了“超人”的出现，很好。另外一个可以用的方法大概就是SCRIPTS了。一个好地图，如果存在多种宏观的发展方向，应该会更耐玩一点。比如有两种结局，有多个职业的发展方向，等等。

三、严谨

    严谨应该是最难控制的方面之一。我现在能想到的，包括实力的对比，时间的控制，玩家选择不同难度时的难度控制，还有就是对一些特别的战术使用（BUG使用）方面的控制。如果是对战地图，当然尽可能有保证相同发展速度的环境。打电脑，就一定不要让电脑太弱了。几个星期以前打一个地图World Leader（俄国网站下的），是XL，Champion难度，我也用Champion难度，但是才打了一个月，就没有兴趣了．我都把英雄练满了，所有Relic都拿了，电脑还是一个７级英雄，一个城，一个矿．我都不忍心到他的领地上去．时间的控制主要是控制剧情的发展。这个一点不仔细，要么是搞笑的事情，要么就是BUG。3DO都犯过这样的错误。TGS中，吟游诗人中，我都占领了城市，出去溜达了，它才弹出剧情说我碰见了农民，他们告诉了哪里哪里有个城堡？！不同难度的控制说实话，我现在就一个概念，没有什么具体的想法，也许SCRIPTS是一个办法，一个地图叫Treasure hunt in Charragaust，有这个Script，但是我没仔细研究。最后是战术控制。有些关卡你需要保证玩家不用药水淹没（邪眼？），不堆兵（时间限制？），不用H/R（Scripts控制次数？）．

四、美观

    一个漂亮的地图，总是吸引我去试一下。Celestial Heavens的一个专门评价地图的人，有比较好的见解。大家看看他对地图的评论，可以有些收获（不过他打游戏水平很差，那些对难度，打法等方面的评价不看也罢）。多边的，看起来过渡自然，并且有丰富景物的地形，可以让你的地图看起来非常漂亮。以前有个网友发了一个地图叫《西湖》（或者是《白蛇传》），印象中比较漂亮，可惜现在在GROUP里面找不到了（作者自己删了？如果作者还有备份，请费心再上传一次，虽然我的是英文版本，但是还是想在地图编辑器里面看看。）有些做地图的人喜欢利用底色的变换，在小地图上显示一定的图案。3DO现在也有了这个嗜好。我想说的是过犹不及。有些这样的地图，完全用地面地形拼图形，或者整个地图就几个字，感觉稍有生硬、过火之嫌。

    SSZ（=Fenrir）评注：我自己没有认真遍过地图，实在是不知道其中苦衷。说得不对，或是难听了，大家一定见谅。


制图内幕
作者：Charles Watkins

从根本上来说，制图者也是表演者。无论地图是什么类型，战斗型也好，RPG型也好，最后的评判者是玩家，根据他们打这张图是否愉快决定。不同的地图有不同的特色，但是在玩家的眼中，最终会归结为三个大的方面：探索，美观和胜利。在这个系列中，我将探讨一个制图者应该如何取悦玩家，而不是教如何地图编辑器。我的重点是玩家的心理，讲解制图者如何是玩家在游戏中取得尽可能多的快乐。我的文章有三个部分：探索，胜利和审美；分别从三个角度指导制图。

第一部分：探索

游戏开始，玩家总是在一个小区域内，四周一片漆黑。胜利取决于寻找资源，军队，宝物等。而玩家也一般先派出侦查部队开地图。怪物、障碍物、加行动力（时空门）的地方都可能改变玩家的决策和探索方向，增加探索的乐趣。

使用线索：一个创造和增强探索的乐趣的方法是使用线索。如果你告诉一个ORDER玩家，东方有ORDER魔法宝典；那他得到这个宝典的兴趣和乐趣就比胡乱逛的时候看见的要大多了。制图者可以先模糊地说，东方有宝物，然后等玩家走到半路，再告诉他更多的细节；接着玩家可以了解到看守的怪物是什么，应该怎样战胜它们等。离宝物越近，玩家将越激动，当他真正拿到手，他的成就感是非凡的。

制造意外：这和线索的使用是一个道理，真实的世界中，意外有令人愉快地和不令人愉快的，或许后者还多些。但是在游戏中，意外大多是愉快的，不然玩家会失去新鲜感。甚至可以先给点不愉快的意外，再给一个大的惊喜。

引导期望：线索和意外的使用，都是制图者控制玩家的期望的方法。要先建立一个和谐的环境，才能接着着重于以外的因素。对英雄无敌的制图来说，重要的是仔细处理随机因素，主要包括怪物和宝物。如果怪物都是随机的，那有些特别的（重要的）怪物将不会成为重心。反过来，如果都是事先设定好的，就失去了多样性。宝物也是如此。如果一个重要的宝物和一个宝箱一样容易获得，那乐趣会少很多。

内部统一：一个充满随机怪物和宝物的世界是不实际的。如果不认真设计，玩家将失去对环境的兴趣，仅仅为了过关而一路砍杀。把生物放在它们的原生地，比如九头蛇在沼泽，可以创造良好和谐的气氛（随机怪物无法实现）。让一切更合理，玩家就会更沉醉于制图者设计的情节，不然，就仅仅是对付电脑而已。

随机怪物：是否所有的怪物都需要手动设置？我的地图中，绝大部分是的。我甚至要考究他们站立的方向，以便交战的时候，双方是面对面的。当然为了照顾可玩性，我会放一些随机怪物，但是要注意是否与环境和谐。另一个因素是平衡，对四级生物，巨龙和九头就有很大的不同。所以要避免把随机生物放在关口或守卫重要的宝物。

离奇的情节：惊喜同样隐藏于情节中。电脑突然变节，就可以打破平衡。很多制图者热衷于利用一些小细节或者BUG来制造效果，但是实际效果因人而异。有的人也许根本没有注意到，而有的人或许惊讶无比。

新颖：新颖是另外一个探索的乐趣的源头。我喜欢一个英雄二的地图叫Dragon Rider，我开始有头龙，让我感觉很新鲜。相反一个失败的例子是英雄二的一个地图，玩家开始拥有鬼魂。整个游戏就是一路积攒鬼魂，很无趣。

第二部分：胜利

人人都喜欢胜利，但是如果它来得太轻松，就会失去吸引力。另一方面，如果胜利太艰难，玩家就会烦躁并放弃。作为制图的人，我们需要尽量使胜利更有乐趣。

不是每个人都会赢，制图人应该设置多个挑战，让每位玩家都可以尝到胜利的滋味(不同程度上的)。也就是说，应该让游戏由不同的阶段串起来，让玩家一直有投入游戏的感觉，然后最终获得最后的胜利。

玩家要开地图，修建筑，扩充军队，并培养英雄；这些通常都牵涉到战斗，探索，魔法和宝物。这些因素给制图者提供了足够的手段，让玩家享受追求和获得胜利的乐趣。

甜蜜的胜利: 所有人都喜欢胜利，但是有些胜利来得比其他的更甜蜜。有经验的玩家经常抱怨电脑太笨，因而拒绝玩单机地图。从某种意义上说，所有的电脑游戏AI都不可能和人相比。但是我觉得英雄四的AI足以挑战有经验的玩家，并让普通玩家在选择“冠军”难度的时候不得不犹豫。方法很多，绝不仅仅是给电脑加资源。

对多人地图来说，玩家需要知道他们的开始条件平等，水平最高的人获胜，而不是运气最好的人获胜。大多数对战地图的制图者都为了平衡摆放资源，宝物等而伤脑筋。事实上这样做稍微过火了点。

挑战电脑: 第一个建议，不要试图让玩家和电脑平等发展，AI是无法和人脑比的。利用它好的地方，而不要抱怨它笨。给电脑固定一个颜色，让它呆在那儿等玩家上门相对容易。开始就给它建设好的城，坚固的城防，牛英雄；然后等到玩家打过来的时候，会发现电脑发展的水平和自己相当。

这么做的第二个原因是给玩家一个最后的辉煌结局。英雄三在这方面做得很不好，当电脑被击溃以后，就拼命地化整为零逃命。玩家将以无聊的胜利结尾，而不是辉煌的大会战。

四里面，没有英雄、城三天就下课，这在对战中很好，但是单机游戏就没有必要了。没有英雄了，还怎么占城？

选择: 玩家喜欢可以自己选择如何打一幅地图。如果所有的打法都被固定了，那给人的感觉就不是我玩地图，而是地图玩我。好的地图应该给各种玩家各种选择。

有些地图喜欢不停地告诉玩家下一步该干什么。而我喜欢让我的故事情节因玩家的行动而展开。比如放事件到玩家会被吸引的地方。这样给人以控制感和参与感。

发展: 升级的渴望和吸引力来自人内心深处的本能。既然玩家有这样的渴望，制图者就应该利用它来吸引玩家。发展给玩家多种奖励：金钱让你扩充军队，扩充的军队让你打更大的胜仗；还有英雄的升级。

赢得胜利: 英雄无敌中有难度选项，一个原因就是为了给不同水平的玩家合适的难度。好地图总能提供恰当的考验，不过分难，也不过分简单。对于制图者来说，就是要对玩家开始的发展速度进行控制。

有些地图开始给玩家不少军队，很多城堡。或许有些人喜欢，但是我有被欺骗的感觉。我喜欢从零开始。过程完整，且完全控制。

有些地图开始给个高等级的英雄，是希望玩家用它作主力。一般如果有”英雄被击败”作失败条件，我大半是把那个宝贝英雄放在老家，另外找个人干活。但是如果这个宝贝开始就已经有不少经验了，我就得考虑浪费问题了。当然，还有其他途径解决这个问题。我的地图中，一个是在主力成长前不给玩家酒馆；二是合理安排剧情（让主角当市长）；三是控制可招募的英雄都是剧情中的人物。

我认为合适的升级速度是每周一级。另外，城堡建设也大概是每周一修。一般来说，过一个月以后，玩家应该开始准备建设副城了。

角色成长: 这个和发展的原理差不多。玩家更乐意通过战斗升级，而不是访问祭坛，经验石等。并不是说地图中不应该出现这些，而是应该谨慎。让玩家指导，关键是靠自己的奋斗。

我认为，合适的升级应该允许玩家通过战斗获得一半经验，通过访问、事件等获得另一半。如果一个英雄每周通过战斗升一级，6个月以后就是24级，然后通过其他途径再升24级，就48级，足够强了。 扩张: 制图者可以设计玩家从最简陋的城镇开始发展，但是需要仔细的是不同难度的起始资源数量不同，而且需求量根据城堡类型变化。

个人以为，时间触发的事件给予或者剥夺资源，都不受我控制，使我有“游戏玩我”的感觉。如果实在需要拿走资源，起码也让我参与决定，比如，换点情报。总之，让玩家决定如何发展。

组建军队: 除了城镇建设和英雄培养，玩家也喜欢扩充军队。一般来说，制图者应该可以估计玩家的大概发展速度，然后估计他的兵力。我做图的时候，会估计玩家什么时候，达到什么状态，目标，并据此设计怪物等。为照顾速度慢的玩家，我会给他们些优势，配置敌我兵力对比为3：2。攻城的时候，为弥补AI的缺陷，我会调整兵力比例为2：3。

堆兵: 比较有趣的现象是玩家逐渐用高级兵换掉队伍中的低级兵。我喜欢远程兵，或许有人喜欢全龙队。给玩家选择，比不停重复生产同样的兵有趣。

摆放宝物: 吸引玩家的另一个办法是给他们宝物奖励。英雄四里面有些破坏平衡的低级宝，一些过分强大的高级宝。圣物里面，也有很突出的宝物。设计的时候要注意不要影响了平衡，破坏了玩家对任务和其他奖赏的兴趣。还要注意它们的价值是否和获得的代价成比例。

当我打完一个地图，我通常都会有无数的烂宝。也许大家对低级的宝物在不在乎了。我觉得制图者应该仔细考虑什么宝物，在什么场合下有用。对电脑方，不必要给宝屋，因为它们反正也不打，最后还是给了玩家经验和钱财。需要什么宝物，直接给电脑就可以了。不要让电脑方依赖魔法和技能。最好有SCRIPTS可以根据玩家的等级、时间等控制他的奖赏。

另外对监狱提两句。第一个星期，一个一级的牧师是个奖励；但是六个星期以后，就是个失望了。一个有很好的技能的英雄是很高的奖赏（监狱允许英雄保留宝物，甚至军队）。

难度设置: 合适的难度设置是个艺术，可以给玩家成就感。我一般把难度设置看成玩家水平的体现。水平高的人，选的游戏难度也高。不同难度开始几周的资源有很大差别，所以需要设计，让各种难度下都有合适的发展机会。一般来说，用特定的3级生物守卫关键的矿是合适的，比如用独眼守卫生命旁边的水晶。随机的生物可能使任务过分简单，比如步兵型的生物，对生命族来说就相对容易对付。

作弊: 最简单的避免游戏过分困难的方法是作弊。当玩家觉得地图太难，那么S/L就是当然的选择。特别有随机的埋伏的时候，玩家觉得S/L是当然的。这不但没有增加乐趣，还降低了胜利的价值。我以前做过一个地图，有固定的地方明确声明“可以存盘”。玩家有了可以存盘的制定地点，就不会到处S/L了。问题的关键是，如果玩家已经证明可以实现某个目标，就不用让他们重复下去。

总的来说，好的游戏中，获取胜利的过程比胜利本身更有趣。最好的地图不停地提供阶段性胜利，引导玩家走向最后的胜利。

第三部分：审美

让玩家惊喜的方面还包括图形方面。一些艺术水准很高的地图，让你的每个发现都充满惊喜。有的利用魔法眼来展示等待玩家探索的奇妙景象；有的时候，玩家只需要沿着路走下去，就能有新奇的发现。在我的地图：“Grandmaster”中，有一个魔眼可以让玩家看到远处一个demon头像形状的地形。它的脸将显现在黑暗中，看着你，直到游戏结束。

Qrystal Dragon的一幅新地图：Disenchanted Forest，在游戏的开头就通过魔眼让玩家看到通过地形画出的一棵树（很巧妙地利用了魔眼的观察范围）。不单如此，当电脑玩家不停地占领城堡，会使城堡变色，看起来像树上的果实。最终，玩家将进入那片领域，最终采摘胜利的果实。那里有玩家的主要敌人，因为魔眼的照明，玩家可以一直观察自己的对手是如何强大起来的。

艺术性的放置魔眼等道具，可以增强故事情节，或者指引玩家该如何继续。可以照亮地图的东西可以吸引（提醒）玩家应该到哪里去。有的玩家不看文字说明，或者忘了，那用地图本身来提示他们最好不过了。
使用照亮地图的道具（建筑）需要制图者的几何感觉，来预测哪些是玩家可以看到的，哪些不是。还需要很多的测试修改。这些建筑间隔越近，难度就越高。在不同的情况下，制图者可能希望有些东西被看到，作为指路的方向，或者隐藏起来，直到玩家走到那里。最困难的就是留意哪些可见，哪些不可见。地图编辑器不提供这样的功能。

养眼视觉上的惊喜属于艺术的范畴。同样，认真修剪的地形景物也属此列。合理的布置景物和地形会有意想不到的效果。有时候，精美整洁的布局也给人美感。但是，有时候不合理的布局让人分心。比如我就经常奇怪，为什么雪地会有花？不管怎么说，任何是玩家分心，不能完全投入到制图者布置的场景的因素，都是需要慎重考虑的。不是说我们设计的是奇幻世界，就什么都不管了。

制图的艺术大家已经阅读了我关于制图思想的三个部分。根据这些来制图，你就不仅仅是个编程的，讲故事的，而是个给玩家带来快乐的艺术家了。我们的最终课题是，制图的艺术，这些艺术如何增强玩家的体验。

讲故事讲故事无疑是门艺术。土人和诗人讲的故事是不同的。英雄无敌的地图制作，不光是设置角色，而且还创造一个环境，让玩家和游戏本身交流。
很多地图已经给我们展示了精彩的故事情节。我的朋友Tim Duncan的几个地图，都有完全可以独立出来的故事情节。从二代开始的个别片断，到现在四代，我们已经有如小说般的战役了。
同样美丽的景物和地形也是一种艺术的表达，可惜我没有艺术细胞，不擅长这些。但我作为一个玩家，是非常喜欢它们，特别当它们和其他的因素揉合在一起。

一点题外话衡量一个艺术品的标准之一，是看它能够对经历过的人有多大的感染力。我最喜欢的电脑游戏是“Ultima IV”，不仅仅因为它没有流血的结局，而且它赋予一个角色经典的美德：真理，爱和勇气。

创造性的局限英雄无敌系列的创造性有它自身的局限性。无论如何，最终的目的是胜利。故事本身并不重要，除非它带来激烈的战斗。定义英雄有很多种，战斗只是其中一个。我曾经作过一个图，玩家可以选择战斗或者解谜，不过反应不好。教训就是，要满足玩家对游戏的基本期望。惊喜是好的，但是太偏离主线，会让玩家失望。
所以，最后的一点建议是，始终牢记，我们是在给定的媒体范围内创造。一般来说，神奇的生物，任务，战斗都是不可少的。


初学浅谈（一）：英雄无敌四种族之 Life 篇
作者：Fenrir

前言：
    从高的层次看，“用兵之道在于变通，所以并不存在轻重之说，更多应出于战术考虑。用风清扬的话：用剑之道在于行云流水。”[引游戏人家胡一刀大侠]。我写这些东西的时候，开始想尽量符合大多数情况，但是越写，越发现情况太多，各个不同的场合，有不同的解决方法。到现在，也只能尽量概括自己的经验和理解，希望和大家多讨论。

A、兵种

    Life族的兵种，主要特点有二，一个是防御好（配合英雄以后这点更突出），二是远程多。防御好，反过来说，进攻就不是那么锐利。要有足够的实力放倒对手，一需要时间；二是要想办法尽量保持自己，第二点就是其中之一。 　　侍从：头像挺秀气，是个帅小伙。但是出身低微，大部分时间是个炮灰的角色。Life开局，一般两种初级兵是都要出的。弩手自然是主力，重点保护对象，那么侍从就义不容辞地作炮灰。它的技能和角色挺搭配；一不小心，打昏一组，岂不是很美？别看指数差，死得快，但是初期的骗反击、阻挡、牵制的作用不可代替。

    弩手：游戏初期的主力兵种。量大，射程远（不受距离影响），合理的配合侍从和英雄，非常好用的兵种。游戏初期，英雄经验值的原始积累大部分都靠它了。而且由于其特技（射程），容易依靠阵型保护，数量上容易积累。 　　Life的这两种初级兵相互配合很好；使用得当的话，可以在初期很快积累一支比较强的部队。因为弩手射击距离没有衰减，用紧密阵型排在最后是常用的手法。侍从一个是当炮灰，一个是为了让敌人的分组有利于自己。常见的手法是单个侍从挡路，当炮灰，大群侍从趁机打劫，弩手在后排放箭。这对组合的缺点是速度都不快，特别是地图移动速度。只有注意英雄自身的速度特点，配合合理的部队合并、分离，尽量节约啦。

    从二级兵开始，就要面临选择的问题了。Life的二级兵还是一远一近，但不是用来互相搭配，而要根据实际情况取舍。

    枪兵：攻防指数一般偏下，但是考虑英雄的配合，应该不坏。攻击敌人不受反击是比较好的特技，特别是用来扎英雄或者高级兵。除去欺负电脑白痴的打法不算，大量枪兵主要适合在野外战斗中造成高伤害，起一定的威慑作用。

    弩车：作为机械单位，不怕守序的遗忘魔法，让它有了强大的竞争条件，而且射击无限制的特技也特别适合攻城或者守城。它的缺点也很突出：速度太慢，非常不适合运动行军。

    在选择上，两个兵种各自特点突出，关键还是要根据实际情况判定。但是从总体来说，二级兵的过渡作用强于主战作用，除非决战迫在眉睫。一个是要满足建筑顺序的要求，二个是保持部队实力不出现长时间的真空。当然，如果是野兵，我倒不是很想碰弩车。

    十字军：一个指数上很强的兵种。攻防指数均中等偏上，而且主动攻击时连打两下（三级兵中唯一的），配合骗反击，杀伤力很强。即符合肉盾的条件：杀伤力强（使敌人无法忽略），防守好（配合英雄），也适合当主要杀伤力量；其速度也不慢。

    僧侣：远程三级兵种。指数上略逊于十字军，但是远程有部分弥补。但是如果选择它，造成的一个尴尬局面就是整个部队远程太多，缺乏合理的搭配。面对比战争初期强大得多的敌人，可以打出的战术组合相对少了些。

    三级兵里面，两种兵种的特技都是死亡抵御。主要原因就是为了平衡和Death族相比，三级兵实力的差距。不过即使这样，在清扫野兵、培养英雄方面仍然存在速度上的缺陷。好在Life的打法不很强调快出高级兵种。大多数时候，三级兵的主要作用在于对抗对手，而不是发展。如果就是打野兵等，并不需要等到三级兵形成规模。十字军因为其强力肉搏而在多数情况下强于僧侣，但是作为野兵，我还是情愿面对它。无论如何，Life 的三级兵并不适合独立作战，和低级兵种或者英雄的配合是关键。牧师和十字军，弩手和十字军（当然配牧师）都是很好的组合。另外有人提到用牧师和骑士配合做主力，虽然我个人认为这样速度过慢，并且转型期长，但是大家也不妨试下。 　　精英骑士：特技比较好，冲刺可以造成很高的伤害，而先攻也让人不知如何下口。高产量使它可以成型快，集团的精英骑士是非常有威慑力的；在大地图上尤其厉害。

    天使：指数上显然比骑士强，而且还是飞行兵种，速度快。虽然产量低了，但是在小数量的情况下，无论战斗场面上，还是冒险地图上，作用都比骑士强。个别天使就可以使战略和战术产生丰富的变化，这也是它的优势所在。

    四级兵的选择也没有特别的趋向性，主要在于实际情况和打法。喜欢快的，可以迅速出击的，当然是天使好些。甚至有些时候可以直接从初级跳到高级，以一级兵配合天使作主力。喜欢大兵团作战的，敌人多的，选骑士或许更容易打。

    总体上，Life的兵种特点都很鲜明，防守强悍，依靠保持自身来寻求积累发展；但是个体的自身能力不突出。也正是因为如此，需要讲究配合，初期主要是兵种的配合，后期更依赖英雄的辅助。同时我们也可以发现，Life可以说是没有魔法兵种（天使的几乎不能算）。英雄的技能魔法也大多用于抵消有害魔法（包括物理伤害）。英雄和部队的相互依赖更为突出。一个强力的保护、治疗英雄可以让部队战斗力成倍提高。局部战斗中， Life系很象个牛皮糖，但是整体上的发展速度也不慢。前期没有大的弱点。中期因为缺乏强力的魔法兵种，只有依靠英雄，使得扩张速度受影响。后期在和敌方部队交战中，因为高级兵种实力需要数量支持，不适于长期消耗。打法上，利用初期部队成型快、生命魔法初级好用的特点，可以快速培养一个强力英雄；在开放的小地图上，也可以利用大量初级兵种实行压制；快速过渡到高级兵种，利用骑士的数量冲刺决胜负也是一个办法。总的来说，Life实力不算弱，但是后期不容易上台阶，中等吧。

B、英雄

    英雄为什么是一支部队的核心？因为他的技能和魔法。英雄无敌四里面，英雄可以上战场，使变数更大，即可以自己使用魔法（依靠技能）辅助自己的部队，也可以把自己当作主攻点，或者肉盾；同时还存在尽快消灭敌方英雄，限制其发挥作用的问题。英雄无敌，英雄果然无敌。

    英雄无敌四里面没有了英雄的特性，所以评价起来就没有三那么麻烦，牧师和骑士，搞定！不过3DO设计了那么多英雄，就是给玩家选择。个人推荐 Leslie，Corita等，如果地图允许Alita当然更好啦。Adelaide比以前丑了些，不过要是你旧情难忘，也无可厚非。

    Life系英雄的两种天生技能是战术或生命。另外3DO极力推荐的战斗技能也几乎必学。守序和自然是相邻排序，也很容易学，甚至可以买。其他的几种技能变数太多，完全需要根据情况而定。开局的时候，Life的兵力和英雄自身都还很弱，只能用来欺负老弱病残。当务之急是通过战斗寻求发展，同时提高英雄的能力。英雄的培养时刻需要注意两个方面，统帅部队的能力和自身的战斗力。统帅部队方面，战术和生命都很有用。具体倾向由个人把握。我个人喜欢先培养魔法，等度过发展初期的艰苦岁月以后，再招个战术英雄培养（第二重点）。自身战斗力方面，由于Life的魔法杀伤性不强，主要是从战斗系着手（也是偏重防守性的战斗技能），另外依靠报偿等魔法。

    魔法英雄

    Life的魔法英雄比较容易成型，原因在于Life的低级魔法非常好用，高级的反倒不是那么必要。为一个新招募的牧师，会一级魔法，比如疗伤、祝福、护甲，就可以很好的配合两种初级兵。一般来说，牧师学会三级Life魔法就已经够用了，可以冠以“成型魔法英雄的称号”。二级的医疗、天堂之盾、殉难等，三级的再生、天国护甲都能很好配合英雄和战士。防护、报偿、振奋等也是好魔法，尤其对高等级英雄独立作战。Life到二级，只需要 1000点经验值。Life三级，需要6个技能点，牧师开始就有两个技能点，需要升到五级，4600点经验值就够了，非常快捷！所以说牧师适合速成。通常情况下，Life到二级就可以维持使用一段时间了。我个人而言，如果没有再生，一般不急于上三级。这以后，英雄可以专心锻炼体力（战斗技能）。到8-10 级的时候，英雄应该已经是个好肉盾（宗师战斗），总共1万多一点的经验值就足够了。这个时候的英雄，不但批粗肉厚，而且还有各种治疗、防御魔法辅助，不但可以协助部队，还可以充当肉盾。游戏时间大概不会超过1个月。从这以后，发展起来就很轻松了；具体的方向应该由地图，敌人的发展，以及自己城出的魔法来决定。有好的Life魔法，或者相邻派系的魔法（最好神学院配合）, 当然可以继续深造下去。魔法不中用，也没有关系，可以培养一个战术英雄。总的来说，Life的魔法英雄主要负责支援大部队作战。英雄自身的突击能力不强，如果打电脑，可以采用单英雄作战，但在对战的时候，必须配合主力部队。Life魔法以低级魔法挑大梁，英雄成型快，配合大量低级兵种，发展上不比别的种族慢。

    战术英雄

    以骑士开局的，初期不可避免会比魔法英雄多损失部队。但是战术英雄比魔法英雄稳定，不那么依赖运气。战术系好像不如魔法那么威力强大，但是最大的好处是旱涝保收，扎实。战术系技能是很实用的技能之一，不但攻防都有加成， BT的是连速度都能加不少；高级的战术英雄实力不容小视。而且，在小而开放的地图上，战术英雄的快速袭击和压制也是很好的战术。初期的战斗中，对操作的要求更高些；发展也艰苦些。不过带来的好处是，开始就有战术技能，以后需要魔法的时候，配合神学院，很快可以成才。而且Life魔法的精华在低级魔法部分，后期转型成文武双全型人才很容易。（魔法值不是问题，药水就可以了。缺陷是因为没有足够的技能点数在魔法上，魔法效果不一定好）当然，战术英雄更加需要部队的支援。只有有大部队，战术系的强大威力才能发挥。后期高等级的战术英雄，配合低级Life魔法（自己放，或者副英雄放），就像个铁疙瘩，到处乱闯，还不见损耗。很让人头疼。

    当然，总的来说，无论哪种英雄，战斗技能都很重要，一般是必学的。等到战斗技能成熟，自己本身技能也到了一定的层次，再有升级的机会，如何选择，完全决定于实际情况。如果学习其他魔法派系，那主要目的就是魔法了。一定注意尽可能先观察好那些好魔法会出现，英雄四里面魔法塔超级便宜，先造了再选择也无不可。

C、魔法

    英雄无敌四里面的魔法分成五个派系，Life、Order、Death、Nature和Chaos。每个派系有两个相邻的派系和两个对立派系。五个种族各自对应一个派系，加上一个没有魔法的Might，构成英雄无敌四的种族系统。Life系与Order和Nature是相邻派系，与Death和Chaos 是对立派系。其中，Life和Death的对抗到处都可以体现，两者的特点几乎完全相反、相克。

    总的来说，Life系的魔法与其兵种相配合，依然是保护、抵御性魔法居多。进一步增强Life兵种抗打击力强的特点。

    一级魔法

    疗伤（Bind Wound）：非常实用的低级魔法。初期发展的时候，大多依赖低HP的低级兵种；与其给炮灰或者主力弩手疗伤，不如让英雄当肉盾，自己给自己疗伤。这样的打法比较考究初期挑对手，对战斗的操作要求也比较高，但优点是快！在中后期战斗中，因为英雄自身能力提高很多，疗伤恢复的点数不少，但消耗的魔法值很少，无论给英雄还是突前的肉搏兵种，始终是一个很实用的魔法。注意想和护甲配合的时候，先大概估计下哪种省MANA。

    祝福（Bless）：初期可以说和疗伤是绝配。先给弩手一个祝福，然后肉盾往上冲，顶在前面接受疗伤。这样的招数虽然只对电脑有效，但是开局搞开发建设是足够了。中期到后期，也经常用于主力杀伤部队。水魔法的典型。

    驱魔（Exorcism）：前面两个是祝福性的，接下来的两个是防御性的。这个魔法可以解除本方单个部队身上的所有负面魔法；虽然不能解毒，但是作为初级魔法，比Order的那个Dispel好用。初期的战斗，一般重心在于“保护自己”，而不如后期那么偏向“杀伤敌人”，而且也不会去惹那么麻烦的敌人，驱魔就比较好用。

    精神护甲（Spiritual Armor）：远近防御提高25%，不错的比例。作为不可缺少的防御性魔法，和以前的什么皮肤一个意思，就是换了个名字而已。

    圣言（Holy Word）：开始好像不是特别有用。这个魔法是专门为Death两身定做的。作为一个直接杀伤魔法，可以补偿Life对Death的杀伤力，起一定的平衡作用。要是开始碰见一堆骨头、僵尸什么的野兵，就当是自己RP好吧。

    召船（Summon Ship）：除了水世界，没有什么大用；当然打剧情的时候还是用得着的。合理的走位，加上无英雄部队的使用，再一次降低了其必要性。要求本方必须有船的设定比较过分，不如前身到了高级可以凭空造船爽。当然，一个一级魔法，要求也不要太高了。

    Life的初级魔法中有祝福性的，有防御性的，有补救自己的，也有杀伤敌人的；很全面，MANA消耗少，虽然效果不是很强，但搭配初级兵正好。有人喜欢一开始就吃药，实际不智。各种药水在初期都显得昂贵，买一瓶药水，不如多不少兵，或者一个建筑，或者买个技能等。除非是开局就有个强英雄（经常出现在战役的中期），不然最初的发展还是主要依靠初级兵种及初级魔法的配合。

    二级魔法

    天堂之盾（Heavenly Shield）：增加血。50/5，开始的数量就不少，随等级增加的增长幅度也大，是肉盾必备魔法。配合再生，是Life系无耻魔法组合的典型之一，而且很容易就可以实现。

    防护（Defender）：提高防御力87.5%，我个人认为是个好魔法。有人觉得它比较废，就算用了还是只能挨打。然而Life的战法中，通过挨打将敌手耗死是常见的手法之一。这个魔法不象天堂盾需要随时放，作为配合魔法，搭配天堂盾、或者医疗效果的魔法，很少一点MANA，可以很大程度上提高其他魔法的效果（甚至就是单独使用）。在持续作战，快速推进上，作用不小。

    医疗（Heal）：又一个牛魔法。不但恢复生命值，还解毒和瘟疫。配合天堂盾、再生等魔法，是裸奔的又一利器。同时，在大部队作战中也是很优秀的魔法，解毒更增加了使用它的理由。

    报偿（Retribution）：两个用途，一个是加在部队（主要是肉盾）身上，节省魔法和时间。二是英雄自己裸奔的时候使用。总体来说，好像是个额外的占便宜魔法，不过谁又能说清楚，哪种情况下，它刚好可以用来打破僵局？

    殉难（Martyr）：乍听一下，好像光是换了牺牲品，实际上，关键是把高级兵种的高防御，也同时替换给低级兵种。殉难可以确保炮灰发挥作用，并给它们配备高级兵种的防御力。在初期如果可以快速出高级兵种，配合殉难，可以很快清扫野兵；和敌人作战的时候，一个施了殉难的突前部队，也会让人恨得咬牙切齿。

    混乱、死亡、自然、守序抵御（Chaos, Death, Nature, Order Ward）：50%的魔法抵抗，50%的防御加成，听起来是个很好的魔法。唯一的问题是出的抵御魔法，不一定是你想抵御的那个种族。比如你现在的对手是混乱，那么一个二级魔法塔里面，出现混乱抵抗的概率是3/11；其他废物抵抗出现的概率为28/55。

    和平之歌（Song of Peace）：第一次看见它，是从灯神那里。当时灯神的变态给我很深的印象。所以初次学到和平歌，感觉很兴奋，觉得从此也可以变态起来。后来才发现，给和平歌在英雄手上，远不如灯神用得好。原因在于多个灯神一起唱歌，效果才是最好，而且兵种的魔法下次战斗自动补满！和平歌一个可以配合远程兵种，二可以暂时废掉敌人的施法部队。效果当然不能说不好，但是不要指望达到灯神在Order部队中的作用。

    振奋（Mirth）：相比之下，振奋可以算是最有用的二级魔法之一了。兵种行动的顺序在英雄四里面以士气为第一优先。正常情况，+3~+5已经不错了，一下子加到10，几乎可以保证先出手。英雄三里面人人喜欢吹风，四里面的振奋更加作用突出。

    三级魔法

    天国护甲（Celestial Armor）：大家一起加防御，Life的老本行。

    圣唱（Holy Shout）：杀伤所有的亡灵生物。感觉不是特别有用。开始的时候英雄没有那么强，也不会昏头去惹大部队。在后期的大规模战斗中，它的杀伤力又嫌稍弱。而且这么一个作用很局限的魔法，如果占用三级魔法的一半名额，比较令人心痛。

    群体祝福（Mass Bless）：和护甲一起，一个加攻，一个加防；使用时机不同。

    群体医疗（Mass Heal）：不错的魔法。但是真正战斗中，最好避免集体中弹的现象。如果你真的老是依靠群体医疗吃饭，那么魔法、部队损失一定不小，得反思下自己的战略战术了。

    再生（Regeneration）：每个回合自动回复一定的血，变态，真变态。特别适合英雄裸奔，以及消耗弱智电脑。如果是打电脑想得高分，最好把它老人家NEW出来。经常可以配合天堂盾等一两个魔法，然后放个打点计时器在D键上就搞定了。

    除了再生，其他所有魔法都是群体性的，和单体魔法比，效果稍微减弱。一个魔法塔可以出两个三级魔法。如果再给我一次机会，我会希望其中一个是再生。

    四级魔法

    群体驱魔（Mass Exorcism）：打电脑不觉得这个魔法有多好，但是和人打，特别是对方使了这招，一定肚子都气痛了吧。不光是让先前的魔法白费，而且打乱了部署，严重扰乱军心。

    群体振奋（Mass Fervor）：大吹风，好用！

    祈祷（Prayer）：很象水系里面的祈祷。用惯了英雄三的人肯定想问：怎么不加速度？除了Life vs Life的情况，还是好用的。注意由于英雄四的攻防计算方法，在大多数部队为低级部队的情况下，效果和护甲差不多。

    群体混乱、死亡、自然、守序抵御（Mass Chaos, Death, Nature, Order Ward）：单个看都是好魔法，就是不一定能用得上。

    四级魔法也是一堆群体魔法，其中群体振奋和群体驱魔是亮点。再次令人心痛的是，一大堆抵御魔法都混迹四级。不是说它们实力不行，而是很难对症下药。整体看，四级魔法里面没有特别BT的，让人花费四个技能点去学它们，比较费思量。而跳过他们，目标定为五级魔法，更需要花费9个技能点!太夸张了。所以Life魔法经常学到三级就满足了。

    五级魔法

    神圣介入（Divine Intervention）：虽然可以治疗所有部队，但是使用的人心里想的都是英雄。可以让英雄复活，不叫BT叫什么？

    守护天使（Guardian Angel）：另外一个复活英雄的魔法，而且不受生命值限制。在再次感叹BT的同时也让人想到，一瓶商店里随便买的药水，作用相当于一个五级魔法？！

    庇护（Sanctuary）：保护部队（一般都是用在英雄身上）6个回合不受攻击。借此，英雄可以随意走位、可以等其他各种恶作剧都办妥了再出来收拾残局。打弱智电脑的利器之一。

    都到了五级了，还有什么好说的？一个字：强！

D、技巧

    这里应该是本文的重头戏...不过我水平实在太菜了，最关键的内容我都写不出，呵呵，只好说说自己的心得。 　　每一张图，每一次开始，都需要你能够有一个大局上的考虑，一个构思。大到不同的地图，不同的难度发展的构思不同；小到对主力英雄的选择（引用Aqiao 语）。Life系的发展，得根据Life系的特点确定，对手的种族特点也要同时照顾到。如果你可是事先研究地图，那么你至少应该考虑以下的各个问题：

    1、地图大小如何，开放度如何，初期发展能有多少时间？
    2、地图对建筑、兵种、特殊宝物有什么规定、限制？
    3、野兵如何分布（一般不大可能知道，但是多看下也无妨），资源如何分布？
    4、英雄如何培养，技能有无限制条件，有没有相配合的祭坛、建筑？
    5、兵力应该如何发展，主要是什么组合？

    这些问题不一定都能立即回答，但是要随时注意。游戏进行的过程中，也要随时根据情况修改以前的计划。

    开局主力用魔法英雄还是战术英雄，根据实际情况决定。魔法英雄容易产生以弱胜强的战例，对于初期发展有好处。后面转型培养战术英雄时，可以有一支较完整的部队使用；战术英雄培养周期长，开始的战斗如果必须肉搏见分晓，战术技能有优势；同时，战术英雄还可以弥补Life兵种速度慢的缺陷。后期的英雄应该如何发展，要看你是想裸奔还是领军作战。领军作战的英雄可以多修行战术技能，战斗技能等；裸奔的英雄则应该着重战斗技能和魔法技能。应该说，裸奔者在领军作战的时候，仍然有很强的牵制和辅助作用，不一定比单纯的战术英雄差。难点有两个：一是对战的时候，不一定有那么长的时间（最少大半月，最多一个多月）给你培养英雄；二是S/L大法不能用（魔法系如果只学两个的话，不会有很大的变数，但仍然不保险）。即使可以培养裸奔英雄，比如打电脑的情况下，如何培养也很有考究。初次打英雄无敌四的人，大多是升级的时候，挑个好看的图标点了就算了。以后明白了魔法学习和技能的关系，不少人就开始讲究转精。其实还有另外一个境界：合理搭配。同样给你15个技能点，修满一个系，大部分情况下不如选择性学习几个系。可能这几个系都不是水平很高，但是配合起来效果却会出人意料。比如一个宗师Life，很可能不如一个高级Life、宗师Combat、高级Nature、初级Order用起来爽。如何选择技能，职业是个比较讲究经验的问题，和魔法、兵种、宝物都有关系，需要逐渐积累感觉（同时需要S/L的耐心）。无论从哪个方向培养，多个英雄相互弥补技能缺陷都是很好的办法，比如战术主英雄带一个（若干）魔法副英雄，或者一个魔法英雄带一个野人肉盾，或者一个主力裸奔英雄，带一个探路英雄。英雄是Life（以及其他种族）发展的重点，需要格外小心。

    和其他一些种族不一样，Life的实力更依赖于部队的规模和配合。开局要考虑初级兵种的搭配，初期弩手和侍从（包括英雄）的配合好坏，对战斗的结果和发展速度有决定性的影响。二级兵出不出（建筑肯定需要造），出什么也需要根据地图决定。大地图（资源丰富），说不定就可以直接跳过二级兵（甚至三级兵）而直接出更高级的兵种。中期是否出二级兵，是否以三级兵为主力，高级兵种和低级兵种的配合也需要考究。弩手、侍从配合十字军，甚至直接出天使或骑士也可以。纯粹以高级兵种做主力兵种比较消耗资源和时间，而且中间兵力真空时间实际比跳过二级兵更危险。在追求速度（得高分，或对战）的情况下不推荐。 　　Life的建筑不是特别消耗资源，选择兵种的时候也不是个严重问题。需要单独说的就是兵器铺、神学院和马厩了。如果选择骑士，兵器铺就是必须建筑之一，但是它自身不需要很多前提建筑，所以什么时候修是个问题。早期就依靠药水不是很好的战术，初级的英雄很容易消耗大量药水，这笔钱用来搞发展，无论是招兵还是修建筑，都能做不少事情。马厩加行动力真是爽，特别适合Life系的蜗牛部队；但是要多注意部队合并的问题。神学院提供的魔法在短期内不会顾得上学，而且也不一定有钱交学费。再对比马厩的加速作用，很多时候都可以左右四级兵的取舍。

    DarkRain.cn注：初学浅谈系列是Fenrir的作品，而游戏资料部分那些魔法、兵种评价则是我写的。两边的观点，有相当一部分不同，甚至有些刚好相反。这也不希奇，每个人的习惯、喜好都不会完全相同，有些观点差异是非常正常的事情。


初学浅谈（二）：英雄无敌四种族之Death篇
作者：Fenrir

    Death和Life是英雄四种族中最对立的两个，结合Life的特点分析Death，可以更明了其优劣和对立。Life的特点是强化自身，而Death的特点是削弱敌人，这两个鲜明的对比随处可见。

A、兵种

    Death族的兵种，随处都体现Death系的最大特点，诅咒、削弱敌人。打就打呗，还要顺带下毒、老化、恐惧等；落井下石，不过如此了。

    恶魔之子（Imp）：很好的初级兵种，典型的一好遮百丑。攻防差、血少，但是咱跑得快！不光是战场上跑得快，更关键的是冒险地图上跑得快。这个好处可太大了。探地图，拣资源，对初期的快速发展至关重要。数量又多又不怕死，一天派出去6、7队，可以说偷光、抢光、探光。吸魔法的特技对开始发展没有什么大的帮助，但是仍然可以通过高移动力来调动敌人，骗反击等。它和下毒、疲劳配合尤其无耻。后期战斗，尤其是守城的时候，如果条件允许，几队恶魔之子站在后排，一个回合8点10点魔法，大部分英雄是招架不住的。

    骷髅兵（Skeleton）：高远程防御。比起Life的初级兵种，骷髅兵仍然是一个脆弱的兵种。虽然产量还过得去，但是要依靠它来开疆拓土，难度依然颇大。何况人比人，气死人，和恶魔之子站在一起，不由得让人埋怨：你怎么这么慢？以前英雄三的骷髅海人见人怕，如今骷髅海却难得一见。原因不少：一是它太慢（英雄四里面移动力以最慢的计算，所以部队移动力被制约）；二是积攒骷髅没有以前容易（一个城一周只能招一个英雄）；三是大伙都急着攒吸血鬼去了，没有人在乎它。骷髅的地位虽然大不如前，但是开局的前几次战斗仍然可以依赖它。另外，作为高远程防御兵种，尤其适合在战斗中临时召唤（驱役骷髅（Raise Skeletons））出来充当盾牌。这个用法一直到游戏中、后期仍然实用。

    乍看Death的初级兵种不如Life的强。命短，攻防也若；但是别忘了，Death不止一级兵种，后面有的是厉害的角色。作为配合单位，Death的初级兵非常好用，从整体发展速度讲，不比Life慢。Life可以使用大量初级兵种作主力，而Death的初级兵种都是肉搏型，不适合高密度的作战，更多的是用在发展经济，配合高级兵种上面。速度是其最大的优势。

    地狱犬（Cerberi）：同时攻击多个目标，而且打人不反击。很好听的特技，可惜它不是九头。狗的特技是很好的，在近战中相当于3：2的优势。但是限于自身脆弱，无法长期依靠它为主战兵种；等到上了数量，大概也过了时间。当然，选择它也不是一无是处。如果初期就开仗，大家兵力都不足，地狱犬的能力还是很有用的。

    幽灵（Ghost）：老化特技非常BT。多个单组的幽灵无论对付野兵还是敌方部队都非常实用。和吸血鬼配合，或者直接配合裸英雄都极其好用。更恐怖的是地图移动力非常高。行军打仗带上它完全没有拖累，而且对裸英雄还可以增加行动力。同时作为超级炮灰，每仗消耗只一点点，实在是完美。唯一的削弱，就是从高血低防，变成了高防低血。

    Death的二级兵种实在太强了。不是说战斗力多强，而且起的作用大。同样是作为辅助、过渡兵种，Death的两个二级兵在战斗力上面丝毫不输给Life，同时还有强大的特技。论能力，幽灵非常强悍；狗虽然相比弱了一些，但是因为建筑简单，而且幽灵可以通过招魂获得，所以实战中选择狗的人可能还多些。用Death很少有不招魂的，在招到吸血鬼之前，应该已经积累了一大批幽灵了。神速的初级兵，那么强悍的二级兵还是免费的？！

    食尸怪（Venom Spawn）：一个实力上远逊于竞争对手，而且没有任何产量、价格上的优势，实在是生不逢时。食尸怪作为Death中的唯一远程部队，有下毒这么个好技能，而且还是三级兵，应该处于很关键的位置。可惜竞争对手太过强大，实在是报国无门。有人觉得吸血鬼可以通过招魂获得，但是问题的关键还是一个我们自始至终强调的因素：速度。我有了一两个吸血鬼，就可以出去扫荡野兵，培养招魂英雄了；但是食尸怪有这么好用么？有这么快速么？如果我有两个城，或许会考虑食尸怪的。但是它绝大多数时候不是第一选择。

    吸血鬼（Vampire）：吸血，打人不反击，能飞，速度快，还是亡灵生物；别人怎么活？吸血鬼可以说是最强大的兵种之一了。自身攻防指数超过某些四级兵，而且吸血补充生命，还可以通过招魂积累。只能用“过于强大”来形容它。初期很少量的吸血鬼就可以通过和英雄的配合（疲劳，下毒、虚弱等），或者和幽灵的配合消灭实力远胜自己的对手。同时，这样的战斗不怎么消耗魔法，也没有损失，非常适合连续作战。另外，和幽灵一样，吸血鬼的移动力也很高。两个绝配，高速消灭敌人，培养英雄，壮大自身队伍，实在可怕。Death系的魔法也很配合吸血鬼。

    Death的三级兵中充满了不平衡，自身的不平衡导致食尸怪的下岗，同样由于吸血鬼的过于强大，导致Death在游戏中的巨大优势。3DO好像很不善于平衡Death系，三代里面可怕的骷髅海，到了四代，变成更可怕的吸血鬼海。吸血鬼的强大的个体作战能力，比起 Life的僧侣和十字军强大不少，保证了流畅无阻的快速发展。Life（包括大部分其他种族）和Death相比，一级兵种还看不出多少劣势，到二级就显出差距，到三级更是无法相提并论。

    恶魔（Devil）：传送部队，自然是作为突击力量。少了不反击的特技，只好依靠骗反击。不过既然是突击力量，主要就是去消灭敌方关键部队，比如一个英雄，或者一队灯神什么的；自身安危，我只好不管了。作为不怕死的野兵，恶魔是很头疼的对手之一，但是和骨龙相比，能力和杀伤力明显差很多。恶魔召唤的冰魔比较好用，关键在于冷冻，经常可以有意外的惊喜。冰魔对魔法的抵抗（冰抵抗）也时常起作用。Death的主力并不很靠四级兵，如果已经有不少吸血鬼了，相对骨龙，我还是愿意造些恶魔的。它不是主力，我不用在乎它的死活。

    骨龙（Bone Dragon）：强大的杀伤力；恐惧特技不但可以防止反击，而且可以破螳螂的缠身；加上很高的远程防御能力，骨龙比三代强了很多。如果在战斗中四级兵起关键作用（比如小地图上，吸血鬼没有成型之前），我会选择骨龙。

    有了强大的吸血鬼军团，Death的四级兵更多的是锦上添花，而不是画龙点睛。当然，在小地图上，野兵不多的地图上，可以和敌人快速接触的地图上，四级兵种仍然是主力（至少是开战初期）。和Life相比，Death的四级兵恶魔稍弱，但是骨龙强悍。

    总的看来，Death的兵种非常强大。每级兵种都特点鲜明，和英雄、魔法的配合很好。除去吸血鬼军团不说，和Life相比，最大的优势在于高移动力。几乎所有兵都有很高的地图移动力，这保证了快速的发展和英雄快速练级。同时，Death的招魂打法，以及好用的全场有效魔法，比如（下毒、疲劳、诅咒、虚弱…），可以让每个战斗消耗减到最小，非常有利于连续、快速作战。Death的战斗力更集中于兵种上面；加上招魂，到游戏中期和后期，Death会越来越强，而且不怕消耗战。虽然和Life是完全对立，但是Death的实力却很出众，是英雄四里面最强的种族之一。

B.魔法

    和兵种特点相似，Death的魔法也大多是以落井下石为目的。它的魔法并不如Life那么容易造成英雄裸奔，但是和部队的配合并不逊色。

    一级魔法

    诅咒（Curse）：和祝福是完全对立的两个魔法。特点也很相似：开局经常有用，但最大效果还是产生于后期大部队作战的时候，特别适覆盖了对方的祝福，感觉很爽。是不是很象一个火魔法？配合低级兵打仗的时候也很关键，英雄、部队本身就不强，能节省多少算多少吧。

    瓦解射线（Disrupting Ray）：对立于Life的精神护甲。因为英雄四的攻防完全按照乘法计算，所以它比护甲显得弱了些。因为 Death没有什么远程火力，所以也没有时间差可以进行补偿。不过，需要指出的是，削弱魔法和加强魔法同时作用的话，不需要那么强的魔法指数就可以达到平衡。很简单的数学原理：（1+a)(1-b)=1，则b小于a；20%的削弱，正好等于25%的加强。而且，即使单用的时候弱，那也弱就弱点吧，反正也不是特别关键，我们的初级兵本来就基本是炮灰。习惯三的人别奇怪，这个东西现在不能叠加了。

    毒害（Poison）：和疗伤又是完全对立。虽然魔法参数略嫌逊色，但是因为状态永久保持，使它无耻了不少。配合一颗无耻无聊的心（必须），以及疲劳魔法（不是必须），可以磨掉很多比自己实力强很多的部队。同时，它也成为了死亡英雄初级原始积累的工具之一。

    驱役骷髅（Raise Skeletons）：制造骷髅来当炮灰。骷髅的高远程防御可以使招出来的少量骷髅消耗不少野兵的弹药（要是你只会招骷髅，还非得惹大队泰坦，那谁也帮不了你）。开始对付那些野兵，作用实在不小。挡箭兼骗反击，全靠它了。也使因为有这么个魔法，Death初期才不至于一点远程野兵也不敢惹。

    废除（Cancellation）：不但解除敌人单个部队身上附着的所有正面魔法，而且可以用来直接驱除敌人操纵的尸体和幻象。相当于是驱魔和驱散的并集。个人认为是个非常好的魔法。平时还不一定有什么感觉，但是当你的敌人，尤其是对战的敌人，在你得意洋洋放了大堆魔法以后，或者镜像了一群打手之后，一个小小废除的时候，你一定会痛心疾首的。我认为废除是太强了一点，驱散尸体和镜像更过分了些，这样可以限制灯神的作用。作为一个初级魔法，很容易出，更使人觉得难缠。

    总的来说，光初级魔法就已经可以看出Death的诅咒特性。除了毒害，大部分魔法都不能大幅度提高自己部队的能力（特别是发展初期），也就是说，Death的发展和Life相比，更多的会依靠偷、抢，熬到高级兵种的出现。当然，这不包括和Life之间的初级兵对挑。这样的对挑本来就毫无意义。平衡有可玩性的地图也不会给你这个机会。大家的目的还是求发展。最后的综合国力才是最重要的。

    二级魔法

    疲劳（Fatigue）：几乎就是一个迟缓，不能影响亡灵和机械，但可影响元素。这个魔法下可以和毒害搭配（无耻），上可以和吸血鬼配合，采用H/R战术。更加好的地方是，可以和老化同时起作用。先疲劳，在让幽灵去摸一把，搞出个又老又累的家伙，经打么？本身就是好魔法，还有那么一帮相配合的兵，厉害！

    邪恶之歌（Unholy Song）：使战场上所有Life系部队攻击伤害、近战和远程防御力都减少20%。虽然魔法说明上指明是不分敌我，但是和Life组队会士气狂降，相信也没有人轻易这么干。所以应该说是欲盖弥彰！作用是很大，可以针对性太强，使用范围太窄。很多时候不如虚弱。

    吸取生命（Life Drain）：分兵骗反击的克星。另外，英雄等级高了也可以当个简易的疗伤用用。同样，这个魔法只能用于Death的对立派系（Life和Nature）上。效果本来也不明显，而且适用范围还不广，不算废魔法，但是也不算一个关键魔法。

    操纵尸体（Animate Dead）：复活敌方或我方阵亡的生物，可以对尸体或是损失了一部分的部队使用。需要小心的如果先用招骷髅什么的把尸体弄没了，操纵尸体也就不灵了。另外操纵的尸体和活着的时候能力一样，也可以施放魔法。敌方有关键魔法兵种等时可以考虑使用。但是再死了，可就连尸体都没有了。

    泥潭（Mire）：少有的几个英雄地图移动力的魔法之一。可以不夸张的说，影响地图移动力的魔法都是好魔法。泥潭和寻路，以及耐力药水，都是很好的东东。无论是逃跑还是追杀，泥潭都是法宝之一。在准备攻城的时候，要是被抓住机会使用了泥潭，很大程度可以减轻不少损失。等你占了城在回头看那支蜗牛部队的时候，一定得意非凡。

    悲泣（Sorrow）：使敌方单个部队士气降到最低（-10）。可以覆盖振奋的作用。不但平时当个吹风用，还可以完全打乱对方下个回合的部署。好魔法！

    虚弱（Weakness）：使敌人单个部队杀伤力减少25%。没有特别之处，不知道如何评说了。

    Death的二级魔法应该不是很BT。几个魔法有比较强的限制性；几个好魔法如泥潭、疲劳、悲泣和虚弱等都比较普适且好用。总的来说，比较讲究平衡，不会各各看着都可爱，但是用起来也不嫌太烂。想配合BT英雄，难度不小。

    三级魔法

    群体诅咒（Mass Curse）：诅咒就是好魔法，群体的更是了。

    瘟疫（Plague）：群体下毒？听起来很美，不过点数实在是低了点。如果有迟缓效果的魔法配合还不错。但是想靠它来以弱胜强不太容易。

    驱役幽灵（Raise Ghost）：幽灵是个超级好的东西，可以招幽灵的魔法当然牛。也不需要招很多，就轻轻一摸就可以了。战场上很好用的魔法。相当于可以变相施展“老化”。

    恐惧结界（Aura of Fear）：不反击。配合吸血更好。如果我想弄个BT英雄出来，恐惧结界是个好东西。Death的主力兵种里面，吸血鬼和骨龙本来就不受反击，这个魔法很适合英雄和恶魔使用。特别是给恶魔加上以后，H/R战术也是很好使的。

    群体废除（Mass Cancelation）：没啥多说的，看看废除多牛，就知道这个是个好魔法了。

    榨取魔力（Magic Leech）：应该是个好的消耗敌方的魔法，可是除非敌人是那种靠天堂盾过日子的人，这个魔法完全没有其他立即、直接见效的魔法好使。除非一下子干不掉对方英雄，只好祝愿它早早废掉。我有打单机和对方互拼魔法的时候依靠这个取胜，但是不是非常常用。

    Death的三级魔法增强了很多，几乎各各都很好用。但是依然需要注意的是，需要强大的兵力配合。

    四级魔法

    群体虚弱（Mass Weakness）：非常适合大兵团作战的魔法，每次减少25％的损失，在大部队中很快就能显示出威力。

    群体悲泣（Mass Sorrow）：大减速，很好用。

    死亡呼唤（Death Calls）：操纵很多尸体。可惜魔法参数计算出来的是经验值，不是个数。强英雄带大部队打仗的时候能复活几个高级兵，有时候可以起很关键的作用。有了这个魔法，开始突击敌方一两个魔法兵种，然后扭转局势成为可能。

    吸血鬼接触（Vampiric Touch）：打战役，培养裸英雄的时候非常好。但是如果就一个地图，英雄10多级，很难有足够的技能点数来学习吸血鬼接触。而且真要依靠它裸奔，除了战斗，英雄自己的肉搏能力还得很强，技能点数更加紧缺。这个魔法又无法进一步增强吸血鬼大军，让它的必要性进一步削弱。

    Death的四级魔法仍然贯彻了辅助部队的作用。相比Life的四级魔法，Death的要好用些，吸血鬼接触大家都喜欢，但是其他的其实也不相上下。和Life的加强自身相对应，Death的四级可以很大程度削弱对手，利于大部队作战，而不专于英雄单挑。恰好 Death的实力在于部队，所以四级Death的普及率相对高一点。

    五级魔法

    牺牲（Sacrifice）：完美体现炮灰作用的魔法。同时也可以复活英雄！需要注意的是被牺牲的部队没有尸体。

    驱役吸血鬼（Raise Vampires）：制造吸血鬼。一般情况下，可以施五级魔法的英雄大概早有了不少吸血鬼了。而且它还需要大量尸体。实际运用的时候不多，效果也不是那么大。

    死亡之手（Hand of Death）：英雄无敌四里面绝大多数情况下魔法效果计算出来的都是经验值，这个算出来的是个数，显得特别牛。直接作用于强力部队上，效果尤其好。

    除了死亡之手很厉害，感觉Death的其他五级魔法不如Life的同级魔法BT。即使技能点数允许，也不一定要上五级。实际上整个Death系的魔法都是主要用于配合部队作战，起辅助作用。Death的实力在于部队数量上，而其魔法也需要强力部队的配合。Death 的魔法大多作用于对手身上，起诅咒和削弱的作用。因为Death的主力英雄会将很多技能点数献给吸血鬼，所以自身战斗能力经常弱于其他种族的英雄，这些魔法也能在一定程度上起到保护英雄的作用。有时候大家会执着于一些听起来很爽的魔法，比如吸血鬼接触，其实Death的实力要靠部队体现。用好其他魔法，一样战无不胜。

C.英雄

    很少有象Death那么另类的英雄，一门心思就想着第四技能了。别的英雄躲都来不及，他们还一个劲往上扑。和Life类似，Death的英雄也是一个魔法，一个战术。Life的战术英雄以防守起家，Death的以进攻入门。技能和魔法以及兵种相互配合，这也是特点之一了。Death的部队明显比Life 的强大；魔法也都是为了配合兵种造成更大杀伤；Death的兵容易补充，数量也足，所以战术技能着重于进攻多一些。

    魔法英雄

    Death的魔法英雄身兼两职，一个是进修魔法，一个是将来招魂。Death和Life的第四技能又是完全对立，一个复活，一个招魂，但是威力却无法相提并论。一般Life英雄很少把精力花在复活上面，宗师复活也就50%，一个宗师招魂却经常可以招好几个吸血鬼，经常情况是一个星期打仗积累下来的吸血鬼比城堡里面周产量多很多。Death打仗很少需要耗费什么魔法，而且吸血鬼可以自己补充生命很不容易损失，一个星期征战下来就象滚雪球。Life的复活就是再牛也要有损失，加上Life英雄战斗消耗魔法量大，本来就不利于连续作战，就算是一口气打好几仗，也是越打越弱。既然招魂那么好，Death的魔法英雄自然义不容辞地要献身招魂事业。宗师招魂需要专家Death魔法，也就是说总共11个技能点，加上开始自身带的两个，还差9 个，总共16000点经验。Death战斗中有疲劳，下毒等魔法，还有幽灵的老化，吸血鬼在前面顶着，英雄自身不象其他一些族的英雄那么需要战斗技能，这也有利于招魂的快速成型。和Life英雄差不多，10级左右Death英雄已经算是基本成熟了。往后如何发展，还是得看具体情况。三级的Death魔法基本上够用了，在依赖部队威力的环境下，很少有必要立即修炼更高的Death魔法。因为3DO这个时候仍然会相你推荐战斗技能，那也不妨就学学。在练副英雄还是主力的选择中，Death更加偏向于单练主力，原因还是招魂。招魂效果随英雄等级提高而增强。当然，无论什么都要因地制宜。在小地图的情况下，我个人更加偏向于快速打通通道进攻敌人。由于吸血鬼本身实力突出，加上快速，且不受反击，可以因此战胜很多实力很强的部队（配合幽灵更是可怕）。和吸血鬼战术配合的魔法都是状态性魔法，只要最后能胜利，英雄死了也问题不大。这给压制型打发创造了条件。这个时候重心应该放在速决胜负上面，提早加入战术英雄，放弃招魂转练其他有利技能（比如战斗系或者相邻的守序、混乱）都是可行手段。另外还需要说明的是，鬼神学加自然可以获得各种召唤魔法。练成了当然厉害，但是中间过程比较长，升级方向不容易控制；更重要的是为了培养牛英雄，导致兵力大大下降。是否要这么培养，一定多斟酌。

    战术英雄

    战术英雄理应在Death中有一席之地，实际情况中也确实几乎总会招个战术英雄。但是这并不代表战术英雄很受重视。多数情况下，Death 的主力都在为招魂服务。战术英雄几乎总是在招魂成功以后才进入角色。大家都知道攻防加成当然好，但是重心是数量，加成就是能加多少算多少。和Life一样，战术英雄带领下的快速压制战术在某些情况下也很厉害，但是和全民招魂运动比起来，实在是势单力薄。

    总的来说，和Life（以及其他种族）相比，Death兵力强盛，英雄也以技能为主。招魂压倒一切，导致战术的单调（不单调总是可以的，就是效果不一定好而已）。

D.技巧

    前次讲Life的时候，已经说了不少普遍发展中需要注意的东西，这次就只针对Death讲些特色的。Death的发展技巧，仍然以部队为主线。整个游戏中你应该有一个全盘的打算，是要快速进攻还是慢慢消耗。明了自己使用的种族的优劣，扬长避短，是玩家应该始终注意的东西。具体到Death来说，初期速度快、地图探得多、三级兵BT是突出的优点，而英雄个体能力不强，单兵战斗力偏弱是其软肋。那么普遍的来看，Death适合前期迅速出三级（这个一般都比较容易），然后快速扩展取得绝对优势，或者把战斗拖后，用优势数量淹没敌人。

    开局英雄的选择前面已经说过，由于招魂的原因，多数情况是以魔法英雄开始。因为有地图移动范围大的初级兵，很普遍的做法是开始用很多单个的恶魔之子探地图，偷、抢资源。探地图的作用不单是敛聚财物，还有重要的任务是探察野兵的组成分布，由此合理计算资源的使用，如何安排建造顺序。很多人为了快出吸血鬼，经常在二级兵方面选择狗，当然这多数情况无可厚非；但是有些情况下，如果仔细计算，前期多忍几天（或者更加不计较牺牲），出幽灵，配合以后的吸血鬼，可以让后面的战斗更加连贯。小数量的吸血鬼实力也很强，加上Death魔法本身没有必要那么高，在追求快速进攻的情况下，经常会两个（甚至多个）英雄集体作战，依靠少数强力兵种（以及部分低级兵种）进行突击。这个时候英雄在部队中的配合作用更加明显，综合部队的配合是关键。

    前期突击作战中，多个低等级英雄配合少数强力兵种是好搭配，那么后期作战中，就需要多留意对方的英雄。一般到后期，Death英雄的能力大都不如对手（电脑控制的不算），大规模战斗中，需要有快速的手段解决对方的强力英雄，或者关键的魔法部队（比如仙女龙、灯神）。这么作一个是为了尽量保存自己的英雄，二是尽量排除意外因素。这个时候，单独使用吸血鬼是不够的；而加上恶魔等就非常得体；榨取魔力等魔法也很不错。无论什么时期，Death的英雄想裸奔是困难的，而起完全是弃长用短。即使你狂学各种战斗系魔法，那也是把Death英雄当野人用。也许如果兼修Nature（Life）和Death可以做到，不过周期很长，请慎重。

    前面说过，Life系以兵力为主，讲究配合；那么Death更甚，在讲求配合的基础上，还有数量的优势。这个趋势还更加延伸到英雄的培养上面，如何培养英雄，应该主要以配合壮大部队实力为重点，除非情况特殊，不应该太在意培养自己“孤胆英雄”，但是要提防对手的“裸奔人”。

    建筑方面没有什么有争议的敌方，建筑体系简单明了，也是Death的优势之一。招魂塔也便宜，能造就造吧。


初学浅谈（三）：英雄无敌四种族之Order篇
作者：Fenrir

A、兵种

    半身人（Halfling）： 初级远程兵种，伤害有距离限制。它的作用还是在初期的发展上面。感觉四级杀伤加半的特技的文化原因多于平衡原因。半身人本来就慢，后期也不会刻意去攒。专门用来杀四级，大概太勉强了。当然如果要用来威慑威慑换回合，也无不可，就是只能用一次而已。半身人的初期作用还是很大的，配合Order魔法“精确”，前期杀野兵很爽。而且还有它的黄金搭档“矮人”在前面做肉盾，用 法和Life的弩手差不多。

    矮人（Dwarf）： 增强型肉盾。说它增强，是因为有那么一点抗魔的本事。这点抗魔，可以在开始的肉盾阶段减少不少损失，包括保护英雄。用矮人来 围一圈，里面装法师和半身人是最常见的组合。和其他种族的初级肉盾相比，矮人防守能力很不错，优势是皮粗肉厚（相对），缺点 是逼近速度不快。当然矮人还负责以身殉职拣资源（相信很少有人用半身人干这种活）。
    这两个又是经典的一远一近。半身人虽然单个不怎么显眼，但是加了精确以后还是很厉害的。杀伤力来看不如Life系的弩手，但 是产量大，按照周产量来看，几乎一样。半身人有射程衰减，需要法师的“精确”魔法配合。另外一个肉盾型兵种矮人，虽然和其他 初级肉盾比有强有弱有特点，不过使用方法也没有什么大的区别。另外，地图推进速度慢也是它两的通病，到了二级兵仍然没有什么 改善。

    法师（Mage）： 法师是个很尴尬的兵种。当你在野外看到他们的时候不一定就敢轻易去打，即使你实力很强。但是当你自己带一队法师出征的时候，仍然会发现经常有不敢轻易上阵的时候，因为法师太脆弱了。英雄无敌里面这样的兵种不少，特点就是单点杀伤力大，自身脆弱。不怕死的时候很厉害，但是你自己拿到手上其实没有多少，怎么会不怕死？平心而论，法师的能力还是挺强的，几个魔法都很好，上了数量以后更是厉害。感觉有点象某些球员，进攻很强，但是防守实在太惨。所以再好，选择的时候也不得不再三思量。

    金人（Gold Golem）： 两个很突出的特点，抗魔和皮厚；和法师相比，一矛一盾。70％的抗魔在兵种里面算是很牛的了，加上很长的血，肉搏能力突出。作为 一个很好的肉盾，金人和半身人配合不用说了，和高等级的灯神配合也很好。上下适应范围广，是金人对法师的优势。
    法师和金人各有千秋，经常不容易选择。好在兵种不是用来单挑的，是用来配合的。比较法师和金人在整个Order系部队中的作用，经常可以帮助我们作出正确的选择。Order的部队中，灯神占了很重要的地 位，一般前期尽量早出灯神，后期尽量多攒灯神。法师和灯神等配合，甚至算上半身人，四级兵，全进攻阵容。不是不可以，但是要 谨慎，如果很清楚地图，以及野兵、对手的兵种分布，这种组合有很强的杀伤力。如果出金人，一个前期可以单独配合半身人，二是 在四级兵没有出来，灯神数量不很足的情况下，在前面当盾牌和复制标本的时候作用非常明显。攻守平衡，是金人带来的效果。虽然 点攻击力不如法师，但是不失为一个稳妥、普适的打法。但是，鉴于灯神实在变态，有时候速出灯神压倒一切，那么就什么快修什么吧。

    灯神（Genie）： 可以说是英雄四里面最强悍的兵种之一了。建设条件并不很BT（其实再BT，也要砸锅卖铁修出来），魔法极其实用，少量的灯神 可以起决定性的作用。一般来说，灯神出现的时候，也就是大家扬眉吐气的时候。和吸血鬼相比，灯神的作用一点都不逊色，而且和 其他很多兵种配合更能体现价值，用起来不象吸血鬼那么单调。灯神的关键就是魔法，不但可以顶好几个黑马，还能复制，还能吹风 、减速，我C（实在忍不住了，不得不用一下发语词），英雄的作用也不过如此！对了，还有冰箭，灯神上了数量以后，冰箭威力及 其可怕！作为魔法兵种，灯神相对魔法英雄的优势是，魔法值每仗自动恢复满！太牛了。最普通的用法是单个灯神分N组，然后一组 主力灯神。单个灯神使用各种辅助魔法，主力冰箭或者复制。即使灯神少的时候，单个分组用魔法也很强。

    蛇妖（Naga）：风采依然不减当年。打人不还手还是那么强悍。可惜，灯神实在太牛了。蛇妖？哦，屠夫而已。其实四级兵出来之前，和灯神配合最好的就应该算蛇妖了。可惜3DO不让我这么干。少数量的蛇妖好像比灯神杀伤力强些，但是问题应该这么考虑：开始小数量蛇妖很难无损失且造成大伤害，Order自己的英雄又不容易那么早就可以保证肉搏部队小损失，那么蛇妖实在是不容易带领大家冲出去 。冲出去也无以为继。所以靠蛇妖突击不容易实现。什么？不搞HP突击？那么要蛇妖干什么？
    三级兵几乎没有什么好选择的（这也是3DO做得不平衡的地方之一），灯神是绝对主力（除非地图不让我造，比如官方的一个地图 ）。和吸血鬼比，灯神不容易上数量，一旦魔法用尽了就比较困难，但是也有优势，就是容易和其他兵种配合。经常的情况是配合的 兵种越强，整个部队战斗力就越强。作为魔法兵种，有了配合的其他兵种，采用单个分组和主力分组的办法，很容易无损失胜利。而 吸血鬼经常容易和其他部队冲突（主要是分组的原因）。另外前期，少量的灯神经常能比吸血鬼发挥更大的作用。灯神在很大程度上 可以代替多个英雄的作用，而且无论杀伤力还是辅助作用都很强，在任何时候都是绝对主力。这里又印证了英雄四的一个常见的现象，一级兵浴血奋战图发展，二级兵起辅助过渡作用，三级兵往往导致实力的质变，使战略目标从自身发展向进攻敌人转变。

    泰坦（Titan）： 从二代开始就是最受欢迎的兵种之一，尽管一再削弱，现在仍然强大。虽然3DO嘴巴上不承认，把人家的经验值搞那么低，但是实际潜意识里面仍然不愿意让你那么容易就拥有了它，所以建筑条件才那么可恶。从指数上来看，泰坦好像不是很强，但是问题的关键 还是我刚才说的那个观点：兵种不是用来单挑的，是用来配合的。四级兵的高杀伤能力，使其在对付低级兵种的时候有绝对优势，如 果再加上远程（变相的不还手），就更加可观了。同时，守序的精确等魔法完全为泰坦量身定做，加上灯神的复制等，实力及其可观，非 常容易无损失胜利。另外，守城的时候往那三颗大石头上一站，那叫威风。近战伤害不减倒不是什么重要的东西。谁愿意让远程兵肉 搏？而且泰坦本事指数就不是很好，全靠远程吃饭，敌人走近，就已经是落了下风了。

    傀儡龙（Dragon Golem）： 抢先攻击和忽略对手的抢先攻击技能加在一起实际就是保证先攻。指数上比泰坦略强，不过加上远程的因素，实际差不多。傀儡龙的 优势一个在于肉搏的时候实力明显，二个是建筑优势，比起泰坦，大概要便宜7000块钱，这可是白花花的银子啊！带上傀儡龙打 仗，好处有速度快（地图），并且它自身速度快，很容易冲到前头去。不过英雄四里面英雄有自己独立的回合，所以高速兵种的重要 性不是那么明显。
    四级兵里面，傀儡龙和泰坦，一个远程，一个强力肉搏，互有优势。一般来说，傀儡龙出来得早一点（而且附带建筑比较有用），突 击速度快一点，当肉盾合适一点（镜像出来的更好）。泰坦建筑条件太麻烦，但是远程兵使用起来不那么费神。因为灯神出来以后，可以单独用上几天，所以我个人稍微偏好泰坦一点。

    整个Order的设计思路实际照搬了三代的塔城。整体上有魔法优势（从英雄的魔法数量，转移到魔法兵种上），但是地图和战斗 速度偏慢。从兵种的战斗力来看，整体配合非常好，而且有非常BT的灯神；四级兵种实力也不弱，应该说是整个英雄四里面最强的 一个种族了。它的缺点是移动速度不快，而且建设条件相对高。不过Order初级兵开疆拓土的本领不弱，三级兵灯神强悍无匹， 只要地图不是过分贫瘠，整个游戏中期到后期，Order实力都是数一数二的。

B、英雄

    Order的英雄分为魔法英雄和管理英雄。东方卷轴上说的是力量英雄，实际上根本作用还是去当领主。英雄四里面没有特技，贵族系的英雄在肉搏能力和带兵能力上和魔法英雄没有高下之分，所以Order实际上没有力量型英雄。Order的强项在于魔法和兵种（两个都是强项，所以说Order牛），魔法英雄不用说，贵族英雄增加兵力也很合适。没有初始的战术（战斗）英雄，Order的主要发展就得依靠英雄的魔法和兵种的配合。Order是非常讲究配合的种族，由于魔法英雄的初始技能优势，配合的重任就由他们承担了；而贵族英雄们则负责在家里催生。也许3DO想平衡一下各个英雄技 能和职业，把带贵族系的职业技能设计得都还可以，但是可惜的是在分配技能点上，技能相对职业在大多数时候都占优势，而且更不 能浪费。所以真正用领主做主力的情况不多。
    Order的相邻派系是Life和Death。加上可以买技能，学习更多的技能概率很大。对于整个魔法来说，Death和L ife的魔法和Order配合都还不错（基本上，不同派系的魔法配合效果都比同派系的好，如果是对立派系就更牛了），相比之 下，Life对英雄的保护能力强些，Death对部队的帮助大些，就我个人而言，选Death的时候可能会多一些（战役不算 ）。不过一切都要看实际情况决定，我说的偏好只是勉强的细微区分。

魔法英雄：

    Order的初始发展对魔法英雄的依赖很大，Order的魔法虽然很强，但是也不是个个都那么顶用，一旦运气不好，初级魔法不顺手，还是影响发展速度的。好在兵种组合还是比较强的，影响不至于很大。等到有了一定数量的部队以后，英雄等级也比较满意，Order系魔法和兵种的优势就开始显现。Order的好魔法数不胜数，上了等级以后，想不学到好魔法都难。所以用Ord er打的话，开局有可能比较艰苦，但是中后期一般都比较轻松。Order的魔法英雄相比其他族的魔法英雄还有一个优势，就是并不 很需要肉搏技能。肉搏在绝大多数时候都是很有用的技能，特别是你想裸奔的话，肉搏几乎必备。然而很多时候，特别是单关，除去 初期的发展，后面留给你的时间本来就不多，加上Order的主力兵种讲究精简和配合，裸英雄无论是地图速度上还是战斗的难度 上都不比大部队作战占优。所以Order的裸奔战术并不很普及。大多数情况下，大队的灯神肯定是部队的主力，各种控制性的魔 法，以及肉盾和复制出的肉盾，英雄亲自下场的必要性不是很大，而且也很容易被保护。相比其他种族，Order的英雄培养起来 没有那么费心，讲究一个“专”字在很多时候就足够了。Order自身的魔法可以说是博大精深，往高等级学，并不觉得很浪费。Order系的魔法大多是控制性，状态性的，和强力部队配合效果尤其好。Order的战斗技巧很大程度在于魔法和魔法，魔法和兵 种的配合上。

贵族英雄：

    Order的英雄分工很好，一个主内，一个主外。贵族英雄的主要责任就是搞生产。以前打英雄三的时候大家都知道350英雄总 是很好的，在四里面虽然钱和部队实力的关系做得并不很好，导致加钱的英雄不是那么吃香，但是提高产量仍然是一个好技能。在我 看来，贵族技能是多多益善。有人说产量高了招不完？你难道把钱都先拿去招了矮人再说？多几个灯神什么的总还是有用的吧。贵族 英雄自己并不适合出去征战，因为初始技能对战斗没有任何帮助，自己就是一个普通兵而已；要有作用，需要不少技能点数，和其他先天 发达的英雄相比，速度上慢了不少。辅助型英雄虽不是战斗的主力，但也是不可少的，多一分优势就多一分胜算。Order系还有 一个优势就是兵种战斗力比较强，即使没有好英雄，小数量的高级兵种（灯神等）配合低级兵种，可以很容易干掉一些低级野兵。这 给贵族英雄的发展提供了不少空间。摸摸石头，带上来不及上前线的兵打打野味，也能升不少级。游戏的中后期，Order经常可 以保证大规模强力部队，非常恐怖，原因就是由于作战无损失和城堡的高产量。Order的兵本来就是很强悍，还尽超生？！
    总的来说，Order的英雄比较领类，一个是没有战术（力量型）英雄，二是对肉搏技能要求不高，忽视裸奔能力。一般来说，O rder的魔法英雄作为主力，应该比较“专”于本门魔法。开始的发展可能不顺，但是艰苦期很容易度过；整个中期到后期，Or der的实力都非常强。贵族英雄一般开始不培养（可以有），部队成型，开始向外扩展的时候，也是副英雄练级的时候。练好了的 一个领主对发展的贡献不可低估。

C、魔法

    一级魔法

    模糊（Blur） ：提高远程防御力提高50%，这是非常高的一个比例。提高50%也就相当于只受2/3伤害，加一个给肉盾是最好不过的了。作为一个一级魔法，其实初期的作用并不是特别牛，因为Order实际更需要的是提高进攻质量的魔法，比如精确；保护肉盾实际不是特别必要，分兵牵制、阻挡等就基本可以了。而且矮人等小家伙，多死上几个也不会太在意的。它最牛的时候是有了高级兵种，或者高级英雄以后，放（甚至完全可以让一个刚招出来的法师来放）一个不会过期的一级状态魔法，就可以有部分合金护盾（Adamantine Shield）的作用。

    驱散（Dispel） ：解除所有状态魔法，导致良莠不分，比起Life来，稍微不如意。驱除尸体和幻象是它的优势，在针对一些魔法兵种（包括英雄）的时候很好用。发展的初期，我想大家也不会都急着要去和野灯神、魔法师等拼命，所以这个魔法依然是中后期作用更明显。注意，它不能驱散Anti-Magic魔法。

    推移（Displacement） ：两格听起来不是那么动人，但是由于英雄四里面有很多地方涉及了视线问题，所以推开（或者推过来）一点点，形式就大不相同。Or der兵种常用的大部分不是施法部队就是远程部队，推移可以说是很好的搭配了。即使是阻挡肉搏兵种逼近，推移也可以争取到一到两个回合的时间，虽然效果并不惊人，但是作为初级魔法，也足够了。

    魔法拳（Magic Fist） ：杀伤力不大，对付小股部队比较好。毕竟是一个一级魔法，而且Order也不是靠直接杀伤取胜。魔法拳作为一个可以直接奏效的杀 伤魔法，使Order初级魔法全面，各个方面都不弱。

    精准（Precision） ：这是个任何时期都非常好的魔法。远程攻击力提高25%，并使远程攻击伤害不受距离、障碍、城墙的影响，效果比一个中级宝物狙击 弩（Sniper's Crossbow）还强，大概类似英雄三里面的金弓了。Order族的远程本来就强，还有这么些牛的魔法......

    真视（Visions）：典型的对战魔法，平时你经常用么？

    Order的一级魔法是强悍的。前、中、后各个时期都很好用。各种类型的魔法都有，而且在远程方面的造诣，不但可以保护自己的魔 法部队，而且也使自己的远程威力倍增。

    二级魔法

    怯懦（Cowardice）：野灯神经常使用，但是自己却不很常用的魔法。对敌人的关键部队使用，效果比较好。

    飞行（Flight） ：你为什么需要飞行？为了跨越障碍（飞行不增加移动距离）；为什么要跨越障碍？因为要逃命！大多数情况下，飞行要么是和其他魔法配合，达到一个无赖胜利的目的；要么是加给关键部队保命用的。当然情况也不绝对，你见过会飞的机械龙么？英雄四的战场开始没有办法兼顾前后（特别是电脑控制的部队），突然飞到背后干掉英雄的感觉是很过瘾的。

    冰箭（Ice Bolt） ：杀伤力很强的魔法，但是基本上是为灯神（和水元素）设计的。一个英雄再牛，冰箭也杀不了多少东西；更何况英雄牛了以后，有的是 重要的魔法等着他放。冰箭？还是留给灯神吧。一大票灯神的冰箭，威力恐怖。

    制造幻象（Create Illusion） ：又是一个BT魔法。没有相应的驱散魔法，很可能会对这个魔法是一筹莫展的。自己的部队需要比相应的灯神部队占数量上的绝对优势 才可能获胜，即使如此，损失也不会小。也主要就是因为有这个魔法，打野灯神要多加小心。另外，英雄学习这个魔法也还是能起一点作 用的。

    迟缓（Slow）：比疲劳还好，不多说了。

    能量损耗（Power Drain） ：对付魔法兵种（英雄）的武器之一，使用的时机比较微妙。对付敌人的英雄或者魔法兵种，可以直接杀伤，也可以施其他状态魔法；对 于魔法部队和肉搏部队，谁优先照顾等都需要仔细斟酌。能量损耗并不会经常使用，但也不是没有作用。

    窃魔（Steal Enchantment） ：吸取单个敌人部队身上附着的一个正面魔法状态，转移到随机选取的本方部队身上。算是一个比较强的魔法了。Order的魔法以精细见长，要么在魔法方面，要么在战斗方面总有不少的法宝可以四两拨千斤，窃魔算是魔法方面的巧劲了。经常的感觉是对人比对电脑有用；对英雄比对纯野兵有用，对强英雄弱兵比对弱英雄强兵有用。

    大量的状态魔法。迟缓是大家都特别喜欢的，冰箭、幻象等也都很好。配合自己的魔法兵种，可以对付大多数部队（特别是野兵）了。

    三级魔法

    驱逐（Banish） ：用来杀伤召唤类的。可以发现，Order对于召唤、幻象、尸体是最免疫的。而且自身在这方面还特别强。不过比较起来，驱逐是里面最不常用的魔法了。本来遇见召唤生物的机会就不是很多；花费一个回合的魔法，去杀伤一个召唤生物，也不一定划算，也不一定有用。除了实力、优先级上的考虑，出手顺序上的限制也局限了这个魔法的使用。

    遗忘（Forgetfulness） ：没有了时间限制，比英雄三里面的遗忘更牛了，可惜的是没有群体遗忘。不过可以利用视线阻挡，重复使用，还是可以当大半个群体遗 忘使用了。

    群体模糊（Mass Blur）：半个合金护盾（Adamantine Shield ）。强！

    群体驱散（Mass Dispel） ：也是一个很强的魔法，但是实际上一般战斗中幻象或者尸体都不会有很多队，驱散群体化，实在是不太必要的。有时候对付对方的群体 魔法很不错，不过我个人并不是很喜欢它在三级魔法塔中出现，特别是我的第一座塔。

    群体精准（Mass Precision） ：仍然给人大材少用的感觉。群体精确的确很好，唯一可惜的是一般没有那么多远程来享用这么好的魔法。你不能否认这个魔法很牛，但 是经常情愿三级里面出其他的。

    传送（Teleport） ：强力肉搏兵种的恶梦。英雄无敌四的战场扩大，导致这个魔法可以对绝大多数肉搏兵种使用，配合减速（疲劳），成为BT地图的常用 手段。对自己的肉搏兵种，采用传送依然效果突出。可以说作为三级魔法稍嫌过强了一点。也因为如此，很多人都希望三级里面出传送。

    回城（Town Gate） ：BT！英雄四里面独特的部队行动力计算方法导致了无法传兵，快速移动很大程度上成了进攻和防守的瓶颈。没有了时空门，更限制了部队的行动能力，这个时候唯一可以依靠的就是碰野兵逃跑和回城了！Order的回城魔法居然可以在战场上使用，比三代的回城牛太多，实在影响平衡。配合堵城门和回城地点的选择，在移动力上也几乎不逊三代的回城。

    三级魔法仍然是典型的Order特色：大量状态魔法。和强兵配合最好的魔法就是状态魔法。Order这两者都有，想不强大都不容易。三级魔法里面好魔法太多，我都不知道选什么了！无论是配合魔法兵种，还是远程，肉搏，都很好用。有了一、二、三级魔法，配合 Order兵种，很多时候都已经够用了。

    四级魔法

    疯狂（Berserk） ：和三代的疯狂是一个效果，更正了犯傻的BUG；但是没有范围的作用，使用起来不如原来那么爽。把它列到四级里面也还说得过去， 战场的扩大，AI的降低，人脑施给电脑的疯狂还是致命的。一个中规中举的四级魔法。

    失明（Blind） ：效果限制在三个回合，打三打习惯了玩家肯定对此非常不满。列入四级魔法好像有点抬高了。Order系的魔法里面限制敌人行动的魔法不少，兵种和英雄都可以胜任，一个失明那么贵？也许给裸奔的英雄更好的吧。这是少有的可以让自己腾出手干其他事情的魔法了。 Order的魔法里面，很多都可以胜任多种情况，作用也相互重叠，即使这个魔法没有学到，以后还有机会学其他的。

    幻影（Phantom Image） ：高级的召唤魔法。英雄四里面引入生物的经验值（等级越高，和生命值差距越大），并且绝大多数魔法等都按照经验值计算，使幻影有了独特的优势，效果按生命值计算的特点用来复制高级部队最好。好是好，但是不知道为什么，反正使用的机会不多，大概等我很牛的时候，灯神也已经不少了吧。

    群体迟缓（Mass Slow）：好用就一个字！

    四级魔法在Order魔法中的作用没有前面的三各级别那么重要，属于锦上添花，而不是画龙点睛。不过也没有什么垃圾魔法，更何况 是通往催眠大法的必经之路，想来也没有人抱怨学了四级魔法吧。

    五级魔法

    催眠（Hypnotize） ：影响平衡的一个魔法。相信很多苦练Order的玩家都对它寄予很大的希望。除去类似BUG的和其他魔法（牺牲、殉难）的配合效果，单单一个催眠，威力就可以用恐怖来形容。自己最强力的部队被对手控制简直就是恶梦。虽然不是永久控制，但三个回合已经太长了！而且一般会催眠的英雄都已经很牛了，放上4、5个催眠应该不会伤筋动骨；好几队部队同时被控制是经常的事情。一般来说，有了催眠几乎就可以宣布胜利了。

    痛苦之镜（Pain Mirror）：感觉上是最差劲的五级魔法了。难道是NWC自己也觉得Order太强了，就故意给个垃圾魔法？

    通法盗窃（Steal All Enchantments） ：看到自己辛辛苦苦，精心设计的魔法全部起了反作用，打击一定是很大的。假如有兵力支持，又可以拖延交火时间，我很愿意把一个回合献给这个魔法。

    如果说Order的强力兵种是龙，那么前三级魔法就是画龙点睛。第四级已经说过了，是锦上添花，那么第五级呢？是给这条龙手里再塞一把末日之刃！可以不客气的说，NWC在魔法设计和平衡方面作得很不够。四里面一个很特别的设定就是状态魔法没有时间限制，这使得状态魔法比以前要强很多。Order有最强大的控制魔法和状态魔法，加上无论攻击力和魔法都很强的兵种，使它成为最强大的种族之一。从一级开始的模糊、精确、驱散，到二级的幻象、迟缓，然后是遗忘、传送、回城......各个级别的Order魔法都是大众情人。Order以魔法为主，那么什么东西对魔法部队伤害大？远程和快兵。恰恰Order的魔法里面克制远程和快速部队的魔法还特别多！加上自己强大的远程部队和相应的魔法，的确破坏种族的平衡。除去众多的BT魔法不提，Order魔法适用性很强，而且作用重叠的多。即使有什么没有学到的，也有很大可能用其他的代替。这样使得Order的魔法作用很难有削弱的时候。强悍的魔法，很高的学成率，是Order全民进修法师的主要动力。

D、技巧

    Order是比较容易上手的种族，我第一次正式打英雄四，也是用的Order。Order的好处是没有特别的兵力真空时期。从开始的半身人，到灯神配合半身人，到四级兵加灯神，一路顺畅。需要注意的是二级兵种的选择和使用。一般情况下，快速升三级是可行的。开始就有三个灯神，看的就是你有没有钱招出来，招出来和谁配合。Order的二级兵和一级兵配合不是不可以，缺点一个是速度慢，二是能打的仗不多，资金消耗大。对周围环境的侦察很重要，出什么兵，出多少都需要考究。如果可以用初级兵（可能配合少量二级）支撑到灯神是最有效率的。所谓支撑，就是尽量保持每天英雄都有事情做，不耽误升级，也不耽误发展国力。出灯神以后难度大大降低，打法上主要就是战略的考虑了。这也是Order的另一个优势之一：难点不多，战术上限制很小，可以很容易实现绝大多数战略思路。

    开局打法上，Order和Life的打法类似，两种初级兵加上英雄的配合很关键。如果资金允许，当然可以招两个英雄。灯神是需要钱的，到处派炮灰拣资源是必要的，砸锅卖铁也是经常的。Order开局一般不会用贵族英雄主战，所以我写起来也容易，我个人喜欢先到二级魔法，然后根据三级魔法的内容来决定培养方向。如果三级不好，那么先上Combat；如果三级好，那么学了三级Orde r以后再学习Combat。Order的法师不用把肌肉练得那么发达，首要的重心是兵力的建设和魔法的学习。

    Order没有什么快兵，英雄也没有必要执着于裸奔，在Order中，经济基础决定上层建筑。Order的四级兵很贵，但是有了的话实力会大增，所以我个人这个时候喜欢攒点钱。到了中后期，一群灯神是肯定有的了。什么时候出四级兵也需要仔细考虑。因为Or der的特点，四级兵不一定是要亲自上阵，经常作个标本就可以了，所以存在的意义经常远大于数量。英雄四里面如果没有金矿，钱经常是不够的；在很多情况下，我宁愿把钱全部用来招灯神。主力法师英雄当然可以尽量升级，不过最好在先有了魔法塔的情况下决定是否单独升级Order。Order魔法主要是状态魔法，这决定了它能够很好地和大多数兵种和其他派系的魔法配合。一般情况下，学到四级Order魔法已经非常够用了，除非打战役和BT地图，催眠实在不是必要，而且出来的几率个人感觉远小于三分之一。有了一批灯神以后，也是开始培养第二个英雄的时候了。可以多主力，分头进攻，或者培养贵族英雄，放在家里催生。方便的地方在于灯神的以一挡百，快速升级到6－8级不是很困难。我个人而言喜欢贵族英雄，一个是后方比较安定，而且还可以增加产量。二是副英雄毕竟不是很强，打起来费时间，不爽。

    建筑方面，比较有特色的是大学和国库。大学在战役中总是受欢迎的。一个地图，等过了一个月左右，英雄也有个三级Order的时候，办个大学，可以为以后英雄的发展提供参考。国库是个好东西，钱就跟收高利贷一样滚滚而来！要是战斗还得拖上几个星期，在不影响兵力增长的情况下，还是修一个吧！


初学浅谈（四）：英雄无敌四种族之Chaos篇
作者：Fenrir

    Chaos的设计思路比较特别。相信在英语环境中待了一定时间的人都会知道，实际把Chaos翻译成“混乱”，在意义上并不完整，特别在这个游戏中，Chaos更多的是表达一种（带邪恶的）强力、暴力、向外冲击宣泄的意思。在种族的设计上，也遵循了这个思路。要么体现暴力，要么体现邪恶。

兵种

    盗贼（Bandit）：盗贼应该是“肉盾”了？可是它的实际作用全部在特级上面。高级潜行技能可以让它偷矿、偷钱，侦察等。可惜的是现在的地图想偷东西是越来越难了，而且即使能偷到，也不比别人舍身成仁拿到的多多少。侦察倒还可以，不过不是因为它隐身，而是速度还可以。后来发明的堵人大法也仅仅可以偶尔为之。新鲜的潜行技能，在3DO和玩家的联手下，越来越衰落了。

    半兽人（Orc）：虽说是远程部队，可是设计距离那么短，叫远程么？守城还勉强可以，但是想叫人重视，难上加难。它算是英雄四里面最彻底的垃圾兵种 之一了。

    这个种族的各个生物都是各神话传说中标准的Chaos份子。但是从兵种实际能力来说，一级兵比较特别，比其他很多种族的同级兵战斗力要差。虽然从类型上来说，仍然是传统的一远一近，可是远的太弱，导致近的也没有办法发挥作用。我想是因为有盗贼和潜行技能的设计，导致设计者故意把相应的兵种战斗力削弱，来平衡平衡。可惜现在做图的人越来越不给面子了。以前盗贼的特技导致Chaos的初期发展可以比其他种族快很多，这个优势现在越来越弱了。不管怎么说，是可以偷到很多资源，导致能够快速发展高级兵，或者由于自己战斗力太差，不值得大规模培养，反正打Chaos囤积盗贼或者半兽人并不是很有必要。

    美杜莎（Medusa）：非常强悍的远程兵种。强不是在数值上，而是无限弹药和石化上面。无限弹药还好点，石化就可恶了。来了一大票美杜莎，就算能打过也得先想想，特别对于喜欢零伤亡的玩家来说。比起三代里面的石化，这个要牛多了。美杜莎可以和低级兵比如盗贼，高级兵比如梦魇兽，或者巫师英雄配合，使用范围广。美杜莎在Chaos中算相当有用的兵种，巫师群或者黑马群战术中经常需要依靠它。产量是个问题， Chaos经常需要快速的攀升部队等级，很多时候等不及美杜莎成型。经常的情况是一边发展一边堆积美杜莎。使用美杜莎需要注意它的石化概率和自己造成的伤害成正变，不同的作战顺序说不定有不同的效果。

    牛头怪（Minotaur）：一个电脑用起来比你爽的兵。在战斗力方面没有什么可以挑剔的，而且还有格挡的特技。不过问题也就出在这里。用几率做特技本身就不让人放心，一方面电脑在这上面大做文章，另一方面要让自己依靠它打天下更觉得太悬。特别是打单机地图的时候，野兵和敌人经常有数量上的绝对优势，减少损失显得尤为重要，所以选牛头的人实在不多。也许有BT人士愿意通过S/L保证100%的格挡，那我只好寒 到死了。

    Chaos的二级兵是比较好的，从数据上看，美杜莎和牛头怪都挺强，相比之下，前者的出镜率要高一些，因为它是远程，无限弹药加上死亡凝视配合巫师群或者黑马群，可以最大程度减少损失。不过问题出在产量上，两个的产量都不是很高，一般从二级到三级甚至四级的过渡时间也就一个多星期，数量上没有办法积累。积累起来也费钱。如果有多个城堡当然好，不然还不如早早上三级四级算了。在我看来，二级做主力并不是很好，纵观我们谈到的几个种族，没有用二级主打的，原因就在于二级的杀伤力不是很强，而且数量上也没有办法快速累积，说不定钱全部砸在里面，还影响其他发展；算是不上不下，不堪重用。Chaos的二级特级很好用，所以我经常是把英雄和二级同时作为初期的主力。这段时间不长，三级、四级出来以后美杜莎将演变成辅助力量，或者因为速度原因被抛弃。

    梦魇兽（Nightmare）：黑马历来比白马厉害，这里又再证明了一次。Chaos前面两级受了委屈，在第三级里面终于找回了场子。不但数据上不差，而且还会魔法。作为Might和Magic双修的兵种，实力的确不俗。当然，作用上没有灯神那么牛，但是那个叫BT，这个是真的强！多个黑马分组，可以让对方很多回合无法行动，让自己的部队尽情发挥。另一方面，黑马血挺厚，不容易损，硬打巧打都好！地图移动力方面黑马也不是太慢。总之在选择上没有什么特别的劣势。

    火怪（Efreet）：高速部队，且又是一个特技和自身战斗都挺强的兵种。以前灯神和火怪就被设计成对头，如今又成了对立种族。三代的火怪就挺有战斗力，四代里面也丝毫不减。火怪本身不如黑马那么好用，但是火盾和火抵抗有自己独到的好处。火盾的额外攻击按照比例计算，除了火抵抗，连宗师抗魔也不能幸免，纯粹就是以血换血。往人面前一放，真不知道打还是不打。没有医疗等魔法去碰多队火怪是很危险的。火抵抗在以前就是末日的好伙伴，现在虽然不抗末日了，但是仍有不少火属性的攻击和魔法。这里从侧面证明了火属性不是什么好东西，优势没有，还经常被人克制。火怪的另外一个优势是速度快，战场速度和地图行动速度都很快。现在由于英雄的回合单独计算，加上火怪贸然压制并不一定很有效，所以地图移动力更重要一些。

    三级兵种体现了Chaos的强大，无论是肉搏能力，还是特级（魔法）都很强。魔法上没有对立的灯神那么BT，但是在大部分场合，分组的黑马都够用了。另外，在对方不吃魔法的情况下，黑马和火怪有资本直接冲上前线。比起灯神，黑马和火怪前期战斗要轻松，简单。同时，两者的速度都不慢，无论选择谁，行军进度都不会拖很慢。两者相比，黑马的配合要好些，和英雄或者其他兵种搭配都很管用；火怪的作用稍微弱了一些。两个选择，或许在完全不明情况的时候我会选择黑马，英雄很强（或者会快就会培养得很强）的时候我会选择 火怪。

    九头蛇（Hydra）：英雄无敌四里面有不少有时很好用，有时又极其烂的兵种，九头蛇就是其中一种。这种现象其实就说明了它有一个很致命的缺点，被掩盖的时候不觉得，但是一旦对手是人脑而非电脑，就无从躲藏了。一个缺点：慢，导致了九头蛇的脆弱。九头蛇攻击防守都居中庸，杀伤力波动幅度大。如果可以加上喋血，先攻，加上打人不还手，实力非常雄厚，但是所有的前提是敌人足够笨，所以用来打电脑最好不过了。同时电脑的九头蛇集团军也是可与不可求的EXP大餐，相信有不少人曾经毒死大批九头蛇吧。所以说如果有好魔法罩着，九头蛇是很强的兵种，如果没有，一下子就掉价很多。在所有的顶级兵里面，九头蛇算很脆弱的一个了。没有任何防御性的特级（特点），本族魔法还没有解救，实在是很不保险的一个双刃剑。

    黑龙（Black Dragon）：黑龙自从出来就没有弱过，四代里面更是当之无愧的老大。欧洲的神话故事中，龙本来就是凶恶残暴的动物，放在Chaos阵营再合适不过了。免疫所有魔法，加上超强的攻防和血，是最让人头疼的兵种之一。黑龙的缺点不多，主要就是不能加保护性魔法；但是优点大把：地图移动力高，战斗速度快，不容易损失。很适合半裸英雄使用。和九头蛇比，黑龙虽然不能接受魔法，但起码也不受魔法，加上速度快，早期出一个黑龙，就可以出去耀武扬威了。特别是对战的时候，人控制的黑龙，可比电脑控制的牛太多了。Order打黑龙是经常的事，但要是这龙也是人控制的，大概就得多思量5、6遍吧。

    四级兵上面，九头蛇和黑龙各有优点，但是比较起来我还是喜欢黑龙一些。速度是我的一个大的倾向因素，另外，九头除了慢，还得好多 魔法养着，让人心里不踏实。黑龙也许打野兵不如九头爽，但是野兵反正都是菜，总能吃到嘴里，也就无所谓了。

    从整体上来看，Chaos兵种初期很差，高级兵种不弱，所以快速跳到高级就显得很重要。因为不需要大量初级兵，并且有小偷的特级，资金并不是一个大的障碍。Chaos的主力一半是英雄，一半是部队，开始有额外对英雄的投资，但是数额并不大。兵种的特点是力量和魔法方面都比较强。力量方面很好，难得的是魔法方面也不吃亏。和它的对立派系相比，除了整体速度的优势以外，部队的战斗力强很多，但是魔法上面大打折扣。黑龙的魔法免疫有所补偿。开始阶段英雄都不怎么牛，三、四级兵都不很多的时候，甚至可以占优势。

英雄

    Chaos的英雄和Order一样，一个负责战斗，一个负责财务。巫师很适合带兵打仗，小偷初期偷钱财，后期带路跑腿。Chao s的长处在于英雄和部队的杀伤力，巫师几乎可以肯定是战斗主力；小偷开始的作用是快速敛聚财物和侦察，帮助Chaos升级到高级兵种。到了中后期实际隐身作用已经非常有限了，尽量培养侦察和探路很关键，提高的地图移动力无论对单机还是对战都很有帮助。Ch aos的初级兵种战斗力不足，导致了英雄经常需要作为主要攻击点。Chaos魔法不是直接杀伤，就是加强部队的杀伤力，也和这个情况相配合，初期如果没有巫师的杀伤魔法，很难快速扩展。我知道有不少玩家喜欢用盗贼当主力，开始只管偷，一直等到黑龙出来再开始认真培养发展。这样未尝不是一种打法，不过我觉得想要快速发展，每天都不耽误，不浪费，还是需要以巫师为主力。Chaos前期弱，那么用英雄过渡到高级兵种就是变通之法，而Chaos的种族设计也是如此。

    Chaos本身的魔法好像各各都可以见血，但是一个致命的弱点是没有办法保护、医疗自己。所以相邻的Nature和Death魔法就很有裨益。Chaos自己不能凭空学技能，但是买一两个自然或者死亡的法师配合也挺好的。两者的适用范围随具体情况决定，没有办法分个好坏，或许我个人学Nature的可能性大一些。

    魔法英雄：Chaos的初期发展最常见的就是巫师战术了。开始就算很烂，两个巫师应该是能拿出手的。开局两个巫师的攻击性魔法，配合小兵，部分低级野兵还是可以对付的。H/R守路的强兵也是常有的，不过我个人不是很情愿这么做（怕浪费经验呀）。Chaos独特的加经验的建筑可以保证以后的巫师刚招出来就可以使用二级魔法。这里有一个小BUG，经常在城里升级的巫师不被游戏承认，学不了二级魔法。不过没有关系，切换城池或者部队，再回到这个城就可以了。一般个把星期以后，大伙就应该可以使用二级魔法了。Chaos的二级魔法都挺不错，要么可以多个巫师用杀伤魔法打，或者一起混乱，让其他部队出手。巫师群战术开始是很有效的，但是它的最大问题是多英雄分经验值，大家都升不了级！很麻烦的一个解决办法是在战斗的最后，让一些非主力送死。这并不方便，一个是不一定随时都想死就能死，二个尸体虽然没有行动力问题，但是一旦复活了还是很难重新归队。三是操作起来实在费心。我经常的做法是并不刻意让巫师们开始就连连升级，等高级（三）兵种一出，就开始考虑重点培养的英雄。这个时候其实也并不是很需要巫师群，打硬仗的时候能有个人在旁边放个什么魔力闪光就已经很满足了。Chaos的魔法英雄其实是干了最多脏活的魔法英雄，大多数情况下都需要他们亲自上阵，亲手杀人，所以战斗系的技能对他们来说是有很大帮助的。Order的法师不需要很好的战斗技能，但是Chaos的法师如果能有强的战斗系技能，会方便、轻松很多。Chaos系的魔法杀伤性的多，但是直接见血的那些，还是在初期作用突出，到了中后期对付大量的部队就显得戳不着痛处，这个时候发挥作用的其实还是那些辅助性的魔法，依靠强力的部队去取得胜利。Chaos的关键，就是如何发挥部队的最大战斗力。Chaos的魔法每一级都不弱，这点和Order很相似，四、五级魔法非常实在，无论是大幅度提高兵种战斗力，还是突袭对方的关键部队、英雄都很有用，如果地图大小和经验值允许，培养一个专攻Chaos魔法的英雄是很值得的。要是运气好学到了末日风暴，那绝大部分战斗都会很容易。

    盗贼英雄：在最初的几个版本中，盗贼着实风光了一段时间。一个是因为隐身获得的经验值实在太多，二个是墓碑大法。如今的盗贼已经很难当上第一主力了。现在的地图越来越BT，小偷能偷到的东西也越来越少，有不少的地图上，是任何一根木头都偷不着的。但是它的侦察技能和探路技能还是非常好的，完全值得培养。以前英雄三的时候，大家对移动力的研究都挺认真，直走斜走讲究不少，现在玩四的人大概不会去管那么多了吧。实际上，移动力的消耗机制还是和三差不多，电脑选出来的路径也并不保证是最佳的。加上迷雾系统，不用提战略决策，看得远就直接影响到走得快。另一个方面，探路技能的加成非常明显，Chaos的部队本来在大地图上就挺快的，加上探路技能，优势将更加明显。和Order的贵族英雄一样，盗贼英雄在初期带兵打仗没有什么优势，所以不是主力。不过盗贼英雄的培养周期也短， 8个技能点就够，除去刚出来的一个，加上城里经常可以自然升级，其实很快就可以培养出一个带路人。特别是在BT地图中，一个好的带路人可以极大提高你的成绩。

    总的来说，Chaos的英雄和Order的类似，一个主战，一个主后勤。巫师群战术是主要的手段之一，用英雄过渡到高级兵种很常见，但是应该注意的是在合适的时候开始重点培养主力。在技能方面，战斗系的技能应该得到重视。盗贼英雄实际上主要起侦察和带路的作用。

魔法

    一级魔法

    魔箭（Magic Arrow）：一级里面杀伤最强的魔法，Choas巫师成长的本钱之一。其他的没有什么好多说的，这个魔法部分弥补了初级兵种的脆弱，一两个 英雄，带上些烂兵，靠这个魔法还是可以对付部分野兵或者生物巢穴的。

    火花（Sparks）：英雄走到面前施法，比较独特。这个魔法我实在用得太少，记忆中就那么几次。好像挺讲究时机，敌人得凑得很近（因为开始的英雄无论如何也走不了多远），还要扎堆，而且数量还得不多不少，多了还不如趁早逃跑，少了也不需要这个魔法。但是一级魔法好歹这么一个范 围魔法，也不要奢望了。

    嗜血（Bloodlust）：使部队的近战杀伤力提高25%，如同tyfon所说，嗜血和祝福是有差别的，Chaos兵种普遍伤害波动大，一般祝福比嗜血好些。即使如此，嗜血仍然是一个很有用的魔法，不光是加在兵种上面，还包括加在英雄身上的效果。在整个游戏的各个阶段里面，前期这个魔法不是经常用，因为巫师魔法有限，很多时候宁愿去直接杀伤。到了中后期，部队强大，英雄强壮，嗜血就开始常见起来。我是挺喜欢这个魔法的，一般到了后来英雄一天能回复不少魔法值，多这点魔法无关痛痒，但是战斗起来觉得轻松。

    火焰结界（Fire Aura）：一个小火盾，可惜不是按照比例计算的。从效果上来看，和反馈什么的挺像。一级魔法就出这个，可见确实以杀伤力见长，比Life 要强。这个魔法我是经常用的，开始就那么点兵，那么少的血，一下能多打死一个算一个。后期为了图个爽，有什么都加上的时候，自然 也不会忘了这个小火盾。

    疾速（Haste）：同时加出手速度和移动距离，听起来是个好魔法，可是我就是觉得并不很常用，至少比三代里面差多了。英雄四里面战场大了不少，几乎就没有一个可以覆盖整个战场的兵种。减速魔法一下子除以二，比这个效果好多了。另外减速是为了能尽量不见面，但是加速除了放毒跑以外，就只有说是冲上去肉搏，或者挡视线了。这两种用法都给人蛮干的感觉，不爽。

    杀戮（Slayer）：又是一个好魔法，特别是到了后期。前期几乎肯定是用不上的，但是打到后面经常能碰见不少四级生物，50%的额外伤害是很高的增长幅度，效果很明显，这个魔法对电脑特别管用，因为电脑AI的问题，敌方主力部队经常要死缠着和它最近的部队打，加一个杀戮，可以很快消耗掉敌方高级兵种（绝大部分情况下也是主力）。凡尔登绞肉机，那是古今中外的通用经验。

    一级魔法以直接杀伤为主，比较便利于英雄直接参战，算是比较符合Chaos的特点了。和Order相比，这些魔法适应用范围比较 窄。而且特点比较单一。

    二级魔法

    火矢（Fire Bolt）：加强版魔箭。不过因为是火魔法，所以有一些限制条件。总的来说是挺常用的魔法之一。巫师群战术里面，经常使用的就是这个魔法了。因为巫师出来就自然升一级，很容易拿来一个巫师就可以放火矢。加上魔力闪光，一点魔法一个火矢，很经济。在杀伤力方面也还不错 。终规中矩的一个魔法。

    法术枷锁（Spell Shackle）：在我看来不是很常用的魔法，对大群的魔法单位是没有什么作用的，而单个的，经常又不是直接的杀伤主力，如果和人打，即使没有驱 散类魔法，也愿意放魔法吧。不知道有没有电脑AI上面的弱点，比如有了法术枷锁就不用魔法的情况，遇见过的请告知。

    混乱（Confusion）：和和平歌是一个东西，虽然要被反弹，不过我反正已经行动过了，你反弹我也不在乎。反正我经常用仙女龙对仙女龙使用混乱，没有什么顾及的。这个魔法对部队和英雄都很适合，单个分队的仙女龙（说不定你能搞到手哦），或者一群巫师，混乱敌方主力部队不是困难的事情，配合魔力闪光，控制20－30回合没有问题，再好不过了。

    抢先攻击（First Strike）：比较好的一个魔法。无论是早期需要节约每一滴血，还是后期对强力肉搏部队的加强，抢先攻击都是很好的技能。要是能配合丑陋、吓 人的一些东西，经常可以无损地蹂躏很多比自己强大得多的弱智电脑AI部队。

    魔力闪光（Mana Flare）：经常是我选择Chaos的最主要原因，甚至是唯一原因。对于很多派系的很多非常有用的魔法来说，减少2点是极其可观的，比如你的一对灯神，和平歌可以多唱2倍的时间；比如你是个牧师，你可以有三倍的医疗能力......太强的魔法。我太喜欢了。如果我使用其他派系，就几个杀伤魔法根本不值得我的技能点，但是有了魔力闪光就完全不同了，简直就是随身携带魔力源泉！和人对战的时候小心使用，至于野兵么？给它一万魔法，它又能怎么样？

    厄运（Misfortune）：加了整整一半的伤害，实在是很夸张的。

    Chaos的二级魔法非常实用。这里看出来，我们谈了这么多魔法派系，大家的低级魔法都是很有用的。Chaos各种二级魔法都能对它的初期发展起很大作用。很多巫师是出来就能升一级，所以这些魔法可以立即使用，效果就更好了。混乱和魔力闪光尤其适合以弱胜强，而后者更是异族的至爱。

    三级魔法

    火环（Fire Ring）：杀伤无论敌我，中心的部队不受伤害。这有点象冰环。我相信也的确是这么模仿着设计出来的。我很少用这个魔法，因为我被围攻的概 率很小。

    火球（Fireball）：就是三代的火球。没有什么好说的，杀伤力一般，范围还可以。

    群体嗜血（Blood Fenzy）：我觉得意译成群体嗜血比血暴要更上口一些。作为一个三级魔法，让所有部队战斗力同时提高，和群体精确，群体祝福等对应，符合3 DO的一贯设计。中规中举。

    闪电（Lightning）：算是一个强力的杀伤魔法了，这也是我一般情况下可以接受的最强的单体杀伤了，要让我用爆裂？我大半宁愿用其他的魔法。这个魔法 找到了一个魔法值，学习难度和使用效果的最佳平衡点。

    魔镜（Magic Mirror）：反射伤害，且使施法者获得同样的受诅咒状态。需要注意的是，催眠、和平之歌驱除不反弹，另外死人也不反弹任何魔法。我个人极少用这个魔法，感觉作为一个特技给兵种，比如仙女龙倒挺好，挺高兴，让我自己用，就感觉太浪费回合和魔法。我曾经打斜眼的时候用过，但是仍然感觉不是很爽。

    群体杀戮（Mass Slayer）：和群体嗜血一样。

    三级魔法中单体、群体魔法都有，我喜欢闪电和群体状态魔法，那些群体杀伤魔法似乎用处不大。另外电脑永远用分散阵型出战，也是一 个不利因素。比较起来，群体状态魔法都很管用，比Life的一堆Ward好多了。

    四级魔法

    爆裂（Implosion）：强攻击魔法，位居四级不算过分。从前三代的最强单体攻击魔法，现在被人压了一头，一定是很不爽的，不过和碎裂比，爆裂没有特别 的效果，也只好服输。

    地狱火（Inferno）：和三代差不多，威力不很强的群体杀伤魔法。

    群体抢先攻击（Mass First Strike）：使本方所有部队获得“抢先攻击”状态，这个魔法比群体杀戮和群体嗜血在后期作用大一些，尤其在强杀伤力部队身上，比它们高一级 ，应该不过分。

    灵猫反射（Cat Reflexes）：我很喜欢的一个魔法，加在强力部队身上，多打一下的效果是惊人的，加上反击回合的利用，连打6下没有反击是可行的。另外，要是 你有一大票美杜沙，连连石化的效果也很好。总之太爽了，每每贪心地想，怎么就没有群体灵猫呢？我愿意用连闪来换。

    混乱云（Cloud of Confusion）：群体混乱，实在是个强魔法，唯一缺点是范围小了一些，不过有时候可以勾引敌方围攻，然后一个群体和平歌，真的是歌声震天响，人 人傻愣愣。

    群体厄运（Mass Misfortune）：好魔法呀，对于Chaos的强攻击阵容真是如虎添翼。每个人都要多挨一半的打，太痛了。 　　四级魔法里面好魔法依然不少，灵猫反射尤其适合裸奔的英雄们，或者强大的肉搏部队。所有的群体状态魔法都非常有效，混乱云和群体 厄运是对敌方的沉重打击，学到哪一个都应该高兴！到这里，Chaos魔法的状态效果又一次超过了杀伤魔法。

    五级魔法

    末日审判（Armageddon）：攻击对象不包括施法者本人在内，是一个大大的优势，学了就放，没有过多的顾忌，实在很爽。不消耗魔法值应该是一个彩蛋。怎么说 Chaos的魔法也实在太单调，偏弱了一些。在五级上给点甜头也是应该的。而且如果是BUG，这么大一个BUG，无比明显都历经 6次更新而不改，肯定是有悖常理的。再者英雄无敌系列里面：Armageddon一直都有特殊的地位，那么不消耗魔法也算一个吧。有了这个魔法的时候，英雄怎么都很牛了吧，敌人真的围上来之前放2、3个应该没有问题。城堡建设更应该早就成型了，带些黑龙什么的，一通Armageddon，试过了才知道爽！

    连环闪电（Chain Lightning）：伤害传递的方式不变。怎么看也觉得比起以前作用减弱了。出现很晚是一个问题。另外杀伤力也不怎么样。衰减那么大，加上巨耗魔法 ，很度情况下被末日给比下去。杀伤是强的，但是五级里面我最不喜欢他了。

    碎裂（Disintegrate）：不能复活是它最大的特点。杀伤力最强没话说，Chaos系的顶级单体杀伤魔法，再不是最大杀伤力就实在说不过去了。不能复活才是它真正的卖点。特别是和Life对阵的时候，碎裂掉一个关键部队，再有什么都只好去哭了。一击致命，才是它的强项。所以有的时候，需要合力击倒一个关键部队的时候，注意顺序。

    Chaos的五级魔法是强悍的，群杀或者单杀都非常厉害。末日用来平时行军打仗，不耗魔法，还操作简便。碎裂是最好的突击手段，对付敌人的关键部队最有效不过。我个人不喜欢连环闪电，它的作用比三代差了不少。

    整体而言，Chaos的魔法大部分都是直接杀伤别人的，控制类魔法很少，抵御、保护类魔法更是没有。 我长久以来一直不解人类社会的奥秘，为什么完全不同且隔绝的社会最后发展出来有无数吻合。无论中外，邪恶一方总是力量强悍，但最终被正义方发现一个罩门，最终击破。Chaos缺少抵御和保护、恢复魔法是它最大的弱点，恰恰它的兵种也是肉搏居多，失去了保护，就很容易被控制，守损失；这就成了Chaos最大的弱点。Chaos的魔法每一级都设置得不错，能力梯度很合适。抛开片面性不看，单体和群体的分布合适，低级魔法中诅咒类一直适用。优点和缺点同样明显，大概是对Chaos魔法的最好概括。另外，Chaos魔法中大量的状态魔法，效果要好于直接杀伤魔法。英雄无敌中的战争，兵种的杀伤力本来就常常占主要部分，加上状态魔法没有回合限制，使状态魔法优于杀伤魔法，成为不争的事实。

技巧

    Chaos的整体打法上，巫师群是使用最多的，且一般情况下都有效。盗贼英雄作为主力有先天的劣势，经常是到了中期被招出来当跑腿的，练成飞毛腿以后再随军。Chaos的一些高级兵种是非常有战斗力的，一个小偷，带上几个高级兵，运兵过程中东摸西摸，打点野味，升级也挺快的。一个队伍里面加一个小偷，跑得快，看得远，起码就比别人掌握的情报多，机动性好，这是很大的优势。Chao s的兵种速度本身很快，这是它的优势。开局小偷可以很容易探开一大片地图，也许可以偷到一些资源。这使得快速建设到高级兵成为可能。

    Chaos的开局应该注意的是尽快升级到高级兵种，在一级和二级徘徊效率很低。具体如何培养你的巫师可以看个人喜好，但是前期尽量多招两个有益无害。到了高级以后，黑马配巫师，加上杀伤兵种是一个组合，或者多个巫师配杀伤兵种，甚至极端些，全部巫师都可以。我个人喜欢第一个选择，因为可以有重点的培养一个英雄。高级英雄非常之酷，不但一路消灭野兵极其简便，而且和强大的敌方部队交火的时候可以有一个强力的支撑点。 　　Chaos的部队，特别是高级部队，战斗力强且速度快，英雄没有必要裸奔。一般情况是英雄部队一起杀，杀红了眼为止。Chaos的英雄其实是一个很适合和其他种族配合的英雄 ，相邻派系的Death和Nature英雄都可以和Chaos的很好合作。特别是Chaos没有保护魔法，加一个Nature的英雄经常可以帮大忙（当然，要是你的主力可以学Nature那自然更好）。我曾经打过用Nature做主力，Chaos巫师群辅助的打法，效果不错。需要注意的是，保持兵力的强盛，主力身上能多带兵就多带（不拖累速度的前提下）。Chaos经常是以硬拼取胜的。 　　Chaos的建筑中，有特色的是战斗学院、魔力漩涡、小偷训练场。其中战斗学院应该尽早修起来，如果你需要好几个有用的巫师的话。1000点的经验是很小的数目，但是恰好能让你的新招募的英雄立即升到二级，刚好学会二级Chaos魔法。巫师群里面，大伙一起使用的魔法，大部分也就是那些二级了。所以这个建筑非常重要。魔力漩涡和小偷训练场都是挺好的东西，前者让巫师（群）的连续作战能力极大增强，后者也对经常挺身出阵的英雄们有所帮助。或许应该说先出哪个看具体情况，不过我个人是比较偏向魔力漩涡的。


初学浅谈（五）：英雄无敌四种族之Nature篇
作者：Fenrir

    前面说的4个派系分别直接对立，感觉Nature从特性上来说和其他种族界限并不明显，但是为了对立和相邻的和谐问题，还是给它安排了两个对立派系Order和Death，两个相邻派系：Life和Chaos。从派系上说，Nature是自由的，有生机的，所以和Life和Chaos临近，而和严格的Order，以及无生机的Death对立。

兵种

    妖精（Sprite）：最大的特点，也是最大的优点：快。地图速度是我最看重的指标之一。除了可以很快开一大片地图以外，抢夺财宝的速度也是惊人的。一般来说，妖精的敛财速度比盗贼快。打人不反击在发展的初期可以起到一定的作用，配合白老虎和狗，H/R初级野兵也是很有效的。妖精的跑路快，使它成为英雄四里面最受欢迎的兵种之一：一个是刚才说的敛财，一个是极大提高英雄的移动力。如何提高移动力，如何利用高的移动力，这些都是打英雄的技巧之一。

    狼（Wolf）：主动攻击时连击两下的特技在开局是很好用的，虽然是肉搏兵种，但是经常在初期被当作主力使用。配合骗反击的战术，狼的杀伤力还是很不错的。一口不行啃两口，往往敌人被连咬四口都没有办法还手，这是非常痛苦的。狼的使用关键是临场指挥，骗反击、使用时机和往上冲的时机都很重要。虽然妖精不能起到骗反击的作用，但是我们可以利用单独分组的狼，或者英雄召唤出来的其他低级生物。

    Nature的初级兵种是很强的。说它们强并不是说打起仗来多么势不可挡，而是说对整个发展的帮助很大。一个妖精到处拣资源，速度极其BT，另外大部队的妖精和狼配合，如果再有英雄的魔法（特别是初级召唤魔法）前期打矿并不非常困难。小队妖精往前冲，压制远程，英雄召唤炮灰，狼往前冲，大队妖精H/R解决小股部队解决反击问题，很出色的配合打法。流沙配合妖精H/R也是一个办法，但是问题是太消耗时间，并不推荐。前期的发展讲究量力而行，一般对战地图打些最关键的矿还是够的。虽然在某些BT地图上Natu re并不出色，但是绝大多数情况并不是兵种的错，而是其魔法不适合BT的定义。在大多数地图上，Nature的初级兵种同时保证了打矿和拣资源，速度快，探地图很方便，英雄活动能力也大为增加。

    精灵（Elf）：连射两箭，并带抢先射击属性，非常强的二级兵种。精灵的箭本来就多，如果和流沙等魔法配合威力很大，但是唯一的缺点是前提建筑条件比较苛刻。加上二级兵种本来就不容易被拿出来当主力囤积，使得真正打起来，出精灵的机会反倒不大。地图上有招精灵的生物驻地当然好，可惜我很少拿它到处征战。非得它的场合不多，就算如此，也经常是打完就分手，因为它的地图移动速度毕竟慢了点。

    白虎（White Tiger）：抢先攻击。产量导致其经常没法存集，所以抢先攻击也没有多少贡献，不过因为很容易造，上镜率其实不低。如果地图生物不少，白虎和狼配合一起打仗也挺常见。论数据来说，白虎是挺牛的兵种，而且速度快，在野外碰见了也经常觉得讨厌，但是自己要囤积似乎太费时间了。还是别在老虎旁边留恋了，早点往高级兵种挺进吧。

    两种二级兵各有好处，比较起来精灵的损失比较少，但是相对的建筑比较困难，而且速度也偏慢。由于精灵的强杀伤力，有时候有1－2 周的精灵可以帮助正在苦苦升级的英雄打一两个大仗，作用还是很突出的。白虎一个是扑上去的速度快，而是Nature打仗很好找炮灰，所有也挺有用。我个人是很少堆二级兵做主力的，所以经常情况下是速度第一，选白虎，以迅速上高级兵种为目标。单纯靠低级兵种是没有办法发展的。部队靠数量取胜太贻误战机，同时英雄也需要强大的部队做后盾才能升级，所以发展几乎总是第一优先的。另外如果你是用的白虎，就得提醒你一下，不要太在乎伤亡了。不少朋友喜欢追求尽量少伤亡，甚至零伤亡，所以经常会感觉Nature，以及下次会说到的Might特别难打。这种靠低级兵肉搏来求发展的种族，如何作战，如何保持合理的消耗是很重要的一个话题。一般来说，2－3周的初级兵力能够保证战斗到占领关键矿（比如金矿、Order的宝石，Nature的木头），清扫周围大部分野兵就可以了。过分追求少伤亡一个是太耗时间，二是不利于培养实力对比的判断力，进而影响对战的能力。太不主意部队的死活则是容易没有兵力保证持续发展。开始有初始兵力和城堡的普通地图，冠军难度下2－3周出关键兵种，英雄到10级左右是比较合适的速度，如果距离这个目标相差太远，说不定就有需要改进的地方。需要记住的一个战略方针是：大多数情况下都是以高级兵力和英雄取胜的，所以初级兵的使命就是初期发展和后期炮灰。主力部队没有损失（或者说大损失）就可以叫无损失战斗。

    独角兽（Unicorn）：攻击时一定几率让敌人失明三回合的特技挺好的。骗过反击以后多个独角兽上去一人戳一下（注意适可而止）效果一般都还不错。我很少用独角兽来当主力兵种，主要是开始的时候造出来用几次，一般都是打矿或者宝物什么的。独角兽作为肉搏兵种，攻防指数比较低，失明的概率不大，所以并不是很好用。和其他种族的三级兵比起来，独角兽的领军作用大为逊色。当然，虽然它不是什么好货，但是毕竟便宜。过渡一下的时候，还是经常就将就了。

    狮鹫（Griffin）：多了会一个比较强的兵种，无论是从地图移动还是战斗表现来看都不错。无限反击的特技加上蛇击非常好用。夸张的想想，如果有个先攻再有个恐惧......但是这所有的前提都是要求数量，数量的前提是建筑，建筑的前提是加修城墙！这样的条件实在是苛刻了。对我个人来说，少量的狮鹫没有办法起大作用，但是与其花大价钱造狮鹫，然后等半天，不如开始就用独角兽，等的几天，加上价钱的差别，已经差不多都可以出四级了。狮鹫的地图移动力是非常强的，扔一队到敌人部队中，压制远程兵也是很爽的，如果我真的富得流油，一定 会选狮鹫的。

    还是英雄系列的一贯特点，不容易造的兵种实力强，容易造的也容易死。如何抉择取决于你的战术。想要迅速出四级兵种推掉对方，就不要还恋恋不舍什么无限反击。如果一时半会儿还见不了面，资源差得也不太多，就不要心疼钱。从部队的整体实力来说，Nature出了三级仍然没有一个质的飞跃，这是一个大的弱点。无论是从肉搏还是魔法，还是特级来说，Nature的三级部队不能使兵力有实质上的突破。也因为如此，NWC设计了生物门作为补充。另外，四级兵出得快，也算是一个弥补了。

    仙女龙（Faerie Dragon）：施法部队，并自带魔镜。这是一个单机很好用的兵种。巫师群战术在这里可以演变成仙女群战术。它的地图移动速度也很快，英雄需要裸奔的时候带几个仙女作陪再好不过了。仙女龙在队伍中的作用很强，少量的仙女龙分队可以很好地控制对方主力部队，数量多了以后，除了单独分组以外，还可以有一队集中火力攻击。一般魔法部队都可以使用8次主要攻击魔法（比如灯神的冰箭，仙女龙的闪电），总共杀伤自身的240%。所以如果能让仙女龙完全发挥，实力也是很强的。它的弱点是如果快速接火的话，1－2个仙女龙作用不是很突出，二是自身数量少的时候，无法兼顾控制和杀伤，导致战斗力不强，需要其他强力部队配合。而众所周知的是，Nature恰好低级部队杀伤力不强。仙女龙自己的魔镜也是一个挺好的东西，没有特别的把握，一般英雄、部队还真不敢对它轻易下手。仙女的肉搏杀伤比较差，体力也不好，抗魔和肉搏（包括远程）能够有效地对付敌对的仙女龙。

    凤凰（Phoenix）：飞行部队，一次攻击两个部队，最牛的两个地方是快和重生。凤凰自来就是出手最快的部队，英雄四里面英雄行动力根据最高部队行动力计算以后，凤凰的作用又多了一个：带路。现在英雄四的英雄和部队有各自单独的出手时间，快速部队的重要性不如3代。凤凰作为最快的部队，扑得快，飞得远，而且杀伤力强，是很好的压制部队。虽然说加上蛇击会很好，但是并不是每次都能等的。凤凰虽然不是那么皮粗肉厚，但是和仙女龙比起来，也算是“强力”肉搏部队了。重生对电脑玩家是最好的东东了，在电脑身上，野凤凰可以因为重生而发呆任人宰割，可以节省不少魔法；在自己身上，凤凰的100%重生可以增加不少战斗力，特别是初期四级兵少的情况下。单个的几组凤凰，在认真选择攻击点的情况下，复活加上直线打击，攻击力是非常强的。使用凤凰的要点是合理选择每一次的攻击点和分组的方法。攻击点的选择可以保证尽量少的误伤和被骗，在这一点上，电脑的黑龙挺不错，不熟悉的朋友可以去学习学习。

    仙女龙和凤凰终于使Nature的兵种实际上了台阶。可以说，四级兵种出来以后，Nature才和其他种族在发展上平起平坐。开始的Nature虽然在经济上不会吃亏，但是从兵种作战能力上看是相对弱的。有了四级兵以后（因为四级兵出得很快）才扳回了局面。Nature的发展讲究的是个“快”字，快速的一个代价就是没有多少囤积兵力的时间，如果四级兵选择仙女龙，如果3－4周之内可以见面的话，一个尴尬的局面就是没有主战兵种。二三级兵种不会囤积很多，四级兵种又是仙女龙，一两个仙女龙怎么用呢？是混乱还是闪电就比较难受了。如果是凤凰的话，四级兵自身可以作为主力部队，既可以起主要的杀伤作用，也可以牵制敌人，保护英雄。Nat ure的很多战斗力在英雄身上，多两个回合召唤是非常宝贵的。实际选择中，如果你不是图快攻，地图又有足够的发展时间，那么仙女龙比较好些，一个利于培养英雄，二个上了数量以后和英雄的配合也非常好。如果是中小地图很快可以见面的话，我还是建议选凤凰。少量的凤凰作用优于仙女龙。而且建筑条件比较简单，容易快攻。

    总体看来，Nature的兵种相对比较弱一点，初期与其说打江山，不如说是攒江山。单从兵种上来说，一级兵不算很差，二、三级就不太好了。四级出得快，有速度优势，如果拖得时间长，仙女龙就成为强兵种。如果有足够的时间招募生物门的兵种，Nature的实力也不弱。从整个来说，Nature不算是英雄四里面的强族，初期虽然比较快，但是不算是大的优势，中期大家都有四级，英雄又恰恰不很牛的时候处于劣势。

    另外比较特别的是Nature有一个特殊生物门，里面召唤出来的各种元素是非常有用的。生物门相当于让Nature可以同时拥有比其他种族多的各级兵种，相应的就多了很多打法和配合的方式。一些兵种的价值在于魔法，比如水元素、半羊人、丛林妖精等；因为有了它们，有些敌我寡众悬殊的战斗也可以取得胜利，这对于发展是非常关键的。有些兵种的价值在于普通战斗中，比如风元素、火元素、毒蜂草和螳螂等。风元素地图速度很令人满意，出了生物门以风元素为主，困难的地方带上水元素（最好是先让水元素走到那里等着）是经常的打法。当然，如果你有招水魔法，经常就不需要真正招水元素了。毕竟花钱不说，速度也是个问题。毒蜂草是非常慢的生物，并不适合四处征战；但是螳螂却是最好的战斗机器之一。不但攻防很出色，而且特技尤其好，定身是非常好的保护英雄，控制敌人关键部队的法宝；召唤螳螂也是最好的五级魔法之一（特别对裸奔英雄）。总的来说，生物门的部队对Nature来说是及其关键的。其中的低等部队有几个用来放魔法就够了；中间的个个元素是中坚力量之一，它们都是元素，对于对方的魔法来说有一定的优势，自己本身的战斗能力也不错，加上好的特技，在狮鹫和独角兽都不成器的Nature，它们经常可以进入主力阵容。从经验值来看，它们都处于2级半的位置，Nature也因此成为少数以低级部队为主的种族之一。生物门的高级部队螳螂当然强悍，可惜数量上是在难以保证威力。在家憋螳螂是在是很考验耐心的，很容易把人憋屈坏了；倒不如一边战斗一般等螳螂加入。另外还需要提一句的是，对单机地图，特别是可以培养裸奔英雄的地图来说，有龙力保护的螳螂是BT的。

英雄

    Nature的英雄一个是魔法型的，一个是肉搏型的（名字虽然挺好听，实际还是野蛮人）。肉搏的英雄专长箭术，大家都喜欢快速地尽量提高其箭术技能。这在前期是比较有利的，得鲁依作为魔法英雄，铁定应该是后期的主力英雄。一个好得鲁依的召唤可以在战斗中为自己增加周产量甚至更多的部队。另外它的其他辅助魔法也非常有用。这样看来一个负责前期，一个负责后期，分工明确。可是实际上我并不喜欢以弓箭英雄为重心。一般来说，Nature的主要英雄应该是魔法英雄。单独从兵力上来看，Nature经常处于劣势地位，一个高级魔法英雄，不但可以提供优秀的状态魔法，比如流沙，蜂群等等；更必然能召唤生物参战。一个10级左右的英雄，单独一次召唤，比如是招元素，至少可以招大半周的兵力，如果英雄活得长一些，那战场上增加的兵力将非常可观。一般大家打单机地图，特别是自编的地图，野外生物很多的时候还看不出来，打普通的正常地图，或者和人对战，这多出来的兵力优势将是压倒性的。箭术英雄在开始是个诱惑，很容易抢了风头。实际上至少应该在初期让两个英雄同时升级，有一定兵力基础的时候我愿意多培养魔法英雄。箭术英雄在初期可以担当很大一部分攻击任务，同时也可以在必要的时候充当炮灰。总之我认为箭术英雄是为了弥补Nature初期薄弱的兵力，而魔法英雄则在通常情况下应该是主力人选。

    魔法英雄：Nature的主力英雄。Nature的部队强烈需要好的状态魔法，流沙、蜂群都是大家经常可以想得到的。蜂群还有一个好处，不受精神头盔的影响。Nature魔法里面召唤内容及其多，几乎不会有魔法英雄不能召唤的。在初期，召唤出来的生物可以释放魔法，充当炮灰等等。高级英雄召唤出来的高级兵种更加重要。召唤出来的生物是有满魔法，并且不能被直接驱散。一般一个Nature的魔法英雄总是等级越高越好，在Nature魔法中，能召唤高级的兵种总是好的。同时，专一也是经常重要的，Nature的魔法英雄一般都需要本派系魔法和战斗技能，我个人喜欢学习了三级Nature以后再考虑相邻派系的魔法技能。宗师肉搏可以让得鲁依多存活好几个回合，其他的也许抗魔有一个就可以了。魔法师没有必要象Chaos那样成群结队，魔法的配合也没有Order那么讲究，主要需要注意的地方还在于英雄和兵种的操作，这点和Might挺象。Nature的五级魔法是非常厉害的，如果地图允许，往上冲5 级也未尝不可。另外，我个人在所有第四技能里面，最不讨厌的就是Nature的召唤技能了。一个技能点就可以让你不愁带路的妖精，到处拣垃圾的炮灰，非常方便的一个技能。把位置堵满，根本不召唤，经验值会蓄起来什么时候回城了，就放一个想要的生物（例如妖精），那么蓄起来的经验都会变成妖精。高级的召唤技能甚至可以比贵族还好。如果地图允许，一个魔法英雄能顶两个用，就是由此产生的部队调度问题挺麻烦的，很费时间。我不知道有没有人是专攻召唤技能的，如果可行，快速组建一只部队不说，还不花一分钱，有空我也想试验一下。这个打法听起来比较象英雄三里面的外交战术，不过这里形成的部队免费且不混编，当然，实力增长没有那么快，但是在外交实际没有什么用的英雄四里面，这样的增兵速度已经很令人满意了。单机地图，特别是敌方兵力非常多的那种地图里面，Nature的兵力是很微不足道的，除了仙女龙，其他也没有什么可以起关键作用的兵种。但是普通地图，对战的时候，兵力的多少是非常关键的，Nature的魔法英雄，在这方面的作用尤其突出。混乱的巫师英雄对Nature的帮助很大，如果可能，招一个稍微一点经验，说不定就可以放混乱或者魔力闪光，及其划算的。

    箭术英雄：他们可以在游戏初期配合部队和魔法英雄开拓疆土。我怎么看射手都是和野蛮人一路的，作用也就是开始当一个好的远程攻击点。使用射手的问题在于判断什么时候能发挥作用，什么时候开始，如果继续培养将得不偿失。Nature初期是没有远程部队的，这个时候射手是个很关键的英雄，开始的扩张中能够起很大作用。他们既可以充当主力攻击手，在敌人逼近需要阻挡和骗反击的时候也能够挺身而出。我一般喜欢让射手在前面顶着，得鲁依在后面施法。在得鲁依的帮助下，射手应该可以支持一段时间，争取一定的进攻机会，也起码阻挡了敌人的前进步伐。另外我私下还有比较阴险的想法，我其实比较希望射手能够在无关大局的时候光荣倒下，一来是因为得鲁依强烈需要经验值，二来因为有小妖精，而且墓碑不消耗体力，所以战斗死了也没有什么了不起的。这点最体现了射手的价值：在战斗中杀伤，骗反击并阻挡，然后在大局已定的情况下光荣的让出经验值，然后复活也不花国家一分钱，末了还能以充沛的体力冲向下一个战斗地点。话说回来，上面说的都是比较理想的情况，具体如何还需要看具体的环境的操作。另外，我说射手作用局限于初期，仅仅是说在普通地图的情况下。因为这样一来单纯的箭术起不了多大的作用，跟一支部队比起来，除了不花钱以外，整体作用不足，还影响主力的发展。但是如果你周围有不少水晶？如果你有好的宝物？如果敌人很近前期可以H/R？说不定射手就成了主力。

    总的来看，Nature的英雄中得鲁依是主力，但是开始需要射手的帮助。Nature的副英雄在开始帮助主英雄，实际战斗中经常会是副英雄为主。后来才退下来的。其他大部分种族却是 开始就练主力，等到主力差不多了才开始培养培养副英雄的。

魔法

一级魔法

    寻路（Pathfinding）：使部队在任何地形上移动时都不会受到额外的损耗，也就是说，走到哪里，最多消耗1倍行动力。我非常喜欢的一个魔法。只要每天行动以前不要忘了施法，相当于专家探路！凭空多出5个技能点！实在是再好不过的魔法了。需要注意的是，魔法的效果是作用在每队生物上面的，如果你中途又加入了新的队伍，则新的队伍的行动能力可能会对整个部队产生影响，而被分出去的部队仍然具有寻路效果。这个魔法和Nature的妖精可以说是最佳搭配，把Nature的快速特点发挥得淋漓至尽。现在英雄每天回复的魔法值比三代多了很多很多，而且相应的魔法消耗值也小了不少，每天放一次到几次寻路，小菜一碟！按照我在深圳工作的时候学到的话说，“洒洒水啦！”。

    加速（Speed）：使部队速度和战场移动力+3。Nature的兵很多都很脆弱，要想战场上少损失，跑得快是很必要的。出手速度和移动距离在Nat ure同样重要。Speed更多是为了防守的目的，寄望在防守中消耗敌人。不知道有没有人喜欢War3。Undead退十步回头点一个的打法和这个类似。无论是骗反击还是H/R，速度的优势是必要的。

    护体石肤（Stoneskin）：使单个部队近战和远程防御力提高25%。前期靠狼和白虎发展的话，这个魔法还是很重要的。前期的战斗，尽量减少损失是极其关键的，25%的防御力，经常可以减少大半的损失。另外这个魔法还可以和其他的保护性魔法配合，即使效果差不多，但是换个名字还能再冒充一次，这也是它的优势之一。

    地形认知（Terrain Walk）：战斗中使用的寻路魔法魔法，忽略战场上的流沙。和加速是哼哈二将。因为战场中不再象三代一样只算格子，所以地形认知能够对战场上的行动能力有很大帮助。加上忽略流沙，很容易就造成打不还手，无损失战斗。这里比较棘手的问题是不容易找到连续放这么两个魔法的时间。也许有多个英雄或者打慢兵比较好。另外如果开局依靠这种打法，耐心是第一重要的。

    一级魔法个个都好用，我最喜欢的是寻路和护体石肤。我有点速度至上的倾向，不过事实上往往地图的速度影响发展的速度，而发展的速度决定最终的实力。注意我说的是影响，不是决定。这导致了在不同情况下不同的心理。发展的初期，我很希望有加速、地形认知等魔法的帮助，可以把损失减少到最小。因为如果一两仗就能把兵消耗光的话，地图上再快也只能远观，还不如一步一步的亵玩的实在。但是如果我的部队已经强大了，英雄已经向BT靠拢了，则开始迫切盼望这么一个初级魔法，因为平常战斗伤亡不作考虑，行动力成了最关键的问题。安了内，攘外就提上了议事日程。护体石肤是刚开始的肉搏阶段的重要帮助。至于加速和地形认知，当然也很好，特别是配合起来使用；但是我并不指望经常有这样的运气，而且我更愿意把空位留给召唤魔法。Nature魔法的支柱就是召唤，每一级的召唤都非常 重要，一级也不例外。

    二级魔法

    巨人力量（Giant Strength）：使单个部队生命值和杀伤力提高25%。经常使用的魔法，无论是增加防御还是加大打击力度，都挺合适。开始发展的时候给各个炮灰加，后来给英雄，给主力部队加，都挺实用，可以说是一个普适魔法。选择对象的时候注意一下有杀伤力的加成。这个魔法和Life的魔法适可以叠加的，效果很好。

    幸运（Fortune）：将单个部队幸运提升到最高（+10）。也就是说，防御提高二分之一。这里多说两句关于幸运的问题。一个部队的幸运是根据当前回合的幸运值，每次受攻击的时候独立计算的。也就是说，本回合中被A攻击的时候幸运了，并不代表本回合被B攻击的时候还能幸运。幸运魔法可以使某部队总是受2/3的伤害，也就是变相地增强防御了。有一点需要注意的是，如果你能招丛林妖精，又能幸运，你选择哪个呢？我认为大多数情况下是应该选择召唤的。起码来说，魔法消耗少一点，除非刚出来就被干掉，招出来的丛林妖精一样可以幸运某个部队；如果有魔力闪光或者其他因素，说不定可以释放多次魔法；没有魔法以后还可以作肉盾上去阻挡，或者骗反击。这也是我喜欢一级里面能出几个召唤魔法的原因。

    流沙（Quicksand）：这算是破坏平衡的一个魔法了。一个二级魔法，可以让地面部队完全失去作用，不能不说是太强了。虽然三代的泥潭太弱了些，单这个加强版又太强了些。也许设计的时候只是想着让敌方多绕几步路；但是低级的AI，加上那么少的魔法消耗，满地流沙成了经常现象。这还导致另外一个问题，死机。我几乎可以肯定，NWC的测试人员是没有放出过满地流沙的，这从另一个侧面证明了开发者的水平和使用者的确差之千里。流沙的基本用法包括流沙加远程，流沙加飞兵，流沙加不反击，流沙加地形认知，以及流沙加恐惧，流沙加长兵器。另外提醒一下，所有站在流沙上的部队，攻击力下降25%，防御力下降20%，效果与护城河一致。如果经常使用这个魔法，建议还是升级到WOW，有了轨迹显示以后，的确方便了不少。

    蜂群（Wasp Swarm）：比混乱强的混乱。虽然不能影响机械或亡灵生物，但是可影响元素，而且不受精神头盔的限制。从这点来说，蜂群是同类三魔法（另外两个是和平歌、混乱）中最强的。同效果魔法总是出现在相邻魔法派系中是英雄四的特点之一，作为比较弱的种族，Nature分到一个最强的魔法也是挺公平的。但是使用起来，好像也没有人叫过BT，原因当然是Nature缺少可以用蜂群的兵种。要是Nature 也有“养蜂人”这么一个兵种，马上就会BT起来。蜂群只能英雄一个人用，那么使用的时候主意分组就很关键，别把敌方主力弄出好几 组。

    蛇击（Snake Strike）：这个魔法不算很强，但也还经常能用得上，从前期的减少伤亡，到后期给强力兵种，或者强英雄都很好。从防守为主的角度看，蛇击的受 法对象是弱的，施法的目的是尽可能减少伤亡。从进攻的角度看，受法者应该是强力的战斗部队，这刚好适合前后两个发展时期的特点。

    二级魔法里面几乎没有什么废魔法，当然人人都眼巴巴地看着流沙和蜂群，其实其他的也不能算差。Nature的二级魔法中除了召唤类的，其他也都很趁手。前期和后期都经常用得着。Nature的兵种弱，所以尤其注重速度上的控制。一二级里面算上蜂群有5个和速度相关的魔法。加上召唤系魔法，Nature和裸奔英雄有得天独厚的配合优势。

    三级魔法

    防魔（Anti-Magic）：使用后原先附着在该部队身上的魔法状态会立即消失（不包括宝物、职业附加的状态，此外也不能去除中毒与瘟疫），且以后无法再对该部队使用任何魔法。附加在幻象副本或是操纵的尸体上时，会让它们立刻消失。这个魔法产生的效果比较多，从作用上讲，完全是把双刃剑。施法的时机和对象需要认真考虑。如果你有强大的部队，特别是召唤生物，加一个防魔，可以让对方自以为很牛的英雄（比如Ord er、Chaos、Death的）欲哭无泪；比如你的对手不停的给你加各种诅咒魔法，一个防魔可以让世界从此清净下来。注意的是，防魔以后是没有后悔药的，特别是给自己加的时候，一定小心。尤其打单机的时候，敌方一般战斗实力比你强，要以弱胜强，干掉会防魔的英雄特别重要。总的来说，这是我最喜欢的一个三级Nature魔法了。

    群体加速（Mass Speed）：作用中规中举，没有多少好说的。抵消群体减速倒是很划算。对于强烈需要速度的Nature来说，这个魔法在三级里面并不差。

    招魂抵御（Necromancy Ward）：阻止操纵尸体和制造亡灵类魔法在战场上的使用。这个魔法就只有对阵Death的时候比较有用。需要注意的是，这个魔法时候的时机 ，因为施放此魔法的时候，战场上之前通过制造、控制亡灵类魔法产生的部队全部消失，所以经常会当驱散用。可惜适用范围很窄，不是很好用。

    三级魔法里面，除了很好的召唤魔法以外，群体加速是很好的魔法，对于正常状态下发展的Nature比较有用。当然，在单机的情况下，经常发生的情况是英雄单挑，所以除了召唤系里面招水特别受欢迎以外，普通魔法里面抗魔也倍受关注。如果就是自己随便打打，不特别追求速度、BT等等，实际上三级魔法都还不错，没有特别差劲的情况。

    四级魔法

    群体幸运（Mass Fortune）：将本方所有部队幸运值提到最高。相当于大家都只受2/3的伤害。这个和生命里面的群体防御性魔法效果类似，但是因为实现上有细微差别，所以是可以叠加的。这个魔法我个人是挺喜欢的，其优势在于速度，一个回合搞定，很有效率。当然实战中，使用的机会并不是很多。大部分原因在于英雄的魔法值。有了高级召唤魔法以后，一般招高级生物总比招低级生物有用，有限的魔法值限制了其他魔法是使用 。

    群体蛇击（Mass Snake Strike）：使本方所有部队获得“抢先攻击”状态。还是一个速度优势。

    普通的四级魔法里面就是两个群体魔法。在取舍上面要看对手的情况和自己部队的攻击力。两个魔法都是通过加强自身而寻求最小损失，但是作用的机理不同。蛇击是通过在先下手杀伤一部分来减少攻击/反击的伤害，而幸运就是增强抵抗力。如果自己的部队杀伤不强，蛇击实际是浪费，不如幸运；如果你是几个高级部队，敌方是一大堆炮灰，一般来说蛇击比较爽。

    五级魔法

    龙之力量（Dragon Strength）：使本方单个部队生命值和杀伤力加倍。五级中唯一一个非召唤类魔法。这是最好用的五级魔法之一了。加倍的生命值和杀伤力，对于高等级的英雄或者强力部队来说简直就是如虎添翼。如果评选裸奔英雄的最佳魔法，这个应该能进前10。龙力是专门为高级兵种或者高级英雄设计的，比如加在凤凰或者螳螂身上，威力巨大。召唤螳螂配龙力，也是下黑龙的常见手段。龙力可以说是对单个部队增强幅度最大的魔法，怪不得那么多人喜欢。对于脆弱的Nature部队，如果有龙力的辅助，可以一跃成为一支劲旅。

召唤类魔法

    召唤丛林妖精（Summon Leprachaun）：用来放幸运和作挡箭牌，一举两得。问题在于丛林妖精的战斗力太差，所以这个召唤魔法的主要作用在于辅助，减少损失，而不会是战斗 的主力。从针对性来说，对付野外的远程兵，召唤丛林妖精比较合适，除了加强自己的抵抗力以外，还可以消耗敌方的弹药。

    召唤妖精（Summon Sprite）：无赖战术的一个关键条件。配合流沙可以欺负掉慢的步兵。然而流沙不是说来就来的，没有流沙的情况下，召唤妖精的优点和缺点同样突出。一方面速度快，不反击，可以冲到前面阻挡等；但是另一个方面，低级的英雄不可能招出多少妖精，这次小姑娘不可能成为战斗的主力，而且还不能骗反击，在开始阶段的有些最艰苦的战斗中，作用反倒不如其他召唤好。不过，作为最基本的作战手段之一，Summon Sprite的作用主要是引开敌人，在这个任务上，它完成得很好，是个不错的一级召唤魔法。 　　召唤狼（Summon Wolf）：除了不能放幸运魔法，召唤狼真是完美的召唤魔法之一。作为强攻击力的生物，召唤出来的狼本身就可以造成一定的伤害，还可以骗反击 。因为自身的实力，还可以顶在前面充当挡箭牌或者炮灰。大法师见了狼都只有躲，证明狼的实力。

    召唤恶魔之子（Summon Imps）：双倍的魔法消耗，召唤出双倍的兵力。Nature和Death双倍的技能点数，保证双倍的魔法点储备，造就了双倍的威力。这样看来是很平衡的，其实不然，因为还有一个因素：速度。一次招双倍的兵力，部队实力的集结很快，这是一个很大的优势。召唤恶魔之子除了普通的骗反击，压制远程兵力以外，因为数量的优势，作为一支杀伤部队也是经常的。另外，在一些BT的地图里面，吸收转移魔法也 很有用。

    召唤精灵（Summon Elf）：一般刚开始会这招的时候招不了多少，低难度下比较好用，到了高难度效果要打折扣。后期一次招得多了，大概其他更牛的魔法也会了。用得不很多，有流沙或者对付慢兵很好。单单从实力上说，召唤精灵是强的，但是放在具体环境中，考虑刚好会召唤精灵的发展阶段以及一般所选择的对手，是否能保护自己的部队，敌方能压制对方部队等等，则它并不一定是最优的选择。

    召唤白虎（Summon White Tiger）：白虎的速度很好，除了能先攻占便宜，还能快速扑上去压制。不错。

    召唤半羊人（Summon Satyr）：本身杀伤力不错，还能放魔法。喜欢。

    召唤地狱犬（Summon Cerberi）：一大堆打人不还手的狗，强！在适合它出现的场合中，经常是主力。

    召唤火元素（Fire Elemental）：用得不多，火抵抗并不一定随时都有用。单拿出来当远程也不很强。

    召唤水元素（Water Elemental）：最好的元素召唤魔法，水元素除了行动力慢（地图慢的弱势在召唤中不存在）一点以外，能攻能守，冰箭威力大，疲劳和流沙极其好用。 无论是单机还是对战，一般地图还是BT地图，招水是最讨人喜欢的魔法之一。Nature的英雄如果能学到招水，实力会得到很大的 增强。

    召唤风元素（Air Elemental）：风元素虽然经验值不高，但是实际效果却经常比土甚至火好。很高的防御力，是对付远程的好工具，加上速度快，压制作用很明显。

    召唤土元素（Earth Elemental）：又慢，又没有好技能，:(

    召唤冰魔（Summon Ice Demon）：冰魔的战斗实力只在各元素之上。冰冻效果出现的概率是令人满意的，而且没有反击，连续两个回合，甚至比瞎眼还好。论肉搏能力也不弱，不太满意的是冰魔速度比较慢。另外冰魔的经验值设计得太高了些，双倍的魔法点召唤出来的冰魔数量上不太爽。实际战斗中招冰魔的目的大多在于冰冻上面，加上自身比较耐打，对数量的要求不高，当然如果是个裸奔的牛英雄，靠召唤出来的冰魔去肉搏也无不可。

    召唤狮鹫（Summon Griffin）：召唤出来的东西特技不能起决定性的作用。所以这个魔法在普通地图，或者对战中的作用很好，增加的兵力能够改变实力对比。但是在B T地图，或者单机想打出BT成绩，这个魔法并不很讨人喜欢。

    召唤独角兽（Summon Unicorn）：和召唤狮鹫一样，失明是个亮点，可惜概率并不高。

    召唤毒蜂草（Summon Waspwort）：作为一般Nature中能召唤出来的最强的远程，我所知道的使用者着实不少。所带的虚弱也挺不错。

    召唤食尸怪（Summon Venom Spawn）：如果不去和吸血鬼对比，食尸怪还是很强的。召唤食尸怪已经是很高级的魔法了，这个时候大概作用并不主要在放毒上面，而在杀伤力上 面。比起其他的四级召唤，召唤食尸怪明显强大了很多。另外，对于敌方英雄来说，食尸怪的毒击并不容易化解，所以用来秒英雄也挺趁 手。

    召唤凤凰（Summon Phoenix）：召唤出顶级兵种的魔法怎么也该算是强魔法了。凤凰的速度和重生使这个魔法在对战中尤其好用，一般见面时间都不会拖很长，多出一两个顶级兵种，几乎就是一周的兵力了，在胜负的天平上，这是一块很重的砝码。凤凰可以重生，使召唤出来的凤凰更加经久耐用。另外，如果没有召唤螳螂，召唤凤凰经常也可以作为裸奔英雄的主力部队，对付魔法竞技场等完全够用了。

    召唤仙女龙（Summon Faerie Dragon）：仙女龙最大的价值在于分组，然而召唤生物重叠的设计使我们的仙女们非常郁闷。 仙女龙比凤凰好用的时候就是有多组仙女龙的时候，这个平衡现在在召唤中被打破了。

    召唤螳螂（Summon Mantis）：最好用的裸奔魔法之一，尤其适用于黑龙竞技场等场合。因为被缠身的部队攻击减半，所以论单挑的话，螳螂实力非常强。召唤螳螂缠住黑龙，然后英雄给螳螂加龙力，或者直接补充螳螂，都是打黑龙竞技场的最简单的办法。平常战斗中，螳螂经常用于缠住主力杀伤部队，用以保护英雄。可以说，召唤螳螂是最好的护身魔法之一。

    召唤恶魔（Summon Devils）：强力的突击部队。另外还顶一个召唤冰魔。记住如果不是很急的话，恶魔先招了冰魔再往上冲。一般来说，招的恶魔应该是作为主力的， 除非要秒英雄，不然先把冰魔招出来，挡在前面，攻击的时候让冰魔先上都是应该养成的习惯。

    总的来说，Nature的魔法以召唤为主，各级召唤都能在相应的时期内给部队作战能力合适的提高。这一点比其他的魔法设计要相对合理一些，不会出现低级魔法作用过于BT等情况。普通魔法里面，倒是有不少好的状态魔法，从地图到战斗，帮助都非常大。也许是因为Nature兵力偏弱，所以NWC把他们的魔法设计得很好，虽然不如Order那么BT，但是说“非常强大”，是不过分的。这也导致了裸奔英雄对Nature魔法的偏好。

技巧

    Nature的打法，基本是靠德鲁依为主力英雄。开局的时候由于兵力比较弱，并不一定能象其他种族一样征战不休，到处拣资源显得更加重要。Nature的生物建筑条件并不苛刻，虽然多了一个生物门，但出四级仍然很快。不过虽然说初级兵战斗力并不很强，但是矿是依然要打的，英雄是依然要培养的。前面谈兵种的时候也说过，狼和妖精的组合配合英雄，起码可以打大部分矿和一些宝物。迅速出高级兵种是无奈的选择，这之前英雄的培养不要太忽略。很多人的打法喜欢“憋”某某兵，实际大可不必，不要怕牺牲低级兵种，一将功成万骨枯，低级兵种的作用就是开始的那么一段时间。开始的打仗的时候，注意两种英雄的作用，无论怎么说，德鲁依是培养的重点。Nature对其魔法和召唤生物依赖很大。另外提示一下，小兵探路的时候不要就一个人出去，最好2－3个结伴，一个路上看见什么分一个出去拣了其他的还能继续赶路，二是如果有了岔路可以分头走。不用想着攒妖精，反正出来得快，前期能多弄点资源比什么都好。

    除掉速出仙女龙的打法，一般造四级之前会修生物门。出了生物门以后有两个发展方向，一是在生物门阶段停留比较长的时间，以气元素和水元素为主力，同时积攒螳螂；另外就是一口气造出四级兵。如果资源不紧张，我比较偏向后者。毕竟发展的速度快一些，而且有一两个四级兵以后不但跑得快，打仗也比较轻松，不比4、5个元素差。水元素这个东西跑得太慢，靠它打仗的话，海枯石烂了它还没有走到，起码心理上就承受不了。快些有少数强力部队，打仗也轻松，钱也不会少挣，部队待在城里即使不招也不会烂掉。用生物门过渡一段比较长的时间也有不少人用，一般比如开始拣的钱不够多，或者有关键矿没有占到等等，与其“憋”一段时间，不如就用生物门来打。生物门里面也能出四级，就是数量少了些，不如元素爽。两种打法都有适合的场合，一般是选择可以让英雄尽快（持续）战斗的一种。

    Nature的主力部队一般都是高级兵种，不假设财富极大丰富的情况下，招全兵不太可能，而且低级兵种中诸如狼的、白虎等，初期发展消耗不少，数量也不会太多，招全了也没有大用。如果以高级兵力为主，地图速度上很有优势，这个时候是否带元素出战需要斟酌。水元素的加入肯定可以增强实力，但是注意不需要的时候分出来，避免对移动力的影响太大。另外，随时保持一队妖精跟在大部队后面是明智的，高移动力的初级部队不拖累部队步伐，可以周围探路，拣资源、宝物，查看建筑（比如某处教何种魔法）等，遇见打仗可以补上几个进来阻挡视线，压制远程等等。这个做法大家最好能养成习惯，对于Death和Nature，这是他们种族的独特优势。

    特殊建筑方面，一般生物门是必然要造的（速出仙女龙的情况下，为了保证战斗力，也经常补造生物门）。部分因为白虎的原因，部分是自己也很实用，魔法+3也经常造，对于Nature的英雄，召唤消耗魔法大，一个魔法+3能让英雄多召唤4－5次，加上魔法回复，能有6－7次的增值幅度。另一个建筑铁匠铺也是为了魔法设计的，其中最有用的就是魔法药水了。开始阶段可能造不了（木头太多了），等到兵种出齐了，木头也没有什么大用了的时候别忘了把它补上。


初学浅谈（六）：英雄无敌四种族之Might篇
作者：Fenrir

    Might在英雄四里面可以说是最弱的种族了。开始就不顺利，开局可以说是最困难的一个；等好容易发展起来了，见面又没有魔法， 难免为人耻笑。

兵种

    狂暴者（Berserker）：从指数上来说是非常强悍的一个兵种。攻高血厚是它生存的本钱（可惜战场上生存率却不高）。狂暴者的攻击力经常比一些二级兵种要高，但是作为一级兵又更容易积攒，所以是Might的发展过程中较长一段时间内的主力。狂暴者的操作技巧实际就是包围战术。最开始的包围者肯定是半人马，半人马的速度比狂暴者慢，这样就少了一个骗反击的回合。所以经常情况下，走开的半人马并不是去攻击对方，因为这种攻击没有什么杀伤效果（做围栏的半人马经常是单个组队的），而且也无法为狂暴者骗反击。这种情况下，反倒是走到敌人面前站住比较好。这个技巧实际在其他很多时候都能用得着，一个吸引弱智电脑的火力；二个相当于人为知道障碍物，给我方部队争取更多的时间。而且，放出来的时机也需要注意，最好是对狂暴者的行动范围有一个大概的概念。开始围住的时候是无法通过鼠标右键来看行动范围的，放出来以后到底它能窜多远，需要事先估计好。另外，狂暴者也并非一成不变总得找人围着，如果敌方速度很快，一个回合可以到跟前，狂暴者就不需要围起来，因为它们可以在第一个回合就直接攻击对方。最后需要注意的是狂暴者的使用要适度。Might开始的战斗力几乎都集中在一级兵上面，而且英雄没有魔法，狂暴者再牛，也终归是一级兵，属于低质易耗物品，每仗如果消耗太大是很不合算 的。

    半人马（Centaur）：如果光看指数，感觉半人马和三代一样，简直可以说是最牛的一级兵了。可惜实战不然。顶讨厌的问题就是短程射击，加上弹药又少，最终落得个当栅栏的下场。但是我们仍然可以从栅栏身上做文章。一个是如何保证主力半人马部队的弹药使用尽量有效，比如可以对慢兵多耐心等待，对远程兵集中一队攻击，导致其弹药分布不均匀，然后对提前走上来的敌人就有机可乘了，不但对主力半人马来说是求之不得，对狂暴者来说，也是磨刀霍霍所向之物。另外，半人马自身的战斗力也还算强的，近战攻击没有衰减也是很好的东西。在最后的肉搏中，狂暴者天然就是一个“骗”反击的家伙，半人马也就乐得尽量出手。另外需要提醒的是，半人马的最后一箭是没有衰减的，正所谓回光返照，无论是使用半人马的时候（选择目标），还是对阵半人马（是否需要挡箭牌？）的时候都需要小心处理。

    Might的初级兵种在战斗力上面来说是很强的，这个对于平衡英雄很有帮助，可惜老头又给搞得疯疯癫癫，实在让人气恼。好在我们有围栏战术，而大部分的使用技巧就都是围绕着这个战术展开的。从总体来说，单个战斗中，Might的初级兵种相比其他种族经常是有优势的，但是这个优势极其容易被损耗。如何选择对手，战场控制的熟练程度就显得非常关键。两个兵种，可以说都是主力，就是由于狂暴者实在弱智，所以半人马稍微吃亏一点。另外，初级兵种里面总得找人出去拣资源，半人马由于速度快，所以也经常干这种类似自杀的活。这从另一个方面显示了狂暴者的数量优势，弱势群体半人马就更加无奈，只好更加义不容辞地当栅栏。

    鹰身女妖（Harpy）：Might前期地图移动力最高的部队，加上打人不还手，是很好用的一个兵种。除了很特殊的情况下，攻击敌人后自动返回原处是一个优势，特别对于速度慢的兵种。合理利用这一点，如果你足够耐心，甚至可以像用小妖精一样使用鹰身女妖。它的问题是血少，另外攻击力也不是很强，在大的战斗中，不能起很强的作用。鹰身女妖比较脆弱，战斗中经常是用来清扫敌人小股部队，或者辅助其他部队进攻。它不能用来骗反击，和其他部队的配合说不上来有什么很特殊的效果。打完了往回跳是个有趣的特点，和独眼巨人配合挺般配，特别是对付速度慢的兵。攻城的时候打城门也非常合适，不容易损失。使用鹰身女妖要注意位置，不要不小心跳回来刚好被别的部队攻击。

    游牧人（Nomad）：又一个强悍型的部队。攻击力比鹰身女妖强，虽然不能避免反击，但是先攻有一定的补偿。它更好的一个特点是战场出手速度快。游牧人第一个回合就可以冲到对面，加上先攻技能，对于敌方的远程、魔法部队有很好的压制作用。在地图移动力上面，游牧人仅仅比鹰身女妖少一步，不算什么劣势。游牧人属于近身搏斗的兵种，身属Might阵营，那么自然Mighty。从战斗力指数来说，可以说是二级 兵中的佼佼者。

    这两个兵种的取舍，实际就是不反击特技和强力之间的选择。我个人的选择主要依据英雄的状况和地图的大小。如果是战役中的牛英雄，那自然是选择鹰身女妖。无论怎么说，鹰身女妖的存活率要比游牧人好一些。放在牛英雄身上，主要是作为增加移动力。战斗中，鹰身女妖诱使对方分组，消灭小股部队等很在行，而且大多数情况下可以自保。如果是个地图不很大，如果英雄是刚刚培养的，那我想还是宁愿要游牧人的好。毕竟最主要的还是部队的总杀伤力和总HP数。另外，野兵的种类和数量也时常影响我们的决定。如果打法上面有很大的优势，可以更快升级，更快获得关键宝物等，则可以根据打法的需要选择。上面说的选择，都是说，带什么部队在身上，主要招募那种部队。实际建筑中，如果有野外招募地那自然很好，可以根据需要选取。如果光靠城镇建设，那还需要考虑对整个经济形式的影响。一般来说，鹰身女妖的条件比较苛刻些，因为Might很多情况下要靠三级兵打天下，二级能早过渡就早过渡了。即使如此，我仍然知道很多人都喜欢出鹰身女妖，大概还是怕损失的习惯吧。

    食人魔法师（Ogre Mage）：不知道为什么，其他等级的兵种都还设计得比较得体，但是一到三级兵，NWC的智商就立马下降，难道是3犯了3DO的忌讳？食人魔法师的地位完全可以媲美那加：一点出头的希望都没有。攻防差，技能烂。说野蛮，但是肉搏指数比其他魔法种族的大多三级兵都不如；说是魔法兵，甚至整个Might唯一的魔法兵，魔法技能又极其烂。不是说嗜血这个魔法不好，而是让一个三级兵失去肉搏能力，换取一个魔法，而且还不知道给谁放实在划不来。另外，老魔法师的速度还慢，这样雪上加霜，彻底没有救药了。

    独眼巨人（Cyclops）：Might赖以苟延残喘的救星。可以说，没有可爱的独眼，就没有Might。攻高，不反击，范围攻击，三个极其好的特点和在一起使独眼巨人倍受亲睐。独眼巨人的攻击力和吸血鬼一样，比大多数三级兵，甚至部分四级兵还强。不反击也让人很头疼。另外，如果自己手动控制，只要鼠标性能还行，一般误伤概率是很小的。周产量3不算很低，Might出了独眼才算是可以松一口气，出去耀武扬威一段时间了。独眼巨人的范围攻击同时也是敌方英雄的致命武器。一般来说，想躲过独眼的攻击是不可能的；普通的阻挡视线，肉盾等都没有作用。加上独眼攻高，几周的独眼巨人出手一两次，牛英雄大多也得下课。独眼巨人和鹰身女妖是一对好搭档，一个在前面牵制吸引敌人，另外一个在后面落井下石，爽甚！需要注意的是，一般使用独眼，都希望把敌人多分几组出来，这样范围攻击才能发挥其最大的作用。另外，如果对方有数量比较多的快兵，在周围保护的部队不能太少了。

    一个没有选择余地的三级兵。开始有嗜血没有人可以加，即使上了数量也只好自己原地站立几个回合以后才喋着肚子慢慢往前走的老头子，还是能扔巨石，横扫一片的猛男？在建筑条件上，独眼巨人和食人魔法师也没有什么的大的区别，这就再次加剧不平衡。实际就算是独眼巨人的条件再多点，相信绝大多数人的选择还是不会变的。和其他的部队一样，Might的三级兵也有一个通病，就是速度慢。出手速度4，实在是过分了点。在出三级之前，Might的部队还处于低质易耗阶段，独眼腾空出世以后，整个公司才能进入盈利阶段。独眼之于Might，不亚于灯神至于Order。

    雷鸟（Thunderbird）：Might好容易出了一个跑得快的兵。这是我开始打英雄四的时候最喜欢的兵种之一。首先从外表来说，雷鸟是最漂亮的生物之一。另外闪电伤害在上了数量以后是很可观的。速度快，可以说是雷鸟对比比蒙的最大优势了。在没有魔法的种族中，顶重要的两个条件就是速度和数量。雷鸟的速度和移动距离是最大的优势。虽然肉搏能力差了一些，但是产量高，也容易积累。闪电攻击对于高等级的兵种和英雄是一个大的威胁，因为其威力的计算是：伤害值＝雷鸟数量*30。这样无形中削弱了高等级生物和英雄的最大优势：高防御力。我个人比较喜欢出雷鸟，除了上面说的优势，地图移动力也挺高。当然，如果是野兵，我很讨厌雷鸟的。

    巨兽（Behemoth）：强力，单机用非常爽的一个东西。单机打Might的秘诀是什么？是学魔法。有了魔法养着，比蒙的强力可以施展得淋漓尽致。和九头类似，有魔法守护的比蒙非常爽。在杀伤力方面是不用担心的，只要有魔法增强其防御，比蒙杀敌可以说是多快好省。同时，和九头一样，野外一大群比蒙是大家可遇不可求的盛宴。从身体素质来说，比蒙是三甲及第；但是从大脑来说，大概就得倒着数了。和机器打的时候可以多放些心，和人打的时候就要注意了，特别是Order、Nature之类的对手，很容易就让你的比蒙发挥不了作用。

    四级兵里面，雷鸟和比蒙各有所长，就我个人来说，更喜欢速度快一些的雷鸟。雷鸟和独眼一样，都是英雄杀手，而且部队中多了个快速的飞行部队，打法上的选择更多。从建筑条件来说，比蒙实际上要节省一些。而雷鸟需要那三根大柱子，实在是非常奢侈。好在独眼可以支撑很长一段时间，四级如何选，并没有绝对的优劣。如果多考虑对手和地图因素，那在大地图，或者见面不会很快的时候，也许雷鸟要稍微好一些。从自身发展来看，独眼已经很强了，比蒙和雷鸟在杀野兵上没有大的区别。而长时间中，对手有可以出现比较牛的英雄，考虑抗对方魔法的影响，对英雄的杀伤力方面，雷鸟比较占优势。

    总体来说，Might的兵种特点鲜明：肉搏卖力，没有魔法（我不把食人魔法师算在魔法兵种里面，因为上镜率太低，魔法效果太弱）。Might的发展，前期完全是用血换来的；出了独眼以后有了大的改善。但是在面对敌方有英雄的部队的时候，吃亏太多，无法弥补。以前英雄三的时候就有魔法英雄带野蛮兵的做法，现在到英雄四仍然可行。不过由于其他各族魔法兵种大量涌现，Might这种完全靠体力吃饭的种族实在是强不起来了。甚至布阵也没有了，部队偏偏还都慢得像蜗牛。速度普遍偏慢是另外一个很大的缺点，二级兵和雷鸟在地图移动力方面不弱，但是主力部队的移动就不行了。不过Might部队的一个好处是便宜，加上育种棚并不是特别困难，在数量上占绝对优势是可以办到的。加上独眼的特技，上了数量的Might和没有好魔法的魔法种族之间还是有拼头的。Might的发展有两个瓶颈，一个是初期的疯老头比较难控制，一旦某次战斗伤亡过大，以后发展就难以为继。这个可以通过战场操作水平以及敌我实力判断水平的提高部分解决。另外一个就是部队成型以后，在主力对决中没有魔法帮助。这一点是没有办法的，算是天生的缺陷了。让Mig ht英雄学习魔法技能是一个好的补偿办法，但是这得靠地图和运气。加上魔法塔匮乏，实施起来并不容易。

英雄

    Might的英雄没有什么好说的。就是野蛮人嘛，加油练好身体就行了。可以选择的是先练箭术还是肉搏。Might的英雄开始要比别的英雄多一个技能点，想必是为了平衡，但是实际仍然嫌不足。箭术在开始的直接杀伤作用比较明显，而肉搏则能为部队提供一个肉盾。相比起来，抗魔在前期几乎没有什么的作用，但是后期却很管用。战斗技能总是很有用的，到底要练到什么程度，和肉搏或者箭术的进度取舍如何平衡，都是需要根据实际情况认真考虑的问题。我个人的做法一般是在肉搏和箭术中选择一个重点，然后和战斗技能交替升级（并不是严格的轮流一个升一次，而是升几次这个，再升几次那个）。肉搏无论是在攻击力和对敌方防御的降低程度上都优于箭术，如果英雄皮厚，在一场战斗中不会死的情况下，肉搏发挥的威力更大一下。除了作为主力杀伤之一，肉搏英雄还可以兼代做肉盾。箭术英雄如果成型快，在早期的战斗中能够减轻不少负担。另外，在对付魔法种族的时候，箭术英雄的作用也很明显。两个各有各的优点，要根据周围野兵的分布来决定取舍。一般如果周围有些箱子、柱子可以吃，想主打远程的话就直接升箭术，想成肉盾就嫌升战斗。一般英雄到了1 0级左右就已经成了一个专业的宗师了，是否转修另外一个专业，还是学抗魔主要看对手。抗魔是对Might英雄很关键的技能，单机中如果有时间，最好能够学到宗师。和人对战虽然不一定能学到最高级，但是在上面投资两个技能点就可以达到70%以上的抗魔，非常有用的。不过要注意的是先把自己的攻击力练强了以后再抗魔。单机，特别是战役中，无论什么英雄，经常是只练战斗和抗魔技能。那是因为战役英雄有很多加攻防的机会，而且肯定魔法能力特别强。在一般战斗中，没有那么多机会把一个英雄练成超人，如果你没有杀伤技能，光有抗魔别人也不会把回合数浪费到你身上。打一般地图，主力交手之前大概能有10级左右的培养空间，如何选择技能，需要好好安排。Might英雄的技能升级比较稳定，没有那么多需要S/L的情况。假设一个没有外快的英雄，10级的时候能有200的生命，假设肉搏和战斗是宗师，那么攻防为40/60，杀伤3x-4x，加上降低敌方防守，大概相当于2－3个中等的四级兵。记得英雄四刚出来的时候，前瞻里面说过，一个英雄开始很脆弱，培养好了以后战斗力大体相当于1个黑龙。我想大概就是说的这种情况吧。在战役中，这样一个英雄只是刚刚开始成长的英雄胚子，但是在一般战斗中，就已经可以算是成型了，该拿出去用了。

    对于Might英雄来说，最缺乏的是魔法。Life、Nature和Order系的魔法对Might英雄的帮助很大，如果有机会学，最好不要放过。如果资金充裕，招募一个魔法英雄做辅助也很有用。加了有益魔法的英雄，就不止仅仅相当于几个四级兵了。另外， Might打仗靠的就是全兵出击，人多力量大。因为几乎所有兵种的杀伤能力都很好，独眼发挥还稳定，所以即使有几个部队被困住，其他的也可以造成很大伤害。一个Order的贵族英雄对Might也很有帮助，其他的不用管，主力升贵族技能。因为没有魔法，战术技能对Might也很有好处，一般对于没有魔法的部队，想胜过魔法部队，除了抗魔，最先决的条件就是要先下手为强。在英雄四里面，没有了布阵，战术成了唯一的希望。如果是一个一般的大地图，英雄没有指望升很高的级别，也没有满地的水晶让你吃，战术就应该得到重视。有战术指挥的大部队，比没有战术而单英雄多几点攻防要好。


英雄无敌4与魔兽的异同
作者：waohily

    以下英雄无敌四简称H4，魔兽争霸三简称war3。

    1.都有英雄，而且英雄都可以通过打野外兵种获得经验值升级。初期英雄都是很弱的，需要特意的保护。越高等级的英雄对于最后的胜负越起着决定性作用。不过都是相对的，不同的在于一个特高级别的英雄在h4里起的作用比war3里的更显著，即h4里一个英雄特别是带上不朽药能抗击很多数量的怪物，甚至可以一个人独行，war3里的高级别英雄抗击的兵力相比还是有限.还有英雄的等级不同，WAR3的英雄设计最高10级，每次升级时只能在备选基础技能中选择，6级时出现终极技能。H4英雄最高70级封顶，不过不是 BT的BT图一般很难达到，一般地图不是特意练级的话一般就二十多级，英雄有初始技能，共9大类，完全可以通过学习改变自身职业甚至是相对的阵营，比如你完全可以把一个牧师练成刺客，死亡加战斗.关于经验值的获得，也略有不同。H4的英雄必须亲自参战并保证不被打死才可获得，而WAR3，完全可以英雄在一个地方，兵在另一个地方，英雄仍获得经验值

    2 作为战争,总是要花费和死兵的，所以都有相同的思路，尽可能得占有最多的经济,比如城堡啊，金矿啊，能拥有最多的财富的和能保证 死亡最少的兵力的人，总是最接近胜利的人。不同的在于单机时h4有一个强大的“魔法”S/L。war3只能不断的练习了，呵呵。作为战争，都要考虑制定自己的策略，打探情报，骚扰对方，把握战机。这方面东西和情况很多的，就不一一详细的介绍了

    3 死亡族都可以增加额外的兵力，h4里有强化的招魂，从骷髅幽灵到强大的吸血鬼都可以被招魂出来！而战场上，死亡的魔法还有驱役亡 灵、亡灵复生（操纵尸体和死亡呼唤）。war3 的不死倒是只能招出来骷髅和骷髅法师，而且类似于war3的召唤,有时间限制.不过一个尸体就能召唤出来两个骷髅, 也算是满强悍的。这个召唤可以通过升级骨质增强术来延长存在时间，升级骷髅法术产生骷髅法师。还有一个是死亡骑士的终极技能，可以死亡召唤，暂时复活周围最强的六个兵种。中立英雄黑暗游侠是不死阵营的，她的黑暗之箭可以增加额外的伤害，当单位被骷髅之箭杀死时会变为骷髅兵，黑暗之箭产生的骷髅兵比 巫师召唤的要好，不过一个尸体只能召唤一个骷髅

    4 都有人族和死亡族。关于人族，个人认为也听有人这样评价过，人族都是稳扎稳打的防御性打法，以稳健为主，不可冒进。看战报 LT 人族开局总是速带民兵速开分基战术，很快的。（当然看得战报还算不太多）听说过人族英雄秒英雄的设计，血法先对其施展虚化，可以使对方减速，山丘使用飞锤，血法再释放烈焰风暴，几乎可以必死。死亡系都是强悍的一族，h4里不说了吧，强大的cc就足以傲视群雄。war3里不死是很邪恶的，最近的补丁都在削减不死，不知能不能证明一点。有经典的不死三英雄秒杀英雄的纪录，死亡骑士先死亡缠 绕，小强穿刺眩晕之，巫妖释放冰霜之星，如果还没死，死亡骑士可以再来一个缠绕（当然是在理想状态下）

    5 拥有很多相同的兵种。

    1）农民。在土地上…农民提供给我们粮食和财富人族的老农就叫做农民，其实在3里的各族的老农都可以这么称呼，至少基础作用可以采矿采木头相同. 严格来讲，4里并没有详细说各族的城堡收入怎么来的，估计也是压榨广大的劳动人民来的。不过人族到有一个专门的中立兵种，农民， 特技是纳税，每人每天产一钱

    2）骑士。在亚瑟王的圆桌骑士传奇中，有许多关于骑士的英勇传说。亚瑟王是反抗罗马统治的斗士,约为公元6世纪的人物.威尔士人所称的巨龙 之王尤瑟,不列颠之夫也是他。骑士是受过严格训练的骑马战士.在中世纪,欧洲最精锐的军队,就是由骑士组成的这些骑士在欧洲中世纪的封建制度中,举足轻重.领主给骑士土地,让他们生活有所依靠,而骑士就每年为领主服务约40日,为领主作战,出征或守卫城堡.初期,所有骁勇善战的战士都可以成为骑士;后来,骑士形成了一个固定的阶级,成为战士统治者或贵族,在欧洲各地形成统治阶层.骑士应该遵守武士精神的国际规条,所有真正的骑士,除了服从主子外,还应该侍奉上帝.在十字军东征的时期,有些特别的宗教"骑士团"成立,包括12世纪的"圣殿骑士团""条顿骑士团"等,15世纪,新武器和新类型的战争出现,骑士在欧洲军队中的重要性减低.很多骑士不再为主子作战,改为付钱给主子请雇佣兵,于是,富有的骑士就集中精力管理自己的土地.
    骑士在拥有马匹、重武器以及驾驭马匹和使用重武器方面确实有着优势。作为强大的生力军，在h4还是war3里，骑士都是最高级的兵种，h4里是顶级4级兵与天使一争高下，先攻高攻让人不敢小瞧。war3里是人类的地面顶级兵，高甲高攻，可以学习训兽术提高生命值。不同在于如果你仔细观察的话，会发现h4里骑士是冲锋拿长 矛戳向对方的，而war3里骑士是上去一刀一刀砍的

    3）狮鹫。希腊神话中是一种飞行速度非常快的生物，他有老鹰的头、翅膀、以及老鹰的前爪，同时也具有狮子的身体、后腿和尾巴主要生活在魔神山上的高崖上，以小生物为食。据说是一种非常痛恨邪恶的生物。可以被驯服，经常可以看到飞骑士用它来作为坐骑。据但丁描述，狮鹫的鹰头部分是金色的，狮身部分是白色的。有人认为狮鹫代表恶魔，有人则认为它是基督的标志，因为在《语源学》一书中曾有这样的解释："基督是一只狮子，因为他有着统御的才能和巨大的力量；基督也是一只老鹰，因为他在复活后可以升入天堂。"据说狮鹫是战神阿瑞斯的圣物。阿瑞斯的头盔上上就刻有狮鹫。在h4里 狮鹫其实是自然城的三级兵种，无限反击的让人头疼，如果加上蛇击的话，呵呵。在war3里是人族的空中终极，而且是狮鹫骑士的形 态出现，在升级了风暴之锤之后还可以溅射。

    4）凤凰。关于凤凰的传说，东西方都有.凤凰在英语里叫Ｐｈｏｅｎｉｘ、在埃及叫Ｂｅｎｕ，在印度叫Ｇａｒｕｄａ，在阿拉伯叫Ａｎｑａ，在波斯叫Ｓｉｍｏｒｇｈ，它是传说中的神鸟，而且色彩斑斓，它有些像鹰，但它的羽毛为红色和金色。在阿拉伯的传说里，凤凰从火中而诞生。凤凰的生命是周期性的，每隔一段时间它就自焚一次。自焚前，它会唱一首优美的挽歌，用翅膀扇动火苗把自己化为灰烬，然后在灰烬中获得再生。它永远不会死。(又称不死鸟或火烈鸟)一般认为凤凰自焚的周期是５００年一次。在埃及传说里，凤凰与太阳崇拜有关，任何时间里一次只有一个凤凰，均为男性，它的真实原形可能是鹰，也可能是孔雀。根据希腊传说，凤凰生活在阿拉伯荒漠的一口井的旁边，它每天清晨都会在水里沐浴并唱着优美的歌曲。这时，埃及的太阳神就会驻车倾听。凤凰自焚以后，再生的凤凰会把自焚凤凰的灰烬放在蛋壳里，飞送到"太阳城（Ｈｅｌｉｏｐｏｌｉｓ）"里太阳神的祭坛上。因此，凤凰又是不朽和再生的象征。因此凤凰又被 称为"不死鸟"。这是罗马诗人奥维德对不死鸟的描述："大部分怪物都是由其它生物衍生而来的，只有一种例外，它们可以再生，亚述人称之为不死鸟（ Phoenix）。不死鸟并非靠花草果实维生，而是以乳香为食，在降生五百年后它会落在棕榈树顶端的橡木枝上为自己搭建一个巢，然后出外收集肉桂、甘松和没药等香料，衔入巢内，垫在自己的身下，当它呼出最后一口气后会悄然死去，此时从它的身体里将飞出一只新的不死鸟，同样拥有五百年的生命。等这只不死鸟长大到有足够的力量时，就会把父母的巢从树上升起，衔往埃及的赫利奥波利斯城，放在太阳庙里。这个巢是它的摇篮，同时也是它父母的坟墓。"。在h4里是凤凰自然的顶级兵种，虽然常被同级的仙女龙挤压,不过高速，高攻防，还有重生，如果遇到 对方有抗魔的部队时，作用自然比仙女龙大。在war3里是血法的终极魔法，魔免和抗性皮肤，使得对手常不知所措，不过它倒有一个孵化时间，变成蛋时才是攻击凤凰的最好时机。

    5）水元素（Water Elemental）。古代印度把地水火风作为构成世界的四大元素。不过四元素在各个文明中都没有记载。不过在16世纪炼金术师帕拉塞尔苏斯（Para celsus）所写的妖精之书中记载有四大元素精灵。在h4里水元素可施展的魔法包括疲劳、冰箭、流沙和虚弱，冰箭威力为40×水元素数量×0.29，流沙长度则是恒定的20英尺（ 但可通过 奇迹建筑延长）。虽然经验值在地水火风四大元素中排名最低，但实用性却是最高的。疲劳魔法可以对大部分生物起效，流沙更是所有地面部队的天敌。造好召唤门之后，招3到4个水元素来用，虽然不能对付所有种类的敌人，但至少能对付相当一部分。在妖精快速探开地图、看清周围野兵配置的情况下，水元素的使用可以做到有的放矢。虽然地图移动力稍微有点低，但只要能够成功渡过瓶颈期，靠抢来的资源出四级兵，水元素差不多也就可以功成身退了。此后水元素的应用，多半是在召唤魔法中。作为野兵，水元素的难对付程度与风元素仿佛相当，有些时候还更强一些。值得注意的是，冰抵抗特性的存在，让水元素在对付灯神时能发挥奇效。同样是冰箭魔法，却有“只许州官放火，不许百姓点灯”的味道 。召唤水元素，是英雄没抗魔能力时对付野外灯神的好方法之一。在war3里，水元素为大发师的召唤单位，三级水元素的伤害/秒和战斗价值都 可以挤进排名前五 ，威力强大。

    6）石像鬼。石像怪原是一种面目狰狞、有著蝙蝠翼的怪兽形排水口。在西式家居或教会中设置，用来排出墙壁或基层的水。Gargoyle源自古 法文Gargouille（拉丁文为Gurgulio），意指咽喉或食道。在基督教普及中，这些石像怪也魔物化。它是冥界的居民，掌管水。h4里石像鬼是死亡的中立野外兵，虽然看上去攻击力不强，但高移动力和元素属性，却让石像鬼在早期战斗中经常会对英雄的安全造成 大威胁。在战斗中始终有护体石肤护身，近战和远程防御力提高25%。war3里石像鬼是不死的空中强有力兵种，可以升级石像形态快速恢复生命，石像形态时魔法免疫。

    7）骨龙。龙缘何而生？它似动物，有人说它是鳄鱼和蜥蜴的"大共名"，也有人说它演化于蛇，还有人称它是恐龙的遗记；龙，又是象征，既有人 认定它是图腾合并的结果，又有人相信它是云水、闪电和彩虹的集合。这些都是今人对先人的猜测。相对而言，"蛇说"比较占上风。毕竟各个民族都流行过蛇崇拜。几乎世界各大古老文明都有它的掌故，如巴比伦的古龙、北欧的毒龙、 犹太人的撒旦、印度的那伽（Naga），在北美，玛雅人也有以龙为题的艺术，但还有人研究认为它是从亚洲传过去的。龙在希腊语里叫Ｄｒａｋｏｎ，演变成英语叫Ｄｒａｇｏｎ，在拉丁语里还有一个Ｄｒａｃｏ。尽管西方人也一直没有解开龙的起源之谜 ，但多半认为它是蛇崇拜的回响。Ｄｒａｃｏ则来源于蜥蜴，在希腊也有天龙星座的意思。中国的龙，家族庞大，有黄龙、青龙、赤龙、白龙、乌龙、金龙，千年之龙叫应龙、无足之龙叫烛龙、有角之龙叫虬龙、无角之龙叫螭龙，等等。它们有好有坏，有善有恶。以黄龙象征黄帝，中国古人以龙为尊。但传说中，也不乏屠龙、斗龙的记载，如女娲杀黑龙、大禹斩蠢龙、李冰父子伏孽龙、周处除蛟龙，等等。中国的龙崇拜有五千年以上的历史；封建时代，龙又嬗变为皇权的象征，帝王自称"真龙天子"。在西方传说中，龙和宝藏有着密切的关系。在意大利人的传说中，赛努诺私(cernunus)是一个有角的神祉，他的职务是掌控所有的财富以及商业，同时他也是地底之王，赛诺努私常常和他身边的一只长有角的龙一起出现，而这只龙则被认为也和财富有关，尤其是 地底的宝物。《北欧的神话传说》第一章《创造天地的神话》介绍北欧的毒龙时说道：有一条狰狞的毒龙叫尼特霍格，盘踞在冰天雪地的海维格尔玛泉水旁，日夜不停地噬咬着伸入泉水的巨大树根。又说："毒龙生为恶魔，企图最终咬断宇宙树的巨根，毁灭世界。"北欧的毒龙嗜水，不同于中东的古龙，却类似于中国龙的传说。在欧洲战争史上，龙还常常作为武士的徽章。（这个和狮鹫差不多）。龙在西方的待遇和东方不同。在西方，龙是邪恶的象征。埃及的黑暗之神Ａｐｅｐｉ就是一条巨大的蛇。希腊、罗马人接受了他们龙是恶者的说法，同时也把它构想成慈善的力量，希腊的阿波罗就是蛇的崇拜者，但总体上来讲，他们也没有改变龙的邪恶形像。基督教文明的兴起则基本摧毁了西方人对龙的慈善想象。在《圣经》里，龙就是蛇。在《创世纪》里，有一条著名的蛇，他曾引诱夏娃偷吃了伊甸园里的智慧果；在《启示录》里又两次说到：龙就是那古蛇，名叫魔鬼，又叫撒旦。蛇与龙前后相承，而且迷惑天下人。骨龙，即是龙的骸骨了，在h4里骨龙是死亡的死亡系老大，不弱的攻防能力，加上引起恐惧技能的助纣为虐，骨龙排在顶级兵的前几位 乃是必然结果。在面对有生命的敌人部队时，引起恐惧技能多数时候可以等同于不受反击，远程防御力翻倍。在war3里名字到不一样，冰龙，其实也是骨头的龙，可以升级冰冻喷吐，一需要一下就可以让炮塔歇火，高攻，带减速和溅射效果， 强悍。要说他的缺点嘛，贵是一大点，速度上也略有不足。用一两骨龙配合其他兵种，威力甚强。

    8）骷髅。不死怪的一种，生前多为普通士兵，攻击力很强，行动敏捷但没有智慧。多为亡灵巫师利用作为守护财宝的士兵。在h4里为死亡的基础兵种，特级为可以利用高远程防御力来挡箭，可以招魂得来。在war3里只能从尸体中招得，不过是一个尸体出两个的，可以快速的增加兵力，可以学习骨质增强术来延长存在时间。骷髅可以用不死商店的巫术之仗和亡灵巫师召唤出来，万一打出来死亡之书，可以用此召唤。带着装满尸体绞肉车和几个亡灵巫师就可以快速的组建一 个骷髅大军。

    9）狼。狼是集体行动的动物。在北欧神话中，著名的狼王焚利尔（fenrir），焚利尔是火神洛基的儿子生性残忍。主神奥丁却对它栽培培养。后来为了阻止它危害世人，战神泰尔以一只手臂的代价换来将其终身监禁。后来在诛神之黄昏之役中，焚利尔活吞了主神奥丁，但是被奥丁的儿子，森林与和平之神威达尔（vidar）用长枪刺穿可心脏。狼在h4里为自然的一级基础兵种，实力，在一级兵中无疑是名列前茅的。还可以两次攻击 。若有召唤魔法和加速魔法的辅助，狼的实力便能更加充分地发挥了。war3里为先知的得力魔法，先知带小狼骚扰，或加几个巨斧就可以还放心的打猎了。其中高级狼拥有致命一击的技能。先知可以成为 兽族出场率第一的英雄，狼的作用功不可没。

    10)牛头怪。克里特岛的米诺斯王即位时，受到了海中居民的反对，于是他便向海神波塞顿祈祷，请波塞顿送他一只健美雄壮的公牛，以作为遵循神意的象征。接着他又发誓：即位当天早上，会以这头牛作为祭品献给波塞顿。因此波塞顿赐给米诺斯王一头健美雄壮的公牛，帮助米诺斯王登上王位。米诺斯登上王位之後，却舍不得放弃这头公牛，便用其他公牛来代替作为祭品。波塞顿知道后，大发雷霆，便对米诺斯王后帕西帕艾施法，令她对公牛产生情欲，帕西帕艾便制造了一只假母牛，自己潜入其中，诱惑公牛以致自己怀孕，结果产下了一只牛头人身的怪物。这只怪物就是力大无穷、性格暴燥的米诺陶。米诺斯知道这件丑闻后，为了掩盖真相，就召集建筑师和魔法师，在当时最著名的能工巧匠代达罗斯的指挥下，在库诺索斯宫殿下建造了一座复杂精美的双斧迷宫，即米诺斯迷宫，然后把米诺陶囚在此中。还有一种说法是：宙斯之子米诺斯的王后是太阳神阿波罗的女儿，米诺斯为了证明自己的权威向海神波赛冬祈求了一条强壮的白牛，并把白牛养在宫中，阿波罗的宿敌--女神阿佛洛德忒乘米诺斯外出征战的时候，想办法让王后爱上了白牛，在希腊最著名的雕刻建筑师代达罗斯的撮合下，王后和白牛结合，生下了牛头人身的米诺陶，米诺斯征战归来大吃一惊，只好盖了一座迷宫把米诺陶关了起来，强迫周围国家进贡少年来供它吞食。多年后，雅典的英雄忒修斯自愿去进贡，打算趁机除掉这个祸害，他和家人约定：杀牛成功后，他将换下原来黑色的船帆。在女神阿佛洛德忒的帮助下，忒修斯成功勾引了米诺斯的女儿阿里阿德涅，在美女帮助下使用有魔力的毛线团闯入迷宫，杀死了牛头怪，并成功逃脱，但是乐极生悲，忒修斯由于过度兴奋忘记了把黑色的船帆换掉，导致了他那在海边守候的父亲雅典王投海自尽。在h4里牛头怪作为混乱阵营的2级生物 ，在二级兵中还算名列前茅， 拥有格挡技能，不过30%实在有点不够。与同族的身为远程的美杜莎相比，牛头怪在移动力上都不占据优势，因而在混乱城二级兵建造 选择中常被舍弃。在war3里牛头怪作为以地面部队著称的兽族的地面顶级兵种,1300的血,可以算是超长了,可以学会粉碎技能,如果后面在带着几个灵魂行者可以复活的话,会让人很头疼.而兽族的英雄之一,牛头酋长,拥有冲击波,战争践踏和耐久光环三个基础技能,终极技能重生!(如果你不在短时间内杀死他两次的话,几乎就没办法杀死他了,感觉有点废话)

    11)弩车（Ballista）。远程攻击兵器，重型的十字弓。如亚历山大的攻城弩，中国的床弩等。重型十字弓装置在城楼上，分量可达70磅。重型十字弓弦则由弹 簧钢制成，要用绞盘上紧。中国的床弩上有个机匣，可以安放七八支弩箭，自动上膛，类似於冷兵器中的机枪，但射速低，不利於携带。在h4里为生命的2级兵种,作为远程伤害不受任何衰减的兵种， 在实用性上无疑强于枪兵。不吃精神类魔法的特点，也是一大优势，不过速度慢,这恐怕是其在战斗中唯一的缺点了。更重要的还是它缓 慢的地图移动力,个人不喜欢。在war3里是暗夜的,可以升级穿刺剑刃,具有飞溅的攻击效果,弩车需要一个最近攻击距离,当被近身则无法攻击.

    12)投石车。在h4里是人族在战风(WOW)里新增的中立兵种,属于弩车的极度强化版，射击范围略大于地狱火，移动力低的部队与之交战，有一 种送死的感觉。机械特性使得精神控制类法术对其不起作用，只能利用其速度慢、攻击实力其实并不太高的弱点，用快速精锐部队突击取胜。在war3里是兽族的兵种,可以升级燃烧之油，同弩车同样具有飞溅的攻击效果, 需要一个最近攻击距离, 无法攻击太靠近的单位.

    13)剑士和十字军。严格来说,这个的差别大一点,至少说外型上,一个有盾一个没盾.不过都作为人类的步兵,看起来挺像的。十字军1095-1270年，在罗马教廷的主持下，西欧的大封建主、骑士、城市商人，在宗教外衣的掩护下，在近东地区（地中海沿 岸）进行了八次侵略战争，因其标志是十字架，故称"十字军东征"。十字军可以两次攻击,如果能量完全发挥出来，其攻击表现不会弱于某些四级兵。不过作为移动力不高的地面兵种，十字军的作用还是受到了一定程度的限制。具有死亡抵御能力,几乎是为对付吸血鬼量身定做的，不仅能减少所受伤害，也将吸血的效果降低了一半,两次攻 击让吸血鬼死得没吸血复活的多。剑士，人族的基础兵种,可以升级防御特级,配合火枪,牧师,可以充分发挥肉盾作用。

    14）仙女龙和精灵龙。仙女龙可施展的魔法包括混乱、火环、火球和闪电，威力为魔法基本威力×仙女龙数量×0.94。攻防实力一般却具备极强战略价值的兵种，混乱魔法的作用比灯神的和平之歌更强，而40点魔法值令魔法的使用次数更多。还有其魔镜 特性会让对方在施展魔法时有很大顾忌。精灵龙，暗夜的魔法免疫单位，有独特的魔法闪耀技能，可以给一定区域的敌人施法者施加伤害，拥有变相移动能力，一旦遭到攻击就将 处于消失的状态，短时间内不在受到任何伤害。

    15)火元素 火怪 焰魔 和岩魔巨人。火元素（Fire Elemental），古代印度把地水火风作为构成世界的四大元素。在3代里的魔法也有四大元素魔法之说。不过四元素在各个文明中都没有记载。不过在1 6世纪炼金术师帕拉塞尔苏斯（Paracelsus）所写的妖精之书中记载有四大元素精灵。不吃精神类魔法的远程部队，光是这一点就足以让火元素自傲了，与它们交战并不是随随便便就能搞定的。其攻击实力与经验值的比例中规中矩。火怪,在印第安神话中，有一天，创世者来到作恶多端的火魔家里。火魔是那恶火患的罪魁祸首，他总是唱着一首歌："我是夭火之子， 我是烈焰之父！"。随着他的歌声，熊熊大火差点烧到创世者，后来创世者在小路的帮助下逃脱。创世者就把火魔碎尸万段，化成各种冰冷的爬虫。命它们永远生活在阴暗潮湿的地方。在16世纪的炼金术士帕拉塞尔苏斯（parocelsus）所写的妖精之书中，记载有四精灵。其中火精灵撒拉曼达（salama der）是长得象蜥蜴的怪物，耐高热，会吐火，生活在岩浆中。有些勇士会冒险击败他们，以便剥取它们身上可以抵抗火焰的珍贵的批 来做盾牌等（火盾？？）作为混乱城的三级兵种,对他的评价 确实如此 自己用起来感觉一般，但作为敌人时却又难以对付。飞行、高移动力和火盾特性，付出的代价就是攻防能力上的削弱（与梦魇兽相比）。火盾的反弹，除了黑龙、凶牙兽和具备火抵抗能力的 部队外，无人可以幸免，包括宗师抗魔的英雄。焰魔,为中立英雄火焰巨魔召唤的 ,特技是可以分裂生殖,如果时间配合好的话,同时带5,6个焰魔参战并不奇怪。炎魔巨人,为恐怖魔王的终极技能召唤出来的,拥有献祭,魔免和抗性皮肤特性.拥有最高的战斗价值,生命跨度和伤害/秒,完全无愧 的陆地之王。在混乱之治里就出现过,不死只出魔王不停打猎,不于敌接触,最后决战就出炎魔巨人的局面,使得暴学不得不在冰峰王座里修改了英雄 升级系统,使打野怪生不到6级的局面,由此一斑可见炎魔的厉害。

    6.拥有很多相同的魔法和技能 （我们的口号是宁可错杀三千，不可放过一个）。

    1）加血。人类总是很擅长的，在h4里，治疗类魔法以生命魔法为主：包括疗伤、医疗、再生、群体医疗和神圣介入，效果会受英雄等级相关技能 等因素的影响。
    在war3里，圣骑士的圣光可以为同伴医疗，人族的牧师可以释放治疗。死亡骑士可以用死亡缠绕治疗死亡的兵钟，死亡黑暗石雕像的枯萎预兆可以治疗死亡兵种。兽族英雄影子杀手的康复可以以医疗能疗波治疗多个友军。兽族的巫医可以施放治疗守卫为友军加血，每秒恢复2%的生命值,持续 20秒.暗夜的兽爪德鲁伊可以施放返老还童。炼金术士的医疗气雾喷出一波治疗药剂可以治疗一定范围内的单位。还有暗夜的月亮井可以加血加魔。更简单的，英雄可以在商店里买血瓶和群补。

    2）吸血。在h4里吸血鬼的特技即是吸血, 将攻击所造成伤害的一半吸取到自己身上。对机械、元素和亡灵生物无效,并且在遭遇具有“死亡抵御”能力的敌人时，效果减半。最重 要的一点是可以通过吸血复活己方已死的部队.死亡的四级魔法吸血鬼接触 , 可以使该部队在对敌人进行近身攻击时自动治疗创伤，恢复的生命值是攻击伤害的一半。使用对象的无限制性，可以让亡灵、元素、机械 都获得复活的能力。黑暗牧师职业的英雄本人自动获得“吸血鬼接触”技能，近战攻击时能够将敌人损血的一半吸取到自己身上。还有夺魂剑： 英雄近战攻击力和近战防御力+4。近身攻击时将敌人损失生命值的一半吸到自己身上。在 war3里是恐怖魔王的基础技能之一,吸血光环--可以让附近的友军肉搏战中将敌人受到的伤害转化成自己的生命值,三级分别为15% 30% 45%。另外中立英雄黑暗游侠的基础技能生命汲取，可以吸收目标单位的生命补充到黑暗游侠身上。

    3）减速。h4秩序的魔法迟缓: 使单个敌人部队速度和战场移动力减半。死亡的魔法疲劳: 使敌人单个部队速度和战场移动力减半，不能影响亡灵和机械，但可影响元素。死亡冒险魔法泥潭：使敌方部队在地图上的移动力减半，只能对施法者附近的敌人使用，效果维持一天。是死亡系的优势魔法之一，降 低敌方部队地图移动力，对于追击或是逃避追击都有极强的实用性。而敌人中招之后没有任何办法可以消除其不良影响。war3里分别有：人族的女巫的减速，血魔法师的驱散,可以将单位虚无化并减速50％，萨满的净化，可以驱散目标身上的附加法术效果，并以每秒5的速度使目标减速15秒，对本方单位无减速效果，守望者的暗影突袭,投掷一个毒镖对目标造成巨大伤害，随后将持续伤害一段时间。中镖后的3秒单位速度被减慢，树妖的慢性毒药, 一种中毒攻击造成每秒4点的中毒伤害并且减速50％，攻击速度减慢25％，持续5秒，巫妖的霜冻新星 放出一环冰霜对敌人造成伤害，并减慢敌人的速度。和霜冻护甲同样可以降低攻击被冰甲保护的友军的敌人速度，亡灵巫师的残废：减慢移动速度75％，攻击速度50％，降低攻击力50％，冰霜巨龙的冰冻攻击可以减慢目标单位速度10秒，不死的建筑，主基地 蛛网怪塔 幽魂之塔 同样可以起到减速的作用，娜迦海巫的霜冻之箭 增加一个冰冻效果，减慢目标单位的速度 以及龙卷风，熊猫酒仙的醉酒云雾 可以减慢敌人的移动速度，并且有一定的概率击空。

    4）毒害。在h4里死亡一级魔法即有，使敌人部队每回合自动损失一定生命值，从施法的当前回合开始生效。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值。虽然伤害值不高，但毒害还是很实用的。对于敌人受保护的后排射手或英雄施毒，虽然对敌人总体战力的损伤速度较慢，但还是相当有用的。
    同样死亡的3级恶魔阵营的食尸怪，拥有使对人毒害的技能，攻击时使敌人中毒，每回合自动损失一定生命值。除非受攻击的部队拥有1 00%的魔法抗性，否则毒的威力将恒定为食尸怪第一次攻击伤害的1/4。在war3里就是暗夜的树妖（我们一般亲切的称谓小鹿）和兽族的风骑士了，不同的在与小鹿的毒击，除了每秒产生伤害之外，还有减 速和降低对方的攻击力的属性。风骑士的毒击则是在若干秒后产生一定的额外伤害 　　5）复活 特种复活。h4里的复活技能 只有人族的天使可以施放. 可复活本方部队（生物或英雄)，消耗20点魔法值，复活生命值是天使残存数量×92（基本相当于其生命值的40%）。war3里圣骑士的终极技能复活,可以复活附近死亡的最强大的六个单位。还有一种物品复活,即是通过打猎有可能打出复活石,可以让英雄原地复活一次。对应的4里的每城商店里都可以买到不朽药水,使英雄复活, 可以在战前或战斗中 重复多次使用,可以被驱散和废除驱除,即使宗师抗魔也一样.说实话,有点BT,现在的一些地图就开始设计得不允许建造商店了。另外还有牺牲复活和神圣介入复活，都是用在英雄身上的特种复活。在h4里的凤凰有复活的技能, 与天使的复活不同,只能对自身使用，消耗12点魔法值，复活本队死亡的凤凰，复活生命值为本队凤凰生命总值的20%；如果还没有 来得及使用就被完全击倒，那么会自动复活20%，魔法值耗完。与凤凰的复活 相同,牛头酋长的终极技能可以重生,即在被杀死后可以原地复活。而当牛头战士死亡后，如果身后有几个升级了大师级训练的先祖幽灵 的幽灵行者的话，也可以复活，这两种复活都属于特种复活

    6）催眠 魔法控制 灵魂侵占。h4里的秩序以精神控制为主，其中最高级的魔法催眠，使敌人单个部队在三回合内受我方控制，对于部队的强度没有限制条件。控制对方部队后，不能对其进行远程攻击（范围攻击除外）；可以近身攻击，但会遭到反击。整个游戏中最为BT的魔法，既无战力要求，又无视线要求，对平衡性的破坏实在太大，以至于新编地图几乎都把它给禁用了。还有美人鱼的催眠 攻击时一定几率催眠敌人，让他们受控制一个回合。魔法控制：人族的破法者的技能，可以 控制一个敌军的召唤单位。灵魂侵占：不死族女妖通过大师级别训练可以学到，侵占目标单位的灵魂，相当于一换一，不过在冰峰王座中，这一点已经被极大的削弱了。

    7）魂锁链与殉难。它们之间的联系是可以为友军承当伤害，殉难h4人族的2级魔法将本方一支部队承受的伤害转移到另一支部队身上。利用本方不同部队防御力上的区别，来选择转嫁伤害的对象。常见的是，高级兵或是 英雄冲锋陷阵时，将所受伤害转嫁到后方初级兵身上 ，可以有效减少高级兵的损失。魂锁链 兽族灵魂行者的基础魔法技能，把几个友军单位的灵魂锁在一起，对其中一个单位伤害的50%将由被锁在一起的单位共同承受。

    8）传送 回城。在h4里只有秩序才有的3级魔法，使施法英雄及其带领的整支部队回到最近的本方城堡，可以在冒险地图和战场上使用。可以让某些原本无法打赢的战斗分几次来完成。堵城门使用或是在城堡附近战斗中使用，可以让部队回到较远的城堡里，实现大回城。指得注意的一点是，在回城后，镜像部队是不带走的，如果你在走之后留下一大堆镜像部队而对方又没有驱散废除的话，会很惨，当然你也得不到经验加成，这一点可以保留打强力野怪，得高级宝物。回城在war3里其实主要是物品了。回程卷轴，350一个，第一英雄会自带一个，二级基地后的商店里各族都有，合理利用回程其实 很重要，这就看战机了，可以保护英雄不死，持续作战。不同在于人族的商店还可以买到 传送权仗 暗夜的商店可以买到 躲避权仗。当然还有大法的终极魔法，群体传送。可以将大法和他周围的24个单位传送到任何一个角落，不过前提是，必须知道一个单位的具体位 置。施法间隔相当的小，以至于大法可以转移到一个地方参加战斗后立刻转移到另一个地方。

    9）传送 闪烁。在4里,一共有两种传送 ，一种是生物技能 如恶魔、邪魔女 在战斗中以自我传送的方式移动 ，传送移动不受任何限制包括城墙。另一种是，秩序3级魔法传送：将部队传送到战场上的指定位置，可以用来传送敌人部队。传送本方部队多是为了躲避敌人的围攻，而传送敌方部队则为我方围攻敌人创造了条件。对视线没有要求，令传送成为对付敌人远程部队 或英雄最好的方法之一。而在攻城战中，传送的优点就更加突出。在war3里， 闪烁是暗夜的守望者基础技能之一，可以使得守望者短距离跳跃，对付跳跃障碍和游击战极为有利，可以保护不被敌人围歼。同样如果意外打出传送匕首，佩戴的英雄也可以使出闪烁。

    10）瘟疫瘟疫之云 和 死亡衰变。在h4里瘟疫是死亡的3级魔法，使战场上所有部队中毒，不分敌我，包括施法者在内。魔法参数：10/1，计算出的数值为中毒敌人每回合所损失的生命值。此魔法对无生命的部队或死亡系部队无效.近似于群体毒害，可以切切实实地给敌人部队以实质性影响，解除上的不易（只有几个治疗类魔法如医疗可消除，辽伤都不行），令瘟疫很容易延续较长时间，从而累积出相当不错的伤害值。另外，瘟疫和毒害状态是可以同时存在的，这就容易给敌人更大打击。瘟疫之云是不死的憎恶和绞肉车可以拥有的技能，可以在很长时间对敌方的单位造成伤害，，不过并不杀死对手，在生命值为1时会停止 。死亡凋零 为巫妖终极魔法 给与作用范围内的的单位每秒减少4%生命力（按照满生命值计算）的伤害

    11）无敌。神盾是圣骑士特有的基础技能，可以保护他在一定时间内不受任何 物力和魔法攻击，其他英雄也可以在野外商店里买无敌药水拥有。影子猎手的终极魔法 巫毒术 在一定范围内令友军单位无敌，暗影猎手不无敌，持续30秒。死亡骑士的终极技能 操纵死尸 复活6个单位为死亡骑士战斗，该单位无敌。复仇的复仇之魂和月之女祭祀施放的猫头鹰也是无敌状态。建造中的苦工和小精灵，也是无敌。在4里也有一件宝物可以无敌，守护者长袍：每场战斗英雄所遭受的前三次伤害都被视为无效伤害 ，包括任何物理和魔法攻击，其中包括海怪的吞噬，火怪的火盾。不过有个例外，这件宝物不能抵挡死亡之手的进攻。人族5级魔法 庇护 ：使用后保护本方所有部队，受保护的部队不会遭到敌人攻击，也不会受到（我方或敌方）魔法影响。受保护部队只能做移动、等待、防 御这几个动作，否则保护效果将消失。也可以认为是无敌。

    12）连环闪电。h4是混乱的顶级魔法，攻击敌人部队以及邻近的几只部队，伤害力逐次减半。魔法参数：80/8，计算出的数值为对所攻击的第一支 部队的杀伤力。由于英雄的上阵，在4里的伤害魔法普遍设计不高，连环闪电也是如此。在war3里是兽族先知的基础魔法，向目标射出 一道强大的闪电能量，自动弹向供给范围内的另一个目标，直到达到最大目标数，每一个目标单位都比前一个少收到10%的伤害，很有 杀伤力。特别是遇到血薄的弓箭手，民兵，呵呵。

    13）牺牲 死亡契约。h4里牺牲是死亡的5级魔法，消灭本方一只部队来复活其他部队，复活的生命值是消灭部队生命值的两倍。所消灭的部队不能是召唤类魔法制作出来的生物.魔法效果是强的。牺牲低级部队来复活高级部队，是很自然的使用方法，这个魔法仅在艰苦决战中才会充分体现价值，能复活英雄也是其少数亮点之一。死亡契约是不死的死亡骑士的基础技能,可以牺牲一个友军单位，将其生命值以一定比例转给骑士。虽然常被人舍弃。其实死亡契约还有挺有用的，想死亡骑士可以用缠绕给友军的亡灵部队补血，还可以以邪恶光环加友军的移动力和再生 力，但不能给自己加，由此形成的是 常被对手作为第一目标消灭 ，由此可以用死亡契约增加骑士的 存活时间，对胜负一定起相当大的作用。

    14）攻击失误。混乱城的二级兵种牛头怪的特级格挡，能够有30%几率格挡敌人的物理攻击，如果格挡成功将不会受到任何伤害。诅咒，不死的女妖可以释放诅咒，使得敌军一个单位攻击有33%几率出现失败。闪避 恶魔猎手的基础技能，有一定的几率躲过敌人的攻击。熊猫酒仙的醉酒云雾 可以减慢敌人的移动速度，并且有一定的概率击空。熊猫酒仙的醉拳 给予一定的概率躲避攻击并有10％的概率提供额外攻击伤害。

    15）魔免 抗魔 抗性皮肤 防魔护罩。在h4里，魔免和抗魔两种，免疫魔法是黑龙凶牙兽的技能，不受所有魔法影响，不论是有益的还是有害的。除了海怪的吞噬和螳螂的缠身属于生物特技不能避免以外，不受其他所有的魔法的影响。抗魔：受魔法攻击时降低所受伤害，另外有一定几率躲避诅咒类魔法。矮人50%、金人75%、土元素50%、大耳怪骑士50%、巨龙50%。英雄的战斗技能里也有抗魔一项，野蛮人自带基础抗魔,其中基础30% 高级50% 专家70% 大师80% 宗师100% 。抗魔比魔免最大的好处在于可以施加有益魔法。不过即使宗师抗魔，也不能避免火怪的火盾和美人鱼的催眠。在war3里，拥有魔法免疫的分别有，天神护体的山丘之王, 凤凰，魔法破坏者，树妖精灵龙， 复仇天神 石像形态的石像鬼 破坏者 炎魔巨人和释放剑刃风暴的剑圣。抗皮，山丘巨人，复仇天神 凤凰 炎魔巨人。抗性皮肤，减少负面魔法的持续时间，并对某些魔法免疫。 魔法免疫即对一切魔法免疫，不过最近的补丁已经修改了这一点，使得可以接受有益魔法，跟H4的宗师抗魔一样。不死的女妖，可以释放一个防魔法罩，在成为魔法壁障，可以承受一些魔法攻击。h4自然三级魔法有防魔：使单个部队在战斗中免疫所有魔法，使用后原先附着在该部队身上的魔法状态会立即消失（不包括宝物、职业 附加的状态，此外也不能去除中毒与瘟疫），附加在幻象副本或是操纵的尸体上时，会让它们立刻消失。有时可以当自然的驱散使用。

    16)嗜血，h4 里混乱系基础魔法，使部队的近战攻击力提高25% ，是用来加强近战的，实用率相当高。在游戏早期，就算兵力不多，施加嗜血后的杀伤增幅也相当不错，即使赶不上火矢的伤害，几回合攻击累积下来后就可以超越了，适合在战斗早期使用。其中力量城唯一的魔法兵种，食人魔法师可以释放，不过食人魔常被同级的独眼压制，上场不多。war3里是兽族的萨满祭祀的大师级魔法，可以同时增加目标单位的攻击速度和移动速度，牛头和风骑士后面带着几个萨满，可以让一 块顶几块,很爽。

    17)树根缠绕 螳螂缠身特技。螳螂缠身特技 可以使得被定身的敌人不能移动，攻击力减半。不过缠身只对其攻击的最后一个目标起作用，此特技对于具有“虚无”能力的部队（幽灵 和风元素）无效 ，生物特级对魔免的黑龙同样有效。在对付野外的螳螂时候，用一个疯狂让它们互相定住，是很有趣的打法 。树根缠绕 是war3里，暗夜丛林者的基础技能，从地面爆出 树根绕住指定的 敌方单位，使得其无法移动并造成一定伤害。很有战术价值的技能，比如可以杀死重要的正在逃离的 单位。不过可以 用驱散抵御 树根缠绕。

    18) 群体医疗 神圣介入和宁静之雨。人族的魔法：群体医疗：治疗本方所有部队，魔法参数：25/2，计算出的数值为治疗的生命点数。能够给全体解毒是其最大用处，正好用来对付死亡系的瘟疫 。神圣介入:治疗本方所有部队，魔法参数：50/5，计算出的数值为治疗的生命点数。不复活死亡部队，复活英雄，但要在魔法威力超过英雄生命值上限的情况下才能复活。如果部队接受治疗（前提是有损血），那么在补生命值同时会解除身上所有负面魔法状态，包括中毒和瘟疫。一些BT图必需的魔法，关键一点在于可以复活英雄，特别敌人损失大量兵力敲掉你一个强力英雄时，一个神圣介入可以让他无功而返。宁静之雨：丛林守护者终极技能：在一定范围内施放治疗之雨，每秒20点治疗友军。

    19)烈焰风暴 火焰雨和地狱火。烈焰风暴：血魔法师的基础魔法 释放一个火柱对目标地面单位造成伤害并持续燃烧一段时间。上限为6个单位。火焰雨 深渊魔王的基础技能：召唤一阵火焰雨攻击一定范围内的单位，每阵火焰雨构成直接伤害并有3秒的持续伤害。在h4里分别有火环 火球和地狱火，对一定范围内的单位进行伤害，不分敌我。

    20)幻化 镜像。H4中的幻化可以攻击和被攻击。而剑圣的镜像只是为了迷惑对方，当然他还可以驱散魔法。相同的是，他们都可以被一个简单的魔法驱散 消掉.

    21)流星火雨与 末日审判。混乱的5级魔法，末日审判 ：攻击战场上的所有部队，不分敌我，不包括施法者本人在内。魔法参数：40/4，计算出的数值为魔法杀伤力。此魔法使用时不消耗 魔法值.不能享受魔法祝福的黑龙，在末日战术中则可以充分体现重要性。流星火雨：暗夜的英雄月之女祭司的终极魔法，召唤波浪般的流星雨来杀伤敌人。在释放过程中，月之女祭司必须 保持不能随意行动。所以抵挡的办法，除了逃离外，还可以强迫她移动，比如对其眩晕。 　　22)召唤。h4以自然族为主，随着英雄等级魔法的提高，可以召唤到自然族所有生物，如果学了死亡系魔法，还可以召唤到死亡城的恶魔系部队。war3的召唤比较平均,各族都有，大法有水元素，先知有狼，小强有甲虫，丛林守卫者有树人。不过特殊的是召唤树人需要附近有树 木才行，而召唤甲虫则需要尸体。不同在于war3的召唤都有时间限制（甲虫特殊例外,人家小强的嘛，得给个面子），都可以被驱散，h4的召唤在一场战斗中，只要不被打死就可以一直保存，不过秩序也还是有一个专门的魔法驱逐可以来对付， 不过驱逐是按照一定的魔法等级和召唤的生物的生命值来计算的，不是一下子就能完全驱掉，不同的在于H4被驱散的召唤生物的经验值是没有的，而 War3里召唤生物无论被驱散掉还是被打掉，都有经验的收获。war3中几个英雄的终极召唤，如血法的凤凰，恐惧魔王的炎魔巨人，守望者的复仇天神，均具有魔免和抗皮技能，不能被驱散。暗影猎手的毒蛇守卫也有魔法免疫，不能被驱散。

    23)虚无。血法师的基础技能，让一个单位暂处于虚无状态，他无法进行物理进攻但能释放魔法，施放在虚无状态的单位上的魔法也会明显的提高。h4中 具有虚无状态的生物：风元素、幽灵。作用是生物无实际形体，因此物理攻击难以杀伤他们，于是近战和远程防御力加倍。 　　24)法术枷锁 魔力之焰 魔法回应。混乱的魔法 法术枷锁，对单个敌人部队（英雄或生物）使用，使其在施法时每消耗1点魔法值就要受到10点伤害。暗夜精灵龙的魔力之焰，可以在周围的敌方单位施放魔法时对其造成伤害。魔法破坏者的魔法回应 ：魔法破坏者每次攻击消耗目标20（英雄4）点的魔法值。法力消耗的同时对目标生命造成相应数值的生命消耗。此魔法对魔免单位无 效。

    25)吸魔。h4里是死亡基础兵种恶魔之子的技能，吸取敌人2点魔法值，转移给我方魔法值消耗比例最大的部队（英雄或施法生物）。所吸取的魔法值，来自于在恶魔之子视线内、并离其最近的敌方部队。吸取成功率受相关魔法抗性制约，宗师抗魔或是附加了反魔法的部队不被算在吸取对象之列。死亡城堡的奇迹建筑可让吸取效果提高到3点。对于英雄的作用不大，但对如天使，恶魔作用极大，可以使得天使的复活和恶魔的召唤冰魔无从使用。恶魔猎手的技能，法力燃烧 放出一束负作用的能量波，烧掉目标单位一定数量的魔力值，并产生与烧掉的魔力值相同的杀伤力。血魔法师的吸魔 从敌方单位身上持续吸收魔法。自爆：小精灵可以自毁，驱除魔法效果并消耗范围内魔法单位的50点魔法值。对召唤生物造成225点伤害。破坏者的吸收魔法：从自己的一个单位上把魔法全部吸到破坏者身上

    26)驱散 驱魔 窃魔 魔法盗取 吞噬魔法。h4里秩序的驱散 ：解除我方或敌方单个部队身上附着的状态魔法，无论是正面还是负面的。但是不能用来解除中毒和瘟疫状态。可以用来直接驱除操纵的 尸体和幻象副本。生命的驱魔，解除本方单个部队身上的所有负面魔法。但是不能用来解除中毒和瘟疫状态。秩序的窃魔：吸取单个敌人部队身上附着的一个正面魔法状态，转移到随机选取的本方部队身上，还有高级的通法盗窃。war3里魔法破坏者的魔法盗取：将敌军单位身上的有利魔法转移到友军身单位上，将友军单位身上的不利魔法转嫁到敌军单位身上。
    牧师的驱散：驱散一点范围内单位身上的一切魔法效果，对召唤生物造成200点伤害。灵魂行者消魔：消去一定区域的魔法，对召唤生物造成250点伤害。萨满的净化：驱散目标身上的附加法术效果，以每秒5的速度使目标减速15秒，对召唤单位造成400点伤害。该魔法不会减速友军单位。小精灵的自爆，树妖的驱散魔法：驱散敌军身上的有利魔法和友军身上的不利魔法，对召唤生物造成300点伤害。破坏者的吞噬魔法：吞噬范围内一切有利和有弊的魔法效果。每个被吞噬了魔法的单位给破坏者50点生命值和75点魔法，对召唤生物造成180点伤害。

    27)多点攻击。h4里的气息攻击 黑龙和凤凰所拥有的，沿着攻击方向，9英尺×3英尺范围内的部队都会受到气息攻击的伤害。直接攻击目标遭受的攻击类型为火属性攻击，如有火抵抗技能所受伤害就会减半；在直接攻击目标身后，被气息波及到的部队，所受伤害类似于火魔法，如果有火抵抗技能则可完全不受伤。抗魔和免疫魔法的能力对气息攻击的伤害完全没有影响，能起作用的只是火抵抗技能。还有巨龙的弧形焰息：气息攻击的加强版本，相当于气息攻击和三头攻击两个技能的结合体，可以影响一个很大的扇形区域。独眼巨人、恐甲兽用，巨石进行远程攻击，形成范围攻击。war3里的山丘之王雷霆一击，可以凭借地震一般的震动波伤害周围的敌人。牛头战士的粉碎：有25%的机率使牛头战士的攻击造成范围攻击。女猎手的月刃：能够让女猎手在一次攻击中同时攻击两个单位。具备飞溅攻击的能力的单位，如冰龙弩车投石车狮鹫骑士等。深渊魔王的分裂攻击可以同时攻击多个单位。

    28）失去行动。侍从的晕击 攻击时一定几率击晕敌人，让敌人一个回合无法行动（包括反击）。秩序的失明 使敌方部队在3个回合内无法行动。独角兽有使对方失明的技能。混乱的魔法，混乱：使敌人部队丧失一回合的行动机会，施法对象必须在英雄视线内。同样有群体的混乱云。生命的和平之歌：影响英雄视野范围内的单个生物，使其一回合不能主动攻击和施展诅咒类魔法 不会被魔镜反弹
    自然的蜂群：使敌人部队丧失一回合的行动机会，不能影响机械或亡灵生物，但是可影响元素。恐惧，死亡魔法，梦魇兽 暗黑骑士可以施放，使单队敌人两个回合不能行动。冰魔的冷冻攻击 攻击时有30%几率冻住敌人两回合。在war3里，使对方失去行动的 有主要的眩晕。山丘之王的三个技能，风暴之锤 雷霆一击 重击均可以实现 还有先知的地震牛头人酋长战争践踏 巫医陷阱守卫，火焰领主的火山爆发。还可以使对方失去行动的有丛林守护者缠绕须根，恐惧魔王的睡眠，猛禽德鲁依的飓风，掠夺者的网诱捕。穴居恶魔蛛网。龙鹰骑士的空中锁链，魔法锁链锁住对方空军单位，每秒造成30点的伤害。暗影猎手的巫术将目标随机变成一只小动物，使其失去特殊能力。女巫的变形 把敌人的一个非英雄单位变成一头温顺的小绵羊或小飞羊，其防御力和生命值保持不变，但是丧失攻击力，护甲变为“中型”。

    29）强化 削弱。h4里人族的魔法以强化自身为主 混乱和自然也有一些，如，嗜血 疾速 祝福 精神护甲 加速 护体石肤 天堂之盾 振奋 巨人力量 血暴 天国护甲（群体祝福 群体加速 灵猫反射 群体振奋 祈祷 龙之力量等。war3里 圣骑士的专注光环 可以增加光环范围内友军单位的防御能力。牧师 心灵之火可以增加友军10％的攻击力和提升5的护甲。牛头人酋长的耐久光环 提升附近友军的生命恢复速度和移动速度。萨满 嗜血术 在咒语持续时间里，目标单位的攻击速度提升40%，移动速度提升25%。科多兽 战鼓光环 增强所有科多兽周围的友军的攻击力。月之女祭祀 强击光环 增加附近友军的远程攻击力。利爪德鲁依 咆哮 增加友军25％的攻击力。死亡骑士 邪恶光环 增加附近友军的移动速度和生命恢复速度。亡灵巫师 邪恶狂热 增加目标单位攻击力75％，但是每秒消耗4点生命。持续45秒。炼金术士的化学风暴 增加移动速度50％，并且增加攻击速度。削弱 h4里死亡系的魔法以削弱对方为主，死亡魔法 如 诅咒 瓦解射线 疲劳 邪恶之歌 虚弱 悲泣 群体诅咒 群体虚弱 群体悲泣等。猛禽德鲁依的精灵之火 减少目标单位的护甲4点并拥有那个单位的视野，持续120秒。亡灵巫师的残废 减慢移动速度75％，攻击速度50％，降低攻击力50％。女妖的 诅咒 女巫的 减速。

    30)反弹 荆棘光环 刺盾 痛苦之镜 报偿 兽族的建筑。h4里火怪的特级，火盾：遭受近身攻击时，自动将所受伤害的25%反弹给攻击者。除了黑龙和具有火抵抗能力的生物/英雄以外，任 何部队都无法抵抗火盾的反弹，包括宗师抗魔的英雄。生命魔法报偿 使敌人部队攻击本方部队时也要遭受一定伤害。与三代的火盾相似，但火盾是按比例将所受伤害的一部分反射给敌人，而报偿所反射的伤害只与施法者能力有关，与所承受的伤害大小无关。魔法威力与火焰结界相同，但报偿的作用却更强一些。因为一般兵种一回合顶多能有一次攻击加一次反击，而受攻击的次数完全可能多于两次。高防御英雄配合保护和治疗类魔法，即使站在敌人堆中也可以坚持很长时间，多个回合下来之后，报偿所累积的伤害值也是相当可观的。尽管如此，作为二级魔法，感觉威力还是偏低了一点，如果能设高些，会更加好用。秩序的终极魔法，痛苦之镜。对本方单个部队使用，使其在遭受物理攻击或魔法攻击时，自动把一半伤害反射给攻击者，部队本身所受的伤害并不会减少。反弹效果会 受敌人抗魔能力的影响。反弹一切伤害（无论是近身肉搏，远程射击，还是魔法杀伤），在兵力相当的战斗中会起到巨大作用。相同的是war3里，暗夜丛林者的基础技能，给附近友军一个荆棘护盾，肉搏战中，敌人每次攻击都会受到反击。不死的地穴领主的基础技能，刺盾，形成一层带尖刺的保护壳，增加 防御能力，并能将敌人的近战攻击弹身回去。兽人族的建筑可以研究尖刺路障，能够使建筑物对攻击它们的近战兵种造成一定的伤害。在战争磨坊中充分升级长钉路障将获得这种优势 。这能使你在建筑物受到攻击时得到更好的防御，并且可以给敌军士兵造成损伤，甚至有时在敌人接近前就能直接消灭一些入侵者。

    31）隐身和 反隐。盗贼的技能潜行 ，相当于英雄的高级潜行技能。在冒险地图上能够不被1-2级生物和只掌握了基础侦察术的敌英雄发现，但在靠近2级生物或有基础侦 察术的敌英雄时，隐身会失效。英雄的九大技能里就有侦察技能，潜行分为基础 高级 专家 大师 宗师五种。英雄必须独行才行，反隐就必须学习侦察技能，或者带高级兵。隐遁：女性暗夜精灵拥有影遁能力，每到夜晚，当她们静止不动时就会自动隐形。弓箭手、女猎手和月亮祭司都拥有这项能力。即使在激 战中，您也可以通过隐藏 按钮来使她们保持静止，在狂暴的敌人面前突然隐形。影遁能力只能在夜间使用。疾风步 令剑圣隐形并加快移动速度，当攻击对方时隐形消失，并造成额外伤害 疾风步可以穿人了。女巫的魔法 隐形 使得一个单位隐身，但是只要其一进攻或者释放某个魔法的话，那就会现出原形。巫医可以释放 岗哨守卫，召唤一个隐形的固定守卫，用来观察某一区域。可发现隐形单位。持续600秒。也可以释放陷阱守卫 一个隐形的守卫，使接近的敌人晕眩。 陷阱持续150秒。晕眩持续6(2.5)秒。灵魂行者可以 转变为 灵肉形态 不能攻击，也不受物理攻击，但会受到魔法攻击。阴影之狼由先知召唤，隐身的。反隐：人族的防御塔可以升级反隐，矮人直升机具有真实视野显示周围隐形单位，迫击炮小队可以在目标区域施放一颗矮人照明弹，驱散战争迷雾15秒并能显示隐形单位，先知的 透视 用于侦察后一块地图区域，并能发现隐身单位。巫医释放的 岗哨守卫 可发现隐形单位，持续600 秒。牛头人酋长战争践踏可以用来显示附近的隐身单位，月之女祭祀可以召唤一个猫头鹰去侦察一个指定的地图区域，能够发现该区域的隐藏单位，死亡可以牺牲一个侍僧，让他变成阴影，阴影是不可见的幽灵，在它的附近，你能够看见隐身了的单位，但阴影不能攻击。用来侦察对方的行踪实在是再好不过了。当然可以在商店购买物品，比如显影之尘。

    32）吞噬。科多兽可以吞噬一个敌人，在吞下去以后需要一段时间消化。如果你能在科多兽消化掉被它吞进去的单位之前杀掉它，这个单位就可以得救。海怪，攻击时一定几率直接吞食几个敌人，不受抗魔能力和魔法免疫力制约，被吞食的敌人不能复活。最近才发现，除了守护者长袍可以把吞噬 当作一次进攻抵挡以外，没有其他方法可以抵挡。

    7，都是很棒的游戏,我很喜欢，不同在于一个是回合制站棋类游戏,一个是即时战略游戏,出自不同的游戏公司。KAO,这也算.其实还有一点，就是war3里很多生物名字与h4英雄的职业名称相同，比如牧师、圣骑士等,不过相差就万里了。基于一般对战的模式,英雄无敌4,WOW版,不包括MOD，魔兽冰封王座，某些名词的翻译 版本不同会不一致，以看懂为原则，敬请原谅。

    生物介绍，摘自英雄无敌4精华贴《英雄无敌IV生物背景考》。生物介绍和魔法介绍，参考了《东方卷轴 》